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1. Purpose of the document
The current User Manual contains information about orthophotomaps creation using
GeoMosaic program. This program is designed tomerge the georeferenced orthorectified
imagery and create the orthomosaic from them. The main part of document contains
description the technology of mosaic creation in the GeoMosaic program.

2. About program

2.1. Purpose and main definitions

The GeoMosaic program (hereinafter is referred to as ’program’) is purposed to create
the orthomosaic from georeferenced orthorectified aerial and satellite imagery, splitting
of created orthomosaic with the capable of saving sheets in popular raster file formats.

The GeoMosaic program includes to the full version of PHOTOMOD system and also could be
produced separately.

The orthomosaic is the single image, which obtained during the brightness adjustment and
merging the multiple georeferenced orthorectified images. The orthoimage is the image, obtained
after the transformation from the central projection to the orthogonal projection with automatic
removal of distortions, which were caused by the imaging equipment, elevation angle and relief.

The program provides the following features:

• creating the orthomosaic from the source images;

• radiometric images correction (filtration, color balance, brightness, contrast, etc.);

• pan-sharpening – process of merging multispectral and panchromatic images;

• correction (removing visual defects) of images in the DustCorrect module (see the
“Dust Correct” chapter of the “Project creation” User Manual);

The module provides processing for Windows BMP and Stripped SingleScale TIFF without
compression images only.

• automatic cutlines creation considering areas without background and cloudiness on
images;

• different modes of creation and edition cutlines;

• splitting output mosaic into sheets depending on parameters;

• GCP adding and measurement their coordinates on images;

• tie points adding and measurement their coordinates on images;
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• local and global brightness adjustment;

• smoothing areas along cutlines for creating mosaic image;

• import/export of cutlines, sheets borders. ground control points, etc.;

• loading DEM and accuracy control of DTM creation (see the ’Creating DTM’ User
Manual).

2.2. Main conventions and terms

The program uses the following conventions and terms:

• Orthomosaic – orthoimage, created from source images during brightness adjustment
and merging georeferenced orthoimages;

• throughout this User Manual, the orthomosaic, created from the source images, is
referred to as ’output mosaic’ or ’mosaic’;

• Orthoimage is a georeferenced image prepared from a perspective photograph or
other remotely-sensed data in which displacement of objects due to sensor orientation
and terrain relief have been removed;

• Cutline is the boundaries of the specified area from the source image, which will be
included in the output mosaic. The vector polygons are used for the cutlines creation.
The common boundaries of neighbouring cutlines are completely topologically coin-
cide, i.e. the areas of source images, selected using the cutlines, which are the single
area without overlaps and ’gaps’;

• Useful area contains substantial part of image and excludes input background of
image;

• Sheet – a part of output mosaic, which is saved in individual file with chosen format;
edges of sheet are vector polygons;

• Active sheet – a sheet, from which the output mosaic file will be create;

• Inactive sheet – a sheet, excluded from the output mosaic;

• Source image (source image of mosaic project) – source georeferenced orthoimage;

• Reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project;

• Pyramid is a set of resampled copies of image;

• Global brightness adjustment means transformation equally applied to all pixels of
each source image;
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• Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges.

2.3. Input data

The sources data for mosaic creation in the GeoMosaic program are the orthoimages,
referenced to the coordinate system, in the files of following formats:

• Tag Image File Format (TIFF) TIFF и GeoTiff format, included tags for saving of
georeferenced information;

• Windows Bitmap File (BMP);

• VectOr Raster Maps (RSW) raster formats of PHOTOMOD VectOr program;

• ERDAS IMAGINE (IMG) ERDAS system raster format;

• NITF (NITF);

• JPEG (JPEG);

• GIF (GIF);

• PNG (PNG);

• USGS DEM (DEM);

• PCIDSK (PIX) raster format with georeference in the heading developed by PCI
Geomatics company;

• JPEG2000 (JP2) raster format with jpeg compression and georeference in the
heading developed.

the limitation on output file size of JPEG2000 format – no greater then 500 Мb.

The program also provides the ability to load and process of palette images in TIFF, GIF and
BMP files format.

The source images can be placed to resources of the active profile as well as to con-
ventionalWindows file system.

2.4. Output data

The program provides the supporting of multiple raster formats to export the output
mosaic sheets. The program also provides the output formats to export the georeference
data. The cutlines, sheet boundaries and tie points, created in the mosaic project, are
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stored in vector files of internal format. The program supports the multiple import/export
formats of vector data.

The output file size in JPEG2000 and ECW formats cannot exceed 500 MB.

Table 1. Output data

File placementFile formatsOutput data
in the active profile resourcesX-GMOS internal formatMosaic project
in the active profile resourcesX-DATA internal vector formatCutlines and tie points (vector

data)
inWindows file systemExternal georeferenced data for

mosaic sheets
• PHOTOMOD GEO

• MapInfo TAB

• ArcWorld (*.tfw, *.pbw)

inWindows file systemMosaic sheets (orthoimages) • TIFF иGeoTIFF (*.tiff, *.tif)

• Windows Bitmap File (*.bmp)

• ERDAS IMAGINE (*.img)

• NITF (*.nitf)

• JPEG (*.jpg, *.jpeg)

• PNG (*.png)

• Microstation (*.gfn)

• JPEG2000 (*.jp2)

• PCIDSK (*.pix)

• PHOTOMODMegaTIFF (*.prf)

• VectOr Raster Maps (*.rsw)

• ECW (*.ecw)

3. Start of work
Before the beginning work in the program define the folder, in which are placed the
sources data. The program allows to place the files with the source data in the folders
ofWindows file system, as well as in the profile resources.

Activate this profile when the source images placing in the profile resources. Supported
file formats list of source images see in Section 2.3.

Description of resource system see in the General Information User Manual.
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To start the program perform one of the following:

• choose the Start › Programs › PHOTOMOD › GeoMosaic;

• double click the PHOTOMOD Geomosaic icon on the desktop;

• in the context menu of System Monitor module in (the icon in theWindowssystem
tray) choose GeoMosaic;

• start the PHOTOMOD system and choose the Rasters › GeoMosaic.

4. Interface and its elements

4.1. Work area interface

The GUI contains the following elements:

• the main menu, which contained the all program functionality (A);

• the main toolbar is used for quick main program functions access (B);

• the additional toolbars is used for quick miscellaneous program functions access (O);

Toolbars could be placed only one-lined, horizontal or vertical.

• the 2D-window, used for data displaying, contains the following elements:

○ the toolbar is used for the 2D-window modes managing (C);

A number/total sheets/images is shown in header of the individual 2D-window.

○ the work area is used for viewing and processing with loaded data of mosaic project
(F);

○ the navigation bar is used for fast moving on the specified block images area of
mosaic project (D);

By default on launch of the program layers are not shown in the navigation window. If ne-
cessary, click the Navi tab and choose layers to display.

○ the Layer manager is used for managing of mosaic project layers (E);

○ the axes direction of project coordinate system (M);
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○ the status bar is used for viewing current real (ground) and pixel marker coordinates
and brightness, contrast and gamma data adjustment in the work area (G, K, L).

When place marker is on the area out of image or on background, brightness is indicated
as NULL.

Fig. 1. The GeoMosaic program

4.2. Brief description of main menu

The program main menu contains the menu items for mosaic creation, vector data
processing, additional applications starting and setting parameters.

Table 2. Main menu

FunctionMenu
allows to create, open and save mosaic project, and
also obtain information about project

Project

allows to form images block of mosaic projectImages
purposed for cutlines creation and also provides
features for calculating areas without background
(useful areas) and cloudiness

Cutlines
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FunctionMenu
purposed for searching and measurement ground
and tie points in the cutlines region to adjust the
stitching along the neighbour cutlines

GC/tie points

purposed for mosaic splitting and managing active
status of sheets

Sheets

purposed for additional data retrievingMisc
purposed for defining the output parameters of mo-
saic and creating the sheets of mosaic with saving
in output format files

Mosaic

purposed for creating, editing, import/export of vec-
tor data (see the menu description in ’Vectorization’
User Manual)

Vectors

purposed for modes choosing to select and draw
vector objects, to transform curves, repeat/cancel

Edit

the last operation (see the menu description in
’Vectorization’ User Manual)
purposed for applications launching, additional data
loading (e.g., DEM), general parameters setting,
coordinate system editing, etc.

Service

allows to open additional toolbars and windows:
new 2D-window, Marker and Measurements win-

Windows

dows, Objects attributes window (see the chapter
“General system’s windows” of the ’General inform-
ation’ User Manual)
allows to start the ’Help’ systemHelp
purposed for closing of GeoMosaic programExit

4.3. The main toolbar
Table 3. Brief description of main toolbar

FunctionButtons
allows to create a new project
allows to open a mosaic project from active profile
resources
allows to save a mosaic project
allows to save a mosaic project with new name in
active profile resources
allows to add images out of active profile resources
allows to add images from active profile resources
allows to open images list
allows to open sheets list
allows to open current and previous images in indi-
vidual 2D-images
allows to open next image
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FunctionButtons
allows to open previous image
allows to open current and next images in individual
2D-images
allows to set on a single sheet creation mode
allows to create a sheet around marker
allows to set on the area to cutlines additional mode
which is used for adding new cutline to existed one
allows to define the output parameters for creation
of mosaic
allows to rebuild brightness adjustment for all block
scheme
allows to enable using of ground control points
allows to enable using of tie points
allows to open the Preview window for all project
allows to open the Preview window for current sheet
allows to start the mosaic creation
allows to start building a mosaic for selected active
sheets according to the specified settings and
parameters in the distributed processing mode
allows to start building a mosaic and creating an
output file for the selected sheet
allows to load an image from file to the individual
raster layer
allows to launch theDustCorrect module to edit MS-
TIFF images (see the “Dust Correct” chapter of the
“Project creation” User Manual)
allows to undo the last action (see the ’General in-
formation about system’ User Manual)
allows to display the list of last actions (see the
’General information about system’ User Manual)
allows to redo the last undone action (see the
’General information about system’ User Manual)
allows to load a georeferenced image from file, loc-
ated in the file system, for more precise correspond-
ence of cutlines area
allows to load web-map
allows to open the Marker window (see the menu
description in ’Vectorization’ User Manual)
allows to open theMeasurementswindow (see the
menu description in ’Vectorization’ User Manual)
allows to tile 2D-windows
allows to stack 2D-windows
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FunctionButtons
allows to refresh all 2D-windows; to perform re-cal-
culating of brightness adjustment click the button
holding the Shift key
allows to zoom in in all images (Shift+* [NumPad])
allows to zoom out in all images (Shift+/ [NumPad])
allows to open a window of display mode paramet-
ers (see Section 15)

5. Workflow of mosaic creation
Creation of mosaic implies a number of following actions:

1. Creating of mosaic project (see Section 6).

2. Loading of images in the mosaic project:

• images adding;

• setting of transparency for the background color of source images (see Sec-
tion 7.5).

3. Defining of channels set for mosaic.

Use the Mosaic tab in the Mosaic parameters window to define the channels (see Sec-
tion 13.2.2).

4. Defining of the output coordinate system for mosaic and using it for storing of vector
data (the cutlines, sheets boundaries and tie points).

Use theMisc tab to specify the save parameters of vector data in output coordinate system
(see Section 13.2.5). The output coordinate system for mosaic is defined in the Mosaic
parameters window on the Mosaic tab (see Section 13.2.2).

5. Estimation of work areas for cutlines creation: Creating areas without background
and areas with clouds (see Section 8).

6. Cutlines creation and editing (see Section 8).

It is not necessary to create cutlines only if block of initial images with joining boundaries,
i.e. if images block is without overlaps and ’gaps’, is used.

7. [optional] Performing brightness adjustment of mosaic areas: global and local
brightness adjustment, seams feathering (see Section 9.1).
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8. [optional] Stitching of the area from the tie points in the cutlines region and using
ground control points (see Section 10). Setup parameters of GC/Tie points meas-
urement (see Section 13.2.4).

9. Splitting into sheets and selection for creating of output files (see Section 11).

10. Setup the output parameters for mosaic creation: pixel size, map scale, mosaic
sheets file format, etc. (see the Section 13.2.2 and Section 13.2.3).

11. The mosaic creation with saving of the mosaic sheets in the files of selected format,
also in the distributed processing mode.

6. Mosaic project creation

6.1. Project menu
Table 4. Brief description of ’Project menu’

FunctionMenu items
is used for creation of the new mosaic projectNew
is used to open the saved mosaic project from file
with the x-gmos extension in the resources of active
profile

Open

allows to choose and open one of recent projectsRecent
allows to import mosaic project from the *.x-gmos
file

Import

allows to save the opened mosaic project in the file
with the same name and the x-gmos extension in
the resources of active profile

Save

allows to save the openedmosaic project in the new
file and the x-gmos extension in the resources of
active profile

Save as

allows to save the project work environment – a set
of project opened layers (e.g. vector data, raster

Save work environment

images opened to transfer GCPs or DEM) in a file
*.x-work in active profile resources
allows to load project work environment data from
a file *.x-work saved in active profile resources

Load work environment

allows to open the project statistic windowStatistic

6.2. Creating new project

Choose the Project › New or click the button on the main toolbar; The following
blank service vector layers are created automatically and displayed in the Layer manager:

• Useful areas;
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• Clouds/Invisible areas;

• Ground control and tie points;

• Miscellaneous;

• Sheets;

• Cutlines.

Service layers couldn’t be closed or saved as a separate vector layer.

The name project in the title of main program’s window is marked with *, if the project
was changed.

Mosaic project is saved to x-gmos file.

Choose the Project › Save to save the mosaic project. All changes in project layers
are saved.

Choose the Project › Save as to save the mosaic project with new name and define
name and path in active profile resources.

Choose the Project › Open or click the button on the main toolbar to open existed
mosaic project.

The program provides opportunity to load the following additional data in the project:

• choose the Misc › Load metadata to current layer to load images metadata to the
current active layer;

Metadata – structured information about data in the image file,

It is recommended to choose Cutlines or Miscellaneous layers to correct load of metadata.
Metadata could be load only into a system layer.

• choose the Misc › Load nadir and central points to load nadir and central points
to the Miscellaneous layer.

It is possible to work with project without source raster images (e.g. only to view project
parameters or cutlines). In this case images display as a grid in 2D-window.
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Fig. 2. Project without source images

6.3. Mosaic project import

The program allows to import parameters of other project without changing set of source
images

During import of parameters or points/cutlines layers При импорте параметров или слоя
порезов/точек автоматически учитывается расхождение между размерами пикселов на
местности текущего и другого проектов.

To import project parameters to opened project choose the Project › Import.

Fig. 3. Mosaic project import parameters
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The Project import parameters window allows to choose type of the following data to
import:

• Import settings and brightness adjustment – allows to import parameters of the
Mosaic tab on the Mosaic parameters window, and also parameters of local and
global brightness adjustment from the Brightness adjustment tab;

• Import cutlines – to import cutlines layer, associate these cutlines with images of
current project;

• Import tie and ground control points – allows to import tie and ground control
points and to associate then with images of current project;

• Import sheets – allows to import parameters of splitting mosaic into sheets and to
allow these parameters for current project;

• Reference by image name only – to compare imported cutlines only by image name,
not by path;

• Import cell size – to import the output mosaic cell size.

All data import to the service layers of project. Layers with imported data are marked in the
Layer manager.

6.4. Project information

To view information about the project choose Project › Statistic.

The Statistic window, which contains the following information, opens:

• quantity of source images;

• quantity of channels;

• bytes per sample;

• quantity of total/active mosaic sheets;

• mosaic size in megabytes;

• output raster size in pixels.
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Fig. 4. Project information

7. Images block forming

7.1. Images menu
Table 5. Brief description of Images menu

FunctionMenu items
is used for the selecting image files, locating in the
file system, and adding to mosaic project

Add images from files

is used for selecting image files, locating in the re-
sources of active profile, and adding to mosaic pro-
ject

Add images from resources

is used for automatic selection of all images from
the specified folder ofWindows file system

Add images › From files (from folder)

is used for automatic selection of all images from
the specified folder of active profile and adding to
mosaic project

Add images › From resources (from folder)

allows to use the text file, containing the full network
paths to the images (useful when the project files

Add images › Add from files list

are located in different local and network folders),
for adding the images to mosaic project
allows to delete from project the images that are
selected using selection of appropriate vector ob-

Delete selected images

jects, for example, source images boundaries, cut-
lines, areas without background
allows to delete the images outside active sheets
from mosaic (see Section 11)

Delete images outside active sheets

allows to open the added images list for editing list,
search images by name, view the selected image

The Images list window

and its properties; define images background color;
show tie points residuals
is used to open in separate 2D-windows those im-
ages, with highlighted boundaries (see Section 12)

Open selected images
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FunctionMenu items
is used for the checking of the project images (the
file presence, georeferenced data presence, the

Check source images

correct file format); if images were changed, inform-
ation message is displayed
allows to create the overview pyramid set for the
fast images refreshing on screen (the pyramids are

Create pyramids

saved in the files with the pyr extension in the Pyr-
amid folder during this process)
allows to use distributed processing for pyramid
creation of loaded images

Distributed pyramids creation

allows to delete all pyramids, created for loaded
images

Delete pyramids

contains menu items to set up transparency images
background color

Transparent background color

7.2. Adding images

The step forming of source images block follows after the mosaic project creation. It
implies a number of following actions:

1. Loading source images and forming block images of mosaic project.

2. Setting transparency for the background color of source images to exclude the
background from the output mosaic.

The program provides the following possibilities to load source images into the project:

• to add source images manually from files

○ in active profile resources – choose the Images › Add images from resources
or click the button;

○ in theWindows file system folder – choose Block › Add images from files or click
the button.

Shift and Ctrl keys are used to select multiple files.

• to add source images automatically;

Automatic selection is recommended when large number of source raster files are located
in the folder along with files of other formats, and/or when source images are located in
several subfolders of the selected folder.

○ from folder in active profile resources – choose the Images › Add images › From
resources (from folder);

18

Orthophotomaps creationPHOTOMOD 6.4



○ from theWindows file system folder – choose the Images › Add images › From
files (from folder).

To search raster images in subfolders, set on the Search in subfolders checkbox.

It is possible to search and add files only with selected extension. The type of mask like
*.* is used for this (e.g., *.tiff).

• to add set of source images create a text-file with the list of images paths and choose
Images › Add images › Add from files list.

The text-file should contain list of full network paths to source images files.

It is possible to change output channels, if images with channel, that is absent in loaded
images, were added to the project.

7.3. Image selection

The program allows selection one of group of images in theMiscellaneous, Cutlines or
Useful areas layers and also in the window with source image.

The following options are provided for images selection:

• the Misc › Source images outlines menu item is used to create image borders as
vector polygons on the Miscellaneous layer. Images are selected corresponding to
selected polygons;

If there are selected objects on the non active Miscellaneous layer, will be selected images
corresponding to these objects.

• if there are selected polygons on the Cutlines or Useful areas layers, will be selected
images corresponding to selected polygons;

• if there are selected objects on the active 2D-window, will be selected image in this
window only.

7.4. Images preview

Images block opens automatically in the Preview window after adding images to the
mosaic project.

To display all images in the Preview window, choose the Mosaic › Preview or click
the button of the main program toolbar.
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Images are displayed in the Preview window automatically after adding to the mosaic project.
In order to disable automatic displaying of images, set off the checkbox in the Settings › Preview
window (see Section 15.2).

Each image of mosaic project is a raster images, insert to a rectangle.

Background without image has defined color. In program it calls mosaic’s background
and each output mosaic file contain it.

By default is used black background color. Background doesn’t display in the Preview
window.

To display output mosaic background in the Preview window, set off the Transparent mosaic
background on preview checkbox in the Parameters › Preview window (see Section 15.2).

TheBackground color parameter on theMosaic tab in theMosaic parameterswindow allows
to chose (see Section 13.2.2).

Source images in mosaic project also have background, which calls background color
of source images in the system.

It is recommended to exclude this background from output mosaic. To do this set the transparency
of background color (see Section 7.5).

Fig. 5. Mosaic’s background and background color of original images (without transparency)

Perform one of the following to open images of mosaic project in separate 2D-windows:
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• choose the Images › Project images list to open Images list window. Select the
images in the list and click the button.

In order to highlight multiple images, press and hold theCtrl or Shift key while clicking mouse
or use selecting tools in Images list window (see Section 7.8).

• choose the Misc › Source images outlines to create image borders as vector poly-
gons. Select borders of images and choose the Images › Open selected images.

To select more than one object, stretch the rectangle along with pressed Shift key with one
of the group selection instruments on Tools toolbar.

The following buttons on main toolbar are used to pass to previous or to next image:

• – to display previous image;

• – to display next image.

If there is no opened 2D-windows (image) or preview windows, the button allows to open
the last image in the project, – the first image.

The following buttons on main toolbar are used to pass to previous or to next image:

• – to display current and previous images in separate 2D-windows;

• – to display current and next images in separate 2D-windows.

To open any georeferenced orthoimage of acceptable raster format in separate 2D-
window, choose the Mosaic › Open image or click the button on the main toolbar
and choose image file.

In case the same folder contains a *.rmc file, the correction parameters for the selected image
will be loaded

7.5. Setup of image background color

It is recommended to setup of transparency image background color after image loading
into mosaic project to create mosaic correctly.

Setup of transparency background color of input image is highly recommended when there are
areas inside images with the same color as background and you need to consider these areas
in output mosaic as transparent, i.e. to produce mosaic with ’gaps’ without fill of input background
color or using reference image. The Transparent background inside cutlines parameter is
used to consider useful areas transparency (see Section 13.2.2).

Perform one of the following to setup transparency for the background color of source
images:
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If background is not homogeneous in color, use the Source rasters background color range
parameters (see Section 13.2.2).

• in case of white background color of source images, choose the Images › Transparent
background color › White;

• in case of black background color of source images, choose the Images › Transparent
background color › Black;

• choose the Images › Transparent background color › Auto to assign automatically
images background color and set up transparency to all mosaic project images.

Choose the Images › Project images list or click the button on the main toolbar. The
Images list window opens. Select the images to define the images background color and
click the button (see detailed description in Section 7.8).

Choose the Images › Transparent background color › None to cancel transparency
setting for images background color.

Fig. 6. Black color of images background
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Fig. 7. Transparency setting for black color of images background

7.6. Image pyramid creation

To fast images redraw on a screen it is possible to create image pyramid.

Pyramid is a set of resampled copies of image.

The pyramids are saved to the files with the pyr extension in the Pyramid folder.

Choose the Images › Create pyramids for creating the overview pyramid.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to create pyramids using distributed processing:

1. Add images to the project.

2. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

3. Choose Images › Distributed pyramids creation. The Create pyramids window
opens.
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Fig. 8. Pyramid’s distributed processing parameters

The total Number of images in project displays in the window.

4. Specify Number of tasks for processing, which are processed by one computer.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

5. Select the Temporary folder for distributed processing in the resources of active
profile for temporary data storing.

6. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

7.7. Editing of block images

Perform one of he following actions to delete the images from the mosaic project:

• select the image in the Preview window and choose the Images › Delete selected
images;

• choose the Images › Project images list. The Images list window opens. Select
the images in the list and click the button.

To select multiple images use Shift and Ctrl keys or use selecting tools in Images
list window (see Section 7.8).

Also the program provides a possibility to delete images outside of active sheets border
(see Section 11). After sheets creation define the activity of sheets and choose the
Images › Delete images outside active sheets to do this.

7.8. The Images list

The Images list window is provided to view and edit the images list of mosaic project.
To open the Image list window choose the Images › Project images list or click the

button of the main program toolbar.
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Fig. 9. The Images list window

The main part of the window contains a table of mosaic project images with the following
information:

• View – visibility images in the preview window;

• Image – attribute for full path to image file;

Set the Name only checkbox on to display image file name only;

• Background color – background color of source images, specified during setting of
background color transparency;

• Cutlines – information about presence/absence and quantity of cutlines created for
the image;

• Dimensions – image size in pixels;

• Channels – channels number and number of bytes per pixel;

Points sorting in columns of the list is performed by mouse click on the column header.

Double click to image name allows to open 2D-window of source image and all data
for this image (cutlines, sheets borders, etc.).
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Fig. 10. Project image

Toolbar and standard selection and searching tools are placed in upper part of window.
Number of Images total/selection displays in the status bar of the window.

Table 6. The toolbox of ’Images list’ window

FunctionButtons
is used to search for an image by name (part of
name) in the list
allows to select all images in the table
allows to unselect all images in the table
allows to invert selection of images in the table
allows to highlight images, selected in the table, on
active layer
allows to highlight image, selected in 2D-window,
in the table
allows to remove selected images from project
allows remove from the project images without cut-
lines (in the Cutlines column is shown the ’–’)
allows to set coordinate system for selected images
allows to clear coordinate system for selected im-
ages
allows to open selected image in 2D-window
allows to refresh table of images and recalculate
quantity of cutlines, which fall into images
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FunctionButtons
allows to display information about selected image
(path, size, channels)
allows to clear selected images background color
allows to set arbitrary images background for selec-
ted images
allows to apply auto levels to selected images (see
the ’General information about system’ UserManual)
is used to radiometric correction for selected images
(see the ’General information about system’ User
Manual)
allows to delete radiometric correction for selected
images
allows to show tie points residuals for current image
(see Section 10.5)
allows to restore the default order of images after
changing
allows to move selected image at the head of the
list;
allows to move selected image up the list;
allows to move selected image down the list;
allows to move selected image at the end of the list;
allows to invert selected images or group of images
allows to reverse images in the table
allows to save the list of selected images and their
file paths in a text file
allows to remove each n-th images from project
allows to select several images from the project as
a ’reference’ images to apply global brightness ad-
justment

Selected reference images will not be changed during adjustment. Histograms of other mosaic
images will be corrected in accordance with chosen (’reference’) images.

For correct brightness adjustment using one or more reference images selected in the Images
listwindow, make sure that theBy average brightness option is selected in theGlobal adjust-
ment section of the Brightness adjustment tab in the Mosaic parameters window;

Brightness adjustment using several reference images (located in different parts of the mosaic)
can be useful when processing projects containing large number of images.

allows to open the Columns list window
allows to display in the Preview window changes
of brightness, contrast and gamma data settings in
the work area (G, K, L) made in a single image 2D
window without closing it
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In order to display in the Preview window changes of brightness, contrast and gamma
data settings in the work area made in a single image 2D window (without closing it),
perform the following:

1. Make sure that the Use brightness pre-correction checkbox is set in the Bright-
ness adjustment tab in the Mosaic parameters window, and None option is se-
lected in the Global adjustment section;

2. Click the button in Images list window;

3. Click the button of the main program toolbar. Brightness, contrast and gamma
data changes will be displayed in the Preview window.

8. Cutlines creation

8.1. Cutlines menu
Table 7. Brief description of the Cutlines menu

FunctionMenu items
allows to delete cutlines, i.e. to clear the Cutlines
layer completely (without closing of this layer)

Clear

allows to open cutlines saved earlier in vector file
*.x-data in active profile resources

Open

allows to save vector data file with cutlinesSave
allows to save cutlines in vector file *.x-data with
new name

Save as

allows to calculate useful areas in automatic modeUseful areas
allows to calculate cloudy areas in automatic modeClouds/Invisible areas
allows to setup parameters of automatic cutlines
creation and to start cutlines build operation, also
in the distributed processing mode

Build full mosaic

allows to add areas to cutlines during their editing
(see the Section 8.6)

Area to cutlines addition mode

allows to redefine attributes of the Cutlines vector
layer

Parameters

allows to view and edit attribute values of selected
cutline

Cutline properties

allows to check correspondence between cutlines
and images of a project in order to find images

Check cutlines

without cutlines and/or cutlines which are not at-
tached to images
allows to split cutlines according to boundaries of
created sheets

Split cutlines into sheets
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8.2. Requirements of the cutlines creation

The stage of cutlines creation follows after the forming the block images of the mosaic
project.

Cutline is a vector polygon defining the images area, which will be included in output
mosaic.

Combination of automatic and manual cutlines creation, with clouds selection, optional use of
DEM, as well as definition of the cutlines type by attributes provide high quality the stitching of
the areas during the output mosaic creation. There is no need to create cutlines when you process
block of images, which boundaries are docking, i.e. images blocks without overlaps and ’gaps’.
In order to create mosaics using such images you should perform the following actions: setup
transparency of input background color, split into sheets, setup mosaics parameters and create
output mosaics sheets.

Performing the following steps is recommended for the cutlines creation:

1. [optional] Creating areas without background and areas with clouds.

2. Automatic cutlines creation (also in the distributed processing mode).

3. Editing cutlines: manual editing of vector polygons and their attributes in theCutlines
layer.

There are following rules to go by when creating the cutlines for building of the high
quality mosaic:

• cutlines should not have intersections and self-intersections. The common boundaries
of the neighbour cutlines should be fully correspond;

• I.e. all areas of the source images, outlined by cutlines, form one united coverage
without overlaps or gaps;

• It is not recommended to draw cutlines over elevated objects (bridges, buildings,
utility poles, etc), otherwise if the Seams feathering checkbox in the Mosaic para-
meters window in the Brightness adjustment tab is set on, the smearing effect is
possible;

It is recommended to cross extended objects at right angle or create cutline not less than 1.5
cell size apart from extended objects border.

• it is recommended to create cutline parallel to brightness edge on enough distance
from it.
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8.3. Creating areas without background (useful areas)

It is recommended to create areas without background before creating cutlines and set
the background transparency of source images.

Useful area contains substantial part of image and excludes input background of image.
Useful areas are vector polygons on the Useful areas layer.

Useful areas are used as well as setup of input background color transparency to create
cutlines.

There is no need to create useful areas prior to cutlines creation in the following cases:

• there is no background on images;

• manual editing (specification) of useful areas is not required;

• there is no need to select (create) cloudy areas on source images to consider them
during cutlines creation.

Useful areas creationmay exclude a necessity to setup transparency of input background
color.

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have x-feat
extension.

For useful areas creation use menu Cutlines › Useful areas.

Table 8. Brief description of menu ’Useful areas’

FunctionMenu items
allows to define parameters and calculate useful
areas automatically as vector polygons on the
Useful areas layer

Build

allows to clear Useful areas layer (without closing
of this layer); at that information about useful areas

Clear

is not deleted from files of images description *.x-
feat, that allows to restore created useful areas
allows to restore recently created useful areas if the
Useful areas layer was cleared using menu item

Open

Cutlines › Useful areas › Clear, and then to display
them in the Preview window
allows to save useful areas in files of images descrip-
tion x-feat after drawing them manually or editing
areas without background calculated automatically

Save

allows to completely clear the Useful areas layer
without possibility to restore the useful areas, i.e. to

Delete all
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FunctionMenu items
clear the layer along with deleting information in files
of images description x-feat
allows to delete useful areas, created for selected
images, along with information in files with images
description x-feat

Delete for selected images

For automatic calculation of useful areas perform the following actions:

1. Choose Cutlines › Useful areas › Build. The Settings window opens.

Fig. 11. Useful areas parameters

2. [optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images.

3. Set the Image edges trim value to setup offset distance from background boundary
and the image substantial area (in pixels).

4. Set the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created).

5. Set the Minimal components square to specify image area value, that will be
used as area minimal threshold for useful areas creation.

6. [optional] To calculate useful areas for selected images only, set on the For selected
images only checkbox.

7. [optional] Set the Force checkbox on to recalculate already calculated and restore
deleted useful areas. At that information in files with images description *.x-feat
also refreshed.

8. Click OK to calculate useful areas.
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To use distributed processing in calculation of useful areas, perform the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The Distributed processing of
useful areas window opens.

Fig. 12. Creating areas without background (useful areas)

The total Number of images in project displays in the window.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of useful areas creation will be divided.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

There is an example of automatic useful areas calculation:

1. Source image has black input background. There are areas with input background
color inside the image.

32

Orthophotomaps creationPHOTOMOD 6.4

general.pdf


Fig. 13. Source image

2. Set theUnique background color checkbox in the Parameterswindow to consider
’insets’ during useful areas creation.

Fig. 14. Useful area in case of unique background color
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3. Clear theUnique background color checkbox in the Parameterswindow to create
useful areas roughly, almost without considering ’insets’. Closed areas of black
color inside image are not considered as a background and are included to useful
area.

Fig. 15. Useful area in case of non-unique background color

8.4. Clouds calculation

In order to calculate cloudy areas and exclude them during cutlines creation the system
provides possibility of their automatic recognition and calculation. Cloudy areas are
vector polygons on the Clouds/Invisible areas layer.

It is necessary to create useful areas prior to creating of cloudy areas.

The Cutlines › Clouds/Invisible areas menu is used to create cloudy areas.

Table 9. Brief description of menu ’Clouds/Invisible areas’

FunctionMenu items
allows to setup parameters and automatically calcu-
late cloudy areas as vector polygons on the
Clouds/Invisible areas

Build

allows to clear the Clouds/Invisible areas layer
(without closing the layer); at that information about

Clear

clouds is not deleted from files of images description
*.x-feat, that allows to restore created clouds
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FunctionMenu items
allows to restore existing clouds if the Clouds/Invis-
ible areas layer was cleared using menu item Cut-

Open

lines › Clouds/Invisible areas › Clear, and to dis-
play them in the Preview window
allows to save clouds in files of images description
*.x-feat after editing of clouds calculated automat-
ically or after drawing them manually

Save

allows to save cloudy areas created just for selected
images to files of these images description *.x-feat

Save for selected images

after editing of clouds calculated automatically or
after drawing them manually
allows to clear the Clouds/Invisible areas layer
completely without possibility of restoring cloudy

Delete all

areas, i.e. to clear the layer along with information
deleting from files of images description *.x-feat
allows to delete clouds created for selected images,
and to delete information from files of images de-
scription *.x-feat

Delete for selected images

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have *.x-feat
extension.

Automatic clouds detection principle consists in search on image for bright enough and
homogeneous areas, where there is grey color with area not less then specified.

To calculate cloudy areas automatically perform the following actions:

1. Choose Cutlines › Clouds/Invisible areas › Build. The Clouds detecting para-
meters window is opened.
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Fig. 16. Parameters of cloudy areas building

2. [optional] To load pre-set of parameters from *.x-ini file, located in the file system,
click the button and choose a file.

3. Specify the following parameters of automatic clouds detection:

• Brightness lower boundary – allows to define range of brightness for clouds
detection – to specify lower brightness threshold (from 0 to 100, where 100 –
maximal brightness), if the brightness is more that the threshold it is considered
as possible cloud;

• Upper boundary of grey shift – allows to define maximal deviation from grey
color that present in clouds (from 0 to 100, where 0 – grey color, when R, G, B
values are equal);

• Upper boundary of heterogeneity – allows to define range of heterogeneity in
clouds – to specify maximal deviation from homogeneity (from 0 to 100, where
0 – homogeneous area);

• Dispersion upper boundary – allows to define range of dispersion in clouds –
to specify upper dispersion threshold (from 0 to 100);

• Clouds edges thinning – allows to define a degree of clouds boundaries thinning
(filtering of vector polygons vertices) from 0 to 100, where 0 – boundaries without
thinning; 100 – ’rough’ maximally filtered boundaries;

• Minimal cloud area – allows to define minimal area of cloud, when this area is
not considered as cloud, i.e. clouds of small size will be excluded from selection;
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• Clouds offset – allows to setup offset in meters around the cloud detected (to
exclude shadow or half-transparent part of cloud).

4. [optional] To calculate cloud areas for selected images only, set on the For selected
images only checkbox.

5. [optional] Set on the Force checkbox to recalculate already calculated and restore
deleted cloud areas. At that information in files with images description *.x-feat
also refreshed.

6. [optional] To load pre-set of parameters from *.x-ini file, located in the file system,
click the button. Input a file name and click Save.

7. Click OK to search and calculate cloudy areas.

To use distributed processing in calculation of cloudy areas, perform the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The Distributed processing of
useful areas window opens.

Fig. 17. Creating cloudy areas

The Number of images in project field displays the number of source project
images.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of cloudy areas creation will be divided.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.
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5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

8.5. Automatic mode of cutlines creation

The program provides opportunity to create cutlines in automatic mode with one of two
algorithms: Voronoy diagram, and more detailed algorithmwhich is specially recommen-
ded for images with urban or rural building.

Performing the following steps is recommended for the cutlines creation:

1. Use the fast Voronoy diagram method.

2. Estimate the results of cutlines creation.

3. [optional] Edit the cutlines in vector objects drawing mode, if necessary.

4. If the results are not acceptable apply detailed algorithm of cutlines creation.

In this case cutlines are created bypassing separate objects (houses) and crossing roads
at the right angle.

Perform the following actions for automatic cutlines creation:

1. Choose the Cutlines › Build. The Cutlines creation parameters window opens.
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Fig. 18. Parameters of automatic cutlines creation

2. In the Useful areas section choose one of the following options of using useful
areas during cutlines creation:

• Not use – allows to not use useful areas, when the background is absent on
source images;

• Use – is used to use pre-created (automatically or manually) useful areas;

While creating cutlines considering useful areas it is not recommended to use orthoim-
ages with JPEG-compression.
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• Build and use (by default) – allows to calculate useful areas automatically and
use these areas for cutlines creation.

Calculated useful areas don’t display in 2D-window and don’t save on the Useful areas
layer.

The Build and use mode is used by default if the assign automatically images back-
ground color was chosen.

3. In theClouds/Invisible areas section choose one of the following options of clouds
considering during cutlines creation:

• Not use (by default) – allows to not use cloudy areas;

• Use – is used to use pre-created (automatically or manually) cloudy areas;

• Build and use – allows to calculate clouds automatically and consider them
during cutlines building in automatic mode.

Calculated cloudy areas don’t display in 2D-window and don’t save on theClouds/Invisible
areas layer.

4. In the Attribute name input field specify the attribute name of the Cutlines vector
layer, where the full path to the image is stored (by default, image_name).

It is necessary to specify the attribute to perform automatic matching of the cutlines with
images prior to mosaics building, or for preview creation.

5. Check the Check clouds/invisible areas checkbox to exclude ’gaps’ in created
cloudy areas in output mosaic.

The main idea of clouds check is, that the system tries to use reference image to replace
a cloud (entirely or partially) if the reference image does not contain the cloud in this place,
otherwise, the cloud will stay on the output mosaic.

6. [optional] In the Useful areas offset input field specify positive or negative value
of distance in meters to crop(-) or add (+) fields of working area, which is defined
by created useful areas.

TheUseful areas offset value should be much less than theMaximal shift from Voronoy
diagram parameter’s value.

7. In the Method section choose one of the following methods of automatic cutlines
creation:
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• Fast (Voronoy diagram) – this method consists in splitting all the area of cutlines
creation into polygons based on proximity to nadir points or, if the latter are not
given, to image centers;

• Detailed – more ’fine’ algorithm for Voronoy diagram building, In this case edges
of Voronoiy’s diagram, belonging to two different images, are replaced by broken
lines, which provide optimal images joining.

• Images scheme – is a process where installation of source images without a
background is used for the first approximation of constructing cuts.

8. [optional] Click the Show advanced parameters button to open parameters of
detailed algorithm. The following additional parameters of this method are shown:
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Fig. 19. Detailed method cutline creation parameters

• Maximal shift from Voronoi diagram – at zero value you will get Voronoy dia-
gram, if the value is one – maximal area is used for cutlines creation. This al-
gorithm allows to calculate estimation function on images. Cutlines are created
on lines in such a way, that maximal value of this function on them is minimal
among all possible lines (minimax method).

• Weight of objects outlines – allows to avoid separate objects (houses) during
cutlines creation or to cross them at the right angle (in case of roads);
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• Weight of images heterogeneity – allows to avoid small cities and settlements
during cutlines creation, including also urban blocks, since at certain pixel size
settlements look more heterogeneous, comparing with forested areas, agricultural
fields, etc;

• Weight of images correlation – the bigger the differences in vicinity of pointon
adjacent images, the bigger this component for each point;

• Weight of images brightness – is used for cutlines creation in darkened areas
of images, where human eye is less receptive to images inconsistency;

9. [optional] In the Thin out precision input field specify thin out coefficient of polylines
(in meters).

10. In theUse central points section define location of images centers which are used
for Voronoy diagram creation:

• Nadir points (recommended if any);

• Images centers considering or not images background.

The Centers of images without background checkbox allows not to consider images
background when use centers of images.

11. [optional] In the Create cutlines not closer than [ ] m from useful areas edge
input field specify minimal distance in meters from working area boundary to create
cutlines, if source images have small overlap.

12. [optional] The Use DEM checkbox allows us to take into account the terrain relief
when creating cutlines.

It is recommended to be used for the imagery of highlands for creating cutlines taking into
account lowlands, but not mountain peaks. It is also recommended in case of presence of
buildings in the imagery to create cutlines between houses.

13. Click OK to start process of cutlines creation.

To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click theDistributed processing button. TheCutlines distributed processing
window opens.
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Fig. 20. Cutlines distributed processing parameters

The Number of images in project field displays the number of source project
images.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of cutlines creation will be divided.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Select the Output cutlines resource for output vector file for storing cutlines
in the resources of active profile.

6. Click OK to create distributed processing tasks.

The vector polygons are created in the Cutlines layer after the process completion.
Created cutlines are displayed in the Preview window.

14. [optional] if necessary, edit parameters and start automatic procedure of cutlines
creation and/or edit cutlines manually considering recommendations to cutlines
creations.

15. Choose the Cutlines › Save to save the created cutlines in the x-data files of the
active profile resources.

Choose the Vectors › Export to export the cutlines into other formats (see the
Vectorization User Manual).

8.6. Editing cutlines

The following options are provided for cutlines editing:

• to delete all cutlines, i.e all vector objects from the Cutlines layer, choose the Cut-
lines › Clear;
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• to edit cutlines manually is used the standard tools of Vectors menu (see the ’Vec-
torization’ User Manual);

If new cutline creates manually it is assigned that image, the center of which is the closest
to the created cutline.

• the Vectors › Topology › Verify topologymenu item is used for verify topology (see
the ’Vectorization’ User Manual);

• to create a cutline inside an existing cutline are used modes which could be switched
on the Cutlines type additional toolbar.

The buttons of the Cutlines types additional toolbar are used to choose the type of
cutlines:

○ Image – to use main image in cutline area;

○ Transparent with reference image – to use reference image in cutline area
(by default it is supposed to use a nearby image into the cutline area);

○ Background – to use the output mosaic background color in cutline area, which
sets in the Parameters window (see the Section 13.2);

The system also enables using background color beyond cutlines of the Background
type. To do this, set the Fill background color outside “Background” cutlines checkbox
in the Geomosaic tab in the Settings window (Service › Settings).

○ Transparent without filling – to use transparent without filling in cutline area.

• to add new cutline to existed one (e.g. to edit manually cloudy area) is used the
Cutlines › Area to cutlines addition mode and the button of the main program
toolbar; To add new cutline into existed one, perform the following:

1. Choose Cutlines › Area to cutlines addition mode or click the button of the
main toolbar.

2. Choose the type of cutline in the Cutlines types additional toolbar.

3. Make the Cutlines layer active.

4. Create a new polygon (see the ’Vectorization’ User Manual).

5. To display the new cutline area click the button.

• the Cutlines › Split cutline into sheets menu item allows to split cutlines into poly-
gons by sheets’ borders. Polygons are saved in a new vector layer and contain all
citline’s attributes.
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To use this function it is required to create or load into project both cutlines and sheets.

• The Cutlines › Check cutlines menu item is used for checking correspondents
between cutlines and images of a project in order to find images without cutlines
and/or cutlines which are not attached to images or to remove images.

8.7. Cutlines attributes

The attributes of the Cutlines layer extend the capabilities of editing cutlines. Basing
on the attributes, the cutline gets the name and type.

In the case, where the imported objects have another attributes, the capability of setting
attributes provides the correct import of cutlines, created in third party software.

By default, the Cutlines layer has following attributes used to store information about
cutlines:

• image – attribute for full path to image file;

• image_title – attribute for cutline name (equal to image name – source or reference
image);

• rgn_type – the cutline type attribute;

• ref_image_name – the filename of reference image attribute, used in the cutline area.

For editing the Cutlines layer attributes perform the following:

1. Choose the Cutlines › Parameters. The Cutlines parameters window opens.

Fig. 21. Cutlines parameters

The default attribute name is displayed in the Attribute with cutlines name list.

2. To edit attribute choose attribute name from the list or click the button to add
new attribute. Input the name of new attribute and click OK.

3. [optional] Set on the Reference by image name only checkbox to comparison
cutlines only by image name, not by path.
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Editing of vector layer attributes, including editing of attribute name and attribute deleting
are used in cutlines import. Choose the Vectors › Export to export the cutlines into other
formats (see Vectorization User Manual).

Perform the following actions to view and edit attributes of the Cutlines layer and attrib-
utes values of selected cutline:

1. Select a cutline in the Preview window.

2. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

Fig. 22. Cutlines attributes

The following buttons are used to create and edit attributes table:

• – allows to delete all attributes of selected objects;

• – allows to delete common attributes of selected objects;

• – allows to open the Add attribute window to define name, type and value
of attribute;

• – allows to delete current field of attribute table;

• – allows to open the Edit attribute window to edit parameters of selected at-
tribute;

• – allows to sort attributes of selected objects;

• – allows to invert attributes of selected objects.

Attributes may have the following values:

• for image – full path to main image file;

• for image_title – cutline name (is automatically generated from name of file with
source image);

• for rgn_type – cutline type:

○ 1– complies to the Image type;
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○ 2 – complies to the Transparent from reference image type;

○ 3 – complies to the Background type;

○ 4 – complies to the Transparent without filling type.

• for ref_image_name – full path to reference image file, providing that the cutline
type is the Transparent from reference image, i.e.rgn_type = 2.

3. Double-click the string of the Value input field and insert another value for changing
of attributes value.

4. Press Enter to save or press Esc to cancel.

8.8. Cutlines info

To view and change information about several cutlines perform the following:

1. Make the Cutlines layer active.

2. Select a cutline in the Preview windows.

3. Choose Cutlines › Cutline properties. The Cutline info window opens.

Fig. 23. The information about cutline

4. In the Main image field (corresponds to the image attribute value) shows full path
to file of main image, for which the cutline was created. To edit the field value open
the list and select another image of the project.

To return to current main image click the button. To clear the list click the button.

5. Choose one of the Cutline type from the list corresponds to the rgn_type attribute
value):

• Image to use main image in area of cutline;
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• Transparent from reference image to use reference image (fallen into cutline
area) in area of cutline specified in the Source image field;

• Background to color the cutline area with output mosaic background color (see
Section 13.2.2), that is used for coloring of any terrain objects on images;

• Transparent without filling to apply transparency to the cutline area.

To clear the list click the button.

6. [optional] In the Source image (corresponds to the ref_image_name attribute value)
shows full path to file of reference image (fallen into cutline area), if the image is
used for the cutline with the Transparent from reference image type. In order to
select a reference image use a list of project images.

To clear the list click the button.

7. Click the Apply button to apply changes.

9. Brightness adjustment
The system allows to adjust brightness and contrast features of cutlines areas during
their merging (the global and local brightness adjustment of output mosaic) and options
of smoothing areas along cutlines, to create uninterrupted mosaic image.

To do so, the Brightness adjustment tab of the Mosaic settings window is used.

Global brightness adjustmentmeans transformation equally applied to all pixels of each source
image (see Section 9.1).

Local brightness adjustment is a transformation applied along cutlines of images that are merged
into mosaic with a smoothing going down to the image central point and mosaic edges. Pro-
cessing of each pixel during the local brightness adjustment depends on its coordinates (see
Section 9.2).

To perform the brightness adjustment of output mosaic do the following:

1. Select Mosaic › Parameters. The Mosaic parameters window opens;

2. In Mosaic parameters window open the Brightness adjustment tab;

3. [optional] set the global brightness adjustment parameters;

4. [optional] set the local brightness adjustment parameters;

5. [optional] set the general parameters of brightness adjustment;
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6. [optional] set the parameters of smoothing areas along cutlines;

7. Click OK to save all the parameters set in the Brightness adjustment tab;

8. SelectMosaic › Brightness adjustment or click the button on the main toolbar
to rebuild brightness adjustment for all block scheme.

If after cutlines editing you need to rebuild brightness adjustment, choose theMosaic ›
Brightness adjustment.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to rebuild brightness adjustment using distributed processing:

1. Set the brightness adjustment parameters in the Brightness adjustment tab of
the Mosaic settings window and click OK;

2. Click the button on the main toolbar;

3. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

4. Choose Mosaic › Distributed global brightness adjustment. The Brightness
adjustment distributed processing window opens.

Fig. 24. Brightness adjustment distributed processing parameters

The total Number of images in project displays in the window.

5. Specify Number of tasks for processing, which are processed by one computer.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

6. Select the Temporary folder for distributed processing in the resources of active
profile for temporary data storing.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.
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8. After the end of distributed processing click the button on the main toolbar to
reopen the mosaic project from active profile resources.

To clear all data about brightness adjustment choose Mosaic › Clear brightness ad-
justment and click the button on the main toolbar to rebuild brightness adjustment
for all block scheme.

9.1. Brightness adjustment parameters

Fig. 25. Brightness adjustment parameters

The Use brightness pre-correction checkbox allows to consider preliminary BCG-
correction of source images while output mosaic is created.

Brightness pre-correction does not consider in case of any method except None was chosen
in the Global adjustment section.

It is recommended to set on the Use brightness pre-correction checkbox if there are a lot of
cloud areas on scanner images.
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In theGlobal brightness adjustment section choose the way of the brightness adjust-
ment for all block:

• None – allows to use images without adjustment;

• By average brightness – allows to apply brightness adjustment using average images
brightness;

At that brightness and contrast of all images are set to values, found using averaging of
brightness and contrast values calculated over all mosaic images. This method is recommen-
ded when there are big differences between brightness’ of images, but each of them contains
relatively smooth scenes.

It should be noted that in case of scenes with sharp different brightness within one image
(for example ’sea’ and ’coast’) this method may produce incorrect brightness adjustment
results.

• By project image – allows to apply global adjustment by project image: histograms
of mosaic images are corrected in accordance with chosen project (’reference’) image.
To select the reference image is used the button;

It is recommended to use image located in the middle of images block as a reference. It is
not recommended to use this method in case of abnormal local brightness fluctuations
(’trends’) on images, since in this case you can face a problem of smooth increasing or redu-
cing of the brightness and contrast from the reference image to the block edges right up to
complete ’lightening’ (’blackening’).

The system allows to adjust brightness by several reference images (located in different parts
of the mosaic) what can be useful when processing projects containing large number of im-
ages.

To select the reference image is used the button in Images list window. For correct
brightness adjustment using one or more reference images selected in the Images listwindow,
select the By average brightness adjustment in the Global adjustment section.

• By image file – allows to apply global brightness adjustment using brightness from
chosen file. Histograms of mosaic images are corrected in accordance with chosen
image file. To load image is used the button.

The button serves for background color transparency setting for the selected image. For
example, if the image background is black, it is required to select black color in the opened
Color window. The button allows to clear background color transparency settings for the
selected image.

• By overlapped areas – allows to apply global brightness adjustment by overlapping
images. To set the adjustment parameters, use the button.
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Fig. 26. Brightness adjustment parameters (by overlapped areas)

○ Use statistic of overlapped areas with weight – allows to use the weight of the
images’ overlapping areas only;

○ Use statistic of entired images with weight – allows to use the weight of all the
pictures in the block;

If the images’ brightness in a block significantly differ, it is recommended to set a small
value.

○ Fix outline images with weight – allows the user to omit global alignment for
pictures on the block borders;

○ Fix etalon images with weight – allows the user to select images as reference
images and omit global adjustment for them.

TheMatch histogram checkbox allows to apply full (non-linear) brightness adjustment
with histogram matching. Otherwise only mean of distribution and standard deviation
are matched.

Set the On checkbox in the Local adjustment to apply local brightness adjustment
along cutlines of images that are merged into mosaic. If you would like to specify local
brightness adjustment parameters click the Parameters button (see Section 9.2).
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Also set up the following general parameters of brightness adjustment:

• Brightness adjustment cell size – allows to specify a size of a cell (in pixels), which
is used for brightness estimation and correction;

• Do not use excluded areas for global adjustment – allows to apply global adjust-
ment in mosaic areas, defined by vector polygon’s edges;

Vector polygons should be created in file in active profile resources. The button allows
to open file with polygons. The button displays a layer of vector polygons in both the
Layers Manager and in a 2D window.

• Do not use excluded areas for local adjustment – allows to apply global adjustment
in mosaic areas, defined by vector polygon’s edges;

Vector polygons should be created in file in active profile resources. The button to open
the file with polygons.The button displays a layer of vector polygons in both the Layers
Manager and in a 2D window.

• Use clouds – allows to consider areas with clouds in brightness adjustment.

For seams feathering set on the checkbox and define the following parameters in the
Smooth parameters section:

• Smooth aperture size – allows to define the size of smoothing zone along cutlines;

• Consider image edges when use feathering – allows to smooth seams on the
edges of images block, where may be no statistics enough for correct smoothing.

• Smoothing with round aperture – allows to turn on the mode of pixel-by-pixel
smoothing along cutlines.

Using this function results in increasing of time required for rebuilding brightness adjustment.

Set this checkbox if the results of smoothing along cutlines are not satisfactory, especially in
case of the presence of large water-tables in the project.
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Fig. 27. Smoothing with round aperture is not applied to the area (water-table) (left) and smoothing
with round aperture is applied to the area (right)

TheAdditional check for black background checkbox allows to consider background
of source images.

The Local adjustment of active sheets checkbox allows to apply brightness adjustment
only to images, located on active mosaic sheets.

Set this checkbox on only if distributed processing without saving adjustment parameters was
performed. In this case number of tasks should be equal to number of active sheets.

9.2. Local brightness adjustment parameters

Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges. Thus during local brightness adjustment each pixel of the image is pro-
cessed depending on its coordinates. At that the program performs simultaneous change
of brightness (additive component) and contrast (multiplicative component) of initial
images.

For preliminary estimation of local brightness adjustment choose the Misc › Local ad-
justment. In the Preview window you will see a grid of fragments (rectangles), used
for statistics collection for local brightness adjustment. The fragments are vector objects
located on the Miscellaneous layer.

Rectangles have the following colors depending on area, which is used for statistic ac-
quisition:

• green – to obtain statistic between images;
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• blue – to obtain statistic between strips;

• red – to obtain statistic on mosaic edges;

• yellow – to obtain statistic inside of separate images.

The program provides possibility to edit grid of fragments as vector objects on the
Miscellaneous layer (see the ’Vectorization’ User Manual).

Fig. 28. Preliminary estimation of local brightness adjustment

To set the parameters local brightness adjustment you should perform the following:

1. Choose the Mosaic › Parameters. The Mosaic parameters window opens.

2. Click the Brightness adjustment tab. In the Local adjustment section set theOn
checkbox and then click theParameters button. The Local adjustment parameters
window opens.
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Fig. 29. Local brightness adjustment parameters

3. Define images Number of fragments used to create a model of local brightness
adjustment.

In case of color difference inside one fragment in nearby images inconspicuous or homo-
geneous along the cutline, only one fragment is enough to collect statistics.

In case of color difference inside one fragment between images remarkable or heterogen-
eous, it is necessary to increase number of fragments to consider brightness change.

In case of increasing number of fragments, number of pixels in each fragment hold constant.
In this case image from one layer of pyramid is used for brightness adjustment. In case of
increasing number of fragments, brightness adjustment perform more precise, but slower.

4. Set the Inner points – number of points inside image and on mosaic edges, where
brightness should not be changed.

Insufficient quantity of these points leads to creation brightness artefacts while distance
from cutlines. Quantity over leads to unacceptable results of local brightness adjustment
along cutlines.

5. [optional] If errors in contrast of source images leads to not enough adjustments
quality or to errors in local brightness adjustment, increase theContrast coefficient
value from 2 to 7 for better results.

6. Set the Density coefficient to define part of using ties on edges of mosaic.

Insufficient quantity of these points leads to creation brightness artefacts while distance
from cutlines. Quantity over leads to unacceptable results of local brightness adjustment
along cutlines.
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7. [optional] In case if not enough statistic data for local brightness adjustment, program
provides possibility shift of fragment’s grid relative to cutlines. For this set on the
Search additional fragments with 50% overlapping checkbox.

8. [for scanner images with small overlaps] In case of small overlaps, cutline could be
located too close to edge of image, so image background is include to cutline area.
In this case set the Minimal valid part in fragment – minimal part of image in
fragment, when statistics data is collected.

9. Click OK.

Fig. 30. Area without local adjustment
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Fig. 31. Area with local adjustment

9.3. Dodging

Dodging – means brightness adjustment of the single image.

To employ this function you should perform the following:

1. Select Images › Project images list... or click button. The Image List window
opens.

2. Select the image you need to transform in Image List window and click the
button. The Radiometric correction window opens.

3. Click the button in Radiometric correction window. The Filters menu opens.
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Fig. 32. The filters menu

4. Choose the Dodging filter, set aperture size and filtering level. Click OK.

Recommended filtering level – 100%.

10. GC/tie points

10.1. GC/Tie points menu

TheGC/tie pointsmenu items, that are partially duplicated by theGC/tie points toolbar
buttons, are used to measure ground control/tie points.

Table 10. Brief description of the GC/Tie points menu

FunctionMenu items
allows to delete all tie/gc points from Ground control and tie points layerClear
allows to open tie/gc points previously saved in vector file with x-data
extension in active profile resources

Open

allows to save tie/gc points to vector file in active profile resources with
the same name and x-data extension

Save

allows to save tie/gc points to vector file in active profile resources with
different name and x-data extension

Save as

opens sub-menu for measurement of GCP in manual, semi-automatic
and automatic modes

Add ground control points

opens sub-menu for measurement of tie points in manual, semi-automatic
and automatic modes

Add tie points

allows to edit a measurement of selected tie/gc pointRemeasure
opens 2D-windows with initial images, which contain marker positionShowwindows bymarker
opens 2D-windows with initial images, which contain selected tie pointShowwindowsby current

point
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FunctionMenu items
used to close the 2D-windows with the source images and return to the
Previewwindow for viewing the results of cutlines stitching by measured
points

Finish measurement

used to display residuals reveals ’bad’ points, having error vectors notice-
ably different from other points in size and direction

Show residuals

used to remove blunders of tie/gc points automatic measurement: allows
to reject those points, which measurement value results in shift of images
relatively each other at distance more than specified (in meters)

Delete by maximal resid-
ual

allows to setup correlator parameters used for tie/gc points measurement
in semi-automatic or automatic mode

Parameters

shows brief information about selected tie/gc pointInformation about a point

10.2. Brief description of the GC/Tie points toolbar buttons
Table 11. Brief description of the GC/Tie points toolbar buttons

FunctionButtons
allows to measure ground control point in manual mode without correlator
allows to measure ground point in semi-automatic mode using correlator
allows to run automatic search and measurement of GCP on the whole images
block using correlator
allows to measure tie point in manual mode without correlator
allows to measure ground point in semi-automatic mode using correlator
allows to start operation of tie points automatic search and measurement for the
entire images block using correlator
allows to edit a measurement of selected tie/gc point
used to display residuals reveals ’bad’ points, having error vectors noticeably differ-
ent from other points in size and direction
allows to setup correlator parameters used for tie/gc points measurement in semi-
automatic or automatic mode
opens 2D-windows with initial images, which contain marker position
opens 2D-windows with initial images, which contain selected tie point
allows to remove selected tie/ground control points
used to remove blunders of tie/gc points automatic measurement: allows to reject
those points, which measurement value results in shift of images relatively each
other at distance more than specified (in meters)
allows to remove all tie and ground control points
allows to remove only ground control points
allows to remove only tie points
used to close the 2D-windows with the source images and return to the Preview
window for viewing the results of cutlines stitching by measured points
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10.3. General information

The program provides an option of tie points measurement for more precise correspond-
ence of cutlines area. Adjustment of the project source images is the result of tie points
measurement and transforming source images close to cutline.

Measuring ties points consists in defining correspondence between projections of the
same terrain point on two or more source images of the mosaic project in the vicinity
of cutlines.

Also, the program provides the option of using reference image for measuring GCPs
on the source images.

The reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project. I.e the reference image is used
as standard for measuring GCPs, from which is defined the correspondence between
the source images. The coordinates of terrain point on the reference image is assigned
the same terrain point on the source images.

The Tie points vector layer with the attributes for data storing about measured points
is provided for storing the GCPs or tie points.

The program provides three modes of tie/GCPs measurement:

• Manual mode measurement of points without correlator;

• Semi-automatic mode measurement of points using correlator;

• Automatic mode measurement of points using correlator.

It is not recommended to measure the tie points far away from the cutlines to avoid the rough
transformation of images. Also, it is not recommended measuring points on the extended
objects (for example, on the roads), buildings and low-contrast areas.

The correlator parameters are used for measurement ground control/tie points with
correlator in semi-automatic or automatic mode. TheGC/tie points › Parametersmenu
item us used to view and edit correlator parameters values (see Section 10.6).

In order to obtain the information about tie/ground control point, select the point on ed-
itable layer Ground control and tie points and choose the GC/Tie points › Point info.
In the opened Statistic information window you can see the following data:

• point’s name (with tie prefix for tie point, and GCP for GCP);

• number of images where the point is measured;

• path to file of each image where the point is measured.
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Fig. 33. Information about a point

10.4. Measurement of GCPs

10.4.1. Adding reference image

In case there is an image (reference image) with more accurate georeferencing covering
the same area as source images, this reference image can be used for measuring of
ground control points on the source images.

For GCPmeasurement it is necessary define in advance a type of transformation which
will be applied automatically on edges of images block while GCP measurements are
accumulating. Perform the following actions to do this:

1. Choose the Mosaic › Parameters. The Mosaic parameters window opens.

2. Choose theMosaic tab. Set on the Using of ground control points checkbox on
the Ties GCPs tab.

3. In the Images edges section select: No changing, 2D-Shift, Projective.

4. [optional] Set on the Affected area checkbox to limit influence of ground control
point to adjustment and specify the value in meters.

If the Affected area checkbox is set of, maximal distance of ground control point influence
is image border.

To use georeferenced image perform the following actions:

1. Load georeferenced image into the project by one of the following ways:

• to load image located out of profile resources system, choose Service › Load
georeferenced images (files) or click the button on the main toolbar;

If there is a file of the *.rmc format in the same folder, the correction parameters are
downloaded for the selected image.

• to load image located in active profile resources, choose Service › Load geore-
ferenced images (resource).

If there is a file of the *.rmcformat nearby the image file, the correction parameters are
downloaded for the selected image.
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Define a georeferenced image and click OK. The Load georeferenced image
window opens.

2. [optional] Set theConvert coordinate system checkbox on, if the coordinate system
of project is differ from coordinate system of project. Define the source coordinate
system of image and output coordinate system in corresponding fields.

3. [optional] Set on the Transparent background to specify the background color of
source image.

4. Click OK. Image loaded to the mosaic project and in the Manager the new layer is
shown.

10.4.2. Addition ground control points in manual and semi-automatic
modes

Perform the follows for defining correspondence between the source images by control
point on reference image in manual or semi-automatic mode:

1. Load reference image in the project.

2. Hide the layer with reference image in the Layer manager.

3. Make active the Ground control and tie points layer.

4. To add new ground control point perform the following:

1. In the 2D-window with the source images insert the marker in the place of
adding point on the one of the images in the vicinity of cutline.

2. Choose the GC/Tie points › Show windows by current point or click the
button on the GC/Tie points toolbar;

3. Perform one of the following actions to add point:

• choose theGC/Tie points| Ground control points › Addwithout correlation
or click the button of the GC/Tie points toolbar to add point manually;

• choose the GC/Tie points| Ground control points › Add with correlation
or click the button of the GC/Tie points toolbar to add point in semi-
automatic mode.

4. Turn on visibility of the layer with reference image.

TheGround control and tie points layer should be upper than layer with georeferenced
image in the Manager to display added point.
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5. Specify the point placement on the reference image corresponding selected
terrain point on the source images. For this move the point use the mouse and
pressed Ctrl key.

6. Press Enter to confirm measurement.

7. Hide the layer with reference image in the Layer manager.

5. Repeat the 4’s step to measure point on the neighbour image. Hence a tie point
creates on the source image with coordinates taken from the reference image. The
source images in the Previewwindow are refreshed taking into account the stitching
by added point.

10.4.3. Automatic searching of corresponding points

The program provides opportunity of search and add Ground Control points on the
reference and source mosaic project images in the automatic mode.

For automatic searching of corresponding points on the reference image and source
images of mosaic project perform the following actions:

1. Load reference image in the project.

2. Choose Service › Grid › Create to create grid for the search of ground control
points area.

3. Create a work area of the grid (see the ’Creation of DTM’ User Manual).

4. Make active the layer with reference image.

5. Choose the GC/Tie points| Ground control points › Add automatically or click
the button on theGC/Tie points toolbar; The Pointsmeasurement parameters
window opens.

If the grid has not been previously created, it is requested to do it.
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Fig. 34. Points measure parameters window

6. Set the correlator parameters.

7. Click OK to start searching process.

10.5. Tie points measurement

10.5.1. Manual mode measurement of tie points

Perform the following actions for measuring tie point in manual mode without correlator:

1. Create cutlines.

A pre-requisite for measurement of tie points is the presence of cutlines created.

2. Select the point in the vicinity of cutlines in the Preview window set the marker in
this place to add the tie point.

3. Choose the GC/Tie points › Tie points › Add without correlation or click the
button on the GC/Tie points toolbar; The 2D-windows with source images are
opened. New tie point is added in the specified place.
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4. Choose theGC/Tie points › Remeasure or click the button on theGC/Tie points
toolbar.

After the addition of at least one tie point the Using of tie points mode is set on auto-
matically.

5. For measuring the next point: select the another terrain point on the images in the
each of the 2D-windows and click the button on the GC/Tie points toolbar. A
new point is added as a result.

6. To complete of measuring tie points in 2D-windows and displaying of the stitching
results in the Preview window, choose the GC/Tie points › Finish measurement
or click the button on theGC/Tie points toolbar. The areas stitching is performed
in the middle of the interval between points in the 2D-windows.

10.5.2. Semi-automatic mode measurement of tie points

The semi-automatic mode implies the automatic computing of tie points using correlator
in the marker placement.

It is recommended to set the Correlator parameters before the start working.

Perform the following actions for measuring of tie points in semi-automatic mode:

1. Create cutlines.

A pre-requisite for measurement of tie points is the presence of cutlines created.

2. Select the terrain point in the vicinity of cutlines in the Previewwindow for adjustment
of stitching areas and set the marker in this place.

3. Add tie point in the manual mode.

4. Choose the GC/Tie points › Tie points › Add with correlation or click the
button on the GC/Tie points toolbar;

Tie point may be measured by correlation in one of the following ways:

• In case of successful correlation the tie point is added on the Ground control and
tie points layer. The images of the Preview window are refreshed taking into
account coinciding cutlines areas by the specified tie point.

Correlation coefficient value is specified as an attribute of point.
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• Select the another terrains point closer to the cutlines and repeat the 1st and 2nd
steps. The message about the point is far away from the cutlines is displayed.

• Change the corresponding correlation parameters, if the message about the low
correlation coefficient and/or about high autocorrelator coefficient is shown (see
Section 10.6) or select more contrast point on terrain and repeat the 1st and 2nd
steps.

After the addition of at least one tie point the Using of tie points mode is set on auto-
matically.

5. [optional] Repeat the 1-2 steps for measuring new tie point or edit the point (see
Section 10.7).

6. Choose the GC/Tie points › Finish measurement or click the button on the
GC/Tie points toolbar; The areas stitching is performed in the middle of the interval
between points in the 2D-windows.

Fig. 35. Coinciding source areas of cutlines
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Fig. 36. Stitching areas from two tie points

10.5.3. Automatic mode measurement of points

The automatic mode implies the automatic searching of tie points using correlator on
all block images of project in the vicinity of cutlines.

Perform the following actions for measuring of tie points in automatic mode:

1. Create cutlines.

A pre-requisite for measurement of tie points is the presence of cutlines created in the
Cutlines layer. Otherwise, the message about that cutlines must be created is shown. And
measuring of tie points is not possible.

2. Choose theGC/Tie points| Add tie points › Add automatically for start automatic
measuring of tie points or click the button on the GC/Tie points toolbar; Points
measure parameters window opens.
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Fig. 37. Points measure parameters window

3. Set the correlator parameters.

4. Click OK to start searching process.

After points measurements the Using of tie points mode is set on automatically.

Perform the following actions for measuring points in the vicinity of cutlines in the
distributed processing mode:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The Ties points distributed pro-
cessing windows opens.
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Fig. 38. Parameters of distributed processing for measuring tie points

The Number of images in project displays number of created cutlines in the
mosaic project.

3. Set the maximum number of simultaneous tasks.

4. Define the temporary folder in the active profile resources for distributed pro-
cessing.

5. Define the output file name and path.

6. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

5. Estimate the stitching quality of cutlines in the result of the automatic measuring of
tie points in the Preview window. If necessary, edit the measurement of added tie
points (see Section 10.7).

10.6. Parameters of points measurements

For measuring of tie/ground control points in semi-automatic and automatic mode you
can use and adjust the following correlator parameters.

For automatic mode you can use parameters for automatic points search in vicinity of
cutlines.

Perform one of the following to setup parameters of points measurements:

• Choose theGC/Tie points › Remeasure or click the button on theGC/Tie points
toolbar.

• Choose the GC/Tie points| Add ground control points › Add automatically or
click the button on the GC/Tie points toolbar.
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• Choose the GC/Tie points| Add tie points › Add automatically for start automatic
measuring of tie points or click the button on the GC/Tie points toolbar.

Fig. 39. Points measure parameters

The Correlation parameters section allows to specify the following parameters of
points measure:

• Fragment size – allows to define a size (in pixels) of a fragment which contains the
point indicated on one image in vicinity of cutline;

• Search area – allows to define a search area (in meters) of appropriate point on an-
other image;

• Correlation pixel size – allows to define a value of a pixel size of images, where
correlation to be performed, if the images have different pixel size;

• Max. auto-correlation – allows to control auto-correlation of a point, i. e. a degree
of point’s uniqueness in some its vicinity on the left image;

The more the auto-correlation radius value, the less the point’s uniqueness and the more
probable its incorrect comparison with the right image even when the correlation coefficient
is high.

• Min. correlation – allows to define minimal acceptable value of correlation coefficient;
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• Min. fragment RMS – allows to define a brightness value of image fragment. The
less the value, the worse the correlation.

The Automatic search parameters section allows to set up the following parameters:

• Distance between points – allows to define a distance between points searching
along the cutline in the automatic mode;

• Random shift from cutline – allows to define acceptable deviation from cutline when
searching a point in automatic mode;

• Delete all points with same type before searching – allows to clear the Ground
control and tie points layer from GCP or tie points before start a search of points;

• Search along selected cutlines – allows to search points only along selected cutlines.
Set the checkbox off to search along all cutlines;

• Skip from found point – allows to skip set quantity of points from measured point.

10.7. Editing measurements of points

Perform the following actions for editing measurements of point:

1. Make editable the Ground control and tie points layer in the Layer manager.

2. Select a point in the Preview window by mouse clicking.

3. Choose theGC/Tie points › Showwindows by current point or click the button
on theGC/Tie points toolbar; They are showing the selected point. The 2D-windows
with source images are opened.

4. Insert the marker in another terrains point on the source images in each of the 2D-
windows.

5. Choose theGC/Tie points › Remeasure or click the button on theGC/Tie points
toolbar; The tie point will move in new placement and show in the Preview window.

If not all images with marker position are opened, when clicking the button, other windows
are opened automatically. To change point’s position click the button once more.

The visual non-conformities of tie points are displayed in the 2D-windows on the source
images, because the points are displayed by the data of georeference.

Perform the following actions to delete point:

• the GC/Tie points › Ground control points › Delete menu item and the button
of the GC/Tie points toolbar for deleting all ground control points;
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• the GC/Tie points › Tie points › Delete menu item and the button of the GC/Tie
points toolbar for deleting all tie points;

• the GC/Tie points › Clearmenu item and the button of the GC/Tie points toolbar
for deleting all measuring points on the Ground control and tie points layer;

• the Del key to remove the selected in the Preview window point;

• the GC/Tie points| Delete by maximal residualmenu item and the button of the
GC/Tie points toolbar for rejection the points, the measurement of which causes the
noticeable shift of images relative to each other.

The Objects attributes window is used for viewing and editing tie points data from at-
tributes (see Section 10.8).

To view residuals vector of tie point’s position perform the following:

1. Choose the GC/Tie points| Show residuals or click the button on the GC/Tie
points toolbar;

2. Define the Scale to show vectors and click OK. Residuals are load to the Miscel-
laneous layer.

3. To display residuals vector perform one of the following:

• select the tie point on image; chooseGC/Tie points › Showwindows by current
point or click the button on the GC/Tie points toolbar;

• insert the market near to point; choose the GC/Tie points › Show windows by
marker or click the button on the GC/Tie points toolbar.

The 2D-windows of images with selected point are opens.

4. Analysis of error vectors reveals. ’Bad’ points have error vectors noticeably different
from other points in size and direction.

5. Move error point by vector direction to eliminate detected measurement errors and
choose GC/Tie points › Remeasure or click the button on the GC/Tie points
toolbar; Tie points moves to the new position.

6. Repeat the 1st step to view edited residuals vectors.

10.8. Attributes of Ground control and tie points layer

After tie/gc point measuring the information about measured point is saved to attributes
of the Ground control and tie points layer.

To view point’s attributes data perform the following actions:
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1. Make the Ground control and tie points layer editable.

2. Select a point in the Preview window by mouse clicking.

3. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window is open.

Fig. 40. Point’s attributes data

Point’s attributes contain the following data:

• tie_type – contains information about type of point (with 0 value for tie point, and
1 for GCP);

• points_name – contains a name of point (with tie prefix for tie point, and GCP for
GCP);

• image_count – shows a number of images where the point is measured;

• image_name_image_number – contains a path to one of the image files where
the point is measured;

• image_x_image_number – contains X-coordinate of the point on one of the im-
ages;

• image_y_ image_number – contains Y-coordinate of the point on one of the im-
ages;

• [for points found with correlator] corr_coeff – correlation coefficient of point.
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11. Splitting into sheets

11.1. Sheets menu

The Sheetsmenu is used for splitting mosaic into sheets for saving their in the separate
files of selected output format. The sheets boundaries are the vector polygons in the
Sheets layer.

Items of the Sheetsmenu items are partly duplicate by buttons of the additional Sheets
toolbar.

Table 12. Brief description of Sheets menu and toolbar

FunctionMenu items
allows to delete the created sheets boundaries, i.e
delete all vector objects from the Sheets layer
without closing of this layer

Clear

allows to open sheets boundaries, which were been
saved in the vector file with the x-data extension in
the resources of active profile

Open

allows to save the sheets boundaries in the x-data
file in the resources of active profile

Save

allows to save the sheets boundaries in new file with
the x-data extension in the resources of active
profile

Save as

allows to define the sequential splitting parameters
of block images area and start the process of sheets
boundaries creation by the specified parameters

Sequential splitting

allows to create the single sheet covering all block
images

Full mosaic sheet

allows to create the sheets from each image of blockSplit into sheets by images
allows to create the single sheet with arbitrary
boundaries from any part of block images

Single sheet creation mode

allows to create sheet with set size relative to
marker position

Create sheet around marker

allows to create sheets with set size relative to the
each point object position

Create sheets around point objects

allows to display table with information of project
sheets

Project sheets list

allows to create notations sheets of specified scaleCreate standard orthomap sheet frames
allows to create sheets of several orthomaps, cre-
ated in local coordinate system, grouped by cutlines
and limited by notation frame

Create custom orthomap sheet frames

allows to make all sheets active (include to the pro-
cess of mosaic creation)

Activate all sheets

allows to make all sheets inactive (exclude from the
process of mosaic creation)

Deactivate all sheets
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FunctionMenu items
allows to activate selected sheets for creating mo-
saic

Activate selected sheets

allows to exclude selected sheets from the mosaic
creation

Deactivate selected sheets

allows to select only sheets containing at least part
of block image for creation of output mosaic files

Set sheets status by rasters

(input background color on the images edges is
taken into consideration), i.e the value of status at-
tribute will be equal to ’1’ (active status) for bound-
aries of non-empty sheets
allows to select only sheets containing at least part
of block image for creation of output mosaic files

Set sheets status by useful areas

(input background color on the images edges is
taken into consideration), i.e the value of status at-
tribute will be equal to ’1’ (active status) for bound-
aries of non-empty sheets
allows to invert the status of all created sheetsInvert sheets status
allows to select on block scheme all active sheetsSelect active sheets
allows to select on block scheme all inactive sheetsSelect non active sheets
allows to choose sheets activation modeSheets activation mode
allows to define the output parameters for creation
of output mosaic

Parameters

allows to obtain and modify information about selec-
ted sheet

Sheet info

11.2. Requirements of cutting into sheets

The program allows cutting the output mosaic into sheets for saving them in the separate
files.

At least one active sheet for all or selected area is required to start mosaic creation.

To display sheets borders is used the Sheets layer, which contains attributes of sheet
name and activity status. The program provides different ways of splitting mosaic areas
into sheets, selecting active sheets for creating output files and setting up output para-
meters.

Throughout this User Manual, the Active sheet is referred to as sheet, from which the
output mosaic file will be created. The Inactive sheet is referred to as sheet, excluded
from the output mosaic.

It is recommended to pass the following number of actions during the mosaic sheets
creation:
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1. Definition of the mosaic output coordinate system (see description of the Output
coordinate system panel in Section 13.2.2).

2. Splitting block images into sheets, i.e creating sheets boundaries (the vector objects
with the attributes for storing information about sheets in the Sheets layer).

3. Editing attribute values and sheets boundaries.

4. Managing sheets status.

5. Setting output parameters of sheets.

6. Creating output sheets of mosaic (see Section 13.3).

11.3. Splitting into sheets by the specified parameters

Perform the following actions for splitting block images into sheets by specified para-
meters:

1. Choose the Sheets › Sequential splitting or click the button in the Sheets
toolbar. The Sheets splitting parameters window opens.

Fig. 41. Parameters of sequential splitting

2. Define the following parameters of splitting:

• Block extents – allows to specify the area boundaries (in meters) for splitting;
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• Overlap – allows to define the overlap size (in meters) by width and/or height;

By default the sheets are created without overlap (dock).

• Sheets base name – allows to define the sheets name prefix (by default – Sheet
);

It contains the serial number of sheets row (upward) and serial number of the sheet in
a row (left to right). The rest of the sheet name is generated by program automatically.

By default, if sequential splitting is used, the sheet numbering starts from the lower-left
corner. To set the sheet numbering from the upper-left corner, set the Number from
the top left corner checkbox.

• Sheet size – allows to specify sheet size (in meters) by width and/or height;

The modifying sheet size leads to recalculation of sheets number in the specified splitting
area.

• Number of sheets – allows to specify the number of sheets by width and/or
height;

The splitting begins from the bottom left corner of the specified splitting area in accord-
ance with specified number of sheets and sheet size. Thus, sheet size not recalculated
when the modifying number of sheets.

• Attribute with sheet names – allows to define the name of attribute for storing
the sheet names;

• Sheets creation attribute – allows to define the attribute name for storing inform-
ation about sheet status. By default the create is proposed.

3. Click OK. The process of sheets creation starts. The sheets boundaries are created
in the Sheets layer and displayed in the Preview window.

All sheets, falling within block images, are active.

Active sheet is shown by green outline and has not color filling. Inactive sheet is
shown by red outline and red transparent filling, by default.

The GeoMosaic | Preview tab of the Settings window is used to select color and set up
transparency options for inactive sheets (see Section 15.2).
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Fig. 42. Sequential splitting

11.4. Sheets creation modes

The program provides the following opportunities for sheets creation:

• full mosaic sheet from all images – allows to create one sheet including all block im-
ages;

• one sheet with arbitrary boundaries – allows to create one sheet with arbitrary
boundaries from the any part of block images;

• splitting into sheets by images – allows to create separate sheet from each image of
mosaic project;

• creating sheet around marker – allows to create one sheet in the marker region.

• creating sheets around point objects – allows to create sheets with set size relative
to the each point object position.

Choose the Sheets › Full mosaic sheet or click the button in the Sheets toolbar.

Perform the following actions for creating the single sheet:

80

Orthophotomaps creationPHOTOMOD 6.4



1. Choose the Sheets › single sheet creation mode or click the button in the
Sheets toolbar.

2. Stretch the rectangle in the Preview window along with pressed Shift key.

Choose the Sheets › Split into sheets by images or click the button in the Sheets
toolbar. The sheet boundaries are created for each image.

Perform the following actions for creating sheet around marker:

1. Set the market in area where mosaic sheet will be created.

2. Choose the Sheets › Create sheet aroundmarker. The Sheet creation paramet-
ers window opens.

Fig. 43. Sheet creation parameters

3. [optional] Set manually the Center coordinates by X and Y, with respect to which
the sheets boundaries will be calculated.

4. Set the distance from sheet center (marker position) to its border in the Offset to
north, south, west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. [optional] By default, each new sheet is named as sheet. Specify the Sheet name
to identify sheets, if they are created in the same layer.
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7. Click OK to create the mosaic sheet.

Perform the following actions for creating sheets around point objects:

1. Load or create non-Geomosaic vector layer, containing point objects.

2. Choose the Sheets › Create sheets around point objects. The Sheet creation
parameters window opens.

Fig. 44. Sheet creation parameters

3. [optional] In the Center coordinates section set the offset (by X and Y) between
point objects and sheets centers.

4. Set the distance from sheets centers to its borders in the Offset to north, south,
west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. [optional] By default, each new sheet is named as sheet. Specify the Sheet name
to identify sheets, if they are created in the same layer.

7. Click OK to create the mosaic sheets.

11.5. Project sheets list

The program provides possibility to view project sheets list and to edit sheets.
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To display the sheets list choose the Sheets › Project sheets list or click the button
on the main or Sheets toolbar.

To sort the table contents by the values of selected column, click on the column name.

Fig. 45. Project sheets list

The table with information about all project sheets is displayed in the Sheets listwindow.
The table contains the following columns:

• N – serial number of record;

• Sheet – the sheet name;

• Create – sheets active status;

• Width/Height – linear size of sheet (in pixels);

• Mosaic size – estimated size of output sheet in megabytes.

Double click on row in table allows to edit information about selected sheet. It allows to change
sheet name or active status.

Table 13. The toolbox of ’Sheets list’ window

FunctionButtons
is used to search for an image by name (part of
name) in the list
allows to select all sheets in the list
allows to deselect all sheets in the list
allows to invert selection of sheets in the table
allows to remove selected sheets
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FunctionButtons
allows to edit information about selected sheet –
name and active status
allows to make selected sheet active
allows to make selected sheet non active
allows to open the Preview window for current sheet
allows to save the list with names of selected sheets
in text file

11.6. Generators of splitting into sheets

11.6.1. Standard orthomap sheet frames generator

The program provides possibility to split orthomap for notation sheets of chosen scale,
which consist of vector polygons.

Generators of splitting into sheets are used to:

• to split orthomaps into sheets by images;

• for further use in the GeoMosaicprogram.

Only the Russian coordinate system can be used as the geographic coordinate system (eg.
SK-42 or SK-95).

Perform the following to split survey area to notation sheets of chosen scale:

1. Choose Sheets › Create standard orthomap sheet frames. The Generate
standard sheets window opens.
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Fig. 46. Standard orthomap sheet frames generator parameters

2. In theGeographic coordinate system section choose the input coordinate system,
which is used to specify splitting into sheets by latitude and longitude.

Only the Russian coordinate system can be used as the geographic coordinate system
(eg. SK-42 or SK-95).

3. In the Destination coordinate system section choose the coordinate system to
recalculate coordinate system of sheets during splitting into sheets.

4. [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input co-
ordinates of corners in the North,West, East, South fields.

5. Choose the scale of orthomap in the Scale section.

6. [optional] In case when 1:5 000 or 1:2 000 scale is chosen, set on the Create
outscribed rectangles for sheet checkbox.

7. In the Parameters section define the following settings:

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. [optional] To clarify map position, located in south hemisphere, set on the Add
’(S)’ to sheet name checkbox.
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3. [optional] Set on the Zero-pad the 1:100 000 number checkbox in order to
notation of 1:100 000 scale sheets was wrote correctly.

4. [optional] It is possible to choose one of theQuarters notation in the appropriate
section.

8. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

9. [optional] Change the attribute names or values if necessary and click OK.

11.6.2. Custom orthomap sheet frames generator

Program provides possibility creating sheets from several orthomaps, merged by cutlines
and created in local coordinate system.

Perform the following to split orthomaps by notation sheets in local coordinate system:

1. ChooseSheets › Create customorthomap sheet frames. TheGenerate arbitrary
sheets window opens.
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Fig. 47. Custom orthomap sheet frames generator parameters

2. [optional] To load parameters from file click the button.

3. In theGeographic coordinate system section choose the input coordinate system,
which is used to specify splitting into sheets by latitude and longitude.

4. In the Destination coordinate system section choose the coordinate system to
recalculate coordinate system of sheets during splitting into sheets.

5. [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input co-
ordinates of corners in the North,West, East, South fields.
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6. [optional] Choose the Primary scale only to use one base sheet.

7. In the Parameters section specify the following parameters of primary scale sheet:

In case of using the custom orthomap sheet frames generator it is possible up to 5 levels
splitting orthomaps in to sheets: primary and 4 additional scales. Each next level is created
by splitting the previous level.

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. In the Primary sheet dimension field specify the primary scale sheet size.

3. In the Lower-left corner of the origin sheet input coordinates of the origin
sheet.

Choose the reference point lower and left from work area. The coordinates of origins
of the others sheets are calculated based on this information.

4. In the Origin sheet number input a number of sheet that starts numeration.

5. In the Sheet name template: $(0x)-$(0y)-$(1)-$(2)-$(3)-$(4), where

• $(0x) – number by X on primary scale;

• $(0y) – number by Y on primary scale;

• $(1), $(2), $(3), $(4) – number on the first and next levels in case if the
Separate numeration for rows and columns checkbox is set off;

• $(1x) – number by X in case if the Separate numeration for rows and
columns checkbox is set on;

• $(1y) – number by Y in case if the Separate numeration for rows and
columns checkbox is set on.

Notation with all types, except using Roman numerals, could be created.

8. [optional] In the Parameters section specify the following parameters of primary
scale sheet:

1. Choose one of the template: Scale 1, Scale 2, Scale 3, Scale 4.

2. Choose the Origin of the additional level from the list. By default the top-left
corner is set as origin.
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3. Input number of Rows and Columns.

4. Input arbitrary symbol (letter or number) as a start sheet number in the Starting
with fields.

All changes of parameters are shown in the Sample table.

9. [optional] To save parameters click the button. To reset parameters to default
click the button.

10. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

11. [optional] Change the attribute names or values if necessary and click OK.

11.7. Sheets status management

Each sheet has name and active status, specified in the Sheets layer.

In the Sheetsmenu and in the Sheets toolbar the following facilities provided to change
sheets status:

• to make all sheets active choose the Sheets › Activate all sheets or click the
button;

• to make all sheets non-active choose the Sheets › Deactivate all sheets or click the
button;

• to make selected sheets active choose the Sheets › Activate selected sheets or
click the button;

• to make selected sheets non-active choose the Sheets › Deactivate selected sheets
or click the button;

• to invert sheets status choose the Sheets › Invert sheets status or click the
button;

• to make sheets, which fall into images entirely including their background, active and
to simultaneously make the rest of sheets non-active, choose the Sheets › Set sheets
status by rasters or click the button;

• to make sheets, which fall into images without their background, active and to simul-
taneously make the rest of sheets non active, choose the Sheets › Set sheets status
by useful areas or click the button.
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In order to use provided modes of sheets activation you should activate the Sheets
layer and choose in the Sheets › Sheets activation mode menu one of three modes:

• Select for activation – by default, this mode assumes standard selection of sheets
and further assigning them ’active’ or ’non-active’ status. In order to select sheets
drag a rectangle along with pressed Shift key, and use one of group selection modes
from the Tools toolbar;

• By first sheet – this mode allows to change sheets status without sheets selection.
Drag a rectangle in this mode along with pressed Shift key. The sheets that fall into
the rectangle, obtain the status of the first sheet of the rectangle created;

• Use selection mode – this mode allows to change sheets status without sheets se-
lection too. At that, status of sheets that fall into rectangle created along with pressed
Shift key, depends on a group selection tool selected in the Tools toolbar (see the
’Vectorisation’ User Manual)).

To select sheets use the following modes:

• to select ’active’ sheets choose the Sheets › Select active sheets or click the
button;

• to select ’non-active’ sheets choose the Sheets › Select non-active sheets or click
the button.

11.8. Attributes of sheets

Each sheet is given the name and defined sheet status using the attributes of the Sheets
layer. The capability of presetting provides correct import of sheets, which were created
in third party software, in case when the imported objects have another names of attrib-
utes for storing information about sheet (see the Vectorization User Manual).

By default the Sheets layer contains the following names of attributes:

• create – for storing information about sheet status;

• sheet_name – for storing sheet name.

To change the default attributes of the Sheets layer perform the following:

After changing attributes it is necessary to rebuild existed sheets.

1. Choose the Sheets › Parameters or click the button in the Sheets toolbar. The
Sheets parameters window opens.
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Fig. 48. Setting attributes names

2. Choose the way of creating sheet name in the Sheet names section:

• From attribute – define the new name of attribute for storing sheets name: select
the name from list or specify it using the button;

• Serial numbers – specify prefix of sheets names manually.

3. In the Sheets activity section define the following settings:

• in the Attribute value field specify the value of attribute, chosen in the list,
whereby list is marked as active;

• choose theAttribute name from the list for storing information about sheet status
or specify new name using the button.

4. Click OK. Thus, after the completion of splitting process, the data about the sheet
name and sheet status will be stored in the defined attributes irrespective of splitting
mode.

Perform the following actions for obtaining and editing information about a sheet:

1. Select the sheet boundaries by double click in the Preview window.

2. Choose the Sheets › Sheet info. The Sheet info window opens.
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Fig. 49. Values of cutline attribute

Window contains the following information:

• the Sheet name field corresponds to the sheet_name attribute value;

• the Sheet will be created checkbox corresponds to the sheet status is active.

Perform the following actions to view and edit attributes values of selected sheet:

1. Select the sheet boundaries by double click in the Preview window.

2. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

Fig. 50. Values of sheet attributes

The following buttons are used to create and edit attributes table:

• – allows to delete all attributes of selected objects;

• – allows to delete common attributes of selected objects;

• – allows to open the Add attribute window to define name, type and value
of attribute;

• – allows to delete current field of attribute table;

• – allows to open the Edit attribute window to edit parameters of selected at-
tribute;

• – allows to invert attributes of selected object;

• – allows to sort attributes of selected objects.
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Also the window contains the table with at least two rows:

• create attribute– the ’1’ value corresponds to the active sheet status, the ’2’ value
corresponds to the inactive sheet status;

• sheet_name attribute– contains the name of selected sheet.

The image name in the attribute is generated automatically and depends on the splitting
mode and parameters.

3. Click the string of the Value input field and insert another value for changing of at-
tributes value.

4. Press Enter to save or press Esc to cancel.

There are also other facilities in the program interface that provide fast managing of
the sheet activity status (see Section 11.7).

11.9. Setting output parameters

The output parameters allow to define the method of output files naming and criteria of
selection sheets for creating output files.

Perform the following actions to set up output parameters:

1. After splitting part of block images into sheets, editing boundaries and sheets attrib-
utes, choose the Sheets › Parameters or click the button on the Sheets toolbar.
The Sheets parameters window opens.

Fig. 51. Sheets parameters
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2. Choose the way of creating sheet name in the Sheet names section:

• From attribute – allows to use the value of selected attribute;

• Serial numbers – allows to use serial numbers and define the file name prefix.

In this case, while creating mosaic, the sheet names are generated as follows: Pre-
fix+Sheet serial number.

3. In the Number of vertices section defines criterion of sheets selection for creating
output files by number of vertices within sheets boundaries.

• Arbitrary – sheets selection by number of vertices within the boundaries of cre-
ated sheets is not performed;

• Value – allows to select sheets by number of vertices and specify the number of
vertices in the input field.

4. In the Sheets activity section perform the selection of sheets for creating output
files by the attribute values:

• define the Attribute value, whereby list is marked as active;

• choose the Attribute name which set the sheets activity.

5. Click OK. Sheets activity changes automatically depending on parameters.

12. Using auxiliary data

12.1. Misc (Miscellaneous) menu

The Misc menu is used to show in the Preview window an auxiliary data that may be
considered during mosaics creation. For auxiliary data (that is vector data) the Misc
layer is provided.

Table 14. Brief description of Misc menu

FunctionMenu items
allows to delete all vector objects created in theMisc
layer

Clear

allows to load data from a file saved in active profile
resources

Open

allows to save theMisc layer data to vector file with
different name and x-data extension in active profile
resources

Save as

allows to show in the Preview window a grid of
fragments for preliminary estimation. The grid of

Local adjustment
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FunctionMenu items
fragments is intended for collecting of statistics data
of local brightness adjustment (see Section 9.2)
allows to show in the Preview window boundaries
of source images with background

Source images outlines

allows to create polygons by images frames with
background

Source images layout

allows to create polygons by images frames without
background

Source images useful areas layout

allows to find areas with full cover of cloudsCloudless coverage/Visible areas map
allows to find errors or cutlines creationCutlines coverage map
allows to select image with selected cutline automat-
ically; it is necessary to display frames of source

Synchronize cutlines selection

images before that with theMisc › Source images
outlines menu item.
allows to open all 2D-windows with marker placeOpen images in marker position
allows to load images metadata to current active
layer

Load metadata to current layer

allows to load coordinates of nadir and central points
to the Miscellaneous layer

Load nadir and central points

allows to convert orthomap metadata, created in
third party software, to the system interior format

Convert metadata from AUX to X-FEAT

allows to save images borders as vector objects in
the orthophotomap; could be used only for othopo-
hoto created by satellite images

Save images borders frommetadata to MIF/MID

12.2. Images layout

The program provides possibility to create polygons by images frames with background
or by images edges without background. Misc › Source images layout and Misc ›
Source images useful areas layout menu item are used for that.

Choose the Misc › Source images layout to create polygons by images frames with
background.

The following attributes are assigned to each created polygon:

• image_name – the name of image which is in the polygon, and the path to the image
file;

• bytes_ps – bytes per sample;

• aver_pix_size – average GSD size;

• img_width – image width;

• img_height – image height.
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Fig. 52. Creation polygons by images frames with background

Perform the following to create polygons by images frames with background:

1. Choose the Source images useful areas layout. The Parameterswindow opens.

Fig. 53. Parameters of creation polygons by images frames without background

2. [optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images.

3. In the Image edges trim specify the offset from images border in pixels.
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4. Specify the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created).

5. In theMinimal components square specify the minimal square of the image, below
which polygon is not created.

6. [optional] To create polygons not exactly by image frame, but by some distance
from it, specify the negative value in the Offset from images edges in pixels to
create polygons inside frame, or positive value to create them outside.

7. Click OK to start polygons by images frames without background creation.

Fig. 54. Creation polygons by images frames without background

12.3. Coverage maps

The program provides possibility to display errors of cutlines creation and to find totally
cloudy areas in images, what resulting to ’gaps’ in mosaic creation. Cutlines and
cloudless coverage maps are used for that. These maps are vector layers with polygons

Perform the following to find totally cloudy areas on images:

1. Choose theMisc › Cloudless coverage/Visible areasmap. TheCutlines creation
parameters window opens. It allows to create outline of image block.
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2. [optional] If there is no data in theClouds/Invisible areas layer, theCutlines creation
parameters window opens. Choose the Build and use in the Clouds/Invisible
areas section and setup the rest parameters if necessary.

3. Click OK. The system displays information window which includes information about
outlines quantity and areas with full cover of clouds. Data is load to the new
Cloudless coverage/Visible areas map layer. The clouds are highlighted by red
color.

Fig. 55. Totally cloud areas

To find errors in cutlines creation, choose the Misc › Cutlines coverage maps. The
system displays information window which includes information about outlines quantity
and errors in cutlines creation. Polygons from images with cutlines and ’gaps’ in cutlines
are added in to the Coverage maps layer.
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Fig. 56. Errors in cutlines creation

13. Mosaic creation

13.1. Mosaic menu
Table 15. Brief description of Mosaic menu

FunctionMenu items
allows to setup parameters of mosaic preview and
creation, as well as brightness adjustment and out-
put data save

Parameters

allows to open Preview window for the entire block
of loaded images considering data processing res-
ults

Preview

allows to open Preview window for the selected
sheet of mosaic

Preview (current sheet)

allows to clear all data about brightness adjustmentClear brightness adjustment
allows to rebuild local adjustment after cutlines
change

Brightness adjustment

allows to use distributed processing to brightness
adjustment

Distributed global brightness adjustment
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FunctionMenu items
is used to start mosaic building and creation of out-
put files for selected active sheets

Build full mosaic

is used for start of mosaic building and creation of
output file for selected sheet

Build current sheet

allows to start mosaic creation for specified active
sheets considering user settings and parameters in
distributed processing mode

Distributed processing

allows to start mosaic creation using distributed
processing with splitting of active sheets

Distributed processing of PHOTOMODMegaTIFF

allows to open any image of acceptable raster
format for preview in the application window

Open image

allows to save mosaic parameters setting for further
use them in other mosaic projects (see a description

Save parameters preferences

of the Use saved mosaic settings option in Sec-
tion 15)

13.2. Setup mosaic parameters

13.2.1. General information

To setup mosaic building parameters, choose theMosaic › Parameters or click the
button on the main toolbar. The Mosaic parameters window opens.

The window contains the following groups of parameters:

• main parameters of mosaic building on the Mosaic tab (see Section 13.2.2);

• parameters of local and global brightness adjustment on theBrightness adjustment
tab (see Section 9.1);

• parameters of output mosaic sheets on the Output tab (see Section 13.2.3);

• additional parameters on the Misc tab (see Section 13.2.5).

To save parameters of mosaic creation (for using in other projects), choose theMosaic ›
Save parameters preferences.

Saved output mosaic settings are load automatically on the program launch. To load
default mosaic settings into the Mosaic parameters window at the program start, set
off the Use saved mosaic settings checkbox on the GeoMosaic tab in the Settings
window (see Section 15).
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Fig. 57. The ’Mosaic parameters’ window

13.2.2. Mosaic’s main parameters

The Mosaic tab of the Mosaic parameters window purposes to setup main options of
mosaic building.
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Fig. 58. The ’Mosaic parameters’ window

The Mosaic tab is used for setting the following parameters of output mosaic:

• Cell size – allows to specify the size of output mosaic cell on the terrain. The cell
size by default is equal to the cell size of the first image of mosaic project;

TheCalculate button allows to set a mosaic size in pixels and recalculate its cell size accord-
ingly.
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The accuracy of this parameter (a number of decimal places) takes precedence over general
system’s settings of numbers of decimal places set in the Settings window (Service › Set-
tings › Modules › Decimal places › Orthorectification/Geomosaic, see the “Setup of
modules start” section of the “General system’s parameters” User Manual).

• Background color – allows to set a color for mosaic background, since output mo-
saic always inscribes into a rectangular raster shape;

The Transparent mosaic background on preview parameter influences on background
color of mosaic in the Preview window (see Section 15.2).

• Resampling method – allows to choose the brightness interpolation mode during
orthomosaic creation: bilinear, cubic or nearest neighbour;

• Shift background color – allows to specify a shift of color on the image if this color
coincides with defined color of mosaic’s background;

• Fill background out of sheet boundaries – allows to specify a type of filling outside
of sheet boundaries in the output mosaic. Otherwise, the images of adjacent sheets
are used for the filling;

• Raster offset of sheet – allows to specify a tolerance distance (in pixels) of raster
extend beyond the sheet borders;

• Geometry correction cell size – allows to setup a fragment size (in pixels) when
creating mosaic using fragments with projective dependence;

The larger the fragment, the faster the mosaic building and the lower the accuracy of output
mosaic. The value of 32 pixels is optimal for ’speed-accuracy’ ratio.

• Output raster channels – opens the window Output image parameters, used for
specifying the following parameters:

By default quantity and structure of channels are defined by first added image.

○ Use radiometric from RMC-files – allows to use data of radiometric correction
from RMC-file, if correction was done preliminary in the Raster Converter module
(see the ’General information’ User Manual);

If the Monochrome output checkbox is set on, this channel could be use as a channel in
output file.

If the checkbox is set on, auto levels or radiometric correction could be applied to selected
images.
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○ Channels list – contains list of source (left) and selected for using in orthorectific-
ation channels (right);

Quantity and structure of channels are forming with buttons of the Channels list section.

○ Data format – allows to choose format of output image: 8 bit or 16 bit;

○ Monochrome output – allows to create output file with one grayscale channel.

In case of monochrome output it is impossible to choose structure of channels.

Fig. 59. Output channels parameters

• Build sheets by images – defines a content of sheets when creating a mosaic that
is split on sheets by images. If the checkbox is set on, each sheet will contain the
only image corresponding to the sheet, i.e. the mosaic will be not created. If the
checkbox is set off, each sheet will contain all images that fall into this sheet;

The option is used to perform only export of initial images into different coordinate system or
export to files of other raster formats.

After splitting of sheets by images, sheets names in attributes of the Sheets layer should be
the same as images names.

If the Build sheets by images checkbox is set on, mosaic is not built.
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• Use images without cutlines – allows to use images without cutlines for preview
and mosaic creation (see also a description of means of images order change when
creating mosaic without cutlines in Section 7.8);

• Use source rasters base layer only – allows to use a base layer of initial images
pyramid if the mosaic is created using docking (not overlapped) images without cre-
ating cutlines. If this checkbox is set off the program uses a pyramid layer correspond-
ing to specified resolution, i. e. the pyramid layer is taken based on the Cell size
parameter value;

• Rotation angle – allows to setup a rotation angle (in degrees) of mosaic’s images;

Is used if a block of initial images has elongated shape and you need to remove unnecessary
background area in rectangular window of created mosaic.

• Source rasters background color range – allows to define a deviation from selected
background color of initial images, i. e. to specify a range of color, existing in initial
images background (see Section 7.5);

• Transparent background inside cutlines – allows to use transparency for areas
with input background color inside cutlines;

To apply this parameter it must be set transparency for background color of original images
(see Section 7.5).

• Align sheets by common grid – allows to define the transformation type witch applies
on edges of images block automatically while data about measurement of GCP ac-
cumulates.

• Align sheets by common grid – allows to set the parameters of pixel-by-pixel
aligning of sheet frames when exporting mosaic’s sheets:

○ If the Align sheets by common grid checkbox is set when exporting mosaic’s
sheets, sheet frames are aligned (shifted) according to pixel mosaic’s grid;

○ If the Align sheets by common grid checkbox is cleared, mosaic sheets are
created independently of each other according to initial vector sheet frames.
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Fig. 60. Aligning the sheets by common grid

Also the Mosaic tab allows to choose Input and Output coordinate system if they
are different to the project’s coordinate system.

13.2.3. Mosaic output parameters

The Output tab of the Mosaic parameters window allows to setup options of mosaic
output.
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Fig. 61. Mosaic output parameters

The Map scale field allows to setup a scale for output mosaic sheet. The Calculate
map scale button to open the window where you can specify a scale and calculate a
map sheet size (in meters) and print resolution.

Output sheets could be created in one or several output formats:

• Create MS TIFF – allows to create output mosaic sheets in MS TIFF format with
pyramid that helps to redraw images more quickly on a screen, when using systems
with MS TIFF format support;

• Create Geo TIFF – allows to create output mosaic sheets in Geo TIFF format with
pyramid;

• Create BigTIFF – allows to create output sheets in the BigTIFF format, if file size is
more than 2 Gb;
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• Create pyramids – allows to create pyramids for output orthoimages in files of internal
format;

• Extended ERDAS Imagine (IMG+IGE) – allows to create output mosaic sheets in
IMG files format for heading and IGM format for image (with no limitations for size);

• Create KML – allows to create additional file in KML format, e.g. to show results in
the Google Earth;

It is necessary to choose global coordinate system as output to create file in KML format.

KML-files are creating both for all block and each image individually.

• Save datum parameters – allows to save seven parameters of coordinate system
to meta data of TIFF-file.

The Output images compression allows to set up the compression parameters of
output mosaic sheets:

• None – files are created without compression;

• JPEGwith quality .. % – TIFF-files are creates with set quality of JPEG-compression;

Default compression level is 75 %, that provides the 5-7 times compression of initial image
volume.

• LZW – TIFF-files are creates with LZW-compression.

Also theOutput tab allows to set the following parameters of saving files during mosaic
creation:

• Georeferenced file – allows to select the format of the additional file created;

• Swap X, Y – allows to swap Х,Y coordinates;

• Create georeference only – allows to create just georeference files of sheets without
building mosaic sheets (i. e. without files creation);

• Set background color as ’transparent’ – allows to set the background color which
is shown in MapInfo system, as transparent when saving the resulting mosaic in
MapInfo format;

• Save georeference as ’NonEarth’ – allows you to save georeference as NonEarth
coordinate system, when saving the resulting mosaic in MapInfo format;
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Used if MapInfo system does not support coordinate system of mosaic project.

• Save metadata – allows to save images metadata in the *.x-feat-file: background
colour, number of channels and its settings.

The Output data button allows to open the Sheets files window to select format and
target folder of output mosaic sheets (see also a list of output formats in Section 2.4).

13.2.4. Using of GC/Tie points parameters

The GC/Tie points tab of the Mosaic parameters window purposes to setup options
of using ground control and tie points for adjustment.

Fig. 62. Using of GC/Tie points parameters

109

Orthophotomaps creationPHOTOMOD 6.4



The Using of ground control points checkbox allows to use ground control points for
more precise correspondence of cutlines area.

TheGCPs section allows to set the following parameters of using ground control points:

• Images edges – allows to choose type of transforming which applies on images
edges:

○ None – allows not to consider images edges;

○ 2D-Shift – edges consider by average plane parallel shift;

○ Projective – to consider edges is used the projective transformation.

• Affected area – allows to define maximal distance of ground control point influence
in meters.

If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

TheUsing of tie points checkbox allows to use tie points for more precise correspond-
ence of cutlines area.

The Tie points section allows to set the following parameters of using tie points:

• Images edges – allows to choose type of transforming which applies on images
edges:

○ None – allows not to consider images edges;

○ 2D-Shift – edges consider by average plane parallel shift;

○ Projective – to consider edges is used the projective transformation.

• Affected area – allows to define maximal distance of tie point influence in meters;

If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

• Filter – allows to filter part of points during geometric model creation.

The Enable flip checkbox allows to invert direction affect of point.

13.2.5. Additional parameters

The Misc tab allows to to setup additional options of creating mosaic.
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Fig. 63. Additional parameters

The Save local adjustment checkbox allows to turn on/off saving of parameters and
settings of local brightness adjustment to file of mosaic project.

The Vector data coordinate system section allows to select input or output coordinate
system of a project for storing of vector data (cutlines, sheets boundaries, tie points
etc.).

It is recommended to select output coordinate system (by default), since it is impossible to re-
calculate coordinate system during sheets creation. Coordinate system of initial images and
output mosaic are specified on the Mosaic tab.
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13.3. Creation of output mosaic sheets

For creation of resulting output product – georeference files and sheets of mosaic (or-
thophotos) in specified coordinate system and scale – perform one of the following ac-
tions:

• to create output orthophoto for current sheet perform the following:

1. On the Sheets layer select a border of a sheet, for which the output file will be
created.

2. Choose theMosaic › Build current sheet. The Save as window is open, where
you can specify name, format and target folder of output file. Default file name
is a name of sheet stored in attributes of the Sheets layer.

• To create output orthophotos for several mosaic sheets perform the following:

1. Define active sheets on the Sheets layer, for which the output files will be created
(see Section 11).

2. Choose theMosaic › Build full mosaic or click the button on the main toolbar.
The Sheets file window opens. Specify format and target folder for output files.

• To create output mosaic in distributed processing mode choose theMosaic › Distrib-
uted processing or theMosaic › Distributed processing of PHOTOMODMegaTIFF
to start mosaic creation using distributed processing with sheets splitting (see the
Section 13.4).

The following files are created with orthophoto:

• mosaic sheets in chosen format;

• reference files;

• the file with *.prj extension, with information about coordinate system in OGCWKT
format.

A file name with *.prj extension corresponds to the project’s name.

The WKT (well known text) format is a common text format of coordinate system description
developed according to ISO standards (International Standardization Organization) and
standards ofOpen Geospatial Consortium, an international organization committed to making
quality open standards for the global geospatial community.
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13.4. Orthoimages creating in distributed processing mode

The system provides possibility of creating orthoimages in distributed processing mode
and also to use distributed processing of MegaTIFF.

To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

2. Choose theMosaic › Distributed processing. TheMosaic distributed processing
window opens.

Fig. 64. Mosaic’s distributed processing parameters

Save the orthorectification project if it was changed.

3. Define Target folder for output orhoimages.

In case of network processing path mast have \\Server\Share\Folder format.

4. The Number of sheets displays in the window. Set the Number of tasks for pro-
cessing based on one kernel for one task.

5. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created orthoimages.

6. Define path for temporary files of distributed processing.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.
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To create orthoimages in distributed processing of MegaTIFFmode, perform the following
actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

2. Choose the Mosaic › Distributed processing of PHOTOMOD MegaTIFF.

Save the mosaic project if it was changed.

The Mosaic distributed processing window opens.

Fig. 65. Mosaic’s distributed processing parameters

The total Number of sheets and Number of MegaTIFF fragments are displays
in the window.

3. Set the Number of tasks for processing based on one core for one task.

4. Define path for temporary files of distributed processing.

5. Define Target folder for output mosaic.

In case of network processing path mast have \\Server\Share\Folder format.

6. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created mosaic sheets.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.
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14. The pan-sharpening operation
The system provides possibility to perform the pan-sharpening operation.

Pan-sharpening is merging of color (multispectal) image with grayscale one with more high
spatial resolution to obtain as a result color image with better resolution.

When synthesizing amultispectral image, the followingmethods can be used to increase spatial
resolution of the output image: Brovey, HSV, Principal Component Analysis and Enhanced
Principal Component Analysis (see below).

The Enhanced Principal Component Analysismethod (selected by default) is recommended
and does not require radiometric correction (see the “Radiometric correction” chapter of the
“General information” User Manual). In this case is strongly recommended to refrain from per-
forming radiometry correction.

For correct multispectral image synthesis using the methods Brovey, HSV and Principal
Component Analysis radiometric correction must be performed. If a radiometric correction
was not performed for the selected image it will be requested to perform it during the pan-
sharpening operation.

As the result of pan-sharpening operation, newmultispectral image is created possessing
the same high spatial resolution as the grayscale image. For pan-sharpening operation
perform the following:

1. Choose the Service › Pan-sharpening.... The Pan-sharpening window opens;
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Fig. 66. Parameters of pan-sharpening

2. Choose Source file with high resolution raster (grayscale);

3. Choose Source file with low resolution raster (color);

4. Choose Output file with high resolution raster (color);

The allowed output file formats are:

• Tag Image File Format (*.tiff) and GeoTIFF – format, included tags for saving of
georeferenced information;

• Windows Bitmap File (*.bmp);

• GIS Panorama raster map (*.rsw) – raster formats of PHOTOMOD VectOr program;
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• ERDAS IMAGINE (*.img) –- ERDAS system raster format;

• NITF (*.nitf);

• JPEG (*.jpeg);

• PNG (*.png);

• DGN (*.dgn) – MicroStation system raster format;;

• PCIDSK (*.pix) – raster format with georeference in the heading developed by PCI
Geomatics company;

• JPEG2000 (*.jp2) raster format with jpeg compression and georeference in the heading
developed. The limitation on output file size of JPEG2000 format – no greater then 500
Мb.

5. The Parameters tab is used for setting the following parameters of output image:

• the Output channels allows to choose quantity of channels in output images:

○ RGB (by default);

○ All – all channels from source image;

○ RGB+Gray – four channels.

• the Pan-sharpening method section allows to choose one of the following
methods of increasing resolution of output image: Brovey, HSV, Principalcom-
ponents and Enhanced Principal Component Analysis.

Depending on the type of images, different methods might be preferable. The default
Enhanced Principal Component Analysis method is recommended as it ensures
minimum distortion of the initial colors. It is recommended to use other methods if the
results are unsatisfactory otherwise.

The HSV and Principal components methods produce similar results, where is no
domination or deficiency of one color. The Brovey produce the same results on images
with average brightness, but different results on dark or glaring images.

It may be difficult to determine beforehand which color correction parameters should be
selected.

• methods of color correction during pan-sharpening:

Color correction is not possible for 4-channel output image RGB+Gray.

○ Interpolate color image (by default) – allows to apply bilinear interpolation of
color in source image.
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Fig. 67. Pan sharpening result using Broveymethod without interpolation of color image (left)
or with interpolation (right). When the interpolation is not used (the option is Interpolate color
image cleared), small squares with pixel size corresponding to initial color raster are clearly

visible on output image, that is undesirable in most cases.

It is recommended to use the option in most cases, except those rare ones when the
interpolation clearly leads to image sharpness deterioration. For some images it would
be enough to apply one of two other methods along with interpolation to obtain an
acceptable result.

Fig. 68. Initial color image (left) and the result of pan sharpening operation by Broveymethod
with color raster interpolation option

○ Spectral color correction – allows to setup and apply parameters of spectral
color correction to eliminate errors of source colors due to pan-sharpening
operation.

Spectral color correction is used only for 3-channel RGB output image.

Spectral color correction is correction color of each pixel so that it becomes close to
color of source image without visible decreasing of output image detalization.

Pan sharpening operation leads unavoidably to some distortion of initial colors.
Sometimes it is insignificant as shown on the figure above, and sometimes it is essen-
tial enough. For instance, the output imagemay acquire gloomy grey tint, or vegetation
may become bright green too much, etc. In order to correct color during pan
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sharpening youmay use an additional options – Spectral color correction orCorrect
colors by area (see below).

To setup color correction parameters by spectrum click the button. The
Parameters window opens to define the following parameters:

Fig. 69. Color correction parameters by spectrum window

■ Automatic correction (by default) is used to automatic analyze and use
spectral characteristics of source image. At that the color correction level
management (using the Level slider) becomes available;

■ Level allows to define part of automatic correction. In the leftmost position
of the slider automatic correction is not performed and in the rightmost
maximal correction is performed (the coarsest detalization with colors nearest
to colors of source image);

It is recommended to use low level for higher detalization (output image could re-
ceive the gray hue). To improve color rendering it is recommended to increase
level.
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Fig. 70. Initial color image (left), pan sharpening operation result by Broveymethod without
color correction (in center), with automatic correction (right)

■ Method allows to choose Standard or Averaging method of correction. Is
used both with automatic correction and without it;

In case of using the Averaging method, each pixel is given a color from linear
combination of pixel color from source multispectral image and corrected color.
This method allows to bring colors to the color image, smoothing the contrast of
black and white image. However, details of output image could have lightly image
blur.

■ TheColor hue section allows to setup intensity of red, green and blue colors.
In the middle position of slider this channel are not corrected. The left position
allows to decrease intensity of color, and the right one allows to increase it.
Color hue correction parameters used both with automatic correction and
without it.

The example of these controls use is brightness decreasing of vegetation green
color (see illustrations below). Each of three sliders influences on color correction
in the area where the value of an appropriate channel prevails. I.e. the Red slider
adjusting results in visualization of red areas on pan-sharpened image, the Blue
slider – for blue areas, the Green one – for green.

Generally it leads to change of color value of selected channel, but it could not be
considered as usual monotonous brightness change. When the parameter value
is less than 0.5 the appropriate brightness it will be decreased, if it is more than
0.5 – it will be increased. If brightness of some color is setup it its average value
(the slider position is in 50%), this color channel will be not corrected.
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Fig. 71. Initial color image (left), pan sharpening operation result by Broveymethod without
color correction (right)

Fig. 72. Result of the same operation when the green color brightness is reduced

○ Correct colors by area – allows to setup and apply parameters of colors cor-
rection by area. As a result for each pixel of color image is performed averaging
out its color by pixel in its vanity considering weight factor.

It is recommended to perform correction colors to obtain images with more homogen-
eity images by color and also in case of visible shift between objects on color and
black-white image. In this case correction colors by area allows to increase sharpness
of objects.

Spectral color correction is used only for 3-channel RGB output image.
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Pay attention when correct colors by area to avoid deterioration of image quality in
non-corrected areas.

To setup color correction parameters by area click the button. The Para-
meters window opens to define the following parameters:

Fig. 73. Color correction parameters by area window

■ The Aperture size allows to define size of area around changing pixel (size
of square in pixel on color image). Color characteristics of pixel’s vanity is
used to correct color of edited central pixel;

For instance, illustration below shows that hatched pixel is surrounded by 3x3
pixels area, which color values will be used for measuring of central pixel color.
So the aperture in this case is 3. Maximal allowed aperture size is 9 pixels.

Fig. 74. Aperture size around pixel with color to be defined

■ RGB threshold – allows not to consider in correction pixels with values in
channels differ from values of changing pixel more than threshold.

Allowable values of intense are from 0 to 255. If the maximal value (255) is set,
correction is performed by whole area. In case of high values of threshold, correction
may cause to halo effect on objects and also could make worse colors of whole
image.
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Fig. 75. Pan sharpening operation result byBroveymethod without color correction
(left) and using neighbor color correction (right)

The option Correct colors by area is off by default. When the thresholds have
big values the aureole around objects may appear when using this option, and
also the color of whole image may worsen. It is recommended to use the Correct
colors by area option very carefully. Along with image improvement in some part
of image, it would result in quality worsening in other parts.

○ Cut off background colors of source images allows not to apply histogram
stretching to background color of source image. The Background color field
allows to define color of background.

• the Trim left and Trim right fields of the Grayscale and Colors section allows
to define size of histogram area on color and b/w images (in percent), that will
not consider in histogram stretch operation.

• the Color depth list is used to choose color depth of output image: 8 bit, 16 bit,
Auto (by default).

• the Areas without color raster section allows to choose one of the following
ways of filling areas without color image:

○ Fill background color to fill areas with background color of source images;

○ Fill grayscale raster to use grayscale image as a base for these areas.

• Value of the Color area outside color raster parameter (in pixels) to perform
color extrapolation on image edges.

• the Measure tie points checkbox allows to use tie points in pan-sharpening in
case of visible shift between objects on color and black-white images.

6. The Output tab is used for setting the following parameters of output image:
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Fig. 76. Output parameters
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• Create MS TIFF – allows to create output mosaic sheets in MS TIFF format with
pyramid that helps to redraw images more quickly on a screen, when using sys-
tems with MS TIFF format support.

• Create GeoTIFF – allows to create output mosaic sheets in GeoTIFF format with
pyramid;

• TheOutput images compression allows to set up the compression parameters
of output orthoimages files:

○ None – files are creates without compression;

○ JPEG with quality .. % – TIFF-files are creates with set quality of JPEG-
compression;

Default compression level is 75 %, that provides the 5-7 times compression of initial
image volume.

○ LZW – TIFF-files are creates with LZW-compression.

• Georeference file – allows to select the format of the additional file created;

○ None – files are creates without compression;

○ PHOTOMOD GEO (*.geo) – PHOTOMOD georeference file, contains pixel
and ground coordinates of 4 mosaic cells as well as cell size by X and Y axes
in given units.

Example of *.geo file:

Mosaic created by PHOTOMOD 10.01.07

Units: (m)

Linscale: 8.600

Colscale: 8.600

(0.5, 0.5) (8271360.000 East, 1857514.200 North)

(0.5, 2446.5) (8271360.000 East, 1836470.000 North)

(2612.5, 0.5) (8293831.800 East, 1857514.200 North)

(2612.5, 2446.5) (8293831.800 East, 1836470.000 North)

Coordinate system: UTM, (North)

○ Arc World (*.tfw extension at export to *.tiff format) – georeference file,
used by Arc INFO.
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Example of *.tfw file:

1.000000

0.000000

0.000000

-1.000000

551286.128054

200588.824470

After mosaic export to other formats georeference files (of text format likewise
*.tfw file) are created with the following extensions: :

■ After export to *.bmp georeference file with *.tfw extension is created;

■ After export to *.jpg georeference file with *.tfw extension is created;

■ After export to *.nitf georeference file with *.tfw extension is created;

■ After export to *.dgn georeference file with *.tfw extension is created;

■ After export to *.png georeference file with *.tfw extension is created.

○ MapInfo TAB (*.tab) – Georeference file, used by MapInfo.

Example of *.tab file:

!table

!version 300

!charset WindowsLatin1

Definition table

File “mosaic.tif”

Type “RASTER”

(143424.937,2635592.133) (0,0) Label “Point 1”,

(224834.937,2635592.133) (1163,0) Label “Point 2”,

(143424.937,2565592.133) (0,1000) Label “Point 3”,

(224834.937,2565592.133) (1163,1000) Label “Point 4”

CoordSys Earth Projection 8, 104, “m”, 33.000000, 0.000000, 0.999600,
500000.000000, 0.000000
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7. The Correlation tab is used to setup correlator parameters for tie points measure-
ment:

Correlation parameters are only available if theMeasure tie points check box is set in the
Parameters tab.

Fig. 77. Correlation tab of the Pan-sharpening window
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• Fragment size – allows to define a size (in pixels) of a fragment which contains
the point indicated on one image;

• Search area – – allows to define a search area (in meters) of appropriate point
on another image;

• Correlation pixel size – allows to define a value of a pixel size of images, where
correlation to be performed, if the images have different pixel size;

• Max. auto correlation – allows to control auto-correlation of a point, i. e. a degree
of point’s uniqueness in some its vicinity on the left image;

The more the auto-correlation radius value, the less the point’s uniqueness and the
more probable its incorrect comparison with the right image even when the correlation
coefficient is high.

• Min. correlate value – allows to define minimal acceptable value of correlation
coefficient;

• Min. fragment RMS – allows to define a brightness value of image fragment.
The less the value, the worse the correlation.

• Number of fragments – number of fragments on one image.

If an image contains objects with big brightness difference (dark lake and light colored
field, for example), it is recommended to set more fragments number.

• Number of points of fragment – number of matching points on one fragment.

• Check residual deviations allows to evaluate the accuracy of overlaying black
and white and color rasters (in pixels). Data is displayed in the information window
which opens once the pan-sharpening operation is completed.

8. Click ОК to start the pan-sharpening operation.

14.1. Batch pan-sharpening

The system allows possibility to perform the pan-sharpening operation with same
parameters for more than 2 images.

To do this it is necessary to prepare a *.txt file with the list of paths to source images:
high resolution, low resolution images and also a path of output file which will be created
as a result of pan-sharpening.

In order to start batch pan-sharpening perform the following actions:

1. Prepare a *.txt or *.csv file with the list of paths to source images.
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2. Choose the Service › Pan-sharpening. The Pan-sharpening window opens.

Fig. 78. Parameters of batch pan-sharpening

3. In the Batch files list section click the button and choose a text file with list of
paths to source images.

Otherwise to form image list click the button. The Pan-sharpening images list
window opens.

Fig. 79. Pan-sharpening images list

Left part of the window is used to form list of high resolution images, right part – to
form list of low resolution images.
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The window contains the toolbar with buttons used to perform the following opera-
tions:

• – allows to choose and add image to the list;

• – allows to remove image from the list;

• – allows to select all images;

• – allows to unselect all images;

• – allows to invert selection of files;

• – allows to move selected image to the top of the list;

• – allows to move selected image up the list;

• – allows to move selected image down the list;

• – allows to move selected image at the end of the list.

Perform the following to create list of source images:

1. Add in the left list high resolution source images.

2. Add in the right list low resolution source images.

3. Click the button and define the Pan-sharpening output directory.

4. Click OK to return for the Pan-sharpening window.

4. Setup the parameters of pan-sharpening.

5. [optional] To start the pan-sharpening operation in distributed processing mode,
perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter of the “General information” User Manual).

2. Click theDistributed processing button. TheDistributed processingwindow
opens.

The Number of images displays in the window.

130

Orthophotomaps creationPHOTOMOD 6.4

general.pdf


Fig. 80. Parameters of pan-sharpening in distributed processing mode

3. Specify Number of tasks for processing, which are processed by one com-
puter.

4. [optional] Set on theOverwrite existing images to overwrite preliminary created
images.

5. [optional] By default if process was completed successfully, temporary project
is deleted. Set the appropriate checkbox off not to delete temporary files.

6. Select the Temporary folder for distributed processing for temporary data
storing.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

6. Click OK to start pan-sharpening operation. When operation complete produces
information message, that contains number of created/skipped images as a result
of pan-sharpening.

15. Program parameters

15.1. General parameters

Programs provides possibility to setup general parameters of program and mosaic
preview parameters on the Preview tab. See the description of general parameters of
the program in the ’General system’s parameters’ User Manual.

To set up common program parameters choose the Service › Settings or click the
button on the main toolbar. The Settings window opens.
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Fig. 81. Common parameters

The GeoMosaic tab allows to setup the following general settings:

• Save local adjustment – allows to turn on/off saving of parameters and settings of
local brightness adjustment to file of mosaic project;

• Create backup – allows to setup automatic save of mosaic project backups to active
profile resources;

In the Backup depth field the number of backup projects copies is displayed.

• Vector data link to the project – allows to save (in the first time) all external data
with names attached to project name automatically (e.g. project name_sheets.x-
data);
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• Show objects from current image – allows to display vector objects relating only
to image opened in the Images preview window (see Section 7.4);

• Switch off computer after mosaic is built – allows to setup computer automatic
switch off after completion of mosaic creation;

• PHOTOMODGeoMosaic exit affirmation – allows to show a prompt on confirmation
of exit from the program when user tries to close main program window;

• Use saved mosaic settings – allows to load previous mosaic parameters when
program starts;

• Input cache size – allows to set the limitation of the cache size for reading images
(by default 256 Mb);

• Output cache size – allows to set the limitation of the cache size for recording images
(by default 100 Mb);

• Restrict cache size from – allows to set max images number, when cache size is
5 Mb per image, otherwise the cache size has limited to 0.5 Mb per image;

• Maximal number of simultaneously opened images – allows to set limit on the
opened images number in the formats JPEG, NIFF, IMG, PIX (in the case of a lot of
images, it is recommended to convert the images files to the TIFF-format files);

• Correct cloud topology when saving clouds layer – allows to correct topology
errors of vector polygons automatically on layer Clouds/Invisible areas while it is
saving;

• Fast building without background analysing – allows to build fast mosaic without
transparency of input background color;

• Add to project images with same names – allows to add images with the same
names, which store in different folders;

• Clear layer before single sheet creation – allows to delete all vector objects from
the Sheets layer before creation of single sheet;

• Enable cutlines nodes deleting – allows to delete node of cutline – point, where
three or more cutlines are connected. As a result, points, nearest to deleted node,
are connected against each other.

• Enable cutlines moving – allows to enable/disable the movement of cutlines on the
images, if the checkbox is not set, only the vertices of the cutlines are moving;

• Additional black and white background replacement – allows to use both black
and white color in the background;
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For correct consideration of several background colors, set the Shift background color
checkbox in the Mosaic tab of the Parameters window (Mosaic › Parameters).

• Fill background color outside “Background” cutlines – beyond “Background”
cutlines the output mosaic background color is used which is to be determined in the
Parameters window (see Section 13.2);

15.2. Preview parameters

The Preview tab is used to specify display parameters of mosaic.

Fig. 82. Preview parameters

The Preview tab allows to setup the following mosaic visualization options:

• Show rasters in zoom greater than – allows to setup a zoom at which a visualizing
of mosaic project images in the Preview window begins;

• Transparent mosaic background on preview – allows to setup a transparency of
output mosaic background visible in the Preview window (see Section 7.4);

• Redraw preview on editing – allows to set automatic refreshing of mosaic data in
the Preview window during editing of vector objects – cutlines and change points;

• Open preview immediately – allows to show added images in the Preview window
right away (see Section 7.4);
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• Skipped sheets fill color – allows to select a fill color to show inactive sheets of
mosaic (i.e. sheets excluded from output files creation). To adjust the transparency
degree for selected color is used the Skipped sheets color transparency (%) slider
(see Section 11.8);

• Fast view in zoom < = 100% – allows to display images block as a scheme in the
Preview window when zoom out (is recommended for large images blocks);

It is recommended to set on this parameter while processing of large image blocks.

• Preview extents – allows to define extents for displaying content in the Preview
window:

○ By source images – extents by full image;

○ By sheets – extents by all created sheets;

○ By images and sheets – edges of images and sheets.

16. Creating marginalia for orthophotomap
PHOTOMOD GeoMosaic allows to create map frame and marginalia in styles and
symbols used in Russian State Land Use Survey in map scales

• 1:2000

• 1:5000

• 1:10 000

• 1:25 000

• 1:50 000

for MicroStation and MapInfo systems. Marginalia contains the following data:

• Decoration – image frame, outer bold frame, text labels, scale segment, scheme of
sheets, names of the neighbor sheets in frame cutouts;

• Grid – coordinate grid lines;

• Frames – frames of all the created sheets.

Marginalia for MicroStation consists of one *.DGN file for every orthophoto sheet (con-
taining Decoration and Grid), and a single file for the entire project containing Frames.
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Marginalia for MapInfo is saved as two (Decoration and Grid), or three (Decoration,
Grid and Text data) MIF/MID file pairs per each orthophoto sheet, plus single Frames
file pair for the entire project.

16.1. Workflow for creating marginalia

For marginalia creation perform the following:

Described int this section is the workflow for creating marginalia forMicroStation in 1:2000 map
scale symbols.

1. After the orthophoto itself has been created, choose Mosaic › Create Marginalia
1:2000 › MicroStation DGN.... TheMarginalia parameters 1:2000window opens;

Fig. 83. Marginalia parameters

2. In theNames tab of theMarginalia parameterswindow, set the Path tomarginalia
files (output);
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3. [optional] Adjust the contents of the text labels for outside the frame (in the names
Names tab), if necessary;

4. Specify the frame style (in the Frame parameters tab);

5. Set the *.DGN specific parameters in the DGN parameters tab;

6. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

The system allows to save marginalia parameters settings. To save settings as a file with *.x-
ini extension, click the Save button in the Marginalia parameters window. To set previously
saved settings, click Load.

To open orthophoto with marginalia in MicroStation system perform the following:

1. Open the created *.DGN file in MicroStation system;

2. To open corresponding orthophoto raster sheet choose File › Raster management ›
File › Attach in MicroStation system. The program displays the orthophoto with
marginalia.

Fig. 84. An orthophoto in MicroStation window
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Marginalia can be created for the orthophoto as a whole as well as for the sheets in which it is
split.

16.2. Marginalia parameters

This section contains detailed description of marginalia creation parameters for all
supported scales.

16.2.1. Marginalia 1:2000

This section contains detailed description of marginalia creation parameters for 1:2000
scale for MicroStation and MapInfo systems.

MicroStation DGN

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:2000 › MicroStation DGN.... This command brings up the following dialog box
with parameters:

Fig. 85. Marginalia parameters
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2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. 86. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. 87. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

Names tab is identical to the one in the parameters dialog for 1:2000 marginalia in DGN format.
Frame parameters tab is identical to the one in the parameters dialog for 1:2000 marginalia in
DGN format.
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1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:2000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:

Fig. 88. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;
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• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. 89. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. 90. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Neighbour sheets on the frame option allows, along with the scheme of sheets
in the lower left corner, insert the names of the neighbour sheets in the cut-outs
of the external (thickened) frame;
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• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

16.2.2. Marginalia 1:5000

This section contains detailed description of marginalia creation parameters for 1:5000
scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:2000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:2000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:5000 › MicroStation DGN.... This command brings up the following dialog box
with parameters:
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Fig. 91. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;
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• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. 92. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. 93. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:5000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. 94. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;
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The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. 95. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. 96. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;
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5. Click ОК.

16.2.3. Marginalia 1:10 000

This section contains detailed description of marginalia creation parameters for 1:10
000 scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:10
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:

Fig. 97. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;
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• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).
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• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;
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■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

Fig. 98. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. 99. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:10
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. 100. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:
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• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

162

Orthophotomaps creationPHOTOMOD 6.4



Fig. 101. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. 102. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

16.2.4. Marginalia 1:25 000

This section contains detailed description of marginalia creation parameters for 1:25
000 scale for MicroStation and MapInfo.

164

Orthophotomaps creationPHOTOMOD 6.4



Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:25
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:

Fig. 103. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;
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• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:
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P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. 104. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. 105. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:25
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. 106. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:
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• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. 107. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. 108. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

16.2.5. Marginalia 1:50 000

This section contains detailed description of marginalia creation parameters for 1:50
000 scale for MicroStation and MapInfo.
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Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:50
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:

Fig. 109. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;
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• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:
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P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. 110. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. 111. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:50
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. 112. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:
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• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. 113. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. 114. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

16.3. Arbitrary marginalia parameters

If necessary the orthophoto marginalia, created in scales 1:2 000 and 1:5 000, may be
configured in accordance with the requirements of the user. To do this, use the following
commands:
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• Mosaic › Create marginalia 1:2000 › MicroStation DGN (arbitrary)

• Mosaic › Create marginalia 1:2000 › MapInfo MIF/MID (arbitrary)

• Mosaic › Create marginalia 1:5000 › MicroStation DGN (arbitrary)

• Mosaic › Create marginalia 1:5000 › MapInfo MIF/MID (arbitrary)

In the window that appears, you can edit the layout parameters in the appropriate fields:

Fig. 115. Marginalia parameters

1. Names tab is identical to the one in the parameters dialog for 1:2000 marginalia
standard, except for additionalContours and Elevation system parameters, which
specify two text strings, which are written consequently at the center bottom;

2. The Frame parameters tab contains the following parameters:
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Fig. 116. Marginalia parameters

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Insert names in frames option causes writing the names of sheets to a file with
frames not only into the corresponding attribute, but also as a text string;

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

3. Frame parameters tab is identical to the one in the parameters dialog for 1:2000
and 1:5000 marginalia standard in DGN and MIF/MID formats.

16.3.1. Batch marginalia file names editing

Sometimes it may be necessary to rename sheet image files together with marginalia
files to working numbers.
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Choose Sheets › Split into sheets by images, if it’s not done yet.

Use menu commands Mosaic › Create Marginalia 1:2000 › Rename to work IDs or
Мosaic › Create Marginalia 1:5000 › Rename to work IDs when the preview window
is open for the mosaic sheets of which are to be renamed.

Then in the dialogue box that appears, select the folder where files with marginalia and
files with sheets, which must be renamed, are stored.

As a result of this operation, the files contained in the selected folder will obtain the
names used in the PHOTOMOD Mosaic module by default, for example, “Sheet_1“,
“Sheet_2”. Files extensions will correspond to their content: for example, *.tiff - for
sheets files, *.tab - for sheets georeferencing in MapInfo, MIF/MID - for files with mar-
ginalia.
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