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1. Purpose of the document
The current User Manual contains information about orthophotomaps creation using
PHOTOMODGeoMosaic program. This program is designed tomerge the georeferenced
orthorectified imagery and create the orthomosaic from them. Themain part of document
contains description the technology of mosaic creation in the GeoMosaic program.

2. About program

2.1. Purpose and main definitions

The GeoMosaic program (hereinafter is referred to as “program”) is purposed to create
the orthomosaic from georeferenced orthorectified aerial and satellite imagery, splitting
of created orthomosaic with the capable of saving sheets in popular raster file formats.

The GeoMosaic program includes to the full version of PHOTOMOD system and also
could be produced separately.

The orthomosaic is the single image, which obtained during the brightness adjustment and
merging the multiple georeferenced orthorectified images. The orthoimage is the image, obtained
after the transformation from the central projection to the orthogonal projection with automatic
removal of distortions, which were caused by the imaging equipment, elevation angle and relief.

One of the most common scenarios of GeoMosaic use is creating a mosaic from orthorectified
images obtained as a result of processing the project in PHOTOMOD (see the “Orthorectification”
User Manual).

Thus, PHOTOMOD output data are at the same time GeoMosaic input data, and creation and
processing of the project in PHOTOMOD is a possible stage of preparation of raw data for further
processing using PHOTOMOD GeoMosaic (depending on the nature of source data).

The program provides the following features:

• creating the orthomosaic from the source images;

• radiometric images correction (filtration, color balance, brightness, contrast, etc.);

• pan-sharpening – process of merging multispectral and panchromatic images (see
“The pan-sharpening operation” chapter of the “General information” User Manual);

• correction (removing visual defects) of images in the DustCorrect module (see the
“Dust Correct” chapter of the “Project creation” User Manual);

The module provides processing for Windows BMP and Stripped SingleScale TIFF without
compression images only.

• automatic cutlines creation considering areas without background and cloudiness on
images;
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• different modes of creation and edition cutlines;

• splitting output mosaic into sheets depending on parameters;

• GCP adding and measurement their coordinates on images;

• tie points adding and measurement their coordinates on images;

• local and global brightness adjustment;

• smoothing areas along cutlines for creating mosaic image;

• import/export of cutlines, sheets borders. ground control points, etc.;

• loading DEM and accuracy control of DTM creation (see the ’Creating DTM’ User
Manual).

2.2. Main conventions and terms

The program uses the following conventions and terms:

• Orthomosaic – orthoimage, created from source images during brightness adjustment
and merging georeferenced orthoimages;

• throughout this User Manual, the orthomosaic, created from the source images, is
referred to as ’output mosaic’ or ’mosaic’;

• Orthoimage is a georeferenced image prepared from a perspective photograph or
other remotely-sensed data in which displacement of objects due to sensor orientation
and terrain relief have been removed;

• Cutline is the boundaries of the specified area from the source image, which will be
included in the output mosaic. The vector polygons are used for the cutlines creation.
The common boundaries of neighbouring cutlines are completely topologically coin-
cide, i.e. the areas of source images, selected using the cutlines, which are the single
area without overlaps and ’gaps’;

• Useful area contains substantial part of image and excludes input background of
image;

• Mosaic’s background – background of output mosaic, without image, which has color
defined by user. Each output mosaic file contain it;

• Source images in mosaic project also have background, which calls background
color of source images in the system;

• Sheet – a part of output mosaic, which is saved in individual file with chosen format;
edges of sheet are vector polygons;
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• Active sheet – a sheet, from which the output mosaic file will be create;

• Inactive sheet – a sheet, excluded from the output mosaic;

• Work area – vector polygons which define the boundaries of the output orthomosaic’s
content. If the user finds it necessary to use work area boundary (see Sec-
tion 13.2.2), the areas outside this area will be filled with the mosaic’s background.

The work area makes it possible to limit the content of the orthomosaic to a polygon (or
polygons) of an arbitrary shape, what can be useful if user need to create a mosaic only
within some object, for example, a settlement.

The system provides for creating sheets of an output mosaic taking into account the work
area of interest, which makes it possible to avoid sheets completely filled with the mosaic’s
background (see Section 11.3.1).

• Source image (source image of mosaic project) – source georeferenced orthoimage;

• Reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project;

• Pyramid is a set of resampled copies of image;

• Global brightness adjustment means transformation equally applied to all pixels of
each source image;

• Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges.

2.3. Input data

The sources data for mosaic creation in the GeoMosaic program are the orthoimages,
referenced to the coordinate system, in the files of following formats:

• Tag Image File Format (TIFF) TIFF и GeoTiff format, included tags for saving of
georeferenced information;

• Windows Bitmap File (BMP);

• VectOr Raster Maps (RSW) raster formats of GIS Panorama software;

• ERDAS IMAGINE (IMG) ERDAS system raster format;

• NITF (NITF);

• JPEG (JPEG);
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• GIF (GIF);

• PNG (PNG);

• USGS DEM (DEM);

• PCIDSK (PIX) raster format with georeference in the heading developed by PCI
Geomatics company;

• JPEG2000 (JP2) raster format with jpeg compression and georeference in the
heading developed.

The program also provides the ability to load and process of palette images in TIFF, GIF and
BMP files format.

PHOTOMOD output data (orthorectified imagery obtained as a result of project processing) are
at the same time possible GeoMosaic. input data.

The source images can be placed to resources of the active profile as well as to con-
ventionalWindows file system.

2.4. Output data

The program provides the supporting of multiple raster formats to export the output
mosaic sheets. The program also provides the output formats to export the georeference
data. The cutlines, sheet boundaries and tie points, created in the mosaic project, are
stored in vector files of internal format. The program supports the multiple import/export
formats of vector data.

The output file size in JPEG2000 and ECW formats cannot exceed 500 MB.

Table 1. Output data

File placementFile formatsOutput data
in the active profile resourcesX-GMOS internal formatMosaic project
in the active profile resourcesX-DATA internal vector formatCutlines and tie points (vector

data)
inWindows file systemExternal georeferenced data for

mosaic sheets
• PHOTOMOD GEO

• MapInfo TAB

• ArcWorld (*.tfw, *.pbw)

inWindows file systemMosaic sheets (orthoimages) • TIFF иGeoTIFF (*.tiff, *.tif)

• Windows Bitmap File (*.bmp)

• Panorama raster (*.rsw)
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File placementFile formatsOutput data
• ERDAS IMAGINE (*.img)

• NITF (*.nitf)

• JPEG (*.jpg, *.jpeg)

• PNG (*.png)

• Microstation (*.gfn)

• PCIDSK (*.pix)

• JPEG2000 (*.jp2)

• PHOTOMODMegaTIFF (*.prf)

• ECW (*.ecw)

• WebP (*.webp)

3. Start of work
Before the beginning work in the program define the folder, in which are placed the
sources data. The program allows to place the files with the source data in the folders
ofWindows file system, as well as in the profile resources.

Activate this profile when the source images placing in the profile resources. Supported
file formats list of source images see in Section 2.3.

Description of resource system see in the General Information User Manual.

To start the program perform one of the following:

• choose the Start › Programs › PHOTOMOD 8 x64 › GeoMosaic;

• double click the PHOTOMOD Geomosaic icon on the desktop;

• in the context menu of System Monitor module in (the icon in theWindowssystem
tray) choose GeoMosaic;

• start the PHOTOMOD system and choose the Rasters › GeoMosaic.
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4. Interface and its elements

4.1. Work area interface

Fig. 1. The GeoMosaic program

The GUI contains the following elements:

• title with name of opened project (A);

• the main menu bar (B);

• the main toolbar is used for quick main program functions access (C);

• the additional toolbars is used for quick miscellaneous program functions access (O);

The system interface is flexible for customizing the locations of additional toolbars according
to the user’s needs. Additional toolbars can either be fixed in designated sections of the work
area (top or bottom, right or left) or undocked by the user and placed in any place in the 2D
window.

Depending on the user-set interface configuration, docked additional toolbars can be partly
minimized (some buttons will be hidden). Docked (optionally minimized) subtoolbars are
displayed as one line, vertical or horizontal, depending on their location.

By default, additional toolbars are docked at the top of the workspace, to the right of the main
toolbar. Additional toolbars are marked with a special icon located on the left or top (de-
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pending on the location) edge of the panel. To maximize the toolbar, click ( ) on the right
(at the bottom).

Undocked additional toolbars are always displayed horizontally, in one line, in a fully maximized
form. To undock a toolbar (or pinpoint it in any place), move the cursor over the icon and,
holding down the left mouse button, drag the toolbar to the area of its targeted location (the
cursor’s shape changes ( ) when it is possible to capture the toolbar).

• the 2D-window, used for data displaying, contains the following elements:

○ the toolbar is used for the 2D-window modes managing (D);

A number/total sheets/images is shown in header of the individual 2D-window.

○ the work area is used for viewing and processing with loaded data of mosaic project
(N);

○ the navigation bar is used for fast moving on the specified block images area of
mosaic project (E);

To do this, click on the chosen point in Navigation bar. To set the layers visibility, move
to the Navi tab in the layer manager.

○ the Layer manager is used for managing of mosaic project layers (F);

○ the work area is used to display the axes direction of project coordinate system
(M);

○ the status bar is used for viewing working coordinate system, current real (ground)
and pixel marker coordinates and brightness, contrast and gamma data adjustment
in the work area (G, K, L);

GSD value is displayed to the right of the current marker coordinates (excluding radiometric
correction windows).

RGB brightness values are displayed to the right of the current marker coordinates. When
placing the marker within the work area, the following brightness values are displayed:
R=128 G=128 B=128.

When place marker is on the area out of image or on background (in Preview window),
brightness is indicated as NULL.

○ scroll bar in 2D-window (H).

The system interface is flexible for customizing the locations of 2D-windows according
to the user’s needs. The 2D-window can either be fixed in designated sections of the
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work area (by default) or undocked by the user and placed in any place in the work
area.

To undock 2D-window (or pinpoint it in any place), move the cursor over the window
title and, holding down the left mouse button, drag the window to the area of its targeted
location.

Use the button on the right side of the window title to undock a docked window.

For convenience, the system also allows you to maximize some key 2D windows,
“stretching” them to the full width of the screen work area. Thus, such a window can be
displayed in three states – “docked”, “undocked”, and “maximized”.

To stretch a 2D window (for example, a window displaying a block scheme) to the full
width of the screen, perform the following:

1. Undock the 2D window. The maximize button is displayed in the main toolbar
of that window;

2. Click in the toolbar. The window fits the full width of the screen work area. The
main toolbar of the window displays the restore button;

3. [optional] To restore down, click .

To quickly return a window to the previous configuration, double-click the left mouse button
on the window title

Several similar windows docked within one work area make up a group of tabs (e.g.,
2D windows). To go to the desired tab, left-click on its title. To close a tab (and the
corresponding window), click in the tab title.

4.2. Brief description of main menu

The program main menu contains the menu items for mosaic creation, vector data
processing, additional applications starting and setting parameters.

Table 2. Main menu

FunctionMenu
to create, open and save mosaic project, and also obtain information about
project

Project

to form images block of mosaic projectImages
purposed for cutlines creation and also provides features for calculating areas
without background (useful areas) and cloudiness

Cutlines

purposed for searching and measurement ground and tie points in the cutlines
region to adjust the stitching along the neighbour cutlines

GC/tie points

purposed for mosaic splitting and managing active status of sheetsSheets
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FunctionMenu
purposed for additional data retrievingMisc
purposed for defining the output parameters of mosaic and creating the sheets
of mosaic with saving in output format files

Mosaic

purposed for creating, editing, import/export of vector data (see the menu
description in ’Vectorization’ User Manual)

Vectors

purposed for modes choosing to select and draw vector objects, to transform
curves, repeat/cancel the last operation (see the menu description in ’Vector-
ization’ User Manual)

Edit

purposed for applications launching, additional data loading (e.g., DEM),
general parameters setting, coordinate system editing, etc.

Service

to open additional toolbars and windows: new 2D-window, Marker and
Measurements windows, Objects attributes window (see the chapter “General
system’s windows” of the ’General information’ User Manual)

Windows

to start the ’Help’ systemHelp
purposed for closing of GeoMosaic programExit

4.3. The main toolbar
Table 3. Brief description of main toolbar

FunctionButtons
to create a new project
to open a mosaic project from active profile resources
to save a mosaic project
to save a mosaic project with new name in active profile resources
to add images out of active profile resources
to add images from active profile resources
to open images list
to open sheets list
to open Points catalog window
to open current and previous images in individual 2D-images
to open next image
to open previous image
to open current and next images in individual 2D-images
to set on a single sheet creation mode
to create a sheet around marker
to turn on the cutlines fast manual editing mode
to create a new cutline as a small rectangle polygon in the place of the node (the point
where three or more cutlines converge). This polygon can be further edited by the user.
to define the output parameters for creation of mosaic
to rebuild brightness adjustment for all block scheme
to enable using of ground control points
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FunctionButtons
to enable using of synthetic points
to enable using of tie points
to open the Preview window for all project
to open the Preview window for current sheet
to start the mosaic creation
to start building a mosaic for selected active sheets according to the specified settings
and parameters in the distributed processing mode
to start building a mosaic and creating an output file for the selected sheet
to load an image from file to the individual raster layer
to launch theDustCorrect module to edit MS-TIFF images (see the “Dust Correct” chapter
of the “Project creation” User Manual)
to undo the last action (see the ’General information about system’ User Manual)
to display the list of last actions (see the ’General information about system’ User
Manual)
to redo the last undone action (see the ’General information about system’ User Manual)
to load a georeferenced image from file, located in the file system, for more precise
correspondence of cutlines area
to load web-map
to open the Marker window (see the menu description in ’Vectorization’ User Manual)
to open the Measurements window (see the menu description in ’Vectorization’ User
Manual)
to tile 2D-windows
to stack 2D-windows
to arrange 2D-windows in a tabsheet
to arrange 2D-windows evenly
to refresh all 2D-windows; to perform re-calculating of brightness adjustment click the
button holding the Shift key
to close all 2D-windows
to close all 2D-windows with opened images (except Preview window)
to zoom in, in all windows with opened images (Shift+* [NumPad])
to zoom out, in all windows with opened images (Shift+/ [NumPad])
to fit data to page, in all windows with opened images
to display data in 1:1 scale, in all windows with opened images
to open a window of display mode parameters (see Appendix A)

5. Workflow of mosaic creation
Both the sequence of procedures and the program’s functionalities involved are largely
driven by the properties of the project under processing itself, i.e., quality and homogen-
eity of source data, possibility to use reference information, as well as the nature of
output data and their requirements (both accuracy and visualization quality aspects).
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Possible scenarios for using the GeoMosaic program can be divided, for clarity, into
two groups:

• Creating a new photomosaic using well-suited and homogeneous data, for example,
as one option, orthorectified images previously obtained as a result of processing
the project in the PHOTOMOD.

Such a scenario (considered as a general case) is described in this manual as a re-
commended sequence of actions when creating and processing a new project (see
Section 5.1).

• Refining an existing orthomosaic (or earlier created PHOTOMODGeoMosaic project)
using inhomogeneous data obtained from various sources, complicated by the spe-
cific terrain, the inability to use reference information, and the need to correct local
areas of the mosaic (or add new areas to the mosaic).

Such tasks may place increased demands on the user’s experience and qualifications,
and their solution may require a deviation from the standard order of operations when
processing a project and the use of additional program capabilities (for example,
specifying the referencing).

Describing all possible situations is beyond this manual; however, some recommend-
ations concerning the most frequent unusual cases are given below in the framework
of the described recommended sequence of actions when processing a standard
project.

5.1. Recommended sequence of actions when processing a new
project

Creation of mosaic implies a number of following actions:

1. Creating of mosaic project (see Section 6).

2. Loading of images in the mosaic project (see Section 7):

• images adding;

• setting of transparency for the background color of source images (see Sec-
tion 7.5).

3. Defining of channels set for mosaic.

Use the Mosaic tab in the Mosaic parameters window to define the channels (see Sec-
tion 13.2.2).

4. Defining of the output coordinate system for mosaic and using it for storing of vector
data (the cutlines, sheets boundaries and tie points).

15

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Use theMisc tab to specify the save parameters of vector data in output coordinate system
(see Section 13.2.5). The output coordinate system for mosaic is defined in the Mosaic
parameters window on the Mosaic tab (see Section 13.2.2).

5. Estimation of work areas for cutlines creation: Creating areas without background
and areas with clouds (see Section 8).

6. Cutlines creation and editing (see Section 8).

It is not necessary to create cutlines only if block of initial images with joining boundaries,
i.e. if images block is without overlaps and ’gaps’, is used.

7. [optional] Performing brightness adjustment of mosaic areas: global and local
brightness adjustment, seams feathering (see Section 9.1).

8. [optional] Ground control or synthetic points employment, stitching the cutlines re-
gions by tie points (see Section 10). Setup parameters of GC/Tie points employment
(see Section 13.2.4).

Using GC/tie points is not a mandatory stage of project processing and is generally not
required when using correct and homogeneous input data. It is recommended to use this
tool with some degree of caution, only in cases where it is really necessary to achieve the
desired results.

If project processing requires GC/tie point using, manual editing of cutlines (see above) is
strongly recommended after completing work with triangulation points

9. Splitting into sheets and selection for creating of output files (see Section 11).

10. Setup the output parameters for mosaic creation: pixel size, map scale, mosaic
sheets file format, etc. (see the Section 13.2.2 and Section 13.2.3).

11. The mosaic creation with saving of the mosaic sheets in the files of selected format,
also in the distributed processing mode.

6. Mosaic project creation

6.1. Project menu
Table 4. Brief description of ’Project menu’

FunctionMenu items
is used for creation of the new mosaic projectNew
is used to open the saved mosaic project from file
with the *.x-gmos extension in the resources of
active profile

Open

to choose and open one of recent projectsRecent
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FunctionMenu items
to import mosaic project from the *.x-gmos fileImport
to save the opened mosaic project in the file with
the same name and the *.x-gmos extension in the
resources of active profile

Save

to save the opened mosaic project in the new file
and the *.x-gmos extension in the resources of
active profile

Save as

to save the project work environment – a set of
project opened layers (e.g. vector data, raster im-

Save work environment

ages opened to transfer GCPs or DEM) in a file *.x-
work in active profile resources
to load project work environment data from a file
*.x-work saved in active profile resources

Load work environment

to open the project statistic windowStatistic

6.2. Creating new project

Choose the Project › New or click the button on the main toolbar; The following
blank service vector layers are created automatically and displayed in the Layer manager:

• Useful areas;

• Clouds/Invisible areas;

• Ground control and tie points;

• Miscellaneous;

• Sheets;

• Cutlines.

Service layers couldn’t be closed or saved as a separate vector layer.

The mark near the Clouds/Occluded zones layer name means that this layer is not available
for manual editing at the moment (see Section 8.4).

The name project in the title of main program’s window is marked with *, if the project
was changed. The names of layers to which unsaved changes have been made are
marked in a similar way.

Mosaic project is saved to *.x-gmos file.

Choose the Project › Save to save the mosaic project. All changes in project layers
are saved.
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Choose the Project › Save as to save the mosaic project with new name and define
name and path in active profile resources.

Choose the Project › Open or click the button on the main toolbar to open existed
mosaic project.

The program provides opportunity to load the following additional data in the project:

• choose the Misc › Load metadata to current layer to load images metadata to the
current active layer;

Metadata – structured information about data in the image file,

It is recommended to choose Cutlines or Miscellaneous layers to correct load of metadata.
Metadata could be load only into a system layer.

• choose the Misc › Load nadir and central points to load nadir and central points
to the Miscellaneous layer.

It is possible to work with project without source raster images (e.g. only to view project
parameters or cutlines). In this case images display as a grid in 2D-window.

Fig. 2. Project without source images
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6.3. Mosaic project import

The program allows to import parameters of other project without changing set of source
images

To import project parameters to opened project choose the Project › Import.

Fig. 3. Mosaic project import parameters

The Project import parameters window allows to choose type of the following data to
import:

• Import settings and brightness adjustment – allows to import parameters of the
Mosaic tab on the Mosaic parameters window, and also parameters of local and
global brightness adjustment from the Brightness adjustment tab;

• Import cutlines – to import cutlines layer, associate these cutlines with images of
current project;

○ [optional] set theDelete existing cutlines checkbox to delete cutlines from opened
project during the import;

• Import tie and ground control points – allows to import tie and ground control
points and to associate then with images of current project;

• Import sheets – allows to import parameters of splitting mosaic into sheets and to
allow these parameters for current project;

• Reference by image name only – to compare imported cutlines only by image name,
not by path;

• Import cell size – to import the output mosaic cell size.

All data import to the service layers of project. Layers with imported data are marked in the
Layer manager.

19

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



6.4. Project information

To view information about the project choose Project › Statistic.

The Statistic window, which contains the following information, opens:

• quantity of source images;

• quantity of channels;

• bytes per sample;

• quantity of total/active mosaic sheets;

• mosaic size in megabytes;

• output raster size in pixels.

Fig. 4. Project information

7. Images block forming

7.1. Images menu
Table 5. Brief description of Images menu

FunctionMenu items
is used for the selecting image files, locating in the
file system, and adding to mosaic project

Add images from files

is used for selecting image files, locating in the re-
sources of active profile, and adding to mosaic pro-
ject

Add images from resources

is used for automatic selection of all images from
the specified folder ofWindows file system

Add images › From files (from folder)
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FunctionMenu items
is used for automatic selection of all images from
the specified folder of active profile and adding to
mosaic project

Add images › From resources (from folder)

to use the text file, containing the full network paths
to the images (useful when the project files are loc-

Add images › Add from files list

ated in different local and network folders), for
adding the images to mosaic project
to delete from project the images that are selected
using selection of appropriate vector objects, for

Delete selected images

example, source images boundaries, cutlines, areas
without background
to delete the images outside active sheets from
mosaic (see Section 11)

Delete images outside active sheets

to open the added images list for editing list, search
images by name, view the selected image and its

The Images list window

properties; define images background color; show
tie points residuals
is used to open in separate 2D-windows those im-
ages, with highlighted boundaries (see Section 12)

Open selected images

is used for the checking of the project images (see
Section 7.9)

Check source images

to create the overview pyramid set for the fast im-
ages refreshing on screen (the pyramids are saved

Create pyramids

in the files with the *.pyr extension in the Pyramid
folder during this process)
to use distributed processing for pyramid creation
of loaded images

Distributed pyramids creation

to delete all external pyramids, created for loaded
images (with the exception of the pyramids currently
in use)

Delete pyramids

contains menu items to set up transparency images
background color

Transparent background color

to open the ImageWizard utility to manage links to
images (see the “ImageWizard. Adjustment of im-
ages” chapter of the “Creating project” User Manual)

ImageWizard

7.2. Adding images

The step forming of source images block follows after the mosaic project creation. It
implies a number of following actions:

1. Loading source images and forming block images of mosaic project.

2. Setting transparency for the background color of source images to exclude the
background from the output mosaic.

The program provides the following possibilities to load source images into the project:
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• to add source images manually from files

○ in active profile resources – choose the Images › Add images from resources
or click the button;

○ in theWindows file system folder – choose Block › Add images from files or click
the button.

Shift and Ctrl keys are used to select multiple files.

• to add source images automatically;

Automatic selection is recommended when large number of source raster files are located
in the folder along with files of other formats, and/or when source images are located in
several subfolders of the selected folder.

○ from folder in active profile resources – choose the Images › Add images › From
resources (from folder);

○ from theWindows file system folder – choose the Images › Add images › From
files (from folder).

To search raster images in subfolders, set on the Search in subfolders checkbox.

It is possible to search and add files only with selected extension. The type of mask like
*.* is used for this (e.g., *.tiff).

• to add set of source images create a text-file with the list of images paths and choose
Images › Add images › Add from files list.

The text-file should contain list of full network paths to source images files.

It is possible to change output channels, if images with channel, that is absent in loaded
images, were added to the project.

7.3. Image selection

The program allows selection one of group of images in theMiscellaneous, Cutlines or
Useful areas layers and also in the window with source image.

The following options are provided for images selection:
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• the Misc › Source images outlines menu item is used to create image borders as
vector polygons on the Miscellaneous layer. Images are selected corresponding to
selected polygons;

If there are selected objects on the non active Miscellaneous layer, will be selected images
corresponding to these objects.

• if there are selected polygons on the Cutlines or Useful areas layers, will be selected
images corresponding to selected polygons;

• if there are selected objects on the active 2D-window, will be selected image in this
window only.

7.4. Images preview

Images block opens automatically in the Preview window after adding images to the
mosaic project.

To display all images in the Preview window, choose the Mosaic › Preview or click
the button of the main program toolbar.

Images are displayed in the Preview window automatically after adding to the mosaic project.
In order to disable automatic displaying of images, set off the checkbox in the Preview tab of
the Parameters window (see Section A.2).

Each image of mosaic project is a raster images, insert to a rectangle.

Background without image has defined color. In program it calls mosaic’s background
and each output mosaic file contain it.

By default is used black background color. Background doesn’t display in the Preview
window.

To display output mosaic background in the Preview window, set off the Transparent mosaic
background on preview checkbox in the Preview tab of the Parameters window (see Sec-
tion A.2).

TheBackground color parameter on theMosaic tab in theMosaic parameterswindow allows
to chose (see Section 13.2.2).

Source images in mosaic project also have background, which calls background color
of source images in the system.

It is recommended to exclude this background from output mosaic. To do this set the transparency
of background color (see Section 7.5).
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Fig. 5. Mosaic’s background and background color of original images (without transparency)

Perform one of the following to open images of mosaic project in separate 2D-windows:

• choose the Images › Project images list to open Images list window. Select the
images in the list and click the button.

In order to highlight multiple images, press and hold theCtrl or Shift key while clicking mouse
or use selecting tools in Images list window (see Section 7.8).

• choose the Misc › Source images outlines to create image borders as vector poly-
gons. Select borders of images and choose the Images › Open selected images.

To select more than one object, stretch the rectangle along with pressed Shift key with one
of the group selection instruments on Tools toolbar.

The system also provides for selecting objects using a freeform polygon ( ).

Create a polygon by holding Shift while moving the cursor sequentially in the work area of
the 2D window. To complete the creation of a polygon, set the last vertex of the polygon by
double-clicking the left mouse button. To delete the last created vertex, press Esc.

The following buttons on main toolbar are used to pass to previous or to next image:

• – to display previous image;
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• – to display next image.

If there is no opened 2D-windows (image) or preview windows, the button allows to open
the last image in the project, – the first image.

The following buttons on main toolbar are used to pass to previous or to next image:

• – to display current and previous images in separate 2D-windows;

• – to display current and next images in separate 2D-windows.

To open any georeferenced orthoimage of acceptable raster format in separate 2D-
window, choose the Mosaic › Open image or click the button on the main toolbar
and choose image file.

In case the same folder contains a *.rmc file, the correction parameters for the selected image
will be loaded

7.5. Setup of image background color

It is recommended to setup of transparency image background color after image loading
into mosaic project to create mosaic correctly.

Setup of transparency background color of input image is highly recommended when there are
areas inside images with the same color as background and you need to consider these areas
in output mosaic as transparent, i.e. to produce mosaic with ’gaps’ without fill of input background
color or using reference image. The Transparent background inside cutlines parameter is
used to consider useful areas transparency (see Section 13.2.2).

Perform one of the following to setup transparency for the background color of source
images:

If background is not homogeneous in color, use the Source rasters background color range
parameters (see Section 13.2.2).

• in case of white background color of source images, choose the Images › Transparent
background color › White;

• in case of black background color of source images, choose the Images › Transparent
background color › Black;

• choose the Images › Transparent background color › Auto to assign automatically
images background color and set up transparency to all mosaic project images.

In case of arbitrary background color of source images, choose the Images › Project images
list or click the button on the main toolbar. The Images list window opens. Select the
images to define the images background color and click the button (see detailed description
in Section 7.8).
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Due to the peculiarities of preprocessing, some satellite images can have two background
colors at the same time (black and the second one is arbitrary), which must be taken
into account during processing. For correct processing of such images, perform the
following:

1. To take into account the arbitrary background color of source images, choose the
Images › Project images list or click the button on the main toolbar. The Images
list window opens. Select the images to define the images background color and
click the button (see detailed description in Section 7.8).

2. To take into account the black background color of source images, choose the
Mosaic › Parameters or click the button on the main toolbar. The Mosaic
parameters window opens. Open the Brightness adjustment tab set the Addi-
tional check for black background checkbox.

Choose the Images › Transparent background color › None to cancel transparency
setting for images background color.

Fig. 6. Black color of images background
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Fig. 7. Transparency setting for black color of images background

7.6. Image pyramid creation

To fast images redraw on a screen it is possible to create image pyramid.

Pyramid is a set of resampled copies of image.

The pyramids are saved to the files with the *.pyr extension in the Pyramid folder.

PHOTOMOD software supports already existing third-party image pyramids, if available (*.ovr).

Choose the Images › Create pyramids for creating the overview pyramid.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to create pyramids using distributed processing:

1. Add images to the project.

2. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).
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3. Choose Images › Distributed pyramids creation. The Create pyramids window
opens.

Fig. 8. Pyramid’s distributed processing parameters

The total Number of images in project displays in the window.

4. Specify Number of tasks for processing, which are processed by one computer.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

5. Select the Temporary folder for distributed processing in the resources of active
profile for temporary data storing.

6. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

7.7. Editing of block images

Perform one of he following actions to delete the images from the mosaic project:

• select the image in the Preview window and choose the Images › Delete selected
images;

• choose the Images › Project images list. The Images list window opens. Select
the images in the list and click the button.

To select multiple images use Shift and Ctrl keys or use selecting tools in Images
list window (see Section 7.8).

Also the program provides a possibility to delete images outside of active sheets border
(see Section 11). After sheets creation define the activity of sheets and choose the
Images › Delete images outside active sheets to do this.
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7.8. The Images list

The Images list window is provided to view and edit the images list of mosaic project.
To open the Image list window choose the Images › Project images list or click the

button of the main program toolbar.

Fig. 9. The Images list window

The main part of the window contains a table of mosaic project images with the following
information:

• Ordinal number;

• View – visibility images in the preview window;

• Image – attribute for full path to image file;

Set the Name only checkbox on to display image file name only;

• Background color – background color of source images, specified during setting of
background color transparency;

• Cutlines – information about presence/absence and quantity of cutlines created for
the image;

• Dimensions – image size in pixels;

• Channels – channels number and number of bytes per pixel;

• Pixel size, in project units;
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A pixel size set when creating an input orthoimage (e.g., created in PHOTOMOD, see
“General orthoimage creation parameters” in the “Orthorectification” User Manual) does not
always coincide with the real GSD of source images (see Section 7.8.1).

• CS – image’s coordinate system;

In some cases, source project imagesmay be initially presented in different coordinate systems
(or, in the most common case, the areas mapped over in the project images are located in
different zones of the same coordinate system).

To assign one or several images their own coordinate system, select the required images in
the table and click in the Images list window toolbar. Set the required coordinate system
in the window that opens and click OK.

To cancel the coordinate system assignment for particular images, select the required images
in the table and click .

To provide correct mutual arrangement of images in such projects, in the preview window,
indicate input and output coordinate systems in the Mosaic tab of the Mosaic parameters
window.

• Off-nadir angle – off-nadir angle (in degrees, shown by default for the scanner im-
ages);

• Along track GSD (shown by default for the scanner images);

• Across track GSD (shown by default for the scanner images).

Points sorting in columns of the list is performed by mouse click on the column header.

Double click to image name allows to open 2D-window of source image and all data
for this image (cutlines, sheets borders, etc.).
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Fig. 10. Project image

Toolbar and standard selection and searching tools are placed in upper part of window.
Number of Images total/selection displays in the status bar of the window.

Table 6. The toolbar of Images list window

FunctionButtons
to search for an image by name (part of name) in the list
to select all images in the table
to unselect all images in the table
to invert selection of images in the table
to highlight images, selected in the table, on active layer
to highlight image, selected in 2D-window, in the table
to add images out of active profile resources
to open the ImageWizard utility to manage links to images (see the “ImageWizard. Ad-
justment of images” chapter of the “Creating project” User Manual)
to remove selected images from project
to remove from the project images without cutlines (in the Cutlines column is shown
the ’–’)
to set coordinate system for selected images
to clear coordinate system for selected images
to open selected image in 2D-window
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FunctionButtons
to refresh table of images and recalculate quantity of cutlines, which fall into images
to display information about selected image (path, size, channels)
to clear selected images background color
to set arbitrary images background for selected images
to apply auto levels to selected images (see the “General information about system”
User Manual)
to perform the radiometric correction for selected images (see the “General information
about system” User Manual)
to load radiometric correction parameters from a *.rmc file
to delete radiometric correction for selected images
to show tie points residuals for current image (see Section 10.5)
to restore the default order of images after changing
to move selected image at the head of the list;
to move selected image up the list;
to move selected image down the list;
to move selected image at the end of the list;
to invert selected images or group of images
to reverse images in the table
to save the list of selected images and their file paths in a text file
to remove each n-th images from project
to select several images from the project as a ’reference’ images to apply global bright-
ness adjustment

Selected reference images will not be changed during adjustment. Histograms of other mosaic
images will be corrected in accordance with chosen (’reference’) images.

For correct brightness adjustment using one or more reference images selected in the Images
listwindow, make sure that theBy average brightness option is selected in theGlobal adjust-
ment section of the Brightness adjustment tab in the Mosaic parameters window;

Brightness adjustment using several reference images (located in different parts of the mosaic)
can be useful when processing projects containing large number of images.

to open the Columns list window, to manage the additional columns, containing inform-
ation from images metadata, if it exists (for the scanner satellite images for example)
to display in the Preview window changes of brightness, contrast and gamma data
settings in the work area (G, K, L) made in a single image 2D window without closing it

In order to display in the Preview window changes of brightness, contrast and gamma
data settings in the work area made in a single image 2D window (without closing it),
perform the following:
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1. Make sure that the Use brightness pre-correction checkbox is set in the Bright-
ness adjustment tab in the Mosaic parameters window, and None option is se-
lected in the Global adjustment section;

2. Click the button in Images list window;

3. Click the button of the main program toolbar. Brightness, contrast and gamma
data changes will be displayed in the Preview window.

The system allows to save radiometric correction parameters to *.rmc files in order to
apply these parameters to other images. Perform the following actions to do this:

1. Select image in the list;

2. Setup parameters and perform radiometric correction of selected image;

3. Click the button and define a folder to save radiometric correction parameters
in file with *.rmc extension;/

4. Choose image for correction in the list;

5. Click the button. The load correction parameters window opens;

6. Choose parameters file file and click OK. Correction parameters apply to selected
images.

A RMC-file is created for each of selected images. Further, these files can be used during
operations related with GC/tie points and mosaic creation.

7.8.1. Extra image data

The system provides for including in the table (Images list window) additional columns
containing info from image metadata if available (e.g., for scanner imagery).

Use the Columns list window for this purpose. To open the Columns list window, click
in the Images list toolbar.
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Fig. 11. The Columns list window

The metadata set for scanner images depends on the specific image provider. When creating
an orthoimage in PHOTOMOD from central projection project images, certain key information
about the images obtained during project processing and adjustment is recorded to the *.x-
feat file containing the metadata (see below).

Table 7. The Columns list window toolbar

FunctionButtons
to select all images in the list
to unselect all images in the list
to invert selection of images in the list

To configure column representation in the table, set the relevant checkboxes in the
Images list window and click OK to close the Columns list window.

The following extra data can be represented in the system:
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• Sensor;

When creating an orthoimage in PHOTOMOD, AeroSensor values from the central projection
project images are recorded into the relevant cells of this column of the Images list window.

• Short earliest Date/Time (incl. for central projection images, if available);

• Short latest Date/Time (incl. for central projection images, if available);

• Long earliest Date/Time (incl. for central projection images, if available);

• Lost latest Date/Time (incl. for central projection images, if available);

• Off-nadir angle – off-nadir angle (in degrees);

Displayed in the Images list window by default – for scanner imagery.

• Viewing angle (incl. for central projection images, according to the adjustment results)

• Incidence angle;

• Cloud cover;

• Image ID (incl. for central projection images);

• Image type;

• Preproc level (see “Formats of satellite scanner images” in the “Creating project”
User Manual);

• Along track GSD;

Displayed in the Images list window by default – for scanner imagery.

• Across track GSD;

Displayed in the Images list window by default – for scanner imagery.

• GSD of source images;

A pixel size set when creating an input orthoimage (see Section 7.8) does not always coincide
with the real GSD of source images.
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• Catalogue ID;

• Remarks;

• Sun azimuth – the Sun angle at the moment of a survey;

• Sun elevation – the Sun elevation angle at the moment of a survey;

• Satellite azimuth;

• Satellite elevation;

• Adjustment step;

• Orientation model – for orthoimages created in PHOTOMOD from scanner images
(see “Adjustment of scanner blocks” of the “Block adjustment” User Manual).

7.9. Checking source project images

The system provides for checking source project images. The following parameters
can be checked:

• available image files (according to specified paths to these files);

• correct image formats and extensions;

• available georeferenced data (files).

To check project images, perform the following:

1. Choose Images › Check source images;

2. Wait for the operation to complete:

• [optional] If all project images have been verified, an appropriate info message
is issued:
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Fig. 12. An informational message

• [optional] If a part of the project images has not been verified, the following win-
dows are displayed in turn:

1. A dialog box informing about the number of images that have not been veri-
fied:

Fig. 13. A dialog box

○ [optional] Click Yes to delete images that have not been verified from the
project and proceed to the error window;

○ [optional] Click No, not to delete images and proceed to the error window.

2. The error window
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Fig. 14. An informational message

7.10. Replacing images

When processing a project, it may be necessary to completely or partially replace the
project images with their copies having identical names but located in a different folder
(in theWindows file system or in the active profile resources).

Project images can be located both in theWindows file system and in the active profile resources,
both in one folder and in several different folders. Cutlines can refer to images by the full path
to the image file (in theWindows file system or in the active profile resources) or by the image
name only.

If it is necessary to replace images in an already processed project, the following pro-
cedure is recommended:

1. Open the Image list window (see Section 7.8);

2. Delete the required images;

3. Add new images with the same names instead of the deleted ones. These added
images may have a different location;

4. To refer the cutline to the added image, select the required cutline and open the
Cutline info window (see Section 8.9). To disregard the image path and refer the
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cutline by image name only, set the Name only checkbox in the Cutline Info win-
dow.

It is strongly discouraged to create projects with non-unique image names. If there are
images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines.

8. Cutlines creation

8.1. Cutlines menu
Table 8. Brief description of the Cutlines menu

FunctionMenu items
to delete cutlines, i.e. to clear the Cutlines layer
completely (without closing of this layer)

Clear

to open cutlines saved earlier in vector file *.x-data
in active profile resources

Open

see “Import of vector objects” in the “Vectorization”
User Manual

Import

see “Export of vector objects” in the “Vectorization”
User Manual

Export

to setup parameters of automatic cutlines creation
and to start cutlines build operation, also in the dis-
tributed processing mode

Build...

to add areas to cutlines during their editing (see the
Section 8.7.1)

Area to cutlines addition mode

to save vector data file with cutlinesSave
to save cutlines in vector file *.x-data with new
name

Save as

to calculate useful areas in automatic modeUseful areas
to calculate cloudy areas in automatic modeClouds/Invisible areas
to control cutlines correctnessVerify
to redefine attributes of the Cutlines vector layerParameters
to view and edit attribute values of selected cutlineCutline properties
to split cutlines according to boundaries of created
sheets (see the Section 8.7)

Split cutlines into sheets

to attach vector polygons obtained from a third-party
source to project’s images according to their geo-

Reference cutlines to images

metric location for further use as cutlines (see Sec-
tion 8.10)
to create a new cutline as a small rectangle polygon
in the place of the node (the point where three or

Replace current node by new cutline

more cutlines converge). This polygon can be further
edited by the user
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If the vertices of adjacent cutlines located next to a node vertex are too close to it, then when
user tries to replace current node by new cutline, the appropriate error message is displayed:
Inserting cutline is too small. If this system message appears, manually delete the vertices
closest to the node and try to repeat this operation by clicking the button in the main toolbar.

8.2. Requirements of the cutlines creation

The stage of cutlines creation follows after the forming the block images of the mosaic
project.

Cutline is a vector polygon defining the images area, which will be included in output
mosaic.

Combination of automatic and manual cutlines creation, with clouds selection, optional use of
DEM, as well as definition of the cutlines type by attributes provide high quality the stitching of
the areas during the output mosaic creation.

In case of automatic cutline creation, the resulting vector layer is primarily available for collab-
orative editing by several users and has *.cx-data extension (see “Co-editing vector layers”
and “Co-editing topologically connected vector objects” of the “Vectorization” User Manual).

When copyingPHOTOMODGeoMosaic containing cutlines, it is important to pay special attention
to whether the vector data link to the project (see Appendix A). In case the appropriate
checkbox is set and cutlines (or other vector layers) from another project are used during the
current project processing, then when saving the project being processed, all the above vector
layers are saved as copies belonging with this project.

Performing the following steps is recommended for the cutlines creation:

1. [optional] Creating areas without background and areas with clouds.

2. Automatic cutlines creation (also in the distributed processing mode).

3. Editing cutlines: manual editing of vector polygons and their attributes in theCutlines
layer.

There are following rules to go by when creating the cutlines for building of the high
quality mosaic:

• cutlines should not have intersections and self-intersections. The common boundaries
of the neighbour cutlines should be fully correspond;

• I.e. all areas of the source images, outlined by cutlines, form one united coverage
without overlaps or gaps;

• It is not recommended to draw cutlines over elevated objects (bridges, buildings,
utility poles, etc), otherwise if the Seams feathering checkbox in the Mosaic para-
meters window in the Brightness adjustment tab is set on, the smearing effect is
possible;
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It is recommended to cross extended objects at right angle or create cutline not less than 1.5
cell size apart from extended objects border.

• it is recommended to create cutline parallel to brightness edge on enough distance
from it.

8.3. Creating areas without background (useful areas)

It is recommended to create areas without background before creating cutlines and set
the background transparency of source images.

Useful area contains substantial part of image and excludes input background of image.
Useful areas are vector polygons on the Useful areas layer.

Useful areas are used as well as setup of input background color transparency to create
cutlines.

There is no need to create useful areas prior to cutlines creation in the following cases:

• there is no background on images;

• manual editing (specification) of useful areas is not required;

• there is no need to select (create) cloudy areas on source images to consider them
during cutlines creation.

Useful areas creationmay exclude a necessity to setup transparency of input background
color.

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have x-feat
extension.

For useful areas creation use menu Cutlines › Useful areas.

Table 9. Brief description of menu ’Useful areas’

FunctionMenu items
to define parameters and calculate useful areas
automatically as vector polygons on theUseful areas
layer

Build

to clear Useful areas layer (without closing of this
layer); at that information about useful areas is not

Clear

deleted from files of images description *.x-feat,
that allows to restore created useful areas
to restore recently created useful areas if the Useful
areas layer was cleared using menu itemCutlines ›

Open
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FunctionMenu items
Useful areas › Clear, and then to display them in
the Preview window
to save useful areas in files of images description
*.x-feat after drawing them manually or editing
areas without background calculated automatically

Save

to completely clear the Useful areas layer without
possibility to restore the useful areas, i.e. to clear

Delete all

the layer along with deleting information in files of
images description *.x-feat
to delete useful areas, created for selected images,
along with information in files with images descrip-
tion *.x-feat

Delete for selected images

For automatic calculation of useful areas perform the following actions:

1. Choose Cutlines › Useful areas › Build. The Settings window opens.

Fig. 15. Useful areas parameters

2. [optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images;

3. Set the Image edges trim value to setup offset distance from background boundary
and the image substantial area (in pixels);
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4. Set the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created);

5. Image simplification, in pixels;

Preliminary simplification of images makes it possible to reduce the time spent on construct-
ing the boundaries of useful areas and reduce the number of their vertices, thus avoiding
unjustified complexity of their configuration.

Specific optimum values of simplification are to be chosen individually for each project,
depending on the project type and geometry of initial data.

It is not recommended to reduce default values for UAS and central projection projects,
that have quite large image overlapping.

When processing satellite scanner survey projects that have small image overlapping, re-
ducing this parameter can be feasible for the purpose of increasing the quality of boundary
construction.

When setting this parameter, it is recommended to take into account the previously set
Precision of calculation of areas boundaries (see above). The Precision and Image
simplification values that differ by several orders of magnitude, are not advisable

Preliminary image simplification before the construction of useful areas’ boundaries is
to be performed only if the unique background color checkbox is set (see above).

6. Set the Minimal components square to specify image area value, that will be
used as area minimal threshold for useful areas creation.

7. [optional] To calculate useful areas for selected images only, set on the For selected
images only checkbox;

8. [optional] Set the Force checkbox on to recalculate already calculated and restore
deleted useful areas. At that information in files with images description *.x-feat
also refreshed;

9. Click OK to calculate useful areas.

To use distributed processing in calculation of useful areas, perform the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system’’ User
Manual).

2. Click the Distributed processing button. The Distributed processing of
useful areas window opens.
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Fig. 16. Creating areas without background (useful areas)

The total Number of images in project displays in the window.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of useful areas creation will be divided.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

There is an example of automatic useful areas calculation:

1. Source image has black input background. There are areas with input background
color inside the image.
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Fig. 17. Source image

2. Set theUnique background color checkbox in the Parameterswindow to consider
’insets’ during useful areas creation.
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Fig. 18. Useful area in case of unique background color

3. Clear theUnique background color checkbox in the Parameterswindow to create
useful areas roughly, almost without considering ’insets’. Closed areas of black
color inside image are not considered as a background and are included to useful
area.

Fig. 19. Useful area in case of non-unique background color
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8.4. Clouds calculation

In order to calculate cloudy areas and exclude them during cutlines creation the system
provides possibility of their automatic recognition and calculation. Cloudy areas are
vector polygons on the Clouds/Invisible areas layer.

It is necessary to create useful areas prior to creating of cloudy areas.

The Cutlines › Clouds/Invisible areas menu is used to create cloudy areas.

Table 10. Brief description of menu ’Clouds/Invisible areas’

FunctionMenu items
to setup parameters and automatically calculate
cloudy areas as vector polygons on the Clouds/In-
visible areas

Build

to clear the Clouds/Invisible areas layer (without
closing the layer); at that information about clouds

Clear

is not deleted from files of images description *.x-
feat, that allows to restore created clouds
to restore existing clouds if the Clouds/Invisible
areas layer was cleared using menu itemCutlines ›

Open

Clouds/Invisible areas › Clear, and to display them
in the Preview window
to save clouds in files of images description *.x-
feat after editing of clouds calculated automatically
or after drawing them manually (see below)

Save

to save cloudy areas created just for selected im-
ages to files of these images description *.x-feat

Save for selected images

after editing of clouds calculated automatically or
after drawing them manually
to clear the Clouds/Invisible areas layer completely
without possibility of restoring cloudy areas, i.e. to

Delete all

clear the layer along with information deleting from
files of images description *.x-feat
to delete clouds created for selected images, and
to delete information from files of images description
*.x-feat

Delete for selected images

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have *.x-feat
extension.

The user cannot edit the Clouds/Occluded zones layer manually directly after project
loading, since this may lead to data loss in case if the *.x-feat file already contains
data on the areas containing clouds.
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To make this layer editable, either first Open the area data (or make sure that they are
absent after executing this command), Build areas with clouds again, or Delete all
relevant data from the *.x-feat file (confirming this action).

The mark near the Clouds/Occluded zones layer name means that this layer is not
available for manual editing at the moment.

Automatic clouds detection principle consists in search on image for bright enough and
homogeneous areas, where there is grey color with area not less then specified.

To calculate cloudy areas automatically perform the following actions:

1. Choose Cutlines › Clouds/Invisible areas › Build. The Clouds detecting para-
meters window is opened.

Fig. 20. Parameters of cloudy areas building

2. Specify the following parameters of automatic clouds detection:

• Brightness lower boundary – allows to define range of brightness for clouds
detection – to specify lower brightness threshold (from 0 to 100, where 100 –
maximal brightness), if the brightness is more that the threshold it is considered
as possible cloud;
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• Upper boundary of grey shift – allows to define maximal deviation from grey
color that present in clouds (from 0 to 100, where 0 – grey color, when R, G, B
values are equal);

• Upper boundary of heterogeneity – allows to define range of heterogeneity in
clouds – to specify maximal deviation from homogeneity (from 0 to 100, where
0 – homogeneous area);

• Dispersion upper boundary – allows to define range of dispersion in clouds –
to specify upper dispersion threshold (from 0 to 100);

• Clouds edges thinning – allows to define a degree of clouds boundaries thinning
(filtering of vector polygons vertices) from 0 to 100, where 0 – boundaries without
thinning; 100 – ’rough’ maximally filtered boundaries;

• Minimal cloud area – allows to define minimal area of cloud, when this area is
not considered as cloud, i.e. clouds of small size will be excluded from selection;

• Clouds offset – allows to setup offset in meters around the cloud detected (to
exclude shadow or half-transparent part of cloud).

3. [optional] To calculate cloud areas for selected images only, set on the For selected
images only checkbox.

4. [optional] Set on the Force checkbox to recalculate already calculated and restore
deleted cloud areas. At that information in files with images description *.x-feat
also refreshed.

5. Click OK to search and calculate cloudy areas.

To use distributed processing in calculation of cloudy areas, perform the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The Distributed processing of
useful areas window opens.
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Fig. 21. Creating cloudy areas

The Number of images in project field displays the number of source project
images.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of cloudy areas creation will be divided.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

8.5. Automatic mode of cutlines creation

The program provides opportunity to create cutlines in automatic mode with one of two
algorithms: Voronoy diagram, and more detailed algorithmwhich is specially recommen-
ded for images with urban or rural building.

Performing the following steps is recommended for the cutlines creation:

1. Use the fast Voronoy diagram method.

2. Estimate the results of cutlines creation.

3. [optional] Edit the cutlines in vector objects drawing mode, if necessary.

4. If the results are not acceptable apply detailed algorithm of cutlines creation.
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In this case cutlines are created bypassing separate objects (houses) and crossing roads
at the right angle.

Perform the following actions for automatic cutlines creation:

1. Choose the Cutlines › Build. The Cutlines creation parameters window opens.

Fig. 22. Parameters of automatic cutlines creation

2. In the Useful areas section choose one of the following options of using useful
areas during cutlines creation:
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• Not use – allows to not use useful areas, when the background is absent on
source images;

• Use – is used to use pre-created (automatically or manually) useful areas;

While creating cutlines considering useful areas it is not recommended to use orthoim-
ages with JPEG-compression.

• Build and use (by default) – allows to calculate useful areas automatically and
use these areas for cutlines creation.

Calculated useful areas don’t display in 2D-window and don’t save on the Useful areas
layer.

The Build and use mode is used by default if the assign automatically images back-
ground color was chosen.

3. [optional] In the Useful areas offset input field specify positive or negative value
of distance in meters to crop(-) or add (+) fields of working area, which is defined
by created useful areas.

TheUseful areas offset value should be much less than theMaximal shift from Voronoy
diagram parameter’s value.

4. In theClouds/Invisible areas section choose one of the following options of clouds
considering during cutlines creation:

• Not use (by default) – allows to not use cloudy areas;

• Use – is used to use pre-created (automatically or manually) cloudy areas;

• Build and use – allows to calculate clouds automatically and consider them
during cutlines building in automatic mode.

Calculated cloudy areas don’t display in 2D-window and don’t save on theClouds/Invisible
areas layer.

5. In the Attribute name input field specify the attribute name of the Cutlines vector
layer, where the full path to the image is stored (by default, image_name).

It is necessary to specify the attribute to perform automatic matching of the cutlines with
images prior to mosaics building, or for preview creation.

6. Check the Check clouds/invisible areas checkbox to exclude ’gaps’ in created
cloudy areas in output mosaic.
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The main idea of clouds check is, that the system tries to use reference image to replace
a cloud (entirely or partially) if the reference image does not contain the cloud in this place,
otherwise, the cloud will stay on the output mosaic.

7. In the Method section choose one of the following methods of automatic cutlines
creation:

• Fast (Voronoy diagram) – this method consists in splitting all the area of cutlines
creation into polygons based on proximity to nadir points or, if the latter are not
given, to image centers;

• Detailed – more ’fine’ algorithm for Voronoy diagram building, In this case edges
of Voronoiy’s diagram, belonging to two different images, are replaced by broken
lines, which provide optimal images joining.

○ Maximal shift from Voronoi diagram – at zero value you will get Voronoy
diagram, if the value is one – maximal area is used for cutlines creation. This
algorithm allows to calculate estimation function on images. Cutlines are created
on lines in such a way, that maximal value of this function on them is minimal
among all possible lines (minimax method).

• Images scheme – is a process where installation of source images without a
background is used for the first approximation of constructing cuts.

8. [optional] To exclude completely overlapping images from processing when
creating cutlines, set the appropriate checkbox;

Almost complete overlap of images can occur when working with data that have a high
degree of overlap and is due to the fact that when processing images, areas with a minimum
off-nadir angle are used whenever possible. If this checkbox is set, redundant images are
completely excluded from processing, what, in turn, helps to avoid unreasonably complicated
cutline configurations.

The redundancy of small cutlines may appear if, for some reason, only a small area of one
of the images is involved in processing. Such a situation may affect negatively the quality
of the output mosaic. Themaximumshare of the area of the region input field is to exclude
such images from processing, thereby optimizing the number of created cutlines

9. [optional] The system allows you to choose the project image pyramid level to be
used during cutline creation. Constructing cutlines using less detailed versions of
images can significantly increase the system’s performance (due to a noticeable
decrease in the quality of constructing cutlines, which occurs with a high degree of
probability);

10. [optional] Specify the Thin out precision the appropriate input field;

At first, cutlines are created with sub-pixel accuracy (taking into account the pyramid level
of images the user selected for cutline construction; see above). Further, the vertices of
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overdetailed cutlines are thinned out. The Thin-Out Precision is the maximum distance
(a perpendicular) from the initial cutline fragment to the unit segment of the output polygon
that approximates it (in the current project units of measurement).

11. In theUse central points section define location of images centers which are used
for Voronoy diagram creation:

• Nadir points (recommended if any);

• Images centers considering or not images background.

The Centers of images without background checkbox allows not to consider images
background when use centers of images.

12. [optional] In the Create cutlines not closer than [ ] m from useful areas edge
input field specify minimal distance in meters from working area boundary to create
cutlines, if source images have small overlap.

13. [optional] Open theAdvanced parameters tab to set the parameters of the detailed
algorithm (see above).

Fig. 23. Detailed method cutline creation parameters

Setup the following additional parameters:

• Weight of objects outlines – allows to avoid separate objects (houses) during
cutlines creation or to cross them at the right angle (in case of roads);
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• Weight of images heterogeneity – allows to avoid small cities and settlements
during cutlines creation, including also urban blocks, since at certain pixel size
settlements look more heterogeneous, comparing with forested areas, agricultural
fields, etc;

• Weight of images correlation – the bigger the differences in vicinity of pointon
adjacent images, the bigger this component for each point;

• Weight of images brightness – is used for cutlines creation in darkened areas
of images, where human eye is less receptive to images inconsistency;

• [optional] The Use DEM checkbox allows us to take into account the terrain relief
when creating cutlines (if available).

○ DEM weight – the greater the weight of the DEM, the better the cutlines wrap
around the objects displayed on DEM.

It is recommended to be used for the imagery of highlands for creating cutlines taking
into account lowlands, but not mountain peaks. It is also recommended in case of
presence of buildings in the imagery to create cutlines between houses (if the buildings
are displayed on DEM).

14. Click OK to start process of cutlines creation.

To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system’’ User
Manual).

2. Click theDistributed processing button. TheCutlines distributed processing
window opens.

Fig. 24. Cutlines distributed processing parameters

3. Define the maximum number of parallel tasks – the tasks number on which
the process of cutlines creation will be divided.

4. Click OK to create distributed processing tasks.
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The vector polygons are created in the Cutlines layer after the process completion.
Created cutlines are displayed in the Preview window.

15. [optional] if necessary, edit parameters and start automatic procedure of cutlines
creation and/or edit cutlines manually considering recommendations to cutlines
creations.

16. Choose the Cutlines › Save to save the created cutlines in the *.x-data files of
the active profile resources.

Choose the Vectors › Export to export the cutlines into other formats (see the
“Vectorization” User Manual).

8.6. Cutlines creation control

The program provides possibility to find and display errors of cutlines creation. The
special coverage maps are used for that. These maps are vector layers with polygons,
that display the following potentially problematic areas:

• Totally cloudy areas on the project images, that may lead to the appearance of “gaps”,
after the cutlines creation;

• The existing “gaps” in the current cutlines;

• The cutlines out of the useful areas.

The cutlines creation control instruments are located in Cutlines › Verify submenu.

Table 11. Brief description of the Verify menu

FunctionMenu items
to check correspondence between cutlines and im-
ages of a project in order to find images without

Assigning to images

cutlines and/or cutlines which are not attached to
images
to find the errors of cutlines creation and build the
“gaps” map

Topology

to find the cutlines out of the useful areas and build
an appropriate map

Out of the useful areas

to find areas with full clouds coverage and build the
potential “gaps” map

Cloudless / visible area

8.6.1. Checking correspondence between cutlines and images

Cutlines › Verify › Assigning to images – is used for checking correspondence
between cutlines and images of a project in order to find images without cutlines and/or
cutlines which are not attached to images or to remove images.
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When the check is complete, an appropriate info message is issued that displays the
number of images without cutlines and the number of cutlines not associated with im-
ages.

Fig. 25. The information window

If any are detected, after the above information window is closed by the user, the Pre-
view window automatically opens, where, in the Cutlines layer, the system will highlight
all detected cutlines that are not associated with images.

For easier search of cutlines not associated with images in the Preview window, make the
Cutlines layer active and, without deselecting the automatically selected objects in this layer,
selectWindows › Objects list.

In theObjects listwindow that opens, set theOnly selected checkbox and click . As a result,
theObjects listwindow will display the list of found cutlines that are not associated with images.
Clicking the left mouse button on the appropriate line in the table in the Objects list window
allows you to move the cursor in the 2D window to the area of the appropriate cutline.

8.6.2. The cutlines errors coverage map

To find errors in cutlines, choose Cutlines › Verify › Topology. The system displays
window which contains information about the quantity of topological errors in cutlines
creation:

57

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Fig. 26. No errors found in current cutlines

TheCutlines coverage map layer is created. The layer contains the images block border
and, optionally, polygons that mark the “gaps” in cutlines. These polygons have a red
fill and hole label.

Fig. 27. The “gaps” in cutlines
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8.6.3. Cutlines out of the useful areas coverage map

To find the cutlines out of the useful areas, choose Cutlines › Verify › Out of the
useful areas. The system displays window which contains information about the
quantity of such errors in cutlines creation:

Fig. 28. The information window

The The out of useful areas layer is created. The layer contains the images block border
and, optionally, polygons that mark the “gaps” in cutlines.
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Fig. 29. The project with incorrect input data and inaccurate cutlines

Fig. 30. The polygons that display the cutlines parts out of the useful areas (marked by blue)
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8.6.4. Cloud coverage maps

Perform the following to find areas with full clouds coverage on images:

1. Choose the Cutlines › Verify › Cloudless / visible area. The Cutlines creation
parameters window opens;

2. Choose the Build and use in the Clouds/Invisible areas section and setup the
rest parameters if necessary;

3. Click OK. Wait until the operation is complete. The system displays the window
which contains information about quantity of areas with full cover of clouds:

Fig. 31. The information window

4. The Cloudless coverage/Visible areas map layer is created. The layer contains the
images block border and, optionally, polygons that mark the areas with full clouds
coverage. These polygons have a red fill and hole label:
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Fig. 32. Totally clouded areas

8.7. Editing cutlines

The following options are provided for cutlines editing:

• to delete all cutlines, i.e all vector objects from the Cutlines layer, choose the Cut-
lines › Clear;

• to edit cutlines manually is used the standard tools of Vectorsmenu (see the “Vector
objects editing”, “Topological operations” and “Co-editing topologically connected
vector objects” chapters in “Vectorization” User Manual);

If new cutline creates manually it is assigned that image, the center of which is the closest
to the created cutline.

• the Vectors › Topology › Verify topologymenu item is used for verify topology (see
the “Vectorization” User Manual);

See also Section 8.6.2 of current manual.
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• to create a cutline inside an existing cutline are used modes which could be switched
on the Cutlines type additional toolbar.

The buttons of the Cutlines types additional toolbar are used to choose the type of
cutlines:

○ Image – to use main image in cutline area;

○ Transparent with reference image – to use reference image in cutline area
(by default it is supposed to use a nearby image into the cutline area);

○ Background – to use the output mosaic background color in cutline area, which
sets in the Parameters window (see the Section 13.2);

The system also enables using background color beyond cutlines of the Background
type. To do this, set the Fill background color outside “Background” cutlines checkbox
in the Geomosaic tab in the Settings window (Service › Settings).

○ Transparent without filling – to use transparent without filling in cutline area.

• the Cutlines › Split cutline into sheets menu item allows to split cutlines into poly-
gons by sheets’ borders. Polygons are saved in a new vector layer and contain all
citline’s attributes.

To use this function it is required to create or load into project both cutlines and sheets.

• Cutlines › Replace current node by new cutline – to create a new cutline as a
small rectangle polygon in the place of the node (the point where three or more cutlines
converge). This polygon can be further edited by the user.

If the vertices of adjacent cutlines located next to a node vertex are too close to it, then when
user tries to replace current node by new cutline, the appropriate error message is dis-
played: Inserting cutline is too small. If this system message appears, manually delete the
vertices closest to the node and try to repeat this operation by clicking the button in the
main toolbar.

8.7.1. Including regions into cutlines mode

The system provides for quick manual cutline editing. The feature of this method is that
there is no need for manual editing (including, removing, or moving) of each vertex of
a cutline under processing. The system allows the user to quickly specify the desired
shape of edited cutlines, after which it automatically rebuilds these objects.

The main scope of this tool is to change the configurations of adjoining segments of
adjacent cutlines. Such a needmay arise, for example, if adjoining segments of cutlines
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(built automatically) intersect any one-piece object (for example, a building) in project
images. In this case, it would be most practical to merge the “boundary” created by
cutlines with the boundaries of the object itself, thus leaving it within a single cutline.

For this, perform the following:

1. Make the Cutlines layer active;

2. Click in the main toolbar, to enable the mode to include a region into a cutline
(or choose Cutlines › Include regions into cutlines);

3. ChooseWindow › Toolbars › Tools;

4. Click in the Tools bar that opens;

5. Create a freeform polygon by holding down the Shift key, sequentially moving the
cursor in the 2D window work area, and clicking the left mouse button. The created
polygon must meet the following conditions:

• The first polygon vertex is to be within the so-called parent cutline, whose
boundaries are supposed to be expanded by changing the configuration of adja-
cent segments;

• The polygon must intersect the editable “boundary”, covering areas of at least
two vector polygons created by the editable cutlines.

The created polygon is visually displayed using black boundaries and a dark fill.
To complete the creation of a polygon, set the last vertex of the polygon by double-
clicking the left mouse button. Press Esc to delete the last created vertex. After
completing the creation of the polygon that defines the new cutline shape, the edited
cutlines are automatically rebuilt.

Fig. 33. Creating a polygon that defines the nature of changes in the configuration of adjacent
segments of neighboring cutlines

Cutline rebuilding operations can be cancelled using the Undo Log (see “Undo editing
operations” in the “Vectorization” User Manual).
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For this operation, the rectangular marquee tool can also be used (the button in the
Tools bar).

The above guide and the illustration describe the most obvious common use of this
tool. When editing more than two cutlines (or cutlines with a more complex initial shape)
using this tool, note the following:

• The results of the operation depend on the number of cutlines involved, their initial
relative position, as well as on the shape and size of the polygon that determines
their new configuration;

• In any case, the change in the mutual configuration of the cutlines is carried out by
increasing the “parent” cutline, which, in turn, is determined by the location of the first
vertex of the polygon created in the Include regions into cutlines mode;

• Small cutlines that are completely covered by a user-created polygon (i.e., falling
entirely within the “expanding” cutline) will be “absorbed” by this cutline (deleted).

8.7.2. Intersection of polygons with the same name

The system provides for creating a polygon that describes the area of intersection of
two other polygons located in different layers and having the same values of the selected
attribute.

For this, perform the following:

1. Create or load two layers with vector polygons (cutlines). The layers must contain
intersecting 2D polygons having the same attributes (the same names and equal
values);

2. Make one of those layers editable;

3. Choose Vectors › Attributes › Intersection of corresponding polygons. The
Layers selection window opens:

Fig. 34. The Layers selection window
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4. Select the second layer that contains the above polygons;

5. Enter polygon attribute name;

6. Click OK. After the operation is complete, an info message on the number of objects
created in the new vector layer appears.

The polygons created describe the areas of intersection of parent polygons from
different layers. They are also assigned the attribute of the parent objects used
during the operation.

8.8. Cutlines attributes

The attributes of the Cutlines layer extend the capabilities of editing cutlines. Basing
on the attributes, the cutline gets the name and type (see also the “Vector objects attrib-
utes” chapter of the “Vectorization” User Manual).

In the case, where the imported objects have another attributes, the capability of setting
attributes provides the correct import of cutlines, created in third party software.

By default, the Cutlines layer has following attributes used to store information about
cutlines:

• image – attribute for full path to image file;

• image_title – attribute for cutline name (equal to image name – source or reference
image);

• rgn_type – the cutline type attribute;

• ref_image_name – the filename of reference image attribute, used in the cutline area.

For editing the Cutlines layer attributes perform the following:

1. Choose the Cutlines › Parameters. The Cutlines parameters window opens.

Fig. 35. Cutlines parameters
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The default attribute name is displayed in the Attribute with cutlines name list.

2. To edit attribute choose attribute name from the list or click the button to add
new attribute. Input the name of new attribute and click OK.

3. [optional] Set on the Reference by image name only checkbox to comparison
cutlines only by image name, not by path.

To set these parameters for a single cutline, select the required cutline and open theCutline
info window (see Section 8.9). To disregard the image path and refer the cutline by image
name only, set the Name only checkbox in the Cutline info window.

Editing of vector layer attributes, including editing of attribute name and attribute deleting
are used in cutlines import. Choose the Vectors › Export to export the cutlines into other
formats (see Vectorization User Manual).

It is strongly discouraged to create projects with non-unique image names. If there are
images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines

Perform the following actions to view and edit attributes of the Cutlines layer and attrib-
utes values of selected cutline:

1. Select a cutline in the Preview window.

2. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

Fig. 36. Cutlines attributes

The following buttons are used to create and edit attributes table:

• – allows to delete all attributes of selected objects;

• – allows to delete common attributes of selected objects;

• – allows to open the Add attribute window to define name, type and value
of attribute;
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• – allows to delete current field of attribute table;

• – allows to open the Edit attribute window to edit parameters of selected at-
tribute;

• – allows to sort attributes of selected objects;

• – allows to invert attributes of selected objects.

Attributes may have the following values:

• for image – full path to main image file;

• for image_title – cutline name (is automatically generated from name of file with
source image);

• for rgn_type – cutline type:

○ 1– complies to the Image type;

○ 2 – complies to the Transparent from reference image type;

○ 3 – complies to the Background type;

○ 4 – complies to the Transparent without filling type.

• for ref_image_name – full path to reference image file, providing that the cutline
type is the Transparent from reference image, i.e.rgn_type = 2.

3. Double-click the string of the Value input field and insert another value for changing
of attributes value.

4. Press Enter to save or press Esc to cancel.

8.9. Cutlines info

To view and change information about several cutlines perform the following:

1. Make the Cutlines layer active.

2. Select a cutline in the Preview windows.

3. Choose Cutlines › Cutline properties. The Cutline info window opens.
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Fig. 37. The information about cutline

4. In the Main image field (corresponds to the image attribute value) shows full path
to file of main image, for which the cutline was created. To edit the field value open
the list and select another image of the project.

To return to current main image click the button. To clear the list click the button.

5. Choose one of the Cutline type from the list corresponds to the rgn_type attribute
value):

• Image to use main image in area of cutline;

• Transparent from reference image to use reference image (fallen into cutline
area) in area of cutline specified in the Source image field;

• Background to color the cutline area with output mosaic background color (see
Section 13.2.2), that is used for coloring of any terrain objects on images;

• Transparent without filling to apply transparency to the cutline area.

To clear the list click the button.

6. [optional] In the Source image (corresponds to the ref_image_name attribute value)
shows full path to file of reference image (fallen into cutline area), if the image is
used for the cutline with the Transparent from reference image type. In order to
select a reference image use a list of project images.

To clear the list click the button.
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7. [optional] To use only the image name (without considering the full path to the image)
for referring the image to the cutline, set the Name only checkbox..

To refer all project cutlines by image name only, set the Reference by image name only
checkbox in the Cutline attributes window (see Section 8.8).

The need to consider only the image name may arise, for example, when project images
are partially replaced by copies with the same names located in a different folder (see
Section 7.10).

It is strongly discouraged to create projects with non-unique image names. If there are
images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines.

8. Click the Apply button to apply changes.

8.10. Using external vector polygons

The system provides for using cutlines of image type ( , see Section 8.7) created in
third-party programs. GeoMosaic can attach third-party vector polygons that have no
attributes to project’s images according to their geometric location for further use as
cutlines.

For this, perform the following:

1. Import third-party cutlines into the PHOTOMOD resource system (see “Import of
vector objects” in the “Vectorization” User Manual);

Imported vector objects are to be polygons.

2. Load these objects as cutlines from *.x-data file in the active profile resources
(see Section 8);

3. Choose Cutlines › Attach cutlines to images;

4. After operation completion, check the values of these objects’ attributes (see Sec-
tion 8.8);

5. Save data.

9. Brightness adjustment
The system allows to adjust brightness and contrast features of cutlines areas during
their merging (the global and local brightness adjustment of output mosaic) and options
of smoothing areas along cutlines, to create uninterrupted mosaic image.
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To do so, the Brightness adjustment tab of the Mosaic settings window is used.

Global brightness adjustmentmeans transformation equally applied to all pixels of each source
image (see Section 9.1).

Local brightness adjustment is a transformation applied along cutlines of images that are merged
into mosaic with a smoothing going down to the image central point and mosaic edges. Pro-
cessing of each pixel during the local brightness adjustment depends on its coordinates (see
Section 9.2).

To perform the brightness adjustment of output mosaic do the following:

1. Select Mosaic › Parameters. The Mosaic parameters window opens;

2. In Mosaic parameters window open the Brightness adjustment tab;

3. [optional] set the global brightness adjustment parameters;

4. [optional] set the local brightness adjustment parameters;

5. [optional] set the general parameters of brightness adjustment;

6. [optional] set the parameters of smoothing areas along cutlines;

7. Click OK to save all the parameters set in the Brightness adjustment tab;

8. SelectMosaic › Brightness adjustment or click the button on the main toolbar
to rebuild brightness adjustment for all block scheme.

If after cutlines editing you need to rebuild brightness adjustment, choose theMosaic ›
Brightness adjustment.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to rebuild brightness adjustment using distributed processing:

1. Set the brightness adjustment parameters in the Brightness adjustment tab of
the Mosaic settings window and click OK;

2. Click the button on the main toolbar;

3. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

4. Choose Mosaic › Distributed global brightness adjustment. The Brightness
adjustment distributed processing window opens.
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Fig. 38. Brightness adjustment distributed processing parameters

The total Number of images in project displays in the window.

5. Specify Number of tasks for processing, which are processed by one computer.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

6. Select the Temporary folder for distributed processing in the resources of active
profile for temporary data storing.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

8. After the end of distributed processing click the button on the main toolbar to
reopen the mosaic project from active profile resources.

To clear all data about brightness adjustment choose Mosaic › Clear brightness ad-
justment.

The system does not allows for mosaic brightness adjustment when building a mosaic in the
distributed processing mode ( ), nor in the mode of MegaTIFF distributed processing ( ).
Herewith, brightness adjustment can be a part of the process of mosaic building in the normal
course ( ).

Building a mosaic in the distributed processing mode ( ) is available either for projects with
previously performed brightness adjustment, or if brightness adjustment is disabled when setting
mosaic parameters (i.e. brightness adjustment is not included in the list of tasks to be executed
when building a mosaic in the distributed processing mode). Otherwise the system gives the
following warning:
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Fig. 39. A warning when starting distributed processing

In case of this warning, to start distributed processing, perform the following:

• [optional] make brightness adjustment previously and save the project ( );

• [optional] disable brightness adjustment previously in the Mosaic parameters window:

○ In the Mosaic parameters window, Brightness adjustment tab, Global adjustment
section, choose None;

○ In theMosaic parameterswindow,Brightness adjustment tab, Local adjustment section,
clear the On checkbox.

73

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



9.1. Brightness adjustment parameters

Fig. 40. Brightness adjustment parameters

The Use brightness pre-correction checkbox allows to consider preliminary BCG-
correction of source images while output mosaic is created.

Brightness pre-correction does not consider in case of any method except None was chosen
in the Global adjustment section.
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It is recommended to set on the Use brightness pre-correction checkbox if there are a lot of
cloud areas on scanner images.

In theGlobal brightness adjustment section choose the way of the brightness adjust-
ment for all block:

• None – allows to use images without adjustment;

• By average brightness – allows to apply brightness adjustment using average images
brightness;

At that brightness and contrast of all images are set to values, found using averaging of
brightness and contrast values calculated over all mosaic images. This method is recommen-
ded when there are big differences between brightness’ of images, but each of them contains
relatively smooth scenes.

It should be noted that in case of scenes with sharp different brightness within one image
(for example ’sea’ and ’coast’) this method may produce incorrect brightness adjustment
results.

• By project image – allows to apply global adjustment by project image: histograms
of mosaic images are corrected in accordance with chosen project (’reference’) image.
To select the reference image is used the button;

It is recommended to use image located in the middle of images block as a reference. It is
not recommended to use this method in case of abnormal local brightness fluctuations
(’trends’) on images, since in this case you can face a problem of smooth increasing or redu-
cing of the brightness and contrast from the reference image to the block edges right up to
complete ’lightening’ (’blackening’).

The system allows to adjust brightness by several reference images (located in different parts
of the mosaic) what can be useful when processing projects containing large number of im-
ages.

To select the reference image is used the button in Images list window. For correct
brightness adjustment using one or more reference images selected in the Images listwindow,
select the By average brightness adjustment in the Global adjustment section.

• By image file – allows to apply global brightness adjustment using brightness from
chosen file. Histograms of mosaic images are corrected in accordance with chosen
image file. To load image is used the button.

The button serves for background color transparency setting for the selected image. For
example, if the image background is black, it is required to select black color in the opened
Color window. The button allows to clear background color transparency settings for the
selected image.

• By overlapped areas – allows to apply global brightness adjustment by overlapping
images. To set the adjustment parameters, use the button.
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Fig. 41. Brightness adjustment parameters (by overlapped areas)

○ Use statistic of overlapped areas with weight – allows to take into account (with
preassigned weight) brightness of the images’ overlapping areas during global
brightness adjustment;

○ Use statistic of entire images with weight – allows to take into account (with
preassigned weight) brightness of every entire image during global brightness ad-
justment;

If the images’ brightness in a block significantly differ, it is recommended to set a small
value.

○ Fix average brightness – allows to save average brightness of images in block
after global brightness adjustment;

○ Fix outline images with weight – allows to save (with preassigned weight)
brightness of images on the block borders;

○ Fix etalon images with weight – allows to save (with preassigned weight)
brightness of reference (etalon) images;

TheMatch histogram checkbox allows to apply full (non-linear) brightness adjustment
with histogram matching. Otherwise only mean of distribution and standard deviation
are matched.
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Set the On checkbox in the Local adjustment to apply local brightness adjustment
along cutlines of images that are merged into mosaic. If you would like to specify local
brightness adjustment parameters click the Parameters button (see Section 9.2).

Also set up the following general brightness adjustment parameters:

• Brightness adjustment cell size – allows to specify a size of a cell (in pixels), which
is used for brightness estimation and correction;

• Do not use excluded areas for global adjustment – allows to apply global adjust-
ment in mosaic areas, defined by vector polygon’s edges;

Vector polygons should be stored in file in active profile resources. The button allows to
open file with polygons. The button allows to choose another file, instead the opened.
The button allows to remove the selected file from the list. The button allows to remove
all the files from the appropriate list. The button allows to display the selected layer of
vector polygons in both the Layers Manager and in a 2D window.

• Do not use excluded areas for local adjustment – allows to apply global adjustment
in mosaic areas, defined by vector polygon’s edges;

Vector polygons should be stored in file in active profile resources. The button allows to
open file with polygons. The button allows to choose another file, instead the opened.
The button allows to remove the selected file from the list. The button allows to remove
all the files from the appropriate list. The button allows to display the selected layer of
vector polygons in both the Layers Manager and in a 2D window.

• Use clouds – allows to consider areas with clouds in brightness adjustment;

• The Additional check for black background checkbox allows to make the areas
of source imagery with black background transparent in the output mosaic;

Due to the peculiarities of preprocessing, some satellite images can have two background
colors at the same time (black and the second one is arbitrary), which must be taken into
account during processing. For correct processing of such images (to take into account the
black background color), set the Additional check for black background checkbox.

To take into account the arbitrary background color of source images, choose the Images ›
Project images list or click the button on the main toolbar. The Images list window
opens. Select the images to define the images background color and click the button (see
detailed description in Section 7.5).

• The Local adjustment of active sheets checkbox allows to apply brightness adjust-
ment only to images, located on active mosaic sheets.

Set this checkbox on only if distributed processing without saving adjustment parameters
was performed. In this case number of tasks should be equal to number of active sheets.
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For seams feathering set on the appropriate checkbox and define the following para-
meters in the Smooth parameters section:

• Smooth aperture size – allows to define the size of smoothing zone along cutlines;

• Consider image edges when use feathering – allows to smooth seams on the
edges of images block, where may be no statistics enough for correct smoothing.

• Smoothing with round aperture – allows to turn on the mode of pixel-by-pixel
smoothing along cutlines.

Using this function results in increasing of time required for rebuilding brightness adjustment.

Set this checkbox if the results of smoothing along cutlines are not satisfactory, especially in
case of the presence of large water-tables in the project.

Fig. 42. Smoothing with round aperture is not applied to the area (water-table) (left) and smoothing
with round aperture is applied to the area (right)

9.2. Local brightness adjustment parameters

Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges. Thus during local brightness adjustment each pixel of the image is pro-
cessed depending on its coordinates. At that the program performs simultaneous change
of brightness (additive component) and contrast (multiplicative component) of initial
images.

For preliminary estimation of local brightness adjustment choose the Misc › Local ad-
justment. In the Preview window you will see a grid of fragments (rectangles), used
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for statistics collection for local brightness adjustment. The fragments are vector objects
located on the Miscellaneous layer.

The brightness adjustment rebuilding ( ) should be already performed. TheOn checkboxmust
set beforehand (the Local adjustment section in theBrightness adjustment tab of theMosaic
parameters window).

Rectangles have the following colors depending on area, which is used for statistic ac-
quisition:

• green – to obtain statistic between images;

• blue – to obtain statistic between strips;

• red – to obtain statistic on mosaic edges;

• yellow – to obtain statistic inside of separate images.

The program provides possibility to edit grid of fragments as vector objects on the
Miscellaneous layer (see the “Vectorization” User Manual).

Fig. 43. Preliminary estimation of local brightness adjustment

To set the parameters local brightness adjustment you should perform the following:

79

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1

vectorization.pdf


1. Choose the Mosaic › Parameters. The Mosaic parameters window opens.

2. Click the Brightness adjustment tab. In the Local adjustment section set theOn
checkbox and then click theParameters button. The Local adjustment parameters
window opens.

Fig. 44. Local brightness adjustment parameters

3. Define images Number of fragments used to create a model of local brightness
adjustment.

In case of color difference inside one fragment in nearby images inconspicuous or homo-
geneous along the cutline, only one fragment is enough to collect statistics.

In case of color difference inside one fragment between images remarkable or heterogen-
eous, it is necessary to increase number of fragments to consider brightness change.

In case of increasing number of fragments, number of pixels in each fragment hold constant.
In this case image from one layer of pyramid is used for brightness adjustment. In case of
increasing number of fragments, brightness adjustment perform more precise, but slower.

4. Set the Inner points – number of points inside image and on mosaic edges, where
brightness should not be changed.

Insufficient quantity of these points leads to creation brightness artefacts while distance
from cutlines. Quantity over leads to unacceptable results of local brightness adjustment
along cutlines.

5. [optional] If errors in contrast of source images leads to not enough adjustments
quality or to errors in local brightness adjustment, increase theContrast coefficient
value from 2 to 7 for better results.

6. Set the Density coefficient – a thinning ratio for the grid of fragments (rectangles)
on mosaic edges (marked red in the illustration above).
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The thinning ratio in the picture is equal to one (the fragment grid is not thinned). The re-
commended Density coefficient value is 2.

7. [optional] In case if not enough statistic data for local brightness adjustment, program
provides possibility shift of fragment’s grid relative to cutlines. For this set on the
Search additional fragments with 50% overlapping checkbox.

8. [for scanner images with small overlaps] In case of small overlaps, cutline could be
located too close to edge of image, so image background is include to cutline area.
In this case set the Minimal valid part in fragment – minimal part of image in
fragment, when statistics data is collected.

9. Click OK.

Fig. 45. Area without local adjustment
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Fig. 46. Area with local adjustment

9.3. Dodging

Dodging – means brightness adjustment of the single image.

To employ this function you should perform the following:

1. Select Images › Project images list... or click button. The Image List window
opens.

2. Select the image you need to transform in Image List window and click the
button. The Radiometric correction window opens.

3. Click the button in Radiometric correction window. The Filters menu opens.
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Fig. 47. The filters menu

4. Choose the Dodging filter, set aperture size and filtering level.

Recommended filtering level – 100%.

5. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

• Background color – value of background color;

If the 0 value is set in the Background color field, background also will be changed
during the correction.

• Tolerance – deviation from background color value.

6. Click OK.

10. GC/tie points

10.1. General information

You may use GC/tie points to transform the project images, which, if applied correctly,
allows for more accurate alignment of photomosaic elements with each other. The
parameters for transforming images under the influence of triangulation points are
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configured by the user in the GC/tie points tab of theMosaic parameters window (see
Section 13.2.4).

Using GC/tie points is not a mandatory stage of project processing and is generally not
required when using correct and homogeneous input data. It is recommended to use
this tool with some degree of caution, only in cases where it is really necessary to
achieve the desired results.

The choice of the types of triangulation points used, as well as the method and degree
of their influence on the images, is determined by both the characteristics of the input
data and the requirements for the output mosaic. When using several types of triangu-
lation points together, it is necessary to constantly take into account that the final
transformation of the image is determined by the integrated influence of all existing
points. Accordingly, the processing of the project is affected by the order of entering
points of certain types, their mutual arrangement, and the settings currently in effect.

In any case, the use of GC/tie points causes the transformation of the mosaic’s images,
which, in general, is a troublesome aspect and may have a negative impact in the future,
for example, if it is necessary to re-process previously created mosaics (a common
situation is the correction or updating of any local areas of the mosaic that were previ-
ously changed because they fell into the zone of influence of the points).

GeoMosaic involves the following types of triangulation points:

• Ground control points – points with known geodetic coordinates that can be measured
by the project images in case of available ground control data. Images are transformed
according to the user-defined parameters.

Optionally, they are used for primary control, for example, if it is necessary to construct
(or, more often, re-construct) a mosaic using inhomogeneous materials obtained in
different times from different sources.

To enable/disable using of ground control points, click the button in main GeoMosaic
toolbar.

• Tie points are the same point locations in overlapped images. Measuring tie point
coordinates involves establishing a connection between the same point on the ground
in two (or more) source mosaic project images in the vicinity of cutlines.

Those points are the main (and often the only necessary) photo control instrument,
solving the most frequent problem of more accurate aligning of images’ sections in
the vicinity of cutlines. Tie points also change images according to the user-defined
settings.

Tie points are solely used for transforming source images exactly close to cutline. It is not
recommended to measure the tie points far away from the cutlines to avoid the rough trans-
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formation of images. Also, it is not recommended measuring points on the extended objects
(for example, on the roads), buildings and low-contrast areas.

To enable/disable using of tie points, click the button in main GeoMosaic toolbar.

• Synthetic point are a highly specialized type of points used by PHOTOMOD GeoMo-
saic and are used only in special cases (for example, when it is impossible to use
reference data and/or when processing a project containing images with significant
distortions, which are caused, for example, by mountainous terrain).

Unlike GCPs or tie points, which transform an image according to the settings specified
in the GC/tie points tab of the Mosaic parameters window, synthetic points allow
you to shift an entire image manually according to the shift direction and range of the
synthetic point created in advance by the user.

Manual image shift allows you, first of all, to achieve its visual correct arrangement;
for example, correctly align elongated objects (rivers, roads, etc.), especially when
the appearance of the resulting mosaic is the most important.

Thus, synthetic points are partly, very conditionally, similar in purpose to GCPs, but,
unlike “real” GCPs, they cannot improve the accuracy of the output data. Synthetic
points affect the location of images only when the Using of ground control and
synthetic points checkbox is set (see Section 13.2.4).

Correct shifting of an image, in exact accordance with the direction and range of displacement
of the synthetic point, is possible only in the case of no influence on the image from other
points—synthetic, GCPs, or tie points.

Therefore, the most optimal scenario for using synthetic points is their separate (or primary)
use, with subsequent measurement of points of other types, for example, tie points (see below).

To enable/disable using of tie points, click the button in main GeoMosaic toolbar.

Depending on the nature of the input data and the user’s goals, the following, to a certain
extent conditional, scenarios for using GC/tie points are possible:

• Primary creation of GCPs, followed by measuring the tie points, for more correct
alignment of the areas of the images near the cutlines;

• Using only tie points, which may be sufficient in many cases;

• Use of synthetic points for visual alignment of images, with possible further measure-
ment of tie points, depending on the tasks at hand.
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10.2. Ground control and tie points layer

The Ground control, tie and synthetic points are displayed in Ground control and tie
points vector layer. The points data is stored in the vector objects additional attributes
(see Section 10.2.1). In order to obtain the brief information about triangulation point,
select the point on editable layer Ground control and tie points (or in Points catalog
window table) and click the button in Points catalog window toolbar.

In the opened Orthorectification statistics window you can see the following data:

• point’s name (with tie prefix for tie point, gcp for GC point and synthetic for the
synthetic point);

• number of images where the point is measured;

• path to file of each image where the point is measured.

Fig. 48. Brief information about ground control point

10.2.1. Attributes of Ground control and tie points layer

After tie/GC point measuring the information about measured point is saved to attributes
of the Ground control and tie points layer.

This functionality is intended for viewing information about a point only. Change of points’ attrib-
utes is strongly discouraged. The appropriate tools for work with triangulation points are intended
for editing points (see Section 10.3).

To view point’s attributes data perform the following actions:

1. Make the Ground control and tie points layer editable.

2. Select a point in the Preview (or Points catalog) window by mouse clicking.

3. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window is open.
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Fig. 49. Tie point attributes

Point’s attributes contain the following data:

• tie_type – contains information about type of point (with 0 value for tie point, 1
for GCP and 2 for synthetic point);

• points_name – contains a name of point (with tie prefix for tie point, GCP for GCP
and synthetic for synthetic point);

• image_count – shows a number of images where the point is measured;

• image_name_image_number – contains a path to one of the image files where
the point is measured;

• image_x_image_number – contains X-coordinate of the point on one of the im-
ages;

• image_y_ image_number – contains Y-coordinate of the point on one of the im-
ages;

• OriginX – contains X-coordinate of the point;

• OriginY – contains Y-coordinate of the point;

• [for points found with correlator] corr_coeff – correlation coefficient of point.

10.3. Triangulation points management instruments

The list of triangulation points (GCPs, tie and synthetic points) is displayed in the Points
catalog window. GCP ant tie point coordinates are measured in the Points measure-
ment window. The reference image (or web map) is loaded into the Reference map
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window. This window is used to measure GCPs together with the Points measurement
one.

The program provides three modes of tie/GCPs measurement:

• Manual mode measurement of points without correlator;

• Semi-automatic mode measurement of points using correlator;

• Automatic mode measurement of points using correlator.

The separate correlator parameters sets are used for measurement ground control/tie
points with correlator in semi-automatic or automatic mode (see Section 10.7).

Synthetic points are measured and used in the Preview window.

Changes made to images by a triangulation point take effect immediately after its cre-
ation, according to settings specified in theGC/tie points tab of theMosaic parameters
window (see Section 13.2.4).

If needed, in order to refresh the Previewwindow, click the button inGeoMosaicmain toolbar.

Fig. 50. The Points catalog, Points measurement and Reference map (with loaded web map) windows
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10.3.1. The “Points catalog” window

The Points catalogwindow contains a list of all triangulation points of a project (ground
control, tie and synthetic points) and also tools for points editing.

To open the Points catalog window click the button on the main PHOTOMOD
GeoMosaic toolbar.

The list of triangulation points is a table. Points sorting in columns of the list is performed
by mouse click on the column header.

Table 12. Table columns (list of points)

FunctionsButtons
displays point’s name (with tie prefix for tie point, gcp for GC point and
synthetic for the synthetic point)

Name

displays point’s type (tie, GCP or synthetic)Type
displays a number of images where the point is measuredImages
displays X-coordinate of the pointX
displays Y-coordinate of the pointY
displays point residual by XYMax Exy

The Points catalog window is located at the lower part of the 2D-window by default.
The system interface is flexible for customizing the locations this window according to
the user’s needs.

The Points catalog window can either be fixed in designated sections of the work area
(top or bottom, right or left) or undocked by the user and placed in any place in the 2D
window.

To undock the Points catalog window (or pinpoint it in any place), move the cursor
over the window title and, holding down the left mouse button, drag the window to the
area of its targeted location.

Use the button on the right side of the window title to undock a docked window.

To quickly return a window to the area where it was docked last time, double-click the left mouse
button on the window title

Buttons of the toolbar allow to input, edit and filter triangulation points. The toolbar in-
struments is also used for viewing of selected point measurements on project images
in the Points measurement window (see Section 10.3.2).

Table 13. Toolbar of the Points catalog window

FunctionsButtons
to add the synthetic point to the images (in Preview window)
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FunctionsButtons
to start operation of tie points automatic search and measurement for the entire images
block using correlator
to run automatic search and measurement of GCP on the whole images block using
correlator
to open the Reference map window
to enable mode, that allows to open the Points measurement window only with two
images, which contain marker position in Preview window ( )
opens Points measurement window with initial images, which contain marker position
in Preview window. In order to open only two images, enable the appropriate mode
( )
opens Points measurement window with initial images, which contain point selected
in Points catalog / Preview windows
to remove selected points (any type)
to remove blunders of tie/GC points automatic measurement: allows to reject those
points, which measurement value results in shift of images relatively each other at dis-
tance more than specified (in meters)
to remove all triangulation points
to remove only ground control points
to remove only tie points
to remove only synthetic points
to display all types of triangulation points in Points catalog, Points measurement and
Preview windows
to display only GC points
to display only tie points
to display only synthetic points
to display in Points catalog window only points on opened images in the Points
measurement window
to display the error vectors in Miscellaneous layer. “Bad” points have error vectors no-
ticeably different from other points in size and direction (see Section 10.8)
to create the residual_tie attribute having a value equal to a residual at this tie point
to display the Orthorectification statistics window containing the brief information
about selected point (see above)
to delete all triangulation points from Ground control and tie points layer
to open triangulation points previously saved in vector file with *.x-data extension in
active profile resources
to save triangulation points to vector file in active profile resources with the same name
and *.x-data extension
to save triangulation points to vector file in active profile resources with different name
and *.x-data extension
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10.3.2. The “Points measurement” window

General information

In order to measure coordinates of triangulation points (tie and GCP) in manual mode
and editing points coordinates with errors obtained after automatic measuring of tie
points coordinates, the system provides the Points measurement window.

To open the Points measurement window, perform one of the following actions:

• [optional] click the button in the Points catalogwindow toolbar, to open the Points
measurement window with initial images, which contain marker position in Preview
window;

• [optional] click the button in the Points catalog window toolbar, to open Points
measurement window with initial images, which contain point selected in Points
catalog / Preview windows.

The Points measurement window represents a set of two windows – the main Points
measurement window and the Triangulation points window.

The main Points measurementwindow displays selected images in separate windows
and contain tools used to perform triangulation points measurement. The Triangulation
points window is a catalogue of all triangulation points along with their measurements
data and contains tools for work with points catalogue.
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Fig. 51. The “Points measurement” window

Awork in the Pointsmeasurement and Triangulation pointswindows is synchronized
in the following way:

• when choosing a triangulation point on one of the images using mouse double click
the system automatically starts search for selected point on the opened images of
the window and search of appropriate point on the terrain, if the point is not measured
on the image. Besides, the point will be also automatically highlighted in the triangu-
lation points catalogue;

• when choosing a triangulation point in a catalogue using mouse click the point will
be shown on opened images of the window automatically, if the point is measured
on these images and/or a search of appropriate point on the terrain, if the point is not
measured on opened image;

• when choosing a triangulation point in a catalogue usingmouse double click all images
where the point is measured are opened automatically (marker is located to the place
ofmeasurement);
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• filtering of display of different points types in catalogue and on opened images is also
synchronized.

When the window is opened marker is placed to estimated position of the point.

Synthetic points are not displayed in Points measurement window.

Fig. 52. Search for a point on terrain with measured coordinates and without measured coordinates

The “Points measurement” window workflow

Themain part of the Pointsmeasurementwindow is used to measure/edit triangulation
points on project images with or without correlator.

It contains the following interface elements:

• the main toolbar, that is used to apply different operations to all opened images. The
toolbar contains buttons used to manage images zoom, images selection for meas-
urements, measuring/editing of triangulation points coordinates and transfer of GCP
from georeferenced maps;
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• windows of opened images, each of them display an image and its name, and contains
its own toolbar and status bar.

During triangulation points measurement in the Points measurement window the fol-
lowing concepts are used in the system:

• The active image – image displayed in the window selected by mouse click on image
window. The active image window is highlighted by blue frame;

• The “left” image – a status assigned to one of opened windows, that is used to correl-
ate other images with this one during measurement of tie points using correlator.

To define one of opened images as a “left” one (including active image), click the button
located in the toolbar of this image.

Fig. 53. The main part of the Points measurement window

Table 14. Toolbar of the Points measurement window

FunctionsButtons
to zoom in an image by one step (*)
to zoom out an image by one step (/)
to fit to page data of opened layers (Alt+Enter)
to fit to page data of opened layers (Alt+Enter)
to center image by marker in working area of 2D-window
to hide/show useful areas in windows of opened images (data is taken only from
the layers which are loaded into the project)
to hide/show cutlines in windows of opened images
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FunctionsButtons
to measure ground control point in manual mode without correlator
to measure ground point in semi-automatic mode using correlator
to run automatic search and measurement of GCP on the whole images block using
correlator
to measure tie point in manual mode without correlator
to measure ground point in semi-automatic mode using correlator
to edit a measurement of selected tie/GC point
to setup correlator parameters used for tie/gc points measurement in semi-automatic
or automatic mode
to correlate the active image with the “left” one to add a new tie point using correl-
ator (see the “Manual measurement of tie points coordinates” chapter in “Aerial
triangulation” User Manual)
to correlate all opened images with the “left” one to perform measurement of new
tie point coordinates using correlator (see the “Manual measurement of tie points
coordinates” chapter in “Aerial triangulation” User Manual)

Windows of opened images

Each of project images opened in the Points measurement window is displayed in a
separate child window.

One of the images windows is the “left”, another is active (see above). The “left” window
may be also an active window at the same time. Images shown in the “left” and active
windows are used for correlation during tie points measurement.

When the Points measurement window opens, the images containing selected point
are opened in viewing windows automatically.

Each child image window contains the following interface elements:

• buttons of upper toolbox used to work with image:

○ – to zoom in an image by one step (*);

○ – to zoom out an image by one step (/);

○ – to fit to page data of opened layers (Alt+Enter);

○ – to display data in 1:1 scale, when one pixel of the image corresponds to one
pixel on the screen;

○ – to center image by marker in working area of 2D-window.

○ – allows to move and add selected point to marker’s position;

○ – allows to remove measurement results for point selected on image;
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○ – allows to select image as a “left” one, with which the rest images will be cor-
related, if tie points coordinates were measured using correlator.

• working area used to display image, its name and path in the resources of the active
profile in the upper left part;

• the status bar displaying image zoom ratio, marker position coordinates (in pix and
mm).

Fig. 54. Image window (the scrollbars and panel used to adjust the image brightness, contrast and
gamma-correction are displayed)

To display the panel used to adjust the image brightness, contrast and gamma-correction
for a single image or both images of a stereopair use the Shift+F8 shortcut.

Use left mouse button to select the image.

The , , sliders are used to adjust a brightness, contrast and gamma-correction
of a stereoimage. Tools located in the right part allow to select the color channels, which
correction settings will be applied to.

It is possible to setup parameters for all channels at once if the button is pressed
down, otherwise the system allows to setup individual channel.
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Fig. 55. Panel used to adjust image brightness and contrast

To restore brightness and contrast settings to default values, right click the settings
panel and select the Reset item in drop-down menu.

Brightness, contrast and gamma settings are not restored after the restart.

The Ctrl+F8 shortcut allows to show/hide scroll bars in the active image window.

To move an image in the window the system provides the panoramic mode – moving
an image using mouse move along with pressed Alt key.

10.3.3. The “Reference map” window

Georeferenced external data (raster and web-maps) for the same terrain as project
images, are used as a basis to obtain GCP coordinates and measurement of the GCP
on project images.

Main purpose of the Reference map window – load of georeferenced data in order to
use them for adding GC points and measurement their coordinates on project images.

To open the Map window, open the Points catalog window and click the button of
the window toolbar.
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Fig. 56. The Reference map window

In addition to the reference data itself, the work area of the Reference map window
can also display some layers open in the 2D window, such as sheets and cutlines.

There is a toolbar in the top of the window. In the status line of the Reference map
window the marker’s position coordinates on the georeferenced map are shown.
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It is possible to move the whole image in the working area of theReferencemapwindow
in panning mode by moving mouse with pressed left button along with holding pressed
the Alt key.

Table 15. The Reference map window toolbar

FunctionsButton
to open a window used to select a raster map file located out from active
profile resources, which have one of the raster formats supported by GDAL
library
to open a window used to select a raster map file from active profile resources
to open a window used to select a source of geospatial data of WMS format
and to load web-maps, located on specified area
to manage a zoom of the whole image of the window working area (see the

Section 10.3.2). The field is used to display a current zoom

, , ,

to center image in working area by marker (F7)
to hide/show cutlines
to hide/show sheets
to hide/show the images names (for the raster data only)
to open the Images list window (for the raster data only, see below)
allows to select image as a “left” one, with which the rest images will be cor-
related, if tie points coordinates were measured using correlator

Fig. 57. The Images list window
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Table 16. The toolbar of Images list window

FunctionButtons
to delete all raster images from Reference map window
to select all images in the table
to unselect all images in the table
to invert selection of images in the table

Prepare and load georeferenced data

The system supports using of the following georeferenced data: raster maps and web-
maps to acquire GCP data. Prior to use georeferenced maps perform the following ac-
tions:

1. Prepare the input data in the following way:

• for raster data specify a folder out of active profile resources to place a raster
format file supported by GDAL library and georeference file with the same name.

The need for a separate georeference file depends both on the raster file format on the
whole and characteristics of a particular file, due to its origin.

Thus, for example, GeoPDF and GeoTIFF images initially contain georeference data,
what, however, is not true by default for an arbitrary file with *.pdf or *.tiff extensions.

In turn, formats of some images (for example, *.bmp) do not provide for including geor-
eference data and require obligatory separate georeference files.

The system allows to georeference scanned cartographic raster material using points
with known geodetic coordinates (see the Appendix B).

• in case of working with a web map – make sure that the Internet connection is
available.

2. Open the Points catalog window;

3. Open the Points measurement window;

4. Open the Reference map window;

To load a raster map, perform the following actions:

1. Click the button. The Loading images window opens;

2. Select a raster map file and click the Open button.

To load a raster map from active profile resources, perform the following actions:

1. Click the button. The Open window opens:
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Fig. 58. Parameters of raster map loading

2. Select raster map file in active profile resources and click the Open button.

Perform the following actions to load a web-map to a project:

1. Click the button.

2. [optional] During the Load web-map window first launch, the Parameters window
opens at first:
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Fig. 59. Parameters of web-map loading

3. [optional] Setup parameters of the web-map loading.

4. Click OK. The Load web-map window opens.

Fig. 60. Parameters of web-map loading

5. In the Source list select a source of georeferenced data:

• Rosreestr – cadastral map of Russia produced by The Federal Service for State
Registration, Cadastre and Cartography (Rosreestr).

○ Base Map – basic geography map;

○ Cadastre Map.

• OpenStreetMap (OSM) – non-commercial free world map;

102

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



• RosCosmos;

• ESRI.

6. [optional] Define a working area to load a web-map.

7. In the Reproject section define a coordinate system of loaded web-map using the
following way:

• Auto – automatic transformation to coordinate system of a project;

• None – use coordinate system of the web-service;

• Reproject into coordinate system and specify necessary coordinate system.

8. Click OK.

10.4. Measurement of GCPs

Ground control points – a points with known geodetic coordinates and which are a
source points in aerial triangulation. The program provides the option of using reference
data for measuring GCPs on the source images – the reference image or different web-
maps (in this case the internet connection is needed).

The reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project. I.e the reference image is used
as standard for measuring GCPs, from which is defined the correspondence between
the source images. The coordinates of terrain point on the reference image is assigned
the same terrain point on the source images.

General workflow on GCP transfer includes the following steps:

1. Load of georeferenced data (reference map);

2. Selection of terrain point on the map and search for the point on project images;

3. Transfer the point from the map – add/measure of point’s coordinates on project
images;

4. [optional] Editing of the GC point.

For GCPmeasurement it is necessary define in advance a type of transformation which
will be applied automatically on edges of images block while GCP measurements are
accumulating. Perform the following actions to do this:

1. Choose the Mosaic › Parameters. The Mosaic parameters window opens.

2. Set on the Using of ground control points checkbox on the Ties tab.
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To enable/disable using of ground control points, click the button in main GeoMosaic
toolbar.

3. In the Images edges section select: No changing, 2D-Shift, Projective.

4. [optional] Set on the Affected area checkbox to limit influence of ground control
point to adjustment and specify the value in meters.

If the Affected area checkbox is set of, maximal distance of ground control point influence
is image border.

10.4.1. Addition ground control points in manual and semi-automatic
modes

Perform the follows for defining correspondence between the source images by control
point on reference image in manual or semi-automatic mode:

1. Open the Points catalog and Reference map windows in turn;

2. In the Reference map window, load a reference image or a web map:

Fig. 61. Point catalog and Reference Map (with loaded web map) windows
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3. In the Reference map window, find a place in the loaded reference data that is
suitable for creating a GCp. Move the marker there. Without moving the marker,
synchronize the marker position in the Reference map and Preview windows by
double-clicking the left mouse button in the Reference map window;

4. Click in the main Points catalog toolbar. The Points measurement window
opens:

Fig. 62. Point catalog, Reference Map, and Measure points windows (opened after marker
synchronization)

5. Correct the marker position in the windows of open images in the Points measure-
ment window:
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Fig. 63. Point catalog, Reference Map, and Measure points windows (corrected marker’s position)

6. Perform one of the following actions to add GC point:

• [optional] click the button of the Points measurement window toolbar to add
point manually;

• [optional] In case a raster image is used as reference data, the system provides
for measuring GCPs in a semi-automatic mode using a correlator.

It is recommended to set the Correlator parameters before the start working.

[optional] click the button in the Reference map window toolbar (to set the
reference image as the “left” image) and then click the button of the Points
measurement window toolbar to add point in semi-automatic mode.

After correlation operation one of the following events will occur:

○ if the system failed to calculate correlation coefficient, the Bad point warning
will appear. It may contain the error description:
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Fig. 64. The warning message

Fig. 65. The warning message

Fig. 66. The warning message

Max. auto-correlation coefficient (specified in Points measurement parameters
window) allows to control auto-correlation of a point, i. e. a degree of point’s unique-
ness in some its vicinity on the left image.

The more the auto-correlation radius value, the less the point’s uniqueness and the
more probable its incorrect comparison with the right image even when the correlation
coefficient is high.

○ if correlation coefficient is calculated successfully, theNewGCPwindow opens.
It allows to analyse correlation coefficients and make a decision whether to
add a new GC point.

The window displays created point name and calculated correlation coefficients:
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Fig. 67. Correlation of all opened images with the “left” image (reference raster)

Data display in the coefficients table depends onMin. correlation value, spe-
cified in Points measurement parameters window.

To add a point select images in the list (set appropriate checkboxes) and click
OK, otherwise click the Cancel button.

7. Repeat the steps described above, to measure another GC points. Hence a GC
points are created on the sources image with coordinates taken from the reference
image. The source images in the Previewwindow are refreshed taking into account
the stitching by added points.

If needed, in order to refresh the Preview window, click of the GeoMosaic main toolbar

10.4.2. Automatic searching of ground control points

The program provides opportunity of search and add Ground Control points on the
reference and source mosaic project images in the automatic mode (in case if the raster
reference data is used). For automatic searching of corresponding points on the refer-
ence image and source images of mosaic project perform the following actions:

It is recommended to set the Correlator parameters before the start working.

1. Sequentially open the Points catalog, Reference map and Points measurement
windows;

2. Load reference raster image in the Reference map window. Click the button in
the Reference map window toolbar, to set the reference image as the “left” image;

3. Click the button on the Points measurement window toolbar;
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4. [optional] If the Grid layer has not been previously created, it is requested to do it:

Fig. 68. The dialog box

5. Click Yes to setup the Grid properties in appropriate window (see the “Regular
grid of nodes” chapter in “DTM Generation” User Manual):

Fig. 69. The Grid properties window

Click Ok to create a work area of the grid.

6. The Points measurement parameters window opens:
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Fig. 70. Points measure parameters window

7. Set the correlator parameters;

8. Click OK to start searching process;

9. [optional] in order to delete all existing GC points before searching, click Yes.

Fig. 71. The dialog box
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10.5. Tie points measurement

Tie points – the same points on the terrain on adjacent project images. Tie points
measurement consists in defining correspondence between projections of the same
terrain point on two or more source images of the mosaic project in the vicinity of cutlines.

Tie points are solely used for transforming source images exactly close to cutline. It is not re-
commended to measure the tie points far away from the cutlines to avoid the rough transform-
ation of images. Also, it is not recommended measuring points on the extended objects (for
example, on the roads), buildings and low-contrast areas.

For tie points measurement it is necessary define in advance a type of transformation
which will be applied automatically on edges of images block while tie points measure-
ments are accumulating. Perform the following actions to do this:

1. Choose the Mosaic › Parameters. The Mosaic parameters window opens.

2. Set on the Using of tie points checkbox on the Ties tab.

3. In the Images edges section select: No changing, 2D-Shift, Projective.

4. [optional] Set on the Affected area checkbox to limit influence of ground control
point to adjustment and specify the value in meters.

If the Affected area checkbox is set of, maximal distance of ground control point influence
is image border.

10.5.1. Addition tie points in manual and semi-automatic modes

Perform the follows for defining correspondence between the source images in manual
or semi-automatic mode:

1. Create cutlines;

A pre-requisite for measurement of tie points is the presence of cutlines created.

2. Open the Points catalog window;

3. Select the point in the vicinity of cutlines in the Preview window set the marker in
this place to add the tie point.

4. Click the button it the Points catalogwindow toolbar. The Pointsmeasurement
window opens:
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Fig. 72. The Points catalog and Points measurement windows

5. Edit the marker position in the windows with opened images;

6. Perform one of the following actions to add tie point:

• [optional] click the button of the Points measurement window toolbar to add
point manually;

• [optional] click the button in the one of the windows with opened images toolbar
(to set this image as the “left” image) and then click the button of the Points
measurement window toolbar to add point in semi-automatic mode.

It is recommended to set the Correlator parameters before the start working.

After correlation operation one of the following events will occur:

○ if the system failed to calculate correlation coefficient, the Bad point warning
will appear. It may contain the error description:

112

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Fig. 73. The warning message

Fig. 74. The warning message

Fig. 75. The warning message

Max. auto-correlation coefficient (specified in Points measurement parameters
window) allows to control auto-correlation of a point, i. e. a degree of point’s unique-
ness in some its vicinity on the left image.

The more the auto-correlation radius value, the less the point’s uniqueness and the
more probable its incorrect comparison with the right image even when the correlation
coefficient is high.

○ if correlation coefficient is calculated successfully, the New tie point window
opens. It allows to analyse correlation coefficients and make a decision
whether to add a new GC point.

The window displays created point name and calculated correlation coefficients:
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Fig. 76. Correlation of all opened images with the “left” image

Data display in the coefficients table depends onMin. correlation value, spe-
cified in Points measurement parameters window.

To add a point select images in the list (set appropriate checkboxes) and click
OK, otherwise click the Cancel button.

7. Repeat the steps described above, to measure another tie points. The source images
in the Preview window are refreshed taking into account the stitching by added
points.

If needed, in order to refresh the Preview window, click of the GeoMosaic main toolbar

10.5.2. Automatic mode measurement of points

The automatic mode implies the automatic searching of tie points using correlator on
all block images of project in the vicinity of cutlines.

Perform the following actions for measuring of tie points in automatic mode:

1. Create cutlines.

A pre-requisite for measurement of tie points is the presence of cutlines created in the
Cutlines layer. Otherwise, the message about that cutlines must be created is shown. And
measuring of tie points is not possible.

2. Click the button in the Points catalog window toolbar. The Points measure
parameters window opens.
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Fig. 77. Points measure parameters window

3. Set the correlator parameters.

4. Click OK to start searching process.

After points measurements the Using of tie points mode is set on automatically.

Perform the following actions for measuring points in the vicinity of cutlines in the
distributed processing mode:
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1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The Ties points distributed pro-
cessing windows opens.

Fig. 78. Parameters of distributed processing for measuring tie points

The Number of images in project displays number of created cutlines in the
mosaic project.

3. Set the max. number of simultaneous tasks.

4. Define the output file name and path.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

5. [optional] in order to delete all existing tie points before searching, click Yes.

Fig. 79. The dialog box

Estimate the stitching quality of cutlines in the result of the automatic measuring of tie
points in the Preview window. If necessary, edit the measurement of added tie points.
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10.6. Synthetic points employment

Synthetic point are a highly specialized type of points used by PHOTOMODGeoMosaic
and are used only in special cases (for example, when it is impossible to use reference
data and/or when processing a project containing images with significant distortions,
which are caused, for example, by mountainous terrain).

Unlike GCPs or tie points, which transform an image according to the settings specified
in the GC/tie points tab of the Mosaic parameters window, synthetic points allow you
to shift an entire image manually according to the shift direction and range of the syn-
thetic point created in advance by the user.

Manual image shift allows you, first of all, to achieve its visual correct arrangement; for
example, correctly align elongated objects (rivers, roads, etc.), especially when the
appearance of the resulting mosaic is the most important.

Thus, synthetic points are partly, very conditionally, similar in purpose to GCPs, but,
unlike “real” GCPs, they cannot improve the accuracy of the output data. Synthetic
points affect the location of images only when the Using of ground control and syn-
thetic points checkbox is set (see Section 13.2.4).

Correct shifting of an image, in exact accordance with the direction and range of displacement
of the synthetic point, is possible only in the case of no influence on the image from other
points—synthetic, GCPs, or tie points.

Therefore, the most optimal scenario for using synthetic points is their separate (or primary)
use, with subsequent measurement of points of other types, for example, tie points (see below).

To enable/disable using of tie points, click the button in main GeoMosaic toolbar.

10.6.1. Operation procedure

To create a synthetic point and use it to transform a project’s image, perform the follow-
ing:

1. Open the Points catalog window clicking in the PHOTOMOD GeoMosaicmain
toolbar;

2. In the Preview, find an area on the project’s image block that could benefit from
manual transformation using a synthetic point;

3. Move the marker to the desired position:
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Fig. 80. The elements of an extended object (road) are poorly aligned with each other in adjacent
images

4. Click in the Points catalog toolbar. The created point is displayed in the Points
catalog and Preview windows

The Using of synthetic points mode is enabled automatically.

A synthetic point can be linked to a single image. The point’s belonging to the image is
determined by its location relative to the cutlines during its creation. The creation of a
synthetic point leads to a certain transformation of the image

118

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Fig. 81. A synthetic point is created

5. [optional] Double-click the left mouse button to select a synthetic point

6. While holding the left mouse button and Ctrl, move the synthetic point in the de-
sired direction and to the required distance, based on the expected need to shift
the image;
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Fig. 82. Expected shift of the synthetic point

Fig. 83. The point was moved using standard vector object editing tools
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7. Press Enter. The relevant image is reconstructed in accordance with the user-
specified shift of the synthetic point.

If needed, in order to refresh the Preview window, click of the GeoMosaicmain toolbar.

Fig. 84. The image is transformed

8. [optional] To cancel the changes made by a synthetic point, delete it. For this, select
the point in the Preview or Points catalog window and press Delete (or click
in the Points catalog toolbar).

To remove all synthetic points, click in the Points catalog toolbar

In order to temporarily eliminate the influence of synthetic points, clear the Using of syn-
thetic points checkbox in the Mosaic parameters window or click the button in main
GeoMosaic toolbar.

10.7. Parameters of GC/tie points measurement

For measuring of tie/ground control points in semi-automatic and automatic mode the
separate correlator parameters sets are used.

You go to this windows automatically when starting automatic measurement of GC or
tie points.
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If you configure the automatic tie point measurement parameters, this window also allows you
to switch to tie point measurement in distributed processing mode (see above).

10.7.1. Tie points measurement

Click the button in the Points catalog window toolbar. The Points measure para-
meters window opens.

Fig. 85. Points measure parameters

The Correlation parameters section allows to specify the following parameters of
points measure:

• Fragment size – allows to define a size (in pixels) of a fragment which contains the
point indicated on one image in vicinity of cutline;
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• Search area – allows to define a search area (in meters) of appropriate point on an-
other image;

• Correlation pixel size – allows to define a value of a pixel size of images, where
correlation to be performed, if the images have different pixel size;

• Max. auto-correlation – allows to control auto-correlation of a point, i. e. a degree
of point’s uniqueness in some its vicinity on the left image;

The more the auto-correlation radius value, the less the point’s uniqueness and the more
probable its incorrect comparison with the right image even when the correlation coefficient
is high.

• Min. correlation – allows to define minimal acceptable value of correlation coefficient.
Points that have correlation threshold below specified value are not considered during
adding (the Bad point warning appears).

Correlation threshold is defined considering source data quality.

• Min. fragment RMS – allows to define a brightness value of image fragment. The
less the value, the worse the correlation.

The Automatic search parameters section allows to set up the following parameters:

• Distance between points – allows to define a distance between points searching
along the cutline in the automatic mode;

• Random shift from cutline – allows to define acceptable deviation from cutline when
searching a point in automatic mode;

• Search along selected cutlines – allows to search points only along selected cutlines.
Set the checkbox off to search along all cutlines;

• Skip from found point – allows to skip set quantity of points from measured point.

The Radiometry from project checkbox allows to use data on radiometric correction
from the RMC-file.

• The Spectral channels section allows to choose the following image spectral chan-
nels:

○ All similar – spectral channels, which are the same for project images, are used;

○ RGB – red, blue, and green channels are used;
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○ Average (gray scale) – one channel is used, which is the arithmetic average for
all available channels of images and sketches;

○ Green – the green channel of images and sketches is used as the most clear.

10.7.2. GC points measurement

Click the button in the Points catalog window toolbar. The Points measure para-
meters window opens.

Fig. 86. Points measure parameters

The Correlation parameters section allows to specify the following parameters of
points measure:

• Fragment size – allows to define a size (in pixels) of a fragment which contains the
point indicated on one image in vicinity of cutline;

• Search area – allows to define a search area (in meters) of appropriate point on an-
other image;

• Correlation pixel size – allows to define a value of a pixel size of images, where
correlation to be performed, if the images have different pixel size;

• Max. auto-correlation – allows to control auto-correlation of a point, i. e. a degree
of point’s uniqueness in some its vicinity on the left image;
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The more the auto-correlation radius value, the less the point’s uniqueness and the more
probable its incorrect comparison with the right image even when the correlation coefficient
is high.

• Min. correlation – allows to define minimal acceptable value of correlation coefficient.
Points that have correlation threshold below specified value are not considered during
adding (the Bad point warning appears).

Correlation threshold is defined considering source data quality.

• Min. fragment RMS – allows to define a brightness value of image fragment. The
less the value, the worse the correlation.

The Radiometry from project checkbox allows to use data on radiometric correction
from the RMC-file.

• The Spectral channels section allows to choose the following image spectral chan-
nels:

○ All similar – spectral channels, which are the same for project images, are used;

○ RGB – red, blue, and green channels are used;

○ Average (gray scale) – one channel is used, which is the arithmetic average for
all available channels of images and sketches;

○ Green – the green channel of images and sketches is used as the most clear.

10.8. Editing ground control and tie points
The procedure for working with synthetic points is described in Section 10.6.

Since input data forGeoMosaic are georeferenced imagery and the use of triangulation
points is due to the potential need to transform images for more accurate alignment of
mosaic elements, then editing triangulation points in GeoMosaic actually resolves into
the following:

• Correcting gross errors of point locations in images (for example, after automatic
point search);

• Deleting points (in case the influence of a particular point on the images was eventually
considered undesirable by the user).

The program allows you to quickly delete points of any type directly in the Preview window.
For this, make theGround control and tie points layer editable, select the point by left-clicking,
and press Delete.
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When analyzing error vectors (which represent the difference between the location of
a point in the image and its position in the output mosaic after all transformations have
been performed), it is necessary to take into account that they are influenced by both
geometric distortions inherent in the input georeferenced data and transformations of
the project images caused by the integrated influence of existing triangulation points
of all types.

Thus, tie and ground control points can not only make the necessary changes to the
image block but also, in part, if certain conditions are met, serve as a tool for monitoring
the accuracy of the input orthorectified images.

A noticeable discrepancy between the error values and the visual correctness of the
location of points in the images (for example, large error vectors for a tie point that is
correctly measured in all images, or, vice versa, small errors for a point that has evidently
incorrect measurements) may, when excluding the influence of other factors, such as
transformations from GC or synthetic points, indicate significant distortions of the input
orthoimages, which may be typical for images displaying man-made objects or terrain
with mountainous relief.

To view residuals vector of tie point’s position perform the following:

1. Click the button on the Points catalogwindow toolbar. The Scalewindow opens:

Fig. 87. The Scale window

2. Define the scale to show vectors in Load tie point error vectors field and click
OK. Residuals are load to the Miscellaneous layer;

3. Analysis of error vectors reveals. In the common situation, “Bad” points have error
vectors noticeably different from other points in size and direction (see above).

The main tool for managing triangulation points is the Points catalog window. To open
it, click in the main program toolbar. The system provides for the following ways to
delete points using the tools in this window:

FunctionsButtons
to remove selected points (any type)
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FunctionsButtons
to remove blunders of tie/GC points automatic measurement: allows to reject those
points, which measurement value results in shift of images relatively each other at dis-
tance more than specified (in meters)
to remove all triangulation points
to remove only ground control points
to remove only tie points
to remove only synthetic points

To edit the location of a tie point, perform the following:

1. Выделите точку в таблице окна Каталог точек и нажмите на кнопку в панели
инструментов этого окна (или дважды щелкните левой клавишей мыши по
нужной строке в таблице) Открывается окно Points measurement.

Select the point in the Points catalog window’s table and click in the toolbar of
this window (or double left-click the appropriate row in the table). The Points
measurement window opens.

You can edit the point Name by double-clicking the cell in appropriate column.

Fig. 88. The Points measurement window that displays a tie point with incorrect locations in the
images
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2. To change the location of a point in the images, move the marker to the required
location in the windows of open images and click in the main Points measure-
ment window toolbar.

To change the location of a point in one of the images, move the marker to the re-
quired location in the window of the open image and click in this window toolbar.

3. Close the Points measurement window. If necessary, to refresh the Preview
window, click in the main GeoMosaic toolbar.

Для того чтобы отредактировать положение опорнойточки выполните следующее:

To edit the location of a ground control point, perform the following:

GeoMosaic does not provide manual input or correction of GCP’s geodetic coordinates. The
user can correct erroneous measurements of a point in images, delete a ground control point
or create a new one.

1. Open the Reference map window and load reference data;

2. Select the point in the Points catalog window’s table and click in the toolbar of
this window (or double left-click the appropriate row in the table). The Points
measurement window opens:

Fig. 89. The Points measurement window displaying a ground control point
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3. To change the location of a point in the images, move the marker to the required
location in the windows of open images and click in the main Points measure-
ment window toolbar.

To change the location of a point in one of the images, move the marker to the re-
quired location in the window of the open image and click in this window toolbar.

4. Close the Points measurement window. If necessary, to refresh the Preview
window, click in the main GeoMosaic toolbar.

11. Splitting into sheets

11.1. Sheets menu

The Sheetsmenu is used for splitting mosaic into sheets for saving their in the separate
files of selected output format. The sheets boundaries are the vector polygons in the
Sheets layer.

Items of the Sheetsmenu items are partly duplicate by buttons of the additional Sheets
toolbar.

Table 17. Brief description of Sheets menu and toolbar

FunctionMenu items
to delete the created sheets boundaries, i.e delete
all vector objects from the Sheets layer without
closing of this layer

Clear

to open sheets boundaries, which were been saved
in the vector file with the x-data extension in the
resources of active profile

Open

see “Import of vector objects” in the “Vectorization”
User Manual

Import

see “Export of vector objects” in the “Vectorization”
User Manual

Export

to save the sheets boundaries in the x-data file in
the resources of active profile

Save

to save the sheets boundaries in new file with the
x-data extension in the resources of active profile

Save as

to define the sequential splitting parameters of block
images area and start the process of sheets
boundaries creation by the specified parameters

Sequential splitting

to create the single sheet covering all block imagesFull mosaic sheet
to create the sheets from each image of blockSplit into sheets by images
to create the single sheet with arbitrary boundaries
from any part of block images

Single sheet creation mode

to create sheet with set size relative to marker pos-
ition

Create sheet around marker
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FunctionMenu items
to create sheets with set size relative to the each
point object position

Create sheets around point objects

to display table with information of project sheetsProject sheets list
to create notations sheets of specified scaleCreate standard orthomap sheet frames
to create sheets of several orthomaps, created in
local coordinate system, grouped by cutlines and
limited by notation frame

Create custom orthomap sheet frames

to make all sheets active (include to the process of
mosaic creation)

Activate all sheets

to make all sheets inactive (exclude from the pro-
cess of mosaic creation)

Deactivate all sheets

to activate selected sheets for creating mosaicActivate selected sheets
to exclude selected sheets from the mosaic creationDeactivate selected sheets
to select only sheets containing at least part of block
image for creation of output mosaic files (input

Set sheets status by rasters

background color on the images edges is taken into
consideration), i.e the value of status attribute will
be equal to ’1’ (active status) for boundaries of non-
empty sheets
to select only sheets containing at least part of block
image for creation of output mosaic files (input

Set sheets status by useful areas

background color on the images edges is taken into
consideration), i.e the value of status attribute will
be equal to ’1’ (active status) for boundaries of non-
empty sheets
to invert the status of all created sheetsInvert sheets status
to select on block scheme all active sheetsSelect active sheets
to select on block scheme all inactive sheetsSelect non active sheets
to choose sheets activation modeSheets activation mode
to define the output parameters for creation of output
mosaic

Parameters

to obtain and modify information about selected
sheet

Sheet info

to create output mosaic sheets taking into account
the given work area

Split work areas into sheets

11.2. Requirements of cutting into sheets

The program allows cutting the output mosaic into sheets for saving them in the separate
files.

At least one active sheet for all or selected area is required to start mosaic creation.

To display sheets borders is used the Sheets layer, which contains attributes of sheet
name and activity status. The program provides different ways of splitting mosaic areas
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into sheets, selecting active sheets for creating output files and setting up output para-
meters.

Throughout this User Manual, the Active sheet is referred to as sheet, from which the
output mosaic file will be created. The Inactive sheet is referred to as sheet, excluded
from the output mosaic.

It is recommended to pass the following number of actions during the mosaic sheets
creation:

1. Definition of the mosaic output coordinate system (see description of the Output
coordinate system panel in Section 13.2.2).

2. Splitting block images into sheets, i.e creating sheets boundaries (the vector objects
with the attributes for storing information about sheets in the Sheets layer).

3. Editing attribute values and sheets boundaries.

4. Managing sheets status.

5. Setting output parameters of sheets.

6. Creating output sheets of mosaic (see Section 13.3).

11.3. Splitting into sheets by the specified parameters

Perform the following actions for splitting block images into sheets by specified para-
meters:

1. Choose the Sheets › Sequential splitting or click the button in the Sheets
toolbar. The Sheets splitting parameters window opens.
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Fig. 90. Parameters of sequential splitting

2. Define the following parameters of splitting:

• Block extents – allows to specify the area boundaries (in meters) for splitting;

• Overlap – allows to define the overlap size (in meters) by width and/or height;

By default the sheets are created without overlap (dock).

• Sheets base name – allows to define the sheets name prefix (by default – Sheet
);

It contains the serial number of sheets row (upward) and serial number of the sheet in
a row (left to right). The rest of the sheet name is generated by program automatically.
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By default, if sequential splitting is used, the sheet numbering starts from the lower-left
corner. To set the sheet numbering from the upper-left corner, set the Number from
the top left corner checkbox.

• Choose, how should the system perform the borders check – by source images,
by useful areas or by worked areas;

• Sheet size – allows to specify sheet size (in meters) by width and/or height;

The modifying sheet size leads to recalculation of sheets number in the specified splitting
area.

• Number of sheets – allows to specify the number of sheets by width and/or
height;

The splitting begins from the bottom left corner of the specified splitting area in accord-
ance with specified number of sheets and sheet size. Thus, sheet size not recalculated
when the modifying number of sheets.

• Attribute with sheet names – allows to define the name of attribute for storing
the sheet names;

• Sheets creation attribute – allows to define the attribute name for storing inform-
ation about sheet status. By default the create is proposed.

3. Click OK. The process of sheets creation starts. The sheets boundaries are created
in the Sheets layer and displayed in the Preview window.

All sheets, falling within block images, are active.

Active sheet is shown by green outline and has not color filling. Inactive sheet is
shown by red outline and red transparent filling, by default.

The GeoMosaic | Preview tab of the Settings window is used to select color and set up
transparency options for inactive sheets (see Section A.2).
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Fig. 91. Sequential splitting

11.3.1. Creating sheets taking into account the work area

The system provides for creating sheets of an output mosaic taking into account the
work area of interest, which makes it possible to avoid sheets completely filled with the
mosaic’s background. For this, perform the following:

1. Split the mosaic into sheets (see Section 11.3);

2. Load the work area boundary into the layer manager (see Section 13.2.2);

3. Choose Sheets › Split work areas into sheets. A vector layer is created that
contains polygons which are the previously created sheets bounded by the work
area. The value of the name attribute of each of the specified polygons corresponds
to this attribute value from the “parent” sheet;

4. Save the created vector layer in the active profile resources;

5. Choose Sheets › Clear;

6. Choose Sheets › Open, to open the previously saved vector layer (see item 4);

134

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



7. [optional] Save the mosaic project if needed.

11.4. Sheets creation modes

The program provides the following opportunities for sheets creation:

• full mosaic sheet from all images – allows to create one sheet including all block im-
ages;

• one sheet with arbitrary boundaries – allows to create one sheet with arbitrary
boundaries from the any part of block images;

• splitting into sheets by images – allows to create separate sheet from each image of
mosaic project;

• creating sheet around marker – allows to create one sheet in the marker region.

• creating sheets around point objects – allows to create sheets with set size relative
to the each point object position.

Choose the Sheets › Full mosaic sheet or click the button in the Sheets toolbar.

Perform the following actions for creating the single sheet:

1. Choose the Sheets › single sheet creation mode or click the button in the
Sheets toolbar.

2. Stretch the rectangle in the Preview window along with pressed Shift key.

Choose the Sheets › Split into sheets by images or click the button in the Sheets
toolbar. The sheet boundaries are created for each image.

Perform the following actions for creating sheet around marker:

1. Set the market in area where mosaic sheet will be created.

2. Choose the Sheets › Create sheet aroundmarker. The Sheet creation paramet-
ers window opens.
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Fig. 92. Sheet creation parameters

3. [optional] Set manually the Center coordinates by X and Y, with respect to which
the sheets boundaries will be calculated.

4. Set the distance from sheet center (marker position) to its border in the Offset to
north, south, west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. Choose the way of creating sheet name in the Sheet names section:

• Input the fixed sheet name;

• Sheets names from attribute – define the name of attribute for storing sheets
name in appropriate field.

By default, each new sheet is named as sheet.

7. Click OK to create the mosaic sheet.

Perform the following actions for creating sheets around point objects:
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1. Load or create non-Geomosaic vector layer, containing point objects.

2. Choose the Sheets › Create sheets around point objects. The Sheet creation
parameters window opens.

Fig. 93. Sheet creation parameters

3. [optional] In the Center coordinates section set the offset (by X and Y) between
point objects and sheets centers.

4. Set the distance from sheets centers to its borders in the Offset to north, south,
west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. Choose the way of creating sheet name in the Sheet names section:

• Input the fixed sheet name;

• Sheets names from attribute – define the name of attribute for storing sheets
name in appropriate field.
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By default, each new sheet is named as sheet.

7. Click OK to create the mosaic sheets.

11.5. Project sheets list

The program provides possibility to view project sheets list and to edit sheets.

To display the sheets list choose the Sheets › Project sheets list or click the button
on the main or Sheets toolbar.

To sort the table contents by the values of selected column, click on the column name.

Fig. 94. Project sheets list

The table with information about all project sheets is displayed in the Sheets listwindow.
The table contains the following columns:

• N – serial number of record;

• Sheet – the sheet name;

• Create – sheets active status;

• Width/Height – linear size of sheet (in pixels);

• Mosaic size – estimated size of output sheet in megabytes.
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Double click on row in table allows to edit information about selected sheet. It allows to change
sheet name or active status.

Table 18. The toolbox of ’Sheets list’ window

FunctionButtons
to search for an image by name (part of name) in the list
to select all sheets in the list
to deselect all sheets in the list
to invert selection of sheets in the table
to remove selected sheets
to edit information about selected sheet – name and active status
to make selected sheet active
to make selected sheet non active
to open the Preview window for current sheet
to save the list with names of selected sheets in text file

11.6. Generators of splitting into sheets

11.6.1. Standard orthomap sheet frames generator

The program provides possibility to split orthomap for notation sheets of chosen scale
(see Appendix C), which consist of vector polygons.

Generators of splitting into sheets are used to:

• to split orthomaps into sheets by images;

• for further use in the GeoMosaicprogram.

Orthomap sheets generation is available if project coordinate system is geodetic (latitude-longit-
ude) or based on map projection.

Perform the following to split survey area to notation sheets of chosen scale:

1. Choose Sheets › Create standard orthomap sheet frames. The Generate
standard sheets window opens.
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Fig. 95. Standard orthomap sheet frames generator parameters

2. The Input coordinate system in which you perform splitting into sheets (for ex-
ample, the project coordinate system) is displayed in the appropriate section. In
order to immediately recalculate the output sheets into another coordinate system
after creating them, set the transform sheets into another coordinate system
checkbox and configure the relevant parameters.

Recalculation of created sheets into another coordinate system can be performed later,
using a separate command: Vectors › Geometry › Convert coordinate system (see the
“Change objects coordinate system” chapter in “Vectorization” User Manual). The checkbox
transform sheets into another coordinate system allows you to optimize data processing
within the framework of a single operation (instead of two consecutive ones).

Sometimes it may be necessary to perform splitting into sheets in a coordinate system
different from the project CS (input), but then save the sheets in it. In this case, change
the coordinate system in which the splitting should be performed in the Input coordinate
system section, then set the transform sheets into another coordinate system checkbox
and specify the source coordinate system in this section.
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3. [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input co-
ordinates of corners in the North,West, East, South fields.

4. Choose the scale of orthomap in the Scale section.

5. [optional] In case when 1:5 000 or 1:2 000 scale is chosen, set on the Create
outscribed rectangles for sheet checkbox.

6. In the Parameters section define the following settings:

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. [optional] To clarify map position, located in south hemisphere, set on the Add
’(S)’ to sheet name checkbox.

3. [optional] Set on the Zero-pad the 1:100 000; 1:5 000; 1:2 000 numbers
checkbox in order to notation of 1:100 000, 1:5 000 and 1:2 000 scale sheets
was wrote correctly.

4. [optional] It is possible to choose one of theQuarters notation in the appropriate
section.

7. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

8. [optional] Change the attribute names or values if necessary and click OK.

11.6.2. Custom orthomap sheet frames generator

Program provides possibility creating sheets from several orthomaps, merged by cutlines
and created in local coordinate system.

Perform the following to split orthomaps by notation sheets in local coordinate system:

1. ChooseSheets › Create customorthomap sheet frames. TheGenerate arbitrary
sheets window opens.
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Fig. 96. Custom orthomap sheet frames generator parameters

2. [optional] To load parameters from file click the button.

3. [optional] Choose the Primary scale only to use one base sheet.

4. Specify the following parameters of primary scale sheet:

In case of using the custom orthomap sheet frames generator it is possible up to 5 levels
splitting orthomaps in to sheets: primary and 4 additional scales. Each next level is created
by splitting the previous level.

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. In the Primary sheet dimension field specify the primary scale sheet size.

3. In the Lower-left corner of the origin sheet input coordinates of the origin
sheet.

Choose the reference point lower and left from work area. The coordinates of origins
of the others sheets are calculated based on this information.
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4. In the Origin sheet number input a number of sheet that starts numeration.

5. In the Sheet name template: $(0x)-$(0y)-$(1)-$(2)-$(3)-$(4), where

• $(0x) – number by X on primary scale;

• $(0y) – number by Y on primary scale;

• $(1), $(2), $(3), $(4) – number on the first and next levels in case if the
Separate numeration for rows and columns checkbox is set off;

• $(1x) – number by X in case if the Separate numeration for rows and
columns checkbox is set on;

• $(1y) – number by Y in case if the Separate numeration for rows and
columns checkbox is set on.

Notation with all types, except using Roman numerals, could be created.

5. [optional] Specify the following parameters of primary scale sheet:

1. Choose one of the template: Scale 1, Scale 2, Scale 3, Scale 4.

2. Choose the Origin of the additional level from the list. By default the top-left
corner is set as origin.

3. Input number of Rows and Columns.

4. Input arbitrary symbol (letter or number) as a start sheet number in the Starting
with fields.

All changes of parameters are shown in the Sample table.

6. Setup the appropriate parameters in Coordinate systems tab:
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Fig. 97. Custom orthomap sheet frames generator parameters

• In the Geographic coordinate system section choose the input coordinate
system, which is used to specify splitting into sheets by latitude and longitude.

• In the Destination coordinate system section choose the coordinate system
to recalculate coordinate system of sheets during splitting into sheets.

• [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input
coordinates of corners in the North,West, East, South fields.

7. [optional] To save parameters click the button. To reset parameters to default
click the button.

8. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

9. [optional] Change the attribute names or values if necessary and click OK.

11.7. Sheets status management

Each sheet has name and active status, specified in the Sheets layer.

In the Sheetsmenu and in the Sheets toolbar the following facilities provided to change
sheets status:

• to make all sheets active choose the Sheets › Activate all sheets or click the
button;

• to make all sheets non-active choose the Sheets › Deactivate all sheets or click the
button;
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• to make selected sheets active choose the Sheets › Activate selected sheets or
click the button;

• to make selected sheets non-active choose the Sheets › Deactivate selected sheets
or click the button;

• to invert sheets status choose the Sheets › Invert sheets status or click the
button;

• to make sheets, which fall into images entirely including their background, active and
to simultaneously make the rest of sheets non-active, choose the Sheets › Set sheets
status by rasters or click the button;

• to make sheets, which fall into images without their background, active and to simul-
taneously make the rest of sheets non active, choose the Sheets › Set sheets status
by useful areas or click the button.

In order to use provided modes of sheets activation you should activate the Sheets
layer and choose in the Sheets › Sheets activation mode menu one of three modes:

• Select for activation – by default, this mode assumes standard selection of sheets
and further assigning them ’active’ or ’non-active’ status. In order to select sheets
drag a rectangle along with pressed Shift key, and use one of group selection modes
from the Tools toolbar;

• By first sheet – this mode allows to change sheets status without sheets selection.
Drag a rectangle in this mode along with pressed Shift key. The sheets that fall into
the rectangle, obtain the status of the first sheet of the rectangle created;

• Use selection mode – this mode allows to change sheets status without sheets se-
lection too. At that, status of sheets that fall into rectangle created along with pressed
Shift key, depends on a group selection tool selected in the Tools toolbar (see the
“Vectorisation” User Manual).

The system also provides for selecting objects using a freeform polygon ( ).

Create a polygon by holding Shift while moving the cursor sequentially in the work area of
the 2D window. To complete the creation of a polygon, set the last vertex of the polygon by
double-clicking the left mouse button. To delete the last created vertex, press Esc.

To select sheets use the following modes:

• to select ’active’ sheets choose the Sheets › Select active sheets or click the
button;

• to select ’non-active’ sheets choose the Sheets › Select non-active sheets or click
the button.
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11.8. Attributes of sheets

Each sheet is given the name and defined sheet status using the attributes of the Sheets
layer. The capability of presetting provides correct import of sheets, which were created
in third party software, in case when the imported objects have another names of attrib-
utes for storing information about sheet (see the Vectorization User Manual).

By default the Sheets layer contains the following names of attributes:

• create – for storing information about sheet status;

• sheet_name – for storing sheet name.

To change the default attributes of the Sheets layer perform the following:

After changing attributes it is necessary to rebuild existed sheets.

1. Choose the Sheets › Parameters or click the button in the Sheets toolbar. The
Sheets parameters window opens.

Fig. 98. Setting attributes names

2. Choose the way of creating sheet name in the Sheet names section:

• From attribute – define the new name of attribute for storing sheets name: select
the name from list or specify it using the button;

• Serial numbers – specify prefix of sheets names manually.
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3. In the Sheets activity section define the following settings:

• in the Attribute value field specify the value of attribute, chosen in the list,
whereby list is marked as active;

• choose theAttribute name from the list for storing information about sheet status
or specify new name using the button.

4. Click OK. Thus, after the completion of splitting process, the data about the sheet
name and sheet status will be stored in the defined attributes irrespective of splitting
mode.

Perform the following actions for obtaining and editing information about a sheet:

1. Select the sheet boundaries by double click in the Preview window.

2. Choose the Sheets › Sheet info. The Sheet info window opens.

Fig. 99. Values of cutline attribute

Window contains the following information:

• the Sheet name field corresponds to the sheet_name attribute value;

• the Sheet will be created checkbox corresponds to the sheet status is active.

Perform the following actions to view and edit attributes values of selected sheet:

1. Select the sheet boundaries by double click in the Preview window.

2. Choose theWindow › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

Fig. 100. Values of sheet attributes

147

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



The following buttons are used to create and edit attributes table:

• – allows to delete all attributes of selected objects;

• – allows to delete common attributes of selected objects;

• – allows to open the Add attribute window to define name, type and value
of attribute;

• – allows to delete current field of attribute table;

• – allows to open the Edit attribute window to edit parameters of selected at-
tribute;

• – allows to invert attributes of selected object;

• – allows to sort attributes of selected objects.

Also the window contains the table with at least two rows:

• create attribute– the ’1’ value corresponds to the active sheet status, the ’2’ value
corresponds to the inactive sheet status;

• sheet_name attribute– contains the name of selected sheet.

The image name in the attribute is generated automatically and depends on the splitting
mode and parameters.

3. Click the string of the Value input field and insert another value for changing of at-
tributes value.

4. Press Enter to save or press Esc to cancel.

There are also other facilities in the program interface that provide fast managing of
the sheet activity status (see Section 11.7).

11.9. Setting output parameters

The output parameters allow to define the method of output files naming and criteria of
selection sheets for creating output files.

Perform the following actions to set up output parameters:

1. After splitting part of block images into sheets, editing boundaries and sheets attrib-
utes, choose the Sheets › Parameters or click the button on the Sheets toolbar.
The Sheets parameters window opens.
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Fig. 101. Sheets parameters

2. Choose the way of creating sheet name in the Sheet names section:

• From attribute – allows to use the value of selected attribute;

• Serial numbers – allows to use serial numbers and define the file name prefix.

In this case, while creating mosaic, the sheet names are generated as follows: Pre-
fix+Sheet serial number.

3. In the Number of vertices section defines criterion of sheets selection for creating
output files by number of vertices within sheets boundaries.

• Arbitrary – sheets selection by number of vertices within the boundaries of cre-
ated sheets is not performed;

• Value – allows to select sheets by number of vertices and specify the number of
vertices in the input field.

4. In the Sheets activity section perform the selection of sheets for creating output
files by the attribute values:

• define the Attribute value, whereby list is marked as active;

• choose the Attribute name which set the sheets activity.

5. Click OK. Sheets activity changes automatically depending on parameters.
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12. Using auxiliary data

12.1. Misc (Miscellaneous) menu

The Misc menu is used to show in the Preview window an auxiliary data that may be
considered during mosaics creation. For auxiliary data (that is vector data) the Misc
layer is provided.

Table 19. Brief description of Misc menu

FunctionMenu items
to delete all vector objects created in the Misc layerClear
to load data from a file saved in active profile resourcesOpen
to save theMisc layer data to vector file with different name
and *.x-data extension in active profile resources

Save as

to show in the Preview window a grid of fragments for pre-
liminary estimation. The grid of fragments is intended for

Local adjustment

collecting of statistics data of local brightness adjustment
(see Section 9.2)
to show in thePreviewwindow boundaries of source images
with background

Source images outlines

to create polygons by images frames with backgroundSource images layout
to create polygons by images frames without backgroundSource images useful areas layout
to select image with selected cutline automatically; it is ne-
cessary to display frames of source images before that with
the Misc › Source images outlines menu item.

Synchronize cutlines selection

to load images metadata to current active layerLoad metadata to current layer
to load coordinates of nadir and central points to theMiscel-
laneous layer

Load nadir and central points

to convert orthomap metadata, created in third party soft-
ware, to the system interior format

Convert metadata from AUX to X-FEAT

to save images borders as vector objects in the orthopho-
tomap; could be used only for othopohoto created by satellite
images

Save images borders from metadata to
MIF/MID

to check the completeness of output rasters. After performing
the procedure informationmessage is displayed. Such errors
may occur as a result of network failure.

Check completeness of rasters

12.2. Images layout

The program provides possibility to create polygons by images frames with background
or by images edges without background. Misc › Source images layout and Misc ›
Source images useful areas layout menu item are used for that.

Choose the Misc › Source images layout to create polygons by images frames with
background.
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The following attributes are assigned to each created polygon:

• image_name – the name of image which is in the polygon, and the path to the image
file;

• bytes_ps – bytes per sample;

• aver_pix_size – average GSD size;

• img_width – image width;

• img_height – image height.

Fig. 102. Creation polygons by images frames with background

Perform the following to create polygons by images frames with background:

1. Choose the Source images useful areas layout. The Parameterswindow opens.
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Fig. 103. Parameters of creation polygons by images frames without background

2. [optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images.

3. In the Image edges trim specify the offset from images border in pixels.

4. Specify the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created).

5. Image simplification, in pixels;

Preliminary simplification of images makes it possible to reduce the time spent on construct-
ing the boundaries of polygons and reduce the number of their vertices, thus avoiding un-
justified complexity of their configuration.

Specific optimum values of simplification are to be chosen individually for each project,
depending on the project type and geometry of initial data.

It is not recommended to reduce default values for UAS and central projection projects,
that have quite large image overlapping.

When processing satellite scanner survey projects that have small image overlapping, re-
ducing this parameter can be feasible for the purpose of increasing the quality of boundary
construction.

When setting this parameter, it is recommended to take into account the previously set
Precision of calculation of areas boundaries (see above). The Precision and Image
simplification values that differ by several orders of magnitude, are not advisable

Preliminary image simplification before the construction of polygons boundaries is to be
performed only if the unique background color checkbox is set (see above).
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6. In theMinimal components square specify the minimal square of the image, below
which polygon is not created.

7. [optional] To create polygons not exactly by image frame, but by some distance
from it, specify the negative value in the Offset from images edges in pixels to
create polygons inside frame, or positive value to create them outside.

8. Click OK to start polygons by images frames without background creation.

Fig. 104. Creation polygons by images frames without background

13. Mosaic creation

13.1. Mosaic menu
Table 20. Brief description of Mosaic menu

FunctionMenu items
to setup parameters of mosaic preview and creation,
as well as brightness adjustment and output data
save

Parameters

to open Preview window for the entire block of
loaded images considering data processing results

Preview
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FunctionMenu items
to open Preview window for the selected sheet of
mosaic

Preview (current sheet)

to clear all data about brightness adjustmentClear brightness adjustment
to rebuild local adjustment after cutlines changeBrightness adjustment
to use distributed processing to brightness adjust-
ment

Distributed global brightness adjustment

to start mosaic building and creation of output files
for selected active sheets

Build full mosaic

to start of mosaic building and creation of output file
for selected sheet

Build current sheet

to start mosaic creation for specified active sheets
considering user settings and parameters in distrib-
uted processing mode

Distributed processing

to start mosaic creation using distributed processing
with splitting of active sheets

Distributed processing of PHOTOMOD
MegaTIFF

to open any image of acceptable raster format for
preview in the application window

Open image

to save mosaic parameters setting for further use
them in other mosaic projects (see a description of

Save parameters preferences

the Use saved mosaic settings option in Ap-
pendix A)

13.2. Setup mosaic parameters

13.2.1. General information

To setup mosaic building parameters, choose theMosaic › Parameters or click the
button on the main toolbar. The Mosaic parameters window opens.

The window contains the following groups of parameters:

• main parameters of mosaic building on the Mosaic tab (see Section 13.2.2);

• parameters of local and global brightness adjustment on theBrightness adjustment
tab (see Section 9.1);

• parameters of ground control and tie points usage for adjustment on the Ties tab
(see Section 13.2.4);

• parameters of output mosaic sheets on the Output tab (see Section 13.2.3);

• additional parameters on the Misc tab (see Section 13.2.5).

To save parameters of mosaic creation (for using in other projects), choose theMosaic ›
Save parameters preferences.
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Saved output mosaic settings are load automatically on the program launch. To load
default mosaic settings into the Mosaic parameters window at the program start, set
off the Use saved mosaic settings checkbox on the GeoMosaic tab in the Settings
window (see Appendix A).

13.2.2. Mosaic’s main parameters

The Mosaic tab of the Mosaic parameters window purposes to setup main options of
mosaic building.

Fig. 105. The ’Mosaic parameters’ window
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The Mosaic tab is used for setting the following parameters of output mosaic:

• Fill background out of sheet boundaries – allows to specify a type of filling outside
of sheet boundaries in the output mosaic. Otherwise, the images of adjacent sheets
are used for the filling;

• Raster offset of sheet – allows to specify a buffer zone size on the sheet borders
(in pixels);

• Build sheets by images – defines a content of sheets when creating a mosaic that
is split on sheets by images. If the checkbox is set on, each sheet will contain the
only image corresponding to the sheet, i.e. the mosaic will be not created. If the
checkbox is set off, each sheet will contain all images that fall into this sheet;

The option is used to perform only export of initial images into different coordinate system or
export to files of other raster formats.

After splitting of sheets by images, sheets names in attributes of the Sheets layer should be
the same as images names.

If the Build sheets by images checkbox is set on, mosaic is not built.

• Use images without cutlines – allows to use images without cutlines for preview
and mosaic creation (see also a description of means of images order change when
creating mosaic without cutlines in Section 7.8);

• Use source rasters base layer only – allows to use a base layer of initial images
pyramid if the mosaic is created using docking (not overlapped) images without cre-
ating cutlines. If this checkbox is set off the program uses a pyramid layer correspond-
ing to specified resolution, i. e. the pyramid layer is taken based on the Cell size
parameter value;

• Transparent background inside cutlines – allows to use transparency for areas
with input background color inside cutlines;

To apply this parameter it must be set transparency for background color of original images
(see Section 7.5).

• Align sheets by pixel grid – allows to set the parameters of pixel-by-pixel aligning
of sheet frames when exporting mosaic’s sheets:

○ If the Align sheets by common grid checkbox is set when exporting mosaic’s
sheets, sheet frames are aligned (shifted) according to pixel mosaic’s grid;

○ If the Align sheets by common grid checkbox is cleared, mosaic sheets are
created independently of each other according to initial vector sheet frames.
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Fig. 106. Aligning the sheets by common grid

• Cell size – allows to specify the size of output mosaic cell on the terrain. The cell
size by default is equal to the cell size of the first image of mosaic project;

TheCalculate button allows to set a mosaic size in pixels and recalculate its cell size accord-
ingly.

The accuracy of this parameter (a number of decimal places) takes precedence over general
system’s settings of numbers of decimal places set in the Settings window (Service › Set-
tings › Modules › Decimal places › Orthorectification/Geomosaic, see the “Setup of
modules start” section of the “General system’s parameters” User Manual).

• Background color – allows to set a color for mosaic background, since output mo-
saic always inscribes into a rectangular raster shape;

The Transparent mosaic background on preview parameter influences on background
color of mosaic in the Preview window (see Section A.2).

○ Shift background color – allows to specify a shift of colour, for some pixels on
the substantial part of image (inside cutlines), if color of these pixels coincides with
defined colour of output orthoimages background, after the orthotransformation.

During an orthophoto creation, images are subjected to geometric transformations and
resampling. As a result of such operations, the color of some informative pixels of the
raster image may by chance precisely match the chosen output image background color.

For example, if an image contains three standard channels (RGB) and the user-set output
background color is black (R=0, G=0, B=0), then, if the color shift was set as 1, pixels inside
the cutlines, whose color became black after the processing, will be considered as (R=1,
G=1, B=1).

The color shift direction depends on user-set output background color and given color shift
absolute value. For the white background color (R=255, G=255, B=255), for example, the
RGB values will decrease.
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• Resampling method – allows to choose the brightness interpolation mode during
orthomosaic creation: bilinear, cubic or nearest neighbour;

• Output raster channels – opens the window Output image parameters, used for
specifying the following parameters:

By default quantity and structure of channels are defined by first added image.

○ Use radiometric from RMC-files – allows to use data of radiometric correction
from RMC-file, if correction was done preliminary, for example – in the Raster
Converter module (see the ’General information’ User Manual);

If the Monochrome output checkbox is set on, this channel could be use as a channel in
output file.

If the checkbox is set on, auto levels or radiometric correction could be applied to selected
images.

○ Channels list – contains list of source (left) and selected for using in orthorectific-
ation channels (right);

Quantity and structure of channels are forming with buttons of the Channels list section.

○ Data format – allows to choose format of output image: 8 bit or 16 bit;

○ Monochrome output – allows to create output file with one grayscale channel.

In case of monochrome output it is impossible to choose structure of channels.

Fig. 107. Output channels parameters
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• Geometry correction cell size (in pixels) allows to increase significantly data pro-
cessing speed setting sizes of image fragments to process in accelerated mode.

If Geometry correction cell size is equal to one, each image pixel undergoes complex
geometric transformations during processing, what provides the maximum accuracy of mo-
saic creation at, often, practically unacceptable time expenditures.

Increasing the geomety correction cell size allows a user to select the optimal ratio of data
processing speed and output mosaic quality. In this case, only the four extreme pixels of the
cell undergo geometry correction to the full cycle of geometric transformations, while the
main content of the cell is interpolated by the bilinear interpolation method.

Default 32 pixel Geometry correction cell size is optimal in most cases.

• Rotation angle – allows to setup a rotation angle (in degrees) of mosaic’s images;

Is used if a block of initial images has elongated shape and you need to remove unnecessary
background area in rectangular window of created mosaic.

• Source rasters background color range – allows to define a deviation from selected
background color of initial images, i. e. to specify a range of color, existing in initial
images background (see Section 7.5);

Also the Mosaic tab allows to choose Input and Output coordinate system if they
are different to the project’s coordinate system.

To use work area boundary (see Section 2.2), set the appropriate checkbox and
specify the path (in the active profile resources) to the prearranged vector layer contain-
ing at least one polygon.

The button allows to open file with polygons. The button allows to choose another file,
instead the opened. The button allows to remove the selected file from the list. The button
allows to remove all the files from the appropriate list. The button allows to display the selected
layer of vector polygons in both the Layers Manager and in a 2D window.

Data in the Preview window (if open) will be updated taking into account the loaded work area
boundary.

The system provides for creating sheets of an output mosaic taking into account the work area
of interest, which makes it possible to avoid sheets completely filled with themosaic’s background
(see Section 11.3.1).

13.2.3. Mosaic output parameters

The Save tab of the Mosaic parameters window allows to setup options of mosaic
output.
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Fig. 108. Mosaic output parameters

The Map scale field allows to set the scale of output orthoimages.

The Calculate map scale button allows to calculate a scale and map sheet size (in
meters) and print resolution.

Information on the printing resolution of an output image (dpi, dpm) is recorded in the metadata
of *.tiff and *.bmp images, respectively. DPI is dots per inch and DPM is dots per millimeter.
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Fig. 109. Map scale

When creating an orthoimage, various additional data can also be created depending
on the input File type. For this, set or clear the following checkboxes:

• Create tiled TIFF – an orthoimage will be created as a MS-TIFF file;

Creation of MS-TIFF files (so called tiled TIFFs) is available only if TIFF/BigTIFF (*.tiff,
*.tif) File type was preselected in Output window.

If the Create tiled TIFF checkbox is cleared – a *.TIFF file is created with a standard line
data record format.

○ Create internal pyramids – allows for creating pyramids inside MS-TIFF output
images for quick redrawing of images on the screen in case of changing the viewing
scale.

To use internal pyramids, the viewer must support the MS-TIFF format.

• Create external pyramids – allows for creating pyramids as additional files saved
in a separate folder;

Creation of external pyramids is available only if TIFF/BigTIFF (*.tiff, *.tif) File type was
preselected in Output window.

It is recommended to create external pyramids for large orthoimages in case when the MS-
TIFF format with internal pyramids is not used for orthoimage recording (Create tiled TIFF
and Create internal pyramids checkboxes are cleared).

Creation of external pyramids for MS-TIFF files is not provided.

• Create GeoTIFF – output orthoimages created in GeoTIFF format with pyramids;
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Creation of GeoTIFF is available only if TIFF/BigTIFF (*.TIF, *.TIFF) File type was
preselected in Output window.

• Create KML – allows to create additional file in *.kml format, e.g. to show results in
the Google Earth;

It is necessary to choose global coordinate system as output to create file in *.kml format.

*.kml-files are creating both for all block and each image individually.

[optional] Select the MegaTIFF parts format, MSTIFF or JPEG 2000 if PHOTOMOD
MegaTIFF (*.prf) files were selected as File type in the Output window.

The Output images compression allows to set up the compression parameters of
output mosaic sheets:

• None – files are created without compression;

• JPEGwith quality .. % – TIFF-files are creates with set quality of JPEG-compression;

Default compression level is 75 %, that provides the 5-7 times compression of initial image
volume.

• LZW – TIFF-files are creates with LZW-compression;

• Deflate – TIFF-files are creates with deflate compression.

Also theOutput tab allows to set the following parameters of saving files during mosaic
creation:

• Georeferenced file – allows to select the format of the additional file created;

• Swap X, Y – allows to swap Х,Y coordinates;

• Save georeference as ’NonEarth’ – allows you to save georeference as NonEarth
coordinate system, when saving the resulting mosaic in MapInfo format;

Used if MapInfo system does not support coordinate system of mosaic project.

• Create georeference only – allows to create just georeference files of sheets without
building mosaic sheets (i. e. without files creation);

• Save map projection and datum parameters to GeoTIFF – allows to save the ap-
propriate additional parameters to metadata of TIFF-file;

162

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Used if it was decided to Create GeoTIFF.

To record this information, GeoTIFF tags with 34736 and 34737 codes are used (if the
checkbox is cleared, this information is disabled and the default values are used – PHOTOMOD
GeoReference).

In any case, the image metadata include the coordinates of the image’s upper left corner;
the image rotation matrix, including the pixel size and coordinates of the image’s upper left
corner; the type of coordinate system; the units of the coordinate system; and the EPSG
(GeoTIFF) code, if available.

• GeoTIFF for GIS Panorama (GSK-2011/PZ90.11 in zones) – allows to save the
appropriate parameters of coordinate system to metadata of TIFF-file;

Used if it was decided to Create GeoTIFF, for the further processing in Panorama software.

• Transparent background color – allows to set the output background color which
is shown in MapInfo and GIS Map 2011 systems, as transparent, when saving the
resulting orthoimage in MapInfo or GIS Map 2011 formats, chosen in the File type
list in the Output window;

To save an orthophoto in the MapInfo format, choose the File type used by this program in
the Output window and set the Georeferenced file that is to be MapInfo TAB.

To save an orthophoto in the GIS Map 2011 format, choose Panorama raster (*.rsw) in the
File type list in the Output window.

• Save metadata – allows to save images metadata in the *.x-feat-file (see Sec-
tion 7.8.1).

The Output data button allows to open the Output window to select format and target
folder of output mosaic sheets.

13.2.4. Using of GC/Tie points parameters

The Ties tab of the Mosaic parameters window purposes to setup options of using
ground control and tie points for adjustment.
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Fig. 110. Using of GC/Tie points parameters

TheUsing of synthetic points checkbox allows to use synthetic points for more precise
correspondence of cutlines area. TheSynthetic points section allows to set the following
parameters of using ground control points:

• Images edges – allows to choose type of transforming which applies on images
edges:

○ None – allows not to consider images edges;

○ 2D-Shift – edges consider by average plane parallel shift;

○ Projective – to consider edges is used the projective transformation.

• Affected area – allows to define maximal distance of ground control point influence
in meters.
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If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

To enable/disable using of tie points, click the button in main GeoMosaic toolbar.

The Using of ground control points checkbox allows to use ground control points for
more precise correspondence of cutlines area. The GCPs section allows to set the fol-
lowing parameters of using ground control points:

• Images edges – allows to choose type of transforming which applies on images
edges:

○ None – allows not to consider images edges;

○ 2D-Shift – edges consider by average plane parallel shift;

○ Projective – to consider edges is used the projective transformation.

• Affected area – allows to define maximal distance of ground control point influence
in meters.

If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

To enable/disable using of ground control points, click the button in main GeoMosaic
toolbar.

TheUsing of tie points checkbox allows to use tie points for more precise correspond-
ence of cutlines area. The Tie points section allows to set the following parameters of
using tie points:

• Images edges – allows to choose type of transforming which applies on images
edges:

○ None – allows not to consider images edges;

○ 2D-Shift – edges consider by average plane parallel shift;

○ Projective – to consider edges is used the projective transformation.

• Affected area – allows to define maximal distance of tie point influence in meters;

If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

• Filter – allows to filter part of points during geometric model creation.
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The Enable flip checkbox allows to invert direction affect of point.

TheOutput mosaic shift section allows to set an output mosaic shift by the coordinate
axes (DX, DY) in meters.

To enable/disable using of tie points, click the button in main GeoMosaic toolbar.

13.2.5. Additional parameters

The Misc tab allows to to setup additional options of creating mosaic.

Fig. 111. Additional parameters

The Save local adjustment checkbox allows to turn on/off saving of parameters and
settings of local brightness adjustment to file of mosaic project.

The Vector data coordinate system section allows to select input or output coordinate
system of a project for storing of vector data (cutlines, sheets boundaries, tie points
etc.).

It is recommended to select output coordinate system (by default), since it is impossible to re-
calculate coordinate system during sheets creation. Coordinate system of initial images and
output mosaic are specified on the Mosaic tab.

13.3. Creation of output mosaic sheets

For creation of resulting output product – georeference files and sheets of mosaic (or-
thophotos) in specified coordinate system and scale – perform one of the following ac-
tions:

• [optional] to create output orthophoto for current sheet perform the following:

1. On the Sheets layer select a border of a sheet, for which the output file will be
created;
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2. Choose the Mosaic › Build current sheet or click the button on the main
toolbar. The Save as window opens. Specify the name, format and output file
location in Windows file system. Default file name is a name of sheet stored in
attributes of the Sheets layer.

• [optional] To create output orthophotos for several mosaic sheets perform the following:

1. Define active sheets on the Sheets layer, for which the output files will be created
(see Section 11);

2. Choose theMosaic › Build full mosaic or click the button on the main toolbar.
The Sheets file window opens. Specify format and target folder for output files;

3. The Output window opens. Configure or confirm pre-configured orthoimage
parameters:

Preliminary access to theOutputwindow is possible via theOutput data button located
in the Save tab of theMosaic parameters window. When you start building the mosaic,
the Output window opens for final confirmation of the settings.

Fig. 112. Output parameters

Set the following parameters:

○ Choose File type for output orthoimages from drop-down list.

■ TIFF / BigTIFF files (*.tiff, *.tif);

■ Windows Bitmap (*.bmp);

■ Panorama raster (*.rsw);

■ ERDAS IMAGINE (*.img);

■ NITF (*.nitf);
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■ JPEG (*.jpg, *.jpeg);

■ PNG (*.png);

■ Microstation (*.gfn);

■ PCIDSK (*.pix);

■ JPEG2000 (*.jp2);

■ PHOTOMOD MegaTIFF (*.prf);

■ ECW (*.ecw);

■ WebP (*.webp).

○ Select an output folder location:

■ [optional] in file system;

• click the button to specify the path to files.

■ [optional] in PHOTOMOD resources.

• click the button to specify the path to resource.

Click OK.

4. [optional] If the Panorama raster (*.rsw) File typewas chosen inOutputwindow
(see paragraph 3 above), the Panorama map selection window opens:

Fig. 113. Parameters of Panorama map export

Set name and path for the map file with one of the following ways:

○ click the button to export the map *.sit-file;

○ click the Create button to create a new Panorama map (*.sit), input filename
and click the Save button;
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○ to export DEM that is used in orthomap creation, set on the Export DEM to
Panorama map checkbox.

The following files are created with orthophoto:

• mosaic sheets in chosen format;

• reference files;

• the file with *.prj extension, with information about coordinate system in OGCWKT
format.

A file name with *.prj extension corresponds to the project’s name.

The WKT (well known text) format is a common text format of coordinate system description
developed according to ISO standards (International Standardization Organization) and
standards ofOpen Geospatial Consortium, an international organization committed to making
quality open standards for the global geospatial community.

13.3.1. Distributed processing

To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Distributed
processing” chapter in the “General information about system” User Manual).

2. Choose theMosaic › Distributed processing. TheMosaic distributed processing
window opens.
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Fig. 114. Mosaic’s distributed processing parameters

Save the orthorectification project if it was changed.

3. Choose the output folder location:

• File system;

○ Define Target folder for output orhoimages.

In case of network processing path mast have \\Server\Share\Folder format.

• PHOTOMOD resources.

○ Specify the path to resources.

4. The Number of sheets displays in the window. Set the Number of tasks for pro-
cessing based on one kernel for one task.

5. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created orthoimages.
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6. [optional] By default if process was completed successfully, temporary project is
deleted. Set the appropriate checkbox off not to delete temporary files.

7. Set the Total progress bar checkbox, to keep the progress bar open when distrib-
uted processing tasks are completed (see “Progress bar for distributed processing”
in the “General information” User Manual).

8. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

The system does not allows for mosaic brightness adjustment when building a mosaic
in the distributed processing mode ( ), nor in the mode of MegaTIFF distributed pro-
cessing ( ). Herewith, brightness adjustment can be a part of the process of mosaic
building in the normal course ( ).

Building a mosaic in the distributed processing mode ( ) is available either for projects
with previously performed brightness adjustment, or if brightness adjustment is disabled
when setting mosaic parameters (i.e. brightness adjustment is not included in the list
of tasks to be executed when building a mosaic in the distributed processing mode).
Otherwise the system gives the following warning:

Fig. 115. A warning when starting distributed processing

In case of this warning, to start distributed processing, perform the following:

• [optional] make brightness adjustment previously and save the project ( );

• [optional] disable brightness adjustment previously in theMosaic parameterswindow:

○ In the Mosaic parameters window, Brightness adjustment tab, Global adjust-
ment section, choose None;

○ In theMosaic parameterswindow,Brightness adjustment tab, Local adjustment
section, clear the On checkbox.
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13.3.2. Distributed processing of PHOTOMOD MegaTIFF

To create orthoimages in MegaTIFF format in distributed processing mode, perform
the following actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

2. Choose the Mosaic › Distributed processing of PHOTOMOD MegaTIFF.

Save the mosaic project if it was changed.

The Mosaic distributed processing window opens.

Fig. 116. Mosaic’s distributed processing parameters

The total Number of sheets and Number of MegaTIFF fragments are displays
in the window.

The system allows to changeMaximum size of MegaTIFF “fragment” value. Upper limit
of file size included to MegaTIFF files set – 8 192 MB; file size by default – 1 024 MB (see
the “System settings” chapter of the “General system’s parameters” User Manual).
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3. Set theNumber of fragments per task. It is recommended to define this parameter
depending on computer hardware performance. Recommended approximate
Number of fragments per task is Number of MegaTIFF fragments / number of
processor cores ratio.

When setting distributed processing, it is also necessary to take into account the network
capacity. For example, for 1 Gbit/s local network the recommended Max tasks is no more
than 4.

To setMax tasks quantity choose Service › Distributed processing › Monitor and press
the button (see the “General information” User Manual).

4. Define path for temporary files of distributed processing.

5. Choose the output folder location:

• File system;

○ Define Target folder for output orhoimages.

In case of network processing path mast have \\Server\Share\Folder format.

• PHOTOMOD resources.

○ Specify the path to resources.

6. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created mosaic sheets.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

8. [optional] in case if the any File type, except PHOTOMODMegaTIFF, was chosen
in Output window, the appropriate warning message opens:

Fig. 117. The warning message
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Set the correct File type (PHOTOMODMegaTIFF) to continue the orthorectification
in MegaTIFF format in distributed processing mode ( ).

The system does not allows for mosaic brightness adjustment when building a mosaic
in the distributed processing mode ( ), nor in the mode of MegaTIFF distributed pro-
cessing ( ). Herewith, brightness adjustment can be a part of the process of mosaic
building in the normal course ( ).

Building a mosaic in the distributed processing mode ( ) is available either for projects
with previously performed brightness adjustment, or if brightness adjustment is disabled
when setting mosaic parameters (i.e. brightness adjustment is not included in the list
of tasks to be executed when building a mosaic in the distributed processing mode).
Otherwise the system gives the following warning:

Fig. 118. A warning when starting distributed processing

In case of this warning, to start distributed processing, perform the following:

• [optional] make brightness adjustment previously and save the project ( );

• [optional] disable brightness adjustment previously in theMosaic parameterswindow:

○ In the Mosaic parameters window, Brightness adjustment tab, Global adjust-
ment section, choose None;

○ In theMosaic parameterswindow,Brightness adjustment tab, Local adjustment
section, clear the On checkbox.

Appendix A. Program parameters

A.1. General parameters

Programs provides possibility to setup general parameters of program and mosaic
preview parameters on the Preview tab. See the description of general parameters of
the program in the ’General system’s parameters’ User Manual.

To set up common program parameters choose the Service › Settings or click the
button on the main toolbar. The Settings window opens.
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Fig. A.1. Common parameters

The GeoMosaic tab allows to setup the following general settings:

• Save local adjustment – allows to turn on/off saving of parameters and settings of
local brightness adjustment to file of mosaic project;

• Create backup – allows to setup automatic save of mosaic project backups to active
profile resources;

In the Backup depth field the number of backup projects copies is displayed.
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• Vector data link to the project – allows to save (in the first time) all external data
with names attached to project name automatically (e.g. project name_sheets.x-
data);

In case this checkbox is set and cutlines (or other vector layers) from another project are
used during the current project processing, then when saving the project being processed,
all the above vector layers are saved as copies belonging with this project.

Otherwise, there are still possible troubles due to the fact that the same vector object was
edited several times during the processing of several different projects.

Note that in case of automatic creation such vector objects as cutlines in PHOTOMOD
GeoMosaic, the created vector layer is primarily available for collaborative editing by several
users and has *.cx-data extension (see “Co-editing vector layers” and “Co-editing topologically
connected vector objects” of the “Vectorization” User Manual).

• Show objects from current image – allows to display vector objects relating only
to image opened in the Images preview window (see Section 7.4);

• Switch off computer after mosaic is built – allows to setup computer automatic
switch off after completion of mosaic creation;

• PHOTOMODGeoMosaic exit affirmation – allows to show a prompt on confirmation
of exit from the program when user tries to close main program window;

• Use saved mosaic settings – allows to load previous mosaic parameters when
program starts;

• Input cache size – allows to set the limitation of the cache size for reading images
(by default 256 Mb);

• Output cache size – allows to set the limitation of the cache size for recording images
(by default 100 Mb);

• Restrict cache size from – allows to set max images number, when cache size is
5 Mb per image, otherwise the cache size has limited to 0.5 Mb per image;

• Maximal number of simultaneously opened images – allows to set limit on the
opened images number in the formats JPEG, NIFF, IMG, PIX (in the case of a lot of
images, it is recommended to convert the images files to the TIFF-format files);

• Correct cloud topology when saving clouds layer – allows to correct topology
errors of vector polygons automatically on layer Clouds/Invisible areas while it is
saving;

• Fast building without background analysing – allows to build fast mosaic without
transparency of input background color;
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• Add to project images with same names – allows to add images with the same
names, which store in different folders;

• Clear layer before single sheet creation – allows to delete all vector objects from
the Sheets layer before creation of single sheet;

• Enable cutlines nodes deleting – allows to delete node of cutline – point, where
three or more cutlines are connected.

○ If checkbox is cleared – a points, nearest to deleted node, are connected against
each other;

○ If checkbox is set – a “hole” appears, after the point is deleted.

Use Cutlines › Replace current nod by new cutline to create a new cutline as a small
rectangle polygon in the place of the node (the point where three or more cutlines converge).
This polygon can be further edited by the user.

If the vertices of adjacent cutlines located next to a node vertex are too close to it, then
when user tries to replace current node by new cutline, the appropriate error message
is displayed: Inserting cutline is too small. If this system message appears, manually
delete the vertices closest to the node and try to repeat this operation by clicking the
button in the main toolbar.

• Enable cutlines moving – allows to enable/disable the movement of cutlines on the
images, if the checkbox is not set, only the vertices of the cutlines are moving;

• Additional black and white background replacement – allows to use both black
and white color in the background;

For correct consideration of several background colors, set the Shift background color
checkbox in the Mosaic tab of the Parameters window (Mosaic › Parameters).

• Fill background color outside “Background” cutlines – beyond “Background”
cutlines the output mosaic background color is used which is to be determined in the
Parameters window (see Section 13.2);

• The checkbox, activating theClouds/invisible areas/useful areas saving affirmation
when the programs close (if any changes have been made);

• The checkbox, allowing to check transparency by channelswhen setting background
color of source images (see Section 7.5).

For example, if an image contains three standard channels (RGB) and the user-set background
color of source images is black (R=0, G=0, B=0), then, if the checkbox was set, pixels whose
intensity value corresponds to the given one (zero), at least in one of the channels, will also
be considered transparent.
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In case of incorrect compression of source raster images (before their processing in PHOTO-
MOD), separate pixels may appear on the border between the background and the content
of the image, actually initially belonging to the background, but, in the end, slightly different
from its original color.

Transparency check over individual channels makes it possible to consider such pixels as
transparent, in case if the original image background is black (R=0, G=0, B=0), or, for example,
white (R=255, G=255, B=255).

This checkbox is not recommended, if the background color of source images is arbitrary,
since all pixels whose intensity values match the color selected by the user, will be processed
as transparent, at least within one channel.

A.2. Preview parameters

The Preview tab is used to specify display parameters of mosaic.

Fig. A.2. Preview parameters

The Preview tab allows to setup the following mosaic visualization options:
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• Show rasters in zoom greater than – allows to setup a zoom at which a visualizing
of mosaic project images in the Preview window begins;

• Transparent mosaic background on preview – allows to setup a transparency of
output mosaic background visible in the Preview window (see Section 7.4);

• Redraw preview on editing – allows to set automatic refreshing of mosaic data in
the Preview window during editing of vector objects – cutlines and change points;

• Open preview immediately – allows to show added images in the Preview window
right away (see Section 7.4);

• Skipped sheets fill color – allows to select a fill color to show inactive sheets of
mosaic (i.e. sheets excluded from output files creation). To adjust the transparency
degree for selected color is used the Skipped sheets color transparency (%) slider
(see Section 11.8);

• Fast view in zoom < = 100% – allows to display images block as a scheme in the
Preview window when zoom out (is recommended for large images blocks);

It is recommended to set on this parameter while processing of large image blocks.

• Preview extents – allows to define extents for displaying content in the Preview
window:

○ By source images – extents by full image;

○ By sheets – extents by all created sheets;

○ By images and sheets – edges of images and sheets.

• Preview cache size – allows to set the size of a cache for mosaic project images
which are displayed in the Preview window.

When setting this parameter, it is required to take into account available RAM of the worksta-
tion.

Appendix B. Raster data georeference
The program allows to georeference raster data located in Windows file system (for
example, scanned cartographic maps, see also the “ScanCorrect” User Manual).

The following materials could be used to do this:

• A file, containing information about the points with known geodetic coordinates;
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• The already georeferenced map for the same terrain area:

○ The raster georeferenced map located inWindows file system;

■ The additional vector map, located in PHOTOMOD active profile resources.

The system also allows to transfer GC points and measure them on project images, during the
project processing (see the “Transfer GCP from georeferenced external data” and the “GC point
transfer from DEM considering adjustment data” chapters of the “Aerial triangulation” User
Manual).

TheRaster georeferencewindow is used to perform raster map georeference (Service ›
Images georeferencing).

To open this window in PHOTOMOD or PHOTOMOD UAS software, select Rasters › Images
georeferencing.

Fig. B.1. The Raster georeference window

The window contains the following GUI elements:

• The main window toolbar;
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• The window in the left part of the working area (where the raster image, that need to
be georeferenced is loaded) with the standard tools used to manage image’s zoom
and rotation;

• The window in the right part of the working area (there can be located reference
raster map or raster and additional vector maps, if these maps are used) with the
standard tools used to manage map’s zoom and rotation;

• Table in the bottom part of the working area containing georeference points coordin-
ates with the following columns:

○ Xg, Yg – point’s geodetic coordinates;

○ Xp, Yp – pixel point’s coordinates on the raster image, that need to be georeferenced;

○ Name – point’s name;

○ (Ex,Ey) – errors in point’s X,Y coordinates measurements.

• A string in the lower part of the window, displaying the marker coordinates (Xp, Yp
and Xg, Yg – the last ones are for the georeferenced data only).

Table B.1. Main toolbar of the Raster georeference window

FunctionsButtons
to load raster image without georeference to the left part of the window. If you load
an image with an existing (for example, preliminary) georeference that will be re-
cognized by the program, the reference points will be loaded into the table described
above and also visually displayed in the images, on the left, and as an option, on
the right, as yellow X-shaped crosses (see the button description below)
to load georeferenced raster map to the right part of the window. If you load an
image with no georeference (or that is not recognized by the program), an appro-
priate message is issued. When another image is loaded, the previous one is
automatically removed from the window
to add georeferenced additional vector map from the active profile resources, to
the right part of the window (only if the raster data has been already loaded). When
loading another vector map, the previous one is automatically removed from the
window
to load GC points data from text file with *.txt or *.csv extensions
to save the created georeference data toMapInfo files (with *.aux and *.tab exten-
sions) with a names, that coincide with the processed raster image name
to manage the zoom of image and map(s) display in both parts of the window, , ,
to remove all GC points from the table and from the both images
to add a new point both to the image(s) and to the coordinate’s table. The pixel
coordinates (Xp, Yp) are saved as marker’s ones on the processed image (left), and
geodetic coordinates (Xg, Yg) are taken from the marker’s position on the reference
map (right), in case if the reference data is loaded. Otherwise – Xg and Yg cells are
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FunctionsButtons
assigned to 0 value. The points on the image(s) are marked by yellow X-shaped
crosses by default (see the button description)
to delete a point selected in the table
to refresh pixel and/or geodetic coordinates of selected point (to save the coordinates
of a new marker position on the image (or on the image and on the map)
to move marker on map point, selected in the table, that means that the system
performs search for selected point on the map
to copy coordinates of a point selected in the table to clipboard (the coordinates
are copied in the following format: Xp Yp Xg Yg, separated by space symbol)
to refresh coordinates of selected point – to paste them from a clipboard (the fol-
lowing formats are acceptable: Xg Yg; Xg Yg Zg; Xp Yp Xg Yg; Xp Yp Zp Xg Yg Zg,
where Z coordinates will be not added to the table)
to open Windows standard color settings window, that allows to choose color of
GCP symbols shown on the image/map

Table B.2. Toolbar of the georeferenced raster image (left)

FunctionsButtons

to manage the zoom of processed image display. The field is
used to display a current scale

, , ,

to hide/show the raster image
to rotate image in the working window (no rotation, rotate by 90, 180, 270 degrees), , ,

Table B.3. Toolbar of the reference raster and vector maps (right)

FunctionsButtons

to manage the zoom ofmap(s) display. The field is used to display
a current scale

, , ,

to hide/show the raster map
to rotate map(s) in the working window (no rotation, rotate by 90, 180, 270 degrees), , ,
to hide/show loaded vector objects
to hide/show loaded vector object’s vertices

B.1. Raster data georeference with manual data input

To perform georeference of raster map, using the known geodetical coordinates of GC
points, do the following actions:

1. Select Service › Images georeferencing. The Raster georeference window
opens.

To open this window in PHOTOMOD or PHOTOMOD UAS software, select Rasters › Im-
ages georeferencing.
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2. Click the button of the main toolbar. Select a raster file without georeference,
located out of active profile resources and click OK. After that a raster image is
displayed in the left part of the window:

Fig. B.2. Loaded image that need to be referenced

If you load an image with an existing (for example, preliminary) georeference that will be
recognized by the program, the reference points will be loaded into the table described
above and also visually displayed in the images, on the left, and as an option, on the right,
as yellow X-shaped crosses.

3. Locate GC point on the image and place marker to this terrain point.

4. Click the button. The point with pixel coordinates is added to the table.

5. Input manually geodetic coordinates of this point into the Xg, Yg columns and specify
the point’s name in the Name field.
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When the fifths point coordinates on the map are measured, coordinates measurement
residuals are calculated automatically and are shown in the Ex, Ey columns of the table.

Fig. B.3. The geodetic coordinates manual input

6. Repeat these steps for other GC points.

For correct map reference it is recommended to recognize at least four points on the map.
If the reference is performed using only one point, the system considers that measurement
unit is one pixel and axes coincide. When two points are used for reference, the system
performs image zoom and rotation, in case of reference by three points the system applies
affine transformations.

7. [optional] Edit GC points (see the description of the main toolbar of the Raster
georeference window).
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8. Click the button to save georeference file to MapInfo format.

B.2. Raster data georeference using points file

To perform georeference of raster map, using the file with points data, do the following
actions:

1. Select Service › Images georeferencing. The Raster georeference window
opens.

To open this window in PHOTOMOD or PHOTOMOD UAS software, select Rasters › Im-
ages georeferencing.

2. Click the button of the main toolbar. Select a raster file without georeference,
located out of active profile resources and click OK. After that a raster image is
displayed in the left part of the window:
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Fig. B.4. Loaded image that need to be referenced

If you load an image with an existing (for example, preliminary) georeference that will be
recognized by the program, the reference points will be loaded into the table described
above and also visually displayed in the images, on the left, and as an option, on the right,
as yellow X-shaped crosses.

3. Prepare the *.txt or *.csv file, containing the needed data: points names and
geodetic coordinates (Xg, Yg) and, optionally, pixel coordinates (Xp, Yp) for the current
processing image (if such data is available):
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Fig. B.5. The CSV-file example with the geodetic coordinates (the comma is used as the columns
separator)

4. In order to load data used for georeference, click the button. The Import para-
meters window opens:

Fig. B.6. Import parameters of points coordinates from a text file

Click the button, to select the input text file;
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5. Set the appropriate checkboxes, to specify the dataset to be imported and the data
columns separators format. Specify the correct columns numbers in input text file;

6. [optional] In order to prevent change of points coordinates, which are already
measured on images, set the Clear before import checkbox.

7. Click OK to add points to catalogue:

Fig. B.7. Loaded points with geodetic coordinates

8. In order to add pixel coordinates of GCP on the map perform the following actions:

1. Select the point in the table;

2. Locate GC point on the image and place marker to this terrain point.
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3. Click the button to match geodetic coordinates of point selected in the table
to pixel coordinates of the point on the image. The point’s pixel coordinates are
added to the table.

4. Repeat the 1 – 3 steps for other GC points.

For correct map reference it is recommended to recognize at least four points on the
map. If the reference is performed using only one point, the system considers that
measurement unit is one pixel and axes coincide. When two points are used for refer-
ence, the system performs image zoom and rotation, in case of reference by three
points the system applies affine transformations.

When the fifths point coordinates on the map are measured, coordinates measurement
residuals are calculated automatically and are shown in the (Ex,Ey) column of the
table.

9. Click the button to save georeference file to MapInfo format.

Fig. B.8. Loaded points with geodetic coordinates correctly placed on the image. The correct residuals
are shown in the (Ex,Ey) column

189

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



B.3. Raster data georeference using reference raster and vector
map(s)

To perform georeference of raster image, using the reference map(s), do the following
actions:

1. Select Service › Images georeferencing. The Raster georeference window
opens.

To open this window in PHOTOMOD or PHOTOMOD UAS software, select Rasters › Im-
ages georeferencing.

2. Click the button of the main toolbar. Select a raster file without georeference,
located out of active profile resources and click OK. After that a raster image is
displayed in the left part of the window:

Fig. B.9. Loaded image that need to be referenced
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If you load an image with an existing (for example, preliminary) georeference that will be
recognized by the program, the reference points will be loaded into the table described
above and also visually displayed in the images, on the left, and as an option, on the right,
as yellow X-shaped crosses.

3. To load georeferenced raster map click the button. Reference map is opened
in the separate Map window (right to the window with unreferenced raster map)
and allows to acquire geodetic coordinates in any point:

Fig. B.10. Loaded georeferenced raster map (right)

When another image is loaded, the previous one is automatically removed from the window.

If you load an image with no georeference (or that is not recognized by the program),
an appropriate message is issued.
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Fig. B.11. The warning message

4. [optional] to load georeferenced vector map click the button. The Parameters
window opens:

Available only if the raster data has been already loaded.

Fig. B.12. Import parameters of vector map

To clear existing vectors from the window (if any) before loading data – set the
appropriate checkbox.

If the Swap X, Y checkbox is not set, vector objects are imported in the right co-
ordinate system. Vice versa, in the left coordinate system.

Click OK. The info message appears:

Fig. B.13. The info message
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5. Reference vector map is opened in the separate Map window (right to the window
with unreferenced raster map):Vectors are loaded on top of the georeferenced map
(if exist).

Fig. B.14. Loaded georeferenced raster and vector maps (right)

6. Click the button to add GC point with all required data on the raster image and
to the coordinates table:
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Fig. B.15. GC point transfer from the reference map to the raster image

7. Repeat this step for other GC points.

For correct map reference it is recommended to recognize at least four points on the map.
If the reference is performed using only one point, the system considers that measurement
unit is one pixel and axes coincide. When two points are used for reference, the system
performs image zoom and rotation, in case of reference by three points the system applies
affine transformations.

When the fifths point coordinates on the map are measured, coordinates measurement
residuals are calculated automatically and are shown in the (Ex,Ey) column of the table.

8. Click the button to save georeference file to MapInfo format.
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Appendix C. Notation sheets system

Latitude higher than 76°60° – 76°Latitude lower than 60°Scale
T-35,36,37,38R-35,36N-371 000 000
T-35-В,Г,36-В,ГR-36-А,БN-37-Г500 000
T-35-10,11,12R-36-09,10N-37-36200 000
T-35-005,006,007,008R-37-019,020N-37-144100 000
T-35-115-А,Б,116-А,БR-36-069-А,БN-37-111-Г50 000
T-35-116-А-а,б,Б-а,бR-36-069-Г-а,бN-37-111-Б-г25 000
T-35-068-Г-а-3,4,б-3,4R-36-069-Г-г-3,4N-37-111-Б-б-410 000
T-35-068-(017,018,019,020)R-36-069-(019,020)N-37-111-(256)5 000
T-35-068-(017-ж,з,и)R-36-069-(021,022-и)N-37-111-(123-и)2 000

Appendix D. Creating marginalia for orthophotomap
PHOTOMOD GeoMosaic allows to create map frame and marginalia in styles and
symbols used in Russian State Land Use Survey in map scales

• 1:2000

• 1:5000

• 1:10 000

• 1:25 000

• 1:50 000

for MicroStation and MapInfo systems. Marginalia contains the following data:

• Decoration – image frame, outer bold frame, text labels, scale segment, scheme of
sheets, names of the neighbor sheets in frame cutouts;

• Grid – coordinate grid lines;

• Frames – frames of all the created sheets.

Marginalia for MicroStation consists of one *.DGN file for every orthophoto sheet (con-
taining Decoration and Grid), and a single file for the entire project containing Frames.

Marginalia for MapInfo is saved as two (Decoration and Grid), or three (Decoration,
Grid and Text data) MIF/MID file pairs per each orthophoto sheet, plus single Frames
file pair for the entire project.
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D.1. Workflow for creating marginalia

For marginalia creation perform the following:

Described int this section is the workflow for creating marginalia forMicroStation in 1:2000 map
scale symbols.

1. After the orthophoto itself has been created, choose Mosaic › Create Marginalia
1:2000 › MicroStation DGN.... TheMarginalia parameters 1:2000window opens;

Fig. D.1. Marginalia parameters

2. In theNames tab of theMarginalia parameterswindow, set the Path tomarginalia
files (output);

3. [optional] Adjust the contents of the text labels for outside the frame (in the names
Names tab), if necessary;

4. Specify the frame style (in the Frame parameters tab);

5. Set the *.DGN specific parameters in the DGN parameters tab;
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6. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

The system allows to save marginalia parameters settings. To save settings as a file with *.x-
ini extension, click the Save button in the Marginalia parameters window. To set previously
saved settings, click Load.

To open orthophoto with marginalia in MicroStation system perform the following:

1. Open the created *.DGN file in MicroStation system;

2. To open corresponding orthophoto raster sheet choose File › Raster management ›
File › Attach in MicroStation system. The program displays the orthophoto with
marginalia.

Fig. D.2. An orthophoto in MicroStation window

Marginalia can be created for the orthophoto as a whole as well as for the sheets in which it is
split.

197

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



D.2. Marginalia parameters

This section contains detailed description of marginalia creation parameters for all
supported scales.

D.2.1. Marginalia 1:2000

This section contains detailed description of marginalia creation parameters for 1:2000
scale for MicroStation and MapInfo systems.

MicroStation DGN

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:2000 › MicroStation DGN.... This command brings up the following dialog box
with parameters:

Fig. D.3. Marginalia parameters

2. The Names tab contains the following parameters:
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• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. D.4. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:

Fig. D.5. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;
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• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

Names tab is identical to the one in the parameters dialog for 1:2000 marginalia in DGN format.
Frame parameters tab is identical to the one in the parameters dialog for 1:2000 marginalia in
DGN format.

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:2000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:

Fig. D.6. Marginalia parameters

2. The Names tab contains the following parameters:
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• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. D.7. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:

Fig. D.8. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;
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• Neighbour sheets on the frame option allows, along with the scheme of sheets
in the lower left corner, insert the names of the neighbour sheets in the cut-outs
of the external (thickened) frame;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

D.2.2. Marginalia 1:5000

This section contains detailed description of marginalia creation parameters for 1:5000
scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:2000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:2000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:5000 › MicroStation DGN.... This command brings up the following dialog box
with parameters:

Fig. D.9. Marginalia parameters
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2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. D.10. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:

Fig. D.11. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;
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• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia
1:5000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:

Fig. D.12. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;
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• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• 8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

• [optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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Fig. D.13. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:

Fig. D.14. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;
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• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

D.2.3. Marginalia 1:10 000

This section contains detailed description of marginalia creation parameters for 1:10
000 scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:10
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:

Fig. D.15. Marginalia parameters
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2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:
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P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;
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■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

Fig. D.16. Marginalia parameters
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4. The DGN parameters tab is used for setting standard DGN v7 parameters:

Fig. D.17. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:10
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. D.18. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. D.19. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. D.20. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

D.2.4. Marginalia 1:25 000

This section contains detailed description of marginalia creation parameters for 1:25
000 scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:25
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:
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Fig. D.21. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. D.22. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. D.23. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:25
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. D.24. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. D.25. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. D.26. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

D.2.5. Marginalia 1:50 000

This section contains detailed description of marginalia creation parameters for 1:50
000 scale for MicroStation and MapInfo.

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in DGN format.

Marginalia forMapInfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:50
000 › MicroStation DGN.... This command brings up the following dialog box with
parameters:
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Fig. D.27. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. D.28. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. D.29. Marginalia parameters

• Names for MU and SU (see MicroStation system User Manual);

• Ratios MU/SU and SU/Pos.Units;

• Origin of coordinates in a file - auto selection or manual setting.

5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

MapInfo

1. Marginalia is created using the menu command Mosaic › Create Marginalia 1:50
000 › MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. D.30. Marginalia parameters

2. The Names tab contains the following parameters:

• Path to marginalia files – the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

• Coord. system, Country, State, District – text lines placed consequently at the
upper left corner of marginalia;

• Caption, City – text lines placed consequently at the top center of marginalia;

• Stamp – text line placed at the upper right corner of marginalia;

• Next come 5 strings placed consequently at the bottom right corner of marginalia.
;

The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-В-б-1 › P-54-76-В-б-1 (49)

○ This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-В-б-1 › 54-76-В-б-1

• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

237

Orthophotomaps creation (Windows x64)PHOTOMOD 8.1



Fig. D.31. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. D.32. Marginalia parameters

• User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

• Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

• Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click ОК.

D.3. Arbitrary marginalia parameters

If necessary the orthophoto marginalia, created in scales 1:2 000 and 1:5 000, may be
configured in accordance with the requirements of the user. To do this, use the following
commands:

• Mosaic › Create marginalia 1:2000 › MicroStation DGN (arbitrary)

• Mosaic › Create marginalia 1:2000 › MapInfo MIF/MID (arbitrary)

• Mosaic › Create marginalia 1:5000 › MicroStation DGN (arbitrary)

• Mosaic › Create marginalia 1:5000 › MapInfo MIF/MID (arbitrary)

In the window that appears, you can edit the layout parameters in the appropriate fields:
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Fig. D.33. Marginalia parameters

1. Names tab is identical to the one in the parameters dialog for 1:2000 marginalia
standard, except for additionalContours and Elevation system parameters, which
specify two text strings, which are written consequently at the center bottom;

2. The Frame parameters tab contains the following parameters:
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Fig. D.34. Marginalia parameters

• Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

• External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

• External frame width specifies thickness of external (thickened) frame;

• Internal / external frame layer,Coordinates grid layer,Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

• Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

• Insert names in frames option causes writing the names of sheets to a file with
frames not only into the corresponding attribute, but also as a text string;
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• [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

○ No – names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

○ Scheme – a CSV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-В-б-1,P-54-76-В-б-2

P-54-76-В-б-3,P-54-76-В-б-4

○ List – file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-В-б-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0

P-54-76-В-б-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0

P-54-76-В-б-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0

P-54-76-В-б-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

■ Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

■ Column with sheets names – number of CSV column, which contains the
names of the sheets;

■ Column with X1 – Column with X4 and Column with Y1 – Column with
Y4 – parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

■ Swap X, Y – if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

■ Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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3. Frame parameters tab is identical to the one in the parameters dialog for 1:2000
and 1:5000 marginalia standard in DGN and MIF/MID formats.

D.3.1. Batch marginalia file names editing

Sometimes it may be necessary to rename sheet image files together with marginalia
files to working numbers.

Choose Sheets › Split into sheets by images, if it’s not done yet.

Use menu commands Mosaic › Create Marginalia 1:2000 › Rename to work IDs or
Мosaic › Create Marginalia 1:5000 › Rename to work IDs when the preview window
is open for the mosaic sheets of which are to be renamed.

Then in the dialogue box that appears, select the folder where files with marginalia and
files with sheets, which must be renamed, are stored.

As a result of this operation, the files contained in the selected folder will obtain the
names used in the PHOTOMOD Mosaic module by default, for example, “Sheet_1“,
“Sheet_2”. Files extensions will correspond to their content: for example, *.tiff - for
sheets files, *.tab - for sheets georeferencing in MapInfo, MIF/MID - for files with mar-
ginalia.
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