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1. Purpose of the document
The purpose of this User Manual is to give detailed information about how to create a
project in the PHOTOMOD system (further – system), to add images into a block, to
edit a images block, to manage projects in system, also information about types of
projects and types of coordinate systems and about additional features.

2. Workflow in system
To create new project is used the following action sequence:

1. Creating and selecting active profile – creating local profile or creating/connecting
network profile to place all project/project group files – resources, and selecting the
profile as active.

2. Creating project – creating new project: specifying project type and name, choosing
coordinate system and a folder into active profile resources to place new project
files.

3. Forming images block – loading project images.

3. Creating and choosing active profile
Prior to work in the system you should create a profile for placing project resources
such as project configuration files, images files, files processing projects/project group.

A profile represents a resources tree with the following structure:

• Root – profile virtual name.

• Top level branches – profile virtual folders – virtual names of physical local or network
folders/disks.

One physical folder/disk or folders/disks group could be specified as a virtual folder (storages
group).

Storage folders are a special type of virtual folder. Resources are automatically placed in
storage folders by the system on the basis of free space analysis. Thus, storage folders allow
optimization of multiple disk usage for storage resources, which is advantageous when network
processing large projects.

• Resources – all data of a profile – all subfolders and files of each virtual folder in
profile.

Thus, profile resources are placed on any servers, workstations or network disks.
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Profiles can be local or network to organize individual or shared work with projects, re-
spectively.

For profiles creation and organizing resources structure of each profile you can use the
Control Panel module.

To view and edit active profile resources is used the PHOTOMOD Explorer module.

To launch these modules is used the Start › Programs › PHOTOMOD 8 x64 menu
and also the context menu of the System Monitor module (the icon in theWindows
system tray).

More details about system resources, recommendations on organizing of local or network
work, and about creating profiles and virtual folders connecting see in the “General in-
formation” User Manual.

In one work session of the system could be used only one active profile.

Close all program modules an perform one of the following to choose active profile:

• choose active profile in the Profile list from the context menu of the System Monitor
module (the icon in theWindowssystem tray);

• choose active profile with mouse double-click by profile name in the Profile list in the
Control Panel module.

Current active profile is marked in the profile list by the icon.

Restart program after chosen active profile. All active profile resources are available
for work until another active profile is selected.
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Fig. 1. Resources structure of network profile

The folder tree displays in the PHOTOMOD Explorer window after creating profile.

Fig. 2. Resources tree of network profile in the Explorer window

To avoid loss of data, it is not recommended to edit virtual folder for storage group.

6

Project creation (Windows x64)PHOTOMOD 8.0



4. Coordinate Systems

4.1. General information

Coordinate system should be selected on the step of project creation. It is possible to
change the coordinate system of existing project in the Project properties window
(see Section 8.3) or during block adjustment step (see the “Block adjustment” User
Manual).

For coordinate system choose during project creation click the Select button of the
Coordinate system section in the New project window (see Section 6.1). Project co-
ordinate system could be chosen from the following sources:

• From DB – from the list of coordinate systems database (see Section 4.2);

• From file – from coordinate system files with *.x-ref-system extension, located out
of profile resources (if any);

• From resource – from files with *.x-ref-system extension, located in active profile
resources;

• From GeoCalculator – from the list of GeoCalculator program database (see the
“Coordinate Systems” chapter in “The GeoCalculator program” User manual).

TheGeoCalculator program allows to edit coordinate systems, to create new ones, to perform
import and export of coordinate systems (see the “The GeoCalculator program” User Manual).

This allows, for example, to choose coordinate system from another project of active
profile. After selecting coordinate systems database, theCoordinate systems database
international window with coordinate systems list included to the selected database
appears.

Fig. 3. Coordinate systems database window
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4.2. Coordinate systems databases

4.2.1. International coordinate reference systems database

The International reference system database is the list of reference systems in sup-
ported formats with the GeoTIFF (the EPSG – European Petroleum Survey Group
company’s standard) image georeference. Besides EPSG database, the list includes
Cartesian (on plane) and Local Curved (on the sphere) reference systems. Cartesian
reference system is used for processing of small image blocks with large scale survey.

Fig. 4. International coordinate reference systems database

4.3. Coordinate reference systems types

Coordinate system database contains the following coordinate systems types:

• Geodetic – curvilinear, latitude/longitude/height reference system;

• Geocentric – Cartesian;

• Local Cartesian – reference systems on the plane;

• Local Curved – reference systems on the sphere;

• Projected – a reference system defined by the map projection;

• Topocentric horizontal – a coordinate reference system with coordinate origin in
chosen point. The Y axes is leftward in the left-handed coordinate reference system
and it is northward in the right-handed reference system.

Ground control points coordinates specified by latitude/longitude should be converted to Projected
coordinate system, using theGeoCalculator program (see description in the “The GeoCalculator
program” User Manual).
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5. Project types

5.1. General information

The system supports the following project types:

• Central projection is used to process aerial and space borne images of central pro-
jection, acquired by photographic camera

• Satellite scanner imagery is used to process space scanner images, acquired by
different sensors, such as GeoEye-1, IKONOS, QuickBird, SPOT, ASTER, IRS,
FORMOSAT, CARTOSAT, “Resours DK”, WorldView- 1, 2;

• ADS 40/80/100 is used to process images acquired by scanner survey system ADS
40/80/100, installed on aircraft;

• VisionMap A3 SLF is used to process aerial images acquired by VisionMap A3 pho-
togrammetric complex.

Depending on type of space survey the following kinds of images blocks are forming
during images loading to the system:

• Monoblock – is a block where images do not form valid stereopairs (i.e. Imagery
product is not a stereo product). Single space image also belongs to monoblock type.
During monoblock forming images are loaded to separate strips, as usual.

If each image is placed in a separate strip, images are placed in the order of names.

• Stereoblock – is images block formed by stereopairs. During stereoblock forming
each stereopair is loaded to a separate strip.

5.2. Central projection imagery

In order to process images acquired by photographic camera you should choose the
Central projection project type during project creation (see Section 6.1). Once the
project of central projection type is created, you can load images and form images
block. Processing of images block of central projection implies full photogrammetric
processing, including interior, relative and exterior orientation. In case of a single image
or monoblock could be performed interior orientation and direct georeferencing (see
the “Aerial triangulation” User Manual).
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5.3. Satellite scanner imagery

5.3.1. Processing images algorithms

In order to process space scanner images you should choose the Satellite scanner
imagery project type (see Section 6.1).

Satellite scanner images are delivered consisting in remote sensing product, that is a
set of images files and files of accompanying data, for example, metadata with interi-
or/exterior orientation parameters. Data content of remote sensing product depends on
a sensor model.

Special aspects of loading satellite images to a project are described in Section 7.5.

Depending on data content of remote sensing product (sensor model) the system sup-
ports the following algorithms of images processing:

• Rigorous algorithm – allows to process remote sensing products, that includemetadata
files with interior and exterior orientation parameters. Rigorous algorithm of images
processing provides accuracy that is about image resolution (by RMS on check
points). It allows to use minimal number of ground control points and to obtain more
accurate results during calculation of exterior orientation parameters.

• Generic – uses parallel-perspective model or DLT (Direct Linear Transformation) al-
gorithm – allows to process any satellite images (including IRS, LandSat, etc.).

However, it requires more GCP per stereopair (10 GCP is recommended, 6 at least) as
compared with rigorous algorithm.

• RPC-algorithm – allows to process remote sensing products, that include metadata
RPC-files (for example, IKONOS, QuickBird, OrbView-3). With RPC-coefficients
available you can use fewer amount of GCP to obtain satisfying results of photogram-
metric processing.

About recommended amount of triangulation points used for satisfying accuracy of adjustment
of satellite images block see in Section 5.3.4. How to adjust satellite images blocks depending
on processing algorithm, see in the “Block adjustment” User Manual. Adjustment accuracies
of scanner blocks see in Section 5.3.3.

5.3.2. Formats of satellite scanner images

Table 1. Generic (DLT and it’s modifications)

Stereo processingProcessing
level

FormatSatellite

No1B2CEOSALOS (AVNIR-2)
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Stereo processingProcessing
level

FormatSatellite

NoTTIFFLandsat 8
No1R, 1GTIFF/GeoTIFF, HDFLandsat7/ETM+

Yes, from the adjacent
passes

1A, 1BSuper Structured, HDF, Fast CIRS-1C, 1D/PAN

Yes1, 2Super Structured, HDF, Fast CResourcesat-1(IRS P6)
No0TIFF/GeoTIFFResours-DК

Table 2. Rigorous algorithm

Stereo processingProcessing
level

FormatSatellite

Yes1ARAW, TIFFEROS A, B
No1ADIMAPFORMOSAT-2
Yes1ADIMAP V2KazEOSat-1
Yes1R, 1GTIFF/GeoTIFFKazEOSat-2
Yes1R, 1GTIFF/GeoTIFFKOMPSAT-2

Yes, from the adjacent
passes

0TIFF/GeoTIFFResours-DК

Yes, same-pass1ACEOS (SISA, CAP), DIMAPSPOT 1-5
Yes, same-pass1AHDFTERRA/ASTER

Yes1ATIFFVNREDSAT1

Table 3. RPC-algorithm

Stereo processingProcessing
level

FormatSatellite

Yes, from the adjacent
passes

1B1, 1B2CEOS, GeoTIFFALOS (PRISM)

No1DTIFF/GeoTIFFArmsat-1
YesOrthokitTIFF/GeoTIFFCartosat-1, 2 (IRS P5)
-1R, 2RTIFF/GeoTIFFDeimos 1

Yes, from the adjacent
passes

1BTIFF/GeoTIFFDeimos 2

YesRadioTIFF/GeoTIFFDubaiSat-2
YesSCTIFF+XMLGaoFen-7

Yes, same-pass2A, OR2A,
OR2A Stereo

TIFF/GeoTIFF, NITFGeoEye-1

No1ATIFF/GeoTIFFGF-1, 2
Yes, same-pass2A, OR2A,

OR2A Stereo
TIFF/GeoTIFF, NITFIKONOS

YesStandard Stat-
ic Level 1

TIFF/GeoTIFFJilin 1
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Stereo processingProcessing
level

FormatSatellite

Yes, from the adjacent
passes

1, 2, 3TIFF/GeoTIFFKanopus-V

Yes2ATIFF/GeoTIFFKazEOSat-1
Yes1R, 1GTIFF/GeoTIFFKOMPSAT-2
Yes1R, 1GTIFF/GeoTIFFKOMPSAT-3
Yes1R, 1G, 1OTIFF/GeoTIFFKOMPSAT-3A

Yes, same-passBasicTIFF/GeoTIFFOrbView-3
YesPrimaryDIMAP V2Pleiades

Yes, same-passSensorDIMAPPeruSat-1
Yes, same-pass2A, OR2A,

OR2A Stereo
TIFF/GeoTIFF, NITFQuickBird

No1BGeoTIFF, NITFRapidEye
Yes, from the adjacent

passes
1A, 2ATIFF/GeoTIFFResours-P

Yes, same-passBasicTIFF+json+RPCSkySat
YesPrimaryDIMAP V2 (JPEG2000 или

GeoTIFF)
SPOT 6, 7

NoL1TIFF/GeoTIFFStilSat-1
Yes1A, 2BTIFF/GeoTIFFSuperView-1
Yes1A, 2ATIFF/GeoTIFFTripleSat
Yes1A, 1BTIFF/GeoTIFFТН-1

Yes, same-pass2A, OR2A,
OR2A Stereo

TIFF/GeoTIFF, NITFWorldView-1, 2, 3, 4

Yes-TIFF/GeoTIFFZY-3
No1ATIFF/GeoTIFFZORKIY-2M
No1A, 2ATIFF/GeoTIFFАИСТ

5.3.3. Accuracy of satellite scanner blocks adjustment

Accuracy parameters of satellite scanner blocks adjustment for the different survey
systems are given in the table below:

Table 4. Accuracy of satellite scanner blocks adjustment

Stereo pro-
cessing*

Processing
algorithms

RMS Exy,
without GCP

(m)

RMS Exy/Ez
withGCP (m)

Scale of or-
thophoto
(mosaic)

Resolution
(bw/color, m)

Survey sys-
tem

Yes (SO)RPC103 / 5250002.5ALOS Prism
Yes (SO)Rigorous20015 / 255000015ASTER
Yes (SO)RPC8003 / 525000

(10000)
2.5Cartosat-1

(IRS P5)
YesRigorous1004250002EROS A
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Stereo pro-
cessing*

Processing
algorithms

RMS Exy,
without GCP

(m)

RMS Exy/Ez
withGCP (m)

Scale of or-
thophoto
(mosaic)

Resolution
(bw/color, m)

Survey sys-
tem

YesRigorous302100000.7EROS B
NoRigorous1003.5250002 / 8FORMOSAT-

2
(10000)

Yes (SO)RPC30.5 / 1.55000 (2000)0.5 / 2GeoEye-1
Yes (SO)Rigorous,

RPC
101 / 350001 / 4IKONOS

Yes (DO)Generic–20 / 201000006 / 23IRS 1C, 1D
Yes (DO)RPC501.3 / 3.325000

(10000)
2.5 / 10KANOPUS-V

Yes (DO)Rigorous,
RPC

2002 / 5100001 / 4КOMPSAT-2

Yes (SO)RPC40250000.7 / 2.8КOMPSAT-3
Yes (SO)RPC40250000.5 / 2.2КOMPSAT-3A
Yes (SO)RPC15150001 / 4OrbView-3
Yes (SO)RPC40.8 / 25000 (2000)0.5 / 2Pleiades

NoRigorous,
RPC

10150000.6 / 2.4QuickBird

NoRigorous,
generic

–3-5100001 / 3Resours-DK

Yes (DO)RPC503 / 450000.7 / 4Resours-P
Yes (DO)Generic–20 / 20100000– / 5.8Resourcesat-

1 (IRS P6)
Yes (DO)Rigorous10010 / 155000010 / 20SPOT 1-4

Yes (DO and
SO)

Rigorous503 / 525000
(10000)

5 (in mode
SuperMode -

2.5)/ 10

SPOT 5

Yes (SO)RPC172 / 210000 (5000)1.5 / 6SPOT 6, 7
Yes (SO)RPC26110000 (5000)1 / 4TripleSat

YesRigorous,
RPC

150.55000

(2000)

0.5WorldView-1,
2

* DO – different orbits, SO – same orbit.

5.3.4. Number of points recommended for adjustment of scanner block

There are some recommendations about number of GCP and check points used for
different methods adjustment of images included to scanner mono/stereo blocks.

For space scanner images it is possible to use only XYZ GCP (with X, Y, Z coordinates).
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Fig. 5. Number of points recommended for adjustment of scanner block by rigorous method

If a monoblock contains images with triple or quadruple overlap area, it is recommended to
measure several points in this area.

Number of GCP could be decreased due to tie points measured in triple or quadruple overlap.
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Fig. 6. Number of points recommended for adjustment of scanner block by RPC method

Number of GCP could be decreased due to tie points measured in quadruple overlap.
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Fig. 7. Number of points recommended for adjustment of scanner block by generic method

Recommended number of check points on images is not absolute and in many cases is determ-
ined by the customer requirements to specific project. Nevertheless, it is necessary to have
check points available for objective estimation of adjustment accuracy.

5.4. Airborne Digital Sensor ADS

5.4.1. Workflow of ADS processing

ADS 40/80/100 – Airborne Digital Sensor – by “Leica Geosystems” (Switzerland) is a
scanner survey system installed on aircraft carrier, which allows to perform simultaneous
survey in different spectral bands under different angles from nadir.

Processing of ADS project in the system implies performing the following steps:
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1. Preprocessing of data, received from on board storage device, using dedicated
software included to ADS set.

2. [optional] Preparing of ADS data for loading to a project using system functionality.

It is necessary to perform this step if preprocessing of ADS data was executed on different
workstation, so it is necessary to correct absolute paths to ADS data files in order to create
ADS project in the system. This step could be skipped if data preprocessing and project
creation was performed on the same machine.

3. Creation of ADS project in the system loading of ADS data to a project.

4. Creating of math models during the adjustment.

5. Stereoprocessing, DTM ant orthoimages creation.

5.4.2. Preprocessing ADS data

Working procedure with ADS data in the system implies its full processing using dedic-
ated software included to delivery set of ADS survey complex, for example, XPro/GPro
program by Leica Geosystems, and ORIMA software developed by L. Hinsken.

Usually, ADS data preprocessing contains the following steps:

1. initial processing – transfer of images and trajectory data from on board device to
workstation; creating of Level 0 images;

2. post-processing of trajectory data (GPS and inertial systemmeasurements) to obtain
exterior orientation parameters measured in flight (*.odf files);

3. geometric transformations – projection of Level 0 images on some plane of constant
height (rectification plane) in so called LSR (Local Space Rectangular) coordinate
system, using exterior orientation parameters from previous step; creating of Level
1 images;

Rectification plane – is a plane in LSR coordinate system (Z=const), which constitutes a
right topocentric horizon coordinate system with an origin placed in the center of the area
captured; coordinates of the origin are supplied along with image metadata.

4. automatic tie points measurement and block adjustment of Level 1 images
with/without GCP (using ORIMA program).

Data obtained after preprocessing include the following files:

• transformed Level 1 data – *.tif files, each of them is an image or image fragment
from a set of image fragments composed according to file of image description *.ads;
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That means that during Level 1 images creation the imagemay be split into several fragments
(tif-files), as defined by options of images transformations performed by dedicated software.

• exterior orientation parameters measured in flight – *.odf files;

• adjusted exterior orientation parameters – *.odf.adj files;

• image description files – *.ads files, containing list of fragment files names, which
consist the whole image;

• exterior orientation parameters – *.cam files, containing data about optical system
focal length, as well as coordinates of each detector in sensor focal plane;

• metadata – *.sup files for Level 1 images, which contain parameters of LSR coordin-
ate system, and parameters of linking between rectification plane coordinates and
Level 1 image coordinates.

A limit of Level 1 image size, and size of fragments, the image consists of, could be specified
during preprocessing. It is recommended that each Level 1 image is not more than 4 GB in
size and consist of fragments not more than 500 MB in size each. Otherwise, during adding
images to the project and their processing in the system the performance would considerably
decrease.

Once the preprocessing results of ADS data are obtained, do one of the following:

• If ADS project would be created on the same computer where the preprocessing of
the ADS data was performed, proceed to creation of ADS project in the system and
images loading to it.

• Otherwise, perform preprocessing of ADS data in the system, that includes copying
of files needed for ADS project creation to a separate folder, correction of absolute
paths to ADS files, and histogram normalization (if necessary).
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Fig. 8. Workflow of ADS data preprocessing

5.4.3. Preparing ADS data in the system

Preprocessing of ADS data in the system includes automatic extraction of necessary
files from preprocessing data, copying them to the target folder with organization of
storages structure and automatic correction of absolute paths to files according to their
placement.

At the stage of ADS data preparing it is also could be process a converting of 16 bit
images to 8 bit MS-TIFF images with histogram normalization.

It is recommended to prepare ADS data in the system only if you use different workstations for
ADS data preprocessing in dedicated software and for creation of ADS project in the system.

In order to prepare ADS data in the system perform the following:

1. Choose Service › Prepare ADS data. The Preparation of ADS data window
opens.

19

Project creation (Windows x64)PHOTOMOD 8.0



Fig. 9. Preparation of ADS data

2. Specify folder with ADS data, obtained after preprocessing, in the Source data
placement section.

Make sure that all necessary source data, including all *.cam files, are placed in this folder.

3. [optional] If ADS data folder includes subfolders (with data from on board device,
Level 0 and Level 1 images, preprocessing files), you should set the Including
subfolders checkbox.

4. In the Target folder section choose target folder for files needed for ADS project
processing in the system.

5. In the Processing section choose what is necessary to perform:

• Fix absolute paths in .sup files (strongly recommended) – is used for automatic
input to sup-file absolute paths to the following files:

○ *.ads – images features;

○ *.odf – exterior orientation parameters measured in flight;

○ *.odf.adj – adjusted exterior orientation parameters;

○ *.cam – interior orientation parameters.
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• Convert 16 bps images to 8 bpsMS-TIFFwith histogram normalization (gray
scale only) – is used for images transformation that increases processing per-
formance, but decreases the quality.

The images also could be proceed later – when loading images to a project (see Sec-
tion 5.4.4).

6. Click OK to start data search and copying operation.

In order to prepare big ADS data volumes in the system user can use distributed
processing mode. Perform the following actions to do this:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The Preparation of ADS data:
Distributed Processing window opens.

Fig. 10. Parameters of distributed processing of ADS data preparation

Quantile of found metadata files is displayed in the Found *.sup files field.

3. [optional] Specify the number of tasks.

4. Click OK to create distributed processing tasks.

As a result of ADS data preparing the following subfolders are created in the target
folder:

• ADS_Products – contains the subfolders with names which are the same as images
names. Each of subfolders contains the following files: *.sup, *.odf, *.odf.adj,
*.ads, as well as image file (*.tif) or set of (*.tif) files that contain the image fragments
according to description in ads-file;

• Cameras – contains the subfolders with the interior orientation parameters data –
*.cam files and misalignment.dat files.

Once the ADS data is prepared you can proceed to ADS project creation and images
loading to strips.
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5.4.4. Loading ADS images

Since ADS sensor is able to make survey in different spectral bands (both pan and
multispectral) and at different along-track off-nadir angles (for example, +28°, 0°, -14°),
prior to images adding to a project you should define which of them are most suitable
for specific tasks. Besides, when choosing off-nadir images (-14° or +28°) it is recom-
mended to consider operators’ opinions about comfort of work in stereo mode.

Depending on tasks to be solved, the system provides the following ways of images
block forming:

• add images to each strip in order to form stereopairs using nadir image and one of
off-nadir images (it is preferable to use off-nadir images taken along flight (+28°),
since in this case you obtain more basis to height rate, that results in DEM accuracy
decreasing.

• form images block using only nadir images to create orthomosaic as a result product.
Nadir images are especially preferable if it is necessary to build panchromatic mosaic;

Orthoimage is a high accuracy image of the earth’s surface converted to the map projection.

• form stereopairs from two off-nadir images in each strip (-14° and +28°); that allows
to reach maximal value of survey basis to height rate, and provides maximal DEM
accuracy, but could bring poor result during automatic tie points measurement (if it
is necessary for quality control of mathematical models creation after adjustment
import, for instance);

• creating a “general” project where triplets were made by the following way: add off-
nadir images to one strip (-14° and +28°) and nadir images in the other. It is recom-
mended to use strips with off-nadir images for DEM creation, and strips with nadir
images – for orthomosaic creation considering DEM, built by off-nadir images.

The system provides for automatic splitting of images into strips in ADS projects, for further
formation of triplets from one nadir and two oblique images. For this, choose Block › Split
into strips › By metadata.

In order to load images to ADS images project perform the following actions:

1. Define a set of images block in ADS project, according to way of block forming listed
above.

It is strongly not recommended to use not adjustment exterior orientation parameters from
*.odf-files. Otherwise, incorrect data could be used. In case of loading such data warning
and full path to images are displayed.
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2. Choose the Block › Add strip or click the button in the Block editor window to
create a strip (see Section 7.3).

3. Choose Block › Add images from files or click the button in the Block editor
window. The Add pushbroom images window opens.

Operation of ADS images adding is the same as operation of satellite scanner im-
ages adding.

During ADS project processing you can perform search for ADS images only (not any
scanner images) in the Add pushbroom images window. And vice versa, for Satellite
scanner imagery project you can search only for satellite scanner images and then recog-
nize their metadata.

For ADS project in the Add pushbroom images window there is the Prepare ADS data
button, that duplicates the Service › Prepare ADS data menu item (see Section 5.4.3).

Fig. 11. Search for ADS images and accompanying data

4. Choose folder that contains images. The contents of selected path are displayed
in the right part of the window.

5. In the Autosearch section define the following settings:

• Selected folder only used to search for remote sensing data in the selected
folder only;
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• Selected folder and subfolders used to search for remote sensing data in the
selected folder and its subfolders.

• Pan-sharpening allows to open the Adding images found window to view de-
tailed parameters, to perform pan-sharpening operation and images setting.

• Show rasters without metadata – allows to perform search of all files with im-
ages in selected folder, including those without metadata.

6. Click the Search button. In the Images to add section are shown found data.

The automatic split to strips feature allows to load all images to one strip at once, and then
distribute images among strips using defined image name template or according to exterior
orientation parameters.

Non-ADS scanner images, found in specified folder, are marked in the table by yellow
color.

Images, already added in to project, are marked in the table by gray color.

7. [optional] Click theRadiometry button to perform radiometric correction of images,
selected in the Images to add table.

8. Click the Add all button to add all images of the table to the list of convertible files.
Click theAdd selected button to add one or more images. The Parameterswindow
opens for setting of output images parameters.

Fig. 12. Default parameters of images transformation
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9. Setup parameters of ADS images transformation, specify target folder in profile
resources where to save transformed images, and choose action for the case if the
target folder already contains images files with the same names.

It is recommended to choose the Auto option in the Format section, since the size of ADS
images is big.

MegaTIFF format is used for converting of Level 1 images which size is more than 4 GB,
and/or for images fragments if their size exceeds 500 MB. After MegaTIFF conversion all
ADS images files will have prf extension and will be placed to target folder.

10. Click OK to start operation of images load and transformation. It could take notice-
able time due to big size of ADS images.

11. [optional] Adjust images if necessary in the ImageWizardwindow and edit the block
after images loading is completed.

12. After block forming from ADS images you should import adjustment results and
proceed to project processing (see Section 5.4.5).

5.4.5. Processing ADS project

In order to proceed to project processing stage (stereo vectorization, DEM creation,
mosaic creation) you should build mathematic models of images using data loaded to
a project by the following way:

1. Choose Adjustment › Block adjustment (see also the “Block adjustment” User
Manual).

2. Click theAdjustment parameters button. The Parameterswindow opens. Choose
the Images tab.

3. Choose the Import adjustment in the Method section.

4. Set theCreate stereopairs andUse adjustment result to create epipole images
checkboxes.

5. Click the Apply to all button, then click OK.

In order to analyze ADS 40/80/100 data adjustment and correctness of their loading to the
system, it is necessary to measure GCP and check points (see the “Aerial triangulation”
User Manual). Further it is necessary to measure at least three GCP on block stereopairs
if the project is performed in local coordinate system like Cartesian (left or right).
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Fig. 13. Setting of adjustment parameters of ADS 40/80/100 images

After images models in ADS project were created, proceed to project processing stage
(see the “Vectorization“, “DTM Generation” and “Orthorectification” User Manuals).

5.5. VisionMap A3 imagery

5.5.1. VisionMap project processing

Aerial photogrammetric complex VisionMap A3 consists of digital metric aerial camera
and ground-based system of automatic processing. Aerial camera provides wide aerial
survey swath with high ground resolution. Ground-based system allows to perform
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automatic processing of photogrammetric blocks, consisting of hundred thousands im-
ages and millions tie points.

Ground-based processing system provides full production cycle: from images upload
to photogrammetric production output.

The processing includes the following operations:

• copying of images and accompanying information to the ground-based system;

• flight results preprocessing and validation;

• aerial triangulation (without GCP);

• check of aerial triangulation results;

• [optional] exterior orientation using GCP (with additional adjustment);

• [optional] DEM calculation;

• orthomosaic creation and quality control of work;

• import of large-format images (KCC or SLF) suitable for stereo vectorization in the
system.

Depends on type of source image there are two ways of VisionMap A3 project pro-
cessing:

• to export initial large-format images SLF (Super Large Frame), create a project of
the VisionMap A3 SLF type (see Section 5.5.2);

• to small format images, create a project of the Central projection type (see Sec-
tion 5.5.3).

5.5.2. VisionMap A3 SLF

In order to perform stereo processing of large-format SLF images in the system perform
the following actions:

1. Specify VisionMap A3 data folder. The sufficient initial data for processing in the
system are pairs of files of the same name, each includes image tif-file and
metadata dat-file, that contain interior and exterior orientation parameters for cor-
responding image.

In case of processing a big project, use the Raster Converter module in distributed pro-
cessing mode for pre-processing of source SLF-images. After conversion add metadata
dat-files to target folder with images files.
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2. Create VisionMap A3 SLF project. Choose the VisionMap A3 SLF project type
in the Type section, specify project name, coordinate system, terrain heights differ-
ence and folder to place project files in profile resources (see Section 6.1).

It is strongly recommended to input terrain heights values to the Relief elevation section
during creation of VisionMap A3 SLF projects type.

3. Load images to the project (see Section 7.4.2).

The system allows to form strips of VisionMap A3 images automatically, using exterior
orientation parameters from metadata (see Section 7.8.1).

4. Choose the Project › Synchronize.

5. Create block layout using adjustment results. For that in the Block layout window
set the By ties option, set the Adjustment results checkbox only and click the
Apply button. Block adjustment quality control is performed in the Aerial triangulation
module (see the “Aerial triangulation” User Manual).

Fig. 14. VisionMap A3 SLF project

For VisionMap A3 SLF projects the Block adjustment toolbar is not shown. Accuracy
control could be checked bymerging coordinates of the same points on neighbor stereopairs
in stereomode.

Proceed to stereo processing step.
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5.5.3. VisionMap A3 (central projection)

In order to perform processing of small-format images in the system, execute the follow-
ing actions:

1. Specify folder with VisionMap A3 data.

2. Create a project of theCentral projection type. In theNew projectwindow choose
theCentral projection project type, specify project name, coordinate system, terrain
heights difference and folder to place project files in profile resources (see Sec-
tion 6.1).

3. Load images to the project from a folder with VisionMap A3 data, including subfolders
(see Section 7.4.2).

4. ChooseOrientation › Import orientation frommetadata.... The Import orientation
from metadata window opens.

5. Set the Import interior orientation and Import preliminary exterior orientation
checkboxes.

6. Click OK. After that the exterior and interior orientation parameters are imported
from images metadata to the project. At that a camera file with name containing
camera serial number is created for each project camera.

Fig. 15. VisionMap A3 project (central projection)
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7. Choose Orientation › Direct georeferencing or click the button of the AT
toolbar. After that the system displays information window, which contains informa-
tion about number of images adjusted using exterior orientation parameters.

Proceed to stereo processing step.

6. Project creation

6.1. Creating new project

In order to create a new project perform the following actions:

1. Choose active profile.

2. Run the system.

3. Open the New project window using one of the following ways:

• choose Project › Open/Manage... (Ctrl+Alt+O) or click the button on the
main toolbar. The Manage project window opens. Click the New button;

• choose Project › New.

TheNew projectwindow opens automatically if there is no existed projects in the active
profile.

Fig. 16. New project window
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4. Define a Name of new project.

5. [optional] Input to the Description section a brief project description, its main fea-
tures, notes etc.

6. Specify project type in the Type field depending on survey type:

• Central projection – used for processing of aerial or space borne images of
central projection and also for small format images from VisionMap A3.

Acceptable image formats are *.jpg and *.tiff.

In theAdditional parameters section, select actions to be executed when creating
a project:

○ [optional] create an Empty project to process it manually in usual way (see
below);

○ [optional] Add images from folder ( ) to the project, place all the project’s
images into one strip and perform automatic splitting images into strips using
image names, exterior orientation parameters or metadata, as well as create
block layout automatically (see Section 6.1.1).

■ [optional] To convert images when adding from *.jpg to *.tiff format, set
the appropriate checkbox.

Fast project creation allows for automatic execution of some primary project processing
stages which are usually executed manually according to this Manual after Empty
project creation.

Fast project creation is available only for Central projection type projects and this
greatly facilitates and accelerates data processing.

Fast project creation is recommended only if high quality initial data are available,
i.e. *.jpg or *.tiff images, as well as interior and exterior orientation elements (see
Section 6.1.1).

• Satellite scanner imagery – used for processing of space borne scanner images;

• ADS 40/80/100 – used for processing of data, acquired by ADS 40/80/100 digital
sensor;

• VisionMap A3 SLF – used for processing of images, acquired by VisionMap A3
camera.

7. In theCoordinate system section click the Select button (see Section 4.1). Project
coordinate system could be chosen from the following sources:
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In case of fast project creation, the Autoselect of a coordinate system is possible if the
appropriate metadata are available (see Section 6.1.1).

• From DB: International, Local – used for coordinate system choosing from in-
ternational or local database.

• From file – used to load a coordinate system from the *.x-ref-system file (if
any), placed outside from active profile resources.

• From resource – used to load a coordinate system from the *.x-ref-system file,
located in active profile resources (from another project of active profile, for in-
stance);

• From GeoCalculator – from the list of GeoCalculator program database (see
the “Coordinate Systems” chapter in “The GeoCalculator program” User manual).

The GeoCalculator program allows to edit coordinate systems, to create new ones, to
perform import and export of coordinate systems (see the “The GeoCalculator program”
User Manual).

When choosing coordinate system from database theCoordinate systemdatabase
opens, which contains the list of coordinate systems.

Fig. 17. Window used to select coordinate system from coordinate system database

To perform fast search for coordinate system, input the whole coordinate system name or
its part to the Find input filed.

To choose geoid to be used, click the button. Select proper type of geoid usage:
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• No geoid;

• EGM 96.

The system allows to use the EGM2008 geoid. See more details in the “Installation
EGM2008 Geoid” User Manual. After installation the geoid is displayed in the list.

PHOTOMOD GeoCalculator provides for creating a user height system (geoid) with
preset parameters. PHOTOMOD system allows to use previously created custom ver-
tical datum (geoid). See instructions in the “Creating custom height system” chapter of
“The GeoCalculator program” User Manual.

8. [optional] Set the Relief elevation checkbox and specify approximate difference
of terrain heights on project images in the min and max input fields.

If the relief elevation data is unavailable or inaccurate by the time of project creation, the
system allows to define the value later in project properties. Terrain elevation data is used
to refine a block layout, it is considered during import of exterior orientation parameters
and during calculation of ground sample distance (GSD).

If the Relief elevation was not indicated while project creation, it is in any case will be set
when importing exterior orientation elements (see the “Aerial triangulation” User Manual),
including in the case of fast project creation (if the appropriate metadata are available).

9. In the Project path list choose a folder of active profile resources to place project
files there.

Only folders of two upper levels could be used to place project files into the Project path
list (virtual folders and their subfolders), which do not contain images files. To edit structure
of profile resources use the PHOTOMOD Explorer module (see the “General information”
User Manual).

Virtual folders connection to network profile is performed only in theControl Panel module.
After update of profile resources structure click the button to refresh the list in the Project
path section.

The search field that allows to Find a project in the list by its name or name part is situated
below the Project path list. F3 key allows to focus marker on the search field. Press F3
again to focus marker on the next found project in the list.

The Full project path input field will show the project name and full path.
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10. Click OK to complete a project creation. After that service folders and configuration
files are created in the specified project folder.

In case of fast creation of a Central projection type project, it is possible to use
the distributed processing mode. For this, perform the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button.

11. [optional] In case of creating the ADS project, proceed to ADS data preparing and
images loading (see Section 5.4.4).

Fig. 18. Service folders and files of a new project

In order to view or edit some parameters of created project, use the Project properties
window.

To display residuals vector perform one of the following:

• choose Project › Properties (see Section 8.3);

• double-click coordinate system name in status bar. The Select reference system
type window opens. Click the Project properties button.

After project creation proceed to the image block forming step: load and setup project
images (see Section 7).
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6.1.1. Fast project creation

The system allows us to create projects of the Central projection type in two ways:

• [optional] create an Empty projectmanually in usual mode according to this Manual;

• [optional] use the function of fast project creation of the Central projection type.

Fast project creation supposes automatic execution of some primary project processing
stages which in usual mode are executed manually according to this Manual after
Empty project creation.

Fast project creation is available only forCentral projection type projects and greatly facilitates
and accelerates data processing.

Fast project creation is recommended only in case of high quality initial data, i.e. *.jpg or *.tiff
images, as well as interior and exterior orientation elements.

Fast project creation allows you to automate the following operations:

• Image block forming – when finding suitable initial data in the folder indicated by the
user, the system adds images in one strip and optionally convert them into *.tiff,
otherwise the operation is interrupted and the following message is created:

Fig. 19. Project creation interruption because of the lack of correct initial data.

In case of fast project creation, radiometric correction of images is not performed

• Image interior orientation (see the appropriate section in the “Aerial triangulation”
User Manual);

In most cases metadata of modern digital aerial images contain necessary information for
interior image orientation. When checking the correctness of interior orientation (after project
creation), the user can also calibrate cameras if necessary data are available (see the “Aerial
triangulation” User Manual).

• Import of image exterior orientation elements and further automatic splitting images
into strips by image names, by exterior orientation elements, or by metadata, as well
as automatic block layout (see the “Aerial triangulation” User Manual);
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Execution of selected processing stages depends directly on the availability (and quality) of
exterior orientation elements delivered with initial data. In many cases (depending on a sensor)
these data can be incomplete.

The system provides possibility to create a block scheme by UAS images if angular exterior
orientation parameters of block images are specified with low accuracy or are unavailable.

In this case the system automatically launches the algorithm that allows us to set kappa angle
according to the flight path.

For each highlighted image the system calculates the direction from previous to next center
in a strip (for utmost images of a strip – from adjacent image to the current one) and kappa
angle is setup from this direction.

After automatic project primary processing completion, it is recommended to ensure that
block splitting into strips and block layout is performed quite correctly.

• Autoselection of the project coordinate system and project elevation range by the
exterior orientation elements, if they are not selected by the user manually (see below).

Autoselection of the coordinate system is possible if the appropriate data are available. If
such a checkbox is set, but exterior orientation elements are not found and imported, the
Cartesian right-handed coordinate system will be set by default

After automatic project primary processing completion, the appropriate message appears
with the description of current project status and the list of executed operations (depend-
ing on input data quality).

In ideal case, given the satisfying results of fast project creation, the user can skip to
relative image orientation execution (see the “Aerial triangulation” User Manual).

First, ensure that image interior orientation, automatic block splitting into strips, and block layout
were made quite correctly. Optional, perform radiometric image correction (if necessary) and
camera calibration (if the appropriate data are available).

Otherwise, it is necessary to execute skipped project primary processing stages
manually (according to the info message, this document, as well as to the “Aerial trian-
gulation” Manual).

6.1.2. Fast central projection project creation

For fast creation of a central projection project, perform the following:

1. Choose active profile;

2. Run the system;

3. Open the New project window using one of the following ways:
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• choose Project › Open/Manage... (Ctrl+Alt+O) or click the button on the
main toolbar. The Manage project window opens. Click the New button;

• choose Project › New.

Fig. 20. New project window

TheNew projectwindow opens automatically if there is no existed projects in the active
profile.

4. Define a Name of new project;

5. [optional] Input to the Description section a brief project description, its main fea-
tures, notes etc;

6. Specify project type – Central projection;

7. In the Additional parameters section, select the Add images from folder option
and click the button to specify the folder with images inWindows file system;

Acceptable image formats are *.jpg and *.tiff.

• [optional] To convert images when adding from *.jpg to *.tiff format, set the
appropriate checkbox.
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When adding images, it is recommended to convert them into the *.tiff format to in-
crease system performance during execution of some operations. Note, that *.tiff
images take up larger amount of disk space.

8. In the Coordinate system section perform one of the following actions:

• [optional] set the Autoselect checkbox;

Autoselection of the coordinate system is possible if the appropriate metadata are
available. If such a checkbox is set, but exterior orientation elements are not found and
imported, the Cartesian right-handed coordinate system will be set by default.

• [optional] click the appropriate button to Select coordinate system manually, if
it’s reasonable (see Section 4.1). Project coordinate system could be chosen
from the following sources:

○ From DB: International, Local – used for coordinate system choosing from
international or local database.

To create new coordinate system is used the Coordinate system builder (see the
“General information about system” User Manual).

○ From file – used to load a coordinate system from the *.x-ref-system file (if
any), placed outside from active profile resources.

○ From resource – used to load a coordinate system from the *.x-ref-system
file, located in active profile resources (from another project of active profile,
for instance);

○ From GeoCalculator – from the list of GeoCalculator program database (see
the “Coordinate Systems” chapter in “The GeoCalculator program” User
manual).

The GeoCalculator program allows to edit coordinate systems, to create new ones,
to perform import and export of coordinate systems (see the “The GeoCalculator
program” User Manual).

When choosing coordinate system from database theCoordinate systemdatabase
opens, which contains the list of coordinate systems.

To perform fast search for coordinate system, input the whole coordinate system name or
its part to the Find input filed.
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Fig. 21. Window used to select coordinate system from coordinate system database

To choose geoid to be used, click the button. Select proper type of geoid usage:

• No geoid;

• EGM 96.

The system allows to use the EGM2008 geoid. See more details in the “Installation
EGM2008 Geoid” User Manual. After installation the geoid is displayed in the list.

PHOTOMOD GeoCalculator provides for creating a user height system (geoid) with
preset parameters. PHOTOMOD system allows to use previously created custom ver-
tical datum (geoid). See instructions in the “Creating custom height system” chapter of
“The GeoCalculator program” User Manual.

9. [optional] Set the Relief elevation checkbox and specify approximate difference
of terrain heights on project images in the min and max input fields.
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If the relief elevation data is unavailable or inaccurate by the time of project creation, the
system allows to define the value later in project properties. Terrain elevation data is used
to refine a block layout, it is considered during import of exterior orientation parameters
and during calculation of ground sample distance (GSD).

If the Relief elevation was not indicated while project creation, it is in any case will be set
when importing exterior orientation elements (if the appropriate metadata are available).

10. In the Project path list choose a folder of active profile resources to place project
files there.

Only folders of two upper levels could be used to place project files into the Project path
list (virtual folders and their subfolders), which do not contain images files. To edit structure
of profile resources use the PHOTOMOD Explorer module (see the “General information”
User Manual).

Virtual folders connection to network profile is performed only in theControl Panel module.
After update of profile resources structure click the button to refresh the list in the Project
path section.

The Full project path input field will show the project name and full path.

11. Click OK to complete a project creation.

When fast project creation, it is strongly recommended to use the distributed pro-
cessing mode (otherwise, click OK to complete project creation). To use the distrib-
uted processing mode, perform the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button.

During project creation, service folders and configuration files are created in the
selected project folder. After automatic primary project processing completion, the
appropriate info message describing current project status and the list of executed
operations (depending on input data quality) appears.
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Fig. 22. An info message on download of imagery without metadata into the project.

12. Read the info message. According to this document, as well as to the “Aerial trian-
gulation” Manual, ensure that interior imager orientation, automatic splitting block
into strips, and block layout were performed quite correctly.

Perform radiometric image correction (if necessary) and calibrate camera (if the
appropriate data are available).

If you are satisfied with fast project creation, go to relative orientation of images
(see the “Aerial triangulation” Manual), otherwise, first performmanually the skipped
stages of primary processing of the project (guided by the info message).

6.2. “Without project” mode

The system allows working without loading a project.

Without project mode allows to load processing data of some active profile project –
vector objects, TIN, DEM – to view, edit, control accuracy, import/export.

Without project mode provides the following possibilities: changing working coordinate
system, processing of georeferenced raster images, 3d-modeling in the 3D-Mod program.

In order to work in the system without loading a project perform one of the following:
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• in the Project management window click theW/o project button (see Section 8);

• choose Project › Close if there is some opened project in the system.

During working without project it is necessary to setup the working coordinate system
for correct loading of georeferenced data to the system.

Specifying the working coordinate system is required to display in Yandex.Maps and in Google
Maps, for this, there should exist conversion between the working coordinate system andWGS84
(see Section 4.3).

To setup or change working coordinate system, perform one of the following:

• choose Service › Working coordinate system;

• double-click coordinate system name in status bar. The Select reference system
type window opens. Click the Project properties button.

Working coordinate system allows to display marker coordinates in theMarker window
and status bar, and also to show marker position in Yandex.Maps or in Google Maps.
Also during import/export of objects working coordinate system is considering as a
source coordinate system.

Fig. 23. Working coordinate system

7. Images block forming

7.1. The “Block” menu

The Blockmenu is used for work with images block in 2D-window. It includes extended
features for images block forming, as well as additional functions for block scheme
creation and obtaining of auxiliary data.

The Block menu functions are partially duplicated in the Block editor window (see
Section 7.2) and in the Block forming toolbar.

Some menu items allow to manage operations with selected images in 2D-window.
The Tools additional toolbar is used for group selection (highlighting) of images block
in 2D-window (see the “Vectorization” User Manual).
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Table 5. Brief description of the “Block” menu

FunctionMenu items
to add new stripAdd strip
to delete selected strips of block in 2D-windowDelete strip
to view and edit properties of selected strips – strip’s
name and type (regular or irregular)

Strip properties

to invert strips orderInvert image order in strip
to move selected strips to the beginningSelected strips to block start
to move selected strips to the endSelected strips to block end
to move selected strips one strip upMove selected strips up
to move selected strips one strip downMove selected strips down
to change regular strip to irregularMake selected strips irregular
to change irregular strip to regularMake selected strips regular
to add images from files located out of active profile
resources to selected strip (see Section 7.4.2)

Add images from files

to add images located in active profile resources to
selected strip (see Section 7.4.3)

Add images from resources

to automatically add images from specified folder
of active profile resources to selected strip, with or
without its subfolders

Add images from resource folder

to delete selected images from project (images files
are not physically deleted at that)

Delete images

to select images in accordance with specified criteria
for deleting (see Section 7.8.3)

Delete images selectively...

to display and edit properties of selected imageImage properties
opens a group of menu items used to images block
editing; allows to invert images order in a strip, and
to move selected image left/right/up/down

Move images

to perform radiometric correction of selected image
(see Section 7.7)

Image radiometric correction

to show images of block in 2D-window if the limita-
tion on images display is specified on the Block

Show images

scheme | Raster tab in the Settings window (see
“General information” User Manual)
to turn on/of selected images displayShow selected images only
to perform search for 16-bit project images without
radiometric correction (no *.rmc file associated with

Check images

the image, see “Radiometric correction” in the
“General information” User Manual). If images are
found in the project that meet the criteria described
above, an appropriate info message is issued
to exclude project images validation - check their
presence and compliance to images files during
project opening at the next working session

Mark all images as checked
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FunctionMenu items
to move marker to center of the image, selected in
the list of the Block editor window

Marker to selected image

contains groups of menu items used to create block
layout; allows to refresh, load, save block layout,

Block layout

applyw/o layout or by exterior orientationmodes,
build block layout automatically for Unmanned Aer-
ial System (UAS) projects, delete results of automat-
ic block layout (see the “Aerial triangulation” User
Manual)
to split images block to strips automatically using
images names, exterior orientation parameters,

Split to strips

metadata, and split VisionMap images block (see
Section 7.8.1)
to rotate selected images at any angle relatively to
initial or current position of block images

Rotate selected images

to rotate all or selected images of block considering
block layout data; images don’t rotate if the w\o

Rotate images by block layout

layoutwas used (see the “Aerial triangulation” User
Manual)
to define/calculate GSD value in meters for all or
selected images of block (see Section 10.1)

Set GSD for selected images

to create map of images and/or strips overlap in
new vector layer (see Section 10.2)

Create overlap map...

to create vector layers with common block outline,
boundaries of all images or selected image of the
block (see Section 10.3)

Create vector layer from block layout

to create pre-regions by images/stereopairs to
provide joint work on a project (see Section 10.4)

Build pre-regions

to export block scheme to KML or KMZ formatExport block layout to KML, KMZ...
to calculate useful areas in automatic modeUseful areas
to open the TK-350 camera passport file (with *.txt
extension) for the further processing

Reference crosses conversion

to build brightness adjustment for all block schemeBrightness adjustment
to delete the brightness adjustment resultsDelete brightness adjustment

7.2. The “Block editor” window

The Block editor window is used to form a block of project images.

TheBlock editorwindow contains a table of created strips and images loaded to project
and contains tools for images block editing.

TheBlock editorwindow is synchronized with 2D-window: so all changes in the images
list of the Block editor (choosing, adding, deleting, moving of strips and images) are
shown in the block scheme in 2D-window and vice versa.
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To open the Block editor window choose the Windows › Block editor (Ctrl+Alt+B)
or click the button on the main toolbar.

Fig. 24. The Block editor window

The Block editor window contains the following elements:

• toolbar to form and edit block images;

• the list of existed strips and loaded there images;

• the status bar with the following data:

○ Strip – the Strip name [item No/total] is displayed for strip selected in the table;

○ Image – the Image name [item No/total in strip/total in block] is displayed
for image selected in the table;

○ Font size – allows to change the font size of table text.

To select (highlight) the image in the Block editor window click the image name in the
list. To select strip click the name of strip.

To select multiple images\strips use Shift and Ctrl keys.

To highlight several images in 2D-window use additional toolbar of group selection (see the
Tool section in the “Vectorization” User Manual).

The Edit › Select all, Edit › Invert selection and Edit › Cancel selection allows to
change strip or images selection both in block scheme and in 2D-window.

The Block menu items, buttons of the Forming block toolbar and the toolbar of the
Block editor window.
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Table 6. The toolbox of Block editor window

FunctionButtons
to change the Block editor window size so that window displays all list of
strips/images
to show/hide the list of strips/images and the status bar to comfort work with block
images in 2D-window (in the Block editor window only toolbar displays)
to search for an image by name (part of name)
to select in the list initial images, that contain marker position
to edit names of several strips of the block at the same time
to display and edit properties of selected strip (name and type of strip)
to reverse images in the strip order
to add new strip
to remove selected strip
to move selected strips on one strip up
to move selected strips on one strip down
to display and edit properties of selected image
to add images from files located out of active profile resources to selected strip
to add images from files located in active profile resources to selected strip
to delete selected images from project
to radiometric correction of selected image
to move selected images left/right/up/down, , ,
to rotate selected images to any angle relatively to initial or current location of images
in the block

to open theBlock layoutwindow to build block scheme in 2D-window considering
source or acquired data (see the Aerial triangulation User Manual)

to open the ImageWizard utility to setup images

to show block images in 2D-window, if they were not displayed during project
loading, due to limitation specified in the system’s setting window (see the “Gen-
eral information about system” User Manual)

to set on/off displaying only selected images mode

to open the list of images that form stereopairs with an image selected in theBlock
editor window, including the case when two images forming a stereopair are loc-
ated on different strips

7.2.1. Search and select images

To search images in the Block editor window, perform the following:

1. Click the button at the Block editor toolbar. The Find section opens:
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Fig. 25. The Find section in Block editor window

2. Customize search parameters in the appropriate drop-down menu:

• [optional] set the appropriate checkbox to search whole words only;

• [optional] set the appropriate checkbox to add to selected found images;

3. To search, click the next (or backward) buttons repeatedly, as well as to add found
images to selection (optional, if the appropriate checkbox is set).

7.3. Adding strips

During strip creation load images to the project using one of the following ways:

• estimate number of strips, define their names, number of images in each strip, then
add strips one by one and load images there.

• load all images of the project into the same strip and then perform automatic splitting
images into strips using images names, exterior orientation parameters (if such data
is available) or metadata.

Automatic splitting of VisionMap images is also available.

Perform the following actions for creating the single sheet:

1. Choose the Block › Add strip or click the button in the Block editor window’s
toolbar. The New strip window opens.

During creating of project the New strip window opens automatically to create the first
strip.
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Fig. 26. New strip properties

2. Define Name of the strip.

3. [optional] To create block scheme not linked to regular grid, set the Irregular strip
checkbox. Otherwise, the system creates strip of regular type.

If there is no tie points between regular strips, by default overlap percent is used to tie
strips (not less than 10%),

If irregular strip is creating, block scheme does not stick to regular grid.

Images with overlap are loaded in separate strip. If there is a strip with “gap” between im-
ages, it is recommended to create two strips, one of which is irregular.

4. Click OK. New strip creates and its frame displays in block scheme 2D-window.
The row with name of strip displays in the table of the Block editor window.

Frame of regular strip displays in block scheme 2D-window with blue color, irregular - with
orange. Irregular strip is marked by orange color in the table of the Block editor window.

To view and edit strip properties (name and type), click the button or double click the
strip name in the table.

5. Repeat the 1-4 steps for adding new strips.

7.4. Adding images

7.4.1. Images formats

The system provides work with images of commonly used raster formats. However, for
effective work in the system it is strongly recommended to use images of interior MS-
TIFF format (or MegaTIFF for images with more than 4 GB size).

MS-TIFF format – raster TIFF format with pyramid (set of resampled copies of image).
Pyramid provides fast refreshing of images on the screen.
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PHOTOMOD software supports already existing third-party image pyramids, if available (*.ovr).

The system contains some features used for conversion of images of different raster
formats to files of MS-TIFF format. For conversion to MS-TIFF format or direct load to
the system you can use initial images with the following raster formats:

• Tag Image File Format (TIFF) – images of TIFF, BigTIFF and GeoTiff formats, includ-
ing 12-bit images with/without JPEG-compression (with pyramid or without it), that
the system considers as 16-bit ones, so images radiometric correction is not neces-
sary;

• Windows Bitmap File (BMP);

• VectOr Raster Maps (RSW) – images of Panorama software;

• ERDAS IMAGINE (IMG) ’ ERDAS system raster format;

• NITF (NITF);

• JPEG (JPEG);

• GIF (GIF);

• PNG (PNG);

• USGS DEM (DEM);

• PCIDSK (PIX) – raster format with georeference in the heading developed by PCI
Geomatics company;

• JPEG2000 (JP2) – raster format with JPEG compression and georeference in the
heading developed.

the limitation on output file size of JPEG2000 format – no greater then 500 Мb.

7.4.2. Adding images from files

During adding of source images located out of profile resources system, the following
operations are performed by the system: conversion files of internal format, saving
converted files to specified folder of active profile resources, and loading images to
selected strip of a block.

To add and correct source images is used the Add images window.
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Fig. 27. Adding images from files, located out of profile resources

The Add images window allows to perform the following transformations of source
images of acceptable raster formats:

• transformation file of source images in files of inner format: MS-TIFF – for images
with size less than 4GB; MegaTIFF – for images with size more than 4 GB (for ex-
ample, for satellite scanner images or images of ADS 40/80/100 project);

• apply JPEG compression of specified level or LZW compression without quality loss
to 16-bit images;

• convert 8 or 16-bit images;

• perform radiometric correction to improve visual properties of images;

• save images georeference (if georeference files are available for source images);

• to use distributed processing for conversion.

The following buttons in the Source section allows to select images source files:
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• – allows to select all files;

• – allows to unselect all files;

• – allows to invert selection of files.

Table 7. The “List” section toolbar

FunctionButtons
to select all files
to unselect all files
to invert selection of files
to enable display only source images of acceptable raster formats (enabled by default).
to add to the list images files selected in the Files section
to open a drop-down menu that allows user to switch to other methods for adding files
to remove selected images files from the list (they are not removed physically at that)
to remove all images files from the list (they are not removed physically at that)
to enable display of selected images with created pyramid in the View window (enabled
by default)
to show in Preview window all images (if selected image without pyramid, temporary
pyramid creates automatically)
to enable display of images with radiometric correction applied (enabled by default)
to perform radiometric correction of image selected in the list
to apply radiometric correction parameters saved in *.rmc file to selected images
to save radiometric correction parameters of selected image to *.rmc file
to save radiometric correction parameters of each selected image to its own *.rmc file
to perform the autolevels for selected images without opening the Radiometric correction
window.
to create the pyramid
to create the pyramid (distributed processing)

The View section contains the image view window and toolbar with the following buttons:

• – allows to zoom in an image by one step (*);

• – allows to zoom out an image by one step (/);

• – allows to fit to page data of opened layers (Alt+Enter);

• – allows to display data in 1:1 scale, when one pixel of the image corresponds to
one pixel on the screen;

• – allows to open image on full screen.

In order to add images from files, perform the following actions:
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1. Choose/select a strip to add images to the Block editor window or to 2D-window.

2. Choose Block › Add images from files or click the button in the Block editor
window. The Add images window opens.

See detailed description of the Add images window in the “General information” User
Manual.

3. Select folder in the Folders section or click the button in the File section for
choosing folder.

4. Load image in the list by one of the following ways:

• Select image in the File section and click the button.

The button allows to open menu used to perform one of the following actions:

○ Add all from the current folder;

○ Add all from the current folder and subfolders;

○ Adding satellite images;

○ Merge channels from files (see the “Merging channels from separate files”
chapter in the “General information” User Manual).

• in the File section select the image, press and hold left mouse button to move
selected image to the List section.

5. [optional] To build temporary pyramids to open source images and provide their
fast redraw in the View window or in the Radiometric correction window click the

button in the List section.

Temporary pyramid is build automatically, when you choose file without pyramid in mode
of all images displaying. Temporary pyramid is also build automatically after Files with
pyramids are placed to the Pyramid subfolder created automatically in the source image
folder (see the “General information about system” User Manual).

6. [optional] Perform the radiometric correction to eliminate radiometric errors. To
perform radiometric correction without additional settings click the button. The
Auto levels window opens.

52

Project creation (Windows x64)PHOTOMOD 8.0

general.pdf
general.pdf
general.pdf


Fig. 28. Selecting image correction mode

The following types of correction are displayed in the window:

• Stretch channel histogram – allows to spread histogram evenly, separately in
each channel;

○ Set the Trims left and right – area of histogram (in percent) which will not
consider in stretching of histogram.

• +-3 std. dev. – allows to cut histogram area out of 3 standard deviations;

○ Set the Trims left and right – area of histogram (in percent) which will not
consider in stretching of histogram.

• +-5 std. dev. – allows to cut histogram area out of 5 standard deviations;

○ Set the Trims left and right – area of histogram (in percent) which will not
consider in stretching of histogram.

• Auto std. dev – allows to exclude light-exposed areas on image;

○ Set the Trims left and right – area of histogram (in percent) which will not
consider in stretching of histogram.

• Manual std. dev. – allows to cut histogram area out of specified number of
standard deviations;

○ Set the value of deviation each pixel from “average” in the Standard deviations
field.

• QuickLook – allows to use brightness from remote sensing data files.
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○ Set the Trims left and right – area of histogram (in percent) which will not
consider in stretching of histogram.

Processed channels areRed,Blue, andGreen. The channels are identified according
to the channel order displayed (or user defined) in the Channels window. Additional
channels are processed using the average QuickLook histogram.

7. In the Output format section define the following output parameters to convert
images from list:

• File format section specify output files format – interior MS-TIFF format.

• To perform radiometric correction, choose the following actions in theCorrection
parameters section:

○ Save separately (recommended) to save parameters of radiometric correction
of images into separate *.rmc files. In this case just geometric transformations
(rotation-flip) are applied to rasters directly;

At that the image is displayed in the system with all defined parameters of radiometric
correction.

○ Apply to image to apply radiometric correction to the image directly without
possibility to cancel radiometric transformations applied.

• Color depth – Auto, 8 bit or 16 bit.

If color depth of source image is less or equal 8 bit, then color depth of output image
(with the Auto option selected) will be 8 bit, otherwise, 16 bit.

• Compression – choose compression type of output files:

○ None – files are creates without compression;

○ JPEG with quality .. % – TIFF-files are creates with set quality of JPEG-
compression;

Default compression level is 75 %, that provides the 5-7 times compression of initial
image volume.

○ LZW – TIFF-files are creates with LZW-compression;

○ Deflate – TIFF-files are creates with deflate compression.

This type of compression is applied to output images of MS-TIFF format only.
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• In the MegaTIFF section define format to convert voluminous images:

MegaTIFF format is a set of following files: *.prf and files of MS-TIFF format
images placed to folder which has a name of source file and is created after
conversion in specified target folder.

To convert image in to MegaTIFF format, choose one of the following:

○ Auto (by default) for automatic identification of output format depending on
source image size: MegaTIFF only if the size is more than 2 GB; otherwise –
MS-TIFF format;

○ Always on to convert source images to MegaTIFF regardless of their size;

○ Always off to convert source images to MS-TIFF regardless of their size. Im-
ages with more than 4 GB size are displayed incorrectly in the system.

• In the Georeference section specify source files format with georeference:

○ None – in case of no georeferenced files;

○ Internal/GeoTIFF – to create GeoTIFF file;

○ ArcInfoWorld File – to create file in chosen format with ArcInfo georeference;

○ MapInfo TAB – to create file in chosen format with *.tab georeference file.

The button is used to choose coordinate system of georeference file. The Save
datum parameters checkbox allows to save seven parameters of coordinate system
to meta data of TIFF-file;

8. In the Output files placement section define the following parameters of output
files:

• click the button to define target folder in active profile resources where to
save output images files.

• [if files with the same names exist in the target folder] In the When output file
exists section you should define one of the following actions:

○ Skip – not overwrite existing file with the same name;

○ Overwrite – overwrite existing file.

9. Click the Convert button to convert initial images, save them to files in specified
folder of active profile resources and load images to chosen strip. When the opera-
tion is completed the system displays information message that shows a number
of added and skipped images.
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10. [optional] In order to start distributed processing perform the following actions:

To process images correctly, it is strongly not recommended to choose files on a local PC
(in this case the system will display a warning that the input file list contains local paths)..

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter of the “General information” User Manual).

2. Click the Distributed processing button. The Distributed image conversion
window opens.

Fig. 29. Distributed image conversion parameters

3. Set the distributed processing Tasks number.

It is recommended to define number of tasks depending on computer power and
hardware, but not more than five tasks.

4. Click OK to create distributed processing tasks.

7.4.3. Adding images from resources

During adding images from active profile resources, they are loaded in their initial format,
i.e. conversion to the system interior format is not performed. That is why, prior to adding
it is strongly recommended to prepare source images in the Raster Converter program,
save them to target folder and connect this folder to active profile resources as virtual
(see the “General information” User Manual). Otherwise, the source images of acceptable
raster formats are loaded to the system ’directly’ (with creation of pyramids in separate
files in the Pyramid folder), that could result in noticeable slowdown of the system work.

In order to select and add images located in active profile resources, perform the follow-
ing actions:

1. Choose/create a strip in the Block editor window or in 2D-window to add images
there.

2. Choose Block › Add images from resources or click the button in the Block
editor window. The Open window opens, that shows all active profile resources.
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Fig. 30. Choosing images from active profile resources

3. Choose images files using one of the following ways:

• To display images files of interior MS-TIFF format and usual TIFF format, choose
the TIFF images option in the list located in the right lower corner of the window.

• To display JPEG images files, choose the JPEG images option in the list located
in the right lower corner of the window.

• To display images files of acceptable image formats, except for MS-TIFF and
TIFF formats, choose the All resources option in the list located in the right
lower corner of the window.

During images loading you will get a query whether to build a pyramid for speed up im-
ages refresh on a screen. Files of such images will be saved to the Pyramid subfolder
in source images folder.

4. Choose images files and click the Open button. The images are added to selected
strip.

If you are loading 16-bit images, for which it is strongly recommended to perform
radiometric correction, you will get a query whether to start ImageWizard module
to perform radiometric correction.
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Click the Yes button to perform radiometric correction, or perform it later after
loading images to a project (see Section 7.7).

For fast adding of all images of suitable raster formats from defined folder of active
profile resources to chosen strip perform the following actions:

1. Choose Block › Add images from resource folder. The Select folder window
opens that shows only active profile folders without displaying folders’ content.

2. Choose a folder containing images files.

3. [optional] Set the Including subfolders checkbox to search for files with images
in subfolders of chosen folder.

4. Click OK. Automatic images search and add them to selected strip is performed.
When the operation is completed the system displays information message that
shows a number of added and skipped images.

7.5. Adding scanner images

7.5.1. Adding scanner images

The system provides possibility of converting scanner images into internal format, their
radiometric correction and also preparing ADS data to load into project.

For next strips adding choose the Block › Add strip or click the button in the Block
editor window. The Add pushbroom images window opens.

To perform preliminary preparation, conversion and saving of scanner images in active profile
resources use the Raster Converter module (see the “General information” User Manual);

The Block › Add images from resources menu item is used for adding scanner images from
active profile resources.
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Fig. 31. Automatic images search in remote sensing product

The Add pushbroom images consists of the following parts:

• folder tree in the left part;

• in the Project images section is displayed the list of images already added in the
project (their project names);

• list of found images in the right part;

• parameters of searching files specifies in the Auto-search section;

• the Images to add section contains table with found images, their names and prop-
erties and also buttons to edit properties of image.

The table contains the following columns:

○ Name – image name;

Edit the appropriate cell to change project name of selected image (by default the image
name is the same as the file name).

○ R – denotes that the radiometric correction was performed;

○ ID – source name of image, obtained from metadata;
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○ Type – type of sensor, from which image was obtained;

○ Width/Height – linear size of sheet (in pixels);

○ Bands – number of channels in image;

○ Bytes/pixel – number of bytes per pixel of image.

The Images to add table contains the following features used to work with images:

○ – allows to perform radiometric correction of selected image;

If the radiometric correction is already performed the R column of the table displays
symbol for selected image, otherwise – symbol.

If a source image has more than three channels, it is recommended to perform histogram
normalization without radiometric correction in order to obtain output orthophoto with the
same number of channels and color depth (see Section 7.5.3).

○ – allows to remove selected images from the table;

○ – allows to remove all images from the table;

○ – allows to display features of selected image;

Fig. 32. Image properties

○ – allows to create the georeference file in MIF/MID format.
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Ctrl+A hotkeys allows to select all images.

The ADS data preparing allows to perform the preprocessing of ADS 40\80\100 data
(see the Preprocessing of “ADS data in the system” section).

Button is shown while working with ADS project only.

In order to add satellite images to a project perform the following actions:

1. Choose/create a strip (see Section 7.3).

The first strip is created automatically after project creation. For next strips adding
choose the Block › Add strip or click the button in the Block editor window.

2. Choose Block › Add images from files or click the button in the Block editor
window. The Add pushbroom images window opens.

The system also allows to add scanner images from active profile resources (Block › Add
images from resources). To perform preliminary preparation, conversion and saving of
scanner images in active profile resources use the Raster Converter module (see the
“General information” User Manual);

3. Choose folder that contains remote sensing product. The contents of selected path
are displayed in the right part of the window.

4. In the Autosearch section define the following settings:

• Selected folder only used to search for remote sensing data in the selected
folder only;

• Selected folder and subfolders used to search for remote sensing data in the
selected folder and its subfolders.

The Pan-sharpening checkbox allows to open the Adding images found window
to view detailed parameters, to perform pan-sharpening operation and images
setting.

The Show rasters withoutmetadata checkbox allows to perform search of all files
with images in selected folder, including those without metadata.

5. Click the Search button. The system performs search for remote sensing
products – browses for files and images and recognizes their properties from
metadata (see a list of scanner images formats in Section 5.3.2).

Once the search is completed you will get one of the following results:
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• If the system failed to recognize RS product format, you will get the following
warning No remote sensing imagery products is found.

Set the Show rasters without metadata checkbox on to add images from TH-1 sensor
with incomplete data set. Images could be added if RPC-files are available.

While working with ADS projectAdd pushbroom imageswindow is used just to search
for ADS images (not all the pushbroom images), for Pushbroom scanner imagery –
to search for satellite pushbroom images only and to search for their metadata

• If in the Auto-search section the Pan-sharpening checkbox is not set, the Im-
ages to add table shows all images found and their properties from metadata.

• If in the Auto-search section the Pan-sharpening checkbox is set, the Adding
images found window opens and you can view detailed parameters of remote
sensing products, perform pan-sharpening, setup images and choose images
manually to add them to the Images to add table (see description in Section 7.5).

Already added images are marked in the table by gray color.

While searching for images with metadata, in the added images list they can be
highlighted with various colours depending on processing level:

• Red colour – indicates non-photogrammetric images;

• Yellow colour – indicates images without any orientation data. Only generic ad-
justment method is applied to them (see Section 5.3).

6. [optional] Click the button to perform radiometric correction of images selected
in the Images to add. If a source image has more than three channels, it is recom-
mended to perform histogram normalization without radiometric correction in order
to obtain output orthophoto with the same number of channels and color depth.

7. Form images list in the Images to add table to add them to a strip.

The system allows to load all images in one strip and split them in to strips automatically
later, using image names or exterior orientation parameters.

8. Click the Add all button to add all images of the table to the list of convertible files.
Click theAdd selected button to add one or more images. The Parameterswindow
to define output parameters of images.

In order to select multiple images in the Images to add table use the Shift and Ctrl keys,
to select all images use Ctrl+A hotkeys.
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9. After setting of output parameters in the Parameters window, click OK. Selected
images are saved to active profile resources, loaded to a strip and displayed in
block scheme in 2D-window.

7.5.2. Detailed properties of adding images

To display detailed parameters of recognized remote sensing products, choose, prepare
and add found images manually to load them to a project is used the Add pushbroom
images window.

Perform the following actions to open Adding images found window:

1. Choose folder that contains images. The contents of selected path are displayed
in the right part of the window.

2. In the Autosearch section set on the Pan-sharpening checkbox.

3. Click the Search button. The Adding images found window opens.

Fig. 33. Detailed properties of adding scanner images

When the images list is formed click the Close button in the Images to add section to
go back to the Add pushbroom images window. The Images to add section of the
Add pushbroom images window displays all images to be loaded (added both auto-
matically and manually).

The Adding images found window is divided for Products and Images parts.

The Products panel is used to view properties of RS products found and contains the
following features:
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• The Products table is used to view found RS products and their properties (ID of
product delivered by supplier, product type – sensor type and preprocessing level,
product format, number of images included to the product);

For images without metadata found by auto-search with the Show rasters without metadata
checkbox set, you should specify Raster as a product type.

• The Product images table is used to display only images included to remote sensing
product and their properties (ID, width, height, number of channels and number of
bytes per pixel).

It is not recommended to change image ID received from supplier using standard OSWindows
tools, for instance.Otherwise, you may face some issues during work with the image, since
the rest of files related to the product may be associated with initial file name.

The Images panel is used to view images properties, perform radiometric correction,
define project names and manually form a list of images to be added to a project. The
panel Images contains the following features:

• The Project images list is used to display images loaded to a project (project names
of the images).

• The Images to add section is used to display data selected for loading to a project.

The table shows all images selected for loading: added manually to the Adding im-
ages foundwindow and added automatically to theAdd pushbroom imageswindow.

The table displays the following images properties: ID, width, height, number of
channels, number of bytes per pixel, and label about radiometric correction availability
+/- in the R column (see Section 7.7).

Edit the appropriate cell to change project name of selected image (by default the image
name is the same as the file name).

The Added images section contains the following buttons used to work with images:

○ – allows to display the features of image, selected in Added images table;

○ – allows to open the Files of product window, which is used to display all files
(images files, files with metadata) of remote sensing product and their properties
(name, path, size and extension);
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Fig. 34. The product files list

○ – allows to create the georeference file in MIF/MID format;

Ctrl+A hotkeys allows to select all images.

○ – is used to start pan-sharpening operation – merging of color (multispectral)
image with grayscale one with more high spatial resolution to obtain as a result
color image with better resolution;

○ – allows to add selected image to the Added images table to load it then to the
project;

○ – allows to remove selected images from the Added images table;

○ – allows to perform radiometric correction of selected image.

If the radiometric correction is already performed the R column of the table displays
symbol for selected image, otherwise – symbol.

65

Project creation (Windows x64)PHOTOMOD 8.0



7.5.3. Parameters of images loading

After choosing images to be added to a strip in the Add pushbroom images window
the Parameters window opens and you can use it to specify parameters of images
conversion and to select a folder in profile resources to place there output images files.

Fig. 35. Parameters of images loading

In order to setup images output parameters in the Parameters window perform the fol-
lowing actions:

1. In the Correction parameters section choose one of the following actions:

• Save separately (by default) is used to save radiometric correction parameters
to individual *.rmc files. In this case only geometric transformations will be applied
to image. And the image is displayed in the system with all correction parameters
specified;

• Apply to image to apply all parameters of radiometric correction (except for
histogram normalization) directly to the image, i.e. the file is saved with changes;

• Normalize histogram is used only to apply histogram normalization automatically
(to correct white color level).

If a source image has more than three channels, it is recommended to perform histogram
normalization without radiometric correction in order to obtain output orthophoto with
the same number of channels and color depth. In case of creating orthophoto, set off
theUse radiometric correction from project checkbox in theOutput image paramet-
ers window (see the “Orthorectification” User Manual).
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2. Depending on the source image you should define color depth of output image in
the Color depth section: 8 bit, 16 bit or Auto (by default) for automatic selection
of color depth.

3. In the Compression section choose one of the following options:

• None – without compression,

• JPEG with quality – to compress image with specified quality;

• LZW – without quality loss;

• Deflate – without quality loss.

Only LZW compression (selected by default) could be used to 16-bit images.

4. In the Format section choose one of the following options:

• MS-TIFF/Big TIFF to convert images with size less than 2 GB;

• MegaTIFF to convert images with size more than 2 GB;

File of MegaTIFF format has prf extension.

Besides, during MegaTIFF file creation a subfolder is created in target folder. The sub-
folder has the same name as image file and contains all necessary auxiliary files to
display big size image in the system.

It is strongly recommended to convert multichannel images (with more than 3 channels)
to MegaTIFF format, otherwise, channels names will not comply with used ones.

• Auto (by default) to define output format automatically depending on size of
source image.

The Auto option is recommended for scanner images.

5. In the Output folder section click the button to define target folder of active
profile resources to place converted images files there. In theOutput folder section
path to the Images folder is displayed or it could be created automatically .

It is strongly not recommended to place image files in the root project folder (e.g., /Pro-
jects/Project_name). It is necessary to place source images only in the Images folder.
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6. In the If output resource exists section select one of the following actions for the
case if the target folder already contains files with the same names:

• Skip – allows to leave existing file;

• Overwrite – allows to refresh existing file;

• Rename – allows to save file with new name.

7. Click OK to start images loading operation. Once it is completed images loaded
will be shown in 2D-window.

8. [optional] Setup paths to image files with the ImageWizard module.

After block forming proceed to aerial triangulation step (see the “Aerial triangulation”
User Manual).

If metadata with exterior orientation parameters is available, create block layout in the
by exteriormode, measure recommended amount of triangulation points and proceed
to adjustment step (see the “Block adjustment” User Manual).

7.6. Image properties

To display properties of image, select an image in the 2D-window and choose the
Block › Image properties or click the button in the Block editor window or double-
click on image name in the table of the Block editor window.

The Image properties window with the following information opens:

Fig. 36. Image properties

• Name of image in the project;
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In case of changing image name, only name in project is changing, not file name.

• Code – unique ID of image that does not change in case of changing image name in
project or file name (see Section 9.2.1);

Image code by default is the same as image name.

• Size in pixels;

• Pixel format – number of channels/bit;

• Color channels – quantity and contents of image channels;

• Resource name – path to an image in active resources profile;

• Ground sample distance, in meters, if it has been specified.

It is recommended to set GSD in case of different-scale survey or toomuch elevation difference
on ground. Also GSD is used for accuracy control for points measurements in triplets. To do
this set the tolerance for error in meters in the Relative orientation report settings window
(see the “Aerial triangulation” User Manual).

The Block › Set GSD menu item is also used to specify GSD for all or selected images (see
Section 10.1).

7.7. Radiometric correction

Images radiometric correction – means improvement of visual features of initial images.
Their insufficient quality may be due to the peculiar properties of the optical path of
surveying devices, radiant energy converter, analog-digital converter, etc.

For example, in case of 16-bit image, that looks plain black on a screen, you have to
perform histogram correction. For example, in case of 16-bit image, that looks plain
black on a screen, you have to perform histogram correction.

If a source image has more than three channels, it is recommended to perform histogram nor-
malization without radiometric correction in order to obtain output orthophoto with the same
number of channels and color depth (see Section 7.5.3).

Images radiometric correction could be performed on different stages of project pro-
cessing, for example:

• on stage of initial images preparation in theRaster Converter module (see the “Gen-
eral information” User Manual);
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• on stage of images loading from files, located out of profile resources, including
loading of satellite scanner images, as well as ADS 40/80/100 scanner images;

• on stage of block forming from project images;

• on stage of project images setting in theImageWizard module.

TheRadiometric correctionwindow is used to perform radiometric correction of selec-
ted image.

Perform one of the following to open the Radiometric correction window:

• click the button in the Block editor window;

• choose the Block › Image radiometric correction.

• click the button in the Add pushbroom images window;

Table 8. The toolbox of Radiometric correction window

FunctionButtons
to load radiometric correction parameters from a *.rmc file
to save radiometric correction parameters of image to *.rmc file
to zoom in an image by one step (*)
to zoom out an image by one step (/)
to fit to page data of opened layers (Alt+Enter)
to display data in 1:1 scale, when one pixel of the image corresponds to one pixel on
the screen
to change the channels order
to perform the channel transformation
to perform the radiometric correction
to edit curves
to change brightness, contrast and gamma of image
to edit color balance of the image
to apply filters
to apply geometric transformation (rotate, reflection)
to cancel all actions (up to 10 last actions)
to undo the last action
to redo the last undone action
to view raster image histogram (see Section 9.11)

Perform the following actions for radiometric correction:

1. Select image in the List section in main window of the Raster Converter module.
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2. Click the button or double click the strip name in the list. As a result, temporary
pyramid for faster refresh of image creates and theRadiometric correctionwindow
opens.

Temporary pyramid is placed in the \Pyramid folder inside of folder with source images.
To display images in scales differing from 1:1, required amount of free place on chosen
disk to store temporary pyramid’s files.

Fig. 37. The Radiometric correction window

Name, height, width and byte per pixel of image are displayed in the title of the
Radiometric correction window. Coordinates of marker and brightness are dis-
played in the status bar of window.

3. It is recommended to perform autolevels setup for 16-bit image. Otherwise it is
displayed with black color.

If bytes per channel more than 8, histogram of images stretches for full brightness range
separately on each channel.

Fig. 38. Requirement to perform radiometric correction
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4. Click the Yes button. The Auto levels window opens.

Fig. 39. The Auto levels window

5. Setup parameters of correction (see below) and click OK. Image radiometric correc-
tion is performed.

Generally, it is suffices in the Standard deviationsmode specify the Standard deviations
value or click the Auto adjust button to correct image automatically.

The system allows to save radiometric correction parameters to *.rmc files in order to
apply these parameters to other images. Perform the following actions to do this:

1. Select image in the List section in main window of the Raster Converter module.

2. Setup parameters and perform radiometric correction of selected image.

3. Click the button and define a folder to save radiometric correction parameters
in file with rmc extension.

To save radiometric correction parameters in folder with source image, click the button.

4. Choose image for correction in the list.

5. Click the button. The Load correction parameters window opens.

6. Choose parameters file and click OK. Correction parameters apply to selected im-
ages.

Perform the following to change channel’s order of output image:
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1. In the Radiometric correction window click the button. The Channels window
opens.

The first order of channels is set depending on their order in the source image.

Fig. 40. Window of the order channels setup

2. Specify the mode of channel usage in the system:

• RGB and other channels – all image channels are to be used;

The user can assign any channel as a red, green, or blue one (see below, next subsec-
tion). Other image channels will be considered as supplementary.

• RGB only – only three channels are used;

The user can assign any channel as a red, green, or blue one (see below, next subsec-
tion).

When processing images with a large number of channels, using RGB only mode (or
channels designated as such) allows one to exclude “extra” channels from processing
if the user does not need them to perform current tasks.

• Grayscale (single channel) – is used to display one channel.

The Raster Converter module also provides for transforming a one-channel panchro-
matic raster image into a three-channel one. For this, when converting such an image,
choose RGB only. As a result, when saved, the image has three identical channels.

3. Setup channels order to display and use in the system.
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The Apply button allows to display changes.

4. Click OK.

Perform the following to transform channels of output image:

It is impossible to preform channels transformation for image with single channel.

1. In the Radiometric correction set the checkbox on near to the button and click
the button. The Channels transformation window opens.

The window contains table with weight coefficients image channels.

Fig. 41. The Channels transformation window

2. Change values in the channels table.

3. Click the Apply button to display changes.

4. Click OK to save changes.

Perform the following to perform more detailed radiometric correction (to correct white
color level):

1. In theRadiometric correctionwindow click the button. TheAuto levelswindow
opens.
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Fig. 42. The Auto levels window

2. Choose the correction Mode:

• Separate channels - correction separately for each channel;

• All channels – correction for all channels rateable;

• Red, Green, Blue – correction only for chosen channel;

• Autocolor – automatic selection of the best brightness for displaying;

• Standard deviations – stretching histogram of source image for full brightness
range;

• QuickLook – allows to use brightness from remote sensing data files.

Processed channels are Red, Blue, and Green. The channels are identified according
to the channel order displayed (or user defined) in the Channels window. Additional
channels are processed using the average QuickLook histogram.

• External image – using image from folder as a sample for correction.

3. Set the Trims left and right – area of histogram (in percent) which will not consider
in stretching of histogram.

4. [optional] Bу default the Cut background checkbox is set on for removing back-
ground on image edges. To remove background set the following parameters:

• Background color – value of background color for cutting;

If the 0 value is set in theBackground color field, background does not consider during
correction.
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• Tolerance – deviation from background color value for cutting.

5. Set the value of deviation each pixel from “average” in the Standard deviations
field.

The Auto adjust button allows to calculate value of Standard deviations in such a way as
to none of pixels was not light-exposed.

6. Click OK. As a result histogram stretches of source image for full brightness range.

To view histogram of image and setup activation function, that specify arbitrary brightness
transformation, perform the following:

Activation function in graphic form is a curve with color of chosen band. Values of brightness
on source images are placed by X-direction (values in the In field), be Y-direction – values after
transformation (values in the Out field). Activation function is specified by creating nodes on
curve. Activation function between nodes is a cubic spline.

1. In the Radiometric correction window click the button. The Curves window
opens.

Fig. 43. The Curves window

The window contains the toolbar with buttons used to perform the following opera-
tions:

• – allows to restore linear dependence;

• – allows to display grid;

• – allows to show source histogram (with gray color);

• – allows to show destination histogram (with white color);

• – allows to smooth segment;
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• Restore – allows to restore source curves;

• Load – allows to load curves from crv-file;

• Save – allows to save curves in to crv-file (by default in the folder with images).

Values of brightness of node in source and changed histograms are displayed ac-
cordingly in the In and Out fields.

2. [optional] To edit channels histogram separately, set the For all checkbox off and
choose Channel for edit from the list.

By default the For all checkbox is set on to edit curve for all channels in one time.

3. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

• Background color – value of background color;

If the 0 value is set in the Background color field, background also will be changed
during the correction.

• Tolerance – deviation from background color value.

4. [optional] Set the Preview checkbox on to preview changes.

5. To add node click on the histogram. To move node, move marker holding pressed
left mouse button.

To select node, click in its vicinity. To delete node, right click on it.

6. Click the Apply button to apply changes and return to the Radiometric correction
window.

To perform color correction do the following actions:

1. In the Radiometric correction window click the button. The Brightness-Con-
trast-Gamma window opens.
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Fig. 44. The Brightness-Contrast-Gamma window

2. Choose Channels for correction: All in the same time or separately.

3. Setup balance of image brightness, contrast and gamma using sliders.

4. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

• Background color – value of background color;

If the 0 value is set in the Background color field, background also will be changed
during the correction.

• Tolerance – deviation from background color value.

5. [optional] To display changes automatically set the On fly checkbox on.

The Apply button allows to display changes.

6. Click OK to apply color corrections of image.

To perform color balance do the following actions:

1. In the Radiometric correction window click the button. The Color balance
window opens.
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Fig. 45. The Color balance window

2. Set the red, green or blue channels balance using sliders or input values of color
in the Values field with range from -100 to 100.

3. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

• Background color – value of background color;

If the 0 value is set in the Background color field, background also will be changed
during the correction.

• Tolerance – deviation from background color value.

4. [optional] To display changes automatically set the On fly checkbox on.

The Apply button allows to display changes.

5. Click OK to apply color balance of image.

To improve visual properties of source image with using different filters perform the
following:

1. In the Radiometric correction window click the button. The Filters window
opens.
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Fig. 46. The Filters window

2. Specify one of the following image processing types in the Filter type list:

• Blur – is used for image details dithering;

• Gaussian blur – is a type of blur filter where transfer value is not a linear function,
but part of Gauss function (“Bell curve”);

• Sharpen – allows to highlight and intensify differences between image’s individual
details (image sharpness);

• Sharpen edges – is used to setup image sharpness, but performs filtering only
when brightness differences between details are exceeding some threshold;

Suits very well for identifying and highlighting of objects borders which are homogeneous
insight (agricultural fields, for instance), at that inner part of objects remains unchanged.

• Median – non-linear filter intended mainly for impulse noises filtration (single
pixels with unnatural brightness);

• Sobel – non-linear differential filter, which is the first derivative of the initial raster.
Used to acquire contour borders of image in raster form.

3. In the Aperture size list define the matrix size from 3x3 pixels to 21x21pixels.

4. Move slider to define Filtering level in percent.

5. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

• Background color – value of background color;
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If the 0 value is set in the Background color field, background also will be changed
during the correction.

• Tolerance – deviation from background color value.

6. [optional] To display changes automatically set the On fly checkbox on.

The Apply button allows to display changes.

7. Click OK to apply filter.

For geometric transformations of image in the Radiometric correction window, click
the button. The Rotate-flip window opens, you can use it for selection of rotation
angles (at 90,180, 270 degrees) or horizontal/vertical reflection. To cancel the last op-
eration or all geometric transformations applied to image using appropriate buttons.

Fig. 47. The Rotate-flip window

7.8. Editing images block

7.8.1. Splitting into strips

The system provides possibility to split images, loaded in one strip, into different strips
automatically. Strips recognition could be made by image names, by external orientation
parameters or by metadata. Also images could be split into strips automatically for
VisionMap project.

In order to split images into strips using images names perform the following actions:

1. Choose Block › Split into strips › By image names. The Automatic splitting
into strips by image names window opens.
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Fig. 48. Split images into strips by names

2. Choose one of the following name formats:

• Strip name (- /_) Image name is used for simple images names, where you can
use the ’-’ or ’_’ separator to specify strip name and image name;

• Regular expression allows to define a template of images complex names to
recognise a strip name and image number in the strip;

For example R09_56RS85 and R09_56RS86 – two images of 9-th strip, R10_56RS05 и
R10_56RS06 – two images of 10-th strip.

The template allows the following symbols combination:

○ \d – to define any digit;

○ \w – to define any digit or character;

○ . – to define any symbol.

Specify position of strip name (R) and image number in images names (S) tem-
plate.

3. [optional] Select one of the following options to split images:

• Each image in a separate strip is used to form scanner monoblock (see Sec-
tion 7.5).

• All images in one strip allows to split all the images in one strip in the numerical
order.
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Given operation allows to cancel the previous splitting into strips as well.

4. Set one of the following templates for strips name:

• From image names – strip name obtained from images name is used;

• Serial numbers – allows to specify strip name as a serial number.

To split images into strips by imported exterior orientation parameters (if any), perform
the following:

1. Choose Block › Split into strips › By exterior orientation data. The Split into
strips by exterior orientation window opens.

Fig. 49. Split images into strips by exterior orientation

2. Specify the following parameters of splitting images into strips:

• Images order from by GPS-time or image names;

If the GPS-time is unavailable for part of images, they add to the separate strip automat-
ically;

• Direction of motion between strips – up to down or bottom up;

• Direction of motion inside strips – left to right or right to left.

See information about import of exterior orientation parameters in the “Aerial trian-
gulation” User Manual.

To split images of the VisionMap project into strips by exterior orientation parameters
(if any), choose Block › Split into strips › By exterior orientation data (see Sec-
tion 5.5).
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It is not recommended to create stereopairs and perform Stereoprocessing for adjacent images
of one strip in VisionMap project.

To split images into strips by metadata (if any), choose Block › Split into strips › By
metadata. As a result, exterior orientation parameters (approximate, i.e. calculated by
on-board devices) loads from metadata into project. As a result images split into strips
in such way that one strip contains images only from the same orbit.

In case of ADS project processing, image splitting into strips by metadata is carried out when
triplets are to be formed further from one nadir and two oblique images.

If other ADS project processing options are intended, image blocks are split into strips manually.
More information on the specifics of strip formation for ADS projects described in Section 5.4.4.

To split images collected by a system of several lens and CCD-sensors as they pass
over the same point of space (the syntopic exposure principle of image collection which
is used, for example, by UltraCam family cameras) into strips, perform the following
actions:

1. Choose Block › Split into strips › Split by multiple cameras. The Split paramet-
ers window opens.

Fig. 50. The Split parameters window

2. Set the parameters of splitting images into strips:

• By image names – allows to split images into strips using images names;

• By exterior orientation – allows to split images into strips by imported exterior
orientation parameters (if any);

○ SetMax angle deviation in degrees to account for deviations due to surveying
aircraft evolution;

Too large values of maximum deviation angle may result in errors in the splitting of
imagery taken by vertical and oblique cameras into strips.

Unsorted images are to be added to strips having names of unsorted_X type, where
X is the number of a strip containing unsorted images.
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• Auto mode – allows to split images into strips using both images names and
imported exterior orientation parameters (if any).

3. Click ОК.

7.8.2. Renaming strips

The system provides possibility to group rename of strips in the block scheme: add
prefix and suffix to names, remove a specified number of characters at the beginning/end
of the name of selected strips.

To rename strips perform the following:

1. Select strips to rename In the Block editor window. To select strips, press and
hold Ctrl key and click on the strips names to select them.

2. Click the button. The Group rename window opens.

Original and New names of selected strips are displayed in the window.

Fig. 51. Group rename

3. Choose one or more actions to rename strips:

• Delete staring symbols;

• Delete ending symbols;

• Add prefix;

• Add suffix.

New names of strips are displayed in the right column of the table.

4. Click OK to apply changes and return to the Block editor window.
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7.8.3. Deleting images selectively

The system allows to delete images selectively using specified selection criteria. Perform
the following actions to do this:

If images were removed from project, the do not remove from theWindows file system.

1. ChooseBlock › Delete images selectively.... TheSelective delete imageswindow
opens.

Fig. 52. Setting of images selection criteria for deleting

2. Set on one or more checkboxes to search images by chosen parameters:

• set on the appropriate checkboxes to search images with No GPS time, No in-
terior orientation or No measured triangulation points.

• to search images where not specified projection centers and/or not specified ex-
terior orientation angles set on the No projection center or No EO angles
checkboxes;
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• to search images with omega, phi, kappa or pitch/roll/yaw angles absolute values
greater than specified value (in degrees), set on the “Omega” absolute value,
“Phi” absolute value, “Kappa” absolute value, Pitch absolute value, Roll
absolute value and Yaw absolute value checkboxes accordingly;

• to search images with projection center hight more or less specified value (in
meters), set on the Projection center Z < or Projection center Z > accordingly;

• when theUse adjustment results checkbox is set and exterior orientation angles
and heading angles are chosen, the adjusted exterior orientation values are used
for search, otherwise the initial ones;

• to find each N-th image in strip, set the appropriate checkbox and set the step
of image downsampling;

• to search images with Distance between centers in strip less than specified
value, set on the appropriate checkbox;

• to choose images By overlap percentage, set the appropriate checkbox;

• The By adjusted convergent angle checkbox allows to set the following criteria
for image search:

○ Image number in overlap;

○ Don’t filter images with convergence angle range from ...° to ...°.

■ [optional] set the block bounds offset in meters to prevent the images de-
letion near the block bounds.

3. Click the Find images matching criteria button. Images found are shown in the
Search results list and compose the list of images to delete.

4. [optional] To cancel deleting image set off the checkbox near to image name in the
Search results section.

5. [optional] Click the View in block layout button to analyze images selection using
block layout.

6. Click the Delete checked button to delete images selected in the list.

7.9. The Images list

The Images list window is provided to view the images list of the project. To open the
Image list window choose theWindow › Image list... or click the button of the Or-
thorectification toolbar.
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Fig. 53. The Images list window

The main part of the window contains a table of project images with the following
columns:

• Image – attribute for full path to image file;

Set the Name only checkbox on to display image file name only;

• Dimensions – image size in pixels;

• Channels – channels number and number of bytes per pixel;

• Tie points – the number of tie points on the image;

• GCPs – the number of GCPs on the image;

• Check points – the number of check points on the image;

• Unused points – the number of unused points on the image;

• The extra columns designated for satellite scanner survey projects.

To add extra columns designated for satellite scanner survey projects to the page, click
the button in the Images list window toolbar and set the appropriate checkboxes in
the Columns list window that opens.
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Fig. 54. The Columns list window

Number of Images total/selection displays in the status bar of the window.

Toolbar and standard selection and searching tools are placed in upper part of window:

Table 9. The toolbox of ’Images list’ window

FunctionButtons
to search for an image by name (part of name) in the list
to select all images in the table
to unselect all images in the table
to invert selection of images in the table
to highlight images, selected in the table, on active layer
to highlight image, selected in 2D-window, in the table
to refresh table of images and recalculate quantity of cutlines, which fall into images
to restore the default order of images after changing
to move selected image at the head of the list;
to move selected image up the list;
to move selected image down the list;
to move selected image at the end of the list;
to invert selected images or group of images
to reverse images in the table
to save the table content, for the selected images (including the additional columns se-
lected to be displayed) in a text file
to open the Columns list window (see above)
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7.10. Brightness adjustment

The system allows for adjusting brightness and contrast image characteristics (relative
to each other) within the whole image block.

Noticeable inhomogeneity of the abovementioned image characteristics within one
block arises, as a rule, in case of abrupt changes in the luminosity parameters during
the imaging (for example, as a result of the influence of cloudiness). Brightness adjust-
ment often minimizes the influence of such factors.

Image brightness adjustment (in case of such data use) can facilitate manual project
processing (e.g. during the stereovectorization), also it is recommended before such
operations as orthorectification, True Ortho, Dense DEM generation using SGMmethod,
or creation of textured 3D TIN surfaces.

Brightness adjustment settings for images within a block are selected automatically,
the results of that operation are saved to a RMC file and can be reset or overwritten by
a user if they are found to be unsatisfactory.

PHOTOMOD provides for similar (but not identical) operation to create a united continuous
mosaic image (see “Brightness adjustment” chapter of the “Orthophotomaps creation” User
Manual).

Before brightness adjustment, tie points are to be measured and the project adjusted (see the
“Aerial triangulation” and “Block adjustment” User Manuals). In the process of brightness adjust-
ment, the results of analysis of brightness and contrast characteristics of the image regions
located in the vicinity of the tie points are processed.

The quality of image brightness adjustment directly depends on tie point number, density, and
uniformity of spacing over block images (as well as on the quality of the measurements them-
selves, in particular, available measurements of a given tie point on all images where it is actually
present).

An identical set of bands for all images of the project is desirable. Otherwise, during brightness
adjustment, only those bands that are present in each of the processed images will be taken
into account.

To adjust brightness for the whole image block, perform the following:

1. Make sure that tie point measurement and project adjustment have been performed;

2. Choose Block › Brightness adjustment. The Brightness adjustment window
opens:
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Fig. 55. The Brightness adjustment window

3. Set the appropriate checkboxes to perform global brightness adjustment and
local brightness adjustment.

Global brightness adjustment means transformation equally applied to all pixels of each
source image.

Local brightness adjustment is a non-linear local transformation that follow the global
brightness adjustment, primarily affecting areas in the vicinity of tie points. The effect of
those transformations gradually weakened with distance from a tie point.

In case of unsatisfactory results of brightness adjustment (for example, local regions of
images with non-uniform brightness), it is recommended to repeat brightness adjustment
by clearing the local brightness adjustment checkbox (the results of the previous operation
will be automatically reset and deleted beforehand).

4. Output raster channels – opens the window Output image parameters, used
for specifying the following parameters:

By default quantity and structure of channels are defined by first added image.

• Channels list – contains list of source (left) and selected for using in orthorecti-
fication channels (right);

Quantity and structure of channels are forming with buttons of theChannels list section.

• Data format – allows to choose format of output images: 8 bit or 16 bit;

• Monochrome output – allows to create output files with one grayscale channel.

In case of monochrome output it is impossible to choose structure of channels.
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Fig. 56. Output channels parameters

5. To start brightness adjustment, click Ok.

When adjusting brightness, it is possible to use the distributed processing mode.
For this, perform the following:

1. Configure and start the server/client of distributed processing mode (see the
“Distributed processing” chapter in the “General information” User Manual).

2. Click the Distributed processing button.

6. After successful operation completion, an appropriate info message appears. If
brightness adjustment has not been performed for some block images, an additional
info message is issued with a list of unprocessed images.

Fig. 57. An info message

Brightness adjustment for a separate image may not be performed if there is an insufficient
number of tie points in this image (or if they are completely absent).
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7. To check the results of brightness adjustment, create an orthoimage (see “FastOrtho
displaying” in the “Orthorectification” User Manual).

Для того чтобы учитывать результаты выравнивания яркости при построении
ортофотоплана в окне Параметры выходного растра установите флажок
Использовать радиометрию из RMC-файлов. Для того чтобы построить
ортофотоплан без учета результатов выравнивания яркости – снимите данный
флажок

To take brightness adjustment results into account when creating an orthoimage,
set theUse radiometric from RMC-files checkbox in theOutput image paramet-
ers window. To create an orthoimage without taking into account brightness adjust-
ment results, clear this checkbox.

Note, that visual assessment of brightness adjustment results directly depends on the degree
of inhomogeneity of the brightness and contrast characteristics of source images. In the
case of using homogeneous source data, the results of brightness adjustment can be almost
imperceptible during visual analysis of the constructed orthoimages.

8. [optional] To repeat a brightness adjustment operation (e.g. when after analyzing
the results, it was decided to be limited to the global brightness adjustment, excluding
the local one), choose Block › Brightness adjustment and repeat the steps de-
scribed in items 3, 4 and 5. If any data on the operations performed before are
available, the following dialog box opens:

Fig. 58. Диалоговое окно

Click Yes to rebuild brightness adjustment (deleting the previous results);

9. [optional] To delete the results of brightness adjustment, choose Block › Delete
brightness adjustment. If any data on the operations performed before are avail-
able, the following dialog box opens:

93

Project creation (Windows x64)PHOTOMOD 8.0

ortho.pdf


Fig. 59. A dialog box

Click Yes to delete the results of brightness adjustment.

8. Project management window

8.1. Project menu
Table 10. Brief description of ’Project menu’

FunctionMenu items
to create a new projectNew...
to open the Project management windowOpen/Manage (Ctrl+Alt+O);
to create a copy of project selected in the listCopy
to create project backupBackup project...
exports project data into a *.xml file, which is used
inBlocks Exchange XML protocol betweenPHOTO-

Project export...

MOD and external software such as Agisoft
Metashape or Bentley ContextCapture (only for
central projection projects)
imports project data from a *.xml file, which is used
inBlocks Exchange XML protocol betweenPHOTO-

Project import...

MOD and external software such as Agisoft
Metashape or Bentley ContextCapture (only for
central projection projects)
to reloads a project to update it after changes ap-
peared during mutual work

Reload

to re-calculate a project data after editing of some
parameters, e.g. re-calculates interior orientation
after changing camera parameters

Synchronize

to close current project and to start “without project”
mode (see Section 6.2)

Close

to open the window used to view and edit some
parameters of opened project (see Section 8.3)

Properties
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FunctionMenu items
to open a list of projects opened recently in the
system

Recent

is used for selective project temporary data deletion
(see Section 8.12)

Delete temporary data...

to merge data from several projects of active profile
(see Section 8.9)

Join projects...

to display processing status of the following project
stages (see Section 8.4)

Project state

to load during a project opening a project work en-
vironment (a set of all layers loaded to the system)
saved previously to *.x-work file

Load work environment

to save a project work environment to *.x-work file,
i.e. to memorize a set of all layers loaded before
save operation

Save work environment

to close the main window of the systemExit

8.2. Project management window

The Project management window shows the list of all projects of active profile and
contains basic functions for project management.

Perform one of the following actions to open the Project management window:

• choose the Project › Open/Manage...;

• click the button on the main toolbar;

• use the Ctrl+Alt+O hotkeys.
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Fig. 60. Project management window

The Project management window contains the following elements:

• list of all projects of active profile;

• toolbar with the following buttons used for project list management:

○ – allows to refresh project list after some changes made to resources structure
of active profile using the PHOTOMODExplorer (see Section 8.8) or after connect-
ing a virtual folder (see Section 8.7);

○ – allows to display all projects as hierarchic tree list – shows project folders
(virtual folders and their subfolders);

○ – allows to display all projects as linear list;

○ – allows to display all projects opened recently in the system;
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○ – allows to open the Control Panel window used to manage profiles (see the
“General information” User Manual);

After performing of some changes in profiles list resources structure in the Control Panel
window you need to restart all opened modules of the system.

○ – allows to open the PHOTOMOD Explorer window to change the structure of
active profile resources (see the General information about system User Manual);

After changing the resources structure of active profile in the PHOTOMODExplorerwindow
you should refresh projects list using the button.

○ – allows to open the Join projects window used to merge data of several pro-
jects (see Section 8.9).

○ – allows to open the Rename project window used to rename a project selected
in the list.

It is possible to change project name if it is not opened on other computers in the network.

• comments section shows project description, input by user during the project creation
in the New project window or during project properties editing in the Project
properties window;

• the following buttons are used for projects management:

○ Project properties – allows to open the window used to view and edit parameters
of project selected in the list (see Section 8.3);

○ Create – allows to create new project and to setup its parameters and features;

○ Copy – allows to create a copy of project selected in the list;

○ Delete – allows to delete chosen project; delete project folder with all contents from
active profile resources;

○ Backup – allows to create project backup;

○ Restore – allows to restore a project from backup;

○ Connect – allows to connect new folder to place projects there, i.e. to create new
virtual folder in the profile resources (see Section 8.7).

• the search field that allows to search a project in the list by its name or name part;
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F3 key allows to focus marker on the search field. Press F3 again to focus marker on the
next found project in the list.

• additional parameters:

○ Show this window on startup (enabled by default) – allows to open the Project
properties window automatically on the system startup, otherwise, the system will
be startedWithout project.

○ Open last loaded project on startup – allows to open last loaded project on
startup.

• the following buttons used to manage the window:

○ Open – allows to close the Project properties window and to load a project selected
in the list;

○ W/o project – allows to close the Project properties window to start work in the
system without project (see Section 6.2);

○ Cancel – used to close the Project properties window.

• status bar shows path to selected project (in active profile resources).

In order to open project of active profile perform the following actions:

1. Open the Project management window.

2. Choose a project in projects list.

3. Click the Open button. Project data is load to the system.

8.3. Project properties

To view/edit project parameters specified during project creation use the Project
properties window.

To open the Project properties window perform one of the following:

• choose Project › Properties to display properties of the project opened in the system;

• open the Project management window. Select a project in the list of all projects of
active profile and click the Project properties button.

• make a double click into Coordinate system name in the status panel.
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Fig. 61. Project properties

The window contains the following parameters:

• Project – shows opened/selected project name;
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• Path – path to a project in active resources profile;

• Type – type of opened project: central projection, satellite scanner survey,
ADS 40/80/100 or VisionMap A3 SLF;

• Description - description input during project creation;

• Number of images – number of images loaded to a project;

The Statistics button allows to display statistic data about images in project.

Fig. 62. Project images statistic

• Coordinate system – coordinate system and its parameters (see Section 4.1);

• Relief elevation – shows minimal and maximal values of terrain height, displayed
on the project images, if these values were specified at project creation;

Relief elevation data provides correct block scheme creation and is considered during import
of external orientation parameters.

• Contents – content of project data and its size.

To display the data contained in the Contents table, click the Update button. Calculation of
necessary data may take considerable time. Click the Cancel button to terminate this opera-
tion.

Contains of Description, Coordinate system and Relief elevation fields could be
changed on the Project properties window.
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8.4. Viewing project report

The Project state window is used to view state report of opened project on steps of
block forming, interior, relative and exterior orientation.

Choose Project › Project state or click the button on the main toolbar. The Project
state window opens.

Fig. 63. Project state summary window

The Project state window contains a list of project processing steps and toolbars to
perform these steps.

Project state on interior, relative and exterior orientation steps is marked by the following
icons:

• – completely accomplished step;

• – partly accomplished step;

• – not accomplished step.

The window contains information about number of images/strips in the block and the
following buttons used for block forming:

• – to add new strip;

• – to add the image from files located out from active profile resources to selected
strip (see Section 7.4.2);

• – to add the image from active profile resources to selected strip (see Sec-
tion 7.4.3).

You can use the following buttons to perform interior orientation step (see the “Aerial
triangulation” User Manual):
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• – to define camera parameters;

• - to perform manual measuring of fiducial marks;

• – to perform interior orientation in semi-automatic mode;

• – to perform interior orientation in automatic mode;

• – to open interior orientation report.

The following buttons are used to perform relative orientation step (see the “Aerial trian-
gulation” User Manual):

• – to build block layout;

• – to view, input and edit ground control points coordinates;

• – to measure tie points in automatic mode;

• – to view, input and edit tie points;

• – to view relative orientation report.

The button is used to block adjustment (see the “Block adjustment” User Manual).

8.5. Copying project

In order to copy selected project to another folder of active profile resources perform
the following actions:

1. Open the Project management window (see Section 8).

2. Choose a project in the list to delete.

3. Click the Copy button. The Backup project window opens. In the Source project
field you can see a path to chosen project in active profile resources.

In order to copy a current (opened) project – choose Project › Copy.
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Fig. 64. Copying of project

4. Input a name for a project copy into the Name input field.

By default the Project_name_copy is used as a name of project copy.

In case of making copy from copy of project, the Project_name_copy 2 is used as a name.

5. Define a set of data to be copied in the Contents table. To do that, set on the
checkbox of data for making copy.

To copy source images into /Images folder of new project the Images checkbox is used.

The following buttons allows to manage the selections:
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• – allows to set all checkboxes;

• – allows to clear all checkboxes;

• – allows to invert selection.

6. In the Placement section choose a folder to place a project copy to active profile
resources. The Full project path field displays a path to a new project copy in
active profile resources.

7. [optional] Set theDo not check images in the projects copy checkbox to exclude
check of presence of all project images (according to their relative paths) and their
parameters, that could take a long time.

This process could take much time in case of checking amount of source images. Thus in
most cases it is not recommended to set on this checkbox.

8. Click OK to create a copy of project.

8.6. Deleting project

In order to delete selected project perform the following actions:

1. Open the Project management window (see Section 8).

2. Choose a project in the list to delete.

3. Click the Delete button;

4. Click the Yes to confirm the project deleting. At that the project folder will be com-
pletely removed (with all files and service folders) from active profile resources. To
delete project files located out of project folder (e.g. images files) use PHOTOMOD
Explorer (see Section 8.8).

8.7. Connecting new folder

The Project management window (see Section 8) allows to connect new virtual folder
to active local profile to place projects during their creation or copying.

In order to connect a virtual folder to network profile use theControl Panel module (see the
“General information” User Manual);

In order to connect new virtual folder perform one of the following:

• click the Connect button. The Browse for folder window opens. Choose physical
folder to connect it to a profile. Click OK. Input virtual folder name to the Connect
virtual folder window and click OK.
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• click the button of the Manage projects window’s toolbar. The PHOTOMOD Ex-
plorer window (see Section 8.8) opens, that displays all active profile resources and
contains tools to manage resources structure. To connect a new virtual folder is used
the button.

8.8. The “PHOTOMOD Explorer”

The Project management window (see Section 8) allows to open the PHOTOMOD
Explorer to view resources and edit structure of active local profile: create folders. re-
name, copy and delete resources.

In order to edit resources structure of network profile use the Control Panel module (see the
“General information” User Manual);

Do not delete, rename or remove configuration files in the PHOTOMOD5.VAR folder in order
to avoid lost of project data.

Please, be careful during change resources structure of profile to avoid data loss.

To open the PHOTOMOD Explorer window click the button in the Project manage-
ment window. See detailed description in the “General information” User Manual.

Fig. 65. The PHOTOMOD Explorer window

8.9. Joining projects

In some cases you need to share work with a project among several operators that re-
quires creating separate projects for each strip of a block in order to their independent
orientation/processing. For further joining of obtained project data into integrated project
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you should use joining projects operation. The system supports joining of several pro-
jects.

For successful joining, the projects should meet the following requirements:

1. Contain ground control points and exterior orientation parameters in the same co-
ordinate system.

In case of coordinate systems discrepancy, you should re-calculate them using the tool in
theGCP list and Exterior orientation parameters windows (see the “Aerial triangulation”
User Manual).

2. Joined projects should be placed in active profile resources.

Use the Control Panelmodule (see the “General information” User Manual); In the Control
Panel it is also possible to prepare in advance new virtual folder, that will be used as a
target folder for new joined project.

The main idea of projects joining is as follows:

1. Define a base project, and then to add data from additional projects to the base
one. The base project is privileged, i.e. its data is copied to target project first of all,
and then data from other projects, missing in the base project, is added to it.

2. Properties of joined target project are taken from selected base project.

3. Cameras used in additional projects are added to base project cameras.

4. Images are copied to joined project, if they are located in the project folders, other-
wise only relative paths to images are copied. Those images could be connected
later to joined project using replace and auto-replace operations in ImageWizard
(see Section 9.2.1). Images from additional projects, that are absent in base project,
are always added to new strips of target project. In case of some inconsistency in
strips order you may use block editing features to adjust a block scheme (see
Section 7).

5. Images, GCP/check points are joined by names matching.

6. Tie points are not joined, just added to triangulation points of a target project, i.e.
are recognized as new points with new names.

7. Only data of preliminary exterior orientation is copied to a target project, so after
projects joining you should perform block adjustment (see the “Block adjustment”
User Manual).
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8. Projects processing data (vector resources, DEMs, TIN, mosaics data) are copied
to a target project. In case of names coincidence, the resources will obtain new
unique names automatically.

9. Other data located in user project folders is also added to target project.

To join several projects of active profile perform the following actions:

1. Click the button of the Project management window (see Section 8). The Step
1 of 4: Base project window opens.

Fig. 66. Selection of base project used to be joined with other projects
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2. Select a base project and in the Items to copy table define a set of data, that will
be copied from the base to target project. Click the Next button. The Step 2 of 4:
Additional projects window opens.

Fig. 67. Selection of additional projects

3. Define a list of additional projects and set of their data to be added to base project
data. Use the button to add and the button to remove items from list of addi-
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tional projects. Click the Next button. The Step 3 of 4: Name and placement for
the target project window opens.

Fig. 68. Selection of name and placement of joined project

4. Specify name, description and placement of target project in active profile resources.
Click the Next button. The Step 4 of 4: Joining parameters window opens.
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Fig. 69. Parameters of projects joining

5. In the Images section choose one of the following:

• No common images – if projects do not contain identical names of images. In
case of names coincidence and enabled option, images will be added to new
strips under new names, composed as follows: image name [N], where N is a
number of image copy;

• Regard images with identical names as common – allows to join images if
their names are the same.

6. Set on the Merge tie points checkbox in the Triangulation points section to add
tie points of additional projects to tie points of base project and they will get new
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names automatically; if the option is disabled ’ tie points are taken only from base
project.

7. To merge ground control or add ground control\check points set on the Merge
ground control and check points checkbox and choose:

• No common images – points are not joined, but added (in case of identical
names they will be added with the same names).

• Regard imageswith identical names as common – points are joined by names.

8. Set on the Merge exterior orientation data checkbox in the Exterior orientation
section to add exterior orientation parameters of additional projects to exterior ori-
entation parameters of base project.

9. [optional] To avoid check for images existence according to their relative paths and
parameters, set on the Skip checking of images checkbox.

It is recommend to enable this option, to save time during joining operation.

10. Click the Execute button to start joining projects.

8.10. Creating project backup

The system provides creation of project backup in the form of compressed or uncom-
pressed archive located out of profile resources (on any local or network disk), that is
helpful for project storing or further sending/passing.

Copy of project creates only in active profile resources during making copy of project.

In order to create backup copy of a project as compressed/uncompressed archive
perform the following actions:

1. Select a project in the projects list of the Project management window (see Sec-
tion 8).

2. Click the Backup button.

In order to backup a current (opened) project – choose Project › Backup project.

3. Specify a file name for project backup and select a folder for backup placement
inWindows file system.
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4. Specify one of the following backup types in the File type list: TAR uncompressed
archive (*.tar) or TAR-GZip compressed archive (*.tar.gz).

It is recommended to create uncompressed TAR-archives for storing of projects copies.
Creation of compressed archives (file *.tar.gz) is used to send small projects or part or
project data by e-mail (see also Section 8.11).

5. Click the Save button. The Backup project window opens.

Fig. 70. Creating of TAR uncompressed archive

6. Define in the table content of data to project backup. To do that, set on the checkbox
of data for making copy.

The following buttons allows to manage the selections:

• – allows to set all checkboxes;

• – allows to clear all checkboxes;

• – allows to invert selection.

During project backup creation only selected resources located in project folder are
saved/archived. If images are placed out of project folder, you can backup only
raster cache (reduced copies of images).
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7. [optional] Define a compression level of backup copy using an appropriate slider
in the Compression section (the panel is active only if compressed backup is se-
lected (file *.tar.zg)).

8. Click OK to backup the project.

8.11. Restoring project backup

To restore a project from a backup copy using integrated tools of the system, as well
as third-party tools (any standard archiving utility, for instance).

When restoring project in system, copy of project places in chosen path in active profile
resources. In case of using external resources – in folder in Windows file system. This
folder should be join to resources as a virtual folder.

In order to restore a project from a backup copy using system tools perform the following
actions:

1. Click the Restore button in the Project management window (see Section 8). In
the window opened you can choose a file with project backup *.tar.gz (compressed
backup) or *.tar (uncompressed backup) to be restored.

Maximum of data restore from archive in case of restore broken or incomplete archives.
Warning is shown in case of error in restoring.

2. Choose a backup and click the Open button. The Restore project window opens
allowing to specify a project’s name and path in active profile resources.

Fig. 71. Restore of project backup
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3. Click OK to restore project from backup.

8.12. Deleting project temporary data

The system provides for selective project temporary data deletion from the active profile
resources. For this, perform the following:

1. Choose Project › Delete temporary data. The Delete temporary data window
opens:

Fig. 72. The Delete temporary data window

The Delete temporary data window contains the following sections:

• The Project field displays a name of the current project for which temporary data
will be deleted;
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• The Groups table of temporary data containing the following columns:

○ Temporary data Type:

■ Backup – backup copies of project data (stored in the project root folder);

■ Temp – temporary project data (stored in the project root folder);

■ Temp UAS – temporary data on image relative orientation (for aerial survey);

■ Temp Pushbroom – temporary data on image relative orientation (for satellite
scanner imaging);

■ Other Backup – all folders inside the project named Backup (other data of
project processing);

■ Other Temp – all folders inside the project named Temp (other data of project
processing).

○ Folders – the number of selected / existing folders in the active profile resources
containing temporary data of the specified type;

○ Resources – the number of selected / existing resources containing temporary
data of the specified type;

○ Size column contains sizes of selected / existing resources containing temporary
data of the specified type.

To select a group of temporary data for deletion, set the appropriate checkboxes:

○ the button allows to select all the groups of temporary data;

○ the button allows to cancel selection of all the groups of temporary data.

The total number and size of the resources with temporary data that are chosen
for deletion is displayed in the Selected: field under the Groups table.

• The table that displays the Contents of temporary data of the selected type
contains the following columns:

○ Folder – folders with temporary data of the selected type in the active profile
resources;

○ Resources – the number of resources containing temporary data in this folder;

○ Size of temporary data in this folder.
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To choose the Type of temporary data the Contents of which it is required to
display, select the appropriate line in the Groups table.

To delete only a portion of temporary data of the selected type, clear or set the
appropriate checkboxes in the Contents table:

○ the button allows to select all the groups of temporary data;

○ the button allows to cancel selection of all the groups of temporary data.

2. Clear or set the appropriate checkboxes in the Groups and Contents tables;

3. Click Delete to start deletion of temporary project data.

8.13. Work environment

It is possible to save/load project work environments to work with project in new session
with project data opened in previous session.

Project work environment is a set of all opened layers in the project (vector data, DEM
and so on). The work environment is stored in the file *.x-work of the active profile re-
sources.

To save the work environment do the following:

1. Choose theProject › Savework environment. TheDestination filewindow opens.

2. Define name and path to save the work environment.

3. Click OK to save work environment.

By default it is offered the folder Data in the project folder in active profile resources.

To load a work environment do the following:

1. Open a project.

2. Choose the Project › Load work environment. The Save window opens.

3. Select a file *.x-work with the work environment and click OK.

4. Click OK to load work environment.
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8.14. Export and Import of Projects (Blocks Exchange XML)

The system provides for exporting and importing project data using the Blocks Exchange
XML protocol. The data exchange between PHOTOMOD and external software such
as Agisoft Metashape or Bentley ContextCapture could be performed that way.

An *.xml file is used for data exchange.

This functionality is available only for the central projection project types.

The exchange file contains the following data:

• The project coordinate system info (including EPSG-code or full description);

Standard EGM96 and EGM2008 geoids are supported.

• Information about sub-blocks;

• Information about cameras, including calibration parameters – focal length calibration
parameter (f); coordinates of symmetry point (zero distortion – x0, y0); coefficients
of radial distortion (k1, k2, k3); coefficients of tangential distortion (P1, P2);

Metashape calibration data will be recalculated for use in PHOTOMOD, with some parameters
approximated.

ContextCapture and PHOTOMOD calibration data are the same.

• Project imagery info;

The block exchange protocol does not provide the ability to export/import images themselves
or full paths to image files in the operating system file system (or in the PHOTOMOD resource
system).

• Triangulation point info (GCP, check, tie).

When exporting data fromMetashape, all the points from catalog are to be exported, including
the excluded points.

To export PHOTOMOD project data, choose Project › Export project.

To perform the data export from Metashape software, choose Export › Export Cameras.
Choose the output file extension – Blocks exchange (*.xml).

To perform the data export from ContextCapture software, choose Block › Export › Export to
XML.... Choose the output file format – BlocksExchange XML format.
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To import data to PHOTOMOD from an exchange file, perform the following:

1. Choose Project › Import project project. The XML-file selection window opens;

2. Select the exchange file and clickOpen. The Project importwindow opens, where
you can specify the project name and path in the active profile resources:

Fig. 73. The Project import window

3. Click OK to import the project data.

After the project import in PHOTOMOD, the adjustment using imported exterior
orientation parameters is performed.
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9. Processing of raster images

9.1. The “Raster” menu

The system provides theRastermenu to perform various operations with raster images.

Table 11. Brief description of Raster menu

FunctionMenu items
to launch the Raster Converter program for prepar-
ing and converting raster images into the internal

Raster Converter

format files and then for placing them in active profile
resources (see the “General information” User
Manual).
to run the ScanCorrect program for compensation
of metric errors occurred when scanning graphical

ScanCorrect

data on flatbed polygraphic scanners (see the
“ScanCorrect program” User Manual)
to perform georeferencing images by geodetic co-
ordinates GCP points, obtained from vector/raster

Image georeferencing

maps or from a list of file *.txt (see the “Aerial tri-
angulation” User Manual)
to perform affine correction of georeferenced imagesAffine georeference correction
to load georeference images from folder inWindows
file system (see the “Georeferenced external data”

Load georeferenced images (files)

section of the “Aerial triangulation” User Manual and
the “Pseudo-stereo mode” section of the “Vectoriz-
ation” User Manual)
to load georeference images from active profile re-
sources (see the “Georeferenced external data”

Load georeferenced images (resources)

section of the “Aerial triangulation” User Manual and
the “Pseudo-stereo mode” section of the “Vectoriz-
ation” User Manual)
to load georeferenced web-maps from the Internet
(see Section 9.6)

Load web-map

to save a georeference raster image of the active
layer with specified parameters in output file format
(TIFF, MS-TIFF, MegaTIFF)

Save raster layer

to close all opened raster layersClose all opened layers
contains menu items which allow to perform batch
management of raster layers visibility in the Layer
manager

Layers visibility

to create orthophoto production and mosaicking
(see the “Orthorectification” User Manual)

Orthorectification

to run the GeoMosaic program allows to create the
orthomosaic from georeferenced orthorectified aer-

GeoMosaic

ial and satellite imagery, splitting of created ortho-
mosaic with the capable of saving sheets in popular
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FunctionMenu items
raster file format (see the “Orthophotomaps creation”
User Manual)
to perform pan-sharpening – a technique that
merges high-resolution panchromatic data with

Pan-sharpening

medium-resolution multispectral data to create a
multispectral image with higher-resolution features
(see “The pan-sharpening operation” chapter of the
“General information” User Manual)
to perform the pan-sharpening for the list of image
pairs with same properties and also in distributed

Batch pan-sharpening

processing mode (see “The pan-sharpening opera-
tion” chapter of the “General information” User
Manual)
to ’clean’ images of dust particles, photo emulsion
defects etc (see Section 9.8)

Dust Correct

to delete raster cache from RAMClear cache
to edit path to image files (see Section 9.2.1)ImageWizard module
to use one of three modes of displaying raster im-
ages in 2D-window: Cached only (Ctrl+Shift+1),

Show rasters

Depending on zoom (Ctrl+Shift+2) or Source
only (Ctrl+Shift+3)
to rearrange block images by z-orderImages order
to rebuild image pyramids for MegaTIFF images
(see Section 9.5)

Rebuild Mega Tiff pyramids

to set zoom of images in 2D-window by set GSD in
pixels

Adjust zoom

9.2. ImageWizard Adjustment of images

9.2.1. The ImageWizard window

To manage links to images is used the ImageWizard module.

Raster image file in active profile resources could be used in more than one project the
same time. In this case each project contains only links to source images and information
about size and color of images, interior and exterior orientation parameters.

ImageWizard module main function – is managing of the links to the source files, i.e.
matching project images with raster files, as well as control of correctness of this
matching, allows to build pyramids, and perform images radiometric correction.

Pay attention when edit images in the ImageWizard module module to avoid of project data
lost.

The ImageWizard module provides the following capabilities:

• view images properties and features;
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• create/delete exterior pyramid of images (not for MS-TIFF format);

Such as MS-TIFF images already have pyramids, it is not allowed to create pyramids for
them again.

• images radiometric correction;

• edit links to images source files:

○ replace links to source files to match them to project images;

○ replace project images with virtual rasters of certain size with pattern fill;

Virtual rasters are used in case of absence of source raster images. Virtual images are
formed dynamically in RAM and do not occupy any disk space. Virtual images are used
in case of absence of source images, for instance. This provides absolutely correct work
with a project when the image information is not used, for example, in this case the system
supports view/import/export of vector objects, TIN, and DEM.

○ remove links to source files to disable project images.

To start the module choose the Rasters › ImageWizard or click the button in the
Block editor window. The ImageWizard window opens.

Fig. 74. The ImageWizard window

A name of opened project is shown in header of the ImageWizard window.

The ImageWizard window contains the following main sections:
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• The Project images section is used for control of project images setting, view images
properties and links to images source files. The section contains toolbar, project im-
ages table and window of selected image view.

The table contains the following information:

○ Name – project image name;

○ – perform of radiometric correction;

○ – image pyramid;

○ Properties – size of image in pixels and size of source image in megabytes;

○ Image path – link to the source image file in active profile resources.

The view window is used for displaying of project image selected in the table. To
show image in the view window, set the View checkbox on.

The toolbox contains the following buttons:

○ – allows to refresh data;

○ – allows to select all images;

○ – allows to unselect all images;

○ – allows to inverts images selection;

○ – allows to load radiometric parameters from *.rmc file and apply them to project
image selected in the table;

○ – allows to save radiometric parameters of project image selected in the table
to *.rmc file;

○ – allows to start radiometric parameters of selected images without additional
parameters;

○ – allows to delete radiometric parameters of project image selected in the table;

○ allows to start the Raster Converter to add new source images in active profile
resources (see the “General information” User Manual);

○ - allows to save the selected images filenames list to the *.txt file stored in
Windows file system;
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○ - allows to save the filenames list (a *.txt file stored in Windows file system)
for those images that don’t have link to source image (in the Project images section
an error is displayed in Properties column).

• The Parameters section contains additional features for project images setting:

○ Match by contents (enabled by default) – during executing of auto-replace oper-
ations, in addition to automatic names matching the system checks content of im-
ages source files. This helps to reduce chance of errors during replacing links to
source files in project images table;

○ Automatically check images (enabled by default) – allows to start initial images
check and refresh properties in the table of project images after performing of any
operation in the ImageWizard module. Otherwise, table data is not updated after
operations performing;

○ Auto-replace only problem images (enabled by default) – during executing of
auto-replace operations for search/replace links to images allows to perform pre-
liminary check of project images and in case of problem images, the system will
search images source files only for them. If the option is disabled, the images,
which are matched with project images, are fully replaced.

• The Tasks panel is used to perform main operations of project images setting:

○ Radiometric correction – allows to open the Radiometric correction window
to perform radiometric processing of project image selected in the table, i.e. images
from source file;

Radiometric correction applies only for image loaded into the system. Source image is not
changed. It is possible to apply only geometric transformation (flip-rotate) to the source
image.

○ Create pyramids – allows to build external pyramids for project images selected
in the table, i.e. images from source files. The pyramids are saved to subfolder of
folder with initial images in active profile resources;

○ Delete pyramids – allows to delete pyramids for project images selected in the
table of Project images section, i.e. images from source files;

○ Replace image – allows to match the image selected in project images list with
another image source file selected in the Source section, i.e. the tool allows to
change a link to source file in the table.

To replace link in active profile resources, choose source file in the Source section on the
Resources tab. To replace link to file from other project , choose source file in the Source
section on the Projects tab.
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○ Autoreplace all – allows to automatically replace links to images source files
for all project images selected in the table, using matching of project images
names shown in the table and names of source files in folder of active profile re-
sources selected in the Source section (see also description of the Match by
contents and Auto-replace only problem images additional parameters below).

Autoreplace is used, for example, to connect initial images to a project in case, if the images
were disabled or relocated byWindows file system tools.

○ Autoreplace all – allows to automatically replace links to images source files
for all project images selected in the table, using matching of project images names
shown in the table and names of source files in folder of active profile resources
selected in the Source section (see also description of the Match by contents
and Auto-replace only problem images additional parameters below).

To replace link in active profile resources, choose source file in the Source section on the
Resources tab. To replace link to file from other project , choose source file in the Source
section on the Projects tab.

○ Disconnect selected – allows to remove links to source files selected in the
table. Autoreplace selected and Autoreplace all buttons are used to re-link to
source images.

○ Use virtual – allows to replace selected images in the table of the Project
images section to virtual raster images with defined size and background.

Virtual rasters are used in case of absence of source raster images. Virtual images are
formed dynamically in RAM and do not occupy any disk space. Virtual images are used
in case of absence of source images, for instance. This provides absolutely correct work
with a project when the image information is not used, for example, in this case the system
supports view/import/export of vector objects, TIN, and DEM.

• The Source section allows to select images source files to match them with Project
images.

This section contains table of project images, preview window and toolbar.

The following tabs in the Source section are used to select source files:

○ Resources – displays all active profile resources. Resources tree containing a
name of active profile in the root displays at the left. At the right – the whole content
of selected folder of a profile – all subfolders and files. Only images source files
from active profile resources could be matched with images of current project.

To add new images source files to active profile resources without closing the click the
button to start theRaster Converter module (see the “General information” User Manual);
Save images files in active profile resources and close the Raster Converter module and
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click the button of the Project images section in the ImageWizard window. As a result
source image files are displayed in the Source section on the Resources tab.

○ Projects – displays all projects of the profile. At the left only projects list of a profile
is displayed. And at the right – only images list of selected project. When you replace
image of current project by other project image, in fact you are dealing with a link
to image source file of another project.

At that, if in the Source section the Resources tab is selected, the image is replaced by
source file from active profile resources.

9.2.2. Workflow

To re-link source image perform the following:

1. Choose Rasters › ImageWizard or click the button in the Block editor window.
The ImageWizard window opens.

Fig. 75. The ImageWizard window

2. In the table of the Project images section select image to re-link.

3. In the Source section on the Resources or Projects tab choose the source image
to re-link.

4. Click the Replace image button to replace link for this source image.

5. Click the Close button to exit from ImageWizard module.

125

Project creation (Windows x64)PHOTOMOD 8.0



To join link to source image (if there is no link) perform the following:

If one of the links to source file is unavailable, the system automatically offers to launch theIm-
ageWizard module to search and add link to image.

1. Choose Rasters › ImageWizard or click the button in the Block editor window.
The ImageWizard window opens.

Fig. 76. The ImageWizard window

2. In the Project images section an error is displayed for those images that don’t
have link to source image.

Click the button in themain ImageWizardwindow toolbar to save these images filenames
to the file with *.txt extension.
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Fig. 77. Image without link to source file

3. Select images in the Project images table.

4. In the Source section on theResources or Projects tab choose the source image.

5. Click the Autoreplace selected button to get a link to selected file. As a result
path to the source file is shown in the table of the Projects images section.

Fig. 78. Image with link to source file

6. Click the Close button to exit from ImageWizard module.
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9.3. Affine georeference correction

The system provides possibility to perform affine correction for georeferenced data.

This correction is necessary to affine coordinate system to obtain correct results.

An affine coordinate system is a coordinate system on an affine space where each coordinate
is an affine map to the number line.

For correction perform the following:

1. Choose Rasters › Affine georeference correction. The Georeference affine
correction window opens.

Fig. 79. Parameters of georeference affine correction

2. In the Source images section choose the way to obtain source image:

• to apply correction only for some of project images, choose the Image list:

○ click the button and select images;

○ click the button to replace the appropriate image in the list to another;

○ click the button to remove the selected image from the list.
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• to apply correction for all images of project, which are placed in one path, choose
the Image folder. Click the button and choose path with images.

In order to choose images of one format, specify the mask of extension in the File name
mask field.

To search raster images in subfolders, set on the Search in subfolders checkbox.

3. In the Correction section specify coefficients of polynomial approximate a11..a23
in corresponding fields.

In this method, finding new coordinates (X ’, Y’) task is merely the transformation of the
initial coordinates of the point (X, Y) into new coordinates using the coefficients a1,..., an
of the polynomial approximant.

4. Click OK. Information message with number of corrected images id displayed.
Georeference files are creates in MapInfo TAB format and locates in folder with
source images.

9.4. Saving of raster image

The system provides possibility to save georeferenced raster images, loaded to project,
in chosen format.

To save georeferenced raster images, perform the following actions:

1. Load raster layer to the project (see the “Georeferenced external data” chapter in
“Aerial triangulation” User Manual);

2. Make the Raster layer active.

3. Choose the Raster › Save raster layer. The Save raster layer window opens.
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Fig. 80. Raster layer saving parameters

4. Specify coordinates of layer Limits to save.

5. [optional] To save image only inside of selected object, set the Use limits of selec-
ted objects in current vector layer checkbox on.

6. Define the following parameters of Output file:

• GSD of image in meters;

In the field the Estimated file size in pixels and megabytes is displayed.

• Image Format could be TIFF, MS-TIFF or MegaTIFF;

• the compression type could be None (without compression), LZW, Deflate or
JPEG;

In case of JPEG-compression set the quality of compression.

• type of the georeference file – TFW or TAB.
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7. Click OK.

8. Define name and path for file and click the Save button.

9.5. Image pyramid creation

The system provides possibility to create pyramids for MegaTIFF image if images of
this format without pyramid are used in the project.

Perform the following to create pyramids:

1. Choose the Rasters › Rebuild MegaTiff pyramids. The Parameters window
opens.

Fig. 81. Parameters of rebuilding MegaTiff pyramids

2. Create the MegaTIFF files list:

• click the button and select images;

• click the button to replace the appropriate image in the list to another;
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• click the button to remove the selected image from the list.

3. In the Compression parameters source set one of the following:

• Source MegaTIFF to use parameters from the source image;

• Input parameters to set the following compression parameters of images:

○ None – files are creates without compression;

○ JPEG with quality .. % – TIFF-files are creates with set quality of JPEG-
compression;

Default compression level is 75 %, that provides the 5-7 times compression of initial
image volume.

○ LZW – TIFF-files are creates with LZW-compression;

○ Deflate – TIFF-files are creates with deflate compression.

4. [optional] By default pyramids replace the existing one. To create only missing
pyramids, set the Overwrite existing pyramids checkbox off.

5. Click OK to rebuild pyramids.

9.6. Web-map loading

The system provides possibility to load different web-maps as a raster layer (Internet
connection is needed).

In order to load a web-map perform the following actions:

1. Choose the Rasters › Load web-map. The Load web-map window opens.

Fig. 82. Parameters of web-map
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During the Load web-map window first launch, the Settings window opens at first (see
paragraph 5 below).

2. In the Source section choose one of the web-source for data:

• Rosreestr – cadastral map of Russia produced by The Federal Service for State
Registration, Cadastre and Cartography (Rosreestr).

○ Base Map – basic geography map;

○ Cadastre Map.

• OpenStreetMap (OSM) – non-commercial free world map;

• RosCosmos;

• ESRI.

3. [optional] Defile limits of web-map loading in to the project.

4. In the Reproject section select one of the following:

• Auto – to transform into projects coordinate system automatically (if possible);

• None – to use coordinate system of the web-service;

• Reproject into coordinate system – allows to choose the output coordinate
system of web-map.

5. [optional] To setup web-map loading click the Settings button and setup parameters
of network using.

Fig. 83. Parameters of web-map loading
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6. Click OK. New vector layer adds in the Layer Manager and in the work are of the
Map window loaded map is displayed.

9.7. Image georeferencing

The system provides possibility of georeferecing from one image to another (allows to
transfer ground control points from one image to another).

The Raster georeference window is used for referencing one raster image to another.

Fig. 84. Raster georefence window

The Raster georeference window contains the following elements:

• toolbar with buttons allow to load, save and scale image, add ant edit points and also
to display coordinate system of used data;

• left part of window is used to load image;

• right part of image to load georeferenced image and/or vector layer;

• table with coordinates of points;
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• status bar for displaying marker coordinates.

To perform georeference perform the following:

1. Choose theRasters › Images georeferencing. TheRaster georeferencewindow
opens.

2. Click the to load source image. Choose file and click the Open button. Image
loads to the Raster georeference window.

3. Click the to load the second georeferenced image. Choose file and click the
Open button. Image loads to the Raster georeference window.

Fig. 85. Loading images

4. [optional] To load vector layer click the button. The Parameters window opens.
The Clear existing vectors checkbox is set on by default to delete vector objects
on the georeferenced image. Click OK. Then click the Open button. Information
message about loaded vectors is displayed. Vectors are load over loaded georefer-
enced image.
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If the Swap X Y checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

5. [optional] To import coordinates of point from text file perform the following:

1. Click the button. The Import parameters window opens.

Fig. 86. Import parameters of points coordinates from a text file

2. Click the and choose *.txt or *.csv file. Click the Open button.

3. Setup parameters of import.

4. [optional] In order to prevent change of points coordinates, which are already
measured on images, set the Clear before import checkbox.

5. Click OK to add points to catalog.

6. Find points from catalog on the map. To do this click the button and match
geodetic coordinates of point selected in the table to pixel coordinates of the
point on the map.

6. In order to add geodetic coordinates of GCP on the map manually perform the fol-
lowing actions:

1. Locate GC point on the map and place marker to this terrain point.

2. Click the button. The point’s pixel coordinates are added to the table.

3. Input manually geodetic coordinates of this point into the Xg, Yg columns and
specify the point’s name in the Name field.
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When the fifths point coordinates on the map are measured, coordinates measurement
residuals are calculated automatically and are shown in the Ex, Ey columns of the
table.

4. Repeat the 1–3 steps for other GC points.

For correct map reference it is recommended to recognize at least four points on the
map.

5. [optional] To move ground control points or to edit their coordinates see the
description of the main toolbar of the Raster georeference window.

6. Click the button to save georeference file to TAB format.

Table 12. Main toolbar of the Raster georeference window

FunctionButtons
to load source image without georeference
to load georeferenced image
to add georeferenced vector map of DXF, SHP or DGN format to another working
window
to load/add GC points data from text file to coordinate table
to save georeference file in MapInfo format with name similar to image
to zoom out of left and right parts of window for one step
to display data in 1:1 scale
to zoom in of left and right parts of window for one step
to fit to page data of opened layers
to delete all points from the table
to add new point in the table (as a pixel coordinates (Xp, Yp) are displayed coordin-
ates of marker, as a geodetic coordinates (Xg, Yg) – 0)
to delete a point selected in the table
to refresh coordinates of selected point (to save pixel coordinates of a new marker
position on the map for the point selected in the table)
to move marker on map point, selected in the table, that means that the system
performs search for selected point on the map
to copy coordinates of selected point

to refresh coordinates of selected point – to paste them from a clipboard (the fol-
lowing formats are acceptable:

to open the Windows standard color box that allows to choose color of GCP
symbols shown on the map

[raster map window] to display raster image in grey scale
to rotate image: No rotate, Rotate 90, 180 or 270 degree, , ,

[raster map window] to show/hide loaded vectors
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FunctionButtons
[raster map window] to show/hide nodes of vectors

9.8. Dust Correct

TheDust Correctmodule is used for ’cleaning’ the artifacts on the orthoimages – images
of dust particles, photo emulsion defects etc.

Artifact is called any object on image that shouldn’t be on object: images of dust particles, photo
emulsion defects, smooth, etc. Look like moire pattern, color errors, grainy lines etc.

Image could be edited only in the True Color monitor mode.

Perform one of the following actions to start module:

• choose Rasters › Dust Correct in the main system menu;

• choose Rasters › Dust Correct in the GeoMosaic program.

The module provides processing for Windows BMP and Stripped SingleScale TIFF without
compression images only.

Fig. 87. The main program’s window

The top toolbar contains the following buttons:
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• (Alt+X) – allows to close the DustCorrect module;

• (Ctrl+O) – allows to open image to edit;

• (Ctrl+Shift+O) – allows to open more than one image;

• – allows to return to previous image in module;

• – allows to move to next image in module;

• – allows to zoom out an image;

• (Alt+1) – allows to show raster image in zoom 1:1;

• – allows to zoom in an image;

• (Alt+Enter) – allows to zoom image to fit;

• – allows to open the Editor window;

• – allows to disable image editing.

To set the image background color, set the checkbox in the right part of the window
toolbar and select the appropriate item in the neighbor drop-down menu.

TheWindow menu contains the following menu items:

• Cascade – allows to stack opened windows;

• Mosaic – allows to arrange windows in a mosaic pattern;

• Close – allows to close active window;

• Close all – allows to close all windows in the DustCorrect module.

To specify the Dust Correctmodule settings, choose Settings › Options. The Options
window opens:

Fig. 88. The Options window
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• to open the Editor window in fullscreen mode – set the Maximize editor window
checkbox;

• use the appropriate standard tools to specify the Line color in main window;

• use the appropriate standard tools to specify the Line color in editor window.

To clear image from artifacts perform the following:

1. Choose File › Open (Ctrl+O) or click the button on the main module toolbar and
choose image in BMP or TIFF without compression format to load into module.

Themodule provides processing for Windows BMP and Stripped SingleScale TIFF without
compression images only.

The module provides possibility to clear from artifact more several images at the same
time. To open more than one image click the button. It is used the same workflow as
for only one image.

2. Find artifact should be edited on image.

Fig. 89. Image fragment with artifact

To change scale of working window is used * key to zoom in and / to zoom out. To
move on zoomed image right after mouse move press and hold Alt key and left
mouse button or press and hold Shift key and use arrows on the keyboard.

3. Select fragment on image with artifact and “clear” fragment to replace artifact.

Press and hold the Shift key and drag a rectangle by mouse.
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To break off selection, press the Esc key.

Fig. 90. Selecting fragment with artifact

4. Click the button on the main module toolbar. The Editor window opens.

Fig. 91. The Editor window
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5. In order to delete artifact perform the following actions:

The tool described below (so called “clone brush”) is used to retouch small local image
defects by using multiple copies of adjacent image fragments used as data sources (so-
called samples).

1. [optional] To specify the aperture size, input value in pixels in the field on the
right of the scale, in Editor window toolbar.

Aperture is a diameter of circle around the source point of which texture is used for
correction (see below).

2. Use the appropriate slider ( ) in the Editor window toolbar, to set the intensity
of the “clone brush” impact (in percent);

3. Choose the source point with “clean” texture.

4. Place market in the chosen point and click, while holding pressed the Shift key,
to mark the source point. The source point is marked by circle with the specified
aperture diameter.

5. To “clear” image press and hold left mouse button and move rectangle on the
artifact area.

To cancel all actions in the editor click the button. To undo the last action in the
Editor window click the button. To redo the last undone action click the button.

6. [optional] The background color is considered as transparent by default. Set
the checkbox in the Editor window toolbar, to choose the desired background
color in the appropriate drop-down list: Black, White or Other. Clear this
checkbox in order to change the background pixels during image correction.

In most cases background on edges of image has constant value of color and bright-
ness. It is not recommended to edit image on edge of raster and background to process
image correctly, because in further image processing it could be necessary to merge
raster image and background by color and brightness values.

7. Click the button to save results.

To exit without saving close the Editor window.
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Fig. 92. Image fragment without artifact

6. Repeat the actions, described in step 5 to clear other parts of image.

Fig. 93. Results of image correction in the Dust Correct module
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9.9. Changing of block images order

The Images z-order additional toolbar is used to change block scheme view and con-
tains buttons used to perform the following operations:

• –allows to reset images order (use the first order);

• – allows to invert images order (images in all strips and order of strips);

• – allows to move selected images to the top;

• – allows to move selected strips to the top;

• – allows to reverse images in the strip order;

• – allows to invert strips order.

9.10. Creating areas without background (useful areas)

It is recommended to create areas without background before dense DEM generation
using SGM method in Satellite scanner imagery projects (see the “Dense DEM gener-
ation using SGM method” chapter of the “DTM Generation” User Manual).

Useful area contains substantial part of image and excludes input background of image.
Useful areas are represented as vector polygons.

Useful areas along with other information, are located in image description files, in the
same folder with the images. Files with image description have *.x-feat extension.

The existing useful areas are used by the system’s algorithms during dense DEM generation
using SGM method (or they will be created automatically during DEM generation).

Areas without background, among other things, are necessary when creating a DEM using the
SGM method (see the “Dense DEM generation using SGM method” in the “DTM Generation”
User Manual).

When processing Satellite scanner imagery or ADS projects, the program checks the presence
of areas without background automatically, then, if they are absent, builds them automatically
with default parameters or uses the areas without a background previously created by the user,
if available.

The areas without background created in such a way can then be edited by the user for further
use, e.g. when rebuilding a DEM based on updated data (if appropriate). However, in most
cases, the preliminary creation of areas without background and/or their manual correction are
not required.

When creating a DEM using the SGM method for projects on the base of central projection
aerial imagery, automatic creation of areas without background is not performed. However, if
areas without background, for some reason, will be manually created by the user beforehand,
they will be taken into account when building a DEM.
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This may be necessary in cases when aerial images have areas containing a background, and
this, for example, cannot be corrected through theOffset from image boundaries customization
(see the “Dense DEM generation using SGM method” in the “DTM Generation” User Manual).

For useful areas creation use menu Block › Useful areas.

Table 13. Brief description of menu ’Useful areas’

FunctionMenu items
to define parameters and calculate useful areas
automatically as information located in files with
image description (*.x-feat)

Build

to load useful areas as vector polygons after cre-
ation

Load

to save useful areas after manual correctionSave

To load Useful areas as vector polygons after creation or verify their existence choose Block ›
Useful areas › Load.

For automatic calculation of useful areas perform the following actions:

1. Choose Block › Useful areas › Build. The Settings window opens.

Fig. 94. Useful areas parameters

2. [optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images.

3. Set the Image edges trim value to setup offset distance from background boundary
and the image substantial area (in pixels).
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4. Set the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created).

5. Image simplification, in pixels;

Preliminary simplification of images makes it possible to reduce the time spent on construct-
ing the boundaries of useful areas and reduce the number of their vertices, thus avoiding
unjustified complexity of their configuration.

Specific optimum values of simplification are to be chosen individually for each project,
depending on the project type and geometry of initial data.

It is not recommended to reduce default values for UAS and central projection projects,
that have quite large image overlapping.

When processing satellite scanner survey projects that have small image overlapping, re-
ducing this parameter can be feasible for the purpose of increasing the quality of boundary
construction.

When setting this parameter, it is recommended to take into account the previously set
Precision of calculation of areas boundaries (see above). The Precision and Image
simplification values that differ by several orders of magnitude, are not advisable

Preliminary image simplification before the construction of useful areas’ boundaries is
to be performed only if the unique background color checkbox is set (see above).

6. Set the Minimal components square to specify image area value, that will be
used as area minimal threshold for useful areas creation.

7. [optional] Set the Force checkbox on to recalculate already calculated and restore
deleted useful areas. At that information in files with images description *.x-feat
also refreshed.

8. Click OK to calculate useful areas.

To use distributed processing in calculation of useful areas, perform the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The Distributed processing of
useful areas window opens.
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Fig. 95. Creating areas without background (useful areas)

The total Number of images in project displays in the window.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of useful areas creation will be divided.

It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

There is an example of automatic useful areas calculation:

1. Source image has black input background. There are areas with input background
color inside the image.
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Fig. 96. Source image

2. Check the Unique background color checkbox in the Parameters window to
consider ’insets’ during useful areas creation.

Fig. 97. Useful area in case of unique background color
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3. Clear theUnique background color checkbox in the Parameterswindow to create
useful areas roughly, almost without considering ’insets’. Closed areas of black
color inside image are not considered as a background and are included to useful
area.

Fig. 98. Useful area in case of non-unique background color

9.11. Raster image histograms

The system provides for constructing raster image histograms.

An image histogram is the histogram of image brightness levels (either total or divided into color
channels).

To create the raster image histogram, perform one of the following actions:

• Load a raster image layer into the project (see “Georeferenced external data” section
in the “Aerial triangulation” User Manual and “Pseudo-stereo mode” in the “Vectoriz-
ation” User Manual). Make the raster image layer editable ( ). Choose Rasters ›
Create histogram by raster.

• Click the button in Radiometric correction window toolbar (see the “Radiometric
correction” section in the “General information” User Manual):

The Histogram window opens:
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Fig. 99. The Histogram window

The histogram is the graph of statistical distribution of a digital image elements with
different brightness values. The horizontal axis represents the pixel brightness (0 to
255 for 8-bit rasters or 0 to 65535 for 16-bit ones), and the vertical axis denotes the
number of pixels with particular brightness values.

There is a table in the bottom of the Histogram window that contains the following in-
formation on data used for histogram creation:

• Arithmeticmean brightness values used for histogram construction (the sum of pixel
brightness values divided by the number of pixels);

• Mean absolute is the sum of pixel brightness moduli divided by the number of pixels;

• RMS (root mean square) is the square root of the sum of squared pixel brightness
values divided by the number of pixels;

• Std. Dev. (standard deviation) is the square root of the sum of squared deviations
divided by the number of pixels;

Deviation is the difference between the pixel brightness and the arithmetic mean brightness
in the data used (see above).

• Mode is the brightness value most frequent in the data used to construct the histo-
gram;
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• Median bisects a series of ordered brightness values, with an equal number of values
both above and below the median (i.e. left and right on the X-axis);

• Step.

A total image histogram is to be constructed by default (all channels are to be used).
To re-build the histogram for a particular channel, choose this channel in the drop-down
list in the upper part of the window.

To display a tooltip with the exact values of the number of pixels (Y axis) and the
boundaries of brightness range segment (X axis) when you hover the cursor over a
separate chart column, click .

To disable tooltips, click once more.

10. Additional features

10.1. Specifying ground sample distance (GSD)

The systems provides an opportunity to set ground sample distance (GSD) for block
images.

GSD (Ground Sample Distance) is a pixel size on ground for satellite digital images.

The GSD parameter is used to create block layout and affect the size of block images
(see the “Aerial triangulation” User Manual).

The GSD value could be set manually or calculate automatically by DEM (if any).

For automatic calculation of GSD data by DEM it is necessary to have both interior orientation
and exterior orientation parameters available (projection centers coordinates, at least).

GSD value also could be set in the Image properties window, that is opened using the
button in theBlock editorwindow. However, this feature allows to set GSD value only manually
and separately for each image selected in the table of the Block editor window.

In order to define GSD for block images perform the following actions:

1. Choose theBlock › Set GSD or click the of theBlock forming additional toolbar.
The Ground sample distance (GSD) window opens.
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Fig. 100. Defining GSD

The table contains the following columns:

• Name – displays a list of all block strips and images;

• GSD, m – displays current GSD value (in case of unavailable GSD data, ’-’ is
displayed);

• Interior orientation – displays statistics about interior orientation parameters
availability for block images: ’+’ – available, ’-’ – unavailable;

• Exterior orientation – displays statistics exterior orientation parameters availab-
ility for block images: ’+’ – available, ’-’ – unavailable

• GSD modified – displays “*” if GSD value was changed.

Toolbar of theGround sample distance (GSD) image contains the following buttons
for selecting images:

• – allows to select all images;

• – allows to unselect all images;

• – allows to invert selection of files;

• – allows to select highlighted images;
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• – allows to unselect highlighted images;

• – allows to select in a table or list those images which are highlighted on a
block scheme in 2D-window;

• – allows to highlight on a block scheme in 2D-window those images which
are selected in a table or list.

2. Select images of block to set them GSD.

3. Set GSD value in the Set GSD value section.

For scanner images GSD could be set only manually.

The Unset GSD button allows to cancel defined GSD value for selected images. In this
case the GSD column in the table will display ’-’ for selected images.

To specify image GSD value manually input this value to the GSD field in the Set
GSD value section and click the Set GSD button.

For calculating GSD automatically perform the following:

1. Define Image pixel size, um manually in the Calculator section or click the
From project button to obtain information from metadata.

2. Set the Survey scale as 1:m in meters. Calculated value is displayed in the
GSD field in the Set GSD value section.

3. Click the Set GSD button. Set GSD values are displayed in the table for selected
images.

To calculate GSD values by DEM perform the following:

1. Click the button of the Compute by DEM section and specify DEM for
automatic GSD calculation.

It is necessary to have data of interior and exterior orientation of image for automatic
GSD calculation by DEM.

2. [optional] Set the In void DEM cells use Z checkbox on and specify Z-coordin-
ate in the input field for empty DEM cells (if any).

3. [optional] Set the Use image points out of DEM extents checkbox on for the
case when DEM does not “cover” images block completely.

4. Click the Compute button. GSD values calculated by DEM are displayed in
the table for selected images.
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4. Save defined GSD values by clicking the Apply button.

10.2. Creating overlap map

For visual analysis of images and strips overlap in a block the system provides a feature
of overlap map creating. After creating of such a map the overlap areas are created as
kind of vector polygons on a new vector layer.

Perform the following actions to create overlap map:

1. Choose Block › Create overlap map. The Overlap map parameters window
opens.

Fig. 101. Parameters of overlap map creating

2. Choose elements of a block to be used for overlap map creating: For images or
For strips.

3. [optional] Set on the Paint by overlapmultiplicity checkbox to color overlap areas
depending on overlap multiplicity, i.e. on number of images/strips that fall into the
overlap. When the option is disabled overlap areas are not colored.

4. [optional] Set on the Limit overlap multiplicity checkbox and input number of im-
ages/strips in overlap area, and when the value will be exceeded the fill color will
be not changed.

5. Click OK. A new vector layer containing overlap map is created.

In order to obtain information about number of images that fall to chosen overlap area, al-
locate a part of overlap map and choose theWindow › Objects attributes.

You can export overlap map using the Vectors › Exportmenu item to choose export format.
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Fig. 102. Overlap map

10.3. Creating vector layers from block layout

The system allows to obtain auxiliary data from block scheme – outlines of all/selected
block images (strips) or common boundary of block/group of selected images (strips) –
as vector objects on new vector layers. This data from block scheme is used, for ex-
ample, to define boundaries during TIN, or DEM building.

Perform the following actions to obtain vector data from block scheme:

1. [optional] Select block images (or strips) to build outlines for particular part of a
block.

To select (highlight) the image in the Block editor window click the image name in the list.
To select strip click the name of strip.

2. Choose Block › Create vector layer from block layout. The Create vector layer
from block layout window opens.

3. Click one of the following buttons:
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• All images (strips). The system creates and displays three vector layers: Block
outline with common block boundary, Block scheme with outline of each block
image and Block strips scheme with outline of each block strip.

• Selected images (strips). The system creates and displays three vector layers:
Block outline with common boundary of selected block images, Block scheme
with outline of each block image selected and Block strips scheme with outline
of each block strip selected.

To export vector outlines, obtained from block scheme, choose export format in the Vectors ›
Export menu.

For projects of Satellite scanner imagery type the Block scheme layer contains attributes
of objects that helps to extract scanner images data from metadata.

Fig. 103. Outlines from block scheme

10.4. Creation pre-regions for a block

The system provides possibility to create block pre-regions by images frames or by
stereopair frames to allow mutual project processing during vectorization. Pre-regions
created by stereopairs frames can also increase the speed of automatic points calculation
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and building dense DEM by reducing the number of images overlap areas (see the
“Creation of DTM” User Manual).

Pre-regions – vector layer which consists of polygons, drawn by images block.

Perform the following actions to create pre-regions:

1. Select Block › Build pre-regions. The Create pre-regions window opens.

Fig. 104. Pre-regions parameters

2. In theUse frames of section select one of the following ways of pre-regions creation:

• stereopairs to create pre-regions using overlap areas of two stereopair images;

When using stereopairs frames the system fills in polygons attributes automatically as
follows: region_image_code (with the left image code), region_image_name (with the
left image name), region_image_code_2 (with the right image code), region_im-
age_name_2 (with the right image name).

• images to create pre-regions by near-nadir areas of each image.

When using images frames the system fills in polygons attributes automatically as follows:
region_image_code, region_image_name.

3. Select a way to create pre-regions using selected frames: Using Voronoy diagram
or version 4.x algorithms earlier system’s version algorithm (PHOTOMOD 4.x).

4. [optional] Set the Remove slivers slider (at min value the pre-regions are built
considering narrow strips; at max value the pre-regions is created without narrow
strips).
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5. Click OK to create pre-regions. The system creates a new vector layer with pre-
regions.

To load, edit, save and close of pre-regions layer the system provides standard too for
work with vector objects (see description in the “Vector objects editing” chapter of the
Vectorization User Manual).

Fig. 105. Creation of pre-regions using Voronoy diagram, when the “Remove slivers” slider is placed
to the middle position
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Fig. 106. Pre-regions created using images frames

Fig. 107. Pre-regions created using stereopairs frames
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10.5. The list of stereopairs for a selected image

The system allows to open the list of images that form stereopairs with an image selected
in the Block editor window, including the case when two images forming a stereopair
are located on different strips.

Only two images adjacent to the selected image are displayed from among the images that
form stereopairs with this selected image and located on the same strip with it.

The displaying of images that form stereopairs with the selected image and located on different
strips depends on the settings of interstrip stereopair formation in the Settingswindow (Service ›
Settings › Block scheme, Forming interstrip stereopairs section).

Formation of stereopairs for the projects of Satellite scanner imagery and Airborne Digital
Sensor ADS types is described in the “Manual creation of stereopairs” section in the “Block
adjustment” User Manual.

To open the list, perform the following:

1. Select one image in the Block editorwindow and click the button. The following
window opens: Stereopair images for image which was selected in the Block
editor window.

Fig. 108. The list of images with which the selected image forms stereopairs, additionally sorted by
the convergence angle

This window contains the following elements:

• The table containing the list of images with which the selected image forms a
stereopair. The table has the following columns:

○ Image name – with which the selected image forms a stereopair;

○ Strip name – the name of the strip this image is located in;

○ Intersection angle.

• The toolbar containing the following buttons:
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○ – allows to open a stereopair to the image selected in the abovementioned
table;

○ – allows to specify the Settings for displaying a list of stereopair images
depending on the convergence angle.

• The section that displays the number of images contained in the table (depending
on the preset convergence angle) as relating to the total number of images with
which the selected image forms stereopairs.

2. To specify the Settings for displaying a list of stereopair images depending on
the convergence angle, click the button. The Settings for displaying a list of
stereopair images window opens:

Fig. 109. The Settings for displaying a list of stereopair images window

• Set the minimum intersection angle;

• Set the maximum intersection angle;

• Click OK to close the window.

10.6. Block scheme settings

The system provides possibility of block scheme export to KML (KMZ) format.

1. For export choose the Block › Export block layout to KML, KMZ. The Export
block layout to KML window opens.

2. Specify the following parameters:

• the Export selected images only checkbox is used to export part of block
scheme;

• Frames color – allows to specify color of block scheme border;

• Fill color – allows to set on the color filling inside of block scheme border.
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Fig. 110. Block scheme export settings

3. Click OK.

The system allows to obtain auxiliary data from block scheme – outlines of all/selected
block images (strips) or common boundary of block/group of selected images (strips) – as
vector objects on new vector layers.

To export vector outlines, obtained from block scheme, choose export format in the Vectors ›
Export menu.

11. Convert reference crosses

The system provides the possibility to process data from TK-350 topographic camera
installed on the Kometa satellite topographic unite designed to obtain high-precision to-
pographic imagery used for terrain mapping.

For data processing, the camera passport file (with *.txt extension) is used that cor-
responds to the orbit under processing, with grid cross coordinates corrected taking
into account calibrated distortion, refraction, and coordinates of the main point.

The system allows to convert this file to the camera passport file with *.x-cam extension
(required for further block adjustment with original imagery when measuring points of
laser reflection) and to the table of crosses with *.txt extension for its further processing
using PHOTOMOD ScanCorrect (see the “ScanCorrect” User Manual).

To convert TK-350 camera passport file, perform the following:

1. ChooseBlock › Reference crosses conversion. TheConvert cross coordinates
window opens.
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Fig. 111. The Convert cross coordinates window

2. In the File with refinements input field, click the button to locate an input
camera passport file (with *.txt extension) in theWindows filesystem;

3. In the Output file input field, click the button to locate output camera passport
files and tables of crosses in theWindows filesystem;

4. Click OK to convert a file.
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