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1. Purpose of the document

The current User Manual contains information about orthophotomaps creation using
GeoMosaic program. This program is designed to merge the georeferenced orthorectified
imagery and create the orthomosaic from them. The main part of document contains
description the technology of mosaic creation in the GeoMosaic program.

2. About program

2.1. Purpose and main definitions

The GeoMosaic program (hereinafter is referred to as 'program’) is purposed to create
the orthomosaic from georeferenced orthorectified aerial and satellite imagery, splitting
of created orthomosaic with the capable of saving sheets in popular raster file formats.

g The GeoMosaic program includes to the full version of PHOTOMOD system and also could be
produced separately.

% The orthomosaic is the single image, which obtained during the brightness adjustment and
merging the multiple georeferenced orthorectified images. The orthoimage is the image, obtained
after the transformation from the central projection to the orthogonal projection with automatic

removal of distortions, which were caused by the imaging equipment, elevation angle and relief.

The program provides the following features:
+ creating the orthomosaic from the source images;
+ radiometric images correction (filtration, color balance, brightness, contrast, etc.);

* pan-sharpening — process of merging multispectral and panchromatic images (see
“The pan-sharpening operation” chapter of the “General information” User Manual);

 correction (removing visual defects) of images in the DustCorrect module (see the
“Dust Correct” chapter of the “Project creation” User Manual);

ﬁ The module provides processing for Windows BMP and Stripped SingleScale TIFF without
compression images only.

» automatic cutlines creation considering areas without background and cloudiness on
images;

+ different modes of creation and edition cutlines;

+ splitting output mosaic into sheets depending on parameters;

» GCP adding and measurement their coordinates on images;

« tie points adding and measurement their coordinates on images;
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local and global brightness adjustment;
smoothing areas along cutlines for creating mosaic image;
import/export of cutlines, sheets borders. ground control points, etc.;

loading DEM and accuracy control of DTM creation (see the 'Creating DTM’ User
Manual).

2.2. Main conventions and terms

The program uses the following conventions and terms:

Orthomosaic — orthoimage, created from source images during brightness adjustment
and merging georeferenced orthoimages;

throughout this User Manual, the orthomosaic, created from the source images, is
referred to as 'output mosaic’ or ‘'mosaic’;

Orthoimage is a georeferenced image prepared from a perspective photograph or
other remotely-sensed data in which displacement of objects due to sensor orientation
and terrain relief have been removed,;

Cutline is the boundaries of the specified area from the source image, which will be
included in the output mosaic. The vector polygons are used for the cutlines creation.
The common boundaries of neighbouring cutlines are completely topologically coin-
cide, i.e. the areas of source images, selected using the cutlines, which are the single
area without overlaps and 'gaps’;

Useful area contains substantial part of image and excludes input background of
image;

Mosaic’s background — background of output mosaic, without image, which has color
defined by user. Each output mosaic file contain it;

Source images in mosaic project also have background, which calls background
color of source images in the system;

Sheet — a part of output mosaic, which is saved in individual file with chosen format;
edges of sheet are vector polygons;

Active sheet — a sheet, from which the output mosaic file will be create;
Inactive sheet — a sheet, excluded from the output mosaic;

Work area — vector polygons which define the boundaries of the output orthomosaic’s
content. If the user finds it necessary to use work area boundary (see Sec-
tion 13.2.2), the areas outside this area will be filled with the mosaic’s background.
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@ The work area makes it possible to limit the content of the orthomosaic to a polygon (or
polygons) of an arbitrary shape, what can be useful if user need to create a mosaic only
within some object, for example, a settlement.

@ The system provides for creating sheets of an output mosaic taking into account the work
area of interest, which makes it possible to avoid sheets completely filled with the mosaic’s
background (see Section 11.3.1).

» Source image (source image of mosaic project) — source georeferenced orthoimage;

* Reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project;

* Pyramid is a set of resampled copies of image;

» Global brightness adjustment means transformation equally applied to all pixels of
each source image;

» Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges.

2.3. Input data

The sources data for mosaic creation in the GeoMosaic program are the orthoimages,
referenced to the coordinate system, in the files of following formats:

» Tag Image File Format (TIFF) TIFF n GeoTiff format, included tags for saving of
georeferenced information;

* Windows Bitmap File (BMP);

* VectOr Raster Maps (RSW) raster formats of GIS Panorama software;
+ ERDAS IMAGINE (IMG) ERDAS system raster format;

* NITF (NITF);

+ JPEG (JPEG);

+ GIF (GIF);

+ PNG (PNG);

+ USGS DEM (DEM);

+ PCIDSK (PIX) raster format with georeference in the heading developed by PCI
Geomatics company;
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+ JPEG2000 (JP2) raster format with jpeg compression and georeference in the
heading developed.

@ The program also provides the ability to load and process of palette images in TIFF, GIF and
BMP files format.

The source images can be placed to resources of the active profile as well as to con-
ventionalWindows file system.

2.4. Output data

The program provides the supporting of multiple raster formats to export the output
mosaic sheets. The program also provides the output formats to export the georeference
data. The cutlines, sheet boundaries and tie points, created in the mosaic project, are
stored in vector files of internal format. The program supports the multiple import/export
formats of vector data.

é The output file size in JPEG2000 and ECW formats cannot exceed 500 MB.

Table 1. Output data

Output data File formats File placement
Mosaic project X-GMOS internal format in the active profile resources
Cutlines and tie points (vector X-DATA internal vector format in the active profile resources

data)

External georeferenced data for
mosaic sheets

PHOTOMOD GEO in Windows file system
* Maplinfo TAB

* ArcWorld (*.tfw, *.pbw)

Mosaic sheets (orthoimages) * TIFF n GeoTIFF (*.tiff, *.tif)|in Windows file system
* Windows Bitmap File (*.bmp)
* Panorama raster (*.rsw)

* ERDAS IMAGINE (*.1img)

* NITF (*.nitf)

* JPEG (*.]pg, *.]peg)

* PNG (*.png)

* Microstation (*.gfn)

- PCIDSK (*.pix)

- JPEG2000 (*.ip2)




PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

Output data File formats File placement
*+ PHOTOMOD MegaTIFF (*.prf)

« ECW (*.ecw)

* WebP (*.webp)

3. Start of work

Before the beginning work in the program define the folder, in which are placed the
sources data. The program allows to place the files with the source data in the folders
of Windows file system, as well as in the profile resources.

Activate this profile when the source images placing in the profile resources. Supported
file formats list of source images see in Section 2.3.

Description of resource system see in the General Information User Manual.
To start the program perform one of the following:

» choose the Start » Programs » PHOTOMOD 7 x64 » GeoMosaic;

+ double click the PHOTOMOD Geomosaic icon on the desktop;

« in the context menu of System Monitor module in (the €3 icon in theWindowssystem
tray) choose GeoMosaic;

+ start the PHOTOMOD system and choose the Rasters » GeoMosaic.
4. Interface and its elements

4.1. Work area interface

The GUI contains the following elements:

« title with name of opened project (A);

» the main menu bar (B);

» the main toolbar is used for quick main program functions access (C);

+ the additional toolbars is used for quick miscellaneous program functions access (O);

% The system interface is flexible for customizing the locations of additional toolbars according
to the user’s needs. Additional toolbars can either be fixed in designated sections of the work
area (top or bottom, right or left) or undocked by the user and placed in any place in the 2D

window.
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Depending on the user-set interface configuration, docked additional toolbars can be partly
minimized (some buttons will be hidden). Docked (optionally minimized) subtoolbars are
displayed as one line, vertical or horizontal, depending on their location.

By default, additional toolbars are docked at the top of the workspace, to the right of the main
toolbar. Additional toolbars are marked with a special icon | located on the left or top (de-
pending on the location) edge of the panel. To maximize the toolbar, click 3 (¥ ) on the right
(at the bottom).

Undocked additional toolbars are always displayed horizontally, in one line, in a fully maximized
form. To undock a toolbar (or pinpoint it in any place), move the cursor over the icon and,

holding down the left mouse button, drag the toolbar to the area of its targeted location (the
cursor’s shape changes (:') when it is possible to capture the toolbar).

+ the 2D-window, used for data displaying, contains the following elements:
o the toolbar is used for the 2D-window modes managing (D);

é A number/total sheets/images is shown in header of the individual 2D-window.

o the work area is used for viewing and processing with loaded data of mosaic project
(N);

o the navigation bar is used for fast moving on the specified block images area of
mosaic project (E);

é To do this, click on the chosen point in Navigation bar. To set the layers visibility, move
to the Navi tab in the layer manager.

o the Layer manager is used for managing of mosaic project layers (F);

o the axes direction of project coordinate system (M);

o the status bar is used for viewing current real (ground) and pixel marker coordinates
and brightness, contrast and gamma data adjustment in the work area (G, K, L);

% RGB brightness values are displayed to the right of the current marker coordinates. When

placing the marker within the work area, the following brightness values are displayed:
R=128 (=128 B=128.

@ When place marker is on the area out of image or on background (in Preview window),

brightness is indicated as NULL.

o scroll bar in 2D-window (H).
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Fig. 1. The GeoMosaic program

4.2. Brief description of main menu

The program main menu contains the menu items for mosaic creation, vector data
processing, additional applications starting and setting parameters.

Table 2. Main menu

Menu Function
Project to create, open and save mosaic project, and also
obtain information about project
Images to form images block of mosaic project
Cutlines purposed for cutlines creation and also provides

features for calculating areas without background
(useful areas) and cloudiness

GCltie points purposed for searching and measurement ground
and tie points in the cutlines region to adjust the
stitching along the neighbour cutlines

Sheets purposed for mosaic splitting and managing active
status of sheets
Misc purposed for additional data retrieving
Mosaic purposed for defining the output parameters of mo-

saic and creating the sheets of mosaic with saving
in output format files

10
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Menu Function

Vectors purposed for creating, editing, import/export of vec-
tor data (see the menu description in 'Vectorization’
User Manual)

Edit purposed for modes choosing to select and draw
vector objects, to transform curves, repeat/cancel
the last operation (see the menu description in
‘Vectorization’ User Manual)

Service purposed for applications launching, additional data
loading (e.g., DEM), general parameters setting,
coordinate system editing, etc.

Windows to open additional toolbars and windows: new 2D-
window, Marker and Measurements windows, Ob-
jects attributes window (see the chapter “General
system’s windows” of the ’General information’ User

Manual)
Help to start the 'Help’ system
Exit purposed for closing of GeoMosaic program

4.3. The main toolbar

Table 3. Brief description of main toolbar

Buttons Function
! to create a new project
= to open a mosaic project from active profile resources
to save a mosaic project
= to save a mosaic project with new name in active profile resources
e to add images out of active profile resources
H to add images from active profile resources
= to open images list
= to open sheets list
&L to open current and previous images in individual 2D-images
4= to open next image
= to open previous image
I to open current and next images in individual 2D-images
o to set on a single sheet creation mode
BT to create a sheet around marker
ot to turn on the cutlines fast manual editing mode
e to create a new cutline as a small rectangle polygon in the place of the node (the point
where three or more cutlines converge). This polygon can be further edited by the user.
H to define the output parameters for creation of mosaic
= to rebuild brightness adjustment for all block scheme
to enable using of ground control points

11


vectorization.pdf
vectorization.pdf
general.pdf
index.pdf

PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

Buttons Function

= to enable using of tie points

a to open the Preview window for all project

@] to open the Preview window for current sheet

2 to start the mosaic creation

B3 to start building a mosaic for selected active sheets according to the specified settings
and parameters in the distributed processing mode

I | to start building a mosaic and creating an output file for the selected sheet

= to load an image from file to the individual raster layer

B to launch the DustCorrect module to edit MS-TIFF images (see the “Dust Correct” chapter
of the “Project creation” User Manual)

Ly to undo the last action (see the 'General information about system’ User Manual)

=] to display the list of last actions (see the 'General information about system’ User
Manual)

T to redo the last undone action (see the 'General information about system’ User Manual)

& to load a georeferenced image from file, located in the file system, for more precise
correspondence of cutlines area

&l to load web-map

B to open the Marker window (see the menu description in "Vectorization’ User Manual)

B0 to open the Measurements window (see the menu description in 'Vectorization’ User
Manual)

EE to tile 2D-windows

i to stack 2D-windows

™ to arrange 2D-windows in a tabsheet

[ to arrange 2D-windows evenly

8= to refresh all 2D-windows; to perform re-calculating of brightness adjustment click the
button holding the Shift key

b4 to close all 2D-windows

to zoom in, in all windows with opened images (Shift+* [NumPad])

to zoom out, in all windows with opened images (Shift+/ [NumPad])

& to fit data to page, in all windows with opened images

@, to display data in 1:1 scale, in all windows with opened images

to open a window of display mode parameters (see Appendix A)

5. Workflow of mosaic creation

Creation of mosaic implies a number of following actions:

1. Creating of mosaic project (see Section 6).

2. Loading of images in the mosaic project (see Section 7):

* images adding;

12
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10.

1.

+ setting of transparency for the background color of source images (see Sec-
tion 7.5).

Defining of channels set for mosaic.
@ Use the Mosaic tab in the Mosaic parameters window to define the channels (see Sec-

tion 13.2.2).

Defining of the output coordinate system for mosaic and using it for storing of vector
data (the cutlines, sheets boundaries and tie points).

% Use the Misc tab to specify the save parameters of vector data in output coordinate system

(see Section 13.2.5). The output coordinate system for mosaic is defined in the Mosaic
parameters window on the Mosaic tab (see Section 13.2.2).

Estimation of work areas for cutlines creation: Creating areas without background
and areas with clouds (see Section 8).

Cutlines creation and editing (see Section 8).
é It is not necessary to create cutlines only if block of initial images with joining boundaries,

i.e. if images block is without overlaps and 'gaps’, is used.

[optional] Performing brightness adjustment of mosaic areas: global and local
brightness adjustment, seams feathering (see Section 9.1).

[optional] Stitching of the area from the tie points in the cutlines region and using
ground control points (see Section 10). Setup parameters of GC/Tie points meas-
urement (see Section 13.2.4).

Splitting into sheets and selection for creating of output files (see Section 11).

Setup the output parameters for mosaic creation: pixel size, map scale, mosaic
sheets file format, etc. (see the Section 13.2.2 and Section 13.2.3).

The mosaic creation with saving of the mosaic sheets in the files of selected format,
also in the distributed processing mode.

6. Mosaic project creation

6.1. Project menu

Table 4. Brief description of 'Project menu’

Menu items Function

(New is used for creation of the new mosaic project

13
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Menu items Function
=Open is used to open the saved mosaic project from file
with the *.x-gmos extension in the resources of
active profile
Recent to choose and open one of recent projects
Import to import mosaic project from the *.x-gmos file
[HSsave to save the opened mosaic project in the file with
the same name and the *.x-gmos extension in the
resources of active profile
Hlsave as to save the opened mosaic project in the new file

and the *.x-gmos extension in the resources of
active profile

Save work environment

to save the project work environment — a set of
project opened layers (e.g. vector data, raster im-
ages opened to transfer GCPs or DEM) in a file *. x-
work in active profile resources

Load work environment

to load project work environment data from a file
* . x-work saved in active profile resources

Statistic

to open the project statistic window

6.2. Creating new project

Choose the Project » New or click the [ button on the main toolbar; The following
blank service vector layers are created automatically and displayed in the Layer manager.

» Useful areas;

Clouds/Invisible areas;
* Ground control and tie points;
» Miscellaneous;

» Sheets;

Cutlines.

§ Service layers couldn’t be closed or saved as a separate vector layer.

% The [R/0] mark near the Clouds/Occluded zones layer name means that this layer is not
available for manual editing at the moment (see Section 8.4).

The name project in the title of main program’s window is marked with *, if the project
was changed. The names of layers to which unsaved changes have been made are

marked in a similar way.

Mosaic project is saved to *.x-gmos file.

14
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Choose the Project » Save to save the mosaic project. All changes in project layers
are saved.

Choose the Project » Save as to save the mosaic project with new name and define
name and path in active profile resources.

Choose the Project » Open or click the [= button on the main toolbar to open existed
mosaic project.

The program provides opportunity to load the following additional data in the project:

» choose the Misc » Load metadata to current layer to load images metadata to the
current active layer;

e‘ Metadata — structured information about data in the image file,

? It is recommended to choose Cutlines or Miscellaneous layers to correct load of metadata.
Metadata could be load only into a system layer.

+ choose the Misc » Load nadir and central points to load nadir and central points
to the Miscellaneous layer.

It is possible to work with project without source raster images (e.g. only to view project
parameters or cutlines). In this case images display as a grid in 2D-window.

3: 1:160 Preview

3:1:160 Preview 8 x
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Fig. 2. Project without source images
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6.3. Mosaic project import

The program allows to import parameters of other project without changing set of source

images

g During import of parameters or points/cutlines layers Npu nmnopte napameTpoB nnu crnos
NMope30B/TOYEK aBTOMATUYECKN YUNTLIBAETCS PacXOXAEHMEe Mexay pasMepamMiy MUKCENoB Ha

MECTHOCTM TEKYLLLEro 1 Apyroro NpoeKkToB.

To import project parameters to opened project choose the Project » Import.

4% Project import parameters [ﬁj

Import settings and brightness adjustment

| Import cutlines

| Delete existing cutlines

| Import tie and ground control paints
| Import sheets
| Reference by image name only

Import cell size

K ] | Cancel

Fig. 3. Mosaic project import parameters

The Project import parameters window allows to choose type of the following data to
import:

+ Import settings and brightness adjustment — allows to import parameters of the
Mosaic tab on the Mosaic parameters window, and also parameters of local and
global brightness adjustment from the Brightness adjustment tab;

» Import cutlines — to import cutlines layer, associate these cutlines with images of
current project;

o [optional] set the Delete existing cutlines checkbox to delete cutlines from opened
project during the import;

* Import tie and ground control points — allows to import tie and ground control
points and to associate then with images of current project;

* Import sheets — allows to import parameters of splitting mosaic into sheets and to
allow these parameters for current project;
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» Reference by image name only — to compare imported cutlines only by image name,
not by path;

* Import cell size — to import the output mosaic cell size.

@ All data import to the service layers of project. Layers with imported data are marked in the
Layer manager.

6.4. Project information

To view information about the project choose Project > Statistic.

The Statistic window, which contains the following information, opens:
+ quantity of source images;

* quantity of channels;

* bytes per sample;

» quantity of total/active mosaic sheets;

* mosaic size in megabytes;

» output raster size in pixels.

-~

.
% Orthorectification statistics I 28 =

Source images: 16

Channels: 3

Bytes per sample: 1

Sheets Total/Active: 81/22
Muosaic size: 6,15 GB

Output raster size: 7000070000

Fig. 4. Project information
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7. Images block forming

7.1. Images menu

Table 5. Brief description of Images menu

Menu items

Function

tLAdd images from files

is used for the selecting image files, locating in the
file system, and adding to mosaic project

Y Add images from resources

is used for selecting image files, locating in the re-
sources of active profile, and adding to mosaic pro-
ject

Add images > From files (from folder)

is used for automatic selection of all images from
the specified folder of Windows file system

Add images > From resources (from folder)

is used for automatic selection of all images from
the specified folder of active profile and adding to
mosaic project

Add images » Add from files list

to use the text file, containing the full network paths
to the images (useful when the project files are loc-
ated in different local and network folders), for
adding the images to mosaic project

Delete selected images

to delete from project the images that are selected
using selection of appropriate vector objects, for
example, source images boundaries, cutlines, areas
without background

Delete images outside active sheets

to delete the images outside active sheets from
mosaic (see Section 11)

i=The Images list window

to open the added images list for editing list, search
images by name, view the selected image and its
properties; define images background color; show
tie points residuals

Open selected images

is used to open in separate 2D-windows those im-
ages, with highlighted boundaries (see Section 12)

Check source images

is used for the checking of the project images (see
Section 7.9)

Create pyramids

to create the overview pyramid set for the fast im-
ages refreshing on screen (the pyramids are saved
in the files with the *.pyr extension in the Pyramid
folder during this process)

Distributed pyramids creation

to use distributed processing for pyramid creation
of loaded images

Delete pyramids

to delete all external pyramids, created for loaded
images (with the exception of the pyramids currently
in use)

Transparent background color

contains menu items to set up transparency images
background color
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7.2. Adding images

The step forming of source images block follows after the mosaic project creation. It
implies a number of following actions:

1. Loading source images and forming block images of mosaic project.

2. Setting transparency for the background color of source images to exclude the
background from the output mosaic.

The program provides the following possibilities to load source images into the project:
+ to add source images manually from files

o in active profile resources — choose the Images > Add images from resources
or click the ] button;

o in theWindows file system folder — choose Block » Add images from files or click
the L button.

5 Shift and Ctrl keys are used to select multiple files.

+ to add source images automatically;
% Automatic selection is recommended when large number of source raster files are located
in the folder along with files of other formats, and/or when source images are located in
several subfolders of the selected folder.

o from folder in active profile resources — choose the Images » Add images > From
resources (from folder);

o from theWindows file system folder — choose the Images » Add images » From
files (from folder).

? To search raster images in subfolders, set on the Search in subfolders checkbox.

% It is possible to search and add files only with selected extension. The type of mask like
* * is used for this (e.g., *.tiff).

+ to add set of source images create a text-file with the list of images paths and choose
Images > Add images » Add from files list.

5 The text-file should contain list of full network paths to source images files.
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It is possible to change output channels, ifimages with channel, that is absent in loaded
images, were added to the project.

7.3. Image selection

The program allows selection one of group of images in the Miscellaneous, Cutlines or
Useful areas layers and also in the window with source image.

The following options are provided for images selection:

» the Misc » Source images outlines menu item is used to create image borders as
vector polygons on the Miscellaneous layer. Images are selected corresponding to
selected polygons;

§ If there are selected objects on the non active Miscellaneous layer, will be selected images

corresponding to these objects.

« if there are selected polygons on the Cutlines or Useful areas layers, will be selected
images corresponding to selected polygons;

« if there are selected objects on the active 2D-window, will be selected image in this
window only.

7.4. Images preview

Images block opens automatically in the Preview window after adding images to the
mosaic project.

To display all images in the Preview window, choose the Mosaic » Preview or click
the & button of the main program toolbar.

é Images are displayed in the Preview window automatically after adding to the mosaic project.
In order to disable automatic displaying of images, set off the checkbox in the Preview tab of
the Parameters window (see Section A.2).

Each image of mosaic project is a raster images, insert to a rectangle.

Background without image has defined color. In program it calls mosaic’s background
and each output mosaic file contain it.

By default is used black background color. Background doesn’t display in the Preview
window.

§ To display output mosaic background in the Preview window, set off the Transparent mosaic
background on preview checkbox in the Preview tab of the Parameters window (see Sec-
tion A.2).
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? The Background color parameter on the Mosaic tab in the Mosaic parameters window allows
to chose (see Section 13.2.2).

Source images in mosaic project also have background, which calls background color
of source images in the system.

ﬁ It is recommended to exclude this background from output mosaic. To do this set the transparency
of background color (see Section 7.5).

L:1:02 | 3: 1128 Preview

3:1:128 Preview

@ 8 @EIRERR Qs

e ERe s GRUNA D R R R R

Mosaic background color

Images background color

[ I} o I} [ T u)=/= [@foal(a

| [[2592722.850000 ; 6584678.6.50000 w; 0.000000 1 [Aexaprosa npasan

Fig. 5. Mosaic’s background and background color of original images (without transparency)
Perform one of the following to open images of mosaic project in separate 2D-windows:

» choose the Images » Project images list to open Images list window. Select the
images in the list and click the 2 button.

@ In order to highlight multiple images, press and hold the Ctrl or Shift key while clicking mouse

or use selecting tools in Images list window (see Section 7.8).

» choose the Misc » Source images outlines to create image borders as vector poly-
gons. Select borders of images and choose the Images » Open selected images.

5 To select more than one object, stretch the rectangle along with pressed Shift key with one
of the group selection instruments on Tools toolbar.

5 The system also provides for selecting objects using a freeform polygon (
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Create a polygon by holding Shift while moving the cursor sequentially in the work area of
the 2D window. To complete the creation of a polygon, set the last vertex of the polygon by
double-clicking the left mouse button. To delete the last created vertex, press Esc.

The following buttons on main toolbar are used to pass to previous or to next image:
+ 4= — to display previous image;

+ =» —to display next image.

@ If there is no opened 2D-windows (image) or preview windows, the #= button allows to open
the last image in the project, = — the first image.

The following buttons on main toolbar are used to pass to previous or to next image:
&L — to display current and previous images in separate 2D-windows;
« I —to display current and next images in separate 2D-windows.

To open any georeferenced orthoimage of acceptable raster format in separate 2D-
window, choose the Mosaic » Open image or click the [ button on the main toolbar
and choose image file.

@ In case the same folder contains a *. rmc file, the correction parameters for the selected image
will be loaded

7.5. Setup of image background color

Itis recommended to setup of transparency image background color after image loading
into mosaic project to create mosaic correctly.

A Setup of transparency background color of input image is highly recommended when there are
areas inside images with the same color as background and you need to consider these areas
in output mosaic as transparent, i.e. to produce mosaic with ’gaps’ without fill of input background
color or using reference image. The Transparent background inside cutlines parameter is
used to consider useful areas transparency (see Section 13.2.2).

Perform one of the following to setup transparency for the background color of source
images:

% If background is not homogeneous in color, use the Source rasters background color range
parameters (see Section 13.2.2).

* in case of white background color of source images, choose the Images > Transparent
background color » White;

* in case of black background color of source images, choose the Images > Transparent
background color > Black;

22



PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

* choose the Images » Transparent background color > Auto to assign automatically
images background color and set up transparency to all mosaic project images.

@ In case of arbitrary background color of source images, choose the Images » Project images
list or click the (& button on the main toolbar. The Images list window opens. Select the
images to define the images background color and click the Fll button (see detailed description

in Section 7.8).

Due to the peculiarities of preprocessing, some satellite images can have two background
colors at the same time (black and the second one is arbitrary), which must be taken
into account during processing. For correct processing of such images, perform the
following:

1. To take into account the arbitrary background color of source images, choose the
Images » Project images list or click the & button on the main toolbar. The Images
list window opens. Select the images to define the images background color and
click the Hl button (see detailed description in Section 7.8).

2. To take into account the black background color of source images, choose the
Mosaic > Parameters or click the % button on the main toolbar. The Mosaic
parameters window opens. Open the Brightness adjustment tab set the Addi-
tional check for black background checkbox.

Choose the Images > Transparent background color » None to cancel transparency
setting for images background color.

3 1128 Praviem

3:1:128 Preview 8 x

@ s & @EDRQUE Q@ Q[ o o B e RN D ROR D o T R

asic

+32 EEH 28

i points (cores_test_tiepoints)

LA N IS

[T G
] o ] |5 ] === [afe/a [a

2552722 850000 ; 6564675.650000 ; 0.000000 [ Recaprosa mpases

Fig. 6. Black color of images background
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Fig. 7. Transparency setting for black color of images background

7.6. Image pyramid creation

To fast images redraw on a screen it is possible to create image pyramid.

el Pyramid is a set of resampled copies of image.

The pyramids are saved to the files with the *.pyr extension in the Pyramid folder.

ﬁ PHOTOMOD software supports already existing third-party image pyramids, if available (*.ovr).

Choose the Images > Create pyramids for creating the overview pyramid.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to create pyramids using distributed processing:

1. Add images to the project.

2. Change settings and run the distributed processing server/client (see the 'Distributed
processing’ chapter in the 'General information about system’ User Manual).

3. Choose Images » Distributed pyramids creation. The Create pyramids window
opens.
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& Pyramids creation 2

Images number in project: 15

Mumber of tasks for processing: 4 =
Tempaorary folder for distributed processing:

=)

[ OK ] | Cancel |

Fig. 8. Pyramid’s distributed processing parameters
The total Number of images in project displays in the window.

4. Specify Number of tasks for processing, which are processed by one computer.

% It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

5. Selectthe Temporary folder for distributed processing in the resources of active
profile for temporary data storing.

6. Click OK. Distributed processing tasks are created and the system shows a message
about number of created tasks.

7.7. Editing of block images
Perform one of he following actions to delete the images from the mosaic project:

* select the image in the Preview window and choose the Images » Delete selected
images;

» choose the Images » Project images list. The Images list window opens. Select
the images in the list and click the & button.

To select multiple images use Shift and Ctrl keys or use selecting tools in Images
list window (see Section 7.8).

Also the program provides a possibility to delete images outside of active sheets border
(see Section 11). After sheets creation define the activity of sheets and choose the
Images > Delete images outside active sheets to do this.

7.8. The Images list

The Images list window is provided to view and edit the images list of mosaic project.
To open the Image list window choose the Images » Project images list or click the
= button of the main program toolbar.
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r’ Images list l =NACE X )
] Name only | {4 BEHGEDR PREREEODO HAKAER S BARVY LR EEE @
Ordinal number View Image Back. color Cutlines Dimensi Ch | Pixel size s

: P s Rowes  wow |
2 9 - 673 tif | 1 7396 x 7452 (R, G, B)x8 0.400000

3 13 = 677 tif | 1 T418 x 7472 (R, G, Bjx8 0.400000

4 10 = 674 tif | 1 7420 x 7465 (R, G, B)x8 0.400000

5 6 - 669.tif | 1 7446 x 7451 (R, G, Bjx8 0.400000

6 15 = 679.tif | 1 7459 x 7487 (R, G, Bjx8 0.400000

7 16 = 680.tif | 1 7459 x 7497 (R, G, Bjx8 0.400000

g 2 - 665.tif | 1 7496 x 7529 (R, G, Bjx8 0.400000

g 1 - 664 tif | 1 7508 x 7531 (R, G, Bjx8 0.400000

10 5 - 668.tif ] 1 7521 x 7519 (R, G, Bjx8 0.400000

11 4 - 667.tif ] 1 7521 %7534 (R, G, Bjx8 0.400000

12 3 - 666.tif ] 1 7539 x 7564 (R, G, Bjx8 0.400000

13 11 - 675.tif ] 1 7539 x 7576 (R, G, Bjx8 0.400000

14 14 - 678.tif ] 1 7555 x 7610 (R, G, Bjx8 0.400000

15 7 - 670.tif ] 1 7580 x 7579 (R, G, Bjx8 0.400000

16 & - 671.tif ] 1 7596 x 7602 (R, G, Bjx8 0.400000

Images total/selected: 16/1

Fig. 9. The Images list window

The main part of the window contains a table of mosaic project images with the following
information:

* Ordinal number;
* View — visibility images in the preview window;
* Image — attribute for full path to image file;

§ Set the Name only checkbox on to display image file name only;

» Background color — background color of source images, specified during setting of
background color transparency;

» Cutlines — information about presence/absence and quantity of cutlines created for
the image;

» Dimensions —image size in pixels;
* Channels — channels number and number of bytes per pixel;

@ Points sorting in columns of the list is performed by mouse click on the column header.

Double click to image name allows to open 2D-window of source image and all data
for this image (cutlines, sheets borders, etc.).
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Fig. 10. Project image

Toolbar and standard selection and searching tools are placed in upper part of window.
Number of Images total/selection displays in the status bar of the window.

Table 6. The toolbox of 'Images list’ window

Buttons Function
i to search for an image by name (part of name) in the list
E1= | to select all images in the table
g to unselect all images in the table
EE to invert selection of images in the table
i to highlight images, selected in the table, on active layer
S to highlight image, selected in 2D-window, in the table
e to add images out of active profile resources
B to remove selected images from project
M to remove from the project images without cutlines (in the Cutlines column is shown
the '~
! to set coordinate system for selected images
i to clear coordinate system for selected images
= to open selected image in 2D-window
to refresh table of images and recalculate quantity of cutlines, which fall into images
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Buttons Function

(i to display information about selected image (path, size, channels)

to clear selected images background color

£ to set arbitrary images background for selected images

[ to apply auto levels to selected images (see the ‘General information about system’ User
Manual)

“h to perform the radiometric correction for selected images (see the 'General information
about system’ User Manual)

= to load radiometric correction parameters from a *. rmc file

% to delete radiometric correction for selected images

D to show tie points residuals for current image (see Section 10.5)

i to restore the default order of images after changing

= to move selected image at the head of the list;

N to move selected image up the list;

W to move selected image down the list;

¥ to move selected image at the end of the list;

i to invert selected images or group of images

B0 to reverse images in the table

to save the list of selected images and their file paths in a text file

1| to remove each n-th images from project

= to select several images from the project as a 'reference’ images to apply global bright-

ness adjustment

¢

Selected reference images will not be changed during adjustment. Histograms of other mosaic

images will be corrected in accordance with chosen (‘reference’) images.

list window, make sure that the By average brightness option is selected in the Global adjust-
ment section of the Brightness adjustment tab in the Mosaic parameters window;

Brightness adjustment using several reference images (located in different parts of the mosaic)

é For correct brightness adjustment using one or more reference images selected in the Images

can be useful when processing projects containing large number of images.

to open the Columns list window, to manage the additional columns, containing inform-
ation from images metadata, if it exists (for the scanner satellite images for example)

to display in the Preview window changes of brightness, contrast and gamma data
settings in the work area (G, K, L) made in a single image 2D window without closing it

In order to display in the Preview window changes of brightness, contrast and gamma
data settings in the work area made in a single image 2D window (without closing it),
perform the following:

1. Make sure that the Use brightness pre-correction checkbox is set in the Bright-
ness adjustment tab in the Mosaic parameters window, and None option is se-
lected in the Global adjustment section;
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2. Click the ¥if button in Images list window;

3. Click the & button of the main program toolbar. Brightness, contrast and gamma
data changes will be displayed in the Preview window.

The system allows to save radiometric correction parameters to *. rmc files in order to
apply these parameters to other images. Perform the following actions to do this:

1. Select image in the list;
2. Setup parameters and perform radiometric correction of selected image;

3. Click the g" button and define a folder to save radiometric correction parameters
in file with *. rmc extension;/

4. Choose image for correction in the list;
5. Click the &' button. The load correction parameters window opens;

6. Choose parameters file file and click OK. Correction parameters apply to selected
images.

5 A RMC-file is created for each of selected images. Further, these files can be used during
operations related with GC/tie points and mosaic creation.

7.9. Checking source project images

The system provides for checking source project images. The following parameters
can be checked:

+ available image files (according to specified paths to these files);
+ correct image formats and extensions;

* available georeferenced data (files).

To check project images, perform the following:

1. Choose Images > Check source images;

2. Wait for the operation to complete:

* [optional] If all project images have been verified, an appropriate info message
is issued:
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4% PHOTOMOD 8.0.4588 = . -

@ 10.07.2024 16:35:17: Rasters totalfvalid: 16/16

ok

Fig. 11. An informational message
+ [optional] If a part of the project images has not been verified, the following win-
dows are displayed in turn:

1. A dialog box informing about the number of images that have not been veri-
fied:

i #® Question Iﬁ |

Delete 92 raster(s)?

Fig. 12. A dialog box

o [optional] Click Yes to delete images that have not been verified from the
project and proceed to the error window;

o [optional] Click No, not to delete images and proceed to the error window.

2. The error window
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Fig. 13. An informational message

7.10. Replacing images

When processing a project, it may be necessary to completely or partially replace the
project images with their copies having identical names but located in a different folder
(in the Windows file system or in the active profile resources).

& Projectimages can be located both in the Windows file system and in the active profile resources,
both in one folder and in several different folders. Cutlines can refer to images by the full path
to the image file (in the Windows file system or in the active profile resources) or by the image
name only.

If it is necessary to replace images in an already processed project, the following pro-
cedure is recommended:

1. Open the Image list window (see Section 7.8);
2. Delete the required images;

3. Add new images with the same names instead of the deleted ones. These added
images may have a different location;

4. To refer the cutline to the added image, select the required cutline and open the
Cutline info window (see Section 8.8). To disregard the image path and refer the
cutline by image name only, set the Name only checkbox in the Cutline Info win-
dow.
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é It is strongly discouraged to create projects with non-unique image names. If there are
images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines.

8. Cutlines creation

8.1. Cutlines menu

Table 7. Brief description of the Cutlines menu

Menu items Function
#% Clear to delete cutlines, i.e. to clear the Cutlines layer
completely (without closing of this layer)
#2 Open to open cutlines saved earlier in vector file *.x-data
in active profile resources
Import see “Import of vector objects” in the “Vectorization”
User Manual
Export see “Export of vector objects” in the “Vectorization”
User Manual
i Save to save vector data file with cutlines
£l save as to save cutlines in vector file *.x-data with new

name

Useful areas

to calculate useful areas in automatic mode

Clouds/Invisible areas

to calculate cloudy areas in automatic mode

Build full mosaic

to setup parameters of automatic cutlines creation
and to start cutlines build operation, also in the dis-
tributed processing mode

& Area to cutlines addition mode

to add areas to cutlines during their editing (see the
Section 8.6.1)

#° Parameters

to redefine attributes of the Cutlines vector layer

Cutline properties

to view and edit attribute values of selected cutline

Check cutlines

to check correspondence between cutlines and im-
ages of a project in order to find images without
cutlines and/or cutlines which are not attached to
images

Split cutlines into sheets

to split cutlines according to boundaries of created
sheets (see the Section 8.6)

Attach cutlines to images

to attach vector polygons obtained from a third-party
source to project’s images according to their geo-
metric location for further use as cutlines (see Sec-
tion 8.9)

Replace current node by new cutline

to create a new cutline as a small rectangle polygon
in the place of the node (the point where three or
more cutlines converge). This polygon can be further
edited by the user
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7

If the vertices of adjacent cutlines located next to a node vertex are too close to it, then when
user tries to replace current node by new cutline, the appropriate error message is displayed:
Inserting cutline is too small. If this system message appears, manually delete the vertices
closest to the node and try to repeat this operation by clicking the % button in the main toolbar.

8.2. Requirements of the cutlines creation

The stage of cutlines creation follows after the forming the block images of the mosaic

project.

Cutline is a vector polygon defining the images area, which will be included in output
mosaic.

7

<

Combination of automatic and manual cutlines creation, with clouds selection, optional use of
DEM, as well as definition of the cutlines type by attributes provide high quality the stitching of
the areas during the output mosaic creation.

In case of automatic cutline creation, the resulting vector layer is primarily available for collab-
orative editing by several users and has *.cx-data extension (see “Co-editing vector layers”
and “Co-editing topologically connected vector objects” of the “Vectorization” User Manual).

When copying PHOTOMOD GeoMosaic containing cutlines, it is important to pay special attention
to whether the vector data link to the project (see Appendix A). In case the appropriate
checkbox is set and cutlines (or other vector layers) from another project are used during the
current project processing, then when saving the project being processed, all the above vector
layers are saved as copies belonging with this project.

Performing the following steps is recommended for the cutlines creation:

1.
2.
3.

[optional] Creating areas without background and areas with clouds.
Automatic cutlines creation (also in the distributed processing mode).

Editing cutlines: manual editing of vector polygons and their attributes in the Cutlines
layer.

There are following rules to go by when creating the cutlines for building of the high
quality mosaic:

» cutlines should not have intersections and self-intersections. The common boundaries
of the neighbour cutlines should be fully correspond;

* l.e. all areas of the source images, outlined by cutlines, form one united coverage
without overlaps or gaps;

It is not recommended to draw cutlines over elevated objects (bridges, buildings,
utility poles, etc), otherwise if the Seams feathering checkbox in the Mosaic para-
meters window in the Brightness adjustment tab is set on, the smearing effect is
possible;
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@ It is recommended to cross extended objects at right angle or create cutline not less than 1.5
cell size apart from extended objects border.

* it is recommended to create cutline parallel to brightness edge on enough distance
from it.

8.3. Creating areas without background (useful areas)

It is recommended to create areas without background before creating cutlines and set
the background transparency of source images.

Useful area contains substantial part of image and excludes input background of image.
Useful areas are vector polygons on the Useful areas layer.

Useful areas are used as well as setup of input background color transparency to create
cutlines.

There is no need to create useful areas prior to cutlines creation in the following cases:
+ there is no background on images;
* manual editing (specification) of useful areas is not required;

+ there is no need to select (create) cloudy areas on source images to consider them
during cutlines creation.

Useful areas creation may exclude a necessity to setup transparency of input background
color.

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have x-feat
extension.

For useful areas creation use menu Cutlines > Useful areas.

Table 8. Brief description of menu 'Useful areas’

Menu items Function
Build to define parameters and calculate useful areas
automatically as vector polygons on the Useful areas
layer
Clear to clear Useful areas layer (without closing of this

layer); at that information about useful areas is not
deleted from files of images description *.x-feat,
that allows to restore created useful areas

Open to restore recently created useful areas if the Useful
areas layer was cleared using menu item Cutlines »
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Menu items Function

Useful areas » Clear, and then to display them in
the Preview window

Save to save useful areas in files of images description
* x-feat after drawing them manually or editing
areas without background calculated automatically

Delete all to completely clear the Useful areas layer without
possibility to restore the useful areas, i.e. to clear
the layer along with deleting information in files of
images description *.x-feat

Delete for selected images to delete useful areas, created for selected images,
along with information in files with images descrip-
tion *.x-feat

For automatic calculation of useful areas perform the following actions:

1.

2.

Choose Cutlines » Useful areas » Build. The Settings window opens.

r* Parameters [&Jﬁ

Maximum deviation from background color: 0 =
| Unigue badkground color
Image edges trim: 0.00 1 pix
Predision: 2.00 1 pix
Image simplification: g.00 1 pix
Minimal components sguare: 1000,00 = pin"2

For selected images only

Farce

QK l |Distributed processing. .. | | Cancel

Fig. 14. Useful areas parameters

[optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images;

Set the Image edges trim value to setup offset distance from background boundary
and the image substantial area (in pixels);

Set the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created);
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5. Image simplification, in pixels;

<

7

A

Preliminary simplification of images makes it possible to reduce the time spent on construct-
ing the boundaries of useful areas and reduce the number of their vertices, thus avoiding
unjustified complexity of their configuration.

Specific optimum values of simplification are to be chosen individually for each project,
depending on the project type and geometry of initial data.

It is not recommended to reduce default values for UAS and central projection projects,
that have quite large image overlapping.

When processing satellite scanner survey projects that have small image overlapping, re-
ducing this parameter can be feasible for the purpose of increasing the quality of boundary
construction.

When setting this parameter, it is recommended to take into account the previously set
Precision of calculation of areas boundaries (see above). The Precision and Image
simplification values that differ by several orders of magnitude, are not advisable

Preliminary image simplification before the construction of useful areas’ boundaries is
to be performed only if the unique background color checkbox is set (see above).

6. Set the Minimal components square to specify image area value, that will be
used as area minimal threshold for useful areas creation.

7. [optional] To calculate useful areas for selected images only, set on the For selected
images only checkbox;

8. [optional] Set the Force checkbox on to recalculate already calculated and restore
deleted useful areas. At that information in files with images description *.x-feat
also refreshed;

9. Click OK to calculate useful areas.

To use distributed processing in calculation of useful areas, perform the following:

1.

Change settings and run the distributed processing server/client (see the 'Dis-
tributed processing chapter in the 'General information about system’ User
Manual).

Click the Distributed processing button. The Distributed processing of
useful areas window opens.
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P

& Useful areas parallel processing lﬁ

Mumber of images in project: 4

Max. number of simultaneous tasks 4 =

Temporary folder for distributed processing:

sky-Movoselov/Orthe_Second/Data/Temp _l

[ QK l | Cancel |

L™ A

Fig. 15. Creating areas without background (useful areas)
The total Number of images in project displays in the window.

3. Define the Max. number of simultaneous tasks for tasks number on which
the process of useful areas creation will be divided.

é It is recommended to set quantity of tasks in proportion to quantity of used cores, but
not more than 25 tasks.

4. Select the Temporary folder for distributed processing for temporary data
storing.

5. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

There is an example of automatic useful areas calculation:

1. Source image has black input background. There are areas with input background
color inside the image.
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B ! o J i J OOEICE D

Fig. 16. Source image

2. Setthe Unique background color checkbox in the Parameters window to consider
'insets’ during useful areas creation.

o | ©r | A | see(ecnm e

Fig. 17. Useful area in case of unique background color
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3. Clear the Unique background color checkbox in the Parameters window to create
useful areas roughly, almost without considering ’insets’. Closed areas of black
color inside image are not considered as a background and are included to useful

area.

A ! ses||enme

Fig. 18. Useful area in case of non-unique background color

8.4. Clouds calculation

In order to calculate cloudy areas and exclude them during cutlines creation the system
provides possibility of their automatic recognition and calculation. Cloudy areas are
vector polygons on the Clouds/Invisible areas layer.

ﬁ It is necessary to create useful areas prior to creating of cloudy areas.

The Cutlines > Clouds/Invisible areas menu is used to create cloudy areas.

Table 9. Brief description of menu 'Clouds/Invisible areas’

Menu items Function
Build to setup parameters and automatically calculate
cloudy areas as vector polygons on the Clouds/In-
visible areas
Clear to clear the Clouds/Invisible areas layer (without

closing the layer); at that information about clouds
is not deleted from files of images description *.x-
feat, that allows to restore created clouds
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Menu items Function

Open to restore existing clouds if the Clouds/Invisible
areas layer was cleared using menu item Cutlines »
Cloudsl/Invisible areas > Clear, and to display them
in the Preview window

Save to save clouds in files of images description *.x-
feat after editing of clouds calculated automatically
or after drawing them manually (see below)

Save for selected images to save cloudy areas created just for selected im-
ages to files of these images description *.x-feat
after editing of clouds calculated automatically or
after drawing them manually

Delete all to clear the Clouds/Invisible areas layer completely
without possibility of restoring cloudy areas, i.e. to
clear the layer along with information deleting from
files of images description *.x-feat

Delete for selected images to delete clouds created for selected images, and
to delete information from files of images description
*.x-feat

Useful areas along with other information, such as background color, cloudy areas,
cutlines are located near files with images. Files with image description have *.x-feat
extension.

The user cannot edit the Clouds/Occluded zones layer manually directly after project
loading, since this may lead to data loss in case if the *.x-feat file already contains
data on the areas containing clouds.

To make this layer editable, either first Open the area data (or make sure that they are
absent after executing this command), Build areas with clouds again, or Delete all
relevant data from the *.x-feat file (confirming this action).

The [R/0] mark near the Clouds/Occluded zones layer name means that this layer is
not available for manual editing at the moment.

Automatic clouds detection principle consists in search on image for bright enough and
homogeneous areas, where there is grey color with area not less then specified.

To calculate cloudy areas automatically perform the following actions:

1. Choose Cutlines » Clouds/Invisible areas » Build. The Clouds detecting para-
meters window is opened.
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4 Clouds detecting parameters I,-;-:h,l

Brightniess lower boundary: 50,000

Upper boundary of gray shift: 25,000

Upper boundary of heterogeneity 10,000

4|k 4|k 4|k 4|k 4|k 4|k Ak

Digpersion upper boundary: 30,000

Clouds edges thinning: 0,000

Minimal doud area: 100,000 M2
Clouds offset: 40,000 M

For selected images only

Force

[ k. ] |Dist’ibuted prncessing...| | Cancel |

Fig. 19. Parameters of cloudy areas building

2. Specify the following parameters of automatic clouds detection:

Brightness lower boundary — allows to define range of brightness for clouds
detection — to specify lower brightness threshold (from 0 to 100, where 100 —
maximal brightness), if the brightness is more that the threshold it is considered
as possible cloud;

Upper boundary of grey shift — allows to define maximal deviation from grey
color that present in clouds (from 0 to 100, where 0 — grey color, when R, G, B
values are equal);

Upper boundary of heterogeneity — allows to define range of heterogeneity in
clouds — to specify maximal deviation from homogeneity (from 0 to 100, where
0 — homogeneous area);

Dispersion upper boundary — allows to define range of dispersion in clouds —
to specify upper dispersion threshold (from 0 to 100);

Clouds edges thinning — allows to define a degree of clouds boundaries thinning
(filtering of vector polygons vertices) from 0 to 100, where 0 — boundaries without
thinning; 100 — 'rough’ maximally filtered boundaries;

Minimal cloud area — allows to define minimal area of cloud, when this area is
not considered as cloud, i.e. clouds of small size will be excluded from selection;

Clouds offset — allows to setup offset in meters around the cloud detected (to
exclude shadow or half-transparent part of cloud).
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3.

[optional] To calculate cloud areas for selected images only, set on the For selected
images only checkbox.

[optional] Set on the Force checkbox to recalculate already calculated and restore
deleted cloud areas. At that information in files with images description *.x-feat
also refreshed.

Click OK to search and calculate cloudy areas.

To use distributed processing in calculation of cloudy areas, perform the following:

1.

Change settings and run the distributed processing server/client (see the 'Dis-
tributed processing' chapter in the 'General information about system’ User
Manual).

Click the Distributed processing button. The Distributed processing of
useful areas window opens.

4% Clouds parallel processing léj

Mumber of images in project: 4

Max. number of simultansous tasks 4 =

Temporary folder for distributed processing:

¢-Movoselov/Ortho_Second/Data/Temp _

[ QK ]| Cancel |

Fig. 20. Creating cloudy areas

The Number of images in project field displays the number of source project
images.

Define the Max. number of simultaneous tasks for tasks number on which
the process of cloudy areas creation will be divided.

é’ It is recommended to set quantity of tasks in proportion to quantity of used cores, but

not more than 25 tasks.

Select the Temporary folder for distributed processing for temporary data
storing.

Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.
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8.5. Automatic mode of cutlines creation

The program provides opportunity to create cutlines in automatic mode with one of two
algorithms: Voronoy diagram, and more detailed algorithm which is specially recommen-
ded for images with urban or rural building.

Performing the following steps is recommended for the cutlines creation:

1. Use the fast Voronoy diagram method.

2. Estimate the results of cutlines creation.

3. [optional] Edit the cutlines in vector objects drawing mode, if necessary.

4. If the results are not acceptable apply detailed algorithm of cutlines creation.

In this case cutlines are created bypassing separate objects (houses) and crossing roads
at the right angle.

Perform the following actions for automatic cutlines creation:

1. Choose the Cutlines > Build. The Cutlines creation parameters window opens.
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i .
&% Cutlines creation parameters ﬁ

Main parameters Advanced parameters

Lzeful areas
i) Motuse () Use @ Build and use

-

Useful areas offset (+/-): 0.00 = m

Clouds/Invisible areas

@ Motuse () Use () Build and use

Attribute name: image_name Chedk doudsjinvisible areas
Method
@ Fast (Voronoi diagram) ) Detailed ) Images scheme

Maximal shift from Voronoi diagram
0.0 M
Method parameters
[] Exdude completely overlapping images

4k

Pyramid level 2

4k

The maximum share of the area of the region 0.001

-

Thin out predsion 0.000 = M

Use central points

(") Images centers @ Madir points

Create cutlines not doser than  48.00000 %1 m from useful areas edge
[7] centers of images without background

[ QK l [Dish’ibuted pmcessing...] [ Cancel

Fig. 21. Parameters of automatic cutlines creation
2. In the Useful areas section choose one of the following options of using useful
areas during cutlines creation:

* Not use — allows to not use useful areas, when the background is absent on
source images;

+ Use —is used to use pre-created (automatically or manually) useful areas;

@ While creating cutlines considering useful areas it is not recommended to use orthoim-
ages with JPEG-compression.
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» Build and use (by default) — allows to calculate useful areas automatically and
use these areas for cutlines creation.

% Calculated useful areas don’t display in 2D-window and don’t save on the Useful areas
layer.

5 The Build and use mode is used by default if the assign automatically images back-
ground color was chosen.

3. [optional] In the Useful areas offset input field specify positive or negative value
of distance in meters to crop(-) or add (+) fields of working area, which is defined
by created useful areas.

5 The Useful areas offset value should be much less than the Maximal shift from Voronoy

diagram parameter’s value.

4. Inthe Clouds/Invisible areas section choose one of the following options of clouds
considering during cutlines creation:

* Not use (by default) — allows to not use cloudy areas;
» Use —is used to use pre-created (automatically or manually) cloudy areas;

* Build and use — allows to calculate clouds automatically and consider them
during cutlines building in automatic mode.

ﬁ Calculated cloudy areas don'’t display in 2D-window and don’t save on the Clouds/Invisible
areas layer.

5. In the Attribute name input field specify the attribute name of the Cutlines vector
layer, where the full path to the image is stored (by default, image name).

It is necessary to specify the attribute to perform automatic matching of the cutlines with
images prior to mosaics building, or for preview creation.

6. Check the Check clouds/invisible areas checkbox to exclude 'gaps’ in created
cloudy areas in output mosaic.

The main idea of clouds check is, that the system tries to use reference image to replace
a cloud (entirely or partially) if the reference image does not contain the cloud in this place,
otherwise, the cloud will stay on the output mosaic.

7. In the Method section choose one of the following methods of automatic cutlines
creation:
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10.

1.

» Fast (Voronoy diagram) — this method consists in splitting all the area of cutlines
creation into polygons based on proximity to nadir points or, if the latter are not
given, to image centers;

* Detailed — more ’fine’ algorithm for Voronoy diagram building, In this case edges
of Voronoiy’s diagram, belonging to two different images, are replaced by broken
lines, which provide optimal images joining.

o Maximal shift from Voronoi diagram — at zero value you will get Voronoy
diagram, if the value is one — maximal area is used for cutlines creation. This
algorithm allows to calculate estimation function on images. Cutlines are created
on lines in such a way, that maximal value of this function on them is minimal
among all possible lines (minimax method).

* Images scheme — is a process where installation of source images without a
background is used for the first approximation of constructing cuts.

[optional] To exclude completely overlapping images from processing when
creating cutlines, set the appropriate checkbox;

& Almost complete overlap of images can occur when working with data that have a high
degree of overlap and is due to the fact that when processing images, areas with a minimum
off-nadir angle are used whenever possible. If this checkbox is set, redundant images are
completely excluded from processing, what, in turn, helps to avoid unreasonably complicated
cutline configurations.

@ The redundancy of small cutlines may appear if, for some reason, only a small area of one
of the images is involved in processing. Such a situation may affect negatively the quality
of the output mosaic. The maximum share of the area of the region input field is to exclude

such images from processing, thereby optimizing the number of created cutlines

[optional] The system allows you to choose the project image pyramid level to be
used during cutline creation. Constructing cutlines using less detailed versions of
images can significantly increase the system’s performance (due to a noticeable
decrease in the quality of constructing cutlines, which occurs with a high degree of
probability);

[optional] Specify the Thin out precision the appropriate input field;

& At first, cutlines are created with sub-pixel accuracy (taking into account the pyramid level
of images the user selected for cutline construction; see above). Further, the vertices of
overdetailed cutlines are thinned out. The Thin-Out Precision is the maximum distance
(a perpendicular) from the initial cutline fragment to the unit segment of the output polygon
that approximates it (in the current project units of measurement).

In the Use central points section define location of images centers which are used
for Voronoy diagram creation:
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* Nadir points (recommended if any);

* Images centers considering or not images background.

7

background when use centers of images.

The Centers of images without background checkbox allows not to consider images

12. [optional] In the Create cutlines not closer than [ ] m from useful areas edge
input field specify minimal distance in meters from working area boundary to create

cutlines, if source images have small overlap.

13. [optional] Open the Advanced parameters tab to set the parameters of the detailed

algorithm (see above).

-
@ Cutlines creation parameters

S=)

| Main parameters Advanced parameters

.......

Ok

] lDish’ibuted prucessing...] I Cancel

Fig. 22. Detailed method cutline creation parameters

Setup the following additional parameters:

+ Weight of objects outlines — allows to avoid separate objects (houses) during
cutlines creation or to cross them at the right angle (in case of roads);

+ Weight of images heterogeneity — allows to avoid small cities and settlements
during cutlines creation, including also urban blocks, since at certain pixel size
settlements look more heterogeneous, comparing with forested areas, agricultural

fields, etc;

+ Weight of images correlation — the bigger the differences in vicinity of pointon
adjacent images, the bigger this component for each point;

47



PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

+ Weight of images brightness — is used for cutlines creation in darkened areas
of images, where human eye is less receptive to images inconsistency;

* [optional] The Use DEM checkbox allows us to take into account the terrain relief
when creating cutlines (if available).

o DEM weight — the greater the weight of the DEM, the better the cutlines wrap
around the objects displayed on DEM.

@ It is recommended to be used for the imagery of highlands for creating cutlines taking
into account lowlands, but not mountain peaks. It is also recommended in case of
presence of buildings in the imagery to create cutlines between houses (if the buildings

are displayed on DEM).

14. Click OK to start process of cutlines creation.
To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The Cutlines distributed processing
window opens.

4% Maximum number of parallel tasks |i|éj

Distributed processing settings

n -
7] -

K ] | Cancel

L A

Fig. 23. Cutlines distributed processing parameters
3. Define the maximum number of parallel tasks — the tasks number on which
the process of cutlines creation will be divided.
4. Click OK to create distributed processing tasks.

The vector polygons are created in the Cutlines layer after the process completion.
Created cutlines are displayed in the Preview window.

15. [optional] if necessary, edit parameters and start automatic procedure of cutlines
creation and/or edit cutlines manually considering recommendations to cutlines
creations.
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16. Choose the Cutlines » Save to save the created cutlines in the x-data files of the
active profile resources.

Choose the Vectors » Export to export the cutlines into other formats (see the
Vectorization User Manual).

8.6. Editing cutlines
The following options are provided for cutlines editing:

» to delete all cutlines, i.e all vector objects from the Cutlines layer, choose the Cut-
lines > Clear;

+ to edit cutlines manually is used the standard tools of Vectors menu (see the “Vector

objects editing”, “Topological operations” and “Co-editing topologically connected
vector objects” chapters in “Vectorization” User Manual);

5 If new cutline creates manually it is assigned that image, the center of which is the closest

to the created cutline.

» the Vectors > Topology > Verify topology menu item is used for verify topology (see
the "Vectorization’ User Manual);

+ to create a cutline inside an existing cutline are used modes which could be switched
on the Cutlines type additional toolbar.

The buttons of the Cutlines types additional toolbar are used to choose the type of
cutlines:

o Image — to use main image in cutline area;

o [#] Transparent with reference image — to use reference image in cutline area
(by default it is supposed to use a nearby image into the cutline area);

o [¥] Background — to use the output mosaic background color in cutline area, which
sets in the Parameters window (see the Section 13.2);

@ The system also enables using background color beyond cutlines of the Background
type. To do this, set the Fill background color outside “Background” cutlines checkbox
in the Geomosaic tab in the Settings window (Service » Settings).

o ] Transparent without filling — to use transparent without filling in cutline area.

+ the Cutlines > Split cutline into sheets menu item allows to split cutlines into poly-
gons by sheets’ borders. Polygons are saved in a new vector layer and contain all
citline’s attributes.
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7

To use this function it is required to create or load into project both cutlines and sheets.

* The Cutlines » Check cutlines menu item is used for checking correspondents
between cutlines and images of a project in order to find images without cutlines
and/or cutlines which are not attached to images or to remove images.

When the check is complete, an appropriate info message is issued that displays the
number of images without cutlines and the number of cutlines not associated with
images. If any are detected, after the above information window is closed by the user,
the Preview window automatically opens, where, in the Cutlines layer, the system
will highlight all detected cutlines that are not associated with images.

7

For easier search of cutlines not associated with images in the Preview window, make the
Cutlines layer active and, without deselecting the automatically selected objects in this layer,
select Windows > Objects list.

In the Objects list window that opens, set the Only selected checkbox and click [4]. As a
result, the Objects list window will display the list of found cutlines that are not associated
with images. Clicking the left mouse button on the appropriate line in the table in the Objects
list window allows you to move the cursor in the 2D window to the area of the appropriate
cutline.

» Cutlines » Replace current node by new cutline — to create a new cutline as a
small rectangle polygon in the place of the node (the point where three or more cutlines
converge). This polygon can be further edited by the user.

7

If the vertices of adjacent cutlines located next to a node vertex are too close to it, then when
user tries to replace current node by new cutline, the appropriate error message is dis-
played: Inserting cutline is too small. If this system message appears, manually delete the
vertices closest to the node and try to repeat this operation by clicking the % button in the
main toolbar.

8.6.1. Including regions into cutlines mode

The system provides for quick manual cutline editing. The feature of this method is that
there is no need for manual editing (including, removing, or moving) of each vertex of
a cutline under processing. The system allows the user to quickly specify the desired
shape of edited cutlines, after which it automatically rebuilds these objects.

The main scope of this tool is to change the configurations of adjoining segments of
adjacent cutlines. Such a need may arise, for example, if adjoining segments of cutlines
(built automatically) intersect any one-piece object (for example, a building) in project
images. In this case, it would be most practical to merge the “boundary” created by
cutlines with the boundaries of the object itself, thus leaving it within a single cutline.

For this, perform the following:
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1. Make the Cutlines layer active;

(or choose Cutlines » Include regions into cutlines);

3. Choose Window » Toolbars » Tools;

4. Click n the Tools bar that opens;

5. Create a freeform polygon by holding down the Shift key, sequentially moving the
cursor in the 2D window work area, and clicking the left mouse button. The created
polygon must meet the following conditions:

* The first polygon vertex is to be within the so-called parent cutline, whose
boundaries are supposed to be expanded by changing the configuration of adja-
cent segments;

» The polygon must intersect the editable “boundary”, covering areas of at least
two vector polygons created by the editable cutlines.

The created polygon is visually displayed using black boundaries and a dark fill.
To complete the creation of a polygon, set the last vertex of the polygon by double-
clicking the left mouse button. Press Esc to delete the last created vertex. After
completing the creation of the polygon that defines the new cutline shape, the edited
cutlines are automatically rebuilt.

Fig. 24. Creating a polygon that defines the nature of changes in the configuration of adjacent
segments of neighboring cutlines

@ Cutline rebuilding operations can be cancelled using the Undo Log (see “Undo editing
operations” in the “Vectorization” User Manual).

@ For this operation, the rectangular marquee tool can also be used (the utton in the

Tools bar).
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The above guide and the illustration describe the most obvious common use of this
tool. When editing more than two cutlines (or cutlines with a more complex initial shape)
using this tool, note the following:

» The results of the operation depend on the number of cutlines involved, their initial
relative position, as well as on the shape and size of the polygon that determines
their new configuration;

* In any case, the change in the mutual configuration of the cutlines is carried out by
increasing the “parent” cutline, which, in turn, is determined by the location of the first
vertex of the polygon created in the Include regions into cutlines mode;

« Small cutlines that are completely covered by a user-created polygon (i.e., falling
entirely within the “expanding” cutline) will be “absorbed” by this cutline (deleted).

8.6.2. Intersection of polygons with the same name

The system provides for creating a polygon that describes the area of intersection of
two other polygons located in different layers and having the same values of the selected
attribute.

For this, perform the following:

1. Create or load two layers with vector polygons (cutlines). The layers must contain
intersecting 2D polygons having the same attributes (the same names and equal
values);

2. Make one of those layers editable;

3. Choose Vectors » Attributes > Intersection of corresponding polygons. The
Layers selection window opens:

& Layers selection I,iE-J

Clouds/Invisible areas

Useful areas

Miscellaneous

Cutlines (cores_test_cutlines)

Ground control and tie points (cores_test_tiepoints)

Attribute name: image_title|

| K || Cancel |

Fig. 25. The Layers selection window

4. Select the second layer that contains the above polygons;
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5. Enter polygon attribute name;

6. Click OK. After the operation is complete, an info message on the number of objects
created in the new vector layer appears.

The polygons created describe the areas of intersection of parent polygons from
different layers. They are also assigned the attribute of the parent objects used
during the operation.

8.7. Cutlines attributes

The attributes of the Cutlines layer extend the capabilities of editing cutlines. Basing
on the attributes, the cutline gets the name and type (see also the “Vector objects attrib-
utes” chapter of the “Vectorization” User Manual).

In the case, where the imported objects have another attributes, the capability of setting
attributes provides the correct import of cutlines, created in third party software.

By default, the Cutlines layer has following attributes used to store information about
cutlines:

* image — attribute for full path to image file;

* image_title — attribute for cutline name (equal to image name — source or reference
image);

* rgn_type — the cutline type attribute;
» ref_image_name — the filename of reference image attribute, used in the cutline area.
For editing the Cutlines layer attributes perform the following:

1. Choose the Cutlines » Parameters. The Cutlines parameters window opens.

4% Cutlines parameters [-Zhj

Attribute with cutlines name

|image_name - | [ ]

Reference by image name only

| QK | | Cancel |

e A

Fig. 26. Cutlines parameters
The default attribute name is displayed in the Attribute with cutlines name list.

2. To edit attribute choose attribute name from the list or click the _ ... | button to add
new attribute. Input the name of new attribute and click OK.
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3. [optional] Set on the Reference by image name only checkbox to comparison
cutlines only by image name, not by path.

@ To set these parameters for a single cutline, select the required cutline and open the Cutline

info window (see Section 8.8). To disregard the image path and refer the cutline by image
name only, set the Name only checkbox in the Cutline info window.

@ Editing of vector layer attributes, including editing of attribute name and attribute deleting

are used in cutlines import. Choose the Vectors > Export to export the cutlines into other
formats (see Vectorization User Manual).

c It is strongly discouraged to create projects with non-unique image names. If there are

images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines

Perform the following actions to view and edit attributes of the Cutlines layer and attrib-
utes values of selected cutline:

1. Select a cutline in the Preview window.

2. Choose the Window > Object attributes or click the |} button of the Vectors ad-
ditional toolbar. The Object attributes window opens.

[ # Object attributes i |
COEBEE 28

Marme Value
"image_name" phres:;/TechSupportTests/GeoMosaicTest/NewZealand_BADL/668 tif
"image_title" 668

Fig. 27. Cutlines attributes

The following buttons are used to create and edit attributes table:

I} — allows to delete all attributes of selected objects;
[ — allows to delete common attributes of selected objects;

[ — allows to open the Add attribute window to define name, type and value
of attribute;

=2 — allows to delete current field of attribute table;

E& — allows to open the Edit attribute window to edit parameters of selected at-
tribute;

o — allows to sort attributes of selected objects;
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« 2] — allows to invert attributes of selected objects.
Attributes may have the following values:
« for image — full path to main image file;

 for image_title — cutline name (is automatically generated from name of file with
source image);

 for rgn_type — cutline type:
o 1- complies to the Image type;
o 2 — complies to the Transparent from reference image type;
o 3 — complies to the Background type;
o 4 — complies to the Transparent without filling type.

« for ref_image_name — full path to reference image file, providing that the cutline
type is the Transparent from reference image, i.e.rgn_type = 2.

3. Double-click the string of the Value input field and insert another value for changing
of attributes value.

4. Press Enter to save or press Esc to cancel.

8.8. Cutlines info

To view and change information about several cutlines perform the following:
1. Make the Cutlines layer active.

2. Select a cutline in the Preview windows.

3. Choose Cutlines > Cutline properties. The Cutline info window opens.

# Cutline info ot S
Main image: |668 - D E

|
Cutline type: |Image - |

SIEIE

Source image:

| Mame anly

[ Apply l | Close |

Fig. 28. The information about cutline
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4. In the Main image field (corresponds to the image attribute value) shows full path
to file of main image, for which the cutline was created. To edit the field value open
the list and select another image of the project.

@ To return to current main image click the & button. To clear the list click the [ button.

5. Choose one of the Cutline type from the list corresponds to the rgn_type attribute
value):

» Image to use main image in area of cutline;

» Transparent from reference image to use reference image (fallen into cutline
area) in area of cutline specified in the Source image field;

» Background to color the cutline area with output mosaic background color (see
Section 13.2.2), that is used for coloring of any terrain objects on images;

+ Transparent without filling to apply transparency to the cutline area.

@ To clear the list click the [ button.

6. [optional] In the Source image (corresponds to the ref_image name attribute value)
shows full path to file of reference image (fallen into cutline area), if the image is
used for the cutline with the Transparent from reference image type. In order to
select a reference image use a list of project images.

% To clear the list click the [ button.

7. [optional] To use only the image name (without considering the full path to the image)
for referring the image to the cutline, set the Name only checkbox..

é To refer all project cutlines by image name only, set the Reference by image name only
checkbox in the Cutline attributes window (see Section 8.7).

é The need to consider only the image name may arise, for example, when project images
are partially replaced by copies with the same names located in a different folder (see
Section 7.10).

ﬁ It is strongly discouraged to create projects with non-unique image names. If there are

images with duplicate names in the project, it is strongly recommended to use only full
paths to images for referring to cutlines.

8. Click the Apply button to apply changes.
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8.9. Using external vector polygons

The system provides for using cutlines of image type (EZ], see Section 8.6) created in
third-party programs. GeoMosaic can attach third-party vector polygons that have no
attributes to project’s images according to their geometric location for further use as
cutlines.

For this, perform the following:

1. Import third-party cutlines into the PHOTOMOD resource system (see “Import of
vector objects” in the “Vectorization” User Manual);

é Imported vector objects are to be polygons.

2. Load these objects as cutlines from *.x-data file in the active profile resources
(see Section 8);

3. Choose Cutlines > Attach cutlines to images;

4. After operation completion, check the values of these objects’ attributes (see Sec-
tion 8.7);

5. Save data.

9. Brightness adjustment

The system allows to adjust brightness and contrast features of cutlines areas during
their merging (the global and local brightness adjustment of output mosaic) and options
of smoothing areas along cutlines, to create uninterrupted mosaic image.

To do so, the Brightness adjustment tab of the Mosaic settings window is used.

Q Global brightness adjustment means transformation equally applied to all pixels of each source
image (see Section 9.1).

Local brightness adjustment is a transformation applied along cutlines of images that are merged
into mosaic with a smoothing going down to the image central point and mosaic edges. Pro-
cessing of each pixel during the local brightness adjustment depends on its coordinates (see
Section 9.2).

To perform the brightness adjustment of output mosaic do the following:
1. Select Mosaic » Parameters. The Mosaic parameters window opens;
2. In Mosaic parameters window open the Brightness adjustment tab;

3. [optional] set the global brightness adjustment parameters;
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[optional] set the local brightness adjustment parameters;

[optional] set the general parameters of brightness adjustment;

[optional] set the parameters of smoothing areas along cutlines;

Click OK to save all the parameters set in the Brightness adjustment tab;

Select Mosaic » Brightness adjustment or click the [ button on the main toolbar
to rebuild brightness adjustment for all block scheme.

If after cutlines editing you need to rebuild brightness adjustment, choose the Mosaic »
Brightness adjustment.

In case of large data volumes it is recommended to use distributed processing. Perform
the following actions to rebuild brightness adjustment using distributed processing:

1.

Set the brightness adjustment parameters in the Brightness adjustment tab of
the Mosaic settings window and click OK;

Click the button on the main toolbar;

Change settings and run the distributed processing server/client (see the 'Distributed
processing chapter in the ’General information about system’ User Manual).

Choose Mosaic > Distributed global brightness adjustment. The Brightness
adjustment distributed processing window opens.

#¥ Brightness adjustment distributed processing lé,l

Mumber of images in project: 16

Max. number of simultaneous tasks 4 =

Temporary folder for distributed processing:

fprojects-hddftmp |:,
[ QK ]| Cancel |

L8 -

Fig. 29. Brightness adjustment distributed processing parameters
The total Number of images in project displays in the window.

Specify Number of tasks for processing, which are processed by one computer.

§ It is recommended to set quantity of tasks in proportion to quantity of used cores, but not
more than 25 tasks.

Select the Temporary folder for distributed processing in the resources of active
profile for temporary data storing.
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7. Click OK. Distributed processing tasks are created and the system shows a message
about number of created tasks.

8. After the end of distributed processing click the = button on the main toolbar to
reopen the mosaic project from active profile resources.

To clear all data about brightness adjustment choose Mosaic » Clear brightness ad-
justment.

c The system does not allows for mosaic brightness adjustment when building a mosaic in the
distributed processing mode (EH), nor in the mode of MegaTIFF distributed processing ().
Herewith, brightness adjustment can be a part of the process of mosaic building in the normal

course ().

Building a mosaic in the distributed processing mode () is available either for projects with
previously performed brightness adjustment, or if brightness adjustment is disabled when setting
mosaic parameters (i.e. brightness adjustment is not included in the list of tasks to be executed
when building a mosaic in the distributed processing mode). Otherwise the system gives the
following warning:

(4% Waming [ |

Brightness adjustrment was not performed. Either perform brightness adjustment

! and save the project, or disable this option in the project (the "Meosaic
parameters” window, the "Brightness adjustrment” tab, the "Global adjustrment”
and "Local adjustment” sections).

Fig. 30. A warning when starting distributed processing
In case of this warning, to start distributed processing, perform the following:
+ [optional] make brightness adjustment previously and save the project (Ig);
+ [optional] disable brightness adjustment previously in the Mosaic parameters window:

o In the Mosaic parameters window, Brightness adjustment tab, Global adjustment
section, choose None;

o Inthe Mosaic parameters window, Brightness adjustment tab, Local adjustment section,
clear the On checkbox.
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9.1. Brightness adjustment parameters

A Mosaic parameters L )

Mosaic | Brightness adjustment | Save | Ties | Misc |
Use brightness pre-correction

Global adjustment

) Mone
") By average brightness
) By project image

(7} By image file
with background color =
Match histogram

@ By overlapped areas B

Local adjustment

on

General brightness adjustment parameters
Brightness adjustment cell size: 32 | pix
[7] Do not use exduded areas for global adjustment

+ 0O (&

[7] Do not use exduded areas for local adjustment

7] Use invisible areas
[T] additional check for black backaground
[ Local adjustment of active sheets

[T seams feathering

Smooth parameters
Smooth aperture size: |32 | pix
Consider image edges when use feathering

Smoothing with round aperture

’ OK l [ Cancel

Fig. 31. Brightness adjustment parameters

The Use brightness pre-correction checkbox allows to consider preliminary BCG-
correction of source images while output mosaic is created.

ﬁ Brightness pre-correction does not consider in case of any method except None was chosen
in the Global adjustment section.
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7

It is recommended to set on the Use brightness pre-correction checkbox if there are a lot of
cloud areas on scanner images.

In the Global brightness adjustment section choose the way of the brightness adjust-
ment for all block:

* None - allows to use images without adjustment;

» By average brightness — allows to apply brightness adjustment using average images
brightness;

7

<

At that brightness and contrast of all images are set to values, found using averaging of
brightness and contrast values calculated over all mosaic images. This method is recommen-
ded when there are big differences between brightness’ of images, but each of them contains
relatively smooth scenes.

It should be noted that in case of scenes with sharp different brightness within one image
(for example ’sea’ and ’'coast’) this method may produce incorrect brightness adjustment
results.

* By project image — allows to apply global adjustment by project image: histograms
of mosaic images are corrected in accordance with chosen project (‘reference’) image.
To select the reference image is used the _... | button;

7

7

It is recommended to use image located in the middle of images block as a reference. It is
not recommended to use this method in case of abnormal local brightness fluctuations
('trends’) on images, since in this case you can face a problem of smooth increasing or redu-
cing of the brightness and contrast from the reference image to the block edges right up to
complete 'lightening’ ('blackening’).

The system allows to adjust brightness by several reference images (located in different parts
of the mosaic) what can be useful when processing projects containing large number of im-
ages.

To select the reference image is used the [} button in Images list window. For correct
brightness adjustment using one or more reference images selected in the Images list window,
select the By average brightness adjustment in the Global adjustment section.

» By image file — allows to apply global brightness adjustment using brightness from
chosen file. Histograms of mosaic images are corrected in accordance with chosen
image file. To load image is used the _.. | button.

7

The EE button serves for background color transparency setting for the selected image. For
example, if the image background is black, it is required to select black color in the opened
Color window. The [&] button allows to clear background color transparency settings for the
selected image.

* By overlapped areas — allows to apply global brightness adjustment by overlapping
images. To set the adjustment parameters, use the _... | button.
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& Parameters L&J

Brightness adjustment parameters

| Use statistic of overlapped areas with weight: 1,00

Al ([l

| Use statistic of entire images with weight: 0,50

Brightness fixation parameters
| Fix average brightness
| Fix outline images with weight: 5,00

o[ (4l

Fix etalon images with weight: |5.0p

Etalon images

FED
[44]

| Show image titles

| OK | | Cancel |

Fig. 32. Brightness adjustment parameters (by overlapped areas)

o Use statistic of overlapped areas with weight — allows to take into account (with
preassigned weight) brightness of the images’ overlapping areas during global
brightness adjustment;

o Use statistic of entire images with weight — allows to take into account (with
preassigned weight) brightness of every entire image during global brightness ad-
justment;

@ If the images’ brightness in a block significantly differ, it is recommended to set a small
value.

o Fix average brightness — allows to save average brightness of images in block
after global brightness adjustment;

o Fix outline images with weight — allows to save (with preassigned weight)
brightness of images on the block borders;

o Fix etalon images with weight — allows to save (with preassigned weight)
brightness of reference (etalon) images;

The Match histogram checkbox allows to apply full (non-linear) brightness adjustment
with histogram matching. Otherwise only mean of distribution and standard deviation
are matched.
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Set the On checkbox in the Local adjustment to apply local brightness adjustment
along cutlines of images that are merged into mosaic. If you would like to specify local
brightness adjustment parameters click the Parameters button (see Section 9.2).

Also set up the following general brightness adjustment parameters:

* Brightness adjustment cell size — allows to specify a size of a cell (in pixels), which
is used for brightness estimation and correction;

* Do not use excluded areas for global adjustment — allows to apply global adjust-
ment in mosaic areas, defined by vector polygon’s edges;

7

Vector polygons should be stored in file in active profile resources. The + button allows to
open file with polygons. The _.. | button allows to choose another file, instead the opened.
The = button allows to remove the selected file from the list. The [ button allows to remove
all the files from the appropriate list. The £ button allows to display the selected layer of
vector polygons in both the Layers Manager and in a 2D window.

* Do not use excluded areas for local adjustment — allows to apply global adjustment
in mosaic areas, defined by vector polygon’s edges;

7

Vector polygons should be stored in file in active profile resources. The + button allows to
open file with polygons. The _.. | button allows to choose another file, instead the opened.
The = button allows to remove the selected file from the list. The [ button allows to remove
all the files from the appropriate list. The £5 button allows to display the selected layer of
vector polygons in both the Layers Manager and in a 2D window.

* Use clouds — allows to consider areas with clouds in brightness adjustment;

+ The Additional check for black background checkbox allows to make the areas
of source imagery with black background transparent in the output mosaic;

7

Due to the peculiarities of preprocessing, some satellite images can have two background
colors at the same time (black and the second one is arbitrary), which must be taken into
account during processing. For correct processing of such images (to take into account the
black background color), set the Additional check for black background checkbox.

To take into account the arbitrary background color of source images, choose the Images »
Project images list or click the f& button on the main toolbar. The Images list window
opens. Select the images to define the images background color and click the Bl button (see
detailed description in Section 7.5).

* The Local adjustment of active sheets checkbox allows to apply brightness adjust-
ment only to images, located on active mosaic sheets.

7

Set this checkbox on only if distributed processing without saving adjustment parameters
was performed. In this case number of tasks should be equal to number of active sheets.
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For seams feathering set on the appropriate checkbox and define the following para-
meters in the Smooth parameters section:

* Smooth aperture size — allows to define the size of smoothing zone along cutlines;

+ Consider image edges when use feathering — allows to smooth seams on the
edges of images block, where may be no statistics enough for correct smoothing.

+ Smoothing with round aperture — allows to turn on the mode of pixel-by-pixel
smoothing along cutlines.

“ Using this function results in increasing of time required for rebuilding brightness adjustment.

? Set this checkbox if the results of smoothing along cutlines are not satisfactory, especially in
case of the presence of large water-tables in the project.

Fig. 33. Smoothing with round aperture is not applied to the area (water-table) (left) and smoothing
with round aperture is applied to the area (right)

9.2. Local brightness adjustment parameters

Local brightness adjustment is a transformation applied along cutlines of images that
are merged into mosaic with a smoothing going down to the image central point and
mosaic edges. Thus during local brightness adjustment each pixel of the image is pro-
cessed depending on its coordinates. At that the program performs simultaneous change
of brightness (additive component) and contrast (multiplicative component) of initial
images.

For preliminary estimation of local brightness adjustment choose the Misc > Local ad-
justment. In the Preview window you will see a grid of fragments (rectangles), used
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for statistics collection for local brightness adjustment. The fragments are vector objects
located on the Miscellaneous layer.

? The brightness adjustment rebuilding (fg3) should be already performed. The On checkbox must
set beforehand (the Local adjustment section in the Brightness adjustment tab of the Mosaic
parameters window).

Rectangles have the following colors depending on area, which is used for statistic ac-
quisition:

* green — to obtain statistic between images;

* blue — to obtain statistic between strips;

* red — to obtain statistic on mosaic edges;

+ yellow — to obtain statistic inside of separate images.

The program provides possibility to edit grid of fragments as vector objects on the
Miscellaneous layer (see the “Vectorization” User Manual).

1: 1:14 11: 1:128 Preview

11: 1:128 Preview 8 x

@t e @EIAQERE Qe o o EEe s BRHUNMA D R ) s EEE M EE

[Basic | mavi |
+1+3 2 AEHES
- Marker

% # [ © Shects (cores_test_sheets)

[] = Ground control and tie paints (cores test tiepoints)
O » Cutlines (cores_test_cutlines)
[ » Miscellaneous
] & useful areas
O » Clouds/Invisible areas [R/0]
Raster

LR RCE R

R 0 D 0 [=[==] @le[a &

[2521202.850000 v; 6584057.850000 ; 0.000000 1 (NULL) [ Bexaprosa npasas

Fig. 34. Preliminary estimation of local brightness adjustment

To set the parameters local brightness adjustment you should perform the following:
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1.

Choose the Mosaic » Parameters. The Mosaic parameters window opens.

2. Click the Brightness adjustment tab. In the Local adjustment section set the On

checkbox and then click the Parameters button. The Local adjustment parameters
window opens.

& Local adjustment parameters I,-ghj

Mumber of fragments Inner points

32 = 1 =
Contrast coefficent Density coeffident

3 - 2 -

Search additional fragments with 50% overlapping

Minimal valid partin fragment: 33 = %

[ oK ] | Cancel

Fig. 35. Local brightness adjustment parameters

Define images Number of fragments used to create a model of local brightness
adjustment.

@ In case of color difference inside one fragment in nearby images inconspicuous or homo-
geneous along the cutline, only one fragment is enough to collect statistics.

In case of color difference inside one fragment between images remarkable or heterogen-
eous, it is necessary to increase number of fragments to consider brightness change.

é In case of increasing number of fragments, number of pixels in each fragment hold constant.
In this case image from one layer of pyramid is used for brightness adjustment. In case of
increasing number of fragments, brightness adjustment perform more precise, but slower.

Set the Inner points — number of points inside image and on mosaic edges, where
brightness should not be changed.

é Insufficient quantity of these points leads to creation brightness artefacts while distance
from cutlines. Quantity over leads to unacceptable results of local brightness adjustment
along cutlines.

[optional] If errors in contrast of source images leads to not enough adjustments
quality or to errors in local brightness adjustment, increase the Contrast coefficient
value from 2 to 7 for better results.

Set the Density coefficient — a thinning ratio for the grid of fragments (rectangles)
on mosaic edges (marked red in the illustration above).
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The thinning ratio in the picture is equal to one (the fragment grid is not thinned). The re-
commended Density coefficient value is 2.

7. [optional] In case if not enough statistic data for local brightness adjustment, program
provides possibility shift of fragment’s grid relative to cutlines. For this set on the
Search additional fragments with 50% overlapping checkbox.

8. [for scanner images with small overlaps] In case of small overlaps, cutline could be
located too close to edge of image, so image background is include to cutline area.
In this case set the Minimal valid part in fragment — minimal part of image in
fragment, when statistics data is collected.

9. Click OK.

1: 1:14 12: 1:16 Preview
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O » Clouds/Invisible areas [R/0]
Raster
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Fig. 36. Area without local adjustment
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Fig. 37. Area with local adjustment

9.3. Dodging

Dodging — means brightness adjustment of the single image.
To employ this function you should perform the following:

1. Select Images > Project images list... or click & button. The Image List window
opens.

2. Select the image you need to transform in Image List window and click the
button. The Radiometric correction window opens.

3. Click the I button in Radiometric correction window. The Filters menu opens.
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F I
& Filters 5
Filter type: |Dodging v|
Aperture size |3x3 hd |

Filtering level (0-100%%)
| Cut background
Background color: 0 5
Tolerance: [
On fly
[ QK ] | Cancel | | Apply

Fig. 38. The filters menu

4. Choose the Dodging filter, set aperture size and filtering level.

% Recommended filtering level — 100%.

5. [optional] By default the Cut background checkbox is set. This function allows not
to take into account the background on image edges during the correction. To ex-
clude background parts from the correction, set the following parameters:

+ Background color — value of background color;

% If the O value is set in the Background color field, background also will be changed
during the correction.

» Tolerance — deviation from background color value.

6. Click OK.
10. GCltie points
10.1. GC/Tie points menu

The GCltie points menu items, that are partially duplicated by the GC/tie points toolbar
buttons, are used to measure ground control/tie points.

§ The Ties tab of the Mosaic parameters window purposes to setup options of using ground
control and tie points for adjustment.
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Table 10. Brief description of the GC/Tie points menu

Menu items Function
“4 Clear to delete all tie/gc points from Ground control and
tie points layer
4 Open to open tie/gc points previously saved in vector file
with *.x-data extension in active profile resources
‘i Save to save tie/gc points to vector file in active profile
resources with the same name and *. x-data exten-
sion
1 Save as to save tie/gc points to vector file in active profile

resources with different name and *.x-data exten-
sion

Add ground control points

opens sub-menu for measurement of GCP in
manual, semi-automatic and automatic modes

Add tie points

opens sub-menu for measurement of tie points in
manual, semi-automatic and automatic modes

A Remeasure

to edit a measurement of selected tie/gc point

B3, Show windows by marker

opens 2D-windows with initial images, which contain
marker position

BE. Show windows by current point

opens 2D-windows with initial images, which contain
selected tie point

¥ Finish measurement

to close the 2D-windows with the source images
and return to the Preview window for viewing the
results of cutlines stitching by measured points

15 Show residuals

to display residuals reveals 'bad’ points, having error
vectors noticeably different from other points in size
and direction

Create attributes with residuals

to create the residual tie attribute having a value
equal to a residual at this tie point

it Delete by maximal residual

to remove blunders of tie/gc points automatic
measurement: allows to reject those points, which
measurement value results in shift of images relat-
ively each other at distance more than specified (in
meters)

i3 Parameters

to setup correlator parameters used for tie/gc points
measurement in semi-automatic or automatic mode

Information about a point

shows brief information about selected tie/gc point

10.2. Brief description of the GC/Tie points toolbar buttons

Table 11. Brief description of the GC/Tie points toolbar buttons

Buttons Function
& to measure ground control point in manual mode without correlator
k to measure ground point in semi-automatic mode using correlator
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Buttons Function

o to run automatic search and measurement of GCP on the whole images block using
correlator

& to measure tie point in manual mode without correlator

* to measure ground point in semi-automatic mode using correlator

i to start operation of tie points automatic search and measurement for the entire images
block using correlator

15, to display residuals reveals 'bad’ points, having error vectors noticeably different from
other points in size and direction

A to edit a measurement of selected tie/gc point

= to setup correlator parameters used for tie/gc points measurement in semi-automatic or
automatic mode

B8, opens 2D-windows with initial images, which contain marker position

BE_ opens 2D-windows with initial images, which contain selected tie point

i to remove selected tie/ground control points

i to remove blunders of tie/gc points automatic measurement: allows to reject those points,
which measurement value results in shift of images relatively each other at distance
more than specified (in meters)

i to remove all tie and ground control points

o to remove only ground control points

3 to remove only tie points

-1 to close the 2D-windows with the source images and return to the Preview window for
viewing the results of cutlines stitching by measured points

10.3. General information

The program provides an option of tie points measurement for more precise correspond-
ence of cutlines area. Adjustment of the project source images is the result of tie points
measurement and transforming source images close to cutline.

Measuring ties points consists in defining correspondence between projections of the
same terrain point on two or more source images of the mosaic project in the vicinity
of cutlines.

Also, the program provides the option of using reference image for measuring GCPs
on the source images.

The reference image is the raster image on the same area, but with more accurate
georeference, then source images of mosaic project. |.e the reference image is used
as standard for measuring GCPs, from which is defined the correspondence between
the source images. The coordinates of terrain point on the reference image is assigned
the same terrain point on the source images.

The Tie points vector layer with the attributes for data storing about measured points
is provided for storing the GCPs or tie points.
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The program provides three modes of tie/GCPs measurement:
* Manual mode measurement of points without correlator;
+ Semi-automatic mode measurement of points using correlator;

» Automatic mode measurement of points using correlator.
@ Itis not recommended to measure the tie points far away from the cutlines to avoid the rough

transformation of images. Also, it is not recommended measuring points on the extended
objects (for example, on the roads), buildings and low-contrast areas.

The correlator parameters are used for measurement ground control/tie points with
correlator in semi-automatic or automatic mode. The GC/tie points » Parameters menu
item us used to view and edit correlator parameters values (see Section 10.6).

In order to obtain the information about tie/ground control point, select the point on ed-
itable layer Ground control and tie points and choose the GC/Tie points > Point info.
In the opened Statistic information window you can see the following data:

* point’s name (with tie prefix for tie point, and GCP for GCP);
* number of images where the point is measured;

 path to file of each image where the point is measured.

- ™y
& Orthorectification statistics I,&J

Mame: tie_33

Images number: 2
phres:/TechSupportTests/GeoMosaicTest/NewZealand_BAD1 /677 tif
phres:/TechSupportTests/GeoMosaicTest/NewZ ealand_BAD1/676.tif

Fig. 39. Information about a point

10.4. Measurement of GCPs

For GCP measurement it is necessary define in advance a type of transformation which
will be applied automatically on edges of images block while GCP measurements are
accumulating. Perform the following actions to do this:

1. Choose the Mosaic » Parameters. The Mosaic parameters window opens.

2. Choose the Mosaic tab. Set on the Using of ground control points checkbox on
the Ties tab.

3. Inthe Images edges section select: No changing, 2D-Shift, Projective.
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4. [optional] Set on the Affected area checkbox to limit influence of ground control
point to adjustment and specify the value in meters.

% If the Affected area checkbox is set of, maximal distance of ground control point influence

is image border.

10.4.1. Adding reference image

In case there is an image (reference image) with more accurate georeferencing covering
the same area as source images, this reference image can be used for measuring of
ground control points on the source images.

To use georeferenced image perform the following actions:
1. Load georeferenced image into the project by one of the following ways:

» to load image located out of profile resources system, choose Service > Load
georeferenced images (files) or click the ] button on the main toolbar;

@ If there is a file of the *.rmc format in the same folder, the correction parameters are
downloaded for the selected image.

+ to load image located in active profile resources, choose Service > Load geore-
ferenced images (resource).

% If there is a file of the *. rmc format nearby the image file, the correction parameters are
downloaded for the selected image.

Define a georeferenced image and click OK. The Load georeferenced image
window opens.

2. [optional] Set the Convert coordinate system checkbox on, if the coordinate system
of project is differ from coordinate system of project. Define the source coordinate
system of image and output coordinate system in corresponding fields.

3. [optional] Set on the Transparent background to specify the background color of
source image.

4. Click OK. Image loaded to the mosaic project and in the Manager the new layer is
shown.

10.4.2. Addition ground control points in manual and semi-automatic
modes

Perform the follows for defining correspondence between the source images by control
point on reference image in manual or semi-automatic mode:
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1. Load reference image in the project.

2. Hide the layer with reference image in the Layer manager.

3. Make active the Ground control and tie points layer.

4. To add new ground control point perform the following:

1.

6.

7.

In the 2D-window with the source images insert the marker in the place of
adding point on the one of the images in the vicinity of cutline.

Choose the GC/Tie points » Show windows by current point or click the B,
button on the GC/Tie points toolbar;

Perform one of the following actions to add point:

» choose the GC/Tie points| Ground control points » Add without correlation
or click the & button of the GC/Tie points toolbar to add point manually;

» choose the GC/Tie points| Ground control points > Add with correlation
or click the ® button of the GC/Tie points toolbar to add point in semi-
automatic mode.

Turn on visibility of the layer with reference image.

% The Ground control and tie points layer should be upper than layer with georeferenced
image in the Manager to display added point.

Specify the point placement on the reference image corresponding selected
terrain point on the source images. For this move the point use the mouse and
pressed Ctrl key.

Press Enter to confirm measurement.

Hide the layer with reference image in the Layer manager.

5. Repeat the 4’s step to measure point on the neighbour image. Hence a tie point
creates on the source image with coordinates taken from the reference image. The
source images in the Preview window are refreshed taking into account the stitching
by added point.

10.4.3. Automatic searching of corresponding points

The program provides opportunity of search and add Ground Control points on the
reference and source mosaic project images in the automatic mode.
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For automatic searching of corresponding points on the reference image and source

images of mosaic project perform the following actions:

Choose Service » Grid » Create to create grid for the search of ground control

Create a work area of the grid (see the ’Creation of DTM’ User Manual).

1. Load reference image in the project.
2.
points area.
3.
4. Make active the layer with reference image.
5.

Choose the GC/Tie points » Ground control points » Add automatically or click
the am button on the GC/Tie points toolbar; The Points measurement parameters

window opens.

7

If the grid has not been previously created, it is requested to do it.

e

4% Points measurement parameters

==

Correlation parameters

4|k

Fragment size: 20,00 pix

4|k
=

Search area: 40,000

Caorrelation pixel size: 0.50

0 1

4|k

Max. auto-correlation: &.00

4|k

Min. correlation: 0,90

4|k

Min. fragment RMS: 2.00

Automatic search parameters

e

Distance between points:  40.000 ~| M

-

Random shift from cutline: 0,000 M
Delete all points with same type before searching
Search along selected cutlines

Skip from found point: 10 +| points

[ 0K l | Cancel

Fig. 40. Points measure parameters window

6. Set the correlator parameters.

7. Click OK to start searching process.
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10.5. Tie points measurement

For tie points measurement it is necessary define in advance a type of transformation
which will be applied automatically on edges of images block while tie points measure-
ments are accumulating. Perform the following actions to do this:

1. Choose the Mosaic » Parameters. The Mosaic parameters window opens.
2. Choose the Mosaic tab. Set on the Using of tie points checkbox on the Ties tab.
3. Inthe Images edges section select: No changing, 2D-Shift, Projective.

4. [optional] Set on the Affected area checkbox to limit influence of ground control
point to adjustment and specify the value in meters.

@ If the Affected area checkbox is set of, maximal distance of ground control point influence

is image border.

10.5.1. Manual mode measurement of tie points
Perform the following actions for measuring tie point in manual mode without correlator:

1. Create cutlines.

c A pre-requisite for measurement of tie points is the presence of cutlines created.

2. Select the point in the vicinity of cutlines in the Preview window set the marker in
this place to add the tie point.

3. Choose the GC/Tie points > Tie points » Add without correlation or click the "+
button on the GC/Tie points toolbar; The 2D-windows with source images are
opened. New tie point is added in the specified place.

4. Choose the GC/Tie points > Remeasure or click the & button on the GC/Tie points
toolbar.

ﬁ After the addition of at least one tie point the © . Using of tie points mode is set on auto-
matically.

5. For measuring the next point: select the another terrain point on the images in the
each of the 2D-windows and click the '# button on the GC/Tie points toolbar. A
new point is added as a result.

6. To complete of measuring tie points in 2D-windows and displaying of the stitching
results in the Preview window, choose the GC/Tie points » Finish measurement
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or click the F¥ button on the GC/Tie points toolbar. The areas stitching is performed
in the middle of the interval between points in the 2D-windows.

10.5.2. Semi-automatic mode measurement of tie points

The semi-automatic mode implies the automatic computing of tie points using correlator
in the marker placement.

@ It is recommended to set the Correlator parameters before the start working.

Perform the following actions for measuring of tie points in semi-automatic mode:

1. Create cutlines.

c A pre-requisite for measurement of tie points is the presence of cutlines created.

2. Select the terrain point in the vicinity of cutlines in the Preview window for adjustment
of stitching areas and set the marker in this place.

3. Add tie point in the manual mode.

4. Choose the GCITie points > Tie points > Add with correlation or click the '#
button on the GC/Tie points toolbar;

Tie point may be measured by correlation in one of the following ways:

* In case of successful correlation the tie point is added on the Ground control and
tie points layer. The images of the Preview window are refreshed taking into
account coinciding cutlines areas by the specified tie point.

% Correlation coefficient value is specified as an attribute of point.

» Select the another terrains point closer to the cutlines and repeat the 1st and 2nd
steps. The message about the point is far away from the cutlines is displayed.

» Change the corresponding correlation parameters, if the message about the low
correlation coefficient and/or about high autocorrelator coefficient is shown (see
Section 10.6) or select more contrast point on terrain and repeat the 1st and 2nd
steps.

% After the addition of at least one tie point the © . Using of tie points mode is set on auto-
matically.
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5.

[optional] Repeat the 1-2 steps for measuring new tie point or edit the point (see
Section 10.7).

Choose the GC/Tie points > Finish measurement or click the F¥ button on the
GC/Tie points toolbar; The areas stitching is performed in the middle of the interval
between points in the 2D-windows.
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Fig. 42. Stitching areas from two tie points
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10.5.3. Automatic mode measurement of points

The automatic mode implies the automatic searching of tie points using correlator on
all block images of project in the vicinity of cutlines.

Perform the following actions for measuring of tie points in automatic mode:
1. Create cutlines.

c A pre-requisite for measurement of tie points is the presence of cutlines created in the
Cutlines layer. Otherwise, the message about that cutlines must be created is shown. And
measuring of tie points is not possible.

2. Choose the GC/Tie points| Add tie points » Add automatically for start automatic
measuring of tie points or click the i button on the GC/Tie points toolbar; Points
measure parameters window opens.

( & Points measurement parameters Li:-?-r
Correlation parameters
Fragment size: 20.00 | pix
Search area: k40,000 =M
Correlation pixel size: 0.50
U
a 1

4|»

Max. auto-correlation: 8,00

Min. correlation: 0.90 =

¥

Min. fragment RMS: 2.00

Automatic search parameters

Distance between points: 40,000 ]

Random shift from cutline: 0.000 Hom
Delete all points with same type before searching

Search along selected cutlines

Skip from found point: 10 +| points

[ oK ] |Distributed processing...| | Cancel |

Fig. 43. Points measure parameters window

3. Set the correlator parameters.

4. Click OK to start searching process.

@ After points measurements the © . Using of tie points mode is set on automatically.
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Perform the following actions for measuring points in the vicinity of cutlines in the
distributed processing mode:

1.

Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the 'General information about system’ User
Manual).

Click the Distributed processing button. The Ties points distributed pro-
cessing windows opens.

@ Ties points distributed processing [-th

Mumber of images in project: 4

Max. number of simultaneous tasks 4 >
Temparary folder for distributed processing:

seyor [Zhukovsky-Movoselow/Ortho_Second/Data/Temp \:/
Output resource with tie points:

{Zhukowsky-Movoselov/Ortho_Second /Datafties. x-data )

[ QK ] | Cancel |

L8 4

Fig. 44. Parameters of distributed processing for measuring tie points

The Number of images in project displays number of created cutlines in the
mosaic project.

Set the maximum number of simultaneous tasks.

Define the temporary folder in the active profile resources for distributed pro-
cessing.

Define the output file name and path.

Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

Estimate the stitching quality of cutlines in the result of the automatic measuring of

tie points in the Preview window. If necessary, edit the measurement of added tie
points (see Section 10.7).

10.6. Parameters of points measurements

For measuring of tie/ground control points in semi-automatic and automatic mode you
can use and adjust the following correlator parameters.

For automatic mode you can use parameters for automatic points search in vicinity of

cutlines.
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Perform one of the following to setup parameters of points measurements:

« Choose the GC/Tie points » Remeasure or click the *% button on the GC/Tie points
toolbar.

* Choose the GC/Tie points| Add ground control points » Add automatically or
click the w1 button on the GC/Tie points toolbar.

* Choose the GC/Tie points| Add tie points » Add automatically for start automatic
measuring of tie points or click the s button on the GC/Tie points toolbar.

Correlation parameters

4k

Fragment size: 20.00 pix

Search area: k0,000 2w
Correlation pixel size: 0.5

0 1
Max. auto-correlation: 8,00 i
Min. correlation: 0.90 =

Min. fragment RMS: 2.00 =

Automatic search parameters

Yy

Distance between points: 40,000 = M

Random shift from cutline: 0.000 =M
Delete all points with same type before searching
Search along selected cutlines

Skip from found paint: 10 + points

Fig. 45. Points measure parameters

The Correlation parameters section allows to specify the following parameters of
points measure:

* Fragment size — allows to define a size (in pixels) of a fragment which contains the
point indicated on one image in vicinity of cutline;

+ Search area — allows to define a search area (in meters) of appropriate point on an-
other image;

+ Correlation pixel size — allows to define a value of a pixel size of images, where
correlation to be performed, if the images have different pixel size;

* Max. auto-correlation — allows to control auto-correlation of a point, i. e. a degree
of point’s uniqueness in some its vicinity on the left image;
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The more the auto-correlation radius value, the less the point’s uniqueness and the more
probable its incorrect comparison with the right image even when the correlation coefficient
is high.

* Min. correlation — allows to define minimal acceptable value of correlation coefficient;

* Min. fragment RMS - allows to define a brightness value of image fragment. The
less the value, the worse the correlation.

The Automatic search parameters section allows to set up the following parameters:

» Distance between points — allows to define a distance between points searching
along the cutline in the automatic mode;

* Random shift from cutline — allows to define acceptable deviation from cutline when
searching a point in automatic mode;

* Delete all points with same type before searching — allows to clear the Ground
control and tie points layer from GCP or tie points before start a search of points;

» Search along selected cutlines — allows to search points only along selected cutlines.
Set the checkbox off to search along all cutlines;

» Skip from found point — allows to skip set quantity of points from measured point.

10.7. Editing measurements of points

Perform the following actions for editing measurements of point:

1. Make editable the Ground control and tie points layer in the Layer manager.
2. Select a point in the Preview window by mouse clicking.

3. Choose the GC/Tie points > Show windows by current point or click the 88 button
on the GC/Tie points toolbar; They are showing the selected point. The 2D-windows
with source images are opened.

4. Insert the marker in another terrains point on the source images in each of the 2D-
windows.

5. Choose the GC/Tie points » Remeasure or click the & button on the GC/Tie points
toolbar; The tie point will move in new placement and show in the Preview window.

@ If not all images with marker position are opened, when clicking the & button, other windows
are opened automatically. To change point’s position click the & button once more.

@ The visual non-conformities of tie points are displayed in the 2D-windows on the source
images, because the points are displayed by the data of georeference.
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Perform the following actions to delete point:

the GC/Tie points » Ground control points > Delete menu item and the T button
of the GC/Tie points toolbar for deleting all ground control points;

the GC/Tie points > Tie points > Delete menu item and the i button of the GC/Tie
points toolbar for deleting all tie points;

the GC/Tie points » Clear menu item and the *[3 button of the GC/Tie points toolbar
for deleting all measuring points on the Ground control and tie points layer;

the Del key to remove the selected in the Preview window point;

the GC/Tie points| Delete by maximal residual menu item and the i button of the
GC/Tie points toolbar for rejection the points, the measurement of which causes the
noticeable shift of images relative to each other.

The Objects attributes window is used for viewing and editing tie points data from at-
tributes (see Section 10.8).

To view residuals vector of tie point’s position perform the following:

1.

Choose the GC/Tie points| Show residuals or click the I8 button on the GC/Tie
points toolbar;

Define the Scale to show vectors and click OK. Residuals are load to the Miscel-
laneous layer.

To display residuals vector perform one of the following:

+ select the tie point on image; choose GC/Tie points » Show windows by current
point or click the 8& button on the GC/Tie points toolbar;

+ insert the market near to point; choose the GC/Tie points » Show windows by
marker or click the 8, button on the GC/Tie points toolbar.

The 2D-windows of images with selected point are opens.

Analysis of error vectors reveals. 'Bad’ points have error vectors noticeably different
from other points in size and direction.

Move error point by vector direction to eliminate detected measurement errors and
choose GC/Tie points » Remeasure or click the A button on the GC/Tie points
toolbar; Tie points moves to the new position.

Repeat the 1st step to view edited residuals vectors.
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10.8. Attributes of Ground control and tie points layer

After tie/gc point measuring the information about measured point is saved to attributes
of the Ground control and tie points layer.

To view point’s attributes data perform the following actions:
1. Make the Ground control and tie points layer editable.
2. Select a point in the Preview window by mouse clicking.

3. Choose the Window > Object attributes or click the \I& button of the Vectors ad-
ditional toolbar. The Object attributes window is open.

( 4 Object attributes &J‘
DOEEE 3P

Mame Value

"tie_type" 0
"point_name" tie_34

"images_count” 2
"image_name_0" phres/TechSupportTests/GeoMosaicTest/MNewZealand_BAD1/677.tif

"image_x_0" 5472.502

"image_y_ 0" 3823.284

"OriginX" 2588108687

"Origin¥" 6584219.296

"image_name 1" phresy/TechSupportTests/GeoMosaicTest/MNewZealand_BAD1/676.tif
"image x 1" 3898.502

"image_y_ 1" 1976.284

"corr_coeff_1" 0924

Fig. 46. Point’s attributes data
Point’s attributes contain the following data:

* tie_type — contains information about type of point (with O value for tie point, and
1 for GCP);

* points_name — contains a name of point (with tie prefix for tie point, and GCP for
GCP);

* image_count — shows a number of images where the point is measured;

* image_name_image_number — contains a path to one of the image files where
the point is measured;

* image_x_image_number — contains X-coordinate of the point on one of the im-
ages;
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* image_y image_number — contains Y-coordinate of the point on one of the im-
ages;

* [for points found with correlator] corr_coeff — correlation coefficient of point.
11. Splitting into sheets

11.1. Sheets menu

The Sheets menu is used for splitting mosaic into sheets for saving their in the separate
files of selected output format. The sheets boundaries are the vector polygons in the
Sheets layer.

Items of the Sheets menu items are partly duplicate by buttons of the additional Sheets
toolbar.

Table 12. Brief description of Sheets menu and toolbar

Menu items Function
B Clear to delete the created sheets boundaries, i.e delete
all vector objects from the Sheets layer without
closing of this layer
=# Open to open sheets boundaries, which were been saved
in the vector file with the x-data extension in the
resources of active profile
Import see “Import of vector objects” in the “Vectorization”
User Manual
Export see “Export of vector objects” in the “Vectorization”
User Manual
g Save to save the sheets boundaries in the x-data file in
the resources of active profile
Save as to save the sheets boundaries in new file with the

x-data extension in the resources of active profile

&8 Sequential splitting

to define the sequential splitting parameters of block
images area and start the process of sheets
boundaries creation by the specified parameters

Full mosaic sheet

to create the single sheet covering all block images

[ Split into sheets by images

to create the sheets from each image of block

to create the single sheet with arbitrary boundaries
from any part of block images

to create sheet with set size relative to marker pos-
ition

Create sheets around point objects

to create sheets with set size relative to the each
point object position

B Project sheets list

to display table with information of project sheets

#51 Create standard orthomap sheet frames

to create notations sheets of specified scale
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Menu items

Function

#% Create custom orthomap sheet frames

to create sheets of several orthomaps, created in
local coordinate system, grouped by cutlines and
limited by notation frame

/& Activate all sheets

to make all sheets active (include to the process of
mosaic creation)

/® Deactivate all sheets

to make all sheets inactive (exclude from the pro-
cess of mosaic creation)

% Activate selected sheets

to activate selected sheets for creating mosaic

i Deactivate selected sheets

to exclude selected sheets from the mosaic creation

i Set sheets status by rasters

to select only sheets containing at least part of block
image for creation of output mosaic files (input
background color on the images edges is taken into
consideration), i.e the value of status attribute will
be equal to '1’ (active status) for boundaries of non-
empty sheets

{i¥ Set sheets status by useful areas

to select only sheets containing at least part of block
image for creation of output mosaic files (input
background color on the images edges is taken into
consideration), i.e the value of status attribute will
be equal to ’1’ (active status) for boundaries of non-
empty sheets

## Invert sheets status

to invert the status of all created sheets

B3 Select active sheets

to select on block scheme all active sheets

£ Select non active sheets

to select on block scheme all inactive sheets

Sheets activation mode

to choose sheets activation mode

#* Parameters

to define the output parameters for creation of output
mosaic

Sheet info

to obtain and modify information about selected
sheet

Split work areas into sheets

to create output mosaic sheets taking into account
the given work area

11.2. Requirements of cutting into sheets

The program allows cutting the output mosaic into sheets for saving them in the separate

files.

é At least one active sheet for all or selected area is required to start mosaic creation.

To display sheets borders is used the Sheets layer, which contains attributes of sheet
name and activity status. The program provides different ways of splitting mosaic areas
into sheets, selecting active sheets for creating output files and setting up output para-

meters.
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Throughout this User Manual, the Active sheet is referred to as sheet, from which the
output mosaic file will be created. The Inactive sheet is referred to as sheet, excluded
from the output mosaic.

It is recommended to pass the following number of actions during the mosaic sheets
creation:

1.

6.

Definition of the mosaic output coordinate system (see description of the Output
coordinate system panel in Section 13.2.2).

Splitting block images into sheets, i.e creating sheets boundaries (the vector objects
with the attributes for storing information about sheets in the Sheets layer).

Editing attribute values and sheets boundaries.
Managing sheets status.
Setting output parameters of sheets.

Creating output sheets of mosaic (see Section 13.3).

11.3. Splitting into sheets by the specified parameters

Perform the following actions for splitting block images into sheets by specified para-
meters:

1.

Choose the Sheets > Sequential splitting or click the Ef button in the Sheets

toolbar. The Sheets splitting parameters window opens.
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- !
4 Sequential splitting parameters Iﬁ
Blodk extents (m)
Morth
6588704.782
Morth East
2584054.8386 = 2593054.886
South
6579704.782 =
Owerlap (m)
Horizontally 0,000 = Vertically 0.000 =
Sheets base name: Sheet

[] Mumber from the top left corner
Borders check

@) By source images () Byuseful areas () By worked areas
Sheet size (m)
Width 1000000000 = Height 1000.000000 =

Mumber of sheets

Y

Horizontally 9 = Vertically 9 =

Attribute with sheet names: sheet_name

Sheets creation attribute:  create

QK ] I Cancel

Fig. 47. Parameters of sequential splitting

2. Define the following parameters of splitting:
* Block extents — allows to specify the area boundaries (in meters) for splitting;
» Overlap — allows to define the overlap size (in meters) by width and/or height;

? By default the sheets are created without overlap (dock).

» Sheets base name — allows to define the sheets name prefix (by default — Sheet

);

§ It contains the serial number of sheets row (upward) and serial number of the sheet in
a row (left to right). The rest of the sheet name is generated by program automatically.
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g By default, if sequential splitting is used, the sheet numbering starts from the lower-left
corner. To set the sheet numbering from the upper-left corner, set the Number from
the top left corner checkbox.

* Choose, how should the system perform the borders check — by source images,
by useful areas or by worked areas;

» Sheet size — allows to specify sheet size (in meters) by width and/or height;
5 The modifying sheet size leads to recalculation of sheets number in the specified splitting

area.

* Number of sheets — allows to specify the number of sheets by width and/or
height;

5 The splitting begins from the bottom left corner of the specified splitting area in accord-

ance with specified number of sheets and sheet size. Thus, sheet size not recalculated
when the modifying number of sheets.

+ Attribute with sheet names — allows to define the name of attribute for storing
the sheet names;

» Sheets creation attribute — allows to define the attribute name for storing inform-
ation about sheet status. By default the create is proposed.

3. Click OK. The process of sheets creation starts. The sheets boundaries are created
in the Sheets layer and displayed in the Preview window.

é All sheets, falling within block images, are active.
Active sheet is shown by green outline and has not color filling. Inactive sheet is
shown by red outline and red transparent filling, by default.

ﬁ The GeoMosaic | Preview tab of the Settings window is used to select color and set up
transparency options for inactive sheets (see Section A.2).
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Fig. 48. Sequential splitting

11.3.1. Creating sheets taking into account the work area

The system provides for creating sheets of an output mosaic taking into account the
work area of interest, which makes it possible to avoid sheets completely filled with the
mosaic’s background. For this, perform the following:

1. Split the mosaic into sheets (see Section 11.3);
2. Load the work area boundary into the layer manager (see Section 13.2.2);

3. Choose Sheets » Split work areas into sheets. A vector layer is created that
contains polygons which are the previously created sheets bounded by the work
area. The value of the name attribute of each of the specified polygons corresponds
to this attribute value from the “parent” sheet;

4. Save the created vector layer in the active profile resources;
5. Choose Sheets > Clear;

6. Choose Sheets > Open, to open the previously saved vector layer (see item 4);
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7. [optional] Save the mosaic project if needed.

11.4. Sheets creation modes
The program provides the following opportunities for sheets creation:

* full mosaic sheet from all images — allows to create one sheet including all block im-
ages;

* one sheet with arbitrary boundaries — allows to create one sheet with arbitrary
boundaries from the any part of block images;

* splitting into sheets by images — allows to create separate sheet from each image of
mosaic project;

* creating sheet around marker — allows to create one sheet in the marker region.

* creating sheets around point objects — allows to create sheets with set size relative
to the each point object position.

Choose the Sheets > Full mosaic sheet or click the button in the Sheets toolbar.
Perform the following actions for creating the single sheet:

1. Choose the Sheets > single sheet creation mode or click the ' ; button in the
Sheets toolbar.

2. Stretch the rectangle in the Preview window along with pressed Shift key.

Choose the Sheets > Split into sheets by images or click the [l button in the Sheets
toolbar. The sheet boundaries are created for each image.

Perform the following actions for creating sheet around marker:
1. Set the market in area where mosaic sheet will be created.

2. Choose the Sheets > Create sheet around marker. The Sheet creation paramet-
ers window opens.
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r !
&% Sheet creation parameters lé]
Offset to north
500,000 =
Offset to west Center coordinates Offset to east
¥ 2587346.050 =
500,000 = 500,000 =
Y 6584051.450 .
Offset to south
500,000 =
Sheet names
@ Fixed sheets name: shest
Sheets names from attribute:  |nzame

Clear layer before sheets creation

Ok ] | Cancel

Fig. 49. Sheet creation parameters
3. [optional] Set manually the Center coordinates by X and Y, with respect to which
the sheets boundaries will be calculated.

4. Set the distance from sheet center (marker position) to its border in the Offset to
north, south, west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. Choose the way of creating sheet name in the Sheet names section:
* Input the fixed sheet name;

+ Sheets names from attribute — define the name of attribute for storing sheets
name in appropriate field.

§ By default, each new sheet is named as sheet.

7. Click OK to create the mosaic sheet.

Perform the following actions for creating sheets around point objects:
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1. Load or create non-Geomosaic vector layer, containing point objects.

2. Choose the Sheets > Create sheets around point objects. The Sheet creation
parameters window opens.

r !
&% Sheet creation parameters I,iz-,l

Offset to north
500,000 =

Offset to west Center coordinates Offset to east
¥ 2587346.050 =

500,000 = 500,000 =
Y 6584051.450 .
Offset to south
500,000 =

Sheet names

@ Fixed sheets name: shest

Sheets names from attribute:  |fzame

Clear layer before sheets creation

Ok ] | Cancel

Fig. 50. Sheet creation parameters
3. [optional] In the Center coordinates section set the offset (by X and Y) between
point objects and sheets centers.

4. Set the distance from sheets centers to its borders in the Offset to north, south,
west and east fields accordingly.

5. [optional] By default, new sheet is created in the existed Sheet layer, not depending
on data in this layer. To create sheet around marker in the layer without data, set
on the Clear layer before sheet creation checkbox.

6. Choose the way of creating sheet name in the Sheet names section:
* Input the fixed sheet name;

+ Sheets names from attribute — define the name of attribute for storing sheets
name in appropriate field.
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@ By default, each new sheet is named as sheet.

7. Click OK to create the mosaic sheets.

11.5. Project sheets list

The program provides possibility to view project sheets list and to edit sheets.

To display the sheets list choose the Sheets » Project sheets list or click the Eff button

on the main or Sheets toolbar.

? To sort the table contents by the values of selected column, click on the column name.

(& Sheet list el

4 ME:#H NOHE v- QH
Sheet Create Width (pix) Height (pix) Mosaic size *

P et 100 iooor  l2s610m6 Gl

2 Sheetl 2 - 10001 10001 285.10 MB

3 Sheetl 3 - 10001 10001 285.10 MB

4 Sheetl 4 - 10001 10001 285.10 MB

5 Sheetl 5 - 10001 10001 286.10 MB

6 Sheetl 6 - 10001 10001 286.10 MB

7 Sheetl 7 - 10001 10001 285.10 MB

8 Sheetl 8 - 10001 10001 285.10 MB

9 Sheetl 9 - 10001 10001 285.10 MB

10 Sheet? 1 - 10001 10001 28610 MB  +

Sheets total/active: 81/22

Fig. 51. Project sheets list

The table with information about all project sheets is displayed in the Sheets list window.
The table contains the following columns:

* N — serial number of record;
* Sheet — the sheet name;

» Create — sheets active status;
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+ Width/Height — linear size of sheet (in pixels);

* Mosaic size — estimated size of output sheet in megabytes.

@ Double click on row in table allows to edit information about selected sheet. It allows to change
sheet name or active status.

Table 13. The toolbox of 'Sheets list’ window

Buttons Function
dh to search for an image by name (part of name) in the list
iE to select all sheets in the list
Sk to deselect all sheets in the list
EFi to invert selection of sheets in the table
B to remove selected sheets
(i to edit information about selected sheet — name and active status
v to make selected sheet active
- to make selected sheet non active
@] to open the Preview window for current sheet
= to save the list with names of selected sheets in text file

11.6. Generators of splitting into sheets

11.6.1. Standard orthomap sheet frames generator

The program provides possibility to split orthomap for notation sheets of chosen scale
(see Appendix B), which consist of vector polygons.

Generators of splitting into sheets are used to:
+ to split orthomaps into sheets by images;

« for further use in the GeoMosaicprogram.

c Orthomap sheets generation is available if project coordinate system is geodetic (latitude-longit-
ude) or based on map projection.

Perform the following to split survey area to notation sheets of chosen scale:

1. Choose Sheets » Create standard orthomap sheet frames. The Generate
standard sheets window opens.
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- . !
4 Generate standard sheets lth
Input coordinate system
CK-35, 3oHa 7 (36°%8.0.-42°6. 0. CEBEPHDE NONYILADWE ) Select, @

Crientation: left, geo-referendng: global coordinate system

Transform sheets into another Coordinate system

Limits in destination coordinate system

4|k

Morth 653870475

West 2554054.89 = East 2593054.39 =
South 6579704.75 =
Parameters
Scale 1:2 000 -
Attribute with sheet name Mame
Add "(5)" to sheet name
Zero-pad the 1:100 000; 1:5 000; 1:2 000 numbers
Quarters notation
@ a 6,81 1,2,3 4 ab,cd
Create rectangle sheets boundaries
[ Ok l | Cancel
L A

Fig. 52. Standard orthomap sheet frames generator parameters

2. The Input coordinate system in which you perform splitting into sheets (for ex-
ample, the project coordinate system) is displayed in the appropriate section. In
order to immediately recalculate the output sheets into another coordinate system
after creating them, set the transform sheets into another coordinate system
checkbox and configure the relevant parameters.

g Recalculation of created sheets into another coordinate system can be performed later,
using a separate command: Vectors » Geometry » Convert coordinate system (see the
“Change objects coordinate system” chapter in “Vectorization” User Manual). The checkbox
transform sheets into another coordinate system allows you to optimize data processing
within the framework of a single operation (instead of two consecutive ones).

g Sometimes it may be necessary to perform splitting into sheets in a coordinate system
different from the project CS (input), but then save the sheets in it. In this case, change
the coordinate system in which the splitting should be performed in the Input coordinate
system section, then set the transform sheets into another coordinate system checkbox
and specify the source coordinate system in this section.
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3. [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input co-
ordinates of corners in the North, West, East, South fields.

4. Choose the scale of orthomap in the Scale section.

5. [optional] In case when 1:5 000 or 1:2 000 scale is chosen, set on the Create
outscribed rectangles for sheet checkbox.

6. Inthe Parameters section define the following settings:

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. [optional] To clarify map position, located in south hemisphere, set on the Add
’(S)’ to sheet name checkbox.

3. [optional] Set on the Zero-pad the 1:100 000; 1:5 000; 1:2 000 numbers
checkbox in order to notation of 1:100 000, 1:5 000 and 1:2 000 scale sheets
was wrote correctly.

4. [optional] Itis possible to choose one of the Quarters notation in the appropriate
section.

7. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

8. [optional] Change the attribute names or values if necessary and click OK.

11.6.2. Custom orthomap sheet frames generator

Program provides possibility creating sheets from several orthomaps, merged by cutlines
and created in local coordinate system.

Perform the following to split orthomaps by notation sheets in local coordinate system:

1. Choose Sheets > Create custom orthomap sheet frames. The Generate arbitrary
sheets window opens.
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~ It
#® Generate arbitrary sheets I@
Parameters Coordinate systems
Attribute with sheet name Mame Sample
Primary sheet dimensions Scale 1 Scale 2 Scale 3 Scale 4 |
¥ 1000.00 = Y 1000.00 = 1 2
Lowerdeft corner of the origin sheet:
X 0.00 v oo : 3 4

Origin sheet number

X -21474335493 S ¥ -2147483648 -
Sheet name template:

S0 )-5(0y)-5(1)-5(2)-5(3)-5(4)

() Primary scale only

Cirigin Rows Columns Starting with
@ Scale 1 2 = 2 = 1 1 [] Separate numeration for rows and columns
) Scale 2 2 =1 (2 =1 1 1 [ separate numeration for rows and columns
() Scale 3 2 =1 2 = 1 1 [ separate numeration for rows and columns
) Scale 4 2 = 2 =1 1 [7] Separate numeration for rows and columns

FIENC] [ ok || cancel

Fig. 53. Custom orthomap sheet frames generator parameters

2. [optional] To load parameters from file click the = button.
3. [optional] Choose the Primary scale only to use one base sheet.
4. Specify the following parameters of primary scale sheet:
ﬁ, In case of using the' custom orthomap sheet framg§ generator it is possible up tp 5 levels
splitting orthomaps in to sheets: primary and 4 additional scales. Each next level is created

by splitting the previous level.

1. In the Attribute with sheet name specify the name of attribute for the sheet
name.

2. Inthe Primary sheet dimension field specify the primary scale sheet size.

3. In the Lower-left corner of the origin sheet input coordinates of the origin
sheet.

ﬁ Choose the reference point lower and left from work area. The coordinates of origins
of the others sheets are calculated based on this information.
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4. In the Origin sheet number input a number of sheet that starts numeration.
5. Inthe Sheet name template: $(0x)-$(0y)-$(1)-$(2)-$(3)-$(4), where

* $(0x) — number by X on primary scale;

* $(0y) — number by Y on primary scale;

* $(1), $(2), $(3), $(4) — number on the first and next levels in case if the
Separate numeration for rows and columns checkbox is set off;

* $(1x) — number by X in case if the Separate numeration for rows and
columns checkbox is set on;

* $(1y) — number by Y in case if the Separate numeration for rows and
columns checkbox is set on.

é Notation with all types, except using Roman numerals, could be created.

5. [optional] Specify the following parameters of primary scale sheet:
1. Choose one of the template: Scale 1, Scale 2, Scale 3, Scale 4.

2. Choose the Origin of the additional level from the list. By default the top-left
corner is set as origin.

3. Input number of Rows and Columns.

4. Input arbitrary symbol (letter or number) as a start sheet number in the Starting
with fields.

% All changes of parameters are shown in the Sample table.

6. Setup the appropriate parameters in Coordinate systems tab:
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- ~
Generate arbitrary sheets [ﬁ,l
ry

Parameters Coordinate systems

Geographic coordinate system
WGS 84/ UTM zone 32N {6deg East to 12deg East; northern hemisphere, Algeria. Austria, Cameroon, Denmark, Equator | Select, @
Crientation: right, geo-referencing: global coordinate system
Destination coordinate system
WGS 84 / UTM zone 32N {5deg East to 12deq East; northern hemisphere. Algeria. Austria. Cameroon. Denmark. Equator | Select, @
Crientation: right, geo-referencing: global coordinate system
Limits in destination coordinate system

MNorth 6583704.73 -
West 2584054.89 = East 2593054.89 e

South 6579704.78 ~

\E’ \E’ | OK | | Cancel

Fig. 54. Custom orthomap sheet frames generator parameters

* In the Geographic coordinate system section choose the input coordinate
system, which is used to specify splitting into sheets by latitude and longitude.

* In the Destination coordinate system section choose the coordinate system
to recalculate coordinate system of sheets during splitting into sheets.

* [optional] In the Limits in destination coordinate system section are specified
coordinates of area borders for splitting into sheets. To change area size input
coordinates of corners in the North, West, East, South fields.

7. [optional] To save parameters click the button. To reset parameters to default
click the &= button.

8. Click OK. The splitting orthomaps into sheets with specified notation process start.
When the process is completed the Sheets parameters window opens.

9. [optional] Change the attribute names or values if necessary and click OK.

11.7. Sheets status management
Each sheet has name and active status, specified in the Sheets layer.

In the Sheets menu and in the Sheets toolbar the following facilities provided to change
sheets status:

« to make all sheets active choose the Sheets > Activate all sheets or click the &
button;

» to make all sheets non-active choose the Sheets » Deactivate all sheets or click the
# putton;
\l" H
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+ to make selected sheets active choose the Sheets > Activate selected sheets or
click the &% button;

» to make selected sheets non-active choose the Sheets > Deactivate selected sheets
or click the &% button;

« to invert sheets status choose the Sheets > Invert sheets status or click the g#
button;

» to make sheets, which fall into images entirely including their background, active and
to simultaneously make the rest of sheets non-active, choose the Sheets » Set sheets
status by rasters or click the #& button;

» to make sheets, which fall into images without their background, active and to simul-
taneously make the rest of sheets non active, choose the Sheets > Set sheets status
by useful areas or click the i button.

In order to use provided modes of sheets activation you should activate the Sheets
layer and choose in the Sheets » Sheets activation mode menu one of three modes:

+ Select for activation — by default, this mode assumes standard selection of sheets
and further assigning them ’active’ or 'non-active’ status. In order to select sheets
drag a rectangle along with pressed Shift key, and use one of group selection modes
from the Tools toolbar;

» By first sheet — this mode allows to change sheets status without sheets selection.
Drag a rectangle in this mode along with pressed Shift key. The sheets that fall into
the rectangle, obtain the status of the first sheet of the rectangle created;

* Use selection mode — this mode allows to change sheets status without sheets se-
lection too. At that, status of sheets that fall into rectangle created along with pressed
Shift key, depends on a group selection tool selected in the Tools toolbar (see the
“Vectorisation” User Manual).

ﬁ The system also provides for selecting objects using a freeform polygon

Create a polygon by holding Shift while moving the cursor sequentially in the work area of
the 2D window. To complete the creation of a polygon, set the last vertex of the polygon by
double-clicking the left mouse button. To delete the last created vertex, press Esc.

To select sheets use the following modes:

+ to select 'active’ sheets choose the Sheets » Select active sheets or click the B3
button;

» to select 'non-active’ sheets choose the Sheets » Select non-active sheets or click
the E2 button.
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11.8. Attributes of sheets

Each sheet is given the name and defined sheet status using the attributes of the Sheets
layer. The capability of presetting provides correct import of sheets, which were created
in third party software, in case when the imported objects have another names of attrib-
utes for storing information about sheet (see the Vectorization User Manual).

By default the Sheets layer contains the following names of attributes:
* create — for storing information about sheet status;
» sheet_name — for storing sheet name.

To change the default attributes of the Sheets layer perform the following:

é After changing attributes it is necessary to rebuild existed sheets.

1. Choose the Sheets > Parameters or click the g button in the Sheets toolbar. The
Sheets parameters window opens.

Sheets parameters [&J
p

Sheets names

@ From attribute | sheet_name 'H ]

Serial numbers | Sheet

Mumber of vertices
@ Arbitrary
Value 4

Sheets activity
Attribute value: 1

Attribute name: |create v| | |

QK || Cancel |

Fig. 55. Setting attributes names

2. Choose the way of creating sheet name in the Sheet names section:

» From attribute — define the new name of attribute for storing sheets name: select
the name from list or specify it using the _... | button;

» Serial numbers — specify prefix of sheets names manually.
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3. Inthe Sheets activity section define the following settings:

* in the Attribute value field specify the value of attribute, chosen in the list,
whereby list is marked as active;

» choose the Attribute name from the list for storing information about sheet status
or specify new name using the _... | button.

4. Click OK. Thus, after the completion of splitting process, the data about the sheet
name and sheet status will be stored in the defined attributes irrespective of splitting
mode.

Perform the following actions for obtaining and editing information about a sheet:
1. Select the sheet boundaries by double click in the Preview window.

2. Choose the Sheets > Sheet info. The Sheet info window opens.

#¥ Sheet info —

Sheet name: Sheets_4|

| Sheet will be created

[ Ok ” Cancel |

Fig. 56. Values of cutline attribute
Window contains the following information:
» the Sheet name field corresponds to the sheet_name attribute value;
» the Sheet will be created checkbox corresponds to the sheet status is active.
Perform the following actions to view and edit attributes values of selected sheet:
1. Select the sheet boundaries by double click in the Preview window.

2. Choose the Window » Object attributes or click the [ button of the Vectors ad-
ditional toolbar. The Object attributes window opens.
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4.

[ & Object attributes |
COEEE 2P

Mame Yalue
"sheet_name" Sheetb_4

"create” 1

Fig. 57. Values of sheet attributes
The following buttons are used to create and edit attributes table:
« [0 - allows to delete all attributes of selected objects;

+ [} — allows to delete common attributes of selected objects;

[ — allows to open the Add attribute window to define name, type and value
of attribute;

« [& - allows to delete current field of attribute table;

« [ - allows to open the Edit attribute window to edit parameters of selected at-
tribute;

il — allows to invert attributes of selected object;
- B2 — allows to sort attributes of selected objects.
Also the window contains the table with at least two rows:

* create attribute— the ’1’ value corresponds to the active sheet status, the ’2’ value
corresponds to the inactive sheet status;

» sheet _name attribute— contains the name of selected sheet.

% The image name in the attribute is generated automatically and depends on the splitting
mode and parameters.

Click the string of the Value input field and insert another value for changing of at-
tributes value.

Press Enter to save or press Esc to cancel.

There are also other facilities in the program interface that provide fast managing of
the sheet activity status (see Section 11.7).
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11.9. Setting output parameters

The output parameters allow to define the method of output files naming and criteria of

selection sheets for creating output files.

Perform the following actions to set up output parameters:

1. After splitting part of block images into sheets, editing boundaries and sheets attrib-
utes, choose the Sheets » Parameters or click the g button on the Sheets toolbar.

The Sheets parameters window opens.

.
¥ Sheets parameters

==

Sheets names

@) From attribute |sheet_name

Serial numbers | Sheet_

Mumber of vertices
@) Arbitrary
Value 4

Sheets activity
Attribute value: 1

Attribute name: |create

|| Cancel |

Fig. 58. Sheets parameters

2. Choose the way of creating sheet name in the Sheet names section:

* From attribute — allows to use the value of selected attribute;

» Serial numbers — allows to use serial numbers and define the file name prefix.

? In this case, while creating mosaic, the sheet names are generated as follows: Pre-

fix+Sheet serial number.

3. Inthe Number of vertices section defines criterion of sheets selection for creating
output files by number of vertices within sheets boundaries.

» Arbitrary — sheets selection by number of vertices within the boundaries of cre-

ated sheets is not performed;

» Value - allows to select sheets by number of vertices and specify the number of

vertices in the input field.
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4. In the Sheets activity section perform the selection of sheets for creating output
files by the attribute values:

+ define the Attribute value, whereby list is marked as active;
» choose the Attribute name which set the sheets activity.

5. Click OK. Sheets activity changes automatically depending on parameters.
12. Using auxiliary data

12.1. Misc (Miscellaneous) menu

The Misc menu is used to show in the Preview window an auxiliary data that may be
considered during mosaics creation. For auxiliary data (that is vector data) the Misc
layer is provided.

Table 14. Brief description of Misc menu

Menu items Function
Clear to delete all vector objects created in the Misc layer
Open to load data from a file saved in active profile resources
Save as to save the Misc layer data to vector file with different name

and *.x-data extension in active profile resources

Local adjustment to show in the Preview window a grid of fragments for pre-
liminary estimation. The grid of fragments is intended for
collecting of statistics data of local brightness adjustment
(see Section 9.2)

Source images outlines to show in the Preview window boundaries of source images
with background

Source images layout to create polygons by images frames with background

Source images useful areas layout |to create polygons by images frames without background

Cloudless coverage/Visible areas map |to find areas with full cover of clouds

Cutlines coverage map to find errors or cutlines creation

Synchronize cutlines selection to select image with selected cutline automatically; it is ne-
cessary to display frames of source images before that with
the Misc » Source images outlines menu item.

Open images in marker position to open all 2D-windows with marker place

Load metadata to current layer to load images metadata to current active layer

Load nadir and central points to load coordinates of nadir and central points to the Miscel-
laneous layer

Convert metadata from AUX to X-FEAT |to convert orthomap metadata, created in third party soft-
ware, to the system interior format

Save images borders from metadata to [to save images borders as vector objects in the orthopho-
MIF/MID tomap; could be used only for othopohoto created by satellite
images
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Menu items Function

Check completeness of rasters to check the completeness of output rasters. After performing
the procedure information message is displayed. Such errors
may occur as a result of network failure.

12.2. Images layout

The program provides possibility to create polygons by images frames with background
or by images edges without background. Misc » Source images layout and Misc »
Source images useful areas layout menu item are used for that.

Choose the Misc » Source images layout to create polygons by images frames with
background.

The following attributes are assigned to each created polygon:

* image_name — the name of image which is in the polygon, and the path to the image
file;

* bytes ps — bytes per sample;

» aver_pix_size — average GSD size;
* img_width — image width;

* img_height — image height.
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Fig. 59. Creation polygons by images frames with background
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Perform the following to create polygons by images frames with background:

1.

Choose the Source images useful areas layout. The Parameters window opens.

( @ Parameters ot S )

Maximum deviation from background color: 0 =
| Unique background color
Image edges trim: 0.00 1 pix
Precision: 2.00 1 pix
Image simplification: 3.00 1 pix
Minimal components square: 1000.00 5 pix~2
Offset from images edges: 0.00 | pix

[ (0]4 ] | Cancel |

L% 4

Fig. 60. Parameters of creation polygons by images frames without background

[optional] in case of areas on images with color equal to background color, set on
the Unique background color checkbox and set the Maximum deviation from
background color to define a range of color, which presents in background of
source images.

In the Image edges trim specify the offset from images border in pixels.

Specify the Precision of calculation of areas boundaries (this value influences on
number of nodes in polygon to be created).

Image simplification, in pixels;

<

7

Preliminary simplification of images makes it possible to reduce the time spent on construct-
ing the boundaries of polygons and reduce the number of their vertices, thus avoiding un-
justified complexity of their configuration.

Specific optimum values of simplification are to be chosen individually for each project,
depending on the project type and geometry of initial data.

It is not recommended to reduce default values for UAS and central projection projects,
that have quite large image overlapping.

When processing satellite scanner survey projects that have small image overlapping, re-
ducing this parameter can be feasible for the purpose of increasing the quality of boundary
construction.

When setting this parameter, it is recommended to take into account the previously set
Precision of calculation of areas boundaries (see above). The Precision and Image
simplification values that differ by several orders of magnitude, are not advisable

108



PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

6.

ﬁ Preliminary image simplification before the construction of polygons boundaries is to be
performed only if the unique background color checkbox is set (see above).

In the Minimal components square specify the minimal square of the image, below
which polygon is not created.

[optional] To create polygons not exactly by image frame, but by some distance
from it, specify the negative value in the Offset from images edges in pixels to
create polygons inside frame, or positive value to create them outside.

Click OK to start polygons by images frames without background creation.
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Fig. 61. Creation polygons by images frames without background

12.3. Coverage maps

The program provides possibility to display errors of cutlines creation and to find totally
cloudy areas in images, what resulting to 'gaps’ in mosaic creation. Cutlines and
cloudless coverage maps are used for that. These maps are vector layers with polygons

Perform the following to find totally cloudy areas on images:
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1. Choose the Misc > Cloudless coverage/Visible areas map. The Cutlines creation
parameters window opens. It allows to create outline of image block.

2. [optional] If there is no data in the Clouds/Invisible areas layer, the Cutlines creation
parameters window opens. Choose the Build and use in the Clouds/Invisible
areas section and setup the rest parameters if necessary.

3. Click OK. The system displays information window which includes information about
outlines quantity and areas with full cover of clouds. Data is load to the new
Cloudless coverage/Visible areas map layer. The clouds are highlighted by red
color.
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Fig. 62. Totally cloud areas

To find errors in cutlines creation, choose the Misc » Cutlines coverage maps. The
system displays information window which includes information about outlines quantity
and errors in cutlines creation. Polygons from images with cutlines and 'gaps’ in cutlines
are added in to the Coverage maps layer.
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Fig. 63. Errors in cutlines creation
13. Mosaic creation
13.1. Mosaic menu
Table 15. Brief description of Mosaic menu
Menu items Function
%5 Parameters to setup parameters of mosaic preview and creation,
as well as brightness adjustment and output data
save
Q, Preview to open Preview window for the entire block of
loaded images considering data processing results
[T} Preview (current sheet) to open Preview window for the selected sheet of
mosaic
Clear brightness adjustment to clear all data about brightness adjustment
[l Brightness adjustment to rebuild local adjustment after cutlines change
Distributed global brightness adjustment |to use distributed processing to brightness adjust-
ment
[* Build full mosaic to start mosaic building and creation of output files

for selected active sheets

(¥ Build current sheet to start of mosaic building and creation of output file
for selected sheet
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Menu items Function

Distributed processing to start mosaic creation for specified active sheets
considering user settings and parameters in distrib-
uted processing mode

Distributed processing of PHOTOMOD |to start mosaic creation using distributed processing
MegaTIFF with splitting of active sheets

[E Open image to open any image of acceptable raster format for
preview in the application window

Save parameters preferences to save mosaic parameters setting for further use
them in other mosaic projects (see a description of
the Use saved mosaic settings option in Ap-
pendix A)

13.2. Setup mosaic parameters

13.2.1. General information

To setup mosaic building parameters, choose the Mosaic > Parameters or click the
button on the main toolbar. The Mosaic parameters window opens.

The window contains the following groups of parameters:
* main parameters of mosaic building on the Mosaic tab (see Section 13.2.2);

» parameters of local and global brightness adjustment on the Brightness adjustment
tab (see Section 9.1);

» parameters of ground control and tie points usage for adjustment on the Ties tab
(see Section 13.2.4);

» parameters of output mosaic sheets on the Output tab (see Section 13.2.3);
+ additional parameters on the Misc tab (see Section 13.2.5).

To save parameters of mosaic creation (for using in other projects), choose the Mosaic »
Save parameters preferences.

Saved output mosaic settings are load automatically on the program launch. To load
default mosaic settings into the Mosaic parameters window at the program start, set
off the Use saved mosaic settings checkbox on the GeoMosaic tab in the Settings
window (see Appendix A).

13.2.2. Mosaic’s main parameters

The Mosaic tab of the Mosaic parameters window purposes to setup main options of
mosaic building.
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i !
W Mosaic parameters [ﬁ

Mosaic | Brightness adjustment I Save I Ties I Misc |

Fill background out of sheet boundaries

Raster offset of sheet (+/-): 1.00 = pix
[] Build sheets by images

Lise images without cutlines

[] Use source rasters base layer orly

[] Transparent background inside cutlines

Align sheets by pixel grid

G50: 0. 100000000 M Calculate... ]
Background color Brightrness interpolation

[_] [Nearest neighbor v] [ Cutput raster channels ]
[] shift background colar: 1

Geometry correction cell size: 32 1 pix

Rotation angle: 0.00 =

Source rasters background color range ] =

Input coordinate system
AexapToBa NpaBan ([eKapTOES MPEEaA NOKANLHAA CUCTEMS KOOPAWHET) Select, @

Crientation: right, georeferendng: local coordinate system

Output coordinate system
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[] use work area boundary
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Ok, ” Canicel ]

Fig. 64. The 'Mosaic parameters’ window
The Mosaic tab is used for setting the following parameters of output mosaic:

* Fill background out of sheet boundaries — allows to specify a type of filling outside
of sheet boundaries in the output mosaic. Otherwise, the images of adjacent sheets
are used for the filling;
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* Raster offset of sheet — allows to specify a buffer zone size on the sheet borders
(in pixels);

» Build sheets by images — defines a content of sheets when creating a mosaic that
is split on sheets by images. If the checkbox is set on, each sheet will contain the
only image corresponding to the sheet, i.e. the mosaic will be not created. If the
checkbox is set off, each sheet will contain all images that fall into this sheet;

g The option is used to perform only export of initial images into different coordinate system or
export to files of other raster formats.

@ After splitting of sheets by images, sheets names in attributes of the Sheets layer should be
the same as images names.

é If the Build sheets by images checkbox is set on, mosaic is not built.

+ Use images without cutlines — allows to use images without cutlines for preview
and mosaic creation (see also a description of means of images order change when
creating mosaic without cutlines in Section 7.8);

* Use source rasters base layer only — allows to use a base layer of initial images
pyramid if the mosaic is created using docking (not overlapped) images without cre-
ating cutlines. If this checkbox is set off the program uses a pyramid layer correspond-
ing to specified resolution, i. e. the pyramid layer is taken based on the Cell size
parameter value;

* Transparent background inside cutlines — allows to use transparency for areas
with input background color inside cutlines;

ﬁ To apply this parameter it must be set transparency for background color of original images

(see Section 7.5).

» Align sheets by pixel grid — allows to set the parameters of pixel-by-pixel aligning
of sheet frames when exporting mosaic’s sheets:

o If the Align sheets by common grid checkbox is set when exporting mosaic’s
sheets, sheet frames are aligned (shifted) according to pixel mosaic’s grid;

o If the Align sheets by common grid checkbox is cleared, mosaic sheets are
created independently of each other according to initial vector sheet frames.
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Fig. 65. Aligning the sheets by common grid

» Cell size — allows to specify the size of output mosaic cell on the terrain. The cell
size by default is equal to the cell size of the first image of mosaic project;

% The Calculate button allows to set a mosaic size in pixels and recalculate its cell size accord-
ingly.

% The accuracy of this parameter (a number of decimal places) takes precedence over general

system’s settings of numbers of decimal places set in the Settings window (Service > Set-

tings » Modules > Decimal places » Orthorectification/Geomosaic, see the “Setup of
modules start” section of the “General system’s parameters” User Manual).

+ Background color — allows to set a color for mosaic background, since output mo-
saic always inscribes into a rectangular raster shape;

% The Transparent mosaic background on preview parameter influences on background
color of mosaic in the Preview window (see Section A.2).

o Shift background color — allows to specify a shift of colour, for some pixels on
the substantial part of image, if color of these pixels coincides with defined colour
of output orthoimages background, after the orthotransformation.

< During an orthophoto creation, images are subjected to geometric transformations and
resampling. As a result of such operations, the color of some informative pixels of the
raster image may by chance precisely match the chosen output image background color.

* Resampling method — allows to choose the brightness interpolation mode during
orthomosaic creation: bilinear, cubic or nearest neighbour;

115


settings.pdf

PHOTOMOD 8.0 Orthophotomaps creation (Windows x64)

* Output raster channels — opens the window Output image parameters, used for
specifying the following parameters:

@ By default quantity and structure of channels are defined by first added image.
o Use radiometric from RMC-files — allows to use data of radiometric correction

from RMC-file, if correction was done preliminary, for example — in the Raster
Converter module (see the 'General information’ User Manual);

? If the Monochrome output checkbox is set on, this channel could be use as a channel in
output file.

é If the checkbox is set on, auto levels or radiometric correction could be applied to selected
images.

o Channels list — contains list of source (left) and selected for using in orthorectific-
ation channels (right);

§ Quantity and structure of channels are forming with buttons of the Channels list section.

o Data format — allows to choose format of output image: 8 bit or 16 bit;

o Monochrome output — allows to create output file with one grayscale channel.

@ In case of monochrome output it is impossible to choose structure of channels.

4% Output image parameters [ﬁ

[ Use radiometric from RMC-files

Channels list

Red
Green

Blue
Green

Red Blue

B [&) ) [+ [

<=

Data format: |&bit -

Monochrome output

| 0K | | Cancel

Fig. 66. Output channels parameters
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+ Geometry correction cell size (in pixels) allows to increase significantly data pro-
cessing speed setting sizes of image fragments to process in accelerated mode.

g If Geometry correction cell size is equal to one, each image pixel undergoes complex
geometric transformations during processing, what provides the maximum accuracy of mo-
saic creation at, often, practically unacceptable time expenditures.

Increasing the geomety correction cell size allows a user to select the optimal ratio of data
processing speed and output mosaic quality. In this case, only the four extreme pixels of the
cell undergo geometry correction to the full cycle of geometric transformations, while the
main content of the cell is interpolated by the bilinear interpolation method.

Default 32 pixel Geometry correction cell size is optimal in most cases.

* Rotation angle — allows to setup a rotation angle (in degrees) of mosaic’s images;

§ Is used if a block of initial images has elongated shape and you need to remove unnecessary
background area in rectangular window of created mosaic.

» Source rasters background color range — allows to define a deviation from selected
background color of initial images, i. e. to specify a range of color, existing in initial
images background (see Section 7.5);

Also the Mosaic tab allows to choose Input and Output coordinate system if they
are different to the project’s coordinate system.

To use work area boundary (see Section 2.2), set the appropriate checkbox and
specify the path (in the active profile resources) to the prearranged vector layer contain-
ing at least one polygon.

§ The + button allows to open file with polygons. The _... | button allows to choose another file,
instead the opened. The — button allows to remove the selected file from the list. The [1 button
allows to remove all the files from the appropriate list. The £ button allows to display the selected

layer of vector polygons in both the Layers Manager and in a 2D window.

§ Data in the Preview window (if open) will be updated taking into account the loaded work area
boundary.

§ The system provides for creating sheets of an output mosaic taking into account the work area

of interest, which makes it possible to avoid sheets completely filled with the mosaic’s background
(see Section 11.3.1).

13.2.3. Mosaic output parameters

The Save tab of the Mosaic parameters window allows to setup options of mosaic
output.
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Fig. 67. Mosaic output parameters
The Map scale field allows to set the scale of output orthoimages.

The Calculate map scale button allows to calculate a scale and map sheet size (in
meters) and print resolution.

é Information on the printing resolution of an output image (dpi, dpm) is recorded in the metadata
of *.tiff and *.bmp images, respectively. DPI is dots per inch and DPM is dots per millimeter.
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Fig. 68. Map scale

When creating an orthoimage, various additional data can also be created depending
on the input File type. For this, set or clear the following checkboxes:

» Create tiled TIFF — an orthoimage will be created as a MS-TIFF file;

ﬁ Creation of MS-TIFF files (so called tiled TIFFs) is available only if TIFF/BigTIFF (*.tiff,
* tif) File type was preselected in Output window.

QA If the Create tiled TIFF checkbox is cleared — a *.TIFF file is created with a standard line
data record format.

o Create internal pyramids — allows for creating pyramids inside MS-TIFF output
images for quick redrawing of images on the screen in case of changing the viewing
scale.

ﬁ To use internal pyramids, the viewer must support the MS-TIFF format.

» Create external pyramids — allows for creating pyramids as additional files saved
in a separate folder;

ﬁ Creation of external pyramids is available only if TIFF/BigTIFF (*.tiff, *.tif) File type was
preselected in Output window.

TIFF format with internal pyramids is not used for orthoimage recording (Create tiled TIFF

é It is recommended to create external pyramids for large orthoimages in case when the MS-
and Create internal pyramids checkboxes are cleared).
<

Creation of external pyramids for MS-TIFF files is not provided.

* Create GeoTIFF — output orthoimages created in GeoTIFF format with pyramids;
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é Creation of GeoTIFF is available only if TIFF/BigTIFF (*.TIF, *.TIFF) File type was
preselected in Output window.

* Create KML - allows to create additional file in *.kml format, e.g. to show results in
the Google Earth;

é It is necessary to choose global coordinate system as output to create file in *.kml format.

5 * . kml-files are creating both for all block and each image individually.

[optional] Select the MegaTIFF parts format, MSTIFF or JPEG 2000 if PHOTOMOD
MegaTIFF (*.prf) files were selected as File type in the Output window.

The Output images compression allows to set up the compression parameters of
output mosaic sheets:

* None —files are created without compression;

+ JPEG with quality .. % — TIFF-files are creates with set quality of JPEG-compression;

% Default compression level is 75 %, that provides the 5-7 times compression of initial image
volume.

* LZW — TIFF-files are creates with LZW-compression;
» Deflate — TIFF-files are creates with deflate compression.

Also the Output tab allows to set the following parameters of saving files during mosaic
creation:

» Georeferenced file — allows to select the format of the additional file created;
« Swap X, Y — allows to swap X,Y coordinates;

» Save georeference as 'NonEarth’ — allows you to save georeference as NonEarth
coordinate system, when saving the resulting mosaic in Mapinfo format;

? Used if MaplInfo system does not support coordinate system of mosaic project.

» Create georeference only — allows to create just georeference files of sheets without
building mosaic sheets (i. e. without files creation);

» Save map projection and datum parameters to GeoTIFF — allows to save seven
parameters of coordinate system to meta data of TIFF-file;
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@ Used if it was decided to Create GeoTIFF.

* GeoTIFF for GIS Panorama (GSK-2011/PZ90.11 in zones) — allows to save the
appropriate parameters of coordinate system to metadata of TIFF-file;

§ Used if it was decided to Create GeoTIFF, for the further processing in Panorama software.

+ Transparent background color — allows to set the output background color which
is shown in MapInfo and GIS Map 2011 systems, as transparent, when saving the
resulting orthoimage in Maplinfo or GIS Map 2011 formats, chosen in the File type
list in the Output window;

% To save an orthophoto in the Mapinfo format, choose the File type used by this program in
the Output window and set the Georeferenced file that is to be Mapinfo TAB.

% To save an orthophoto in the GIS Map 2011 format, choose Panorama raster (*. rsw) in the
File type list in the Output window.

+ Save metadata — allows to save images metadata in the *.x- feat-file: background
colour, number of channels and its settings.

The Output data button allows to open the Output window to select format and target
folder of output mosaic sheets.

13.2.4. Using of GC/Tie points parameters

The Ties tab of the Mosaic parameters window purposes to setup options of using
ground control and tie points for adjustment.
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Fig. 69. Using of GC/Tie points parameters

The Using of ground control points checkbox allows to use ground control points for
more precise correspondence of cutlines area.

The GCPs section allows to set the following parameters of using ground control points:

* Images edges — allows to choose type of transforming which applies on images
edges:

o None — allows not to consider images edges;
o 2D-Shift — edges consider by average plane parallel shift;
o Projective — to consider edges is used the projective transformation.

» Affected area — allows to define maximal distance of ground control point influence
in meters.

@ If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.
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The Using of tie points checkbox allows to use tie points for more precise correspond-
ence of cutlines area.

The Tie points section allows to set the following parameters of using tie points:

* Images edges — allows to choose type of transforming which applies on images
edges:

o None — allows not to consider images edges;
o 2D-Shift — edges consider by average plane parallel shift;
o Projective — to consider edges is used the projective transformation.

+ Affected area — allows to define maximal distance of tie point influence in meters;

? If the Affected area checkbox is set off, maximal distance of ground control point influence
is image border.

* Filter — allows to filter part of points during geometric model creation.
The Enable flip checkbox allows to invert direction affect of point.

The Output mosaic shift section allows to set an output mosaic shift by the coordinate
axes (DX, DY) in meters.

13.2.5. Additional parameters

The Misc tab allows to to setup additional options of creating mosaic.

i !
# Mosaic parameters I&

| Mosaic | Brightress adjustment I Save | Ties | Misc |

| Save local adjustment
Vector data coordinate system

Input (source rasters coordinate system)

@ Output (mosaic coordinate system)

OK | | Cancel

Fig. 70. Additional parameters

The Save local adjustment checkbox allows to turn on/off saving of parameters and
settings of local brightness adjustment to file of mosaic project.
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The Vector data coordinate system section allows to select input or output coordinate
system of a project for storing of vector data (cutlines, sheets boundaries, tie points
etc.).

@ It is recommended to select output coordinate system (by default), since it is impossible to re-

calculate coordinate system during sheets creation. Coordinate system of initial images and
output mosaic are specified on the Mosaic tab.

13.3. Creation of output mosaic sheets

For creation of resulting output product — georeference files and sheets of mosaic (or-
thophotos) in specified coordinate system and scale — perform one of the following ac-
tions:

* [optional] to create output orthophoto for current sheet perform the following:

1. On the Sheets layer select a border of a sheet, for which the output file will be
created;

2. Choose the Mosaic » Build current sheet or click the ] button on the main
toolbar. The Save as window opens. Specify the name, format and output file
location in Windows file system. Default file name is a name of sheet stored in
attributes of the Sheets layer.

* [optional] To create output orthophotos for several mosaic sheets perform the following:

1. Define active sheets on the Sheets layer, for which the output files will be created
(see Section 11);

2. Choose the Mosaic > Build full mosaic or click the [ button on the main toolbar.
The Sheets file window opens. Specify format and target folder for output files;

3. The Output window opens.
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File type
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Fig. 71. Output parameters
Set the following parameters:
o Choose File type for output orthoimages from drop-down list.
m TIFF / BigTIFF files (*.tiff, *.tif);
m Windows Bitmap (*.bmp);

m Panorama raster (*. rsw);

ERDAS IMAGINE (*.1img);

m NITF (*.nitf);

JPEG (*.jpg, *.jpeg);

PNG (*.png);

Microstation (*.gfn);

PCIDSK (*.pix);

JPEG2000 (*.jp2);

m PHOTOMOD MegaTIFF (*.prf);
m ECW (*.ecw);

m WebP (*.webp).

o Select an output folder location:
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m [optional] in file system;
« click the _... | button to specify the path to files.
m [optional] in PHOTOMOD resources.
« click the _... | button to specify the path to resource.
Click OK.

4. [optional] If the Panorama raster (*. rsw) File type was chosen in Output window
(see paragraph 3 above), the Panorama map selection window opens:

.
. Pancrama map selection

.
S

Map file name

ci =

Export DEM to Panorama map

Continue Cancel

Fig. 72. Parameters of Panorama map export
Set name and path for the map file with one of the following ways:
o click the .. | button to export the map *. sit-file;

o click the Create button to create a new Panorama map (*.sit), input filename
and click the Save button;

o to export DEM that is used in orthomap creation, set on the Export DEM to
Panorama map checkbox.

The following files are created with orthophoto:
* mosaic sheets in chosen format;
+ reference files;

* the file with *.prj extension, with information about coordinate system in OGC WKT
format.

% A file name with *.prj extension corresponds to the project’'s name.

The WKT (well known text) format is a common text format of coordinate system description
developed according to /SO standards (International Standardization Organization) and
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standards of Open Geospatial Consortium, an international organization committed to making
quality open standards for the global geospatial community.

13.3.1. Distributed processing
To create orthoimages in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing chapter in the ’General information about system’ User Manual).

2. Choose the Mosaic > Distributed processing. The Mosaic distributed processing
window opens.

4 Mosaic distributed processing lﬁ

Output folder

@ File system () PHOTOMOD resources

Target folder (in case of network processing must have UMC format - \\Server\share\Folder):

C:\WorkPh\OpTol en
Path to resources

TecnSupportTests/GeoMosaicTest/cores_test. x-gmos/
Mumber of images: 22

4|

Mumber of tasks for processing: 4
Owverwrite existing images

Delete temparary project if success
Total progress bar

Ok, ] I Cancel

Fig. 73. Mosaic’s distributed processing parameters

@ Save the orthorectification project if it was changed.

3. Choose the output folder location:
* File system;
o Define Target folder for output orhoimages.

? In case of network processing path mast have \\Server\Share\Folder format.
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« PHOTOMOD resources.
o Specify the path to resources.

4. The Number of sheets displays in the window. Set the Number of tasks for pro-
cessing based on one kernel for one task.

5. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created orthoimages.

6. [optional] By default if process was completed successfully, temporary project is
deleted. Set the appropriate checkbox off not to delete temporary files.

7. Setthe Total progress bar checkbox, to keep the progress bar open when distrib-
uted processing tasks are completed (see “Progress bar for distributed processing”
in the “General information” User Manual).

8. Click OK. Distributed processing tasks are created and the system shows a message
about number of created tasks.

The system does not allows for mosaic brightness adjustment when building a mosaic
in the distributed processing mode (), nor in the mode of MegaTIFF distributed pro-
cessing (k). Herewith, brightness adjustment can be a part of the process of mosaic
building in the normal course ([*).

Building a mosaic in the distributed processing mode (E) is available either for projects
with previously performed brightness adjustment, or if brightness adjustment is disabled
when setting mosaic parameters (i.e. brightness adjustment is not included in the list
of tasks to be executed when building a mosaic in the distributed processing mode).
Otherwise the system gives the following warning:

(4% Warning |

Brightness adjustment was not performed, Either perform brightness adjustment

! '. and save the project, or disable this option in the project (the "Mosaic
parameters” window, the "Brightness adjustrent” tab, the "Global adjustment”
and "Local adjustment” sections].

Fig. 74. A warning when starting distributed processing
In case of this warning, to start distributed processing, perform the following:

« [optional] make brightness adjustment previously and save the project (I&]);
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* [optional] disable brightness adjustment previously in the Mosaic parameters window:

o In the Mosaic parameters window, Brightness adjustment tab, Global adjust-
ment section, choose None;

o Inthe Mosaic parameters window, Brightness adjustment tab, Local adjustment
section, clear the On checkbox.

13.3.2. Distributed processing of PHOTOMOD MegaTIFF

To create orthoimages in MegaTIFF format in distributed processing mode, perform
the following actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing chapter in the 'General information about system’ User Manual).

2. Choose the Mosaic > Distributed processing of PHOTOMOD MegaTIFF.

5 Save the mosaic project if it was changed.

The Mosaic distributed processing window opens.
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&% Distributed processing li_:hj

Mumber of images: 22

Mumber of MegaTIFF fragments: 22

Mumber of fragments per task: 1 =
Temporary folder for distributed processing projects:

Cutput folder
@ File system

PHOTOMOD resources

Target folder (in case of network processing must hawve UMC format -

\Server\share \Folder)
C:WorkPh\OpTol D

Path to resources

LT Eslaudl e

Owerwrite existing images

Ok ] I Cancel

Fig. 75. Mosaic’s distributed processing parameters

The total Number of sheets and Number of MegaTIFF fragments are displays
in the window.

3. Setthe Number of fragments per task;

é It is recommended to define Number of fragments per task depending on computer power
and hardware. Recommended Number of MegaTiff fragments / Number of fragments
per task ratio is no more than 1000.

When setting distributed processing, it is also necessary to take into account the network
capacity. For example, for 1 Gbit/s local network the recommended Max tasks is no more
than 4.

@ To set Max tasks quantity choose Service > Distributed processing > Monitor and press
the % button (see the “General information” User Manual).

4. Define path for temporary files of distributed processing.

5. Choose the output folder location:
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* File system;
o Define Target folder for output orhoimages.

@ In case of network processing path mast have \\Server\Share\Folder format.

« PHOTOMOD resources.
o Specify the path to resources.

6. [optional] By default in distributed processing mode only that sheet are creating
that have not created yet. Set on the Overwrite existing sheets to overwrite pre-
liminary created mosaic sheets.

7. Click OK. Distributed processing tasks are created and the system shows a message
about number of created tasks.

8. [optional] in case if the any File type, except PHOTOMOD MegaTIFF, was chosen
in Output window, the appropriate warning message opens:

i . Question I,il?-,l1

q '~ ) This operaticn can be applied to PHOTOMOD MegaTIFF format only.
\ Change cutput format?

Yes ] | Mo

Fig. 76. The warning message

Set the correct File type (PHOTOMOD MegaTIFF) to continue the orthorectification
in MegaTIFF format in distributed processing mode (§&).

The system does not allows for mosaic brightness adjustment when building a mosaic
in the distributed processing mode (), nor in the mode of MegaTIFF distributed pro-
cessing (g). Herewith, brightness adjustment can be a part of the process of mosaic
building in the normal course ([*).

Building a mosaic in the distributed processing mode () is available either for projects
with previously performed brightness adjustment, or if brightness adjustment is disabled
when setting mosaic parameters (i.e. brightness adjustment is not included in the list
of tasks to be executed when building a mosaic in the distributed processing mode).
Otherwise the system gives the following warning:
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(4% Warning -]

Brightness adjustment was not performed. Either perform brightness adjustment

! and save the project, or disable this option in the project (the "Mosaic
parameters” window, the "Brightness adjustrent” tab, the "Global adjustment”
and "Local adjustment” sections].

Fig. 77. A warning when starting distributed processing
In case of this warning, to start distributed processing, perform the following:
« [optional] make brightness adjustment previously and save the project (I&]);
* [optional] disable brightness adjustment previously in the Mosaic parameters window:

o In the Mosaic parameters window, Brightness adjustment tab, Global adjust-
ment section, choose None;

o Inthe Mosaic parameters window, Brightness adjustment tab, Local adjustment
section, clear the On checkbox.

Appendix A. Program parameters

A.1. General parameters

Programs provides possibility to setup general parameters of program and mosaic
preview parameters on the Preview tab. See the description of general parameters of
the program in the 'General system’s parameters’ User Manual.

To set up common program parameters choose the Service > Settings or click the
button on the main toolbar. The Settings window opens.
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W Parameters @
4 | GeoMosaic | GeoMosaic
Preview
4 Windows Save local adjustment
Marker (block scheme) Create badwp
Marker (preview) =
Backup depth: 2 =
Zoom AP aep
Contraol Vector data link to the project
Modules [] Show objects from current image only
St
D:I":“IED [] switch off computer after mosaic is built
4 Vectors |:| PHOTOMOD GeoMosaic exit affirmation
Labels Use saved mosaic settings
Elevation label =
E_W 1on fabels Input cache size: 255 ~| MB
Point numbers
Coordinate transform Output cache size: 123 = MB
Display Restrict cache size from 300 51 images
Raster
Unda Maximal number of simultaneously opened images: &4 =
Backups Correct doud topology when saving douds layer
Auto-save
System [ Fast building without background analizing
Pathz Add to project images with same names
Clear layer before single sheet creation
[] Enable cutlines nodes deleting
Enable cutlines moving
[] Additional black and white background replacement
[ Cloudsfinvisible areas useful areas saving affirmation
[] chedk transparency on individual channels
Ok ] [ Cancel
L% &

Fig. A.1. Common parameters
The GeoMosaic tab allows to setup the following general settings:

» Save local adjustment — allows to turn on/off saving of parameters and settings of
local brightness adjustment to file of mosaic project;

» Create backup — allows to setup automatic save of mosaic project backups to active
profile resources;

@ In the Backup depth field the number of backup projects copies is displayed.
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* Vector data link to the project — allows to save (in the first time) all external data
with names attached to project name automatically (e.g. project name sheets.x-
data);

5 In case this checkbox is set and cutlines (or other vector layers) from another project are
used during the current project processing, then when saving the project being processed,
all the above vector layers are saved as copies belonging with this project.

Otherwise, there are still possible troubles due to the fact that the same vector object was
edited several times during the processing of several different projects.

Note that in case of automatic creation such vector objects as cutlines in PHOTOMOD
GeoMosaic, the created vector layer is primarily available for collaborative editing by several
users and has *. cx-data extension (see “Co-editing vector layers” and “Co-editing topologically
connected vector objects” of the “Vectorization” User Manual).

+ Show objects from current image — allows to display vector objects relating only
to image opened in the Images preview window (see Section 7.4);

» Switch off computer after mosaic is built — allows to setup computer automatic
switch off after completion of mosaic creation;

+ PHOTOMOD GeoMosaic exit affirmation — allows to show a prompt on confirmation
of exit from the program when user tries to close main program window;

+ Use saved mosaic settings — allows to load previous mosaic parameters when
program starts;

* Input cache size — allows to set the limitation of the cache size for reading images
(by default 256 Mb);

» Output cache size — allows to set the limitation of the cache size for recording images
(by default 100 Mb);

* Restrict cache size from — allows to set max images number, when cache size is
5 Mb per image, otherwise the cache size has limited to 0.5 Mb per image;

+ Maximal number of simultaneously opened images — allows to set limit on the
opened images number in the formats JPEG, NIFF, IMG, PIX (in the case of a lot of
images, it is recommended to convert the images files to the TIFF-format files);

» Correct cloud topology when saving clouds layer — allows to correct topology
errors of vector polygons automatically on layer Clouds/Invisible areas while it is
saving;

» Fast building without background analysing — allows to build fast mosaic without
transparency of input background color;
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« Add to project images with same names — allows to add images with the same
names, which store in different folders;

» Clear layer before single sheet creation — allows to delete all vector objects from
the Sheets layer before creation of single sheet;

* Enable cutlines nodes deleting — allows to delete node of cutline — point, where
three or more cutlines are connected.

o If checkbox is cleared — a points, nearest to deleted node, are connected against
each other;

o If checkbox is set — a “hole” appears, after the point is deleted.

@ Use Cutlines » Replace current nod by new cutline to create a new cutline as a small
rectangle polygon in the place of the node (the point where three or more cutlines converge).
This polygon can be further edited by the user.

If the vertices of adjacent cutlines located next to a node vertex are too close to it, then
when user tries to replace current node by new cutline, the appropriate error message
is displayed: Inserting cutline is too small. If this system message appears, manually
delete the vertices closest to the node and try to repeat this operation by clicking the &
button in the main toolbar.

* Enable cutlines moving — allows to enable/disable the movement of cutlines on the
images, if the checkbox is not set, only the vertices of the cutlines are moving;

« Additional black and white background replacement — allows to use both black
and white color in the background;

§ For correct consideration of several background colors, set the Shift background color
checkbox in the Mosaic tab of the Parameters window (Mosaic » Parameters).

* Fill background color outside “Background” cutlines — beyond “Background”
cutlines the output mosaic background color is used which is to be determined in the
Parameters window (see Section 13.2);

» The checkbox, activating the Cloudsl/invisible areas/useful areas saving affirmation
when the programs close (if any changes have been made);

* The checkbox, allowing to check transparency by channels when setting background
color of source images (see Section 7.5).

& For example, if an image contains three standard channels (RGB) and the user-set background
color of source images is black (R=0, G=0, B=0), then, if the checkbox was set, pixels whose
intensity value corresponds to the given one (zero), at least in one of the channels, will also
be considered transparent.
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In case of incorrect compression of source raster images (before their processing in PHOTO-
MOD), separate pixels may appear on the border between the background and the content
of the image, actually initially belonging to the background, but, in the end, slightly different
from its original color.

Transparency check over individual channels makes it possible to consider such pixels as
transparent, in case if the original image background is black (R=0, G=0, B=0), or, for example,
white (R=255, G=255, B=255).

This checkbox is not recommended, if the background color of source images is arbitrary,
since all pixels whose intensity values match the color selected by the user, will be processed
as transparent, at least within one channel.

A.2. Preview parameters

The Preview tab is used to specify display parameters of mosaic.

. !
W Parameters ﬁ
4 (GecMosaic | Previcwy
Preview
4 Windows Show rasters in zoom greater than
Marker (block scheme) Transparent mosaic background on preview
Marker (preview)
7 W = it
Zoom Redraw preview on editing
Control Open preview immediately
Modules Skipped sheets fill color
Stereo
DEM Skipped sheets color transparency (3&)
4 Vectors i Ij
Labels 60
Elevation labels o
Paint numbers |:| Fast view in zoom >= 100%
Coordinate transform Preview extents
Display @ By source images
Raster
Undao | By sheets
Backups ! By images and sheets
Auto-zave
System Preview cache size (MEB)
Paths
Ok ] [ Cancel
L% A

Fig. A.2. Preview parameters

The Preview tab allows to setup the following mosaic visualization options:
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+ Show rasters in zoom greater than — allows to setup a zoom at which a visualizing
of mosaic project images in the Preview window begins;

» Transparent mosaic background on preview — allows to setup a transparency of
output mosaic background visible in the Preview window (see Section 7.4);

* Redraw preview on editing — allows to set automatic refreshing of mosaic data in
the Preview window during editing of vector objects — cutlines and change points;

* Open preview immediately — allows to show added images in the Preview window
right away (see Section 7.4);

» Skipped sheets fill color — allows to select a fill color to show inactive sheets of
mosaic (i.e. sheets excluded from output files creation). To adjust the transparency
degree for selected color is used the Skipped sheets color transparency (%) slider
(see Section 11.8);

* Fast view in zoom < = 100% — allows to display images block as a scheme in the
Preview window when zoom out (is recommended for large images blocks);

@ It is recommended to set on this parameter while processing of large image blocks.

* Preview extents — allows to define extents for displaying content in the Preview
window:

o By source images — extents by full image;
o By sheets — extents by all created sheets;
o By images and sheets — edges of images and sheets.

* Preview cache size — allows to set the size of a cache for mosaic project images
which are displayed in the Preview window.

? When setting this parameter, it is required to take into account available RAM of the worksta-
tion.

Appendix B. Notation sheets system

Scale Latitude lower than 60° 60° — 76° Latitude higher than 76°
1 000 000 |N-37 R-35,36 T-35,36,37,38
500 000 [N-37-I R-36-A,b T-35-B,I,36-B,I
200 000 |[N-37-36 R-36-09,10 T-35-10,11,12
100 000 |N-37-144 R-37-019,020 T-35-005,006,007,008
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Scale Latitude lower than 60° 60° — 76° Latitude higher than 76°
50 000 |[N-37-111-I R-36-069-A,b T-35-115-A,B,116-A,b
25000 |N-37-111-B-r R-36-069-I"-a,6 T-35-116-A-a,6,6-a,6

10000 |N-37-111-b-6-4 R-36-069-I-r-3,4 T-35-068--a-3,4,6-3,4

5000 N-37-111-(256) R-36-069-(019,020) T-35-068-(017,018,019,020)
2 000 N-37-111-(123-n) R-36-069-(021,022-1) T-35-068-(017-%,3,1)

Appendix C. Creating marginalia for orthophotomap

PHOTOMOD GeoMosaic allows to create map frame and marginalia in styles and
symbols used in Russian State Land Use Survey in map scales

+ 1:2000

+ 1:5000

1:10 000

1:25 000

1:50 000
for MicroStation and Mapinfo systems. Marginalia contains the following data:

» Decoration — image frame, outer bold frame, text labels, scale segment, scheme of
sheets, names of the neighbor sheets in frame cutouts;

* Grid — coordinate grid lines;
* Frames — frames of all the created sheets.

Marginalia for MicroStation consists of one *.DGN file for every orthophoto sheet (con-
taining Decoration and Grid), and a single file for the entire project containing Frames.

Marginalia for Mapinfo is saved as two (Decoration and Grid), or three (Decoration,
Grid and Text data) MIF/MID file pairs per each orthophoto sheet, plus single Frames
file pair for the entire project.

C.1. Workflow for creating marginalia

For marginalia creation perform the following:

& Described int this section is the workflow for creating marginalia for MicroStation in 1:2000 map
scale symbols.

1. After the orthophoto itself has been created, choose Mosaic » Create Marginalia
1:2000 > MicroStation DGN.... The Marginalia parameters 1:2000 window opens;
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r* Marginalia parameters 1: 2 000 @1
Mames | Frame parameters I DGM parameters
Path to marginalia files

C:WUsersigukl, E]

Coord, system:

Country:

State:

District:

Orthoimage: 0,000 =

Caption:

Stamp: 0.000 =
0.000 =
0.000 =
0.000 =
0,000 =
0,000 =

Save ] [ Load Ok, ] [ Cancel

Fig. C.1. Marginalia parameters
2. Inthe Names tab of the Marginalia parameters window, set the Path to marginalia
files (output);

3. [optional] Adjust the contents of the text labels for outside the frame (in the names
Names tab), if necessary;

4. Specify the frame style (in the Frame parameters tab);
5. Set the *.DGN specific parameters in the DGN parameters tab;
6. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

é The system allows to save marginalia parameters settings. To save settings as a file with *. x-
ini extension, click the Save button in the Marginalia parameters window. To set previously
saved settings, click Load.

To open orthophoto with marginalia in MicroStation system perform the following:

1. Open the created *.DGN file in MicroStation system;
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2. Toopen corresponding orthophoto raster sheet choose File » Raster management»
File » Attach in MicroStation system. The program displays the orthophoto with

marginalia.

8Mnsaic7marginalia.dgn {3D - ¥8 DGN) - MicroStation ¥& | ﬂ
File Edit Element Settings Toolz Utlites ‘Workspace ‘window Help

o W05 e o @fie|lcd 8L abBlo~ @ 7

N B =lolx|
b

k=D Ao opExd .

& DefeutViews 7] [ |2\3\4|5|5|?\s|

| ad (@ |Level 58

Fig. C.2. An orthophoto in MicroStation window

Marginalia can be created for the orthophoto as a whole as well as for the sheets in which it is
split.

C.2. Marginalia parameters

This section contains detailed description of marginalia creation parameters for all
supported scales.

C.2.1. Marginalia 1:2000

This section contains detailed description of marginalia creation parameters for 1:2000
scale for MicroStation and Maplinfo systems.
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MicroStation DGN

1. Marginalia is created using the menu command Mosaic > Create Marginalia
1:2000 > MicroStation DGN.... This command brings up the following dialog box
with parameters:

r* Marginalia parameters 1: 2 000 lﬁﬁ
Mames | Frame parameters DiGM parameters
Path to marginalia files
C:\Usersigukh, E]
Coord. system:
Courntry:
State:
District:
Orthoimage: 0.000 =
Caption:
Stamp: 0.000 =
0.000 =
0.000 5
0.000 =
0,000 =
0.000 =
Save ] [ Load Ok ] ’ Cancel
. _..

Fig. C.3. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

+ Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

» Caption, City — text lines placed consequently at the top center of marginalia;
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Stamp — text line placed at the upper right corner of marginalia;

Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-

zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

[optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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-
W Marginalia parameters 1: 2 000

S5

Mames Frame parameters DGM parameters
Coordinate grid step: 200,000 =
External frame offset: 26.000 =
External frame width: 4,000 =
Internalfexternal frame layer: 55,000 =
Coordinates arid layer: 56.000 =
Coordinates arid labels layer: 57,000 =
Text layer: 53.000 =
Frames file suffix: _frames
[7] & neighbour sheets only
[7] sheet number instead of name

[ Save ] [ Load (8]4 ] [ Cancel

Fig. C.4. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:

-
4 Marginalia parameters 1: 2 000

===

Measurement units

Master Units (MU): mu

Sub Units {SU); su

Identifications {2 symbols max.): Units ratio:
MU/SU:

| Marmes | Frame parameters | DGM parameters |

SU/DGM Pos, Units: 1,000

4|k

100,000

4|k

Origin
[] Auto =zelection
X Y z
0,000 1 0.000 1 0.000 =
Save ] [ Load oK ] [ Cancel

Fig. C.5. Marginalia parameters

* Names for MU and SU (see MicroStation system User Manual);

* Ratios MU/SU and SU/Pos.Units;
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» Origin of coordinates in a file - auto selection or manual setting.
5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.

Maplnfo

& Names tab is identical to the one in the parameters dialog for 1:2000 marginalia in DGN format.
Frame parameters tab is identical to the one in the parameters dialog for 1:2000 marginalia in
DGN format.

1. Marginalia is created using the menu command Mosaic » Create Marginalia
1:2000 » Mapinfo MIF/MID. This command brings up the following dialog box with

parameters:
r* Marginalia parameters 1: 2 000 @1
Mames | Frame parameters I MIF/MID parameters
Path to marginalia files
C:\Wsers\gukh, [I]
Coord. system:
Country:
State:
District:
Orthoimage: 0.000 =
Caption:
Stamp: 0.000 =
0,000 =
0.000 =
0,000 =
0.000 =
0,000 =
Save ] [ Load oK ] [ Cancel
. 4

Fig. C.6. Marginalia parameters

2. The Names tab contains the following parameters:
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Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

Caption, City — text lines placed consequently at the top center of marginalia;
Stamp — text line placed at the upper right corner of marginalia;

Next come 5 strings placed consequently at the bottom right corner of marginalia.

5 The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

[optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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W Marginalia parameters 1: 2 000

S5

Text layer:

Frames file suffix:

Mames Frame parameters | MIFMID parameters

Coordinate grid step:
External frame offset:
External frame width:
Internalfexternal frame layer:
Coordinates grid layer:

Coordinates grid labels layer:

[7] & neighbour sheets only
[7] sheet number instead of name

4|k

200,000

4k

25.000

[k

4.000

4|k

55.000

[k

56.000

4|k

57.000

4|k

58.000

_frames

J

[ Save

Load K.

] [ Cancel

Fig. C.7. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:

& Marginalia parameters 1: 2 000

o |

| MNames | Frame parameters | MIFMID parameters |

Lineart units:

Grid file suffix:

_text

Decoration file suffix:

[7] Meighbor sheets on the frame
[7] Labels in separate file

m
_decor

_arid

J

[ Save

Load oK ] [ Cancel

Fig. C.8. Marginalia parameters

» User units field specifies the name of the units of measurement in the MIF / MID

MIF/MID file;

» Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding

data;
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* Neighbour sheets on the frame option allows, along with the scheme of sheets
in the lower left corner, insert the names of the neighbour sheets in the cut-outs
of the external (thickened) frame;

» Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click OK.

C.2.2. Marginalia 1:5000

This section contains detailed description of marginalia creation parameters for 1:5000
scale for MicroStation and Maplnfo.

g Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:2000 marginalia in DGN format.

Marginalia for Mapinfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:2000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic > Create Marginalia
1:5000 > MicroStation DGN.... This command brings up the following dialog box
with parameters:

4% Marginalia parameters 1: 5 000 @

Mames | Frame parameters DGN parameters

Path to marginalia files
C:\Users'gukl I:I
Coord. system:
Country:
State:

District:

Ak

Orthoimage: 0.000

Caplion:

Stamp: 0.000
0.000
0.000
0.000

0.000

LlLd Alr Ak Alr LLd LlLd

0.000

Save | [ Load ] | OK | | Cancel

Fig. C.9. Marginalia parameters
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2. The Names tab contains the following parameters:

Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

Caption, City — text lines placed consequently at the top center of marginalia;
Stamp — text line placed at the upper right corner of marginalia;

Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

[optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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‘a '
¥ Marginalia parameters 1: 5 000 ﬁ
Mames Frame parameters DGM parameters
Coordinate grid step: 500,000 =
External frame offset: 72,000 -
External frame width: 4,000 =

4|k

Internalfexternal frame layer: 55,000

4|k

Coordinates arid layer: 52,000

4|k

Coordinates arid labels layer: 56,000

4k

Text layer: 53,000

Frames file suffix: _frames
[7] & neighbour sheets only
[7] sheet number instead of name

[ Save ] [ Load J oK ] [ Cancel

Fig. C.10. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:

i Y
M Marginalia parameters 1: 5 000 ﬁ
| Mames | Frame parameters | DGM parameters |
Measurement units
Identifications {2 symbols max.): Units ratio:
Master Units (MUY mu MLfSL: 100,000 =
Sub Units {SU): su SU/DGM Pos, Units: 1,000 =
Origin
[] Auto selection
X Y z
0,000 1 0,000 1 0,000 =
Save ] [ Load J (8]4 ] [ Cancel
o A

Fig. C.11. Marginalia parameters
* Names for MU and SU (see MicroStation system User Manual);

» Ratios MU/SU and SU/Pos.Units;
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» Origin of coordinates in a file - auto selection or manual setting.
5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.
Maplnfo

1. Marginalia is created using the menu command Mosaic » Create Marginalia
1:5000 » Mapinfo MIF/MID. This command brings up the following dialog box with

parameters:
r* Marginalia parameters 1: 5 000 @ﬁ
Mames | Frame parameters I MIF/MID parameters
Path to marginalia files
C:\Usersigukh, E]
Coord, system:
Courtry:
State:
District:
Orthoimage: 0.000 =
Caption:
Stamp: 0.000 =
0,000 =
0,000 =
0,000 =
0,000 =
0,000 =
Sawve ] [ Load Ok ] [ Canicel
X y.

Fig. C.12. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;
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Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

Caption, City — text lines placed consequently at the top center of marginalia;
Stamp — text line placed at the upper right corner of marginalia;

Next come 5 strings placed consequently at the bottom right corner of marginalia.

% The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers on which the relevant information
is placed;

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

8 neighbour sheets only option constrains the sheet scheme situated in the left
bottom corner by 9 sheets. Current sheet is placed in the center, with not more
than 8 neighbour sheets around it.;

[optional] set the Sheet number instead of name checkbox to change a notation
into sheet number in marginalia;
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i !
4% Marginalia parameters 1: 5 000 ﬁ
Mames Frame parameters | MIFMID parameters
Coordinate grid step: 500,000 =
External frame offset: 72.000 =
External frame width: 4,000 =

4k

Internaljexternal frame layer: 55,000

4|k

Coordinates grid layer: 52.000

4|k

Coordinates grid labels layer: 56,000

4k

Text layer: 53.000

Frames file suffix: _frames
[] 8 neighbour sheets only
[7] sheet number instead of name

[ Save ] [ Load oK ] [ Cancel

Fig. C.13. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:

r !
4% Marginalia parameters 1: 5 000 ﬁ
| Mames I Frame parameters | MIF/MID parameters |
Lineart units: m
Decoration file suffix: _decor
Grid file suffix: _grid

[] Neighbor sheets on the frame
[] Labels in separate file

_text

[ Save ] [ Load ] 0K ] [ Cancel

Fig. C.14. Marginalia parameters

» User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

» Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;
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» Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click OK.
C.2.3. Marginalia 1:10 000

This section contains detailed description of marginalia creation parameters for 1:10
000 scale for MicroStation and Maplinfo.

Q Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in DGN format.

Marginalia for Mapinfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:25 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1. Marginalia is created using the menu command Mosaic > Create Marginalia 1:10
000 > MicroStation DGN.... This command brings up the following dialog box with

parameters:
r* Marginalia parameters 1: 10 000 @1
Mames | Frame parameters I DGM parameters
Path to marginalia files
C:WUsersigukl, E]
Coord, system:
Country:
State:
District:
Orthoimage: 0,000 =
Caption:
Stamp: 0.000 =
0.000 =
0.000 =
0.000 =
0.000 =
0,000 =
Save ] [ Load Ok ] [ Cancel
k. A

Fig. C.15. Marginalia parameters
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2. The Names tab contains the following parameters:

Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

Caption, City — text lines placed consequently at the top center of marginalia;
Stamp — text line placed at the upper right corner of marginalia;

Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).

3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:
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P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

» Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

* Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

+ [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;
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m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.

o !
4 Marginalia parameters 1: 10 000 M
Mames Frame parameters DGM parameters |
Coordinate grid step: 1000,000 =| | [[] Delete first letter
External frame offset: 96,500 = Type of file with neighbour sheets
= @ & i L
External frame width: 7.000 = 9 No © Scheme () List
Internaljexternal frame layer: 55,000 =
Coordinates grid | : 55,000 =
cordinates gricdiayer Start import from string 1
Coordinates grid labels layer:  57.000 = _ )
Column with sheets names |1
Text layer: 58.000 = .
¥ Column with X1 [2 =1 Column with ¥1 |3
Frames file suffix: frames :
= Column with X2 [4 =1 Column with ¥2 |5
[] Rename to work number -
Column with X3 |6 | Column with¥3 |7
[] add sheet work name
File with sheets names Column with ¥4 |8 = Column with ¥4 |3
Start import from string 1
Column with sheets names: |1 : Column with sheets names |1
Columnn with work names: |2 - Swap X, Y
Separators Separators
Comma Tabulation Comma Tabulation
Space Semicolon Space Semicolon
Others Others
Decimal separatars Decimal separators
Dot Comma Dot Comma
Save ] [ Load Ok ] [ Cancel
L% A

Fig. C.16. Marginalia parameters
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4. The DGN parameters tab is used for setting standard DGN v7 parameters:

4% Marginalia parameters 1: 10 000 @

| Mames I Frame parameters | DGM parameters |

Measurement units

Identifications (2 symbaols max.): Units ratio:

L1l3

Master Units (MUY: mu M5 100,000

[k

Sub Units (SL): su SU/DGM Pos, Units: 1,000
QOrigin
[] Auto selection

X Y Fi

- -

0.000 ~| 0.000 | 0.000

[k

Save ] [ Load oK ] [ Cancel

Fig. C.17. Marginalia parameters
* Names for MU and SU (see MicroStation system User Manual);
+ Ratios MU/SU and SU/Pos.Units;
+ Origin of coordinates in a file - auto selection or manual setting.
5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.
Maplnfo

1. Marginalia is created using the menu command Mosaic > Create Marginalia 1:10
000 > Mapinfo MIF/MID. This command brings up the following dialog box with
parameters:
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r* Marginalia parameters 1 : 10 000 I&W
Mames | Frame parameters I MIFMID parameters
Path to marginalia files
C:WUsersigukl, [I]
Coord. system;
Country:
State:
District:
Orthoimage: 0.000 =
Caption:
Stamp: 0.000 =
0.000 =
0.000 =
0,000 =
0,000 =
0.000 5
Save ] [ Load Ok, ] [ Cancel
. A

Fig. C.18. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

« Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

» Caption, City — text lines placed consequently at the top center of marginalia;
« Stamp — text line placed at the upper right corner of marginalia;

* Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

[optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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i '
4% Marginalia parameters 1: 10 000 u
Mames Frame parameters | MIFMID parameters |
Coordinate grid step: 1000,000 4| | [[] Delete first letter
External frame offset: 96,500 z Type of file with neighbour sheets
= |ﬁ| ] = 1i
External frame width: 7.000 = @ No © Scheme (© List
Internaljexternal frame layer: 55,000 =
Coordinates grid layer: 56,000 = :
g Y Start import from string 1 ¥
Coordinates grid labels | + 57000 = -
OOrainates griclabels iayer Column with sheets names |1 -
Text| : 53.000 = B B
SxLiayer Column with ¥1 |2 | Column with¥1 |3 =
F file suffix: fr = =
FAMES e ST —TAMES Colurmn with X2 |4 <[ Column with¥2 |5 =
[] Rename to work number - -
Column with X3 [6 = Columnwith¥3 |7 [=
[] add sheet work name
File with sheets names Column with ¥4 |8 =1 Column with ¥4 |3 |5
Start import from string 1 =
Column with sheets names: |1 s Column with sheets names |1 =
Column with work names: |2 s Swap X, ¥
Separators Separators
Comma Tabulation Comma Tabulation
Space Semicolan Space Semicolon
Others Others
Decimal separators Decimal separators
Dl:lt CDmma D':lt C':lmma
Save ] [ Load ] Ok ] [ Cancel
L A

Fig. C.19. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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5.

i N
4 Marginalia parameters 1: 10 000 I&
| Mames I Frame parameters | MIF/MID parameters
Lineart units: m
Decoration file suffix: _decor
Grid file suffix: _grid

[7] Meighbor sheets on the frame
[] Labels in separate file

EXT

I Save I [ Load Ok J I Cancel

Fig. C.20. Marginalia parameters

User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

Click OK.

C.2.4. Marginalia 1:25 000

This section contains detailed description of marginalia creation parameters for 1:25
000 scale for MicroStation and MapInfo.

<

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in DGN format.

Marginalia for Mapinfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:50 000 marginalia in MIF/MID format.

MicroStation

1.

Marginalia is created using the menu command Mosaic > Create Marginalia 1:25
000 > MicroStation DGN.... This command brings up the following dialog box with
parameters:
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r* Marginalia parameters 1 : 25 000 I&W
Mames | Frame parameters I DGM parameters
Path to marginalia files
(-]
Coord. system;
Country:
State:
District:
Orthoimage: 0.000 =
Caption:
Stamp: 0.000 =
0.000 =
0.000 =
0,000 =
0,000 =
0.000 5
Save ] [ Load Ok, ] [ Cancel
. y

Fig. C.21. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

« Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

» Caption, City — text lines placed consequently at the top center of marginalia;
« Stamp — text line placed at the upper right corner of marginalia;

* Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

[optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. C.22. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. C.23. Marginalia parameters
* Names for MU and SU (see MicroStation system User Manual);
+ Ratios MU/SU and SU/Pos.Units;
+ Origin of coordinates in a file - auto selection or manual setting.
5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.
Maplnfo

1. Marginalia is created using the menu command Mosaic > Create Marginalia 1:25
000 > Mapinfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. C.24. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

+ Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

« Caption, City — text lines placed consequently at the top center of marginalia;
« Stamp — text line placed at the upper right corner of marginalia;

* Next come 5 strings placed consequently at the bottom right corner of marginalia.

é The fields for entering numeric values to the right of some text input fields specify hori-

zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

[optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. C.25. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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5.
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Fig. C.26. Marginalia parameters

User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

Click OK.

C.2.5. Marginalia 1:50 000

This section contains detailed description of marginalia creation parameters for 1:50
000 scale for MicroStation and MapInfo.

<

Marginalia for MicroStation is created using the dialog box with parameters, which is identical
to the one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in DGN format.

Marginalia for Mapinfo is created using the dialog box with parameters, which is identical to the
one in the parameters dialog for 1:10 000 and 1:25 000 marginalia in MIF/MID format.

MicroStation

1.

Marginalia is created using the menu command Mosaic > Create Marginalia 1:50
000 » MicroStation DGN.... This command brings up the following dialog box with
parameters:
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Fig. C.27. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

« Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

» Caption, City — text lines placed consequently at the top center of marginalia;
« Stamp — text line placed at the upper right corner of marginalia;

* Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

[optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. C.28. Marginalia parameters

4. The DGN parameters tab is used for setting standard DGN v7 parameters:
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Fig. C.29. Marginalia parameters
* Names for MU and SU (see MicroStation system User Manual);
+ Ratios MU/SU and SU/Pos.Units;
» Origin of coordinates in a file - auto selection or manual setting.
5. Click OK. *.DGN files containing marginalia would be saved in the folder specified.
Maplinfo

1. Marginalia is created using the menu command Mosaic » Create Marginalia 1:50
000 > MapInfo MIF/MID. This command brings up the following dialog box with
parameters:
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Fig. C.30. Marginalia parameters

2. The Names tab contains the following parameters:

» Path to marginalia files — the directory where the sheets with marginalia will be
saved. By default, this is the folder where orthophoto has been created. If the
setting is changed, it is saved and used the next time;

» Coord. system, Country, State, District — text lines placed consequently at the
upper left corner of marginalia;

» Caption, City — text lines placed consequently at the top center of marginalia;
« Stamp — text line placed at the upper right corner of marginalia;

* Next come 5 strings placed consequently at the bottom right corner of marginalia.

@ The fields for entering numeric values to the right of some text input fields specify hori-
zontal shift of the corresponding lines. The shift is given in the units of the PHOTOMOD
project (usually in meters).
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3. The Frame parameters tab contains the following parameters:

Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

External frame width specifies thickness of external (thickened) frame;

Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

Rename to work number option causes renaming of the sheet (trapezoid) name
in the upper right corner and in the cut-out of external (thickened) frame to the
work number;

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Add sheet work name option causes appending the work number of trapezoid
to name of the sheet in parentheses at the top right corner of marginalia. For
example:

P-54-76-B-6-1 » P-54-76-B-6-1 (49)

o This requires the CSV file having both names of the sheets (the column number
is defined by a column with the nomenclature parameter) and work numbers
(the columns number is defined by the column with numbers of trapezoid
parameter).

Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

Delete first letter of nomenclature option causes deleting the first symbol in the
nomenclature of the sheet. For example:

P-54-76-B-6-1 » 54-76-B-6-1

[optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.
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o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-6-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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Fig. C.31. Marginalia parameters

4. The MIF / MID parameters tab contains the following parameters:
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Fig. C.32. Marginalia parameters

» User units field specifies the name of the units of measurement in the MIF / MID
MIF/MID file;

» Decoration file suffix and Grid file suffix fields specify the lines which are ap-
pended to the base name of the sheet to obtain separate files with corresponding
data;

» Labels in separate file option allows to save all text captions in a separate file
with the specified suffix.;

5. Click OK.

C.3. Arbitrary marginalia parameters

If necessary the orthophoto marginalia, created in scales 1:2 000 and 1:5 000, may be
configured in accordance with the requirements of the user. To do this, use the following
commands:

* Mosaic » Create marginalia 1:2000 » MicroStation DGN (arbitrary)
* Mosaic » Create marginalia 1:2000 » MapInfo MIF/MID (arbitrary)
* Mosaic » Create marginalia 1:5000 » MicroStation DGN (arbitrary)
* Mosaic » Create marginalia 1:5000 » MapInfo MIF/MID (arbitrary)

In the window that appears, you can edit the layout parameters in the appropriate fields:
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Fig. C.33. Marginalia parameters

1. Names tab is identical to the one in the parameters dialog for 1:2000 marginalia
standard, except for additional Contours and Elevation system parameters, which
specify two text strings, which are written consequently at the center bottom;

2. The Frame parameters tab contains the following parameters:
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Fig. C.34. Marginalia parameters

+ Coordinate grid step specifies the distance between the lines of grid on mar-
ginalia;

+ External frame offset specifies the indentation of external (thickened) frame
from the frame along the outer edges of the corresponding image;

+ External frame width specifies thickness of external (thickened) frame;

* Internal / external frame layer, Coordinates grid layer, Coordinates grid labels
layer and Text layer specify the layer numbers (in *.DGN file) on which the relevant
information is placed;

» Frames file suffix specifies a text line attached to the base sheet name to get
the combined file name with all created sheets frames;

* Insert names in frames option causes writing the names of sheets to a file with
frames not only into the corresponding attribute, but also as a text string;
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* [optional] There may be chosen one of the following Type of file with neighbor
sheets values:

o No — names of the neighbor sheets are calculated automatically based on the
SK-42 topomaps nomenclature.

o Scheme — a (SV file is used as the scheme file, which contains only the sheet
names in accordance with the sheets topology. Row numbers correspond to
north-south direction. Column numbers correspond to west-south direction.
For example:

P-54-76-B-6-1,P-54-76-B-0-2
P-54-76-B-6-3,P-54-76-B-6-4

o List — file in the CSV format, containing description of one sheet in each line.
The line should contain the name of the sheet and the eight coordinates of four
vertices of sheet. For example:

P-54-76-B-6-3,1848.0,824.0,5848.0,824.0,5848.0,4824.0,1848.0,4824.0
P-54-76-B-6-4,5848.0,824.0,9848.0,824.0,9848.0,4824.0,5848.0,4824.0
P-54-76-B-6-1,1848.0,4824.0,5848.0,4824.0,5848.0,8824.0,1848.0,8824.0
P-54-76-B-6-2,5848.0,4824.0,9848.0,4824.0,9848.0,8824.0,5848.0,8824.0

If parameters Scheme or List are chosen, specify the path to the CSV file with
neighbor sheet names and set the parameters of this file’s import:

m Start import from string option causes the import process to start from the
given line in the file, skipping the previous lines;

m Column with sheets names — number of CSV column, which contains the
names of the sheets;

m Column with X1 — Column with X4 and Column with Y1 — Column with
Y4 — parameters - define the numbers of CSV columns, which contain corres-
ponding coordinates of the sheets corners;

m Swap X, Y —if this option is checked then during import X and Y coordinates
of objects vertices are swapped;

m Separators panel is used to select the symbols that separate fields in the
CSV file, comma and space are selected as separators by default.
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3. Frame parameters tab is identical to the one in the parameters dialog for 1:2000
and 1:5000 marginalia standard in DGN and MIF/MID formats.

C.3.1. Batch marginalia file names editing

Sometimes it may be necessary to rename sheet image files together with marginalia
files to working numbers.

Choose Sheets > Split into sheets by images, if it's not done yet.

Use menu commands Mosaic > Create Marginalia 1:2000 » Rename to work IDs or
Mosaic > Create Marginalia 1:5000 » Rename to work IDs when the preview window
is open for the mosaic sheets of which are to be renamed.

Then in the dialogue box that appears, select the folder where files with marginalia and
files with sheets, which must be renamed, are stored.

As a result of this operation, the files contained in the selected folder will obtain the
names used in the PHOTOMOD Mosaic module by default, for example, “Sheet 1,
“Sheet 2”. Files extensions will correspond to their content: for example, *.tiff - for
sheets files, *.tab - for sheets georeferencing in Mapinfo, MIF/MID - for files with mar-
ginalia.
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