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1. Purpose of the Document
This manual provides detailed information on main features of PHOTOMOD Stereo-
Measure software module and ForestInterpretation program.

The manual contains a description of work with layer objects without classifier, special
aspects of forestry tasks solving, as well as stereo images interpretation and stereo
vectorization of forest stratums during processing of the Earth remote sensing data.

Stratum – a forest unit that is homogenous by its economic value and taxation characteristic,
that is different enough from adjacent units, and that requires carrying out the same economic
activities on its whole area.

See the detailed description of work with vector objects in the “Vectorization” User Manual.

2. PHOTOMOD StereoMeasure Software Module
PHOTOMOD StereoMeasure software module (hereinafter “module”) is a software
product, created on basis of PHOTOMOD digital photogrammetric system, and used
for stereo interpretation and solving of forest taxation tasks.

PHOTOMOD StereoMeasure software module includes PHOTOMOD Core (control
shell of the digital photogrammetric system that is used to create, edit, import/export of
vector objects without a classifier), and PHOTOMOD StereoWindowmodule (a window
used to view, interpret, measure and vectorize objects in stereo mode by space and
airborne data).

Refer to the in the “General information” User Manual for detailed description of modules and
programs of the PHOTOMOD digital photogrammetric system.

Themodule is designed to work underWindows operating systems with x64 architecture.

3. Functionality of the StereoMeasure module
A set of the module’s functions allows to solve the following tasks:

• to perform stereo vectorization in a vector layer without a classifier;

• to specify a set of required attributes mandatory attributes for vector layers (including
the Area mandatory attribute, which value could be calculated automatically);

• to cut a polygon by a polyline;

• to control change of attribute values for new objects, obtained after merging or splitting,
with the ability to reset or preserve default initial attribute values (at that the attributes
structure remains unchanged, but the Area attribute is re-calculated automatically);
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• to check the uniqueness of attributes values, presence of blank values, compliance
with the values of specified type with the ability to display a list of found errors in the
separate window;

• to display combined (consisting of several attributes) labels of vector objects within
objects boundaries;

• to calculate density of canopy;

• to perform objects stereo interpreting and vectorization by “stereo images”, acquired
after processing of airborne survey data, that allows to measure plain coordinates of
objects with accuracy, that equals to orthophoto images accuracy, and also allow to
perform an off-scale assessment of the difference in exceedances of objects over
the terrain model;

• to measure objects coordinates, lengths, heights and areas in stereomode using RS
data, automatically re-calculate vector objects area after the objects re-shape;

• and also to form stereo images using space and airbornematerials taken from different
routes with quality, required for visual stereo interpretation.

4. Vector layer creating and loading
To create a vector layer without classifier select Vectors › Create layer. After that the
Vector layer is created in the Manager and it has a serial number (starting from the
second).

In order to load vector objects perform the following actions:

1. Choose Vectors › Load or click the button of the main toolbar.
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Fig. 1. Vector layer loading

2. Select one or multiple vector files with *.x-data extension.

After that when multiple files are selected the system suggests two ways of loading: to load
all in the same layer or to load each file in a separate layer.

3. [optional] To disable saving and rewriting of selected file, set the Open read only
checkbox on.

4. [optional] Select method of objects coordinates recalculation For different coordin-
ate systems transforms via – using pixel or geodetic coordinates (see details in
the “General system’s parameters” User Manual).

5. Click the Open button. If one or multiple vector layers are already loaded to active
project, then during loading of new vector layer the window of loading type is opened.
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Fig. 2. Vector layer loading

The system provides the following variants of new layer loading to existing vector
layer:

• Replace layer – vector data of active layer is replaced by data from loading layer;

• Create new layer – vector data is loaded to a new layer;

• Add to layer (without unloading existing data) – during loading vector data is
added to objects of active vector layer.

When it is necessary to load two or more vector files at once, there is the following
ways of loading:

• Clear layer and load all files into it – vector data of active layer is replaced by
data from loading layers;

• Load all into one new layer – vector data is loaded to a single new vector layer;

• Create separate layer for each file – vector data of each file are loaded to
separate layers;

• Load all layers into Vectors without unloading existing data – vector data
of all files adds to objects of active vector layer.
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Fig. 3. Vector layer loading

Vector layers are displayed in Manager.

If vector data layer is saved to different coordinate system or in a project with differ-
ent adjustment results, the system recalculates coordinates automatically. After
loading produces information message about coordinates recalculation.

Fig. 4. Coordinates recalculating during vector layer loading

The system provides a possibility of quick access to recently loaded vector data files.
To do this use the Vectors › Recent menu item. If necessary, the default coordinates
recalculation uses.

5. Preparing to stereovectorization

5.1. Stereopair loading

To open a stereopair window, perform the following actions:
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1. Select Service › Settings (Ctrl+Alt+P) or click the button of the main toolbar.
The Settings window is opened.

2. On the Stereo tab, select Page-flipping mode, and then click OK.

3. Select images in the Block scheme window or in the Block Editor window by one
of the following ways:

• highlight two overlapped images;

• highlight a single image.

4. Выберите Window › New 2D-window (stereopair) (Ctrl+Alt+W). The system
opens a window with a stereopair, which consists of two selected images.

If a single image was selected, the window displays either the best stereopair found using
parametric search, or a stereopair consists of highlighted and its next image in the strip.

If you have highlighted the last image in a strip, the stereopair is consisted of the highlighted
and its previous image in the strip.

5. Press the button (F9), to turn a stereo mode on.

Press the button (F11), to change a stereo mode phase, if necessary.

5.2. Pseudo-stereo mode

The system allows to work in pseudo-stereo mode in the block scheme window.

Pseudo-stereo – is a stereo mode, where orthogonal projection is used for left eye, and
for right eye – parallel projection with some angle to normal line. This mode allows to
display to raster layers as one stereo image.

In order to turn on the pseudo-stereo mode perform the following actions:

1. Choose Service › Settings (Ctrl+Alt+P). The Settings window opens.

2. On the Windows tab set the Allow pseudo-stereo in block scheme window
checkbox.

3. [optional] To define an angle of projection to normal line, specify the Separation
parameter.

A Separation coefficient is equal to survey height/basis ratio. The more precisely Separa-
tion is set, the more accurate Z measurements made in this mode will be.
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4. Click OK. To apply the changes, close block 2D-window and then open it again.
To do this chooseWindow › 2D-window (block).

5. The buttons are the same as buttons in stereopair 2D-window. Buttons used to turn
on and setup stereomode are added in 2D-window toolbar.

6. Choose Raster › Load georeferenced image (files) or Raster › Load georefer-
enced image (resources) and select two images to be loaded from file system or
from projects resources. The Load georeferenced image window opens.

The possibility of conducting specific measurements in this mode depends on the parameters
of the transformation of the georeferenced raster. For example, to measure the heights of
buildings, trees or any other similar objects, georeferenced rasters must be transformed
using a DEMwith no regard to these objects. To performmeasurements of relative altitude,
georeferenced rasters must be transformed using a constant elevation (see section “Type
of DTM” in “Orthorectification” user manual).

Fig. 5. Loading images

7. [optional] If it is need to transform images into another coordinate system, set the
Convert coordinate system checkbox, select the Input coordinate system and
Output coordinate system, and then click OK.

8. [optional] When loading multiple images at once the Load window opens. Select
Create separate layer for each file. After that the images loads to two separate
raster layers.
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Fig. 6. Loading more than one image

9. [optional] Tomaintain the epipolar alignment, the plane should be placed horizontally.
To specify an exact rotation angle of the picture, set the Rotate block scheme
window content chechbox and set the Rotation angle in the Block Scheme tab
of the system Settings window.

10. Right click the layer with the “left” image in the Manager. In the context menu choose
the Raster layer parameters item. The Raster layer parameters window opens.

Fig. 7. Raster layer parameters

11. [optional] To set the layer Z level, specify a value in the Z position of the layer
field.

This value is used as a elevation of stereo zero-parallax (not only for stereoscopic image
formed with the other layer, but for a usual raster layer when the stereo is on in block
scheme window). If current layer contains stereoscopic image formed with the other layer,
then the layer Z position, specified in the window, is applied to both layers.

12. In the Pseudo-stereo layer list select the layer with the “right” image. Raster layer
with the “left” images becomes stereo layer.

In order to estimate a result of obtained pseudo-stereo image perform the following
actions:

1. Turn on the stereo mode in the block scheme window. To do this click the button.
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2. Turn off visibility of layer with image, selected as the “right” one, by clicking the
button next to the layer name in the Manager.

5.3. Stereo image settings

When working in stereo mode to obtain the best stereo effect in created vector object
area it is recommended to tune stereo image depth. This is important when working
with “deep” images, i.e. images with a large Y-parallaxes difference in stereoscopic
viewing area.

To tune stereo place marker to necessary area and project it on object or relief surface
(see “The marker management” chapter of the “Vectorization” User Manual). Click the

button or press the F2 key. Images are moved in such a way that parallax gets zero
value in marker position, and the best stereo is obtained in this point vicinity or in its
“depth”.

To restore basic stereoscopic effect “depth” click the button of 2D window toolbar
or use the F3 hotkey.

To change stereo mode phase (i.e. to switch between left and right images) click the
button of 2D window toolbar or use the F11 hotkey.

To change stereo image depth use the Shift+Page Up/Page Down or Shift+mouse
wheel hotkeys.

6. Vector objects attributes

6.1. Creation attributes in layer without classifier

In addition to creating vector objects attributes attached to a specific code of the classi-
fier, the system has the ability to create attributes of objects in the layer without classi-
fier.

In order to add attributes, that are not attached to classifier code, perform the following
actions:

1. Create or load vector layer without classifier.

2. Select a vector object.

3. Choose the Window › Object attributes or click the button of the Vectors ad-
ditional toolbar. The Object attributes window opens.
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Fig. 8. Vector objects attributes

The following buttons are used to create and edit attributes:

• – allows to delete all attributes of selected objects;

• – allows to delete common attributes of selected objects;

• – allows to add a new attribute and its parameters;

• – allows to delete selected attribute;

• – is used to edit selected attribute properties;

• – allows to sort attributes of selected objects;

• – allows to invert attributes of selected objects.

4. Click on the table field in the Value column opposite to name of selected attribute.
The field becomes editable then.

5. Input attribute value.

6. To complete editing and save the input value press Enter or pass to the next attribute
value cell.

To exit without saving changes press Esc.

6.2. Adding required attributes of a layer

The system allows to assign required attributes to all layer’s objects. These attributes
add to all objects, regardless of their classifier type and code.

In order to add required attributes to a layer objects, perform the following actions:

1. Make editable a layer for which to add required attributes.
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2. Select Vectors › Attributes › Obligatory layer attributes. TheRequired attributes
window opens.

Fig. 9. The Required attributes window

The following buttons are used to create and edit additional attributes:

• – allows to clear the obligatory attribute values list;

• – allows to add a new attribute and its parameters;

• – allows to delete attribute selected in the table;

• – is used to edit selected attribute properties;

To edit an attribute value in the Object Attributes window, double-click on the Value
field

3. To add attribute click the button. The Edit attribute window opens.

Fig. 10. Attribute parameters

4. Define the following parameters:

• Attribute name;
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• Attribute type:

○ integer – attribute of integer type;

○ float – attribute of real type;

○ text – text attribute; text length is determined by its content, but not more than
8 bytes.

• Default value – a value assigned automatically to all objects of selected layer
as an attribute.

5. Click OK. Attributes from the list of the Required attributes window are assigned
to all objects of selected layer.

6.3. Vector objects labels

6.3.1. Labels creation

The system provides possibility to create labels to vector objects both from attribute
values and code table fields, and in the form of coordinates.

To create labels to vector objects perform the following actions:

1. Select Vectors › Attributes › Set labels. The Set label window opens.

Fig. 11. Labels parameters
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2. [optional] To set labels to selected objects, set the For selected objects only
checkbox on.

3. Select one of options of labels creation:

• Attribute value – labels create from values of selected attribute;

The attribute values can be used as signatures only if there are any attributes available.

• Coordinates – object coordinates display as labels (depending on object type);

○ Point object – display coordinates of points and polygon/polyline vertices;

○ Centers of line object – display coordinate of line objects centers;

The system allows to create signatures for all types of objects at the same time. To do
so, set the Point objectsы and Centers of line objects checkboxes.

Coordinates should by created using the template %X% %Y% %Z%.

The system allows to create labels in the coordinate system different from project co-
ordinate system. To do this set the In another coordinate system checkbox on and
select coordinate system to be displayed.

4. Click OK. After that labels to selected objects are displayed in 2D-window.

There are hotkeys to hide labels: in active layer – Ctrl+H, in all layers – Ctrl+Shift+H. Also
the Edit › Active layer › Show/Hide labels in active layermenu item allows to hide labels.

6.3.2. Labels attributes

The system provides possibility to display labels of vector objects combined frommultiple
attributes with delimiters.

In order to show combined labels perform the following actions:

1. Select Vectors › Attributes › Label attributes. The Layer label attributeswindow
opens.
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Fig. 12. Layer labels

The window Layer label attributes contains the toolbar for the following operations:

• – moving attribute to the top position;

• – moving attribute one position up;

• – moving attribute one position down;

• – moving attribute to the bottom position;

• – allows to clear the attributes list;

• – allows to add new attribute;

• – allows to add attribute from list of existing layer attributes;

• – allows to remove selected attribute.

2. In the Label attributes section the list of available attributes with labels is displayed.

3. In the Attributes separator section specify a symbol to be used as a separator of
attributes.

The system supports special symbols of XMLmarkup language that are used as separators.

Line spacing is set on the Labels tab of the Settings window (see the “General system’s
parameters” User Manual).
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4. Click OK. As a result, for vector objects vertices having attributes the labels in the
form of attribute values with specified delimiter are displayed in 2D-window.

During automatic polygon attributes assigning or at manual attributes change labels attrib-
utes are updated automatically.

6.4. Attributes assigning

6.4.1. Assigning of unique attribute value

Unique values could be assigned to attributes of vector objects. This simplifies combining
objects into groups by attribute values and automate the assignment of attribute values
to vector objects. This function is used for further work in 3D-Mod program.

To assign unique attribute value to objects, perform the following actions:

1. Select a vector object or multiple objects in 2D-window.

2. Select Vectors › Attributes › Assign unique attribute value. The Assign unique
attribute value window opens.

Fig. 13. Parameters of unique attribute values

3. Select attribute in the Attribute name field to input unique value or specify a new
attribute name.

When you define a new attribute name the system creates an additional attribute of integer
type for the selected objects.
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4. Select one of the following ways of unique value assigning:

• Assign new unique value – allows to specify new unique value of active object
attribute;

• Copy from active attribute – allows to copy a value of selected object attribute;

• Begin numbering from the value – allows to start numbering from arbitrary
number specified in this field.

5. Select a way to specify the value of selected objects:

• unique for each object;

• equal for all objects.

6. Click OK. Unique attribute value is assigned to selected vector objects.

6.4.2. Save the objects height in the attribute

The system allows to save the objects height in the attribute. Height calculates as dif-
ference between the value of the DEM cell and height of the object vertices.

This function may be used to save roof heights over the ground level as attributes.

In order to save the objects height in the attribute perform the following actions:

1. Load a vector layer and a DEM in the project.

For correct work of the function make sure, that only one layer with vector object and only
one DEM is opened in the current project.

2. Select Vectors › Attributes › Save objects height above DEM to attribute. The
Layers selection window opens.
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Fig. 14. Parameters of saving the objects height in the attribute

3. Define the following parameters in the window:

• Attribute name – "height" by default;

• Decimal places – allows to specify the number of decimal places (from 0 to 24).

• Objects height – allows to use average, minimal or maximal height of vector
object vertices to define difference with DEM;

• DEM height – allows to use average, minimal or maximal value of DEM cells
around vector object to define difference with the object.

4. [optional] To assign objects height only to attribute of selected objects, set theApply
to selected checkbox on.

5. Click OK. As a result, height difference is assigned to all or selected objects of
vector layer as attribute.

6.4.3. Automatic filling layer’s attributes

The system allows to fill layer’s attributes automatically.

Perform the following actions for creating autofilled attributes:

1. Make editable a layer for which to add autofilled attributes.

2. Create attribute with float type.
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3. [optional] To display a value of autofilled attribute in 2D-window specify labels at-
tributes for created attribute.

When automatically filling in polygon attributes or changing the attributes manually, signature
attributes are updated automatically.

4. Choose Vectors › Attributes › Autofilled layer attributes or click the button
of the Vectors additional toolbar. The Autofilled attributes window opens.

Fig. 15. The Autofilled attributes window

The windowAutofilled attributes contains the toolbar with buttons used to perform
the following operations:

• – is used to clear the attributes list;

• – is used to add new obligatory attribute;

• – is used to remove selected attribute.

• – is used to edit parameters of selected attribute.

5. To add click the button. The Edit attribute window opens.

Fig. 16. Attribute editing
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6. Click the button to select attribute from attributes list.

Fig. 17. Selection from list of mandatory attributes

A name of autofilled attribute should be the same as a name of attribute.

7. In the Value list select a value to be used for autofilling:Area in project CS orArea
on the reference surface.

A value of the area on the reference surface is calculated only when using coordinate
system matched with WGS-84.

8. Select one of the following area measurement units: project units, sq.m, ha,
sq.km.

9. Click OK.

10. Choose Vectors › Attributes › Automatic attributes filling or click the button
to automatically calculate area in specified measurement units. The value is dis-
played in the Object attributes window and/or as attributes labels (see Sec-
tion 6.3.2).

The polygon square, created or edited after setting autofilling attributes, also could be
displayed. To do this choose Vectors › Attributes › Automatic attributes filling or
click the button. As a result, the area value is displayed for editable polygons, as
well as for “new” polygons, if such polygons are used.

When working with a layer without a classifier, or when using optional attributes of objects, it is
necessary repeat steps 1-10 to display the area of “new” polygons.

6.5. Layer’s semantics check

The system provides possibility to check layer’s semantics. The following parameters
is checking:
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• type, size and accuracy of selected attribute;

• existence of attribute value;

• uniqueness of attribute values set.

The Check semantics window is used to configure parameters of the operation, and
it contains the following buttons:

• – allows to clear the attributes list;

• – allows to add a new attribute and specify semantics check parameters for it;

• – is used to add attribute existing in the list of layer attributes;

• – allows to remove selected attribute from the list;

• – allows to edit selected attribute properties;

• – allows to load the attribute template file;

• – allows to save the attribute list to file for further using as a template.

To perform semantic check, perform the following actions:

1. SelectVectors › Attributes › Check layer semantic. TheCheck semanticswindow
opens.

Fig. 18. The Check semantics window opens.
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2. To add a new attribute click the button. The Attribute editor window opens.

Fig. 19. The Attribute editor window

3. Define the following parameters:

• Attribute name – arbitrary name;

• Type – attribute type; the system supports the following types:

○ integer – attribute of integer type 4 bytes long;

○ float – attribute of real type 8 bytes long;

○ text – text attribute.

• Size (in bytes) – [for number types of attributes] to check the attributes size;

• Precision – [for number types of attributes] decimal places.

4. [optional] to select existing attribute from the list, click the button. The Attributes
selection window opens. Select single or multiple attributes by mouse click and
click OK.

Fig. 20. The window used to select attributes from existing ones
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5. Click to select an attribute from the list and click the button or double-click the
attribute name. The Attribute editor window will open. The attribute parameters
are set similar to the parameters listed in step 3.

6. [optional] To check semantics of selected objects only, set the Selected objects
checkbox on, otherwise, the check operation will be performed for all objects.

7. The Criteria check section is used to select single or multiple criteria to check
layer semantics:

If the specified attribute is absent for object, the system displays error message.

• Check key uniqueness within the layer – the system creates a key (a set of
consecutive parameters) for values of selected attributes and checks uniqueness
of the key value for each object of the layer.

• Check values type – for specified attributes of each object of the layer the system
checks for the compliance of the attribute value to type, size and accuracy;

• Check values existence – for specified attributes of each object of the layer the
system checks for the attribute values other than the default.

As default values for attributes of “text” type is provided an empty string, for attributes
of “float” and “integer” type – “0” value. If the attribute is mandatory, the system also
performs check its default value.

8. Click OK. The system starts operation of layer semantics check. If there are some
discrepancies the system shows warning and the Errors in attributes window
opens. It contains the list of errors found:
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Fig. 21. The Errors in attributes window

During check of the key uniqueness the error message informs about number of objects
with non-unique attributes.

9. Select a line with error in the list by mouse click. The appropriate object (or objects)
select in the layer, marker is moved on a stereopair with the object and is placed
to the object center. Error correction is performed manually in the Objects attrib-
utes window.

6.6. Calculation canopy of forest

The system provides possibility to calculate a value of canopy of trees cover (in range
from 0 to 1) using measuring grid.

To perform canopy calculation perform the following actions:

1. Open a stereopair with the investigated woodland.

2. Select Grid › Create.

3. Press and hold the Shift key to draw rectangular grid for woodland area.

The grid should extend beyond the woodland area

4. Select Grid › Properties and specify the grid step considering image resolution.
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Fig. 22. Measuring grid creation

5. Choose Vectors › Create layer to create a layer without classifier.

6. Create a polygon in such a way that its boundary coincides with woodland bound-
aries.

7. SelectGrid › Create boundaries from vectors. After that grid boundary coincides
with created polygon.
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Fig. 23. Measuring grid creation

8. Make active the Grid layer in the Manager.

9. Choose Vectors › Pathway › Activate or click the button of the Pathway mode
additional toolbar (detailed description of Pathwaymode see in the “DTMGeneration”
User Manual). After that marker is placed to the first grid node.

10. If grid node is on the top of tree, press Enter to create point in this node. Press
Delete to skip a grid node. Passing to the next grid node is performed automatically.

To pass to the previous grid node, press the Backspace key.

11. After passing of all grid nodes the system displays the “Pathway complete”message.

The system also provides possibility to create points on the grid manually in frames of
polygon without pathway mode. At that it is necessary to comply with the positioning accur-
acy of points in XY plane for the grid nodes within 1/3 of the distance between grid nodes.

12. Make active the Vector layer in the Manager.
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13. Choose Vectors › Attributes › Calculate canopy of forest or click the button
of the Vectors additional toolbar.

Fig. 24. Parameters of forest cover canopy

14. To calculate canopy value select Calculate of reticulation nodes – On trees. To
calculate a value inverse to canopy select Calculate of reticulation nodes –
Between trees.

It is better to create points between trees in case of high trees density. In this case choose
Between trees to calculate cover canopy.

15. Click OK. After that the system displays a message with information about value
of forest cover canopy.

Fig. 25. Forest cover canopy value
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7. Topological operations

7.1. Merging of polylines/polygons

The system provides possibility to merge polylines/polygons, spaced apart from each
other or having a common border or overlaps.

To merge two polylines perform the following actions:

1. Select two polylines in 2D-window.

The system provides possibility to merge only two polylines.

2. Choose Vectors › Topology › Merge two polylines (Shift+P) or click the button
of the Topology toolbar.

Selected polylines merge in one, for this a segment adds between two edge vertices
of merging polylines.

To merge two or more polygons that share a border or overlap with each other, perform
the following actions:

1. Select in 2D-window polygons to be merged.

2. Choose Vectors › Topology › Merge polygons (Shift+G) or click the button
of the Topology toolbar.

Selected polygonsmerging to one with the following way: intersection points became
to a vertices of a new polygon, overlapped segments deleting after intersection
points.

If the polygons have attributes with the same names andmandatory attributes, new polygon
is assigned a value of an attribute whose type is the same type as the mandatory attribute.

If merging polygons have attributes with the same names, but does not have mandatory
attributes, new polygon is assigned a value of an attribute of the polygon, which attribute
type is text. Otherwise, new polygon is assigned a value of an attribute of the polygon,
which attribute type is – float, otherwise – integer.

7.2. Splitting polylines/polygons

The system provides the following splitting operations of vector objects of active vector
layer:

• cutting polyline into two in an arbitrary vertex;
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• cutting multiple polygons/polylines of a layer simultaneously using “cutting” polyline.

To split polyline into two ones, perform the following actions:

1. Select polyline in 2D-window.

2. Specify by marker an arbitrary vertex of polyline segment.

3. Choose Vectors › Topology › Split polyline (Shift+X) or click the button of the
Topology toolbar. After the splitting one polyline is divided into two ones in the
vertex closest to marker.

In order to cut several polylines/polygons of the same layer at once using “cutting”
polyline, perform the following actions:

1. Create the “cutting” polyline, that intersects objects to be cut.

The system allows the intersection of linear objects in any vertex, anywhere in any segment.

In order to cut a polyline in several places, cross the polyline as many times as needed.

In order to cut a polygon, cross this polygon through two points, otherwise the operation
will fail.

2. Choose Vectors › Topology › Split polygons/polylines (Shift+I) or click the
button of the Topology toolbar.

After that the “cutting” polyline cuts crossed vector objects by several objects of the
same type. In points of “cutting” polyline crossing the system creates new segments.
After completing the operation the “cutting” polyline is removed.

The system allows to change attribute values of objects, involving to cutting or merging
polylines. To do this in the Settingswindow on Vectors tab set the Set attributes to default
value while objects merging/splitting checkbox on. Source attributes change with the
following values: text – blank string, float – 0.0, integer – 0. If an object has obligatory at-
tribute with the same name, its value is used as default value.

8. Filling the attributes after topological operations
It is possible to populate the default values or delete values of polygon attributes after
performing topological operations.

To do so, select Service › Settings... (Ctrl+Alt+P) or click the button on the main
toolbar. The Settings window opens.
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On the Vectors tab, set the Set attributes to default valuee while objects mer-
ging/splitting checkbox in order to replace the attribute values of the objects involved
in the merging or splitting. The values are replaced with the following: text – empty
string, float – 0.0, integer – 0. If the object has a required attribute with the same name,
its value is used as the default value.

Set the checkbox off to clean up attribute values after the polygons merging/cutting.

Also the system provides possibility to automatic recalculate square of polygons after
editing. To do this use the Vectors › Attributes › Automatic filling layer’s attributes
menu item and the button of the Vectors toolbar.

To perform automatic value recalculation the attribute should has the float type.

9. ForestInterpretation Program
Program ForestInterpretation (further – Program) and this User Manual are designed
to specialists in sphere of remote sensing of forestry.

Program is designed for the purpose of improving interpretation of remote sensing data
based on the probability theory methods and the most informative indicators of forestry.

Analytical interpretation of forest imagery is the main way of obtaining taxation indicators of
forest vegetation and other categories of land based on remote sensing data. An important role
in the interpretation process belongs to qualitative analysis of patterns, which largely determines
the overall reliability of the determination of the taxation indicators of the forest canopy. Existing
methods of analyzing patterns and creating tables based on these patterns are often descriptive
and include a subjective factor, depending on abilities and expertise of the one who is analyzing
the data.

The program is based on statistical analysis of interpretation patterns, meaning that
features of a particular tree are correlated to those of a certain set that identifies a par-
ticular tree species and age group.

The program extends the range of options of the PHOTOMOD system and the PHOTO-
MOD StereoMeasure module in analyzing the most meaningful interpretation patterns
of forest species based on probabilistic approach.

9.1. Functionality of the ForestInterpretation Program

The ForestInterpretation program performs the following tasks:

• Uses available directories or creates new directories of rocks, colors and attributes
for a faster completion of interpretation table;

• Determines the colors and areas of forest stands in semi-automatic mode;
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• Generates a report on the statistical distribution of interpretation patterns, depending
on the tree species.

9.2. Prepare to work
To ensure the correct operation of ForestInterpretation program, MS Excel should be installed.

9.2.1. Installation of the ForestInterpretation Program

1. Install PHOTOMOD or make sure that PHOTOMOD is already installed (see the
“General information” User Manual);

2. Copy ForestConfig.xml to the folder with basic PHOTOMOD settings (default
C:\PHOTOMOD8.VAR\Config);

3. Unzip PhForestDesc_ver_build _x64.zip to the folder with PHOTOMOD installed
in (default C:\Program Files\PHOTOMOD_8_x64);

Number of zip version (ver_build) must correspond to PHOTOMOD version!

4. After completing ForestInterpretationwill be located in PHOTOMODmenu Service.

Fig. 26. Menu “Service”
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9.2.2. Start of work

1. Start PHOTOMOD. Open existed project, create new project or start working in
mode “Without project”;

Fig. 27. Menu “Project Management”

2. Select Service › ForestInterpretation.

9.3. Interface and its elements

A main window is divided into 2 functional parts:

Fig. 28. ForestInterpretation window

• the top part is a main menu that includes submenu Project, Edit, Directories, Help,
as well as buttons Open project, Calculate, Save, Add row, Delete row;

• the bottom part is a table to input values of interpretation indicators
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Table 1. Brief description of main menu of the ForestInterpretation Program

ActionButton
to open previously created attribute table of interpretation indicators;Open project
to start interpretation algorithm and save result in *.xlsx file format;Calculate
to save save attribute table of interpretation indicators in *.xlsx file format;Save
to add row to the attribute table of interpretation indicators;Add row
to delete row from the attribute table of interpretation indicators.Delete row

9.3.1. The “Project” menu

Menu Project enables to perform following operations:

Fig. 29. The “Project” menu

Table 2. Brief description of the “Project” menu

ActionCommand
Open previously created attribute table of interpretation indicators;Open
Start interpretation algorithm and save result in *.xlsx file format;Calculate
Save attribute table of interpretation indicators in *.xlsx file format;Save
Close the program.Exit

9.3.2. The “Edit” menu

Menu Edit enables to perform following operations:

Fig. 30. The “Edit” menu
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Table 3. Brief description of the “Edit” menu

ActionCommand
Add row to the attribute table of interpretation indicators;Add row
Delete row from the attribute table of interpretation indicators.Delete row

9.3.3. The “Directories” menu

Menu Directories contains following submenu:

• Tokens directory;

• Colors directory;

• Breeds directory;

9.3.4. The “Help” menu

Menu Help contains following submenu:

• User Manual;

• About.

9.4. Work with directories

9.4.1. Tokens directory

Tokens directory contains a set of interpretation indicators. Default set includes 9 indic-
ators: Crown color, Crown projection shape, Shadow shape, Crown convexity,
Crown projection size,Gap shape,Gap size, Visibility in depth иGap color. Every
indicator is specified by type (Тext, Numerical or Color). Text indicators have a set of
Values:

Fig. 31. Tokens directory window
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There is a possibility to add new indicators to the Tokens directory and delete existed
indicators from it. To add new indicator make the following:

1. in Tokens directory window press button + and type indicator name. Tokens type
field is opened in the right part of the window;

2. in Tokens type field select one of the type (Тext, Numerical or Color);

While selecting Тext type Values table is opened. It is possible to add new values
and delete existed ones.

• to add indicator value press button + under the Values table and type indicator
value;

• to delete existed indicator select it and press button - under the Values table.

To delete existed indicator select it and press button - under the under the Tokens
table.

Fig. 32. Adding new tokens to the Token directory.

The Program enables to edit existed tokens. To do it make the following:

1. select edited indicator;

2. [option] edit indicator name;

3. [option] change Tokens type;

4. [option] change, add or delete Values of text indicators;
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Fig. 33. Editing tokens in Tokens directory

5. press OK to save changes in Tokens directory. Press Cancel to abort changes
in Tokens directory.

9.4.2. Colors directory

Colors directory window contains a palette of default colors.

Fig. 34. Colors directory window.

The Program enables to add new colors to Colors directory and delete existed ones
from it. To add new color perform the following:

• press button + under Colors table. New window is opened to specify new color and
typing its name. Color specification is performed with one of the four ways:

○ selecting color from the palette;

○ specifying RGB parameters (Red, Green and Blue colors combination);

○ specifying HSL parameters (hue, saturation, lightness);
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○ specifying pixel with necessary color in the image.

Before adding new color with specifying pixel in the image bymouse right button
click it is necessary to specify mouse macros correctly. To do it make following:

1. select Service › Mouse setup in PHOTOMOD menu;

2. select Drag, function in the macros list, selectmouse right button (mouse R)
from the list of available buttons and with pressing +, assign the button to the
macros;

3. save mouse settings with clicking button ;

4. make sure that Drive active option is on;

5. close Mouse setup window.

Fig. 35. Mouse setup window.

• to delete existed color select it and press button - under Color table.

There is a possibility to edit existed colors in Colors directory. To do it make the fol-
lowing:

1. select color to be changed;

2. [option] edit color name;

3. [option] change color with one of the ways mentioned above.
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Fig. 36. Color selection window.

4. press OK to save changes in Colors directory. Press Colors directory to abort
changes in Cancel.

9.4.3. Breeds directory

Breeds directory window contains a list of breeds of trees.

Fig. 37. Breeds directory window

The Program enables to add new breeds to Breeds directory and delete existed ones
from it.

• to add new breed press button +. New line appears in the bottom part of table. Type
breed name in this line.
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• to delete a breed select it in the Breeds directory window and press button -.

There is a possibility to edit breeds in the Breeds directory window. To do it make the
following:

1. select a breed;

2. edit its name;

3. press OK to save changes in Breeds directory. Press Cancel to abort changes
in Breeds directory.

9.5. Work with Attribute table of interpretation indicators

Attribute table of interpretation indicators constitutes a table each line of which
corresponds to one tree or forest area with the same characteristics.

9.5.1. Work with Attribute table of interpretation indicators

To add row to Attribute table of interpretation indicators it is necessary to do the
following:

1. select Edit › Add row. An empty line to be filled appears in Attribute table;

To perform calculation it is not necessary to fill every cell in the row.

2. in the cell one it is possible to select a breed from the list specified in Breeds dir-
ectory;

Fig. 38. Work with Attribute table of interpretation indicators
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All the other cells should be filled in accordance with indicator type.

3. in a Color type cell specify color index from Colors directory;

To assign a color based on image it is enough to click with mouse right button in image
pixel with color in question.

Fig. 39. Work with Color type cells

4. fill Text type cells with selecting value from the list specified in Tokens directory;

Fig. 40. Work with Text type cells

5. fill Numerical type cells with typing numbers.

Fig. 41. Work with Numerical type cells
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The program provides simplified way to specify number while working with images.
E.g. to input Numerical value of distances (Crown projection size, Gap size) make
the following:

• select cells to be filled in the table;

• click with mouse right button in the start point of measured distance and keeping
it move mouse marker to the end of the distance. Numerical value of the distance
is written to selected cell automatically.

Fig. 42. Simplified filling Numerical type cells.

9.5.2. Deleting row from Attribute table

To delete row fromAttribute table of interpretation indicators it is necessary to make
following:

1. select row to be deleted;

2. select Edit › Delete row.

9.5.3. Saving Attribute table

To save filled table select Project › Save.

9.5.4. Work with previously created Attribute tables

The Program enables to work with tables created earlier. To work with previously created
Attribute table of interpretation indicators, select Project › Open. This operation
provides an ability to edit, monitor and complement Attribute tables created earlier.
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9.6. Generating reports

To generate report select Project › Calculate. The report in *.xlsx file format is gener-
ated based on filled attribute table of interpretation indicators.

Fig. 43. Report file in *.xlsx file format
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