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1. Purpose of the document
This document contains detailed information about generation of digital elevation
model (DEM). The document describes creating of regular nodes grid and working with
layers needed for DEM generation points layersf, triangulated irregular network (TIN),
contour lines and DEMs. The document also describes main ways of generation of di-
gital terrain model using these layers.

2. DTM Generation
The system provides possibility of generation of digital terrain model using different
data sets.

Digital Elevation Model (DEM) – digital cartographic presentation of terrain surface both
as regular grid of elevations (DEM) and as triangulated irregular network (TIN).

The following data sets (individually or in combination) are used for generation of digital
terrain model:

• Points – point vector objects, located on relief surface;

• Triangulation Irregular Network (TIN) – one of the models of spatially coordinated
data, used during designing of digital terrain model as elevation points in nodes of
irregular network of triangles, that corresponds to Delaunay triangulation;

• Contour lines – vector lines, that connect points with the same terrain altitude;

• Digital elevation model – digital cartographic presentation of terrain surface as regular
grid of elevation values.

It is possible to acquire data necessary for DTM generation both from central projection
images and from satellite scanner images.

The Terrain menu is used for working with the above mentioned data sets.

2.1. The “Terrain” menu
Table 1. Brief description of the “Terrain” menu

FunctionMenu items
The Points menu contains usual menu items used
for automatic points measurement, filtering, import

Points

and export (see the “Points” chapter of the “Creating
DTM” User Manual)
The TIN menu contains menu items used to load
and save TIN layers, as well as to perform different

TIN

operations on creation, editing and accuracy control
of TIN building
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FunctionMenu items
TheDEMmenu contains standardmenu items used
to load and save DEM layers, as well as menu items

DEM

used to perform various operations on DEM cre-
ation, accuracy control, filtering and editing
allows to calculate a volume (i.e. embankment or
excavation) located between DEM surface and ar-

Compute volumes

bitrary Z-plane or in a more complex case, the
volume which is the overlap between the two
(roughly, “top” and “bottom”) DEM or TIN surfaces.
The Contours menu contains usual menu items
used for contours generating, editing, import and
export

Contours

The LASmenu contains usual menu items used for
converting the LIDAR data to DEM which is saved

LAS

into the file of active profile (see the “LIDAR Data
processing” User Manual)
The 3D-Modmenu allows to runmodule for creation
3d-objects based on 2D-vectors (see the “Three-
dimensional modeling” User Manual)

3D-Mod

3. Regular grid of nodes

3.1. Grid creation

The system provides possibility of regular grid creation with specified step. The grid is
used for points creation in automatic mode with help of correlator or in semi-automatic
pathway mode. A grid step is used as a frequency of nodes creation, in which vicinity
spatial coordinates are calculated and points are created. Moreover, the grid is used
for different operations, such as map creation in stereo quality, DEM generation using
dense model and for other operations (see the chapters Automatic points creation,
Points creation in pathway mode in the “Vectorization” User Manual).

The grid could be created both for the whole images block and for any part of a block
or for selected stereopair. A shape of grid borders could be rectangular or as arbitrary
polygon (or several polygons).

To create a grid select Grid › Create (Ctrl+N, G) or click the button of the main
toolbar. After that a new layer Grid is created in the Layer Manager.

Area of grid creation is determined in one of the following ways:

• in order to create a grid with specified rectangular border, press and hold the Shift
key, and drag by mouse a rectangular area over images block or over selected ste-
reopair;
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• in order to create a grid with arbitrary border, define a grid creation area in group
selection mode ( ) by polygon and while holding pressed the Shift key, specify by
mouse all nodes of boundary of a grid creation area. Complete creation of arbitrary
grid border by mouse double click.

It is possible to use pre-regions for grid area detection.

• to use vector layer polygons as areas of grid creation, perform the following actions:

1. Select Vectors › Create layer to create vector layer without classifier or load
layer with polygons which could be used as a grid boundaries.

2. Create a polygon in such a way that its boundary coincides with boundaries of
area which is used for grid creation.

3. [optional] Select polygons to be used as boundaries for a grid creation, otherwise,
a grid will be created considering all polygons of the layer.

4. SelectGrid › Create boundaries from vectors. After that created grid boundary
coincides with outline of created polygon.

• to create a grid for the whole images block without defining its boundaries, select
Grid › Properties, specify its parameters and click OK. Grid is created automatically
for the entire block and the grid boundary passes over external boundary of block
images.

When a grid boundary is defined the system creates a grid of nodes with specified or
default parameters.

To save created grid in active profile resources use Grid › Save and Grid › Save as
menu items. The grid is saved to the *.x-grid file.

To open existing grid, select Grid › Open. To close a grid, select Grid › Close. To close
all grid layers, select Grid › Close all opened layers.

Right-click menu of the Grid layer in theManager duplicates save and load commands
in the Grid menu, and allows to close a grid layer.
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Fig. 1. Rectangular grid for the whole images block

3.2. Grid parameters

In order to change parameters of created grid, select Grid › Properties. The Grid
properties window opens.

Fig. 2. Regular grid parameters

The Grid properties window allows to setup the following parameters:

• X step and Y step – steps for nodes creation correspondingly by X and Y axes in
meters;

To change a direction of grid nodes tracking in the pathway mode specify negative values
of grid step.
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• Rotation – angle of nodes grid rotation in degrees;

Should be specified for manual work in the pathway mode.

At that, the nodes grid only is rotated. Area of nodes grid creation remains in initial position.

• Z level – a grid elevation above relief level (in meters) for visual correct display of
the grid;

• Ground sample distance (GSD) – shows a value of average pixel size in meters, if
a project contains adjustment results or pixel size is specified for at least one image.

To display a grid with specified parameters click theApply button. To change parameters
click OK.

Fig. 3. Grid created using arbitrary border (with grid rotation)

In order to change grid display parameters double-click on layer objects color button
( ) in a Layer manager. The Layer display settings window opens. It allows to setup
color of grid nodes and borders, as well as a type and size of symbol used to show grid
nodes.
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Fig. 4. Parameters of grid display

Additional parameters of grid display, as well as settings of pathway mode are setup
on the Grid tab of the Settings window (see the ’General system’s parameters’ User
Manual).

4. Points
Points – point vector objects, located on relief surface. Points like other vector layers
are used as a base layer for TIN generation.

4.1. The “Points” menu

The Pointsmenu contains standard menu items used to load, save, import and export
vector layers, as well as to perform specific operations with point objects (creation and
filtering).

The Points menu is located in the Terrain menu.

Table 2. Brief description of the ’Points’ menu

FunctionThe Points menu
allows to load vector layer from *.x-data fileLoad (Ctrl+O, V)
allows to perform the quick access to recently
loaded vector layers

Recent

allows to save or rewrite active vector layer as file
with *.x-data extension

Save

allows to save active vector layer with new name
as file with *.x-data extension

Save as...

allows to save just selected vector objectsSave selected as...
allows to close vector layerClose
allows to calculate points automatically using correl-
ator in overlap areas of stereopair images by regular
nodes grid

Compute points automatically

contains items used for semi-automatic points cre-
ation using regular grid

Pathway

contains items used for deletion, correction or recog-
nizing points which have fallen on buildings, trees,

Filter
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FunctionThe Points menu
cars, in pits, etc. during automatic points calculation,
and for filtering of accident surges
contains items used to import vector layers from
files with different extensions (see the “Import of

Import

vector objects” chapter of the “Vectorization” User
Manual)
contains menu items used to perform export of
vector layers to different formats (see the “Export

Export

of vector objects” chapter of the “Vectorization” User
Manual)

4.2. Points creation

4.2.1. Points creation modes and methods

The system allows the following modes of points creation:

• manually in stereomode – points are added manually in stereomode using correlator
or without it;

Correlator’s parameters are setup in the window of general system’s settings on the Correl-
ator tab (see the ’General system’s parameters’ User Manual).

• in semi-automatic pathway mode with preliminary creation of regular nodes grid –
that means sequenced passing of all nodes of regular grid and adding of points
manually using correlator or without it, or skipping a node and passing to the next
one;

Correlator’s parameters are setup in the window of general system’s settings on the Correl-
ator tab (see the ’General system’s parameters’ User Manual).

• in automatic mode with preliminary creation of regular nodes grid. At that in grid nodes
vicinity the system calculates points spatial coordinates with help of correlator and
creates points if the coordinates are calculated successfully. In automatic mode the
system passes grid’s nodes specified number of times with different correlator para-
meters, performs accuracy control, points filtering, and saves quality evaluation.

For automatic points calculation correlator’s parameters should be adjusted in the Compute
points window.

4.2.2. The “Pathway mode” toolbar

For work in pathway mode the system provides the Terrain › Points › Pathway mode
menu items, that are partially duplicated by thePathwaymode additional toolbar buttons.
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Table 3. The ’Pathway mode’ toolbar

FunctionButtons
allows to turn on/off pathway modeActivate
allows to add point to current nodeAdd point (Enter)
allows to bypass a node (without adding point) and
to pass to the next node

Bypass point (Delete)

allows to return to the previous node (without point
deletion)

Return (Backspace)

allows to move marker to current active grid nodeMarker to current grid node
allows to move marker to nearest grid node of
markers current position. The node becomes active

To nearest grid node

automatically (provided that marker is inside grid in
geodetic coordinate system), that allows to start
passing points manually
allows to move marker to left lower grid node and
to make the node active

To first grid node

allows to turn on sequential mode of grid passing
by rows

Mode: scan rows

allows to turn on sequential mode of grid passing
by columns

Mode: scan columns

allows to turn on ’zigzag’ mode of grid passing by
rows

Mode: ’zigzag’ by rows

allows to turn on ’zigzag’ mode of grid passing by
columns

Mode: ’zigzag’ by columns

opens the system settings window on the Pathway
mode tab to setup the mode parameters (see Sec-
tion 4.2.4)

Settings

4.2.3. Points creation in pathway mode

For semi-automatic points creation using regular grid the system provides Pathway
mode.

In the pathway mode the system passes grid nodes in such a way that XY coordinates
of points are measured uniformly. Marker XY coordinates are preserved while passing
from one grid node to another, and elevation is measuredmanually. Points measurement
in pathway mode is possible both using correlator or without it.

The first coordinate of marker elevation during passing to the first node corresponds to
grid level by Z, specified in theGrid properties. Marker’s elevation level during passing
to each next node is defined by settings.

Points adding in pathway mode is performed in stereomode in stereopair 2D-window.

If a grid is created for the entire images block, the system allows to setup automatic pass to the
next stereopair while passing nodes. To do this use the window of general system’s parameters
on the Pathway tab.
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To create points in pathway mode, perform the following actions:

1. Create a grid for required area of points creating.

2. Create or make active a vector layer for points creation.

3. Choose Terrain › Points › Pathway › Activate or click the button of the Pathway
mode additional toolbar. Marker will be placed to left lower grid corner – start point
of passing.

If grid node was not created before, it is created automatically for the whole images block.

When the grid layer is closed the pathway mode is turned off automatically.

4. Select a direction of grid nodes passing using Terrain › Points › Pathway menu
or using buttons of the Pathway mode additional toolbar.

5. ChooseWindow › New 2D-window (stereopair) (Ctrl+Alt+L) or click the button
of the main toolbar. The stereopair 2D-window is opened and allows to start grid
nodes passing.

6. [optional] For image automatic centering by marker during passing to the next grid
node turn on the Fixed marker mode. To do this click the button or use the F6
hotkey.

To vectorize objects during grid nodes passing in pathway mode, turn the Fixed marker
mode temporarily off.

7. Click the to turn on stereo mode in 2D-window of a stereopair.

To work in pathway mode it is necessary to turn on the mode of point objects creation –
using the button of the Vectors additional toolbar.

8. To perform grid nodes passing the system provides the following tools:

• to add point to current grid node manually, set marker elevation using mouse
wheel and press Enter;

• to add point to current grid node using correlator, press Space key to set marker
elevation using correlator and press Enter;

After the point is addedmarker moves to the next grid node according to selected passing
direction.
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• to pass to the next node without adding point, press Delete key;

• to pass to the previous node without adding point, press Backspace key.

To delete point use the Ctrl+Z hotkeys. It is possible to delete points, only if history of
recent operations is turned on and cancelling of these operations is allowed (see the
Undo settings chapter in the ’General system’s parameters’ User Manual).

9. After passing of the last grid node the system displays the Pathway complete
message. Click OK. Save the vector layer with acquired points set for further use.

To memorize a position of the current active node during passing, save the grid layer.

To continue grid nodes passing form current position, perform the following actions:

1. Load saved grid layer.

2. Choose Terrain › Points › Pathway › Activate or click the button of the Pathway
mode additional toolbar. After that a grid node which was active at the moment of
the layer saving, becomes active automatically.

3. Place marker to vicinity of the active grid node.

4. Choose Terrain › Points › Pathway › To nearest grid node or click the button
of the Pathway mode additional toolbar, to move marker to the nearest node.

5. Go on to pass grid nodes.

4.2.4. Parameters of pathway mode

To specify preliminary parameters of work in pathway mode, perform the following ac-
tions:

1. Choose Terrain › Points › Pathway › Settings. The Settings window is opened
on the Pathway tab (see the detailed description of general system settings in the
’General system’s parameters’ User Manual).
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Fig. 5. Parameters of pathway mode

2. Choose one of the ways of specifying marker position by Z when pass to next grid
node:

• Do not change – marker position by Z is not change, i.e. Z-coordinate of marker
in previous grid node is used;

• Z from grid – marker position by Z is set equal to Z level of grid, defined in the
Grid properties window;

• Value – marker position by Z is set equal to the value specified in this field (in
meters).

3. [optional] The Limit grid area in stereopair 2D-window checkbox is set on in the
system by default, that allows to setup passing grid nodes in pathway mode only
in borders of stereopair regardless of grid size.

It is not recommended to set the Automatically change stereopair checkbox on while
the Limit grid area in stereopair 2D-window checkbox is set on, since it leads to work
with incorrect data.

4. [optional] In order to pass nodes of ’global’ grid with automatic stereopair change,
set the Limit grid area in stereopair 2D-window checkbox off and set the Auto-
matically change stereopair checkbox on. Besides, the Threshold parameter
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also has influence on automatic stereopair change. The parameter specifies a dis-
tance from stereopair border in percent of the whole stereopair size, and when this
distance is reached during passing nodes in pathwaymode the stereopair is changed
to the next one in 2D-window.

4.3. Points automatic calculating

4.3.1. Automatic calculating of points

The system provides possibility to calculate points automatically using correlator in
overlap areas of stereopair images by regular nodes grid.

All selected stereopairs should be located to adjusted part of a block (see “Block adjustment”
User Manual), otherwise, points calculation is not performed or is performed incorrectly. In the
first case the system displays error message, in the second one – it is not possible to match
calculated points to project coordinate system.

For the satellite scanner imagery projects, the stereoscopic processing is to be carried our
during the adjustment. (see the “Adjustment of scanner blocks” chapter of the “Block adjustment”
User Manual).

Acquired points are used as a vector base for DEM generation. Additional possibilities
of points editing allow to obtain vector base for TIN creation and DEM generation.

The principle of automatic points calculation is as follows. For each selected oriented stereopair
the system performs automatic pass of all grid nodes, located in overlap area of stereopair im-
ages, and tries to calculate spatial coordinates in vicinity of each grid node using correlator.

In case of successful correlation the system performs accuracy control of each found point’s
coordinates, and after that the point is either added to vector layer as point object, or is excluded
(see Accuracy control with reverse stereopair checkbox). If the system fails to calculate
spatial coordinates in vicinity of some grid node, the node is skipped and the system passes to
the next node.
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Fig. 6. Automatic points calculation in arbitrary area

Prior to start of automatic points calculation perform the following preparatory actions:

1. Define search area: select block stereopairs where to perform automatic points
calculation.

2. Create regular nodes grid for selected search area.

3. Select Terrain › Points › Compute points automatically. The Compute points
window opens.

If a grid not was not created, it is created automatically for the entire images block and the
Grid properties window opens, that allows to specify grid parameters.
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Fig. 7. The ’Compute points’ window

4. In theCorrelator preset section select in the list one of the following types of terrain:

• mountainous terrain;

• urban area;

• desert;

• rural area;

• rural area 2.

To view and edit parameters values and to setup correlator configuration the list, to create
new or delete configurations from the list click the button.

5. In the Search area section specify a search area, which will be used for automatic
points calculation:

• All images – allows to select all images of a block;

• Selected images – allows to select block images highlighted in 2D-window;

To view and change a set of highlighted images in block 2D-window click the button.
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• Active stereopair – allows to select images of a stereopair opened in active 2D-
window.

All selected stereopairs should be located on adjusted part of a block (see ’Block adjust-
ment’ User Manual), otherwise, points calculation is not performed or is performed incor-
rectly. In the first case the system displays error message, in the second one – it is not
possible to match calculated points to project coordinate system.

6. [optional] To pass each grid node only once during calculation, prior to define
parameters it is necessary to create pre-regions, set theUse pre-regions checkbox
on and select pre-regions layers in the list.

Binding of pre-regions and stereopairs is performed using region_image_code and region_im-
age_code_2 attributes.

7. [optional] Points calculation is performed by default for in-strip stereopairs. To cal-
culate points for interstrip stereopairs, formed by selected images set the Process
interstrip stereopairs checkbox on.

8. [optional] To filter blunders by Z on images with intersection angle of small or null
value, set the Limit intersection angle checkbox on and define a value of minimal
angle using the slider.

The system allows to estimate the intersection angles in the stereopairs of the project (see
the “The list of stereopairs for a selected image” chapter in “Creating project” User Manual
and the “Creation of “stereo quality” map” chapter in “Vectorization” User Manual).

9. [optional] In the Grid section the Area of the grid layer in m2, as well as Appr.
nodes count in a grid are displayed in appropriate fields. To change a grid layer
parameters click the Properties button.

To change grid boundaries it is necessary to close the Compute points window.

10. In the Initial approximation the method of calculation of the elevation range of
points with the search for the correlator:

Initial approximation defines a value of Z coordinate of grid node, that is used to calculate
initial coordinates of point on the left and right images of a stereopair.

Selection of the most preferable method to calculate elevation range for point search de-
pends on available data on the terrain (degree of terrain roughness, character of a region
of search where automatic calculation of points takes place).

• Stereopair elevation range – the elevation range is calculated for each stereopair
with heights of points, previously measured in the project;
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• Project elevation range – the elevation range is obtained from the Relief elev-
ation values in project properties or it is calculated with heights of points, previ-
ously measured in the project;

• Mean stereopair elevation –mean elevation of each stereopair, calculated using
exterior orientation parameters, is used as initial approximation;

• Fixed elevation – input elevation value in meters to be used as initial approxim-
ation;

• Triangulation points – allows to calculate the elevation range for each stereopair
from a smooth model built by project triangulation points;

• DEM – a value of elevation of selected DEM in point with XY coordinates of grid
node is used as initial approximation.

If grid node falls into null cell of DEM, the system uses average elevation of cor-
responding stereopair. To select DEM in active profile resources click the
button.

To specify value of acceptable deviation of Z-coordinate of calculated points from
initial approximation and input value in meters to the Maximal shift field.

11. [optional] There are the following options in the Additional settings section:

• Save quality assessment to attributes – allows to save quality assessment of
points calculation as attributes of point vector object. Quality assessments are
saved to the following object attributes:

○ ’corr’ (double) – correlation coefficient, number in range from specified correl-
ation threshold up to 1;

○ ’aq’ (double) – auto-correlation sigma;

○ ’std_dev’ (double) – standard deviation;

○ ’pass’ (int) – number of passes;

○ ’disp’ (int) – dispersion value.

To view values of attributes of points calculation quality select the point and
chooseWindow › Object attributes. The Object attributes window opens.
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Fig. 8. Quality assessments of calculated point

• Delete redundant points – allows to thin nearest points, acquired during passing
the same grid nodes on different stereopairs;

Thinning is performed after completion of points calculation operation according to
specified radius value, set by used correlator configuration.

When the Save quality assessment to attributes checkbox is on, points with minimal
correlation coefficient (minimal value of ’corr’ attribute) are removed from several found
nearest points.

• Random points distribution – allows distribute points randomly in area of half-
size of grid cell from grid node;

• Accuracy control with reverse stereopair – allows to check results of found
point on a reverse stereopair; if results do not the same, point removes;

12. In the Destination section define parameters of loading and saving of calculated
points:

• Load into vector layer – allows to load points into active vector layer;

If there is no active vector layer, points are loaded to a new vector layer.

• Save into resources – allows to save points into active profile resources without
loading. Click the Settings button to specify parameters of points saving. The
Settings for saving points window opens.
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Fig. 9. The ’Settings for saving points’ window

To save points in one vector file of active profile perform the following actions:

1. Select the Save into one resource option and click the button. The
Save window opens.

2. Select a folder in the active profile resources and input a name of vector file
in theResource name field. Click OK to create a new vector file and to return
to the Settings for saving points window.

3. The input field of the Settings for saving points window shows path and
name of new vector file. Click OK to return to the Compute points window.

To save points in parts into several vector files of active profile perform the follow-
ing actions:

1. Choose the Split into parts option.

2. Select one of the ways of points splitting – By rectangular sheets and input
a size of rectangular area in meters or By stereopairs.

3. Input path to save file to the Save in folder field or click the button, to
select name and path in active profile resources to save points in parts to
corresponding vector files and click OK.

4. The input field of the Settings for saving points window shows path and
name of new vector file. Click OK to return to the Compute points window.

13. Click OK. The points calculation operation starts.

In some cases operation of automatic points calculation takes a lot of time.

To setup points calculation in distributed mode click the Distributed processing
button and specify parameters of tasks distribution.
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4.3.2. Correlator configurations

Correlator configuration – is a script of points calculation operation, that defined a
number of passes of regular grid nodes and a set of correlator parameters for each
pass.

TheCorrelator configurationwindow is used to form a list of correlator’s configurations.
In order to open the window click the button in the Correlator configuration panel
of the Compute points window.

Fig. 10. The ’Correlator presets’ window

The left part of the window displays a list of all created correlator configurations. Default
list includes standard correlator configurations with fitted values of parameters for the
following terrain types:

• mountainous terrain – for automatic points calculation on images with mainly moun-
tainous terrain with big elevation differences;

• urban areas – for automatic points calculation on images with mainly urban type of
build-up;

• desert – for automatic points calculation on images with monotonously deserted terrain
with rare vegetation;
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• rural area – for automatic points calculation on images with rural areas with with minor
amounts of buildings and infrastructure;

• rural area 2 – for automatic points calculation for ’rural’ area with heterogeneous parts
of relief. If there are images with big intersection angle the configuration uses a mask
of larger size. Accuracy of points calculation is less then when using rural area type.

The right panel of the window contains the following buttons for managing correlator’s
presets:

• Create new – allows to specify name and parameters to create new configuration of
correlator;

• Edit – allows to edit parameters of correlator’s configuration selected in the list;

• Copy – allows to create a copy of selected correlator’s configuration with different
name, but with the same parameters;

• Rename – allows to rename selected correlatior’s configuration;

• Delete – allows to delete selected correlatior’s configuration;

Preset configuration couldn’t be changed or removed.

• Close – allows to close the Correlator presets window.

4.3.3. Setup of correlator configuration

To view and setup correlator’s configuration the system provides the Edit presetwindow,
which is opened in the following cases:

• while editing of existing configuration select configuration in the list of the Correlator
presets window and click the Edit button;

• while creating new configuration click theCreate new button, input new configuration
name and click OK.
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Fig. 11. Window of correlator passes parameters

Setup of correlator configuration in the Edit preset window includes defining of script
of automatic points calculation.

Depending on terrain type the script could include both single andmultiple passes of grid nodes,
it is possible to specify particular set of correlator parameters for each of them.

For correlator configuration setup perform the following actions:

1. Create a list with required number of correlator passes.

Passes in the list are placed according to their order of use during automatic points calcu-
lation.

To form the passes list the following buttons are provided:

• – allows to add new pass to the end of list;

• – allows to delete selected pass;
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• – allows to move selected pass down the list;

• – allows to move selected pass up the list;

• – allows to return settings to default.

2. Select correlator pass in the list to setup its parameters.

3. In the Pass section setup the following main correlator parameters for a pass se-
lected in the list:

• Correlation mask halfsize – half of linear size of rectangular correlation mask
in pixels by X and Y axes;

Increasing the mask size increases recognition quality for smooth relief and decreases
influence of tiny details on terrain surface, however, it decreases total amount of acquired
points. Besides, during processing imagery with low-contrast areas, which correspond
to sloping grounds (fields or lawns on hill slopes, for instance), the system may add
points that correspond an edge of mask, rather than center.

• The Increase search area parameter allows to specify a number of pixels to in-
crease search area more than defined value of correlation mask size;

Increasing of search area is used, when considering stereopair orientation data the es-
timated search area of corresponding point on the right images is insufficient (no tie
points enough on high-rise objects or in stereopair corners, for instance). It is necessary
to increase search area by Y in case of poor accuracy of stereopair relative orientation.

• Correlation threshold – minimal acceptable value of correlation coefficient;

Value of correlation threshold depends significantly both on material and other paramet-
ers. For correct work of correlation algorithm it is recommended to setup the value not
less than 0.7.

• Contrast point search area – a size of area around grid node, where the system
performs search for a point with maximal contrast prior to correlation operation;

It is recommended to increase this value for images with well-defined contours of objects,
and to decrease it for low-contrast (fuzzy) areas, where there is high probability of cor-
relator errors.

• Control autocorrelation and Maximum autocorrelation radius – is used to
control point’s autocorrelation – degree of point’s uniqueness in some its vicinity
on the left image.
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Themore the autocorrelation radius, the less distinctive is the point and themore probable
is incorrect matching of the point with the right image, including cases with high correlation
coefficient.

The More button is used to setup additional parameters of selected pass.

4. In theMiscellaneous section setup the following additional parameters of correlat-
or’s pass:

• Redundant points filter radius – is used to filter nearest points, acquired during
passing the same grid nodes on different stereopairs;

Points thinning is performed after completing of points calculation operation, considering
specified value of the radius in meters.

• Compute first approximation – allows to use results of preliminary points cal-
culation, which parameters are setup using the Settings button;

It is recommended to perform preliminary calculation for automatic search for points on
satellite scanner images.

• Unused image border (in percent) – allows to not consider specified percent of
image edges during points calculation;

• Maximum vertical parallax – allows to specify a limit for points filtering by ver-
tical parallax value (in pixels).

Point acquired as a result of correlation has 4 coordinates – (XL,YL) on the left image and

(XR,YR) on the right image. To calculate vertical parallax the system performs transform-
ation of images coordinate system into project coordinate system and vice versa. As a

result two pairs of new coordinates are acquired (XL2,YL2) and (XR2,YR2) . In this case

parallax is calculated as YPAR = (YR − YL) − (YR2 − YL2) . Points with the value more than

specified YPAR are rejected. This parameter should be selected experimentally, espe-
cially for scanner survey projects.

5. Click OK to complete setup of correlator configuration parameters.

4.3.4. Additional correlator’s parameters

To setup additional parameters of correlator for selected pass in the Edit presetwindow
there is the More button, that allows to open the Additional settings: window Pass #.

28

DTM GenerationPHOTOMOD 7.5



Fig. 12. Additional parameters of selected pass

The Autocorrelation settings section allows to specify additional parameters of auto-
correlation:

• Mask halfsize – half of linear size of mask for auto-correlation in pixels by X and Y
axes. Default value – 10x10 pixels;

• Search area halfsize – a halfsize of area, where auto-correaltion surface is created.

The Contrast settings section allows to consider contrast for low contrast images. Set
the Minimum mask contrast checkbox on and specify the following parameters:

• Mask halfsize – a halfsize of area around a point, where the system performs contrast
calculation;

• Minimum contrast – value lies in range from 0 to 100.

The Overview level parameter allows to perform correlation between thinned images
and is used in the following cases:

’0’ value corresponds to initial image, in other cases that system uses the level of the pyramid
with a specified number.

• for film data with coarse grain, which prevent from reliable operation of correlator;

• on relief surface like fields, that in initial detalization have occasional irregular items
(grass, small bushes), or regular pattern (new-ploughed field). When zoom out such
a terrain surface, the textures comparable on the left and right images appear;

• to exclude small objects on relief (bushes, separate trees, buildings). In this case,
the thinning together with increasing of mask size leads to the fact that even if the
center of the mask falls onto the protruding object, the resulting Z-coordinate of point
corresponds to the surrounding terrain elevation.
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As the passes of the same calculation process, it is advisable to use a correlator con-
figuration differing by no more than one level of the pyramid (for example, 0 и 1; 2 и 3).
Otherwise, in areas of fine detail (in particular, buildings), it is possible to receive the
’chess’ grids of alternating points at the height of the object, and at the height of the
relief.

TheMultilevel correlator checkbox allows to use different levels of pyramid for correl-
ation during search for corresponding points.

4.3.5. Parameters of first approximation calculation

The system provides possibility to use first approximation of digital terrain model during
correlator passes. Such DTM is a TIN, generated using thinned points set.

DTM of first approximation allows to significantly reduce the search area for each point of the
main operation, i.e. to reduce the total search time and reduce the probability of erroneous
points occurrence.

In correlator’s preset configurations first approximation calculation is used for ’mountainous
terrain’ configuration.

To use and configure calculation parameters of first approximation DTM, perform the
following actions:

1. In the Edit preset window set the Compute first approximation checkbox on.

2. Click the Settings button. The First approximation for: window opens ’configur-
ation name’.
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Fig. 13. Parameters of first approximation calculation

3. Specify the First approximation DTM step to define a step of DTM to be created.

4. [optional] To use threshold filtering during DTM creation set the First approximation
DTM filter threshold checkbox on.

Specify a value that corresponds to threshold of filtering of intermediate TIN by
minimum angle of inclination of the normal, given to a range of (0;1).

5. Set the maximum deviation from calculated DEM by Z in both directions.

6. The Correlator passes list and parameters in the Pass section allow to define
correlator configuration for preliminary points calculation (see a description of the
main parameters in the Section 4.3.3).

The More button allows to setup additional parameters of selected pass.

7. Click OK to return to the Edit preset window.
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4.3.6. Points calculation in distributed processing mode

To calculate points in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the ’Distributed
processing’ chapter in the ’General information about system’ User Manual).

2. Select Terrain › Points › Compute points automatically. The Compute points
window opens.

If a grid not was not created, it is created automatically for the entire images block and the
Grid properties window opens, that allows to specify grid parameters.

3. Setup parameters of automatic points calculation.

4. Click the Distributed processing button. The Compute points Distributed Pro-
cessing window opens.

Fig. 14. Parameters of distributed processing of points calculation

5. In the Split into tasks section select a way of splitting of processing operation into
tasks:

• By stereopairs – allows to process each stereopair in a separate task;

Since tasks are executed independently from each other, the system doesn’t remove
points, falling into the same grid nodes from different stereopairs (for example, during
filtering of nearest points).

• By rectangular sheets – it is necessary to specify in the fields a size of rect-
angles, into which the entire search area is split (in meters). Filtering of nearest
points is not performed in this case. The result of each task processing is saved
to the file with name like Sheet_X_Y.x-data.

Rectangle, circumscribing grid boundaries in project coordinates system, is split by
rectangular sheets of a size specified in the fields. Each sheet includes images parts
from all stereopairs, into which it falls.
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If stereopairs are processed in separate tasks, after that it is necessary to perform manual
data correction. Calculated points are saved in resources, named by stereopairs names.

The Tasks number for computing points field displays calculated number of
tasks depending on selected way of workflow split and/or size of specified areas.

By default По умолчанию задается вложенная папка в папке \Data текущего проекта.

It is not possible to define number of tasks manually.

6. In theWorking folder section click the button and select empty folder in active
profile resources to save output DEM.

Before operation is performed all data from selected folder is removed. It is strongly not
recommended to specify a project folder as a working folder, especially when there are no
saved project backups.

7. Click OK. Distributed processing tasks are created and the system shows amessage
about number of created tasks.

When using distributed points calculation, the result of each task is saved to separate file
with tsk extension in specifiedWorking folder of a project.

4.4. Points editing

The system provides possibility of editing of single or multiple selected points. Since
points calculated automatically are points, all operations of points editing are applicable
to them.

To select vector objects manually in active vector layer the system provides the following
features:

• mouse double click or the S key to highlight single polyline/polygon;

• mouse click to highlight point/vertex (place marker in point’s vicinity in advance);

• selection mode Rectangle to select vector objects inside a rectangle;

• selection mode Polygon to select vector objects inside arbitrary polygon.

To highlight objects on active vector layer inside a rectangle choose Edit › Group se-
lection › Rectangle or click the button of the Tools toolbar. Press and hold the Shift
key and drag a rectangle by mouse.
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To highlight objects inside arbitrary polygon choose Edit › Group selection › Polygon
or click the button of the Tools toolbar. Press and hold the Shift key. Then make
mouse click to create the first polygon vertex and a ’rubber line’ directed to current
cursor position. Input subsequent vertices bymouse clicks. To complete objects selection
by polygon use mouse double click. To break off selection, press the Esc key.

For quick switching between Polygon and Rectangle selection modes there is context menu
opened by the Shift+F10 hotkeys.

To select all objects of active vector layer choose Edit › Select all or use the Ctrl+A
hotkeys.

See detailed description of selection tools and modes in the ’Vector objects selection’ chapter
of the ’Vectorization’ User Manual.

To add a new point to active vector layer, perform the following actions:

1. Choose Edit › Vectors create mode › Points (P) or click the button of the
Vectors additional toolbar to turn on points creation mode.

2. Place marker to selected point on image in 2D-window.

3. Press the Insert key to add a point without correlator on specified elevation.

The system also allows to place marker on a model surface automatically using
correlator. The Space key is used to do this.

If the correlator failed to work the Status panel displays the Bad point message and the
system produces warning audio signal (see the ’General system’s parameters’ User
Manual).

Besides the system provides possibility to delete points, located nearer from linear
vector objects than specified distance (see the ’Vectorization’ User Manual).

The system provides possibility of vector objects topology control, i.e. search for duplic-
ated points or points coinciding with vector objects vertices. For this the Vectors › To-
pology › Verify topology menu item is used (see the chapter ’Topology verifying’ of
the ’Vectorization’ User Manual).

4.5. Points filtering

The system provides deletion, correction or recognizing points which have fallen on
buildings, trees, cars, in pits, etc. during automatic points calculation, and filtering of
accident surges.

In this document all points not lying on the relief surface (average smoothed terrain
surface), are called surges.
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To edit automatically calculated points the system provides the following filters:

• Points thinning – thinning out of densely located points with specified level of thinning;

• Filter by Z-range – filtering points and vertices of polylines/polygons, which Z-coordin-
ate is out of specified range;

• Median Z filter – filtering points and vertices of polylines/polygons using mask of
specified size;

• Filter adjacent point objects – filtering of closely located points (located nearer than
specified distance);

• Buildings and vegetation filter – filtering points, which have fallen on tall objects
(buildings, trees) or in pits to obtain layer of points, describing only terrain relief;

• Surface objects filter – filtering points, which have fallen on particular tall objects or
pits of specific size.

• Filter by image properties – filtering objects depending on parameters of raster image.
During preparatory stage (called “learning”) an operator selects specific image areas
manually, serving as a reference samples for the filtering operation.

The set of filters used for points editing partly coincides with vector object filtering instru-
ments (Vectors › Filter, see the “Vector objects filtering” chapter of the “Vectorization”
User Manual).

4.5.1. Points thinning

The system provides possibility of removing of some part of automatically calculated
points, located densely or close to each other. For this there is points thinning feature.

To perform points thinning perform the following actions:

1. Select Terrain › Points › Filter › Thinning. The Points thinning window opens.

Fig. 15. Points thinning parameters

2. Specify degree of points thinning out in percent using the slider.
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3. Click OK. After that the system removes specified percent of points, in order of their
influence on quality of relief representation (the least significant points are removed
first).

4.5.2. Points filtering by Z-range

The system provides possibility to remove points and vertices of polylines/polygons,
which Z-coordinate falls outside specified range.

To perform objects filtering of active vector layer by elevations range, execute the fol-
lowing actions:

1. Select Terrain › Points › Filter › Filter by Z-range. The Z-range filter window
opens.

Fig. 16. Parameters of points filtering by Z

The Layer field displays a name of selected active vector layer, the Zmin and Zmax
fields show terrain elevation difference in meters, calculated by all layer objects.

2. The Filter range section by default shows values of calculated terrain elevation
difference. Specify maximal and minimal Z values in meters to consider for points
filtering.

3. Click OK. Filtration removes all points and vertices of polylines/polygons, which Z-
coordinate falls outside specified range. When the filtering operation is completed
the system displays information message about number of deleted points.

Check and filtering by Z-range is also possible during automatic points calculation.

4.5.3. Median points filtering by Z

The system provides possibility of median filtering to remove single sharp spikes in
presence of smooth relief.

The median filtering contains the following sequence of actions:

1. Sequential scanning of area with vector objects by window-mask. Scanning step
is specified as window-mask halfsize.
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2. Deleting points which elevation is out of range.

The range is calculated as average level of vectors elevation that fall into mask. When
calculating the range the system considers specified deviation from average level.

To execute median filtering perform the following actions:

1. Select Terrain › Points › Filter › Median Z-filter. The Median Z filter window
opens.

Fig. 17. Parameters of median points filtering

2. In theMask size field specify a side size of scanning square window-mask in meters.

3. In the Threshold deviation from the mean level field specify deviation by Z in
meters from mean level of objects elevation in the mask.

4. Click OK. Filtration removes all points and vertices of polylines/polygons, which Z-
coordinate falls outside specified range. When the filtering operation is completed
the system displays information message about number of deleted points.

4.5.4. Filter of adjacent point objects

Filter of adjacent point objects allows to remove points, in which vicinity there are other
objects located closer specified distance.

To filter adjacent points on active layer perform the following actions:

1. Select Terrain › Points › Filter › Filter adjacent point objects. The Filter adjacent
point objects window opens.

Fig. 18. Parameters of adjacent point objects filter
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2. Specify the Radius – maximal distance in meters to each point, and if a points falls
closer that the radius value, the points is deleted.

3. [optional] In order to delete from two points just one which contains the smallest
value of one attribute (for example, if points vector layer was created in automatic
points calculation mode with preserving of quality assessment in attributes), set the
From a group of adjacent objects, delete thosewith lesser value of the attribute
checkbox on and select in the list an attribute to be considered during points removal.

4. Click OK. Filtration removes points, between which the distance is less than spe-
cified. When the filtering operation is completed the system displays information
message about number of deleted points.

4.5.5. Buildings and vegetation filter

The system provides deletion, correction or recognizing points which have fallen on
buildings, trees, cars, in pits during automatic points calculation, and during filtering of
accident surges. For that filter of buildings and vegetation id used. After its work only
points that describe terrain relief are remain in the system.

In this document all points not lying on the relief surface (average smoothed terrain
surface), are called surges.

Filter of buildings and vegetation allows to apply step-by-step points filtering using
particular script, i.e. to apply points filtering in multiple passes with different parameter
sets.

It is possible to develop customized script of filter workflow or to use default script. Creating
script of buildings and vegetation filtering means specifying of passes set, order of their passing
and setup the parameters for each pass.

Step-by-step filtering allows to achieve optimal results of objects filtering on any type
of terrain to acquire points, that correctly describe terrain relief, and that could be used
to generate high quality DEM.

By default, the system uses standard script that includes three passes in the following
order:

1. Basic – main pass with parameters configured for filtering points not lying on the
relief surface (surges). On this step the system rejects majority of points on buildings,
and also correlators blunders (sharp spikes).

2. Additional – additional pass with parameters configured for searching surges,
missed during basic step.

3. Detailed (off by default) – the pass with parameters configured for filtering points
located on low objects, such as small buildings, cars, and so on.
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After filtering the system may perform the following actions with points found (surges):

• rejecting surges from initial points layer;

• correction of surges found on initial points layer, that means editing of surges Z-co-
ordinates;

• search for surges to analyse them with saving of found points to new vector layers
without changing initial points layer.

Fig. 19. Parameters of buildings and vegetation filter

The Buildings and vegetation filter window allows to specify filtering parameters and
setup a number of filter passes. The Layer field displays a name of active vector layer.
The window contains a standard toolbar.

FunctionButtons
allows to load a script of filter work from *.x-filter
resource located out of active profile resources
allows to load a script of filter work from *.x-filter
resource located in active profile resources
allows to save a current script of filter work to *.x-
filter resource located out of active profile re-
sources
allows to save a current script of filter work to *.x-
filter resource located in active profile resources
allows to cancel all changes made to a script
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FunctionButtons
allows to go back to a standard script that includes
two passes with default settings (regardless of which
script has been loaded)

To filter objects on surface perform the following actions:

1. Load points for filtration or make active a points layer.

To avoid loss of data, it is recommended to use a copy of initial layer during filtering.

To create a copy select Terrain › Points › Save as and specify new name of points file.

If a layer contains linear or area vector objects the filter may not work properly.

2. Select Terrain › Points › Filter › Buildings and vegetation filter. The Buildings
and vegetation filter window opens.

Fig. 20. Parameters of buildings and vegetation filter

3. [optional] In order to use filtering for selected objects (points group), set the Filter
selected objects only checkbox on. Otherwise, filter is applied to all points of the
layer.

To filter a group of points, select it by mouse in 2D-window prior to start configuring the
buildings and vegetation filter.
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When using filter for selected objects only, it is not recommended to set the Remove near
the border option in the Untestable points section.

4. [optional] To increase the filtering operation performance set the Copy points to
new layers before removing or correcting checkbox off. By default, the system
saves removed or corrected points in new vector layers used for analysis of filtering
results. These layers could be used to restore basic points layer (using operation
of layers merging), if the copy of initial points layer was not created prior to filtering
start.

If the Copy points to new layers before removing or correcting checkbox is off, it is
highly not recommended to apply filtering to initial points layer, since it is impossible to re-
store the initial layer after filtering.

5. In theUntestable points section specify one of the following actions with untestable
points found after filtering:

Some points can be untestable – the points, in which vicinity there is not enough ’neighbour’
points. For example, points located on the edge of the whole layer or in areas of low
density of points (fields, forests, water bodies).

• Remove all – allows to remove all found untested points;

• Remove near the border – allows to set a value of distance in meters from the
edge of the whole vector layer, at which all untestable points will be removed.
The Distance from the border field is used to do this;

• Mark only – allows to save untested points to separate vector layer for further
analysis.

6. [optional] Values of average distance between points in active layer calculates
automatically. Also the estimated distance between points is equal to average
distance by default. Set the Recalculate parameters for average distance
between points in the layer checkbox off to set the estimated distance between
points manually.

7. Specify a number of filter passes:

• by default it is used two passes with standard parameters –Basic andAdditional.
Set off checkboxes to change set of passes;

• the button allows to add a new pass of filter;

• the button allows to remove selected pass of filter;

• the and buttons allow to move selected pass up/down.
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The Filter passes section contains a table of passes and buttons used to change
set of passes and their order with the following columns:

• Pass – displays pass name and checkbox used to include a pass to script or to
exclude it from filter workflow script;

• Reliable surges – displays action to be applied to well-defined surges found,
that are completely comply with specified filtering criteria;

• Doubtful surges – displays action to be applied to ambiguous surges found, in
which vicinity there is no data enough for analysis.

It is necessary to select an action to be applied to reliable and doubtful surges during
configuring of pass parameters.

8. Select a pass name and click the Edit pass parameters> > button. The Pass
section is opened and allows to display and configure the following parameters of
filter pass:

Fig. 21. Parameters of buildings and vegetation filter

• [optional] to change name of pass, input a new one in the Name field;

• the Average distance between points in the layer (in meters) and Estimated
distance between points (in meters) after filtering are displayed in fields;
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• specify Near and Far distance of mutual points influence in meters to define
the radius of the circle, in which the values of points are analysed for errors;

Near distance of points mutual influence – is the average radius of a circle where
the points are located that are attributed to the same flat surface towering above the
terrain (e.g. a flat roof).

Far distance of pointsmutual influence – is the average distance from points attributed
to the flat surface towering above the terrain where the points attributed to the terrain
are located for sure.

It is recommended to set the near distance (minimum circle radius) value as 3-5 values
of Average distance between points in the layer parameter.

Fig. 22. Near distance of points mutual influence (a) and far distance of points mutual influence
(b)

• specify the following filtering parametersUp (above surface) and/orDown (below
surface):

○ Filter surges – allows to select points to be filtered: points on surface (high
objects) and/or points below surface (pits);

For filter operating it is necessary to set at least one checkbox on.

○ Spikes only – is used to reject just sharp spikes above/below surface, that
are defined by values of the Threshold slope angle for spikes and Distance
of points parameters. The rest of parameters are not considered;
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In an angle between three points exceeds a value of the Threshold slope angle for
spikes parameter, then the surge is called spike.

○ Threshold slope angle for spikes – allows to specify angle of slope in relation
to selected measuring plane (above and/or below surface) to define sharp
spikes;

○ Maximum area of flat surges – allows to define maximal area of plane surges
(above/below surface) – points groups, that form smooth surfaces and are
distant from some plane of neighbour points. Generally, the points are located
on buildings roofs, and are lying on the same plane;

The filter is not applied to plane surface, which area exceeds the specified value.

○ Intermediate smoothing radius – allows to specify a sphere radius
(above/below surface), that defines a level of intermediate smoothing of surface;

○ Allowed point deviation from from smoothed surface – allows to specify
criterion, according which the filter is applied to all points with elevations that
differ from smoothed surface more then on specified value;

○ Maximum area of inclined surges – allows to define maximal area of inclined
surges (above/below surface) – points groups, that form inclined surfaces on
the slopes.

The button allows to go back to a standard script that includes two passes with all
default settings (regardless of which script has been loaded).

9. In the Actions section specify actions for reliable and doubtful surges found after
any step of filtering:

• Delete – deleting of points found from base points layer;

• Correct – editing in base layer Z-coordinates of points found;

• Check – saving of found points in a new layer without change of base layer.

Reliable corrected surges – found well-defined surges that satisfy completely to
all specified filtering criteria.

Doubtful surges – ambiguous surges in which vicinity there is no data enough to
analyse filtering operation possibility.

If the Delete or Correct option is selected, the system allows to edit base points
layer.
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In order to save deleted or corrected points to new layers it is recommended to set the
Copy points to new layers before removing or correcting checkbox on.

If theCheck option is selected the initial points layer remains unchanged, and found
reliable or doubtful surges are copied to a new layer Surges.

10. [optional] To use all cores of workstation CPU for calculation operation, the Use all
available CPU cores checkbox is set on in the system by default. It is necessary
to set the checkbox off to use only one core.

11. Click OK. The system starts DEM filtering operation. When the filtering operation
is completed the system displays information message about number of used basic
points and filtered points.

There are the following recommendations concerning use of buildings and vegetation
filter:

• it is recommended to use step-by-step filtering (in multiple passes with different
parameter sets);

• the passes should be formed in ascending order of the following parameters: distances
of mutual influence, radius of intermediate smoothing, and decreasing of allowed
deviation of point from smoothed surface;

• value of intermediate smoothing radius directly describes terrain relief features, that
it why it is necessary to specify the radius value not exceeding 1500 meters;

• it is recommended to perform preliminary analysis of maximal area of flat surges on
given territory (to measure it in a stereopair window) and then to compare it with area,
calculated automatically for passes. If the measured area is bigger than calculated
one, it is necessary to increase it;

• it is highly not recommended to specify a distance of mutual influence of points ex-
ceeding a step between points in more than 20 times, since it leads to considerable
slowdown of filtering operation.

4.5.6. Surface objects filter

The system provides possibility to correct blunders of correlation, obtained during
automatic points calculation. The filtering allows to delete points located on terrain
surface with specified typical size by XY and Z.

This filtering type is not used for objects of completely built-up area, forest belts and similar
objects.

The principle of filtering is to estimate the location and size of the contours created using
TIN, which was generated with help of initial points. A surge is a group of contours that
is not greater than specified size by XY and with elevations in specified range.
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Surface objects filter is recommended to use to eliminate sharp spikes. For more fine filtering
it is recommended to use this filter along with buildings and vegetation filter.

To apply filter of objects on surface perform the following actions:

1. Select Vectors › Filter › Surface objects filter. The Surface objects filterwindow
opens.

Fig. 23. Parameters of surface objects filter

2. Specify the Typical object size in XY-plane and Typical object size along Z
axis in corresponding fields in meters.

3. Click OK to remove points found.

4.5.7. Filter by image properties

The system provides opportunity of objects filtering depending on parameters of raster
image. During preparatory stage (called “learning”) an operator selects specific image
areas manually (forested areas on example images), serving as a reference samples
for the filtering operation.

To do filtering perform the following actions:

1. Make active a vector layer for filtering.

2. Select the raster image in 2D-window and choose Window › New 2D-window
(stereopair) (Ctrl+Alt+L) or click the button of the main toolbar. The stereopair
2D-window is opened and allows to start filtering.

The function is available in stereomode only.

3. Select Terrain › Points › Filter › Filter by image properties. The Filter by image
properties window opens.
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Fig. 24. Filter by image texture parameters

The window contains a standard toolbar.

FunctionButtons
allows to load a script of filter work from *.x-
filter resource located out of active profile re-
sources
allows to save a current script of filter work to
*.x-filter resource located out of active profile
resources

4. In Parameters section set the Pixel multiple and the Mask half size – a half size
of the area around point where image characteristics are calculated;

5. Place marker over peculiar image area and click the Add button in the Learning
section.

The Delete last button is used to remove the last selected sample, the Delete all button
is used to remove all selected samples.
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Fig. 25. Selection of the samples (filtering points in forestry area)

6. Repeat actions described in the section number 2 several times, using different
marker positions.

To check training, place the marker on image area, which differs from the reference area
(or vice versa - similar to it), and click the Test button. Status bar will show “-” or “+” result,
that informs about match or mismatch of the test site characteristics with those obtained
during training.

7. Click the Collect button in the Statistic section. Around every point inside of mask
half size 6 statistic parameters of pixel brightness distribution are calculated for
every colour channel. Statistic data are recorded in attributes of every point;

To look at statistics collected, select the point and selectWindow › Objects attributes.

To delete statistics collected from the objects attributes, click Clear button.

8. [optional] Turn onUse outlines checkbox to create polygons around areas contain-
ing filtered points automatically;

9. [optional] To create outlines only around large areas containing filtered points, turn
on Skip outlines smaller than и задайте минимальный размера полигона в
метрах;

10. [optional] Clear the Delete found points checkbox, if required.
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While turning onDelete found points checkbox, filtered points will be automatically deleted
after completion of filtration. While turning it off – automatically selected to perform further
operations.

11. Click the Filter button.

Fig. 26. Vector layer with points deleted after completion of filtering by image texture

Fig. 27. Vector layer with points selected and outlines created after completion of filtering by image
texture
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5. Triangulation irregular network (TIN)

5.1. The “TIN” menu

The TINmenu contains standard menu items used to load and save TIN layers, as well
as to perform different operations on creation, editing and accuracy control of TIN
building.

The Points menu is located in the Terrain menu.

Table 4. Brief description of the ’TIN’ menu

FunctionThe TIN menu
allows to load TIN from *.x-tin fileLoad TIN... (Ctrl+O, T)
allows to perform the quick access to recently
loaded TIN files

Recent

allows to save or rewrite active TIN layer as file with
*.x-tin extension

Save

allows to save active TIN layer with new name as
file with *.x-tin extension

Save as...

allows to close TINClose
allows to close all opened TIN layersClose all opened layers
contains menu items which allow to perform batch
management of TIN layers visibility in the Layer
manager

Layers visibility

allows to create TIN using loaded base layersBuild (Ctrl+N, T)
allows to create textured 3D-TIN surfacesBuild 3D-TIN...
allows to create textured 3D-TIN surfaces in batch
mode

Build 3D-TIN (Batch mode)

allows to change coordinate system of 3D-TINConvert 3D-TIN CS
allows to restore TIN from contoursRestore...
allows to create TIN border in automatic modeCompute border
allows to rebuild TIN after editing of base layer ob-
jects

Rebuild

is used to control TIN creation accuracy by triangu-
lation points

Check against adjustment points

is used to control TIN creation accuracy by vector
objects, which were not used during TIN creation

Check against vector objects

is used to check topology of TIN creationVerify topology...
allows to calculate TIN surface area within a polygonThe area of a polygon on the surface
allows to calculate TIN projection area on plane and
area of TIN 3D surface

Calculate area

is used to view statistic information about TINStatistic
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FunctionThe TIN menu
is used to filtering of TIN triangles nodes using filter-
ing of point vector objects in base layers, used for
TIN creation

Simplify

is used to peaks filtering – searching for TIN nodes,
which Z value differs from adjacent ones significantly

Peak filter

is used to edit TIN using Z-filterFilter by Z-range
allows to interpolate TIN to smooth DTM in order to
build or enhance contour lines

Interpolate

allows toconvert TIN into a vector layerConvert to vector layer
Allows to embed vector objects layer to created TINEmbed objects
Contains menu items to export results of TIN cre-
ation to DXF and CSV formats

Export

Contains menu items allowing to import TIN from
different formats

Import

allows to enable/disable editable TIN layer visibilityOn/Off TIN visibility (Ctrl+T)

5.2. General information

Triangulation Irregular Network (TIN) – one of the models of spatially coordinated data,
used during designing of digital terrain model as elevation points in nodes of irregular
network of triangles, that corresponds to Delaunay triangulation;

Delaunay triangulation – is a triangle polygonal network, formed on a set of discretely placed
points connected to each other by disjoint straight line segments in such a way, that a circle
circumscribed around each triangle does not contain points of initial set inside.

The system also provides a possibility to build quasi-contours – isolines with specified
step, which cross sides of TIN triangles. Quasi-contours are rebuilt automatically during
editing of base layers containing vector objects. Quasi-contours are used to provide
additional quality control of TIN generating and to reveal blunders.

During saving or loading TIN all base vector layers used for TIN creation are
saved/loaded.

During TIN creation it is recommended to use breaklines – vector polylines along specific
landforms (for example, watershed lines and valley-lines), as well as linear objects of human
origin (for example, road-sides).

To perform TIN creation the system provides the following workflow:

1. [optional] Pre-regions building.

2. Defining of set of base vector layers.

3. TIN borders creation.
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4. Building TIN.

The system provides the following features to work with TIN:

• different display ways;

• area calculation;

• TIN re-build after base layers change;

• filtering of base layers, used for TIN creation;

• accuracy control of TIN creation;

• export TIN to exchange formats.

Fig. 28. Source data for TIN creation

5.2.1. TIN layer display settings

For a TIN layer could be changed colors of triangles and contours.

To change colors of objects perform the following:

1. Double-click on layer objects color button ( ) in a Layer manager. The Layer
display settings window opens.
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Fig. 29. Layer display settings

2. Double-click on the object’s color in the Colors section and choose necessary
color from standard color palette.

3. Click the Apply button to display changes in 2D-window.

4. Click OK to save parameters.

5.3. TIN creation

5.3.1. Creation pre-regions for a block

The system provides possibility to create block pre-regions by images frames or by
stereopair frames to allow mutual project processing during vectorization. Pre-regions
created by stereopairs also allows to considerably speed up automatic points calculation
and generation of dense relief model due to reducing of number of block images overlap
areas.

Pre-regions – vector layer which consists of polygons, drawn by images block.

Perform the following actions to create pre-regions:

1. Select Block › Build pre-regions. The Create pre-regions window opens.
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Fig. 30. Parameters of pre-regions creation

2. In theUse frames of section select one of the following ways of pre-regions creation:

• stereopairs to create pre-regions using overlap areas of two stereopair images;

When using stereopairs frames the system fills in polygons attributes automatically as
follows: region_image_code (with the left image code), region_image_name (with the
left image name), region_image_code_2 (with the right image code), region_im-
age_name_2 (with the right image name).

• images to create pre-regions by near-nadir areas of each image.

When using images frames the system fills in polygons attributes automatically as follows:
region_image_code, region_image_name.

3. Select a way to create pre-regions using selected frames: Using Voronoy diagram
or version 4.x algorithms earlier system’s version algorithm (PHOTOMOD 4.x).

4. [optional] Set the Remove slivers slider (at min value the pre-regions are built
considering narrow strips; at max value the pre-regions is created without narrow
strips).

5. Click OK to create pre-regions. The system creates a new vector layer with pre-
regions.
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To load, edit, save and close of pre-regions layer the system provides standard too for
work with vector objects (see description in the ’Vector objects editing’ chapter of the
Vectorization User Manual).

Fig. 31. Pre-regions created using images frames
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Fig. 32. Pre-regions created using stereopairs frames

5.3.2. Loading base layers for TIN creation

Prior to TIN creation it is necessary to define a set of base layers used to create a TIN.

The system performs TIN creation using layers, containing the following data:

• vector objects (points, polylines and polygons);

• breaklines – polylines/polygons, drawn along lengthy relief features (edges, watershed
lines and valley-lines), as well as along roads;

• set of regular points – point vector objects, located on relief surface by regular grid
or in arbitrary order;

• triangulation points – tie, check, GC points, acquired on step of aerial triangulation
(see the ’Aerial triangulation’ User Manual).

In order to load vector objects perform the following actions:

1. Choose Vectors › Load or click the button of the main toolbar. TheOpenwindow
opens.
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Fig. 33. Vector layer loading

2. Select one or multiple vector files in active profile resources with x-data extension.

3. [optional] To disable saving and rewriting of selected file, set the Open read only
checkbox on.

4. [optional] Set method of objects coordinates recalculation For different coordinate
systems transforms via – using pixel or geodetic coordinates (see details in the
’General system’s parameters’ User Manual).

5. Click the Open button. If one or multiple vector layers are already loaded to active
layer, then during loading of new vector layer the window of loading type is opened.

Fig. 34. Vector layer loading

The system provides the following possibilities of new layer loading to existing
vector layer:
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• Replace layer – vector data of active layer is replaced by data from loading layer;

• Create new layer – vector data is loaded to a new layer;

• Add to layer – during loading vector data is added to objects of active vector
layer.

If some point of vector objects layer cannot load, the system shows warning about failed
loading of this points. In this case vector layer is loaded without coordinates of this point.

When it is necessary to load two or more vector files at once, the system suggests
the following ways of loading:

• Clear layer and load all files into it – vector data of active layer is replaced by
data from loading layers;

• Load all into one new layer – vector data is loaded to a single new vector layer;

• Create separate layer for each file – vector data of each file are loaded to
separate layers;

• Load all layers into Vectors without unloading existing data – during loading
vector data is added to objects of active vector layer.

Fig. 35. Vector layer loading

Corresponding Vector layers are displayed in Manager.

If vector data layer is saved to different coordinate system or in a project with differ-
ent adjustment results, the system recalculates coordinates automatically and during
loading produces information message, that coordinates were recalculated.
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Fig. 36. Coordinates recalculating during vector layer loading

TIN is rebuilt automatically during editing of base layers containing vector objects.

TIN layer is closed during closing of one of base layers.

To use a layer containing triangulation points, perform the following actions:

1. Choose Vectors › Create layer from triangulation points. The Load triangulation
points window opens.

Fig. 37. Load triangulation points to a project

2. [optional] To export triangulation points from GCP list the Ground control point
catalogue checkbox is set by default.

3. [optional] To export triangulation points from the Block scheme layer in 2D-window,
the Block scheme checkbox is set by default.

4. [optional] To export adjusted points coordinates fromGCP catalogue theAdjustment
results checkbox is set by default.

5. Click OK. The system displays information window containing information about
added or skipped points.

6. Click OK. The Triangulation points (Vectors) layer is created. Vector point objects
(triangulation points) are displayed on block scheme in 2D-window.
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Tie points are shown in 2D-window by yellow color; GCP – by red.

There is a possibility to save triangulation points layer to file of *.x-data format to active
profile resources.

5.3.3. TIN borders creation

The system provides possibility of TIN borders creation manually or automatically.

To create TIN borders manually, create the border polygons on a separate layer and
choose this layer in the list Use polygons from layer of the Create TIN window.

Perform the following actions to create TIN borders in automatic mode:

1. Choose Terrain › TIN › Compute border.... The Compute TIN border window
opens.

Fig. 38. The ’Compute TIN border’ window

2. [optional] In the Source data section the checkboxes near all opened layers are
set on by default, that are used for TIN borders creation. Set unused checkboxes
off, if some layers opened are not used for TIN border creation.

3. [optional] Choose the type of TIN border:

• Convex border – a border is created with connecting of outer boundary points
of selected layer in such a way that TIN has the most smooth border;

It is recommended to create convex border, when some part of vector objects does not
cover all area of TIN creation (for example, when there are lakes and rivers on large
scale images).
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• Nonconvex border – only closest border points of a layer are connected during
border creation.

The Smoothing slider position allows to specify distance between border points, and
if the distance between points is less than the specified, the border will be passed through
them. In the leftmost position of the slider point are connected sequentially, and in the
rightmost one the border looks like convex.

It is recommended to place the Smoothing slider in the middle and smoothly move it
to the left to get the best results.

4. [optional] In order to split TIN border into areas depending on source data, set the
Several regions checkbox on and move the Separation slider to define maximal
distance between initial vector objects, used to create TIN border.

5. Click OK. The system starts to create a TIN border in a new TIN border layer.

5.3.4. Building TIN

Perform the following actions to build TIN:

1. Choose the Terrain › TIN › Build (Ctrl+N, T) or click the button of the TIN addi-
tional toolbar. The Build TIN window opens.
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Fig. 39. The ’Create TIN’ window

2. [optional] By default in the Source data section set on checkboxes for all opened
layers to use them in TIN creation. Set the checkboxes off, if some layers opened
are not used for TIN creation.

To select all available layers click the button, to unselect all layers – click the button.
To invert selecting layers it is used the button.

3. [optional] In the Quasicontours section the Display checkbox on and in the
Starting level filed specify minimal Z level (Zmin), from which to start quasi-contours
creation.

4. [optional] Specify the Interval of quasi-contours creation in meters.
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5. [optional] In order to create quasi-contours as smoothed curves, set the Smooth
contours checkbox on and specify the smoothing parameters.

• Input the Curvature radius for smoothing curve.

Set the auto checkbox to calculate the Curvature radius for smoothing curve automat-
ically.

• Specify in the input field the Precision parameter – maximal distance from
polyline segment to a curve in the area between the two closest vertices.

6. In the Border section set on the following:

• Convex border – a border is created with connecting of outer boundary points
of selected layer in such a way that TIN has the most smooth border;

It is recommended to create convex border, when some part of vector objects does not
cover all area of TIN creation (for example, when there are lakes and rivers on large
scale images).

• Nonconvex border – only closest border points of a layer are connected during
border creation.

The Smoothing slider position allows to specify distance between border points, and
if the distance between points is less than the specified, the border will be passed through
them. In the leftmost position of the slider point are connected sequentially, and in the
rightmost one the border looks like convex.

It is recommended to place the Smoothing slider in the middle and smoothly move it
to the left to get the best results.

• Use polygons from layer – to create a TIN with convex border in limits of area
of polygon(s) selected in the layers list. Select from the list a layer containing
polygons, that will be used as a border. In order to define a border of TIN creation
area, just from selected polygons, set the Selected only checkbox on.

7. Click OK. The TIN is created in the new TIN layer.

5.4. TIN display

The system provides possibility to setup TIN display in 2D-window.

In order to make settings choose menu item Service › Settings or click the button
of the main toolbar. The Settings window opens. It consists of a set of tabs used to
setup various parameters.

The TIN tab is used to setup parameters of TIN display
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Fig. 40. Settings of TIN display

The Color TIN by elevation checkbox is set in the system be default, as a result TIN
is displayed as grid of triangles colored by height. Clear the Color TIN by elevation
checkbox to display all TIN triangles by the same color, defined in the Manager panel
for TIN layer.

The Display optimization section contains the following parameters used to improve
performance and to display a TIN as solid fill:

• Display fill instead of triangles for TIN containing more than specified number
of triangles;

• Display solid fill for TIN when window contains more than specified number of tri-
angles.

The Antialiased display checkbox is used to smooth TIN and quasi-contours for im-
proving visual perception.

When TIN is displayed as solid fill quasi-contours are not displayed.

The Triangulation precision parameter is intended for filtering of errors of TIN creation
using vector objects, which contain closely-spaced nodes. A value in the Triangulation
precision field is used to specify minimal distance between points, at which the points
are considered as different nodes, not the same one.
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To save computer memory when editing large datasets set the Do not build triangles
when layer is created.

If it is necessary to display TIN as triangles when the Do not build triangles when layer is
created checkbox is on, in the Display optimization section input the Display fill instead of
triangles for TIN containing more than parameter with value that exceeds the previous one.

The system provides a possibility to display TIN as three-dimension relief model, to do
this selectWindow › 3D window.

5.5. TIN loading

In order to load a TIN perform the following actions:

1. Select Terrain › TIN › Load (Ctrl+O, T) or click the button of the TIN additional
toolbar. The Open window opens.

Fig. 41. TIN loading

2. Select one or multiple TIN files in active profile resources with x-tin extension.

3. [optional] Set method of objects coordinates recalculation For different coordinate
systems transforms via – using pixel or geodetic coordinates (see details in the
’General system’s parameters’ User Manual).

4. Click the Open button. After that the TIN layer is loaded along with base vector
layers. If one or multiple TIN containing layers are already loaded to active layer,
then during loading of a new layer the window of loading type is opened.
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Fig. 42. TIN layer loading

The system provides the following possibilities of new layer loading to existing TIN
layer:

• Replace layer – vector data of active layer is replaced by data from loading layer;

• Create new layer – vector data is loaded to a new layer.

The system provides a possibility of quick access to recently loaded TIN files. To do
this use the Terrain › TIN › Recent menu item.

5.6. TIN saving

To save and rewrite active TIN layer select Terrain › TIN › Save or click the TIN layer
name by mouse right button in the Manager and choose the Save in right-click menu.

Layer containing TIN is saved in the file with x-tin extension. The file contains paths
to base layers used to create TIN, and a step of quasi-contours in meters.

To save active TIN layer with new name select Terrain › TIN › Save as... or click the
TIN layer name by mouse right button in the Manager and choose the Save as... in
right-click menu, specify file name and destination in active profile resources.

During saving a layer containing TIN, base layers used for TIN creation are saved
automatically.

During closing of one of base layers, the system suggests to save a layer containing
TIN to active profile resources, after that the TIN layer is closed automatically.

5.7. TIN restoring

The system provides possibility to restore TIN from contours. During TIN restoring the
additional vertices between the contours should be created.

This feature set can be useful in case of processing input data that are contours with
an irregular interval, unsuitable for solving current problems. To restore the terrain from
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the input contours, in order to further create contours with the desired step, perform the
following:

1. Restore TIN by contours;

2. Build DEM by TIN

3. Build contours by DEM

Using contours as input data for TIN creation, with correct user settings, results in the best
quality of terrain display with a triangulation irregular network (compared to other types of input
vector objects).

The quality of TIN building, in turn, affects the correct terrain display by DEM and contours that
will be built later using the abovementioned TIN as source data.

5.7.1. TIN restoring from contour lines

Perform the following actions to restore TIN:

1. Choose the TIN › Restore.... The Restore TIN window opens.
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Fig. 43. The ’Restore TIN’ window

2. [optional] By default in the Source data section set on checkboxes for all opened
layers to use them in TIN restoring. Set the checkboxes off, if some layers opened
are not used for TIN restoring.
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To select all available layers click the button, to unselect all layers – click the button.
To invert selecting layers it is used the button.

3. Select the Restore mode in the Restore parameters section:

• Fast;

• Quality;

○ [optional] set the restore accuracy and triangles splitting parameters;

4. [optional] In the Quasicontours section the Display checkbox on and in the
Starting level filed specify minimal Z level (Zmin), from which to start quasi-contours
creation.

5. [optional] Specify the Interval of quasi-contours creation in meters.

6. [optional] In order to create quasi-contours as smoothed curves, set the Smooth
contours checkbox on and specify the smoothing parameters.

• Input the Curvature radius for smoothing curve.

Set the auto checkbox to calculate the Curvature radius for smoothing curve automat-
ically.

• Specify in the input field the Precision parameter – maximal distance from
polyline segment to a curve in the area between the two closest vertices.

7. In the Border section set on the following:

• Convex border – a border is created with connecting of outer boundary points
of selected layer in such a way that TIN has the most smooth border;

It is recommended to create convex border, when some part of vector objects does not
cover all area of TIN creation (for example, when there are lakes and rivers on large
scale images).

• Nonconvex border – only closest border points of a layer are connected during
border creation.

The Smoothing slider position allows to specify distance between border points, and
if the distance between points is less than the specified, the border will be passed through
them. In the leftmost position of the slider point are connected sequentially, and in the
rightmost one the border looks like convex.

It is recommended to place the Smoothing slider in the middle and smoothly move it
to the left to get the best results.
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• Use polygons from layer – to create a TIN with convex border in limits of area
of polygon(s) selected in the layers list. Select from the list a layer containing
polygons, that will be used as a border. In order to define a border of TIN creation
area, just from selected polygons, set the Selected only checkbox on.

8. Click OK. The TIN is created in the new TIN layer. The additional vertices, created
during TIN restoration, are situated in the new Ridges vector layer.

5.8. TIN info

5.8.1. Brief TIN info

To get brief information about TIN layer, click the TIN layer name by mouse right button
in the Manager and choose the Information in right-click menu. After that the system
displays information window which includes the following information about the layer:

• layer name;

• full path to layer file;

• presence of data and changes in the layer;

• possibility to change the layer;

• coordinates of TIN border nodes, including Z-coordinate;

• number of nodes in base layers;

• layer coordinate system.

Fig. 44. TIN layer info
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5.8.2. General TIN info

In order to obtain detailed information about TIN layer, choose Terrain › TIN › Statistics.
The TIN – statistics window opens.

Fig. 45. The ’TIN – statistics’ window

The General section includes brief information about TIN layer.

The Details section contains information about distribution range of the following data
on a layer:

It is recommended to use this information to search for blunders on TIN layer.

• Triangles distribution on area (in square meters);

• Nodes distribution along Z axis (in meters);

• Triangles distribution by min. angle (in degrees);

• Triangles distribution by max. angle (in degrees).

Below is a table of the data distribution, which contains the following lines:

• Min and Max – minimal and maximal data range;

• (for example, 28588.2 - 31764.6) – data distribution in percentage.
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5.8.3. TIN area info

The system provides possibility to calculate TIN surface area.

To calculate TIN surface area within polygon, select the polygon on base layer or create
a new polygon and select Terrain › TIN › Compute surface area inside polygon. After
that the system opens information window with the following data:

• information about value of TIN area within selected polygon;

• information about value of selected polygon area.

Fig. 46. The area of a polygon on TIN surface

In order to calculate area of TIN projection on a plane and area of TIN 3D surface, select
Terrain › TIN › Compute surface area. After that the system displays information
window with values of TIN areas:

Fig. 47. TIN surface area

5.9. TIN re-building

After editing of base layer objects (see the ’Vectorization’ User Manual) the system allows
to perform TIN re-build operation.
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TIN layer is not editable. To change TIN layer it is necessary to edit base layers used for TIN
creation.

In order to re-build TIN considering vector objects of new vector layer, select Vectors ›
Load, select a file and click the Open button. The Loading window opens.

Fig. 48. Vector layer loading

The system provides the following possibilities of new layer loading to existing vector
layer:

• Replace layer or Add to layer (without unloading existing data) – allows to load
vector objects to a base layer. After that the TIN is rebuilt automatically;

• Create new layer – allows to load vector objects to a new layer. Create a TIN using
new layer as a base one.

To re-build TIN considering changes made in vector objects located in base layers,
perform the following actions:

1. Choose Terrain › TIN › Rebuild or click the button of the TIN additional toolbar.
The TIN border smoothing window opens.

Fig. 49. TIN border smoothing

2. Set the following parameters:
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• Convex border – a border is created with connecting of outer boundary points
of selected layer in such a way that TIN has the most smooth border;

It is recommended to create convex border, when some part of vector objects does not
cover all area of TIN creation (for example, when there are lakes and rivers on large
scale images).

• Nonconvex border – only closest border points of a layer are connected during
border creation.

The Smoothing slider position allows to specify distance between border points, and
if the distance between points is less than the specified, the border will be passed through
them. In the leftmost position of the slider point are connected sequentially, and in the
rightmost one the border looks like convex.

It is recommended to place the Smoothing slider in the middle and smoothly move it
to the left to get the best results.

3. Click OK to perform TIN re-build according to changed data.

5.10. Insert objects into TIN

The system provides possibility to insert objects into existed TIN layer.

It is used, e.g. to display walls of buildings vertically in the TIN layer.

To insert vector objects into TIN layer is used the Terrain › TIN › Insert objects menu
item.

Fig. 50. Insert objects to TIN

To choose vector file are used the following buttons:

• – allows to select all files;
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• – allows to unselect all files;

• – allows to invert files selection.

New layer creates when process complete. If the Binding threshold checkbox is set
on, the new layer with inserted objects and TIN is created. Otherwise, only vector objects
are created in new layer.

Threshold snapping allows to set the value in meters. If the value less than threshold,
objects are not insert.

5.11. Accuracy control of TIN creation

5.11.1. Check against adjustment points

If triangulation points layer was not used during TIN creating, the system provides
possibility to perform accuracy control of TIN creation by triangulation points, acquired
on aerial triangulation step. To do this use the Terrain › TIN › Check against adjustment
points menu item.

The Accuracy control window includes a table of all points (GCP/check/tie), acquired
on on aerial triangulation step (see the ’Aerial triangulation’ User Manual).

Fig. 51. Accuracy control using triangulation points

The top toolbar of the window is used to setup of triangulation points display in the list:
Gr.control,Check, Tie, Targeted,Measured only (triangulation points with Z coordinate
calculated during TIN creation), Adjusted.

The Used points field is used to display number of points used for calculation of TIN
deviation by Z-coordinate (in the Use column the is set).

The table of triangulation points contains the following columns:

• Name – point number;

• Type – point type: GCP, check or tie point;
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• Use – Data about point use during calculating of TIN deviation by Z-coordinate, or
about adjustment:

○ – the triangulation point was used;

○ – the triangulation point was not used;

○ – the triangulation point cannot be used, since it was not used for adjustment.

• X, Y, Z – adjusted coordinates of triangulation points;

• Ez – value of TIN deviation from the triangulation point by Z-coordinate.

Status panel is used to display values of root mean square error (RMS) and a value of
maximal error of TIN deviation by Z-coordinate (Max).

The button allows to display in the list a point with maximal error of TIN deviation by
Z-coordinate.

The button allows to display detailed report on accuracy control.

Fig. 52. Report on accuracy control using triangulation points

The top panel of the Report window contains the following buttons:

• – allows to close report window;

• – allows to save a report to file system of Windows;

• – allows to change font, style, size, and color of report text;

76

DTM GenerationPHOTOMOD 7.5



• – allows to print a report.

5.11.2. Check TIN against vector objects

The system allows to control TIN creation accuracy by vector objects, which were not
used during TIN creation Control operation provides values of TIN deviation from vector
objects vertices by Z-coordinate.

To control TIN creation against vector objects perform the following actions:

1. Select Terrain › TIN › Check TIN against vector objects. The Parameters of
check TIN by vectors window opens.

Fig. 53. Parameters of check TIN by vectors

2. Select display parameters of points list:

• Display the worst..values – allows to display a list of vector objects vertices
with worst deviations from TIN by Z-coordinate;

• Display the the shift more than – allows to display a list of vector objects vertices
with deviation from TIN by Z-coordinate, that exceeds specified.

3. Click OK. The system starts operation of comparing of TIN deviation values from
vector objects vertices by Z-coordinate. After that the Check TIN using vector
objects window opens.

Fig. 54. Results of control check of TIN against vector objects
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In order to export points list to file with csv extension, click the button.

4. Select a point in the list by mouse click. After that marker is placed to the crossing
point and is displayed in 2D-window.

5.11.3. Verifying of TIN topology

The system provides possibility to verify TIN topology.

The topology concept is one of the key terms used during quality assessment of created
maps. Throughout this documentation, the topology is referred to as set of functions
and operations, that define mutual location of vector objects and are used to create to-
pologically correct vector data.

Topology (from Greek topos - place) – a branch of mathematics that studies the phenomenon
of continuity in the most general form, in particular, the properties of space, which remain un-
changed under continuous deformations, for example, the connectivity.

Check of TIN topology means searching for closely placed triangles nodes of TIN and
their correction (correction of their corresponding points or vertexes of polylines/polygons
of base vector layers). Topology correction includes deleting or moving of closest TIN
nodes.

In order to start TIN topology check, perform the following actions:

1. Select Terrain › TIN › Verify topology.... The Parameters window opens.

Fig. 55. Parameters of topology check

2. In the Metrics list specify whether 2D or 3D space is used to search for topology
errors.

3. In theMax. distance field define a distance between nodes, below which the nodes
are considered closest.

4. Click OK. The system starts operation of search for closest TIN nodes. When the
search is completed the system opens the Errors correction window.
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Fig. 56. Correction of topology errors

5. Select a point in the list by mouse click. After that marker is placed to the point and
is displayed in 2D-window.

6. Select a way of topology correction: Combine points or Delete points.

7. To correct closest TIN nodes perform one of the following actions:

• ’link’ nodes using snapping (see the ’Vectorization’ User Manual);

• to correct topology for all points in the list click the button;

• to correct topology only for selected points in the list click the button.

After correction of TIN closest nodes topology the erroneous nodes are combined
into a single node with average coordinates value, or are deleted.

5.12. Export TIN

5.12.1. Export TIN to DXF

The system provides possibility to export of TIN layer to DXF format for its further use
in third-party software.

In order to export TIN to DXF format perform the following actions:

1. Select Terrain › TIN › Export › DXF.... The Export to DXF window opens.

2. Choose a folder to place a file to file system of Windows button.

3. Click the Save button. The Export to DXF window opens.
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Fig. 57. Parameters of export to DXF format

4. [optional] In the Objects for export section to export vertices, edges and triangles
of TIN the Vertices, Edges, Triangles checkboxes are set on by default. Clear the
checkboxes to export just particular kind of objects.

5. Set the following parameters:

• Export as polygons – allows to export objects as polygons;

• Export as 3D Face – allows to export top face of an object;

• Export as Polyface Mesh – allows to export object as polyhedral object.

6. [optional] In order to swap coordinate system (left/right) during TIN export, set the
Swap X Y checkbox.

If the Swap X Y checkbox is off, the initial data will be imported in the right coordinate
system. Otherwise, in the left coordinate system.

7. Click OK to complete the export operation.

5.12.2. Export TIN to CSV

The system provides possibility of TIN export to CSV format. CSV format is exchange
text format with csv extension, which is supported by major applications in different in-
dustries. It is used as exchange format when special geospatial data formats are not
applicable for some reason.

In order to export TIN to CSV format perform the following actions:

1. Select Terrain › TIN › Export › CSV.... The Export to CSV window opens.

2. Choose a folder to place a file to file system of Windows button.

3. Click the Save button. The Export to CSV window opens.
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Fig. 58. Parameters of export to CSV format

4. In the Export section select what kind of objects it is necessary to export: Line
vertices or Points and line vertices.

5. The Line template field displays the list of fields, contained in each line of exported
CSV file: To clear the field, click the Clear the list button.

6. [optional] In order to export a line from the Line template field, set the First line
with field names checkbox on.

7. [optional] In order to change number of decimal places in coordinates to be exported,
set the Maximum decimal places: checkbox on and input needed value.

8. In the Available fields list select required field name and click the Add selected
field button or click the Add all fields button, to transfer all field names. After
that all or selected field names are moved to the Used fields list.
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To cancel field name selection click the button or click the button to cancel moving
all field names. To move selected field to the list bottom, click the button, and to move
selected field to the list top click the button.

9. In the Decimal separator section select point or comma to be used to separate
coordinates.

10. [optional] In order to limit required parts of exported list of coordinates by quotes,
in the Enclose in quotes section choose one of the following options:

• Auto – allows to limit by quotes the fields, which are located in the file to be ex-
ported;

• All text fields – allows to limit by quotes only the fields, which contain text inform-
ation;

• All fields – allows to limit by quotes each field, which is located in the exported
file.

11. In the Field separator section choose, what is used to separate fields: comma,
space, tab, semicolon or other delimiters.

If the field separator is selected as a comma, it is not recommended to specify the decimal
separator as a comma, since objects with incorrect coordinates will be created after import
operation.

12. [optional] To define standard parameters set the Transform reference system
checkbox on (see the chapter Transform reference system of objects in the ’Vector-
ization’ User Manual);

13. Click OK to complete the export operation.

5.13. Import TIN

5.13.1. Import from DXF

The DXF format, that is used in the AutoCAD R15 and later versions is not supported. In this
case to perform data exchange it is necessary in AutoCAD program to convert DXF file to R14
format.

The system provides possibility of vector objects import from DXF format (see the
“Vectorization” User Manual). This is exchange format with *.dxf extension, that is
used in the AutoCAD programs.

In case when 3D face objects are to be imported from the DXF format, for the user’s
convenience the system provides for immediate building the TIN layer on the base of
imported 3D face objects.
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A user is able to import 3D face objects as a vector layer (see the “Vectorization” User Manual)
and further to build a TIN on its base.

The settings for both ways of data import from the DXF format are the same, because in any
case, during import, a vector layer will be created at first, which will either be used for automatic
TIN construction, or processed somehow by the user, depending on specific needs.

Note, that 3D face objects can be represented both by triangles and polygons. Their structure
will be completely maintained when importing 3D face objects as a vector layer. When building
a TIN (in every way) polygons will be split into triangles anyway.

In order to import TIN from the DXF format perform the following actions:

1. Choose DEM › TIN › Import › DXF. The Import from DXF format window opens:

Fig. 59. Import from DXF

2. [optional] To multiply all coordinates of objects vertices during import specify the
coefficient in the Scale field;
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3. [optional] To import origin of AutoCAD programobjects blocks as point objects, set
the Use blocks as points;

4. In the Point of origin section specify origin of coordinate system;

5. [optional] To convert 2D objects from DXF file into 3D objects, set the Import 2D
objects checkbox on. In the Z for 2D objects section define one of the calculation
ways of Z coordinates of objects vertices:

• Constant elevation – allows to assign the same value of Z coordinate to all ob-
jects;

• DEM from resources – allows to select a resource with DEM containing Z values.
Click the button to choose file in active profile resources;

• Z from “Elevation” code – allows to import Z coordinate from “Elevation” code.

The Elevation from attribute checkbox allows to import Z coordinate from attribute,
which name is specified in this field, its default value is Elev.

The Use for unknown elevation field allows to fill the empty elevations with a
predetermined value.

6. [optional] To define import accuracy of objects, containing curve lines, specify the
Curves interpolation precision parameter value.

After that the number of curve vertices may change.

7. [optional] To prevent creating text attributes with an empty value during import, set
the Do not create empty text attributes checkbox on.

When the Do not create empty text attributes checkbox is on, in some cases a data loss
may occur.

8. [optional] To define additional parameters set the Use DBF file (see the “Vectoriz-
ation” User Manual), Swap X Y and Transform reference system checkboxes on
(see the “Vectorization” User Manual).

If the last two checkboxes are set on, then when importing first XY-coordinates of points
are swapped, then the system recalculates the coordinates.

9. [optional] To correct wrong import of text objects set the Correct wrong text en-
coding checkbox on.
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10. [optional] To import a particular number of layers set the Select layers for import
checkbox on and click the button. The Layers table window is opened, where
the list of layers to be imported is displayed.

Fig. 60. Table of layers to be imported

Select layers in the table using one of the following ways:

• to import all layers, click the button and click OK;

• to import not all layers, select them and click OK.

to invert layers selecting allows the button, to unselect all layers – the button.

11. Click OK to import.
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5.14. TIN filtering

5.14.1. Simplifying

The system allows to filter TIN triangles nodes using filtering of point vector objects in
base layers, used for TIN creation.

TIN filtering is performed considering breaklines.

To perform points simplifying perform the following actions:

1. Create or load TIN.

2. Select Terrain › TIN › Simplify. The Simplify TIN window opens.

Fig. 61. Parameters of TIN simplifying

The window displays a statistics about source TIN: total Number of nodes in net-
work andMean distance between nodes (average length of TIN edges) in meters.

3. Specify Thinning parameters:

• [optional] set the Maximum deviation from the source model checkbox and
specify maximum deviation between source and thinned models by Z in meters;

The maximum deviation is calculated between the nodes of the source TIN and the
surface of the thinned TIN.

• [optional] set theMean distance between nodes checkbox and specify distance
between nodes after thinning in meters.

4. Click OK.When the filtering operation is completed the system displays information
message about number of deleted nodes.

Deleting of TIN nodes means removing of vector points from base layers. The filter works
with all base layers as with a single editable layer.
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To cancel thinning results the Undo log is used, as well as the and button of the
main toolbar.

5.14.2. Peak filter

The system provides possibility to filter peaks. This feature is used to search for TIN
nodes, which Z value differs considerably from adjacent nodes, so the system defines
nodes with sharp local peaks. Peaks filtering allows to remove part of nodes, that form
the most ’spiky’ pyramids.

TIN filtering is performed considering breaklines.

Perform the following actions to filter peaks:

1. Create or load TIN.

2. Select Terrain › TIN › Peak filtering. The Peak filtering window opens.
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Fig. 62. Peaks filtering

The histogram shows the relative distribution of TIN nodes with different coefficients
of peaks. A node with a value of peak factor, that equals 0, is assumed error-free.
A node with maximal probability of error (in accordance with selected calculation
method) have a peak factor that equals 100.

3. Specify Peak factor threshold or move using mouse button the red line on the
diagram to filter nodes, that fall into areas with values exceeding specified (behind
the red line).
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4. In the Filter settings section select Factor calculation method in the list:

• By minimum normal inclination – peak factor is proportional to the minimum
factor by triangles surrounding the vertex, to the value of angle between the
normal to the plane of the triangle and Z axis;

• By maximum normal inclination – peak factor is proportional to the maximum
factor by triangles surrounding the vertex, to the value of angle between the
normal to the plane of the triangle and Z axis;

• By mean normal inclination – peak factor is proportional to the mean factor by
triangles surrounding the vertex, to the value of angle between the normal to the
plane of the triangle and Z axis;

• By sum normal projection – peak factor is inversely proportional to module
projection of the vector sum of the normals to triangles surrounding the vertex
on Z axis;

• By sum normal abs.value – peak factor is inversely proportional to module
projection of the vector sum of the normals to triangles surrounding the vertex.

5. Click the Refresh button. The bottom part of the window shows a list of nodes, that
correspond to peaks with specified parameters.

6. Select a node in the list by mouse click. After that marker is placed to the selected
node and is displayed in 2D-window.

If the basic vector layer is active and editable, the given vertex is to be selected both in the
Peak filtering window and in the 2D-window.

To select nodes group in the Peak filtering window it is possible to use Ctrl or Shift keys.
The Select all button allows to select all nodes found.

To select a group of vertices in a 2D-window, use the Select button.

7. Click the Delete button to delete points from base vector layer selected in the list.
After that the TIN is rebuilt automatically.

Deleting of TIN nodes means removing of vector points from base vector layers. To cancel
thinning results the Undo log is used, as well as the and button of the main toolbar.

5.14.3. TIN filtering by Z-range

The system provides possibility to edit TIN using Z-filter. During filtering by Z-range the
system performs deleting of vector points, and polylines/polygons vertices (that corres-
pond to TIN nodes), which Z-coordinate is out of the range.
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TIN filtering is performed considering breaklines.

To perform filtering by Z-range of vector objects of base vector layers, used for TIN
creation, perform the following actions:

1. Create or load TIN.

2. Select Terrain › TIN › Filter › Filter by Z-range. The Z-range filter window opens.

Fig. 63. Parameters of TIN filtering

The Layer field displays a name of loaded TIN layer, the Zmin and Zmax fields
show terrain elevation difference in meters, calculated by all TIN nodes.

3. The Filter range section by default shows values of calculated terrain elevation
difference. Specify maximal and minimal Z values in meters to consider for points
filtering.

4. Click OK. Filtration removes all points and vertices of polylines/polygons, which Z-
coordinate falls outside specified range.

Deleting of TIN nodes means removing of vector points from base layers. To cancel thinning
results the Undo log is used, as well as the and button of the main toolbar.

5.14.4. Smooth TIN interpolation

The system provides possibility to interpolate TIN network for DEM smoothing for cre-
ating or improving contour lines, if contour lines layer was one of the base layers for
TIN creation.

TIN filtering is performed considering breaklines.

Perform the following actions to perform TIN interpolation:

1. Create or load TIN.

To interpolate TIN within a grid it is necessary to create or load the grid prior to interpolation
operation.
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2. Select Terrain › TIN › Interpolate. The Smooth TIN interpolation window opens.

Fig. 64. Parameters of TIN interpolation

3. Specify the Interpolation scope:

• Whole TIN area;

• Within grid limits – the system uses parameters of regular grid with specified
step.

4. Specify the Interpolation type:

• Linear – TIN condensation using points adding on triangles surface;

• Smooth model – using second-order surface for interpolation by specified
number of points in the neighbourhood of the triangle, where a grid node is loc-
ated.

For smooth model specify a number of points used to perform interpolation in
the Use neighbourhood of..points field.

It is recommended to specify a value not exceeding 100 points in the Use neighbour-
hood of..points field.

5. Set the Step of interpolation in meters.

6. Select a destination of interpolation results save:

• Active vector layer – the active vector layer will be rewritten;

• New vector layer – interpolation results will be copied to a new vector layer.
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The Include this layer into TIN and rebuild the TIN checkbox is set on by de-
fault, that allows to update TIN network automatically according to filtering results.

7. Click OK. After that the system performs interpolation of base vector layer and
displays results depending on selected parameters.

5.15. Converting TIN into a vector layer

The system provides possibility to convert TIN into a vector layer.

To do this, perform the following:

1. Create or download a TIN layer;

2. Select Terrain › TIN › Convert to vector layer. The Convert TIN window opens;

Fig. 65. The “Convert TIN” window

In the Convert TIN window specify the parameters of TIN conversion into a vector
layer:

• Vertices – to save vertices of irregular triangles as points in the new vector layer;

• Edges – to save edges of irregular triangles as polylines in the new vector layer;

• Triangles – to save irregular triangles as polygons in the new vector layer;

3. Click OK.

5.16. Creation of textured TIN 3D surface

The system allows to create textured 3D-TIN surfaces. A DEM or LAS point cloud can
be used as initial data for creating a 3D surface. Texturing of the created surface is
carried out using images of the loaded project (optional, taking into account the color
of LAS input points). The initial DEM or point cloud is to describe the areas of the earth’s
surface covered by the project images.
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The output files of textured 3D-TIN surfaces have *.json extension. For further work with 3D-
TIN, the PHOTOMOD 3D-Mod program is used (see the “Three-dimensional modeling” User
Manual). 3D-TIN tiles (with *.b3dm extension) are saved in the separate directory (with the same
name) in the folder chosen for output 3D-TIN saving in the active profile’s resources.

To create the textured 3D-TIN surface, perform the following:

1. [optional] If only a share of the project’s images are intended to be used for 3D
surface texturing, first select the necessary images in the Block scheme window
(or in the Block editor window);

2. Choose Terrain › TIN › Build 3D-TIN.... The 3D-TIN creation window opens;

Fig. 66. The “3D-TIN creation” window

The 3D-TIN creation window contains the following elements:

• A toolbar in the upper part of the window, which is intended to save/load paramet-
ers settings on all tabs of the window and contains the following buttons:

○ – allows to load parameter’s settings saved previously to active profile re-
sources;

○ – allows to save all parameter’s settings to *.x-ini file located in active
profile resources;
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○ – allows to load parameter’s settings from *.x-ini file located in a folder
of Windows file system;

○ – allows to save parameter’s settings to *.x-ini file located in a folder of
Windows file system;

○ – allows to restore the last-session’s settings;

○ – allows to restore default parameter’s settings.

• The Resources, Building, Filtration, Texturing and Coord System tabs;

• The Use all cores on local PC checkbox which allows to use all the cores of
workstation CPU for calculation operation;

It is necessary to clear the checkbox to use only one core.

• The Additional parameters button which allows to set additional parameters of
3D-TIN creation in Building and Texturing tabs.

3. Select the input Resources in an appropriate tab:

• [optional] Input DEM – click the button to select input DEM in active profile
resources;

Click the button to open the Layer selection window and select the source DEM
from the list of DEMs uploaded to the project.

• [optional] Input point cloud folder – click the button to select the folder with
input point clouds (LAS) in active profile resources.

The input point clouds (LAS) should be created in PHOTOMOD system.

The third-party lidar data could be used as input point cloud only after the point cloud
colorization by the current project images (see the “Point cloud colorization by project
images” chapter of the “LIDAR Data processing” User Manual).

Input path to save file to the Output 3D-TIN field or click the button, to select
name and path in active profile resources to save 3D-TIN.

4. [optional] Set the following main and additional 3D-TIN building parameters in an
appropriate tab:
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Fig. 67. The “Building” tab

Set the main 3D-TIN building parameters:

• The Detailing parameter (set in the units of the current project) allows to set the
detail degree of created 3D-TIN:

○ If the Input DEM is used, the recommended value of this parameter corres-
ponds to the input DEM cell size (GSD);

○ If the Input point cloud folder is used, it is recommended to input a value that
exceeds the input point cloud resolution 2-3-fold (i.e. the resolution is to be 2-
3-fold worse than the input point cloud resolution).
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The quality of 3D-TIN building directly depends on the quality of the Input DEM (point
cloud), resolution of source project imagery used for texture creation, as well as on
the suitable interrelation between 3D-TIN detailing and the parameters that determine
texture resolution (see the Texturing tab description below).

For nadir imaging with medium ground sample distance (GSD) more than 0.1 m (that
doesn’t depict small parts of buildings), it is recommended to use an Input DEM.

For the projects containing higher quality original imagery (GSD < 0.1 m), it is recom-
mended to use a high resolution input point cloud.

If maximum detailing is needed, use an Input DEM whose cell size corresponds to
one image pixel.

In this case:

■ to create an extra detailed 3D-TIN, the Detailing option value is to outnumber the
input DEM cell size 2-3-fold;

■ to create a detailed 3D-TIN, the Detailing option value is to outnumber the input
DEM cell size 4-6-fold;

■ to create a survey 3D-TIN, the Detailing option value is to outnumber the input
DEM cell size ~10-fold.

• [optional] toDelete borders of the input point cloud set an appropriate checkbox;

This function is available only if the source for 3D-TIN building is the Input point cloud
folder. To convert DEM to points, set the appropriate checkbox (Building tab, Addi-
tional parameters).

Leave the Delete borders checkbox set. Otherwise, the quality of 3D-TIN boundary
regions’ construction may decrease.

[optional] to set theAdditional parameters of 3D-TIN building click the appropriate
button:

• In the Minimum TIN fragment size input field, set minimum size of isolated 3D-
TIN areas, that are not to be deleted;

Isolated 3D-TIN areas – are triangle groups that are not directly related with the main
3D-TIN surface and can arise, including due to errors. Isolated areas are subjected to
filtering at final stages of 3D-TIN creation. The filtering criterion is the size of the isolated
area (number of triangles).

The size of an isolated area (number of triangles in the isolated area) is compared with
the size (number of triangles) of the particular tile containing the isolated area being
tested. The Minimum TIN fragment size, which determines the stringency of filtering,
is set as a percentage of the number of triangles in the tile (see below).
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• In the Tile size field, customize sizes of 3D-TIN tiles by setting the approximate
number of triangles in individual tile;

The product of the values of the Tile size and the Detailing parameters approximately
corresponds to the tile size in the units of the project.

• In The number of tiles in the block field, set the number of tiles to be processed
in the framework of a single task;

Reducing The number of tiles in the block leads to the increased number of distributed
processing tasks and increased 3D-TIN building time. It is advisable to reduce The
number of tiles in the block in case of a lack of system resources.

Increasing The number of tiles in the block leads to the decreased number of distrib-
uted processing tasks what may improve the system performance in case of available
system resources.

• In the Overlapping field, set the 3D-TIN fragment overlap, in %;

It is not recommended to set null overlaps.

• In The number of levels field, set the number of levels of 3D-TIN pyramid;

The system provides the capability to create multi-level 3D-TINs that have various de-
tailing upon review depending on the degree of approximation (when the number of
levels of the pyramid is more than 1, otherwise if looked up in PHOTOMOD 3D-Mod
3D-TIN would be open with the only maximum detailing).

The null value allows to calculate The number of levels of a 3D-TIN pyramid automat-
ically.

• The Use the number of reflections checkbox allows one to take into account
the number of reflections per point when building a 3D-TIN (i.e. points with a
large number of reflections will have more weight when processing the input point
cloud).

This function is available only if the source for 3D-TIN building is the Input point cloud
folder. To convert DEM to points, set the appropriate checkbox (Building tab, Addi-
tional parameters).

In case of the cloud of points, created during the DEM creation using the SGM method,
the number of reflected pulses in the given point is the number of stereopairs on the
basis of which a particular point was calculated: 1, 2, 3, 4, 5, 6, 7, or 8.

Limitation of the “number of reflected pulses” by 1 to 8 results from the limitations of the
LAS format itself, accordingly, in the latter case, the number of stereopairs can be both
“8” and “8 and more”.
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• Configure the Samples per node parameter;

This function is available only if the source for 3D-TIN building is the Input point cloud
folder. To convert DEM to points, set the appropriate checkbox (Building tab, Addi-
tional parameters).

The display of separate objects on the constructed 3D-TIN surface depends not only
on the quality of the source data, but also on the user-defined level of detail of the output
data (see above).

For example, an object with plane dimensions smaller than or comparable to the specified
output detail may not be displayed on the constructed 3D-TIN surface.

By increasing the Samples per node parameter, the user can select the appropriate
settings for displaying objects with small linear dimensions, taking into account the detail
of the output data.

The approximate value of this parameter is the ratio between the input data GSD and
the minimum linear dimensions of the objects that must be displayed when building a
3D-TIN.

The increase of this parameter causes the increase of time required for 3D-TIN building.

• Enter the RMS for simplification value;

This function is available only if the source for 3D-TIN building is the Input point cloud
folder. To convert DEM to points, set the appropriate checkbox (Building tab, Addi-
tional parameters).

When creating a 3D-TIN surface, the initial detailed surface, built in accordance with
the characteristics of the source data, is smoothed and simplified according to the user-
specified building parameters (see above).

Thus, for example, the use of an excessive number of triangles to describe a part of an
object that is a plane (or close in shape to a plane) is somewhat redundant.

By changing the limiting value of RMS for simplification of the surface, the user may
adjust the stringency of algorithms leading to a decrease in the number of triangles that
describe the 3D-TIN surface.

The default (0.25) value is recommended.

• To convert DEM to points, do not clear the appropriate default checkbox before
3D-TIN building.

Some 3D-TIN building parameters (see above) are available only in case when the
source for 3D-TIN building is a point cloud.
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• To build points pyramid before building a 3D-TIN, do not clear the appropriate
default checkbox.

This function is available only if the source for 3D-TIN building is the Input point cloud
folder. To convert DEM to points, set the appropriate checkbox (Building tab, Addi-
tional parameters).

It is recommended to build points pyramid before building a 3D-TIN. Otherwise, the
time spent on building a 3D-TIN may increase significantly.

• To restore points for invisible zones, set the appropriate checkbox.

The system allows for calculating and building sections of a 3D surface that describe
elements of objects on the ground that are not displayed in the project images, for ex-
ample, such as steep walls of buildings that appear on all project images in the so-called
“occluded zone”. It is recommended to restore points for invisible zones if images
with small off-nadir angles were used when project-creating, which generally display
the same-type housing development with simple architectural concepts that do not
contain complex geometric shapes.

• To restore normals, set the appropriate checkbox.

The directions of normals at points in the input cloud are taken into account when ap-
proximating the 3D surface. The system allows one to clarify the directions of the specified
normals (by analyzing normal directions at neighboring points). This has a positive effect
on the output 3D surface construction quality. In most cases, it is not recommended to
clear this checkbox.

• To delete temporary data when building a 3D-TIN from a point cloud, set the
appropriate checkbox.

Temporary data that arise when building a 3D-TIN from a point cloud (i.e. if the initial
resource for building is the Input point cloud folder, or the convert DEM to points
checkbox is set) can be quite large.

However, stored temporary data can significantly improve system performance if the
operation is repeated with the same initial data (e.g. if the first-time result was not con-
sidered satisfactory and a decision was made to re-build 3D-TIN with adjusted building
parameters).

If other input data are used (or if the convert DEM to points checkbox was subsequently
cleared), the stored temporary data will not play any role in the 3D-TIN construction.

5. In the appropriate tab, set the parameters for 3D-TIN filtration.

In this case, by filtering we mean 3D-TIN smoothing due to clarifying positions of vertices
without their removal.

99

DTM GenerationPHOTOMOD 7.5



The system allows for filtering both before and after the simplification of the created
model according to preset detailing parameters (see the Building tab). In both
cases, the bilateral, smooth and clarify filters can be applied during the filtering
any times in the order selected by a user. Every above filter application, and their
order are customized individually by a user, in the appropriate lists in left and/or
right part of the window.

In the list from the left part of the window, user can customize the parameters and
sequence of filters applied for pre-filtering of a non-simplified 3D-TIN model. The
list in the right part of the window allows to customize repeated filtering for a 3D-
TIN model simplified according to preset detailing parameters. The user has the
opportunity not to perform preliminary and/or repeated filtering of 3D-TIN at all by
clearing the appropriate checkboxes or removing filters from the corresponding lists
in the left or right part of the window. However, to ensure suitable 3D-TIN quality,
it is highly recommended to perform filtering.

Pre-filtering is the most preferable towards maximum 3D-TIN model accuracy, but
it is extremely resource-demanding operation if the Bilateral filter is applied. The
Smooth filter is less system resource-demanding, however its application is asso-
ciated with significant time spending. Bilateral and/or smoothing filters applied to
pre-simplified modes (without pre-filtering) allows to significantly increase system
performance, thus avoiding high time spending or involving significant computational
resources.

The Bilateral filter, in most cases, ensures fast creation and high quality of an output 3D-
TIN. However, as it was noted above, it is very resource demanding if used for pre-filtering.
In this case, when creating a very detailed 3D-TIN surface, it is highly recommended to
decrease Tile size down to 32 (see above), and Max MT tasks for a workstation with a
multicore processor and 16 Gb RAM - down to 1 (see distributed processing parameter
settings below).

The smooth filter, under similar circumstances, is less workstation resource-demanding
than the bilateral one, has more flexible settings and provides a comparable quality of data
processing, however, when it is used for pre-filtering, the time spent on building a 3D-TIN
significantly increases. If to skip pre-filtering, and apply filters only to a simplified model,
the differences described above are not so significant.
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Fig. 68. The “Filtration” tab

The toolbar of the Filtration tab contains the following buttons:

• – allows to add the bilateral, smooth or clarify filter into the set of filters
providing pre-filtering or simplified model filtering;

• – removes the selected filter from the set;

Select a filter by clicking the left mouse click.

To exclude a filter from processing not removing it, clear the appropriate checkbox.

The system provides for using pre-configured filters suggested by default. To restore a
deleted filter from this list, click the button.

• – allows to set the order of filters by moving the selected filter higher in the
list;

• – allows to set the order of filters by moving the selected filter lower in the list;

• – allows to configure the selected filter;

• – allows to rename previously added filter.
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To add the Bilateral filter into the set of filters providing pre-filtering or simplified
model filtering, perform the following:

1. [optional] click the button in the left or right part of the window. The Add filter
window opens:

Fig. 69. The “Add filter” window

2. Select the Bilateral filter by clicking the left mouse button and click Ok;

3. Input filter name in appropriate window:

Fig. 70. The input window

4. [optional] Select added bilateral filter by clicking the left mouse button and
click the button. The Bilateral filter window opens:
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Fig. 71. The “Bilateral filter” window

The bilateral filter is used to clarify the position of 3D-TIN vertices without their re-
moval. The filter is based on the analysis of the relative position of normals to 3D-TIN
faces. Corrections to 3D-TIN vertices are accumulated through the sequence of itera-
tions during those there are calculated total weight normals to each face adjacent to
the processed vertex. Corrections are applied in several stages (vertex shift). Ideally,
in case of quite long-term filter operation, the vertex shift in the filtered 3D-TIN at each
next iteration, beginning from the appropriate moment is to be minimal.

When configuring a bilateral filter, set the following parameters:

• A range for search of neighbor faces (in the vicinity of the analyzed face) is
a production of the Detailing (see above) and Sigma distance parameters;

Sigma distance directly affects the number of neighboring faces used when ana-
lyzing a single face under processing. Significant increase of this parameter against
the default value may cause essential loss of performance, especially when creating
detailed 3D-TIN.

• The Sigma normal that determines the degree of impact of neighboring face
normals (within a search range) on the calculation of a total weight normal
to the analyzed face.

The Sigma normal is set between the zero (null impact) and the unity (max impact).
When normal sigma values are close to the zero, the bilateral filter will not correct
the existing roughness of a model, and high values will cause geometric data dis-
tortion (for example, rounded building corners).

• An iterations count for the shift by normals during the calculation of cor-
rections to vertices;
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• The factor of influence of accumulated corrections on the positions of 3D-
TIN vertices when they are shifted;

When processing data that display terrain with significant development, it is not
recommended to exceed the default factor of influence.

• An iterations count for the shift by vertex.

Click Ok.

5. [optional] Select added bilateral filter by clicking the left mouse button and
change its position using the and buttons, if appropriate.

To add the Smooth filter into the set of filters providing pre-filtering or simplified
model filtering, perform the following:

1. [optional] click the button in the left or right part of the window. The Add filter
window opens:

Fig. 72. The “Add filter” window

2. Select the Smooth filter by clicking the left mouse button and click OK;

3. Input filter name in appropriate window:

Fig. 73. The input window
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4. [optional] Select added smooth filter by clicking the left mouse button and click
the button. The Smooth filter window opens:

Fig. 74. The “Smooth filter” window

The smooth filter is used to clarify the positions of 3D-TIN vertices without their re-
moval. Corrections to each of the vertices are calculated based on the analysis of
mutual position of the neighboring 3D-TIN vertices (or faces).

Set the following parameters of the smooth filter:

• [optional] In order to calculate the corrections for the position of vertices
based on the results of the analysis of the relative position of the 3D-TIN
faces closest to them, set the Smooth by faces checkbox, otherwise, the
corrections are calculated based on the results of the analysis of the relative
position of the nearest vertices.

○ To consider the area of a face (as a weight function) when calculating
these corrections, set the Use faces area checkbox. Otherwise, the area
of a face is not taken into account (each face has the same weight at cor-
rection calculation).

• Configure the parameters for search of the closest vertices (or faces) in the
vicinity of a vertex under processing:

○ The number of neighbourhood selection iterations is max neighbor
search depth, i.e. search of faces (or vertices) directly osculant to the vertex
under processing (at the first step) and further, search of faces or vertices
osculant to the “neighbors”.
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The number of neighbourhood selection iterations directly impacts the number
of adjoining faces (vertices) used for the processing of the current vertex. Signi-
ficant increase of this parameter against the default value may cause essential
loss of performance, especially when creating detailed 3D-TIN.

○ A range for search of adjacent faces (vertices) in the vicinity of the analyzed
face is a production of the Detailing (see above) and Sigma distance;

Sigma distance additionally limits the number of neighbourhood selection it-
erations.

• The factor of influence of correction to the 3D-TIN vertex position;

When processing data that display terrain with significant development, it is not
recommended to exceed the default factor of influence.

• Set the iterations counts for filter operation;

• [optional] to use also the bilateral filter, set the appropriate checkbox and
set the Sigma normal parameter (see above).

Click OK.

5. [optional] Select added smooth filter by clicking the left mouse button and
change its position using the and buttons, if appropriate.

To add the Clarify filter into the set of filters providing pre-filtering or simplified
model filtering, perform the following:

1. [optional] click the button in the left or right part of the window. The Add filter
window opens:

Fig. 75. The “Add filter” window
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2. Select the Clarify filter by clicking the left mouse button and click Ok;

3. Input filter name in appropriate window:

Fig. 76. The input window

4. [optional] Select added clarify filter by clicking the left mouse button and click
the button. The Clarify filter window opens:

Fig. 77. The “Clarify filter” window

Specify the detalization settings.

Click Ok.

5. [optional] Select added clarify filter by clicking the left mouse button and change
its position using the and buttons, if appropriate.

6. [optional] In the Texturing tab, set theBuild textures checkbox to create a textured
3D-TIN surface:
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Fig. 78. The “Texturing” tab

Set the main parameters of the textures creation:

• [optional] To use points color of the input cloud points when creating textures
(if such data is available in the input LAS files), set the appropriate checkbox;

This option is available only if the input point cloud folder is used as input data (see
the Resources tab).

Particularly, the color of neighboring points can be used when calculating the final colors
of pixels in a 3D surface region that describes fragments of objects that are not displayed
in the project images (located in occluded zones in all images). To use a uniform user-
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defined background color (see below) when texturing similar 3D surface elements,
clear this checkbox.

• Choose the brightness adjustment method for equalizing brightness between
textures of 3D surface fragments:

○ Best;

○ Average;

○ Decoarsing, best;

○ Decoarsing, average;

○ Decoarsing, nearest;

○ Decoarsing (W), best;

○ Decoarsing (W), average;

○ Decoarsing (W), nearest.

All images covering a 3D surface fragment under processing are involved in the color
calculation. Brightness adjustment allows a user to create a visually unified and
continuous 3D surface by smoothing out differences between the brightness and
contrast characteristics of its individual fragments.

The proposed techniques for calculating the color of the final pixel of a 3D surface
generally come down to either using the average brightness and contrast character-
istics of the relevant pixels of all images involved or to using the color of a pixel of a
specific image that best satisfies certain conditions, i.e., maximum proximity to the
projection center and the smallest off-nadir angle at a given point on the 3D surface.

Averaging the characteristics of all involved images usually leads to the creation of
visually continuous 3Dmodel textures devoid of sharp transitions between areas with
different color, brightness, and contrast characteristics. A disadvantage of such a
technique is the possible blurring that may occur in certain circumstances in some
areas of 3D surface textures.

The use of brightness characteristics of individual images recognized as the most
suitable when calculating a specific pixel, in turn, leads to the greatest reliability when
creating textures for individual fragments, negatively affecting, in certain cases, the
quality of brightness adjustment across the entire 3D surface as a whole.

Automatic filtering allows users to pre-exclude from processing those images in which
the brightness and contrast characteristics of the area of interest differ significantly
from the majority of images covering the given area (for example, if a particular image
was created under changed lighting conditions).

The user also has the option to preliminarily select images intended for creating tex-
tures, manually rejecting unsuitable images (see below).
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• Select the background color used when texturing fragments of the 3D surface
that are not displayed in any of the project images used (being in so-called “oc-
cluded zones”);

• Specify the image selection method:

○ by all images;

○ by selected images.

The image selection method can have a significant impact on the brightness ad-
justment between the textures of 3D surface fragments (see above), especially if
images with noticeably different spectral and brightness characteristics (for example,
taken with a significant time interval, e.g., in different seasons, under different lighting
conditions, etc.) are used for project processing.

• Set the Texture size, in pixels;

It is recommended to set the Texture size exceeding the Tile size (see above) at least
twice (or more). Increasing of this parameter results in increased texture resolution and
increased time of 3D-TIN building:

○ If the Tile size is 64, the recommended Texture size is 256.

○ If the Tile size is 32, the recommended Texture size is 128.

If the Remote Desktop Protocol (RDP) is used for the access to the workstation with
PHOTOMOD installed, then to ensure correct visual assessment of texturing results, it
is strongly recommended to set the Texture size not exceeding 1024 pixels and divisible
by powers of 2 (2, 4, 8, 16, 32, 64, 128, 256, 512, 1024).

Otherwise, due to the peculiarities of the Remote Desktop Protocol, correct display of
output 3D-TIN textures on the screen of a computer remotely connected to a workstation
with PHOTOMOD installed is not ensured.

RDP is theRemote Desktop Protocol supported byMicrosoft used to work remotely with
another computer. This technology allows for controlling a remote computer at a distance,
from the user’s workstation, using an Internet connection.

• In order not to use boundary regions of imagery while texturing, set the Offset
from image boundaries,% by clicking the button. The Imagemarginwindow
opens. Set image margins in percent which are not to be involved in texturing;

It may be necessary so that only useful part of an image was textured (e.g. while pro-
cessing projects with analog imagery as source data).
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Fig. 79. The “Image margin” window

Fig. 80. Offset from image boundaries, %

• Set the Occlusion radius in pixels when texturing overlapping objects;

Recommended Occlusion radius is several pixels. If this parameter is set to zero, in-
visible areas will not be checked what may result in incorrect texturing of overlapping
objects (especially when processing projects with “oblique” survey data as source data).
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• Set the Occlusion distance – minimum distance to invisible areas in the project
units (i.e. minimum distance between overlapping objects). Invisible areas will
be verified when this distance is exceeded.

Invisible area check will not be performed if the Occlusion radius (see above) is equal
to zero.

Fig. 81. Invisible areas when texturing overlapping objects (hatched), where R is the Occlusion
radius and L is the Occlusion distance

[optional] to set theAdditional parameters of textures creation click the appropriate
button:

• Set the Depth map tolerance in the project units. The Occlusion distance is
calculated on the base of the depth map;

• [optional] set theApply sharpen filter checkbox and click the button to open
the Filter parameters window:

The sharpen filter allows to highlight and intensify differences between image’s individual
details (image sharpness). See the “Radiometric correction” chapter of the “General in-
formation” User Manual.
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Fig. 82. Filter parameters

Set the following parameters:

○ In the Aperture size list define the matrix size from 3x3 pixels to 21x21 pixels.

○ Move slider to define Filtering level in percent.

○ Set the Threshold.

Each single image element is filtered only if the brightness difference between adjacent
elements exceed the given filtering Threshold. This helps to avoid errors looking as
spots in the areas of an image with originally uniform hues.

○ [optional] Be default the Cut background checkbox is set on for removing
background on image edges. To remove background set the following para-
meters:

■ Background color – value of background color for cutting;

If the 0 value is set in the Background color field, background does not consider
during correction.

■ Tolerance – deviation from background color value for cutting.

○ Click OK to close the window.

• [optional] The system allows the user to speed up the process of 3D-TIN texturing
by limiting the number of images used. To do this, set the Search the best im-
ages checkbox and select the criterion for terminating the selection process:

○ By coverage;
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■ Set minimum coverage change (in percent) for a certain number of iterations;

○ By iterations.

■ Set maximum number of iterations;

For each 3D-TIN fragment, the selection of the best images is performed. If after the
texturing process completion there are areas unfilled with textures, the selection of the
best images (from among the unused ones) is repeated, either until the maximum user-
defined number of iterations specified is reached, or until the process loses its efficiency,
according to the criteria specified by the user (minimum texture coverage change for
the specified number of iterations).

7. [optional] In the Coord system tab, set the Convert CS checkbox to transform 3D-
TIN from one coordinate system to another:

Fig. 83. The “Coord system” tab

• In the Input coordinates system section select actual Coordinate system of input
resources (if it is different from project coordinate system). Perform the following
actions to do this:

1. Click the Select... button to specify initial coordinate system.

Coordinate system is specified using one of the following ways:

○ From DB – from international or Russian coordinate system database
(see’Coordinate systems databases’ in the Project creation’ User Manual);
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○ From file – allows to select coordinate system from files with *.x-ref-
system, extension located out of active profile resources;

○ From resource – from files with *.x-ref-system extension located in
active profile resources, for example, to select coordinate system from
another active profile project.

○ From GeoCalculator – from the list of GeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program”
User manual).

The GeoCalculator program allows to edit coordinate systems, to create new
ones, to perform import and export of coordinate systems (see the “The GeoCal-
culator program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.

2. [optional] When choosing coordinate system from database the Coordinate
system database opens, which contains the list of coordinate systems.

To perform fast search for coordinate system, input the whole coordinate system
name or its part to the Find input filed.

Fig. 84. Window used to select coordinate system from coordinate system database

3. [optional] To choose geoid to be used, click the button. Select proper type
of geoid usage:

○ No geoid;

○ EGM 96.

The system allows to use the EGM2008 geoid. Seemore details in the Installation
EGM2008 Geoid User Manual. After installation the geoid is displayed in the list.
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• In the Output coordinate system define target coordinate system in which it is
necessary to convert the 3D-TIN. To do this perform the actions described above
or click the Export model to Cesium button to select the appropriate coordinate
system.

For CESIUM 1.38 version, the coordinate system does not matches the geocentric ref-
erence one. It is rotated by -90 degrees around the X axis. CESIUM 1.70 coordinate
system matches the classic geocentric reference system with WGS84 ellipsoid and ori-
entation.

8. Click OK to start operation of 3D-TIN creation in usual mode.

In order to create 3D-TIN using distributed processing, do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Open the Monitor for distributed processing and specify Max MT tasks –
the maximum quantity of simultaneously running tasks onClient inMultiThread-
ing mode;

MultiThreading – in computer architecture, multithreading is the ability of a central
processing unit (CPU) (or a single core in a multi-core processor) to provide multiple
threads of execution concurrently, supported by the operating system.

This approach differs frommultiprocessing. In a multithreaded application, the threads
share the resources of a single or multiple cores, which include the computing units,
the CPU caches, and the translation lookaside buffer (TLB).

Where multiprocessing systems include multiple complete processing units in one or
more cores, multithreading aims to increase utilization of a single core by using thread-
level parallelism, as well as instruction-level parallelism. As the two techniques are
complementary, they are sometimes combined in systems with multiple multithreading
CPUs and with CPUs with multiple multithreading cores.

When setting this option, it is needed to take into account the Client’s specifications
i.e.RAM and the number of processor cores. The recommendedMaxMT tasks value
for a workstation having a multicore processor and 8 GBRAM is 1. The recommended
Max MT tasks value for a workstation with 16 GB RAM is 2, etc.

If the Bilateral filter is used for pre-filtering, when creating a very detailed 3D-TIN
surface, it is highly recommended to set Max MT tasks for a workstation with a mul-
ticore processor and 16 Gb RAM no higher than 1, and to decrease Tile size down
to 32 (see the Building tab),

3. Click the Distributed processing button.

Depending on the size of creation area the operation can take a long time.

116

DTM GenerationPHOTOMOD 7.5

general.pdf


Fig. 85. Textured 3D-TIN surface in the PHOTOMOD 3D-Mod program window

Fig. 86. Textured 3D-TIN surface in the PHOTOMOD 3D-Mod window (texture building function is
disabled)
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5.16.1. Transformation of 3D-TIN coordinate system

The system provides opportunity to transform 3D-TIN from one coordinate system to
another.

In order to transform 3D-TIN to another coordinate system perform the following actions:

1. Select Terrain › TIN › Convert 3D-TIN CS. The Convert 3D-TIN to another CS
window opens.

Fig. 87. Transform 3D-TIN to another coordinate system

2. Click the button in the Input 3D-TIN section and specify a source 3D-TIN file
in active profile resources.

3. Click the button in the Output 3D-TIN section and specify 3D-TIN name and
target folder in active profile resources.

4. In the Initial coordinates system section select actual Coordinate system of 3D-
TIN (if it is different from project coordinate system). Perform the following actions
to do this:

1. Click the Select... button to specify initial coordinate system.
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Coordinate system is specified using one of the following ways:

• From DB – from international or Russian coordinate system database
(see’Coordinate systems databases’ in the Project creation’ User Manual);

• From file – allows to select coordinate system from files with *.x-ref-system,
extension located out of active profile resources;

• From resource – from files with *.x-ref-system extension located in active
profile resources, for example, to select coordinate system from another
active profile project.

• From GeoCalculator – from the list of GeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program” User
manual).

TheGeoCalculator program allows to edit coordinate systems, to create new ones,
to perform import and export of coordinate systems (see the “The GeoCalculator
program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.

2. [optional] When choosing coordinate system from database the Coordinate
system database opens, which contains the list of coordinate systems.

To perform fast search for coordinate system, input the whole coordinate system name
or its part to the Find input filed.

Fig. 88. Window used to select coordinate system from coordinate system database

3. [optional] To choose geoid to be used, click the button. Select proper type
of geoid usage:

• No geoid;

• EGM 96.
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The system allows to use the EGM2008 geoid. See more details in the Installation
EGM2008 Geoid User Manual. After installation the geoid is displayed in the list.

5. In the Output coordinate system define target coordinate system in which it is
necessary to convert the 3D-TIN. To do this perform actions from step 4 or click
the Export to Cesium button to select the appropriate coordinate system.

For CESIUM 1.38 version, the coordinate system does not matches the geocentric reference
one. It is rotated by -90 degrees around the X axis. CESIUM 1.70 coordinate system
matches the classic geocentric reference system with WGS84 ellipsoid and orientation.

6. Click OK to convert 3D-TIN coordinate system.

To use distributed computing for changing of 3D-TIN coordinate system, do the
following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button.

5.16.2. Batch 3D-TIN creation

The system allows to create textured 3D-TIN surfaces in batch mode.

To create the textured 3D-TIN surface in batch mode, perform the following:

1. Choose Terrain › TIN › Build 3D-TIN (Batchmode...). The 3D-TIN creationwindow
opens;
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Fig. 89. The “3D-TIN creation” window

The 3D-TIN creation window contains the following elements:

• A toolbar in the upper part of the window, which is intended to save/load paramet-
ers settings on all tabs of the window and contains the following buttons:

○ – allows to load parameter’s settings saved previously to active profile re-
sources;

○ – allows to save all parameter’s settings to *.x-ini file located in active
profile resources;

○ – allows to load parameter’s settings from *.x-ini file located in a folder
of Windows file system;

○ – allows to save parameter’s settings to *.x-ini file located in a folder of
Windows file system;

○ – allows to restore the last-session’s settings;
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○ – allows to restore default parameter’s settings.

• TheResources section, theBuilding, Filtration, Texturing andCoord System
tabs;

• The Use all cores on local PC checkbox which allows to use all the cores of
workstation CPU for calculation operation;

It is necessary to clear the checkbox to use only one core.

• The Additional parameters button which allows to set additional parameters of
3D-TIN creation in Building and Texturing tabs.

2. Select the data source inResources section: several selected DEM files or folder
with DEMs.

• [optional] click the button to specify the input data (DEM files);

• [optional] click the button to specify the input data (a folder, containing DEM
files).

Click the button, to specify the output data folder;

3. [optional] Set the following main and additional 3D-TIN building parameters in an
appropriate tabs (see Section 5.16.

4. Click OK to start operation of batch 3D-TIN creation in usual mode.

In order to create 3D-TINs using distributed processing, do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Open the Monitor for distributed processing and specify Max MT tasks –
the maximum quantity of simultaneously running tasks onClient inMultiThread-
ing mode;

MultiThreading – in computer architecture, multithreading is the ability of a central
processing unit (CPU) (or a single core in a multi-core processor) to provide multiple
threads of execution concurrently, supported by the operating system.

This approach differs frommultiprocessing. In a multithreaded application, the threads
share the resources of a single or multiple cores, which include the computing units,
the CPU caches, and the translation lookaside buffer (TLB).

Where multiprocessing systems include multiple complete processing units in one or
more cores, multithreading aims to increase utilization of a single core by using thread-
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level parallelism, as well as instruction-level parallelism. As the two techniques are
complementary, they are sometimes combined in systems with multiple multithreading
CPUs and with CPUs with multiple multithreading cores.

When setting this option, it is needed to take into account the Client’s specifications
i.e.RAM and the number of processor cores. The recommendedMaxMT tasks value
for a workstation having a multicore processor and 8 GBRAM is 1. The recommended
Max MT tasks value for a workstation with 16 GB RAM is 2, etc.

If the Bilateral filter is used for pre-filtering, when creating a very detailed 3D-TIN
surface, it is highly recommended to set Max MT tasks for a workstation with a mul-
ticore processor and 16 Gb RAM no higher than 1, and to decrease Tile size down
to 32 (see the Building tab),

3. Click the Distributed processing button.

Depending on the size of creation area the operation can take a long time.

6. Contour lines

6.1. The “Contours” menu

The Contoursmenu contains usual menu items used for contours generating, editing,
import and export.

The Contours menu is located in the Terrain menu.

Table 5. Brief description of the “Contours” menu

FunctionMenu items
allows to load contour lines from *.x-data file (see
the “Vectorization” User Manual)

Load... (Ctrl+O, V)

allows to perform the quick access to recently
loaded contour lines

Recent

allows save or rewrite active contours layerSave
allows to save active layer with new nameSave as...
allows to save just selected contoursSave selected as...
allows to close contour lines layerClose
contains menu items used to create contour lines
with help of various source data

Build contours

contains items used to import contour lines from
files with different extensions (see the “Import of

Import

vector objects” chapter of the “Vectorization” User
Manual)
contains menu items used to perform export of
contour lines to files with different extensions (see

Export
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FunctionMenu items
the “Export of vector objects” chapter of the “Vector-
ization” User Manual)
allows to check created contours for crossing/self-
crossing, that occur after operation of contours
smoothing

Check contours intersections...

allows to perform quality control of contours creation
using regular points, if they were not used for con-
tours creation

Check contours by points

allows to merge created contours in automatic or
manual mode

Merge contours...

allows to check contours for breaks that occur after
manual or automatic contours merging

Check merging contours...

allows to connect created contours automatically or
manually (without merging into a single vector ob-
ject)

Contours connecting

allows to check elevations of created contours ver-
tices

Check contours vertices

allows to set a precision of vector objects coordin-
ates at level of decimal places

Precision of objects coordinates

allows to save, edit, and export contours within the
given notation sheets to the Panorama format

Prepare/export contours sheets

6.2. Contour lines generation

6.2.1. Generation contour lines by TIN

The system provides possibility to create contour lines – vector lines, joining points with
the same terrain elevation – by irregular spatial triangles network (TIN).

To create contour lines by TIN, perform the following actions:

1. Load TIN layer.

2. Choose Terrain › Contours › Build contours › From TIN... or use the Ctrl+N, C
hotkeys. The Create contours by TIN window opens.
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Fig. 90. Parameters of contour lines generation by TIN

3. [optional] Input minimal elevation level (Zmin), which will be zero-level for contours
creation, to the Starting level field.

In order to obtain information about elevation difference (Zmin, Zmax), right click on the
TIN layer in the Manager and select the Information item, or select Edit › Active layer ›
Layer information. The system displays the information window that contains information
about the layer.

4. In the Interval field specify contours interval in meters. Interval of Basic contours
equals to 1 contours Interval (displayed in the Basic contours field).

5. [optional] To create index contour lines the Index contour lines checkbox is on by
default. Set the checkbox off to cancel index contour lines creation.

The interval of index contour lines equals to five intervals of basic contours by default.
The system allows to set arbitrary interval of index contour lines manually.

6. [optional] To create intermediate contour lines the Intermediate contour lines
checkbox is on by default. Set the checkbox off to cancel intermediate contour lines
creation.

The interval of intermediate contour lines equals to half of basic contours interval by
default. The system allows to set arbitrary interval of intermediate contour linesmanually.

The Cut intermediate contours checkbox allows to automatically delete fragments of in-
termediate contours in the areas with increasing slope gradient.
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Fig. 91. Deletion of fragments of intermediate contours in the areas with increasing slope gradient

7. [optional] In order to cancel creation of short contours, set the Skip contour lines
shorter than checkbox on and input minimal contour length in meters.

8. [optional] To create contour lines as smooth curves, set the Bezier or Corner
rounding smoothing methods in the Smoothing section.

• [optional] if the Bezier smoothing method is selected, specify the smoothing de-
gree using the slider.

Fig. 92. Parameters of contour lines generation by TIN
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• [optional] if theCorner rounding smoothingmethod is selected, input the following
smoothing parameters:

○ Curvature radius for smoothing curve.

Set the auto checkbox to calculate Curvature radius for smoothing curve automat-
ically.

○ Precision – maximal distance from polyline segment to a curve in the area
between the two closest vertices.

Fig. 93. Parameters of contour lines generation by TIN

9. [optional] Set the Auto-update checkbox for automated re-generation of contours
created using TIN in case of the TIN layer editing.

10. Click OK. After that the system starts to create contours in a new layer Contours.

To edit created contours selectWindow › Contours classifier table (see Section 6.3).

6.2.2. Generation contour lines by DEM

The system provides possibility to create contour lines by digital elevation model (DEM).

In order to build contours using DEM perform the following actions:
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1. Load a DEM layer.

2. [optional] Create and select one or multiple vector polygons, if it is needed to build
a contours inside selected polygons;

3. Choose Terrain › Contours › Build contours › From DEM.... The Contours cre-
ation parameters window opens.

TheDEM parameters section displays information about elevation difference (Min.
elevation, Max. elevation) in DEM.

Fig. 94. Parameters of contour lines generation by DEM

4. [optional] In order to perform the of DEM smoothing operation, prior to contours
creation, set the Smooth checkbox on in theDEM section. Specify smoothing level
in the Smooth level field (maximal smoothing is applied at 1 value).

During smoothing the system uses information about adjacent nodes in each DEM node.
In order to specify number of adjacent nodes of DEM, select the Aperture size in the list.

5. [optional] To apply Gauss smoothing algorithm set the Smooth byGauss checkbox;
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6. [optional] Set the Build inside selected polygons checkbox to create a contours
within the selected polygons;

7. [optional] Input minimal elevation level (Zmin), which will be zero-level for contours
creation, to the Starting level field.

In order to obtain information about about elevation difference (Zmin, Zmax), select Edit ›
Active layer › Layer information or click the DEM layer by mouse right button in the
Manager and select Information. The system displays the information window that contains
information about the layer.

8. In the Interval field specify contours interval in meters. Interval of Basic contours
equals to 1 contours Interval (displayed in the Basic contours field).

9. [optional] To create index contour lines the Index contour lines checkbox is on by
default. Set the checkbox off to cancel index contour lines creation.

The interval of index contour lines equals to five intervals of basic contours by default.
The system allows to set arbitrary interval of index contour lines manually.

10. [optional] To create intermediate contour lines the Intermediate contour lines
checkbox is on by default. Set the checkbox off to cancel intermediate contour lines
creation.

The interval of intermediate contour lines equals to half of basic contours interval by
default. The system allows to set arbitrary interval of intermediate contour linesmanually.

11. [optional] In order to create contours as smoothed curves, set the Smoothing
checkbox on and specify a level of smoothing using the slider.

12. [optional] In order to cancel creation of short contours, set the Skip contour lines
shorter than checkbox on and input minimal contour length in meters.

13. Click OK. After that the system starts to create contours in a new layer Contours.

To edit created contours selectWindow › Contours classifier table.

6.2.3. Contours creation from smooth DTM

The system provides possibility to create contour lines as smoothed curve lines with
specified accuracy. Source data for contours creation are vector objects obtained after
stereo vectorization. If necessary the system allows to create a polygon and to use it
then as a border of contours creation area.

In order to build contours from smooth DTM perform the following actions:
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1. Load a layer containing vector objects.

2. Choose Terrain › Contours › Build contours › Smooth model.... The Build
contours from smooth DTM window opens.

Fig. 95. Parameters of contours creation from smooth DTM

3. In the Source layers section set the checkboxes on next to opened layers used
for contours creation.

4. In theWorking area border layer specify border of contours creation area:

• Rectangle – used to create rectangular border;

• Convex – used to create border using edge points of selected layer;
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• Use polygons from layer – select from the list a vector layer that contains
polygons used as working area border.

In order to define a border of contours creation area, just from selected polygons, set
the Selected only checkbox on.

5. In theModel accuracy field input acceptable deviation of contours elevation values
from source vector layer in meters.

The Model accuracy parameter should be specified based on errors values obtained
during creation of vector objects using correlator in stereomode.

6. In the Contours accuracy field input maximal deviation of contours from DEM by
Z.

7. [optional] Input minimal elevation level (Zmin), which will be zero-level for contours
creation, to the Starting level field.

In order to obtain information about elevation difference (Zmin, Zmax), right click on the
TIN layer in the Manager and select the Information item, or select Edit › Active layer ›
Layer information. The system displays the information window that contains information
about the layer.

8. In the Interval field specify contours interval in meters. Interval of Basic contours
equals to 1 contours Interval (displayed in the Basic contours field).

9. [optional] To create index contour lines the Index contour lines checkbox is on by
default. Set the checkbox off to cancel index contour lines creation.

The interval of index contour lines equals to five intervals of basic contours by default.
The system allows to set arbitrary interval of index contour lines manually.

10. [optional] To create intermediate contour lines the Intermediate contour lines
checkbox is on by default. Set the checkbox off to cancel intermediate contour lines
creation.

The interval of intermediate contour lines equals to half of basic contours interval by
default. The system allows to set arbitrary interval of intermediate contour linesmanually.

11. [optional] To create contours with number of nodes more then specified value, the
Minimal number of vertices in a contour checkbox is set on by default. Input a
number of nodes to the input field to exclude contours with less number of nodes.

12. [optional] To create contours as arc segments (curves) set the As smooth curves
checkbox on.
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13. Click OK. After that the system starts to create contours in a new layer Contours.

6.2.4. Contours creation in batch mode

The system provides possibility to create contour lines in batchmode. Batchmode allows
to create multiple files of contour lines simultaneously and to save them to specified
folder.

Contours creation in batch mode is possible in 64-bit system version only.

In order to build contours using TIN in batch mode perform the following actions:

1. Choose Terrain › Contours › Build contours › In batch mode.... The Create
contours in batch mode window opens.

Fig. 96. Parameters of contours creation in batch mode
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2. Choose a folder containing vector objects in resources tree.

The button allows to display all available resources in nested files. The button allows
to refresh part of the window with resources.

The button allows to show a list with 10 recently selected resources.

3. Select file with contours in the list and click the button to add a layer.

The and buttons allow to add to the list or remove from it all added files with vector
objects, the button allows to remove selected file from the list.

4. Repeat the 2 and 3 steps to add next files with vector objects.

5. Click the button in theWorking folder field and select a folder in active profile
resources.

6. Click the button in the Output folder filed and select a folder in active profile
resources to save output contour lines.

7. Configure necessary parameters of contours creation like for Generation contour
lines by TIN.

8. Click OK to start contour lines creation in batch mode.

To edit created contours selectWindow › Contours classifier table.

6.3. Contour lines editing

To edit contours display parameters the system providesWindow › Contours classi-
fier table menu item. Display parameters are saved and applied during creation or
loading of new contours layer.

Fig. 97. Contours classifier

The Contours window allows to configure the following parameters:

• – allows to hide/show selected type of contours in 2D-window;

• – allows to select a type of contours to be edited;
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• Layer color – allows to configure color to display selected contours type;

To change contour color, double click the Layer color button. The Color window opens.
Choose contour color and click OK.

• input field allows to specify width of selected contours type, that remains the same
during scale change.

To change a contour width, specify a value in this input field (this parameter remains the
same during scale change).

6.4. Operations with contour lines

Contours are polylines that include straight line segments (broken lines) or arc segments
(curves). Contours saving, loading and editing is performed in the same way as for any
vector layer (see the “Vectorization” User Manual).

For contours editing the system provides tools of polylines editing, see description in
the “Vectorization” User Manual.

The system provides for automatic vector object corner round off through the increase
of vertex number (see the “Corners round off” and “Convolution smoothing” chapters
in “Vectorization” User Manual).

An angle between the segments is rounded by inscribing a circular arc of a given radius in it.

6.4.1. Saving contour lines

To save and rewrite active contours layer select Terrain › Contours › Save or click the
layer name by mouse right button in the Manager and choose the Save in right-click
menu.

To save active layer with new name select Terrain › Contours › Save as... or click the
layer name by mouse right button in the Manager and choose the Save as... in right-
click menu, specify file name and destination in active profile resources.

To save just selected contours, select all contours that should be saved and select
Terrain › Contours › Save selected as.... After that vector objects are still associated
with classifier.

In order to return to vector layer state at the time of the last save, select Vectors › Re-
vert.

The Contours layer is opened in the same way as a layer with usual vector objects, see
Section 5.3.2.
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The system allows to save, edit, and export contours within the given notation sheets
to the Panorama format. This is exchange format with *.sit and *.map extensions, that
is used in GIS Map system.

6.4.2. Export of contours sheets

The system allows to save, edit, and export contours within the given notation sheets
to the Panorama format. This is exchange format with *.sit and *.map extensions, that
is used in GIS Map system.

The system provides the possibility of cutting vector objects of one layer by the boundaries of
polygons of another layer (Vectors › Geometry › Cut objects by selected polygons). Since
both contours and notation sheet boundaries are vector objects, this function can be used to
save contours within the selected notation sheets (see the “Cut vectors by selected polygons”
chapter of the “Vectorization” User Manual).

To do this, perform the following:

1. Create notation sheets (see the “Generators of splitting into sheets” chapter of the
“Vectorization” User Manual);

2. Select notation sheets within which you need to save/export contours;

3. Choose Terrain › Contours › Prepare/export contours sheets. The Prepare/ex-
port contours sheets window opens:
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Fig. 98. The “Prepare/export contours sheets” window

4. In the Сommon tab set the following options:

• [optional] Clear the Performing and splitting into sheets checkbox in order not
to save contours within the selected notation sheets (see the Performing and
splitting into sheets tab);

• [optional] Clear the Export to SIT checkbox in order not to export contours
within the selected notation sheets to the Panorama format (see Export to
Panorama GIS tab);

• In the Contours root folder field click the button and select the folder con-
taining initial contours in the active profile resources;

○ [optional] Clear the Search in subfolders checkbox in order not to search
initial contours in subfolders;

• In the Output sheet name attribute field, input the attribute’s name where
notation sheet names are recorded;

A name of the attribute where notation sheet names are recorded (Name, by default) is
set during notation sheet creation (see the “Generators of splitting into sheets” of the
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“Vectorization” User Manual). To check the attribute’s name, select a notation sheet and
chooseWindow › Object attributes.

• In the Output folder field input the path to save contours or click the button
to choose the folder name and the path in the active profile resources to save
contours within the selected notation sheets;

• [optional] Clear the Delete intermediate data checkbox in order not to delete
processing data after calculation accomplishment.

5. In the Performing and splitting into sheets tab, set the options for contours
editing within the selected notation sheets:

To save contours within the selected notation sheets (without additional editing), clear all
the checkboxes in the Performing and splitting into sheets tab.

Fig. 99. The “Processing and splitting into sheets” tab

• [optional] For automated merging of contours with “breaks”, the default checkbox
Merge contours distance is set. Clear the checkbox not to merge contours, or
input maximal distance between contours in meters, at which the system performs
contour merging.
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• [optional] In order not to Correct contours direction, clear the appropriate
checkbox (only for the Panorama format);

• [optional] To avoid adding point vector objects denoting peaks and pits, clear the
Create peaks checkbox;

• Input the Contours step in the appropriate field;

To get this information from the project, open the layer with contours.

• To set up the parameters to calculate elevations of point objects denoting peaks
and pits, set Top/bottom points elevation shift in contour interval part;

For example, if Top/bottom points elevation shift in contour interval part is 1/3, than
the elevation of a point denoting an upland point will be a sum of the value of the elevation
of the closest contour to the point and one third of contour spacing. Precision of peak
points is set in the Export to Panorama GIS tab (see below).

The system also allows to clarify elevations of point objects denoting peaks and pits
using a DEM together with Contours step and Top/bottom points elevation shift in
contour interval part parameters (see below).

• [optional] In order not to Correct flat areas when creating peaks, clear the ap-
propriate checkbox;

• [optional] To clarify elevations of point objects denoting peaks and pits, the Peaks
height from DEM checkbox is set by default. To avoid taking DEM into account
when calculating elevations of point objects denoting peaks and pits, clear this
checkbox or click the button to select DEM in the active profile resources;

• [optional] To create hachures when saving contours within selected notation
sheets, the default Create hachures with length checkbox is set. Clear this
checkbox in order not to create hachures or input hachures length, in meters;

• [optional] Clear the Fill void attributes (contours, peaks, hachures) checkbox,
if this action is not required;

Filling void attributes can be required, for example, for additional vector objects (contours)
created manually.

6. In Export to Panorama GIS tab, set options for contour’s export to Panorama ex-
change format within the selected notation sheets:
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Fig. 100. The “Export to Panorama GIS” tab

• In the Output folder field, enter the path to save exchange files or click the
button to choose the path for files saving in the Windows file system;

• To indicate the path to the file with classifier, click the button in the Classifier
file name field;

Files with classifiers are located in C:\Program Files\PHOTOMOD6 x64\MapView11\ru
и C:\Program Files\PHOTOMOD6 x64\MapView11\en folders by default. For example,
when exporting contours within 1:2000 notation sheets, choose the map2000.rsc file
with classifier.

• [optional] Edit Contours codе, if needed;

• [optional] Edit Contours codе name, if needed;

• [optional] Edit Fat contours codе, if needed;

• [optional] Edit Fat contours codе name, if needed;

• [optional] Edit Peaks codе, if needed;

• [optional] Edit Peaks codе name, if needed;
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• [optional] Edit Hachures codе, if needed;

• [optional] Edit Hachures codе name, if needed;

• Set the Precision of peak points.

7. Click OK.

Contours located within selected notation sheets are saved in the preset output
folder in the active profile resources in separate folders whose names correspond
to notation sheet names.

Files from the Panorama exchange format are saved in the selected output folder
in the Windows file system.

To check files from the Panorama exchange format, run the GIS Panorama Mini
software. In the GIS Panorama Mini window select File › Open and choose ex-
change files with *.sit extension in the selected output folder in the Windows file
system.

This software is not included with the PHOTOMOD but can be installed separately. If the
GIS Panorama executable file is not found, an appropriate system message will appear.
The software description and URL hyperlink (for download) are indicated in this message.

Click Yes to go to path settings (see the “Paths settings” chapter of the “General system’s
parameters” User Manual.
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Fig. 101. The “GIS Panorama Mini” program window

6.4.3. Contours merging

The system provides possibility to merge created contours in automatic or manual
mode.

In order to merge contours manually, perform the following actions:

1. Load or create a layer with contour lines.

2. Select Terrain › Contours › Load and open a file containing contour lines from
adjacent stereopair. The Loading window opens.

3. Click the Add new data to ... layer without unloading existing data button to
add contours from adjacent stereopair to a source layer.

4. Use tools intended for polylines editing (as well as snapping) for contours manual
merging (see the “Snapping mode” and “The ’Topology’ menu” chapters of the
Vectorization” User Manual).

In order to start automatic contours merging, perform the following actions:
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1. Select Terrain › Contours › Merge contours.... The Parameters window on the
Source contours tab opens.

Fig. 102. Parameters of contours merging on the ’Source contours’ tab

2. Choose a folder containing contours in resources tree.

The button allows to display all available resources in nested files. The button allows
to refresh part of the window with resources.

The button allows to show a list with 10 recently selected resources.

3. Select file with contours in the list and click the button to add a layer to be merged.

The and buttons allow to add to the list or remove from it all added files with contours,
the button allows to remove selected file with contours from the list.

4. Repeat the 2 and 3 actions to add next files with contours.

It is necessary to choose for merging at least two files containing contour lines.
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5. Click the Parameters tab.

Fig. 103. Parameters of contours merging on the ’Parameters’ tab

6. [optional] Input maximal distance between contours in meters, at which the system
performs contours merging, to the Undershoot field.

7. [optional] To the Overshoot input acceptable part of contour line to be deleted in
meters.

8. In the Smooth level section specify a smoothing level of smoothed contour from
vertices of unsmoothed one: Low, Average or Large.

9. Click OK. New vector layer that contains merged contours is created in theManager.

The system also allows to connect contours (without merging contours into a single vector object
and creating a new layer).

6.4.4. Check of contours merging quality

The system provides possibility to check contours for breaks that occur after manual
or automatic contours merging.
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To perform check of contours merging, select Terrain › Contours › Check merging
contours .... The Parameterswindow opens. In theCheck distance input field specify
maximal distance between contours in meters, when the system starts to search for
contours breaks, and click OK.

If the contours breaks are detected the Erroneous contours vertices window opens.

Fig. 104. Erroneous contours vertices

The window displays a list of contour lines breaks, where:

• N – is break serial number;

• X,Y,Z – coordinates of break’s middle point;

• DL – distance between contours in meters.

Select a line in the list by mouse click. After that marker is placed to the break’s middle
point and is displayed in 2D-window.

To ’connect’ contour break, select the contour in the list and click the button.

To ’connect’ all found contour breaks, click the button.

6.4.5. Contours connecting

The system provides possibility to connect created contours (without merging) in auto-
matic or manual mode.

In order to connect contours manually, perform the following actions:

1. Load or create a layer with contour lines.

2. Select Terrain › Contours › Load and open a file containing contour lines from
adjacent stereopair. The Loading window opens.

3. Click the Add new data to ... layer without unloading existing data button to
add contours from adjacent stereopair to a source layer.
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4. Use tools intended for vertices editing (as well as snapping) for contours manual
connecting (see the “Snapping mode” and “Vector objects editing” chapters of the
Vectorization” User Manual).

In order to start automatic contours connecting, perform the following actions:

1. Select Terrain › Contours › Contours connecting.... The Contours connecting
window opens.

Fig. 105. The “Contours connecting” window

2. In the list of opened vector layers, select two layers with contours;

3. Input maximal distance between contours in meters, at which the system performs
contours connecting, to the Maximum deviation field.

4. [optional] Set the Do not change the top layer checkbox to move contour vertices
only within one of the selected layers (otherwise vertices will be moved within both
selected layers during the connection operation);

The and buttons allows to change positions of the selected layer in the list of down-
loaded vector layers.

5. Click OK. Ending contour vertices belonging to different layers, the distance between
which does not exceed Maximum deviation, converge (in central position in the
plan if the Do not change the top layer checkbox is cleared), otherwise ending
vertices from the lower layer will be moved to positions of vertices belonging to the
upper layer.

If there will be 3 or more vertices for “connecting” contours having one elevation at
a distance not exceeding Maximum deviation, the Unconnected points window
opens. The window contains the table with vertices which may require manual
editing. If a line in the table is selected, the marker is moved to the appropriate
vertex.
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Fig. 106. The “Unconnected points” window

The system also provides for merging contours (a new layer containing contours merged into
single vector objects is created).

6.4.6. Precision of objects coordinates

The system allows to set a precision of vector objects coordinates at level of decimal
places.

A need to set decimal places for contour heights can be arisen after recalculation of
vector objects coordinates from one coordinate system to another one (see the
“Transformation of objects coordinates” chapter of “Vectorization” User Manual).

To set a precision of vector objects coordinates, perform the following:

1. Create or load vector layer;

2. [optional] Select vector objects;

3. Select Terrain › Contours › Precision of objects coordinates. The Objects
precision window opens;

Fig. 107. The “Objects precision” opens
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4. [optional] Turn off Selected objects checkbox to apply parameters of coordinates
precision for the all objects of vector layer;

5. Set number of decimal places for XYZ coordinates;

If decimal places are zero coordinates of vector objects will be rounded to integers.

If decimal places are negative numbers coordinates of vector objects will be rounded to
points (i.e. “-1” value leads to rounding to units, “-2” value leads to rounding to tens etc.).

6. Click OK. As a result, selected or all the objects of vector layer are recalculated
according to specified precision of coordinates.

6.5. Accuracy control of contours creation

6.5.1. Control of contours crossing

The system allows to check created contours for crossing/self-crossing, that occur after
operation of contours smoothing.

In order to check contours for crossings perform the following actions:

1. Load or create a layer with contour lines.

2. Select Terrain › Contours › Check contours intersections.... The Parameters
window opens.

Fig. 108. Parameters of contours intersections control

3. [optional] To check intersections of adjacent contours only, theNeighbour contours
only is set on by default. Set the checkbox off to check all contour lines for intersec-
tions.

Operation of created contours check for intersections may take a long time.

4. Click OK. The system start operation of created contours check for intersections.
When the check is completed the system opens the Intersection points window.
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Fig. 109. Coordinates of intersection points of contour lines

In order to export a list of contours intersection points to file with csv extension,
click the button.

To create a new layer that contains intersection points as points, click the button.

5. Select a point in the list by mouse click. After that marker is placed to the crossing
point and is displayed in 2D-window.

6. Use tools of polylines editing to edit contours and correction of intersection\self-in-
tersection errors (see description in the Vectorization User Manual).

6.5.2. Check contours by points

The system provides opportunity to perform quality control of contours creation using
regular points, if they were not used for contours creation.

To start the check operation it is necessary that the Contours layer and the Vectors layer (con-
taining points) are loaded and displayed in the Manager.

In order to start contours check operation by points, perform the following actions:

1. Load or create a layer with points.

2. Make active the layer with contour lines.

3. Select Terrain › Contours › Check contours by points. The Parameters window
opens.
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Fig. 110. Parameters of contours check using points

4. Select a layer containing points.

5. In theMaximum residual field input a value of maximal deviation of contours from
a value of points elevation by Z (in meters).

6. [optional] In order to include to check operation points located on contours with the
same elevation (for example, N=27 (Ext=597.0, 597.0) and N=28 (Ext=597.0,
597.0)), set the Analyse points between equal contours checkbox on.

7. Click OK. The Check contours by points window opens.

Fig. 111. Points coordinates during control of contours using points

The window displays a list, where:

• N – is point serial number;

• X,Y,Z – point coordinates;
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• Ext – distance between contours in XY plane;

• Z'– elevation difference between contours and points, that exceeds maximal
deviation.

In order to export the list to file with csv extension, click the button.

8. Select a point in the list by mouse click. After that marker is placed to the selected
point and is displayed in 2D-window.

9. Use tools of polylines editing to edit contours (see description in the Vectorization
User Manual).

6.5.3. Checking elevations of contour vertices

The system provides for the possibility of checking elevations of contours’ vertices, as
well as whether contour elevations correspond to estimated contour interval. This
function may be required if the contours were created by the user manually.

For this, perform the following:

1. Load or create a layer with contours

2. Choose Terrain › Contours › Check contour vertices. The Check contour elev-
ations window opens.

Fig. 112. The “Check contour elevations” window

• To check vertex elevations, set the appropriate checkbox. The system checks
whether all contour vertices have the same elevation;

• To check contours elevation, set the appropriate checkbox. To successfully
complete this operation, it is necessary to correctly set the start level of contours
and their elevation step (the user must do these in advance). As a result, a
check is made whether all the elevations of the contours increase relative to the
start level, in strict adherence to the specified elevation step.
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Simultaneous check of vertices elevations and contour elevation is not recommended.

3. Click OK.

The contour check runs. If there are no errors, an appropriate message is displayed:

Fig. 113. Informational message about no errors

In case of errors, the Correct contour vertices height window opens:
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Fig. 114. The “Correct contour vertices height” window

The window displays a table. Each of the lines contains the following information:

• Number of the error entry;

• Type of error detected and number of involved vertices:

○ Invalid vertices elevations and total number of vertices with an error;

○ Invalid contour elevation and total number of contour vertices.

A large number of such errors may indicate that the elevation step was ill-specified
by the user

• Current vertices height;

• Estimated correct height.

If for some reason it is impossible to determine the correct value of elevation of a
particular contour, the entry ??? is displayed in the respective line instead of this
value.

Such errors, especially numerous, may indicate that the data being checked are initially
incorrect (for example, the checked vector objects are not contours).

4. The system provides for automated correction of contour vertex elevations.
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It is recommended to correct sporadic Invalid vertices elevations in this way. If an Invalid
contour elevation was detected, it is recommended to first find out the cause of this error.

• [optional] To correct selected contour, select the appropriate error entry and
click ;

○ [optional] If the correct height is not known, theObject vertices heightwindow
opens:

Fig. 115. The “Object vertices height” window

Enter correct height and click ОК.

• [Optional] To correct all contours, click .

It is strongly discouraged to correct all contours if the correct height is unknown for
some objects.

7. Digital Elevation Model

7.1. The “DEM” menu

The DEM menu contains standard menu items used to load and save DEM layers, as
well as menu items used to perform various operations on DEM creation, accuracy
control, filtering and editing.

The DEM menu is located in the Terrain menu.

Table 6. Brief description of the DEM menu

FunctionMenu items
allows to load DEM from *.x-dem fileLoad DEM... (Ctrl+O, D)
allows to load DEM from external data without its
conversion to internal format

Open from file...

allows to perform the quick access to recently
loaded DEM files

Recent

allows to save opened DEM to a new fileSave copy
allows to save DEM areaSave selection
allows to save a DEM as a raster file with geodetic
reference

Save as georeferenced raster...
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FunctionMenu items
allows to close DEMClose
allows to close all opened DEM layersClose all opened layers
contains menu items which allow to perform batch
management of DEM layers visibility in the Layer
manager

Layers visibility

contains menu items used to create DEM with help
of various source data

Build DEM...

allows to recreate DEM after changing of TIN base
layer

Rebuild by TIN

is used to restoring of DEM consistency, which may
be disrupted by applying various operations or DEM
filtering

Restore

contains menu items which can be used to filter
DEMs

Filter

contains menu items used to restore blank cells of
DEM using various methods

Fill null cells

is used to edit coverage area of DEMCut by selected polygons
is used to remove edge areas of DEM, that include
blank cells

Cut null edges

is used to transpose DEM from the left coordinate
system to the right one and vice versa

Transpose

allows to change coordinate system of DEMTransform to another coordinate system
allows to change coordinate system of multiple
DEMs

Batch transform to another coordinate system

allows to recreate DEM considering results of the
last adjustment (if the project was adjusted after
DEM creation once more)

Rebuild considering last adjustment

is used to parallel displacement of DEM by axesShift
allows to split DEM into sheet to save DEM in parts
in separate files

Split DEM into sheets

allows to merge DEMs, that have overlap areaMerge DEMs
is used to perform accuracy control DEM creation
using various data

Accuracy control

allows to calculate a slope mapCalculate slope map
allows to convert DEM to point cloud (LAS)Convert to LAS
allows to convert DEM cells to points with specified
simplifying

Convert to points...

allows to add points to DEM that helps to refine DEM
cells values

Write points to DEM

contains menu items used to perform export of DEM
to different formats

Export...

contains items used to import DEM from files with
*.grd, *.asc, *.tif, *.dem, *.mtw, *.dt1, *.dt2,
*.img, *.pix, *.hgt extensions

Import...
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7.2. General information

DEM (Digital Elevation Model) – is digital cartographic representation of the earth’s
surface in the form of a regular grid of height values.

A source data for DEM creation is the following data, taken individually or in combination:

• TIN (Triangulated Irregular Network);

• regular or irregular points (point objects);

• vector objects (see the Vector objects creation chapter in the ’Vectorization’ User
Manual).

DEM is displayed in 2D-window, and also could be opened to view in 3D-window or in
2D-window of stereopair in stereo mode.

DEM in stereo mode may be displayed inaccurately.

To view information about DEM select Information item in the Manager. The system
displays information window which includes the following information about the layer:

• layer name;

• full path to layer file;

• resource size;

• file creation time;

• presence of data and changes in the layer;

• possibility to change the layer;

• coordinates of DEM border nodes, including Z-coordinate;

• ground sample distance;

• DEM size (number of cells);

• bytes per sample;

• layer coordinate system.
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Fig. 116. Information about DEM layer

7.2.1. DEM layer display settings

For DEM layers could be changed transparency of layer visibility in 2D-window.

Changing of layer transparency is possible only if theDo not use textures for precision raster
display checkbox is set off on a System tab of the Settings window (see the General systems
parameters User Manual).

To do this perform the following:

1. Double-click on layer objects color button ( ) in a Layer manager. The Layer
display settings window opens.

Fig. 117. Layer display settings

2. Set the layer transparency.

3. Click the Apply button to display changes in 2D-window.
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4. Click OK to save parameters.

7.3. DEM creation

7.3.1. DEM creation by TIN

The system provides possibility to create DEM using irregular spatial triangles network
(TIN). Perform the following actions to do this:

1. Create or load source TIN.

2. Choose Terrain › DEM › Build DEM › From TIN (Ctrl+N, D). The DEM by TIN
creation parameters window opens.

Fig. 118. DEM by TIN creation parameters

3. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters.

Default values are coordinates of rectangle corners, which generate TIN creation area.

4. In the Cell size specify the DEM cell size in meters to define cell size of output
DEM. The Cells number, calculated considering specified cell size, displays in the
Height andWidth fields. Also theApproximately DEM size in megabytes displays
in the appropriate field.
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DEM cell size should be comparable to average distance between points of base TIN
layer. If less cell size is used, the time of DEM creation and size of output file increase, but
accuracy is not.

Click the From project button to setup DEM cell size that equals to average GSD value
in the project.

5. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

6. Click OK. Specify DEM file name, define a folder in active profile resources and
click Save (see also Section 7.10 and DEM load). The system starts DEM creation
operation. After that the system creates new layer in the Manager and shows a
message about operation successful or unsuccessful completion.

Fig. 119. DEM built from TIN

Whenmarker is moving over DEM, the status panel in 2D-window displays XYZ-coordin-
ates of DEM points.

The system allows to recreate DEM after changing of TIN base layer. To do this use
the Terrain › DEM › Rebuild by TIN menu item.
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7.3.2. DEM creation using regular points

The system provides possibility to create DEM using a set of points created in regular
grid nodes or imported from external files. Perform the following actions to do this:

1. Create or load a layer with points.

2. Select Terrain › DEM › Build DEM › From regular points... The Parameters of
DEM building by regular points parameters window opens.

Fig. 120. DEM creation using regular points

3. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.

Coordinates of border points of source layer are default values.

4. Specify Cell size in meters to change size of output DEM cell.

DEM cell size should be commensurate with the average distance between points. If less
cell size is used, the time of DEM creation and size of output file increase, but accuracy is
not.

5. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

6. [optional] In order to exclude points with specified elevation from creation operation,
set the Exclude Z values checkbox on and input the parameters in meters.

7. Click OK. Specify DEM file name, define a folder in active profile resources and
click Save (see also Section 7.10 and DEM load). The system starts DEM creation

159

DTM GenerationPHOTOMOD 7.5



operation. After that the system creates new layer in the Manager and shows a
message about operation successful or unsuccessful completion.

7.3.3. DEM creation using points

The system provides possibility to create DEM using points (point vector objects located
on the terrain relief surface). Perform the following actions to do this:

1. Create or load a layer with points.

2. Select Terrain › DEM › Build DEM › From points.... The Parameters of DEM
building from points parameters window opens.

Fig. 121. Parameters of DEM creation from points

3. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.

Coordinates of border points of source layer are default values.

4. Specify Cell size in meters to change size of output DEM cell.

DEM cell size should be commensurate with the average distance between points. If less
cell size is used, the time of DEM creation and size of output file increase, but accuracy is
not.
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5. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

6. Specify Search area size in meters to change ’sliding window’ size (in meters on
terrain).

’Sliding window’ method – means moving of some frame over set of points from node to
node of DEM considering elevations and weights of points falling into the ’sliding’ frame.

A value of DEM cell (elevation), located in the middle of ’sliding window’, is define as the
weighted mean value of heights of the points in the ’sliding window’ . The weight of every
point is inversely proportional to the distance between the point and the center of the
’sliding window’.

Cell size of output DEM should not exceed a size of the ’sliding window’, specified in the
Search area size field.

7. Specify Cache size parameter in lines of search for points in a specified search
area by cell size.

Cache size is used to define a number of lines of search area.

8. Click OK. Specify DEM file name, define a folder in active profile resources and
click Save (see also Section 7.10 and DEM load). The system starts DEM creation
operation. After that the system creates new layer in the Manager and shows a
message about operation successful or unsuccessful completion.

7.3.4. DEM creation using CSV-file

The system provides possibility to create DEM using data obtained from CSV-file.

It is possible to use points coordinates from CSV-file only if points coordinates are recorded
using the template Name X Y Z.

To create DEM by CSV-file perform the following actions:

1. Select Terrain › DEM › Build DEM › From CSV file data... The Parameters of
DEM building by CSV file parameters window opens.
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Fig. 122. DEM creation using CSV-file data

2. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.

Coordinates of border points included to source CSV-file are default values.

3. [optional] To define output DEM border from CSV-file data click the Read extents
from file button.

4. Specify Cell size in meters to change size of output DEM cell.

DEM cell size should be commensurate with the average distance between points. If less
cell size is used, the time of DEM creation and size of output file increase, but accuracy is
not.

5. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

6. Click the button and select CSV-file to be used for DEM creation.

7. [optional] In order to exclude points with specified elevation from creation operation,
set the Exclude Z values checkbox on and specify the value in meters.

8. [optional] In order to swap coordinate system (left/right), set the Swap X, Y checkbox
on. At that the coordinate system do not change.
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If the Swap X Y checkbox is cleared, the vector objects will be imported in the right coordin-
ate system. Otherwise, in the left one.

9. Click OK. Specify DEM file name, define a folder in active profile resources and
click Save (see also Section 7.10 and DEM load). The system starts DEM creation
operation. After that the system creates new layer in the Manager and shows a
message about operation successful or unsuccessful completion.

7.3.5. DEM creation using smooth model

The system provides possibility to build a DEM using smooth model created by objects
of selected vector layers. When using smooth model the system creates smoothed
DEM with specified accuracy.

To create DEM by smooth model perform the following actions:

1. Select Terrain › DEM › Build DEM › Smooth model.... The Parameters of DEM
building by smooth model window opens.

Fig. 123. Parameters of DEM creation using smooth model

2. In the Source layers section set the checkboxes on next to base point layers used
for DEM creation.
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Click the button to select all layers, click the button to unselect all layers, or click the
button, invert layers selection.

3. In theWorking area border layer specify border type of working area:

• Rectangle – used to create rectangular border;

• Convex – used to create border using edge points of selected layer;

• Use polygons from layer – used to create a border from the layer, which poly-
gons are used as a border for DEM creation area. Set the Selected only
checkbox on, to use just selected polygons as a border, otherwise, a DEM will
be created considering all polygons of the layer.

4. In theModel accuracy field input acceptable deviation of DEM cells elevation values
from source vector layer in meters.

The Model accuracy parameter should be specified based on errors values obtained
during creation of vector objects using correlator in stereomode.

5. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters.

6. In the Cell size section specify DEM cell size in meters to change a size of output
DEM cell. In the Height andWidth fields the system displays nodes number calcu-
lated with specified DEM cell size. There is also displayed the Appr DEM size in
megabytes.

DEM cell size should be commensurate with the average distance between points. If less
cell size is used, the time of DEM creation and size of output file increase, but accuracy is
not.

Click the From project button to setup DEM cell size that equals to average GSD value
in the project.

7. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

8. [optional] To reset to default parameters, click the Refresh button.

9. Click OK. Specify DEM file name, define a folder in active profile resources and
click Save (see also Section 7.10 and DEM load). The system starts DEM creation
operation. The new layer is created in the layer manager.
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7.3.6. Dense DEM generation using SGM method

The system provides possibility of generation of dense digital elevation model (DTM),
which cell size coordinates to one pixel of image, using SGM (Semi-Global Matching)
method. The method supports a wide range of input data: aerial central projection im-
ages, UAS data, pushbroom scanner imagery, VisionMap and ADS data.

DEM creation using dense model is executed for adjusted images block only (see “Block adjust-
ment” User Guide). Otherwise the DEM generation is not performed or is performed incorrectly.

When building a dense DEM using the SGM method within the projects of the Satellite scanner
imagery and ADS types (see the “Project types” in the “Creating project” User Manual), it is
necessary to create areas without background (see the “Creating areas without background
(useful areas)” in the “Creating project” User Manual)

When processing Satellite scanner imagery or ADS projects, the program checks the presence
of areas without background automatically, then, if they are absent, builds them automatically
with default parameters or uses the areas without a background previously created by the user,
if available.

The areas without background created in such a way can then be edited by the user for further
use, e.g. when rebuilding a DEM based on updated data (if appropriate). However, in most
cases, the preliminary creation of areas without background and/or their manual correction are
not required.

When creating a DEM using the SGM method for projects on the base of central projection
aerial imagery (see the “Project types” in the “Creating project” User Manual), automatic creation
of areas without background is not performed. However, if areas without background, for some
reason, will be manually created by the user beforehand, they will be taken into account when
building a DEM.

This may be necessary in cases when aerial images have areas containing a background, and
this, for example, cannot be corrected through theOffset from image boundaries customization
(see below).

For dense DEM generation using SGM method the following output data is provided:

• [optional] DEM generation for a predetermined area;

○ [optional] True Ortho creation for an area limited by DEM boundaries.

• [optional] Point cloud (LAS) generation for an area limited by DEM boundaries.

For dense DEM generation using SGMmethod the system allows the following workflow:

1. DEM generation for a predetermined area;

2. Main processing: applying buildings and vegetation filters to created DEM and/or
performing empty cells restoring;

3. [optional] Additional processing — median and/or smoothing filtering.
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If intermediate data is not deleted after operation completing, the system allows to run in-
dividual stages of the processing (filtering and smoothing) without re-calculation of the
source DEM.

To generate dense digital elevation model using SGM method perform the following
actions:

1. Specify a grid to define DEM creation area.

Since the coordinates calculation is performed in each pixel of the selected area, the grid
nodes are not considered. The grid is used just as a border of DEM creation area. A shape
of grid borders could be rectangular or as arbitrary polygon (or several polygons).

2. Select Terrain › DEM › Build DEM › Dense DSM (SGM method).... The SGM
parameters window opens.

If a grid not was not created in advance, the Grid properties window opens, that allows
to create a grid for the entire images block.

Fig. 124. SGM parameters

The toolbar in the upper part of the window is intended to save/load parameters
settings of DEM creation and contains the following buttons:

• – allows to load parameter’s settings saved previously to active profile re-
sources;
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• – allows to save all parameter’s settings to *.x-ini file located in active profile
resources;

• – allows to load parameter’s settings from *.x-ini file located in a folder of
Windows file system;

• – allows to save parameter’s settings to *.x-ini file located in a folder of
Windows file system;

• – allows to restore the last-session’s settings;

• – allows to restore default parameter’s settings.

3. Define the Search area in the appropriate section:

• All images – allows to select all images of a block;

• Selected images – allows to select block images highlighted in 2D-window;

• Active stereopair – allows to select images of a stereopair opened in active 2D-
window.

All selected stereopairs should be located on adjusted part of a block (see “Block adjust-
ment” User Guide). Otherwise, the calculation is not performed or is performed incorrectly.
In the first case the system displays error message, in the second one – it is not possible
to match calculated points to project coordinate system.

4. Specify the settings that determine which stereopair selection method will be
carried out:

• By number of tie points – by default, during processing, one stereopair is selec-
ted for each of the images, based on the maximum number of common tie points.
The stereopair search is carried out over the entire block of images (both in-strip
and among images located on neighboring strips);

○ [optional] To usemore stereopairs, set the appropriate checkbox. The search
for additional stereopairs is also carried out among all the images. It should be
noted, that the number of potential stereopairs for each image (in particular,
taking into account inter-strip pairs) can be quite large. The system allows the
user to limit the max. number of stereopairs per image to no more than the
specified one, in the appropriate field.

Using additional stereopairs allows for compensating for insufficient overlaps between
images, which, under certain circumstances, can lead to errors in the construction of
output products, especially at block boundaries.

Inter-strip stereopair use may be necessary when processing Vision Map projects
(depending on source data features).
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• By block scheme – one stereopair is selected for each of the images according
to the arrangement of images in the Block editor window (see “Images block
forming” of the “Creating project” User Manual). The creation of in-strip stereopairs
only is supposed (if the user has decided not to use more stereopairs).

Such an approach implies the correct arrangement of images in the block scheme and
a sufficiently high image overlap, which is not always feasible when processing UAS
data (in this case, the formation of stereopairs by block scheme is not recommended).
The formation of stereopairs by block scheme is justified in the lack (or insufficient
number) of tie point measurements

Note, that in the latter case DEM creation using dense model can be performed correctly
for adjusted projects only. In turn, the steps of measuring tie and ground control point
coordinates can be excluded from project processing only if quite accurate exterior ori-
entation parameters of block’s images are available what makes it possible to use these
data for the project adjustment (see “Import of exterior orientation parameters” of the
“Aerial triangulation” User Manual).

○ [optional] To use more stereopairs, set the appropriate checkbox. It should
be noted, that the number of potential stereopairs for each image (in particular,
taking into account inter-strip pairs) can be quite large. The system allows the
user to limit the max. number of stereopairs per image to no more than the
specified one, in the appropriate field.

The search for extra stereopairs is carried out over the entire block of images (including
among images located on neighboring strips).

5. [optional] set the Limit intersection angle checkbox on to filter blunders by Z on
images with intersection angle of small or null value, and define a value of minimal
and maximal angles;

The system allows to estimate the intersection angles in the stereopairs of the project (see
the “The list of stereopairs for a selected image” chapter in “Creating project” User Manual
and the “Creation of “stereo quality” map” chapter in “Vectorization” User Manual).

6. In the Initial approximation section select a method of heights range calculation
for DEM generation:

• Stereopair heights range – heights range is calculated for each stereopair indi-
vidually using heights of project tie points measured earlier;

• Project elevation range – heights range is taken from theRelief elevation value
in project properties or is calculated using heights of project points measured
earlier;

• Constant elevation – input a height value in meters to be used as initial approx-
imation;
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The Range extension field allows to increase height range by a predetermined
value to create a DEM. If the Constant elevation mode is on the option specifies
working range of heights (search area).

7. In order not to use boundary regions of imagery while DEM (LAS, true ortho) cre-
ation, set the Offset from image boundaries, % by clicking the button in the
SGM parameters section. The Image margin window opens. Set image margins
in percent which are not to be involved in processing;

It may be necessary so that only useful part of an image was processed (e.g. while pro-
cessing projects with analog imagery as source data).

Fig. 125. The “Image margin” window

Fig. 126. Image margin

8. For more detailed settings of SGM cost calculation click Additional.... The SGM
parameters window opens.
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Fig. 127. SGM parameters

Set the following parameters:

• Limit area of calculation (pixels) – specifies a size of parts that epipolar images
will be splitted to. The parameter’s value affects processing performance;

• Cost calculation method – CT (by default) or MI – this method is less sensitive
to non-linear values of images brightness, but more demanding in performance
(duration of DEM generation becomes 2-3 times longer);

• Paths number – number of calculation directions. It affects DEM accuracy and
generation time. Recommended values: 8, 16, 32;

• Penalty 1 – penalty for parallax change by 1 pixel. It is recommended to increase
this value when using extensively noisy images. The value may be reduced to
improve the accuracy of the DEM when using qualitative data;

The system allows to perform the automatic calculation on penalties. To set the
penalty 1 and the penalty 2 manually clear this checkbox.

170

DTM GenerationPHOTOMOD 7.5



• Penalty 2 – penalty for parallax change by more than 1 pixel. It is recommended
to increase this value when using extensively noisy images. The value may be
reduced to improve the accuracy of the DEM when using qualitative data;

• Histogram smoothing radius – parameters used just for calculation by MI
method (see above). Defines smoothing level of epipolar images histogram;

• Pixel cost calculation radius – half-size of rectangular correlation mask in pixels
by X and Y axes;

• Disparity map interpolation – interpolation distance when auto-filling missed
results (null cells) by adjacent pixels;

• Minimum area of overlapping – minimal overlap area of epipolar image parts
in pixels. Recommended value: not less than 20;

• Maximum vertical parallax, in pixels;

• Filter DEM errors – allows us to delete isolated DEM areas (having sizes lesser
than set ones) during individual processing of each stereopair;

Isolated DEM areas – the cells with values beyond the boundaries of the main DEM or
among null cells.

• Use tie points – allows to improve DEM quality through the creation of temporary
triangulation points before DEM construction to refine the elevation ranges of
each stereopair involved in the construction.

It is recommended to use triangulation points in case when the stages of tie and
ground control points’ coordinate measuring were excluded from the project prepro-
cessing, and the preliminary adjustment necessary for dense DEM generation using the
SGM method was carried out according to imported exterior orientation parameters.

The creation of temporary triangulation point before DEM creation also can improve the
quality of output data in case of using data of initial imaging with large convergence
angles in stereopairs. Note, that preliminary creation of temporary triangulation points
is quite time-consuming.

9. To increase the system performance through graphic processing unit resources,
set the Use GPU checkbox and select the desired device from the drop-down list;

The intensity of GPU usage can be monitored using various free software. Windows 10
users can monitor GPU activity through theWindows Task Manager (Performance Tab).

State-of-the-art graphic adapters with memory no less than 4 – 6 GB are recommended,
especially in case of parallel run of several tasks in the distributed processing mode.
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10. [optional] To remove processing data after the calculation is completed set the
Delete intermediate data checkbox on. Click the (estimate the size) button to get
information about disk space occupied by intermediate data.

It is not recommended to remove intermediate data up to final creation of DEM. After re-
moving of intermediate data it is impossible to start separate steps (filtering or smoothing)
without DEM re-calculation.

11. In the output data section click the button that corresponds to the Working
folder field and choose an empty target folder in active profile resources to save
the output DEM.

If the selected folder already contains some data, before the execution of an operation the
system will offer to decide between emptying the folder or using the existing data for DEM
creation.

Fig. 128. Question

12. Specify DEM cell size in meters to change size of output DEM cell.

The value of the DEM cell size parameter should not be less than average pixel size
(GSD). When using cell size with smaller size the time of DEM creation and a size of output
file are increasing, however, the processing accuracy is not improved at that.

Click the From project button to setup DEM cell size that equals to average GSD value
in the project.

The final DEM cell size may change depending on detailed output DEM parameters
settings (see below).

13. [optional] to create DEM, set the appropriate checkbox it the DEM section, and
specify the following settings:

• [optional] To set the additional output DEM parameters click the Parameters
button in the appropriate section. The Output DEM parameters window opens:
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Fig. 129. Output DEM parameters

○ [optional] In the Auxiliary processing section specify the following filtering
parameters:

■ set the Median filter checkbox to use median filtering during DEM creation
and specify parameters of filter usage;

■ set the Smooth filter checkbox to use smooth filtering during DEM creation
and specify parameters of filter usage.

○ Specify DEM boundaries in the North,West, East, South. In the Height and
Width fields the system displays calculated size of DEM border in meters.

The Height andWidth fields in the lower part of the window display the number
of cells of the DEM (if it would be created with current DEM cell size and
boundaries settings). There is also displayed the Estimated DEM size in
megabytes.
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In order to Calculate parameters by existing DEM, click the appropriate button
and select existing DEM file in active profile resources. Click OK to apply these
parameter and close the Output DEM parameters window.

• Specify the Minimum number of counts in overlapped area parameter value
to setup reliability of DEM.

This parameter determines the minimum number of overlapped stereopairs required for
calculating the resulting DEM cell value.

The cell of the final DEM will be recorded if the number of overlapped stereopairs used
for its calculation is equal to the preset value (or exceeds it).

Correct choice of this parameter value depends on minimum stereopair overlap in a
block and on using interstrip stereopairs during DEM calculation (see above).

Recommended default value is 2. In case of a small overlap of stereopairs, it is recom-
mended to lower the value of the Minimum number of counts in overlapped area to
1.

To estimate stereopair overlap area in the project, choose Block › Create overlap
map... (see “Creating overlap map” of the “Creating project” User Manual).

Function Block › Create overlap map... allows only to estimate stereopair overlap in
the project, since map creation is carried out for images but not for stereopairs.

• Set the Coefficient from RMS to Max error, the parameter influencing the cell
value filtering whenmerging the final DEM from fragments created using separate
stereopairs.

The Coefficient from RMS to Max error participates in the calculation of merged DEM
fragment cell value tolerance. Decreasing this parameter’s value allows to build a DEM
with higher accuracy but it may cause the increased number of null cells. Increasing this
parameter’s value leads to the smoothing of DEM tile cell values during their merging.

Computation of a resulting DEM in overlap areas of several fragments calculated by
separate stereopairs is as follows:

○ Calculating the RMS of deviation from the mean elevation at the given cell;

○ Calculating a threshold value for the above RMS that is a product of Coefficient from
RMS to Max error and DEM cell size parameter values.

○ If RMS falls within the above threshold, the mean value of the cell elevation calculated
under these conditions is used as the resulting; otherwise, step-by-step filtering of
fragments involved in given cell processing takes place until an acceptable result is
achieved.

• Set the output DEM filename.
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14. [optional] To create the True Ortho, limited by DEM boundaries, set the appropriate
checkbox and specify the output true ortho filename. The True Ortho will be cre-
ated in the work folder, in the PHOTOMOD MegaTIFF (*.prf) format;

To create the true ortho set the create DEM checkbox beforehand (see above).

Creating the true ortho will notably (approximately 2-fold) increase the time required for
DEM creation.

PHOTOMOD GeoMosaic program allows to save later the obtained true ortho in any of
available formats (see the “Orthophotomaps creation” User Manual).

For more detailed setting of true ortho creation options, click the Parameters…
button. The True ortho parameters window opens:
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Fig. 130. The “Fill NULL cells” window
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• In DEM section, set Minimum building height in meters to exclude buildings
from interpolation of DEM null cells (see the figure below);

• In DEM section, set Cache size when filling option in megabytes – maximum
cache size allocated for a single task when creating true ortho;

• To Use RGBI channels for true ortho creation, set the appropriate checkbox;

A True Ortho creation using four channels is possible only when the images used as
source data have the 4th channel, e.g. infrared.

• In the True Ortho section, set the Global brightness adjustment checkbox to
apply global brightness adjustment over image overlapping areas when creating
an orthophotomap. For more detailed setting of brightness adjustment options,
click the Parameters… button. The Parameters window opens:

Fig. 131. Brightness adjustment parameters

The opening window allows us to change the following settings of global brightness
adjustment:

○ Use statistic of overlapped areas with weight – allows to use the weight of
the images’ overlapping areas only;

○ Use statistic of entire images with weight – allows to use the weight of all
the pictures in the block;

If the images’ brightness in a block significantly differ, it is recommended to set a
small value.

○ Fix outline images with weight – allows the user to omit global alignment for
pictures on the block borders;
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See the detailed description of brightness adjustment processes when creating an or-
thophotomap in the “Orthophotomaps creation” User Manual.

• [optional] to apply the sharpening filter set the appropriate checkbox and click
the button to open the Filter parameters window:

The sharpen filter allows to highlight and intensify differences between image’s individual
details (image sharpness). See the “Radiometric correction” chapter of the “General in-
formation” User Manual.

Fig. 132. Filter parameters

Set the following parameters:

○ In the Aperture size list define the matrix size from 3x3 pixels to 21x21 pixels.

○ Move slider to define Filtering level in percent.

○ Set the Threshold. Click OK to close the window.

Each single image element is filtered only if the brightness difference between adjacent
elements exceed the given filtering Threshold. This helps to avoid errors looking as
spots in the areas of an image with originally uniform hues.

• [optional] clear the Fill NULL cells checkbox in the True Ortho section in order
not to fill null cells when creating a DEM (what can lead to creation of unfilled
areas when creating an orthophotomap) or specify the following parameters:

The name of unfiltered output DEM with unfilled null cells has to look like the following:
<DEM name>_tmp.x-dem (automatically set).

The name of output True Ortho with non-interpolated null areas has to look like the fol-
lowing: <True Ortho name>_tmp.prf (automatically set).
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○ Overwrite valuable cells in NULL areas – allows to exclude isolated DEM
areas from interpolation of DEM null cells (i.e. interpolate these areas as a
NULL cells);

Isolated DEM areas – the cells with values beyond the boundaries of the main DEM
or among null cells.

○ Interpolate not filled NULL cells – allows to interpolate unfilled DEM/ortho-
photomap areas;

○ Fill single NULL cells – allows to interpolate areas without data having one
pixel size in a DEM or orthophotomap;

○ Visibility distance – the distance within which the visibility of points located
in unfilled areas of an orthophotomap is checked in the project’s images;

○ Visibility step – an increment with which the visibility of points located in unfilled
areas of an orthophotomap is checked in the project’s images;

○ Maximal barrier height – an approximate maximal height of the objects
towering above the Earth surface and hiding some terrain areas (see the illus-
tration below);

○ Maximum images per pixel – maximum number of images of the project
where the visibility of points located in unfilled areas of an orthophotomap is
checked;

The system calculates default Visibility distance, Visibility step and Maximum
images per pixel based on the DEM cell size specified by the user (see above).

If, after closing the Fill NULL cells window, the user changes the DEM cell size in
the SGM parameters window, Visibility distance, Visibility step and Maximum
images per pixel manually set by the user will be automatically recalculated.

When setting parameters for null cell filling, the survey geometry (off-nadir angles) is
to be taken into account, as well as the geometry of the terrain itself (heights of objects
located on the terrain). If the results of cell filling are found to be unsatisfactory, in-
crease visibility distance and visibility step (given that this will increase the time
spent on the operation).

○ Filter outliers – allows to perform orthophotomap median filtering with preset
Threshold. The statistics is collected in the neighborhood whose area is de-
termined by the Aperture size. This filter is used for removing single pixels
with unnatural brightness;

○ Set the Acceptable pixel color RMS, the parameter influencing the filtering
of pixels of various images when creating a true ortho.
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Decreased values of this parameter lead to exacting tolerance for pixel colors of
various images, and, as a consequence, may cause the decrease of the number of
images used for the calculation of each true ortho pixel.

• Define the output True Ortho pixel color selection method:

The color of each True Ortho pixel is calculated over several images involved in the
processing of a particular pixel. By setting an acceptable pixel color RMS, the user
can pre-exclude from the processing those images, the color of a particular pixel of
which differs significantly from the corresponding pixels of the other images.

○ Use the color closest to nadir – only one image with the smallest deviation
from the nadir angle, relative to a given pixel is involved in determining the
resulting color of a pixel;

When using this technique, well-marked differences between the colors of adjacent
pixels may be observed in the output True Ortho, even if global brightness adjust-
ment is used (see above).

○ Use the pixel color of one of the images that is closest to average color cal-
culated for this pixel (according to all images involved in processing);

○ Use weighted color selection;

○ Set average color (average the data of all images involved in the pixel calcu-
lation)

• [optional] set the Overwrite existing DTM/TrueOrtho checkbox in order not to
use intermediate data from the working folder (if DEM and orthophotomap has
already been created) but overwrite them.
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Fig. 133. An example of unfilled area on true ortho, where a is the building height (see Maximal
barrier height parameter), b is the “isolated DEM area” among DEM NULL cells (seeOverwrite
valuable cells in NULL areas checkbox), с is the Visibility step, R is the Visibility distance,
S is the unfilled DEM/orthophotomap area (due to the fact that the image is the central projection
of terrain and objects towering above the Earth surface hide some terrain areas, thus they are
not seen on the image). Also, the quality of an orthophotomap is affected by the zones hidden

by the object’s shadow, and brightness adjustment is required.

15. [optional] To create an output point cloud (LAS) set the appropriate checkbox
(see the “LIDAR Data processing” User Manual). For more detailed setting of point
cloud creation parameters, click Parameters... button. The LAS creation paramet-
ers window opens:

If the Create point cloud (LAS) checkbox is set, it is recommended to use the distributed
processing mode for dense DTM creation using the SGM method.

Points cloud will be saved in the separate LAS directory in the folder chosen for output
DEM saving in the active profile’s resources.
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Fig. 134. The “Create LAS parameters” window

• Set the Maximum intersection angle and mininum intersection angle in de-
grees to filter blunders by Z on images with intersection angle of small or null
value;

Before configuring these parameters, it is recommended to assess the overlapping of
the project images as well as the intersection angles of the stereopairs used in data
processing.

To estimate the project images overlaps, choose Block › Create overlap map... (see
“Creating overlap map” of the “Creating project” User Manual).

The system provides the different methods to estimate the intersection angles in the
stereopairs of the project (see the “The list of stereopairs for a selected image” chapter
in “Creating project” User Manual and the “Creation of “stereo quality” map” chapter in
“Vectorization” User Manual).

To set theminimum intersection angle among all stereopairs used in data processing
as a limiting value, set the autocalculate minimum intersection angle checkbox.

In most cases, especially when processing data with a large number of overlaps and
multiple small intersection angles, leave this checkbox set

Increasing themininum intersection angle manually, user can achieve more LAS ac-
curacy due to tighter point filtering.
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• To classify vegetation by IR channel (if available) set am appropriate checkbox
(see the “Vegetation classification” chapter of the “LIDAR Data processing” User
Manual);

• Set Point cloud density in meters;

By default, Point cloud resolution is twice as large as the DEM cell size (see above).

It is not recommended to set Point cloud resolution lesser than the DEM cell size.

• Specify the Number of returns – the minimum number of stereopairs required
for point calculation;

○ Specify the Max neighborhood images number – the maximum number of
images used for stereopairs creation.

• To perform the preliminary gross errors filtering (for the LAS fragments calcu-
lated for the single images) set an appropriate checkbox and click the appropriate
button to set filtering parameters (see the “LAS statistical outlier removal” chapter
of the “LIDAR Data processing” User manual);

• To perform the small group points filtering set an appropriate checkbox and
click the appropriate button to set filtering parameters:

Fig. 135. The “LAS small group filter parameters”

○ Min number of voxels in one cluster – if the number is less, the cluster will
be deleted;

○ Min number of points in a voxel;

○ Size of Voxel side in one cluster – the side size of the single voxel in project
units.

The small group points filtering allows to delete point groups out of the main cloud
which are located at some distance and most likely are noisy.

A volumetric pixel (voxel) is the three-dimensional equivalent of a pixel and the tiniest
distinguishable element of a 3D object. Volume pixels are used like building blocks
to form a larger 3D object.
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In this case, a voxel is a small fragment of the point cloud, within which the calculations
are performed. Not to be confused with the LAS point cloud tile.

The cluster is the group of voxels.

• To use the smooth filter for the output points cloud set an appropriate checkbox
and click the appropriate button to set filtering parameters (see the “LAS fusion”
chapter of the “LIDAR Data processing” User manual);

• To use themedian filter for the output points cloud set an appropriate checkbox
and click the appropriate button to set filtering parameters (see the “LAS fusion”
chapter of the “LIDAR Data processing” User manual);

• To perform the final block filtering (statistical outlier removal for the output
points cloud) set an appropriate checkbox and click the appropriate button to set
filtering parameters (see the “LAS statistical outlier removal” chapter of the
“LIDAR Data processing” User manual);

• Specify the size of the output block side to set the output LAS tile size. The
default size of the output block side is 1000 points cloud GSD (see the Point
cloud density parameter above).

16. Click OK to start dense DEM generation operation in normal mode. Output DEM
is opened in a new layer after the creation is finished. Output true ortho is also
opened in a new layer if the corresponding checkbox was turned on.

In order to generate DEM using distributed processing, perform the following actions:

While building DSM by SGM method in distributed processing mode, stereopairs are pro-
cessed separately in different tasks (see the Searching area section). The last task is re-
sponsible for merging data acquired.

1. Start the server/client of distributed processing mode (see the “Distributed
processing” chapter in the “General information” User Guide).

2. Open the Monitor for distributed processing and specify Max MT tasks –
the maximum quantity of simultaneously running tasks onClient inMultiThread-
ing mode;

MultiThreading – in computer architecture, multithreading is the ability of a central
processing unit (CPU) (or a single core in a multi-core processor) to provide multiple
threads of execution concurrently, supported by the operating system.

This approach differs frommultiprocessing. In a multithreaded application, the threads
share the resources of a single or multiple cores, which include the computing units,
the CPU caches, and the translation lookaside buffer (TLB).

Where multiprocessing systems include multiple complete processing units in one or
more cores, multithreading aims to increase utilization of a single core by using thread-
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level parallelism, as well as instruction-level parallelism. As the two techniques are
complementary, they are sometimes combined in systems with multiple multithreading
CPUs and with CPUs with multiple multithreading cores.

When setting this option, it is needed to take into account the Client’s specifications
i.e.RAM and the number of processor cores. The recommendedMaxMT tasks value
for a workstation having a multicore processor and 8 GBRAM is 1. The recommended
Max MT tasks value for a workstation with 16 GB RAM is 2, etc.

3. Click the Distributed processing... button.

Depending on the size of creation area the operation can take a long time.

To provide a system performance while building dense DSM by SGM method it is recom-
mended to use Distributed processing mode.

7.3.7. DEM creation in batch mode

The system provides possibility to create DEM in batch mode. Batch mode allows to
create multiple files with TIN and DEM simultaneously and to save them to specified
folder.

For DEM batch creation the source vector resources are divided into sheets using
specified parameters. For each vectors sheet the system creates TIN, used for DEMs
creation, and then they are merged to generate a single output DEM.

Perform the following actions to execute batch processing:

1. Select Terrain › DEM › Build DEM › Batch DTM creation. The Create batch
DTM – Step 1 of 2: Source data window opens:
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Fig. 136. Creating a list of the initial vector resources for batch DTM creation

2. Choose a folder containing vector objects in resources tree.

The button allows to display all available resources in nested files. The button allows
to refresh part of the window with resources.

The button allows to show a list with 10 recently selected resources.

3. Select vector file in the list and click the button to add a layer.

The and buttons allow to add to the list or remove from it all added files with vector
objects, the button allows to remove selected file from the list

4. Repeat the 2 and 3 steps to add next files with vector objects.

5. Click the Next button. The Create batch DTM – Step 2 of 2: Options.

186

DTM GenerationPHOTOMOD 7.5



Fig. 137. Parameters of batch DTM creation

6. In the Processing section define tasks to be performed during DEM creation:

1. Split input data into sheets – specifymax.point quantity per sheet in millions
of points, and specify a size of sheets overlap in percent.

Specified parameters are considered by the system to define a number of sheets for
splitting, so in specified target folder the system creates vector files with x-data exten-
sion and sheet_sheet № names.

2. Build TIN by created sheets – (is set on by default) is used to create TIN by
vector objects layers, divided into sheets. During execution of this task in the
specified target folder the system creates files with x-tin extensions and
sheet_sheet № names, that correspond to vector files.

3. Build DEM by created TIN – (is set on by default) is used to create a single
DEM by the whole TIN, generated using obtained sheets.

The task is performed in two steps: DEM is created for each sheet by TIN, after that
all created DEMs are merged into single one. Thus in the output folder a file with x-
dem extension is created.

7. [optional] Set theDistributed processing checkbox on to use distributed processing
feature for batch DEM generation.
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8. In theWorking folder section define empty folder in active profile resources, where
to place output data.

Before operation is performed all data from selected folder is removed.

9. [optional] In the Filtering section set the Z-range filter checkbox on to apply filtering
to vectors and/or TIN. During filtering the system removes points and vertices of
polylines/polygons (including TIN vertices), which Z-coordinate is out of range,
specified in the Zmin and Zmax fields in meters.

10. In theDEM parameters section specify DEM boundaries in theNorth,West, East,
South fields. In the Height and Width fields the system displays calculated size
of DEM border in meters.

11. Specify Cell size in meters to change size of output DEM cell. In the Height and
Width fields of the Cell size section the system displays nodes number calculated
with specified DEM cell size. There is also displayed the Appr DEM size in mega-
bytes.

DEM cell size should be commensurate with the average distance between points. If less
cell size is used, the time of DEM creation and size of output file increase, but accuracy is
not.

12. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

13. Click the Execute button. The system displays a message about removing of all
data in specified output folder. After that the system creates new DEM layer in the
Manager.

When theDistributed processing checkbox is set on, perform the following actions:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Execute button. The DEM distributed processing window opens.
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Fig. 138. Parameters of distributed batch DTM creation

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.3.8. Building DEM from an external source within the selected
polygon

The system provides possibility to build a DEM from an external source (SRTM data)
within boundaries of area specified by a polygon.

SRTM (Shuttle Radar Topographic Mission) – data obtained as a result of the interna-
tional mission to build a digital elevation model (DEM) of the Earth’s surface. SRTM
data is a DEM, covering the territory of the land from 60°N to 54°S and some parts of
the sea.

There are some versions (releases) of SRTM data, differing in the degree of additional
processing.

The SRTM data are distributed in two versions:

• SRTM1 – a matrix with a cell size of 1x1 angular second (i.e. with a spatial resolution
of 30 meters) – are available on the US territory only;
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• SRTM3 – a matrix with a cell size of 3x3 angular second (i.e. with a spatial resolution
of 90 meters) – publicly available data for the rest of the Earth’s surface covered by
the mission.

At the moment, the system provides the ability to build a DEM using SRTM data of v4.1 with
the cell size 3х3 angular seconds (SRTM3 v4.1), presented in *.zip archive.

The SRTM data are distributed in tiles – fragments of SRTM DEM, with size 1х1 or 5х5
degrees, presented in *.zip archives. For the identification of tiles, mesh-grids are used
in the Shape format with step 1 or 5 degrees, respectively.

Prior to DEM creation from an external source within the selected polygon, you should do the
following:

• set global working coordinate system (see the “Coordinate systems” and “Project properties”
chapters in the “Project creation” User Guide). Otherwise, during DEM creation the system
displays a corresponding error message;

• import to thePHOTOMOD system a Shape file of the corresponding mesh-grid (see the “Import
from Shape” chapter of the “Vectorization” User Guide) and save it to the format used in
PHOTOMOD system.

To create DEM an external source within the selected polygon, perform the following:

1. Load or create a new polygon (see the “Vectorization” User Guide);

2. Select the polygon, and choose Terrain › DEM › Build DEM › Create DEM from
external source bounded by current polygon.... TheDEM creation parameters
window opens. Specify the following settings in the opened window:

Fig. 139. Parameters of DEM creation from an external source within the selected polygon

• DEM type – select from a type of external data used for DEM generation;
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• Vectors of tile coverage – specify a path to preliminary imported file (see above)
of mesh-grid in format used in the PHOTOMOD system;

• Attribute with sheet name – input an attribute name, containing names of
archives with SRTM data. The required attribute name is included to attributes
of a vector layer, obtained during import of mesh-grid (see the previous step);

• DEM folder – specify a folder where SRTM data are stored, presented in *.zip
format archives;

• [optional] set the Search in subfolders checkbox to perform a search for *.zip
archives with SRTM tiles not only by specified path, but also in all its subfolders;

• Folder with temp data – specify a folder to store temporary files;

• Output DEM – specify a folder in active profile resources to save output DEM;

• Cell size – specify the DEM cell size in meters to define cell size of output DEM;

• set the Re-calculate to the current coordinate system checkbox, to calculate
an output DEM into coordinate system of the current project;

SRTM data is presented in WGS 84 coordinate system.

• [optional] set the Open output DEM checkbox.

3. Click OK.

7.4. DEM filtering

The system allows to filter DEMs. The following filters are provided for editing DEMs:

Table 7. Brief description of the “Filter” menu

FunctionMenu items
is used to Buildings and vegetation filtering in DEMBuildings and vegetation filter
allows to filter objects based on slope angleSlope based filter
allows to classify the DEM cells. Classification is
performed through the joint analysis of a DEM and
an orthophoto that has an IR band

DEM classification

allows to save the selected groups of pre-classified
DEM cells into a separate resource

Extract classes from DEM

allows to use median filtering of DEM cellsMedian filter
allows to use smoothing filter for DEM valuesSmooth filter...
the bilateral filter successfully suppresses small
noises, preserving the characteristic features of the

Bilateral filter
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FunctionMenu items
terrain, and therefore it is recommended to use it
before building contours using DEM (after filling in
null cells)
allows to filter DEMs depending on image character-
istics

Filter by image properties

allows to convert DEM cells with specified elevation
to null cells

Cut DEM by Z-range

7.4.1. Buildings and vegetation filter

The system allows to use filtering of buildings and vegetation of DEM. Such filtering
includes calculation of base points with specified coefficient of DEM subsampling. The
operation includes deletion, correction or recognizing points which have fallen on
buildings, trees, cars, in pits, etc. during automatic points calculation, as well as filtering
of accident spikes. After the filtering output DTM contains just terrain relief model.

Fig. 140. Buildings and vegetation filtering from DEM

The Buildings and vegetation filter window allows to specify filtering parameters and
setup a number of filter passes. The Layer field displays a name of active vector layer.
The window contains a standard toolbar.

FunctionButton
allows to load a script of filter work from *.x-filter
resource located out of active profile resources
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FunctionButton
allows to load a script of filter work from *.x-filter
resource located in active profile resources
allows to save a current script of filter work to *.x-
filter resource located out of active profile re-
sources
allows to save a current script of filter work to *.x-
filter resource located in active profile resources
allows to cancel all changes made to a script
allows to go back to a standard script that includes
two passes with default settings (regardless of which
script has been loaded)

To filter buildings and vegetation on DEM perform the following actions:

1. Make active a DEM layer.

2. Select Terrain › DEM › Filter › Buildings and vegetation filter. The Buildings
and vegetation filter window opens.

Fig. 141. Buildings and vegetation filtering from DEM
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3. In the Output DEM section click the button and specify name and target folder
of output DTM in active profile resources.

4. [optional] Specify a number of filter passes:

• by default it is used two passes with standard parameters –Basic andAdditional.
Set off checkboxes to change number of passes;

• the button allows to add a new pass of filter;

• the button allows to remove selected pass of filter;

• the and buttons allow to move selected pass up/down.

5. Select a name of pass and click the Edit pass parameters button to display and
configure the following parameters of filter pass:

Fig. 142. Configuration of buildings and vegetation filter

• [optional] to change a filter pass name, input new name to the Name field;

• the Source DEM cell size field shows DEM cell size in meters before filter apply-
ing;

• specify Thinout coefficient for calculating basic points by DEM. From the
specified value and the Source DEM cell size parameter depends the Space
between basic points parameter in meters;
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• specify Near and Far distance of mutual points influence in meters to define
the radius of the circle, in which the values of points are analysed for errors;

Near distance of points mutual influence – is the average radius of a circle where
the points are located that are attributed to the same flat surface towering above the
terrain (e.g. a flat roof).

Far distance of pointsmutual influence – is the average distance from points attributed
to the flat surface towering above the terrain where the points attributed to the terrain
are located for sure.

Fig. 143. Near distance of points mutual influence (a) and far distance of points mutual influence
(b)

• specify the following filtering parametersUp (above surface) and/orDown (below
surface):

○ Filter surges – allows to select points to be filtered: points on surface (high
objects) and/or points below surface (pits);

For filter operating it is necessary to set at least one checkbox on.

○ Spikes only – is used to reject just sharp spikes above/below surface, that
are defined by values of the Threshold slope angle for spikes and Distance
of points parameters. The rest of parameters are not considered;

In an angle between three points exceeds a value of the Threshold slope angle for
spikes parameter, then the surge is called spike.
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○ Threshold slope angle for spikes – allows to specify angle of slope in relation
to selected measuring plane (above and/or below surface) to define sharp
spikes;

○ Maximum area of flat surges – allows to define maximal area of plane surges
(above/below surface) – points groups, that form smooth surfaces and are
distant from some plane of neighbour points. Generally, the points are located
on buildings roofs, and are lying on the same plane;

The filter is not applied to plane surface, which area exceeds the specified value.

○ Intermediate smoothing radius – allows to specify a sphere radius
(above/below surface), that defines a level of intermediate smoothing of surface;

○ Allowed point deviation from from smoothed surface – allows to specify
criterion, according which the filter is applied to all points with elevations that
differ from smoothed surface more then on specified value.

○ Maximum area of inclined surges – allows to define maximal area of inclined
surges (above/below surface) – points groups, that form inclined surfaces on
the slopes.

The button allows to go back to a standard script that includes two passes with all default
settings (regardless of which script has been loaded).

6. [optional] To use all cores of used computer, the Use all available CPU cores
checkbox is set on in the system by default. It is necessary to set the checkbox off
to use only one core.

7. Click OK. The system starts DEM filtering operation. When the filtering operation
is completed the system displays information message about number of used basic
points and points being filtered.
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Fig. 144. Filtering results

7.4.2. Slope based filter

The system allows to filter objects based on slope angle.

While using a filter, DEM cells covering buildings, vegetation, man-made objects and
accident spikes are searched for and removed. As a result of filtering DEM contains
heights of “true relief” only.

1. Make active a DEM layer;

2. Select Terrain › DEM › Filter › Slope based filter…. The Slope based filterwindow
opens;
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Fig. 145. Parameters of slope based filter

3. In Input DEM section click button and select DEM to filter in resources of the
active profile;

4. InOutput DEM section click button and specify name and target folder to keep
output DEM in resources of the active profile;

5. In Size of object to be removed section specify the typical object size in XY-plane
and typical object size along Z axis in following fields in meters:

• Plane distance (max);

• Height (min).

• Slope angle (min) in degrees.
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A slope angle is one of the parameters used to calculate a threshold for filtering. For
example, for a plumb-wall building, the slope angle is ~ 90 degree (note, that due to
the peculiarities of DEM construction, this angle will never be exactly 90 degrees).

The slope angle is selected individually in each case for the distinctive buildings and
objects that need to be removed. Large values of slope angles (about 80 degrees) may
lead to the fact that those buildings of specific shapes (e.g. hangars) may not be removed
during filtering. Decreasing the slope angle (e.g. to 45 degrees) may lead to removing
some accidents of terrain (e.g. elevations having similar shapes and sizes) along with
abovementioned buildings.

6. To perform initial filtration of a thinned original DEM, set the Intermediate DEM
pyramid level determining the degree of thinning.

Increasing the degree of thinning makes it possible to significantly improve the system
processing performance, lowering the quality of filtration. Recommended values of Inter-
mediate DEM pyramid level are 1, 2, or 3.

To set zero value is strongly discouraged.

7. [optional] Set Use selected polygons checkbox to filter DEM in the borders of
selected polygons only. Select where filtration will be performed:

• Inside selected polygons;

• Outside selected polygons.

ToUse selected polygons, before opening Slope based filterwindow perform the follow-
ing:

• Create vector layer (see the “Vectorization” User Manual);

• Create one or several polygons which limit selected fragments of DEM or load vector
layer with polygons to use them as boundaries for filtering;

• Select no less than one polygon which is used as a boundary for filtering.

8. [optional] Set Open Dem after filtering checkbox to open output DEM in a new
layer immediately after filtration completion.

9. [optional] To remove processing data after the calculation is completed set the
Delete intermediate data checkbox on.

10. Click OK. A process of filtering DEM is started. Output DEM is opened in a new
layer if the corresponding checkbox was turned on.

To use distributed processing for DEM slope based filtering, do the following:
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1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 146. Parameters of distributed DEM filtering

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.4.3. Median filter

The system allows to use median filtering of DEM cells.

The median filtering contains the following sequence of actions:

1. Sequential scanning of DEM by mask with specified size. Size of scanning mask
is defined by the Aperture parameter (in DEM cells).

2. The system replaces current cell elevation values by median values, if a difference
between them is more than specified Threshold in meters.
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To apply median filtering perform the following actions:

1. Make active a DEM layer.

2. Select Terrain › DEM › Filter › Median filter. TheMedian filter parameterswindow
opens.

Fig. 147. Median filter parameters

3. In the Threshold field specify a value of threshold in meters, which is used to
compare difference value between current and median elevation.

4. In the Aperture field specify a size of scanning mask.

5. [optional] Set the Filtering inside selected polygons checkbox if needed.

6. Click OK. After that current values of DEM cells are replaced by median values, if
difference value between current and median elevation does not exceed specified
Threshold.

To use distributed processing for DEM median filtering, do the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.
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Fig. 148. Parameters of distributed DEM filtering

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.4.4. Smooth filter

The system allows to use smooth filtering of DEM cells values.

To execute smooth filtering perform the following actions:

1. Make active a DEM layer.

2. Select Terrain › DEM › Filter › Smooth filter. The Smooth filter parameters
window opens.
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Fig. 149. Smooth filter parameters

3. In the Level field specify filtering coefficient value from 0 to 1.

4. In the Aperture field specify a size of scanning mask.

5. [optional] To apply Gauss smoothing algorithm theGaussian filter checkbox is set
on by default.

6. [optional] Set the Filtering inside selected polygons checkbox if needed.

7. Click OK. After that current values of DEM cells elevation are replaced by filtered
values.

To use distributed processing for DEM smooth filtering, do the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 150. Parameters of distributed DEM filtering
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3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.4.5. Bilateral filter

The system provides for smoothing DEM filtering using a bilateral filter. The bilateral
filter successfully suppresses small noises, preserving the characteristic features of the
terrain, and therefore it is recommended to use it before building contours using DEM
(after filling in null cells).

1. Make active a DEM layer;

2. Select Terrain › DEM › Filter › Bilateral DEM filter. TheBilateral DEM filterwindow
opens:
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Fig. 151. Parameters of bilateral filter

3. In Input DEM section click button and select DEM to filter in resources of the
active profile;

4. InOutput DEM section click button and specify name and target folder to keep
output DEM in resources of the active profile;

5. In the Mask halfsize field specify a size of smoothing mask;

6. Set the Sigma Z value that determines the influence of elevations in a mask on the
smoothing process;

7. [optional] set the appropriate checkbox to use true ortho and click the button
to select orthophotomap in resources of the active profile;

• Set the Sigma color value that determines the influence of true ortho pixel colors
on the DEM filtering process.
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8. [optional] Set Use selected polygons checkbox to filter DEM in the borders of
selected polygons only. Select where filtration will be performed:

• Inside selected polygons;

• Outside selected polygons.

ToUse selected polygons, before opening Slope based filterwindow perform the follow-
ing:

• Create vector layer (see the “Vectorization” User Manual);

• Create one or several polygons which limit selected fragments of DEM or load vector
layer with polygons to use them as boundaries for filtering;

• Select no less than one polygon which is used as a boundary for filtering.

9. [optional] Set Open Dem after filtering checkbox to open output DEM in a new
layer immediately after filtration completion.

10. Click OK. A process of filtering DEM is started. Output DEM is opened in a new
layer if the corresponding checkbox was turned on.

To use distributed processing for DEM slope based filtering, do the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button.

7.4.6. Filter by image properties

The system allows to filter DEMs depending on image characteristics. At the preliminary
step (so-called “Learning”) an operator manually collects specific areas of images (in
example images – areas covered by forestry) as samples for filtering.

To filter DEM, perform the following:

1. Make active a DEM layer;

2. Select an image by characteristics of which filtration will be done in 2D-window or
in Block editor window. Select Window › New 2D-window (stereopair)
(Ctrl+Alt+W) or click button in the main toolbar. 2D-window (stereopair) is
opened;

Filter by image properties function works correctly in a stereomode only.
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3. Select Terrain › DEM › Filter › Filter by image properties. The Filter by image
properties window opens.

Fig. 152. Parameters of filtration by image properties

4. In Parameters section setMask half size – a size of square mask-window scanning
DEM;

5. Move marker into specific image area and click Learn button;

Delete last button is designed to delete the latest collected sample Clear all button is de-
signed to delete all the collected samples.
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Fig. 153. Selection of the samples

6. Repeat actions described in item 2 several times while changing a marker position;

To check learning results move marker into image area similar or dissimilar to samples
areas and click Тест button. “-” or “+” results in a status box indicate matching or mismatch-
ing of tested area characteristics with characteristics of samples areas.

7. In Save result to... section click button and define the name and target folder
to save output DEM in resources of the active profile;

8. Click Filter button. After finishing filtration process the output DEM is saved in re-
sources of the active profile;
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Fig. 154. DEM after filtration by image properties

To use Distributed processingmode while filtering DEM by image properties, perform
the following actions:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. ClickDistributed processing button. Distributed processing parameters window
is opened;

Fig. 155. Parameters of distributed processing

3. Set the number of tasks. It is recommended to set Tasks number as 1 task
per 1 PC.

4. Click OK. Distributed processing tasks are created and the report on the number
of tasks created appears.
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7.4.7. Selective filtering of objects

The system provides for selective filtering of DEM areas that describe houses, trees,
cars, and other similar objects. After applying the filter, the processed section of the
DEM describes only the terrain.

The tools for selective filtering of objects are located on the DEM editing toolbar. The
system also provides for pre-selection of boundaries of the object to be removed from
the DEM’s surface.

To preselect a DEM segment which describes an object that is supposedly not a part
of the terrain, without deleting it, perform the following:

1. Make the DEM layer active;

2. ChooseWindow › Toolbars › DEM edit. The DEM editing toolbar opens;

3. Click on the DEM editing toolbar to preselect objects. The shape of the cursor
( ) indicates the enabled mode of preselection of objects;

Click left mouse button once to refresh the cursor.

4. [optional] Click on the DEM editing toolbar. The section to set object search
parameters opens:

Fig. 156. The “DEM editing” toolbar

Specify:

• The estimate size of object to be deleted, in projects units;

• Slope angle, in degrees.

The slope angle is one of the parameters by which the filtering start threshold is calcu-
lated. For example, for a building with a sheer wall, the slope angle will be ~ 90 degrees
(note, that due to the peculiarities of constructing DEMs, this angle will never be exactly
90 degrees).
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The slope angle is selected individually for each specific case according to the charac-
teristic buildings and objects that need to be identified. Large values of the slope angle
(about 80 degrees) can lead to the fact that buildings of a specific shape (for example,
hangars) may not be removed during the filtering. Reducing the slope angle (for example,
to about 45 degrees) can lead to the fact that, along with the above buildings, some
terrain details can also be removed (for example, hills of similar shape and size).

• Minimal object height over the surface, in project units.

5. Place the cursor on the desired object on the DEM surface and start recognition
double-clicking the left mouse button. The progress window opens. Wait for the
recognition operation to complete and the progress window to close.

If a section of the DEM describing an object that is presumably not a part of the
terrain is found in the vicinity of the marker, then, after the operation is performed,
the boundaries of this DEM section will be visually highlighted in the 2D window.

To separate the specified area from the rest of the DEM surface, the border and
green fill are used. If the object point filtering mode ( ) was enabled, then the filter
would be applied to the object.

If a suitable object is not found in the vicinity of the marker, the No objects for
filteringmessage appears to the right of the displayed current marker coordinates
in the Status bar in the lower part of the 2D window.

6. [optional] To add one more object to the selected one, repeat the steps described
in the above subsection. To deselect the recent object, press Esc.

The Esc key allows to deselect only one recent object. To deselect all objects, press this
key the appropriate number of times. The key works only when the object selection mode
is on( ).

Object selection and filtering modes are not interrelated. If several objects were selected,
and then the filtering mode was turned on, only the object on which the marker was hovered
will be deleted by double-clicking the left mouse button, regardless of which objects were
previously selected.

In order to subject a separate section of the DEM to selective filtering, perform the fol-
lowing:

1. Make the DEM layer active;

2. ChooseWindow › Toolbars › DEM edit. The DEM editing toolbar opens;

3. Click on the DEM editing toolbar to enable the object selective filtering mode.
The shape of the marker ( ) indicates the enabled object point filtering mode;
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Click left mouse button once to refresh the cursor.

4. [optional] Click on the DEM editing toolbar. The section to set object search
parameters opens:

Fig. 157. The “DEM editing” toolbar

Specify:

• The estimate size of object to be deleted, in projects units;

• Slope angle, in degrees.

The slope angle is one of the parameters by which the filtering start threshold is calcu-
lated. For example, for a building with a sheer wall, the slope angle will be ~ 90 degrees
(note, that due to the peculiarities of constructing DEMs, this angle will never be exactly
90 degrees).

The slope angle is selected individually for each specific case according to the charac-
teristic buildings and objects that need to be identified. Large values of the slope angle
(about 80 degrees) can lead to the fact that buildings of a specific shape (for example,
hangars) may not be removed during the filtering. Reducing the slope angle (for example,
to about 45 degrees) can lead to the fact that, along with the above buildings, some
terrain details can also be removed (for example, hills of similar shape and size).

• Minimal object height over the surface, in project units.

5. Place the cursor on the desired object on the DEM surface and start recognition
double-clicking the left mouse button. The progress window opens. Wait for the
recognition operation to complete and the progress window to close.

If a section of the DEM describing an object that is presumably not a part of the
terrain is found in the vicinity of the marker, then after the operation is performed,
this object will be deleted, and the processed fragment of the DEM will describe
only the terrain.
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If a suitable object is not found in the vicinity of the marker, the No objects for
filteringmessage appears to the right of the displayed current marker coordinates
in the Status bar in the lower part of the 2D window.

6. The system provides for canceling some of the operations placed in the DEM
editing toolbar. Standard functions of the action log are used for this ( , , and

buttons of the main toolbar).

The undo log is described in detail in “Editing of active layer” of “General information”
User Manual and its settings are given in “Settings of undo parameters” of “General
system’s parameters” User Manual.

A separate list of actions that can be cancelled is maintained for each layer. It is
impossible to undo if too many operations are run automatically. In this case, the
appropriate warning appears, and the list of executed operations is not maintained.

If the object filtering operation is canceled, the restored object will be highlighted
against the background of the rest of the DEM surface using a border and green
fill (see above). To deselect the object, enable the object selection mode ( ) and
press Esc.

7.5. DEM classification

The system provides for the classification of DEM cells. DEM classification is performed
according to the preset classes provided in the PHOTOMOD system:

• Low vegetation;

• Medium vegetation;

• High vegetation;

• Water;

• Ground;

• Buildings / Bridges;

• Small buildings / Cars.

To see the key of colors of the preset classes in PHOTOMOD system, chooseWindow ›
DEM classifier table. The DEM classes window opens:
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Fig. 158. Preset DEM classes

Classification is performed through the joint analysis of a DEM and an orthophoto that
has an IR band and spatially coincides with the DEM under study.

The DEM analysis is carried out using an algorithm similar to the slope based filter and
allows to identify such objects as buildings, trees, cars, etc. (without deleting them in
this case).

The NDWI-based orthophoto analysis allows to identify areas of terrain representing
the waterplane. The NDVI-based orthophoto analysis allows to identify areas of terrain
covered by vegetation.

NDVI is the normalized difference vegetation index. Vegetation index is a numerical indicator
of the quality and quantity of vegetation in the studied area.

NDVI is one of the most widely used vegetation indices. It is the ratio between the difference in
the intensities of reflected light in the red (Red) and near infrared (NIR) bands and their sum:

NDVI = (NIR - RED) / (NIR + RED)

NDWI is the normalized difference water index. NDWI is used to monitor changes related to
water content in water bodies, using green and NIR wavelengths:

NDWI = (Green - NIR) / (Green + NIR)

To classify a DEM according to the NDVI index and NDWI index, the input orthoimage must
have an IR channel. To create an orthoimage, set the Create checkbox in the True Ortho
section of the SGM parameters window.

To record IR-band data into the orthoimage under creation, click the Parameters button in True
Ortho section. The True Ortho parameters window opens. Set Use RGBI channels for True
Ortho checkbox in True Ortho parameters window and click OK. The creation of True Ortho
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using four bands is available if the images used as initial data contain the fourth channel, for
example, infrared (RGBI).

The system also provides for the classification of a point cloud according to NDVI, that is carried
out in a similar way (see “Vegetation classification” in the “LIDAR Data processing” User
Manual).

7.5.1. DEM cells classification

To classify DEM cells perform the following:

1. Make active a DEM layer;

2. Select Terrain › DEM › Filter › DEM classification…. The DEM classification
window opens;
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Fig. 159. The “DEM classification” window

3. In Input DEM section click button and select DEM to classify in resources of
the active profile;

4. InOutput DEM section click button and specify name and target folder to keep
output DEM in resources of the active profile;

5. To perform initial analysis of a thinned original DEM, set the Intermediate DEM
pyramid level determining the degree of thinning.

216

DTM GenerationPHOTOMOD 7.5



Increasing the degree of thinning makes it possible to significantly improve the system
processing performance, lowering the quality of classification. Recommended values of
Intermediate DEM pyramid level are 1, 2, or 3.

To set zero value is strongly discouraged.

6. Click the button in TrueOrtho section to select an orthoimage spatially coinciding
with the DEM under processing, in active profile resources;

To classify a DEM according to the NDVI index and NDWI index, the input orthoimage
must have an IR channel.

7. [optional] If required, correct the default water class value range in the input fields
corresponding toWater NDWI (-1;+1);

Common water range is 0.35 and more. This threshold is used to avoid creating false
alarms in urban areas.

8. [optional] If required, correct the default value range in the input fields corresponding
to Vegetation NDVI (-1;+1);

A single range is configured for all kinds of vegetation, low, medium, and high.

Common value ranges: from -1 to 0 are for infrastructure objects, as well as for non-wildlife
objects (e.g. snow, water, sand, stones, houses, roads, etc.). Common vegetation range
is between 0 and 1.

9. [optional] If required, change the default value range in the object height threshold
input field that defines the boundary between high and medium vegetation;

10. In Size of object to be classified section specify the typical anthropogenic object
size on the territory to be researched in following fields:

• Plane distance (max);

• Height (min);

• Slope angle (min) in degrees.

A slope angle is one of the parameters used to calculate a threshold for classification.
For example, for a plumb-wall building, the slope angle is ~ 90 degree (note, that due
to the peculiarities of DEM construction, this angle will never be exactly 90 degrees).

The slope angle is selected individually in each case for the distinctive buildings and
objects that need to be classified. Large values of slope angles (about 80 degrees) may
lead to the fact that those buildings of specific shapes (e.g. hangars) may not be classified
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as a buildings during the operation. Decreasing the slope angle (e.g. to 45 degrees)
may lead to the wrong classification of some accidents of terrain (e.g. elevations having
similar shapes and sizes) along with abovementioned buildings.

11. [optional] Set Use selected polygons checkbox to classify DEM in the borders of
selected polygons only. Select where operation will be performed:

• Inside selected polygons;

• Outside selected polygons.

To Use selected polygons, before opening DEM classification window perform the fol-
lowing:

• Create vector layer (see the “Vectorization” User Manual);

• Create one or several polygons which limit selected fragments of DEM or load vector
layer with polygons to use them as boundaries for filtering;

• Select no less than one polygon which is used as a boundary for classification operation.

12. [optional] Set Open Dem after classification checkbox to open output DEM in a
new layer immediately after operation completion.

13. [optional] To remove processing data after the calculation is completed set the
Delete intermediate data checkbox on.

14. Click OK. A process of DEM classification is started. Output DEM is opened in a
new layer if the corresponding checkbox was turned on.

To use distributed processing for DEM classification, do the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.
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Fig. 160. Parameters of distributed DEM filtering

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.5.2. Extraction of classes from DEM

The system provides for extracting classes from a pre-classified DEM. The extraction
of classes means the selective saving of selected groups of DEM cells into a separate
resource.

For this, perform the following:

1. Make active a DEM layer;

2. Select Terrain › DEM › Filtering › Extract classes from DEM.... The Extract
classes from DEM window opens;
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Fig. 161. The “Extract classes from DEM” window

3. In the Input resource section, click and select a DEM to analyze from the
active profile resources;

4. In the Output resource section, click and define a name and folder to store
output DEM in the active profile resources;

5. Select classes of DEM cells that are to be saved in a separate file by setting the
appropriate checkboxes;

• Low vegetation;

• Medium vegetation;

• High vegetation;

• Water;

• Land;

• Buildings, bridges;
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• Cars, low buildings.

6. [optional] Set Use selected polygons checkbox to filter DEM in the borders of
selected polygons only. Select where filtration will be performed:

• Inside selected polygons;

• Outside selected polygons.

ToUse selected polygons, before opening Slope based filterwindow perform the follow-
ing:

• Create vector layer (see the “Vectorization” User Manual);

• Create one or several polygons which limit selected fragments of DEM or load vector
layer with polygons to use them as boundaries for filtering;

• Select no less than one polygon which is used as a boundary for filtering.

7. [optional] Set Open Dem after filtering checkbox to open output DEM in a new
layer immediately after filtration completion.

8. Click OK. The process of saving a new DEM starts.

7.6. Transformation of DEM coordinates

7.6.1. DEM transpose

The system provides opportunity to transpose DEM from the left coordinate system to
the right one and vice versa. To do this use the Terrain › DEM › Transposemenu item.
Such a transformation results in swap of DEM rows and columns.

This feature is used, for example, if vector objects coordinates are incorrectly specified (see the
chapter ’Transformation of objects coordinates’ in the ’Vectorization’ User Manual).

7.6.2. Transformation of DEM coordinate system

The system provides opportunity to transform DEM from one coordinate system to an-
other.

In order to transform DEM to another coordinate system perform the following actions:

1. Select Terrain › DEM › Transform to another coordinate system. TheConversion
DEM to another coordinate system window opens.
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Fig. 162. Transform DEM to another coordinate system

2. Click the button in the Input DEM section and specify a source DEM file in
active profile resources.

3. Click the button in the Output DEM section and specify DEM name and target
folder in active profile resources.

4. In the Initial coordinates system section select actual Coordinate system of DEM
(if it is different from project coordinate system). Perform the following actions to
do this:

1. Click the Select... button to specify initial coordinate system.

Coordinate system is specified using one of the following ways:

• From DB – from international or Russian coordinate system database
(see’Coordinate systems databases’ in the Project creation’ User Manual);

• From file – allows to select coordinate system from files with *.x-ref-system,
extension located out of active profile resources;

• From resource – from files with *.x-ref-system extension located in active
profile resources, for example, to select coordinate system from another
active profile project.
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• From GeoCalculator – from the list of GeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program” User
manual).

TheGeoCalculator program allows to edit coordinate systems, to create new ones,
to perform import and export of coordinate systems (see the “The GeoCalculator
program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.

2. [optional] When choosing coordinate system from database the Coordinate
system database opens, which contains the list of coordinate systems.

To perform fast search for coordinate system, input the whole coordinate system name
or its part to the Find input filed.

Fig. 163. Window used to select coordinate system from coordinate system database

3. [optional] To choose geoid to be used, click the button. Select proper type
of geoid usage:

• No geoid;

• EGM 96.

The system allows to use the EGM2008 geoid. See more details in the Installation
EGM2008 Geoid User Manual. After installation the geoid is displayed in the list.

5. In the Output coordinate system define target coordinate system in which it is
necessary to convert the DEM. To do this perform actions from step 4.

6. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.
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7. Specify Cell size in meters to change size of output DEM cell.

8. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

9. [optional] To open DEM after recalculation of coordinate system the Open output
DEM checkbox is set on by default. Set the checkbox off to not load the created
file in the project.

10. Click OK to convert DEM coordinate system.

To use distributed computing for changing of DEM coordinate system, do the fol-
lowing:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 164. DEM distributed processing

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.

7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.
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7.6.3. Batch transformation of DEMs coordinate system

The system provides opportunity to transformmultiple DEMs from one coordinate system
to another.

To perform this do the following:

1. Select Terrain › DEM › Batch transform to another coordinate system. The
Group DEM transform window opens.

Fig. 165. The “Group DEM transform” window

2. Choose a folder containing DEMs in resources tree.

button allows to display all available resources in nested files.

button allows to refresh part of the window with resources.

button allows to show a list with 10 recently selected resources.

3. Select file with DEM in the list and click the button to add the file.

and allow to add to the list or remove from it all added files with vector objects, the
button allows to remove selected file from the list.

4. Repeat the 2 and 3 actions to add next files with DEMs.

5. Click the Next button.
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Fig. 166. Output folder and coordinate system settings window

6. Click the button in the Output resource directory section and select a folder
in active profile resources.

7. In the Input coordinates system section select actual Coordinate system of DEMs
(if it is different from project coordinate system). Perform the following actions to
do this:

1. Click the Select... button to specify initial coordinate system.

Coordinate system is specified using one of the following ways:

• From DB – from international or Russian coordinate system database
(see’Coordinate systems databases’ in the Project creation’ User Manual);

• From file – allows to select coordinate system from files with *.x-ref-system,
extension located out of active profile resources;

• From resource – from files with *.x-ref-system extension located in active
profile resources, for example, to select coordinate system from another
active profile project.

• From GeoCalculator – from the list of GeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program” User
manual).

TheGeoCalculator program allows to edit coordinate systems, to create new ones,
to perform import and export of coordinate systems (see the “The GeoCalculator
program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.
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2. [optional] When choosing coordinate system from database the Coordinate
system database opens, which contains the list of coordinate systems.

To perform fast search for coordinate system, input the whole coordinate system name
or its part to the Find input filed.

Fig. 167. Window used to select coordinate system from coordinate system database

3. [optional] To choose geoid to be used, click the button. Select proper type
of geoid usage:

• No geoid;

• EGM 96.

The system allows to use the EGM2008 geoid. See more details in the Installation
EGM2008 Geoid User Manual. After installation the geoid is displayed in the list.

8. In the Output coordinate system define target coordinate system in which it is
necessary to convert DEMs. To do this perform actions from step 7.

9. Specify the Cell size of output DEMs in meters.

10. Click OK to start operation of batch DEMs transformation.

In order to perform batch DEM transformation using distributed processing, do the
following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button.
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7.6.4. Rebuilding DEM considering last adjustment

The system provides opportunity to rebuild DEM considering last adjustment (for ex-
ample, if the project was copied and adjusted after DEM creation once more).

To do this perform the following actions:

1. Select Terrain › DEM › Rebuild considering last adjustment. The Rebuild con-
sidering last adjustment window opens.

Fig. 168. The “Rebuild considering last adjustment” window

2. Click the button in the Input resource section and specify a source DEM file
in active profile resources.

3. Click the button in the Output resource section and specify DEM name and
target folder in active profile resources.

4. Click the button in the Project with previous adjustment section and select
the project with previous adjustment in the PHOTOMOD projects window;
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5. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.

6. Specify Cell size in meters to change size of output DEM cell.

7. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

8. [optional] To open DEM after rebuilding the Open output DEM checkbox is set on
by default. Set the checkbox off to not load the created file in the project.

9. Click OK to rebuild DEM.

To use distributed computing for DEM rebuilding, do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 169. DEM distributed processing

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.
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7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.7. Null cells in DEM

7.7.1. General information

During automatic creation of regular relief model (DEM) some part of the cells can not
be defined. Such DEM cells (’gaps’), which elevation is not known, are called null cells.

The system provides possibility to restore null cells of DEM using the following methods
of null cells filling:

Table 8. Brief description of “Fill NULL cells” menu

FunctionMenu items
see Section 7.7.2linear interpolation
see Section 7.7.3smooth interpolation
see Section 7.7.4By adjacent value
see Section 7.7.5By constant value
see Section 7.7.6By minimum value
a border is created by filling the null cells in border areas in such a way
that DEM has the most smooth border

Build convex hull

allows to set the same elevation of DEM cells inside and outside of se-
lected polygons

Set elevation in selected
polygons...

allows to interpolate a value of DEM cells inside and outside of selected
polygons

Interpolate elevation in selec-
ted polygons...

The system also allows to transform DEM cells with specified elevation to null cells.

Filling DEM null cells is also used to change input DEM cell size.

7.7.2. Filling null cells using linear interpolation

The system provides possibility to restore null cells of DEM using the linear interpolation
method. Null cells filling using this method is performed by creating TIN from the DEM
and calculation of null cells elevation using method of linear interpolation by created
TIN. When using this method it is possible to change the DEM borders and cell size,
as well as to remove ’sharp’ peaks of TIN.

To fill DEM null cells by linear interpolation method perform the following methods:

1. Select Terrain › DEM › Fill null cells › Linear interpolation.... The Parameters
of filling null cells in DEM by linear interpolation window opens.
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Fig. 170. Parameters of filling null cells using linear interpolation

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.
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3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_corr.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. In the Extents section specify DEM boundaries in the North, West, East, South
fields. In the Height and Width fields the system displays calculated size of DEM
border in meters, as well as number of DEM nodes.

5. Specify Cell size in meters to change size of output DEM cell.

6. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

7. [optional] In the DEM border section, set the Select from layer checkbox to set
border of the output DEM using a vector polygon.

It is required to create in advance a vector layer with one polygon which sets borders of
the output DEM.

From the opened list of downloaded vector layers, select one vector layer that
contains a polygon limiting a DEM;

8. [optional] In the DEM border section, set the Build checkbox to create borders of
the output DEM automatically;

9. [optional] To remove processing data after the calculation is completed set the
Delete temporary data checkbox on;

10. [optional] To remove sharp peaks in DEM cells with filled elevation values set the
Peak filtering checkbox on and click the button. The Parameters window
opens.

Fig. 171. Parameters of peak filtering

Input the following peak filtering parameters:

• Edge length – allows to specify maximal edge length in DEM cell (in meters);
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• Elevation shift up more than – allows to specify maximal deviation of cell by
elevation above adjacent cells (in meters).

11. Click OK. The system starts calculation of null cells elevation using linear interpol-
ation method. After that the system creates new DEM layer in the Manager and
shows a message about operation successful or unsuccessful completion.

7.7.3. Filling null cells using smooth interpolation

The system provides possibility to restore null cells of DEM using the smooth interpolation
method. When applying the method of smooth interpolation the system evaluates the
factor of input DEM thinning to obtain auxiliary DEM. An auxiliary DEM is used to calcu-
late elevation values of null cells, and DEM cells with filled elevations are not re-calcu-
lated. Borders and cell size of output DEM are fully correspond to the boundary and
the cell size of the input DEM.

This method is recommended for a sufficiently dense DEM.

To fill DEM null cells by smooth interpolation method perform the following methods:

1. Select Terrain › DEM › Fill null cells › Smooth interpolation.... The Parameters
of filling null cells in DEM window opens.

Fig. 172. Parameters of filling null cells using smooth interpolation
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The window displays the ground sample distance (GSD) of input DEM in meters.

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_filled.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. Input the Auxiliary DEM subsampling. After that the GSD of auxiliary DEM is
calculated automatically.

The Auxiliary DEM subsampling must be an odd number.

5. [optional] In the DEM border section, set the Select from layer checkbox to set
border of the output DEM using a vector polygon.

It is required to create in advance a vector layer with one polygon which sets borders of
the output DEM.

From the opened list of downloaded vector layers, select one vector layer that
contains a polygon limiting a DEM;

6. [optional] In the DEM border section, set the Build checkbox to create borders of
the output DEM automatically;

7. [optional] To remove processing data after the calculation is completed set the
Delete intermediate data checkbox on;

8. Click OK. The system starts calculation of null cells elevation using smooth interpol-
ation method. After that the system creates new DEM layer in the Manager.

7.7.4. Filling null cells by adjacent value

The method of filling the null cells using closest value is based on an analysis of the
values of cells surrounding the null cell. This operation allows to fill DEM null cells by
a closest or average value of non-null cells for a given neighborhood. The output DEM
is the same in size and dimensions with the original, or is a thinned source DEM with
the degree of thinning divisible by 2 (depending on the Processed pyramid level
parameter value).
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To restore a DEM with null cells using this method perform the following actions:

1. Select Terrain › DEM › Fill null cells › By adjacent values. The Parameters of
DEM null cells filling by adjacent values window opens.

Fig. 173. Parameters of DEM null cells restoring

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

3. Specify a path for output DEM in active profile resources.

By default the system suggests the <input dem name>_corr.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. [optional] Pre-filtering – is an optional step, which allows you to fill small areas of
null cells (smaller than a given neighborhood area). It is applied to the main layer
of the source DEM.
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5. [optional] If you decided to perform the pre-filtering, specify theAperture size value.
The value defines a size of a neighborhood, within which the height values to fill
the null cells are searched. Recommended aperture size is 3-10.

6. Themain step is performed on selected pyramid level of output DEM. In the Filtering
section specify the following parameters of the main step:

• Aperture size – defines a size of a neighborhood, within which the height values
to fill the null cells are searched. Required value depends on the size of null cells
clusters located on the source DEM and the level of used pyramid.

It is recommended to specify the aperture size value several times larger than for the
preliminary stage.

• Interpolate values – when the checkbox is on the null cell is filled by the average
height value, taken in specified neighbourhood, if the checkbox is cleared – by
closest (geometrically) height value on the specified neighbourhood.

To calculate the average heights value the system uses bilinear interpolation. This im-
proves an output DEM quality, but increases processing time.

• Output pyramid level – allows to select a pyramid level of the source DEM used
to create an output DEM. If the source DEM is too detailed, select the pyramid
level value more than 0 to use thinned image.

7. [optional] In the DEM border section, set the Select from layer checkbox to set
border of the output DEM using a vector polygon.

It is required to create in advance a vector layer with one polygon which sets borders of
the output DEM.

From the opened list of downloaded vector layers, select one vector layer that
contains a polygon limiting a DEM;

8. [optional] In the DEM border section, set the Build checkbox to create borders of
the output DEM automatically;

9. [optional] To remove processing data after the calculation is completed set the
Delete intermediate data checkbox on;

10. Click OK. Null cells of a DEM are filled considering the specified parameters.

7.7.5. Filling null cells by constant value

The system provides possibility to fill null cells of DEM by constant value.

To fill DEM null cells with constant value perform the following methods:
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1. Select Terrain › DEM › Fill null cells › By constant value.... The Fill DEM null
cells by constant value parameters window opens.

Fig. 174. Parameters of filling null cells of DEM by constant value

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_filled.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. Input the Value for filling of null cells.

5. [optional] In the DEM border section, set the Select from layer checkbox to set
border of the output DEM using a vector polygon.

It is required to create in advance a vector layer with one polygon which sets borders of
the output DEM.
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From the opened list of downloaded vector layers, select one vector layer that
contains a polygon limiting a DEM;

6. [optional] In the DEM border section, set the Build checkbox to create borders of
the output DEM automatically;

7. [optional] To remove processing data after the calculation is completed set the
Delete temporary data checkbox on;

8. Click OK. The system starts filling of null cells operation. After that the system dis-
plays a message about number of changed cells and creates new DEM layer in
the Manager.

7.7.6. Filling null cells by minimum values

The system provides possibility to fill null cells of DEM by minimum values.

The system also provides possibility to interpolate areas without data on orthophotomap (true
ortho) created together with the DEM.

The method of filling the null cells using minimum values is based on an analysis of the
values of cells surrounding the null cell. This method allows to exclude nearby buildings
from interpolation of DEM null cells (see the figure below, paragraph 11).

To fill DEM null cells with minimum values perform the following:

1. Select Terrain › DEM › Fill null cells › By minimum values.... The Fill NULL cells
window opens.
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Fig. 175. Parameters of filling null cells of DEM by minimum values

2. In the DEM section click the button to select input DEM in active profile re-
sources.

3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

4. In DEM section, setMinimum building height in meters to exclude buildings from
interpolation of DEM null cells (see the figure below);
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5. InDEM section, setCache sizewhen filling option in megabytes – maximum cache
size allocated for a single task when creating true ortho;

6. [optional] In DEM section, сlear the Fill single NULL cells checkbox in order not
to interpolate single DEM NULL cells;

7. [optional] In True Ortho section, clear the Fill NULL cells checkbox in order not
to interpolate unfilled areas on orthophotomap;

8. In the True Ortho section click the button to select input true ortho in active
profile resources.

For correct work of interpolation algorithm it is required to select the orthophotomap that
was created together with the DEM in the same boundaries (see step 2).

9. [optional] To define name and target folder of output true ortho in active profile re-
sources, click the button.

10. [optional] Set the following parameters of unfilled areas interpolation on orthopho-
tomap:

• Overwrite valuable cells in NULL areas – allows to exclude isolated DEM areas
from interpolation of unfilled true ortho areas;

Isolated DEM areas – the cells with values beyond the boundaries of the main DEM or
among null cells.

• Interpolate not filled NULL cells – allows to interpolate unfilled orthophotomap
areas;

• Fill single NULL cells – allows to interpolate areas without data having one pixel
size on orthophotomap;

• Visibility distance – the distance within which the visibility of points located in
unfilled areas of an orthophotomap is checked in the project’s images;

• Visibility step – an increment with which the visibility of points located in unfilled
areas of an orthophotomap is checked in the project’s images;

• Maximum images per pixel – maximum number of images of the project where
the visibility of points located in unfilled areas of an orthophotomap is checked;

• Filter outliers – allows to perform orthophotomap median filtering with preset
Threshold. The statistics is collected in the neighborhood whose area is determ-
ined by the Aperture size. This filter is used for removing single pixels with un-
natural brightness.
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11. [optional] set theOverwrite existing DTM/TrueOrtho checkbox in order not to use
intermediate data from the working folder but overwrite them.

Fig. 176. An example of unfilled area on true ortho, where a is the building height (see Minimum
building height parameter), b is the “isolated DEM area” among DEM NULL cells (see Overwrite
valuable cells in NULL areas checkbox), с is the Visibility step, R is the Visibility distance, S
is the unfilled DEM/orthophotomap area (due to the fact that the image is the central projection of
terrain and objects towering above the Earth surface hide some terrain areas, thus they are not

seen on the image).

12. Click OK. The system starts filling of null cells operation. After that the system dis-
plays a message about number of changed cells and creates new DEM layer in
the Manager.

To use distributed processing for DEM null cells filling, do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.
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Fig. 177. DEM distributed processing

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.7.7. Converting cells to null

The system allows to convert DEM cells with specified elevation to null cells.

It is recommended to apply this method if there are errors after importing DEM.

In order to convert cells to null ones perform the following actions:

1. Select Terrain › DEM › Cut DEM by Z-range.... The Parameters of converting
DEM cells to null values window opens.
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Fig. 178. Parameters of converting DEM cells to null values

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_corr.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. Specify a range of DEM cells to be converted to null in the Zmin and Zmax fields
in meters.

The system allows to convert DEM cells, located both inside the range and outside the
range.

5. Click OK. After that all output DEM cells, which elevation falls within specified Z-
range are converted into null cells. After the operation is completed, an informational
message about the number of deleted cells is displayed.
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7.8. DEM editing

7.8.1. DEM merging

The system provides possibility of merging (joining) of adjacent DEMs that have overlap.

To merge adjacent DEMs perform the following actions:

1. Select Terrain › DEM ›Merge DEMs.... TheDEMmerging – Step 1 from 2:window
opens Source data.

Fig. 179. Selection DEMs for merging

2. Choose a folder containing DEM in resources tree.

The button allows to display all available resources in nested files. The button allows
to refresh part of the window with resources.

The button allows to show a list with 10 recently selected resources.

3. Select the DEM that has overlap with the adjacent one in the list, and click the
button to add the DEM to be merged.

The and buttons allow to add to the list or remove from it all added DEMs, the
button allows to remove selected DEM from the list.

4. Repeat the 2 and 3 actions to add next DEMs.

It is necessary to choose for merging at least two files containing DEMs with overlap area.
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5. Click the Next button. The DEM merging – Step 2 from 2: Parameters window
opens.

Fig. 180. Parameters of DEMs for merging

6. Specify DEM borders in the North, West, East, South fields. In the Height and
Width fields the system displays calculated size of DEM border in meters, as well
as number of DEM nodes.

7. Specify Cell size in meters to change size of output DEM cell.

8. [optional] It is possible to use parameters of existed DEM to calculate parameters
of output DEM. To do that, click theCalculate parameters by existing DEM button
and choose DEM file in active profile resources.

9. In the Inside overlapping area, use section select the DEM, which values should
be used in the overlap area:
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• Top DEM – use data from top DEM (the first or the top DEM in the list, added
for merging, in the DEM merging – Step 1 from 2: Source data window);

• Bottom DEM – use data from bottom DEM (the second or the bottom DEM in
the list, added for merging, in the DEM merging – Step 1 from 2: Source data
window);

• Average value – calculate and use average cells values of adjacent DEMs in
overlap area.

• Weighted mean value – while calculating average values in overlapping areas
to take into account an estimation of errors in DEM heights with the subsequent
filtering “rough” ones;

Fig. 181. Calculating heights inside overlapping area with weighted mean value

Setup the following parameters of calculating weighted mean values inside
overlapping area:
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○ Apriory DEM accuracy by Z;

DEMs built by SGM method and no having any subsequent additional processing
contain data of priori accuracy estimation.

Priori accuracy estimation is calculated based on image GSD and intersection angle
of stereopair on which DEM is built.

To find data of priori accuracy estimation select Service › Explorer. PHOTOMOD
Explorer window is opened. At the left side of the window in the folder containing
DEM open subfolder “Temp\Dems“, which contains DEMs with *.x-dem extension.
They are built for each stereopair separately.

Fig. 182. PHOTOMOD Explorer window

At the right side of PHOTOMOD Explorer window open a context menu with a click
of mouse right button in the file name of any DEM generated for separate stereopair.
Select View as text. DEM file is opened in a text editor.

Fig. 183. DEM file opened in a text editor

Information on priori accuracy estimation is contained after line <s n="name"
v="apriory_accuracy"/>, where v is a desired value. I.e. <d n="val"
v="2.9873863417182838e+000"/>.
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○ Minimum number of counts in overlap area allows to setup a reliability of
output DEM cell values. Given parameter defines a minimal number of values
needed for calculating final value of output DEM cell. If Minimum number of
counts in overlap area is more than 1, all the DEMs cells placed in areas
without DEMs overlaps will not be recorded.

It is recommended to useWeightedmean value for calculating DEM value in overlapped
area if DEMs being merged can contain “rough” errors.

10. [optional] By default the Open output DEM checkbox is set on that allows to open
the out put DEM after the operation is completed. Set the checkbox off to not load
the resulting DEM in the project.

11. Click OK to start DEM merging process.

To use distributed computing for DEMs merging do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 184. DEM distributed processing

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.
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7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

7.8.2. Change DEM parts elevation

The system allows to align selected part of DEM by elevation. In this case, a fixed elev-
ation value is assigned to all cells of the DEM part outlined by selected polygon.

To align DEM part by elevation perform the following actions:

1. Create or load a vector layer (see the “Vectorization” User Manual).

2. Create single or multiple polygons, that outline selected parts of the DEM, or load
polygons layer to use them as boundaries.

3. Select at least one polygon that will be used as a boundary.

4. Choose Terrain › DEM › Set elevation in selected polygons. The Parameters
of DEM elevation assigning in polygons window opens.
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Fig. 185. Parameters of DEM elevation assigning in polygons

5. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

6. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_fill.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

7. Specify value of DEM cells in each selected polygon:

• DEM average elevation in polygons;
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• DEM max elevation in polygons;

• DEM min elevation in polygons;

• polygon average elevation;

• polygon max elevation;

• polygon min elevation;

• Use constant elevation;

Set the Constant elevation in meters.

• Change elevation – allows to shift selected part of DEM by Z axe in both direc-
tions.

• use polygon surface – allows to build a TIN-surface created using the same
polygon into the DEM (within a polygon).

This function allows to build an object (e.g. a building) described by the abovementioned
vector polygon into the DEM. At the same time, to calculate new values of DEM cells
within a polygon, only the TIN surface built for this (based on the same polygon) is used
(without interpolation of old DEM values).

8. Click OK. After that a specified elevation values is assigned to all DEM cells inside
selected polygons.

7.8.3. DEM shift

The system provides possibility to shift the whole DEM by one or more axes using
parallel displacement.

In order to shift a DEM perform the following actions:

1. Load or create a DEM;

2. Select Terrain › DEM › Shift. The DEM shift window opens;
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Fig. 186. Parameters of DEM shift

3. Specify the value of the Absolute shift by axes in the X, Y, Z fields in meters.

It is possible to shift a DEM by one or all axes at once.

4. Click OK. After that all points of active layer DEM are shifted on specified value by
selected axes with help of parallel displacement.

In order to shift a DEM once again perform the following actions:

1. Select Terrain › DEM › Shift. The DEM shift window opens. In the Absolute shift
by section, the DEM shift will be displayed relative to its initial position.

The information on DEM’s shift relative to its initial position is saved automatically after
each shift operation and is available after closing the DEM layer and/or restart.
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Fig. 187. Parameters of DEM shift. The DEM was shifted to 200 meters by the X-axis

2. To specify a next shift parameters perform one of the following actions:

• [optional] Change the value of the Absolute shift by axes in the X, Y, Z fields;

• [optional] Specify the value of the Relative shift by axes in the X, Y, Z fields in
meters (to do this set an appropriate checkbox). In theAbsolute shift by section,
the DEM shift value(s) will be changed automatically.

Fig. 188. Parameters of DEM shift. The DEM shift will increase by 100 meters by the X-axis. The
absolute shift by the X-axis will be 300 meters

3. Click OK. After that all points of active layer DEM are shifted on specified value of
the relative shift by selected axes with help of parallel displacement.
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In order to restore DEM to initial state perform the following actions:

1. Select Terrain › DEM › Shift. The DEM shift window opens. In the Absolute shift
by section, the DEM shift will be displayed relative to its initial position.

Fig. 189. Parameters of DEM shift. The DEM was shifted to 300 meters by the X-axis, during the
previous actions

2. Set the zero values of the Absolute shift by axes in the X, Y, Z fields;

Fig. 190. Parameters of DEM shift

3. Click OK. After that all points of active layer DEM are shifted on the initial position.
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7.8.4. Split DEM into sheets

Splitting of DEM into sheet is available in the system. It is used to save DEM in parts
in separate files. Sheets are created inside the vector polygons.

See the “Generators of splitting into sheets” chapter in “Orthophotomaps creation” User Manual.

To split DEM into sheets perform the following:

1. Load or create DEM;

2. Load or create vector polygons to use as sheets;

All used polygons must have attributes with shared names and unique values.

3. Make active the DEM layer.

4. Choose Terrain › DEM › Split DEM by sheets. The Split DEM into sheetswindow
opens.

Fig. 191. The “Split DEM into sheets” window

5. Choose layer with polygons with a single left mouse click;

6. Choose the Attribute name to use its values as filenames.

If there is no chosen attribute for some sheets, these sheets can be passed or continuous
numbering can be used as file names.
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7. Choose the Output path for files, in active profile resources;

8. [optional] In the Offset off sheet (+/-) input field, enter a nonzero value, in pixels,
to create sheet margins:

• If the entered value is positive, the sheet is built with the given offset beyond the
border of the relevant polygon;

• If the value of the offset from the borders is negative, the sheet is built with an
offset inward the polygon.

9. Click OK to start the process.

Perform the following to use distributed processing:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click theDistributed processing button. TheSplit DEM to sheets: distributed
processing window opens.

Fig. 192. Distributed processing parameters

3. Number of sheets is calculated automatically and depends on number of
polygons.

It is recommended to define Number of tasks based on “one task – one com-
puter”.

4. Choose the Output path for files.

5. Choose the Temporary path for temporary files.

6. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

As a result DEM splits into parts by polygons of chosen layer. Values of selected
attribute are used as filenames.
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7.8.5. DEM interpolating

The system supports local alignment of elevation values of DEM part, limited by a
polygon on a vector layer.

In order to align a part of DEM perform the following actions:

1. Create a vector layer (see the ’Vectorization’ User Manual).

2. Create single or multiple polygons, that outline selected parts of the DEM, or load
polygons layer to use them as boundaries.

3. Select at least one boundary polygon to be used for interpolation of cell elevation
values inside it.

4. Choose Terrain › DEM › Interpolate elevation in selected polygons. The Para-
meters of DEM interpolation assigning in polygons window opens.

Fig. 193. Parameters of DEM interpolation assigning in polygons

5. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

6. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

257

DTM GenerationPHOTOMOD 7.5

vectorization.pdf


By default the system suggests the <input dem name>_fill.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

7. Specify the DEM interpolation method:

• Smooth model;

• Polynomial model;

• Linear model.

8. [optional] To smooth boundaries between unchanged parts of a DEM and its
changed fragments, set the Smooth feathering with aperture … (pix) checkbox,
and set the aperture size in pixels;

9. Click OK. After that cell elevation values inside selected polygons (one or several)
is interpolated using specified method.

7.8.6. DEM cutting by polygons

The system allows to edit the area of DEM coverage.

In order to correct DEM area, perform the following actions:

1. Create vector layer and polygons in it, or open a layer with bordering polygons (see
the ’Vectorization’ User Manual).

2. Select one or more polygons, that will be used to cut the DEM.

3. Select Terrain › DEM › Cut by selected polygons. The Polygon cutting paramet-
ers window opens.

Fig. 194. Parameters of cutting by polygons
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4. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

5. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_cut.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

6. Specify the Mode of DEM cutting:

• Cut outside – allows to crop DEM outside of selected polygons area;

• Cut inside – allows to cut DEM area located inside of selected polygons.

7. [optional] Specify DEM offset of polygons (pix);

8. Click OK. After that resulting DEM obtained after editing is opened.

Fig. 195. DEM with areas cut inside polygons
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To edit DEM in distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Distributed
processing” chapter in the “General information” User Manual).

2. Click the Distributed processing button.

Fig. 196. Параметры обрезки по полигонам

3. Specify parameters of DEM distributed processing and click OK. The system creates
distributed processing tasks depending on a number of used cores and amount of
fragments.

Besides, the system allows to remove edge areas of DEM, that include null cells Perform
the following actions to do this:

1. Select Terrain › DEM › Cut null edges. The Cut null edges window opens.

Fig. 197. DEM edges cutting

2. In the Input DEM section click the button to select input DEM in active profile
resources.

The DEM loaded to the project is selected by default.

3. [optional] To define name and target folder of output DEM in active profile resources,
click the button.

By default the system suggests the <input dem name>_cut.x-dem name for output DEM
and to place it to the folder, containing input DEM file.

4. Click OK. After that the system opens a DEM without removed edges areas.
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7.8.7. Adding of points to DEM

The system provides possibility to add points to DEM that helps to refine DEM cells
values.

Usually it is necessary to perform the following:

1. Load or create a DEM.

2. Create a vector layer.

3. Draw a polygon around the DEM, which cells values should be edited.

4. Highlight this polygon.

5. Select Terrain › DEM › Convert to points... to create vector layer.

6. In the Parameters of converting to pointswindow select vector layer, where there
is highlighted polygon.

7. [optional] Set the rest of parameters of DEM converting to points, if necessary.

Fig. 198. Parameters of DEM conversion to points
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8. Click OK. DEM area outlined by highlighted polygon will be converted to points,
which are added to a new vector layer.

9. Correct location of obtained points by Z.

10. Select Terrain › DEM › Write points to DEM. After that the DEM is rebuild consid-
ering points layer.

It is impossible to cancel the operation. The system overwrites the active DEM automatically.

7.8.8. Convert DEM to points

The system allows to convert DEM cells points with specified simplifying.

To do this conversion perform the following actions:

1. Load or create a DEM.

2. [optional] Load vector layer and select polygons, within which it is necessary to
perform the conversion.

3. Select Terrain › DEM › Convert to points.... The Parameters of converting to
points window opens.
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Fig. 199. Parameters of DEM converting to points

4. Specify Thinout coefficient of DEM.

5. [optional] Specify DEM borders in the North,West, East, South fields.

Depending on this coefficient the system calculates the Cell size of output DEM in
meters, Height andWidth in meters and in points number. Besides, the estimated
Number of output points is displayed in this window.

The Extents from DEM button allows to specify values of borders of conversion
area.

6. [optional] If additional vector layer with polygons is loaded, set the Convert inside
selected polygons checkbox on and select a layer with polygons in the list to
perform conversion in specified areas only.

7. Click OK. When the conversion is completed the system displays a message about
number of acquired points and new vector layer with obtained points is created.

To Save points to resource at once automatically (without opening the created layer in
the Layer Manager), set the appropriate checkbox.
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Points will be automatically saved in the active profile resources in the folder containing
the input DEM, in a separate folder with a following name: points_<DEM_name>.

7.8.9. The ’DEM editing’ toolbar

The system provides possibility of fast editing of DEM areas using selecting tools (see
details in the ’Objects selection’ chapter of the ’Vectorization’ User Manual). For this
there is an additional toolbarDEM editingwith buttons that allow to perform the following
operations:

• – allows to cut DEM area located inside of selected polygon;

• – allows to set elevation of DEM cells inside of selected area;

• – allows to interpolate selected DEM area using smooth model;

• – allows to interpolate selected DEM area using polynomial model;

• – allows to interpolate selected DEM area using linear model;

• – allows to shift the whole DEM by one or more axes using parallel displacement;

• – allows to add points to DEM that helps to refine DEM cells values;

• – enables the mode of selective object filtering;

• – enables the object’s preselection mode (without deleting);

• – allows to set the selective filtering of objects parameters;

The system provides for canceling some of the operations placed in the DEM editing
toolbar. Standard functions of the action log are used for this ( , , and buttons
of the main toolbar).

The undo log is described in detail in “Editing of active layer” of “General information”
User Manual and its settings are given in “Settings of undo parameters” of “General
system’s parameters” User Manual.

A separate list of actions that can be cancelled is maintained for each layer. It is im-
possible to undo if too many operations are run automatically. In this case, the appro-
priate warning appears, and the list of executed operations is not maintained.

It is impossible to undo DEM shift ( ) and adding points ( ), and the action log is
never maintained for these operations. Changes made to DEM using these two quick
editing tools are immediately saved. In this case, make a DEM copy before editing
(Terrain › DEM › Save a copy...).
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If DEM shift or point adding were preceded by operations recorded in the action log
( , , , or , cancellation is allowed), in this case DEM shift or point adding will
interrupt the action log and cause inability to cancel previous operations. An appropriate
message appears.

To quickly edit a DEM area perform the following actions:

1. Load a DEM or make active a layer with DEM.

2. Click the button of the DEM editing additional toolbar, to define operation to be
performed with DEM cells.

3. [optional] To specify elevation of selected DEM cells, set the elevation value in the
filed to the right from the button.

4. Press and hold the Shift key and select area to be edited by mouse. The editing
is performed automatically using parameters specified by default.

In order to edit multiple areas, repeat the 4 step required number of times. To turn off the editing
mode, selected on the 2 step, click the appropriate button again.

7.8.10. Elevation correction along centerline

This operation does not provide for undo. Ensure creating a сору of the DEM first.

The system provides for correcting DEM cell values along the selected linear objects.

For this, perform the following:

1. Load or create a DEM;

2. Create and select at least one linear vector object that intersects the DEM in the
XY plane:
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Fig. 200. A polyline intersecting a DEM in the XY plane (2D-window viewing)

3. Make the DEM layer active:

Fig. 201. A polyline intersecting DEM in XY-plane and along Z (3D-window view)

4. Choose Terrain › DEM › Elevation correction along centerline. The Elevation
corrections along vector line window opens:
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Fig. 202. The “Elevation corrections along vector line” window

5. Configure the following transformation options:

• The corridor width – is the size of DEM transformation area along the centerline

• Interpolation type:

○ Linear;

○ Squared polynomial;

○ Gaussian;

○ None.

• To delete vector line after elevation correction, set the appropriate checkbox.

6. Click OK. A warning message appears:

Fig. 203. An warning message

7. Click Yes, to confirm the operation;

8. A DEM is edited according to specified settings and used polyline/polygon vertex
elevations. After successful completion of the operation, an appropriate info message
is issued.:
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Fig. 204. An info message

Fig. 205. Edited DEM (2D-window view)
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Fig. 206. Edited DEM (3D-window view). Squared polynomial interpolation. The used polyline
(deleted) crossed the DEM in the XY-plane and along Z

Fig. 207. Edited DEM (2D-window view)
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Fig. 208. DEM edited without interpolation (3D-window view). The used polyline (highlighted in red)
crossed the DEM only in the XY-plane

.

7.9. Accuracy control of DEM creation

7.9.1. Creation of difference DEM

The system provides possibility to create difference DEM using subtraction of one DEM
from the other.

To create difference DEM perform the following actions:

1. Load at least two DEMs to be used for subtraction;

2. [optional] Create and select vector polygon, if it is needed to create a difference
DEM within current polygon;

3. Select Terrain › DEM › Check accuracy › Build difference DEM. The DEMs
comparing parameters window opens:
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Fig. 209. Parameters of DEMs comparing

The list displays all loaded DEMs.

4. Select in the list a layer with DEM, from which the system will subtract. Use the
and buttons to move it to the top of the list;

5. Select a way of resulting DEM creation:

• Difference – the system performs subtraction of one DEM from the other. If there
are null values in the one of DEMs, the output DEM will contain null values in the
same cells;

• Exclusive ’OR’ – the output DEM cells are calculated only in areas, where one
of input DEMs have a null cell values. The final sign (positive or negative) of cells
elevation in output DEM depends on sequence of subtracting of one DEM from
the other;

• Addition – input DEMs cells values are summed up. If there are null values in
the one of DEMs, the output DEM will contain null values in the same cells.

6. In theOutput DEM section click the button and specify name and path of output
DTM in active profile resources;

7. Specify the output DEM cell size – Cell size of top DEM or the Least cell size;
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8. [optional] Set the Within current polygon checkbox to create a difference DEM
within selected polygon;

9. Select two DEMs in the list. To do this press and hold the Ctrl key and click the
DEM list by mouse.

The DEM from which the system performs the subtraction should be higher in the list, than
the subtrahend DEM.

10. Click OK. After that the system shows a message about operation successful or
unsuccessful completion. In case of success the system creates new layer in the
Manager.

To use distributed processing for difference DEM creation, do the following:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button. The DEM distributed processing
window opens.

Fig. 210. Parameters of distributed DEM filtering

3. The number of DEM parts, which the DEM is split on during distributed pro-
cessing, is calculated automatically and depends on the size of the matrix.

4. It is recommended to define Number of fragments per task depending on
computer power and hardware. Recommended number of DEM parts /
Number of fragments per task ratio is no more than 500.

5. Select the Temporary folder for distributed processing for temporary data
storing.

6. Define the output file name and path.
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7. Click OK. Distributed processing tasks are created and the system shows a
message about number of created tasks.

For automatic positioning marker on active DEM surface the Marker Z coordinate
follows DEM in active layer check box is on by default in the general system’s para-
meters.

7.9.2. DEMs comparing

The system provides possibility of comparing of two DEMs for the same territory to
analyse their discrepancies by Z axis.

To compare DEMs perform the following actions:

1. Load DEMs to be compared;

2. [optional] Create and select a vector polygon if it is needed to compare DEMs
within the selected polygon only;

3. Select Terrain › DEM › Check accuracy › Compare DEMs. The DEMs compare
parameters window opens:

Fig. 211. Parameters of DEMs comparing
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The list displays all loaded DEMs.

4. Select two DEMs in the list. To do this press and hold the Ctrl key and click the
DEM list by mouse;

5. Set the sample step (points where elevation value comparison will take place). The
systems allows to:

• Take the cell size from DEM selected from the drop-down list;

Only selected DEMs are available in the drop-down list (see the section above).

• Set the DEM cell size in meters along the X and Y axes.

When selecting a step, it is needed to take into account the search area size (DEM or
selected polygon dimensions). Wrong step size may lead to the inability to form at least
one value.

6. Set the following parameters:

• Display the worst..values – allows to show a list of specified number of points
with maximal error;

• Display with shift more than..m – allows to show a list of points with discrepancy
greater than specified.

7. Set the Compare inside selected polygon checkbox, if appropriate;

8. Click OK. The system starts operation of selected DEMs comparing. When the
operation is completed the Compare DEMs window opens.

Fig. 212. Parameters of DEMs comparing
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The window displays a list of points coordinates, where:

• N – is point serial number;

• X, Y, Z – coordinates of erroneous point;

• DZ – discrepancy by Z.

The status line of the window displays root mean square error (RMS) of discrepancies,
Mean absolute, maximal discrepancy by Z found (Max), as well as Average discrep-
ancy among points found.

The button allows to save the table to file with *.csv extension.

The button allows to save the selected values of current vector layer as points.
For this, select at least one value in the table. DZ values will be saved as attributes
of the created points.

If there are no open vector layers, the system offers to create a new vector layer.

Double click the point record line by mouse to select the point in the DEM active
layer.

7.9.3. Search for DEM areas

To perform analysis of DEM creation quality the system provides possibility of null cells
search in created DEM.

It is not recommended to search for null cells when processing big data amounts.

To search for null cells in DEM perform the following actions:

1. Load or create a DEM.

If multiple DEMs are loaded into project, the search is performed in the active DEM layer.

2. Select Terrain › DEM › Check accuracy › Search for DEM areas. TheDEM areas
searching parameters window opens.
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Fig. 213. DEM areas searching parameters

3. Input the image Pyramid level for null cells search.

Zero pyramid level corresponds to a source image.

4. Set DEM areas for searching:

• NULL cells areas – search for DEM null cells;

• All areas – search for DEM null cells and cells with values;

• Elevation areas – search for cells with values.

5. Set Area nesting level to set “nested areas” search parameters (e.g. an area with
null cells within an area of cells with values in its turn within a large area with null
cells);

6. [optional] set theMinimum polygon perimeter checkbox to exclude areas having
sizes lesser than the specified value from the search. Specify minimum polygon
perimeter in meters;

7. SetNumber of objects for showing, to define the number of areas to be displayed
in the Null cells window (the preset number of areas found first will be displayed
in the window).

8. Click OK. The system starts search for null cells operation. When the search is
completed the system opens the Null cells window or displays a message about
absence of null cells.
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Fig. 214. Null cells list

The list of the areas with null cells (their number is limited by theNumber of objects
for showing parameter) are displayed in the window, where:

• N – is the area serial number;

• X,Y – coordinates of centers of null cells areas;

• (31) – number of vertices of the vector polygon circumscribing the area (to create
a vector layer that contain points on borders of null cells area, click the button).

The button allows to save the list to file with *.csv extension.

To create a vector layer that contain points on borders of null cells area, click the
button.

Vector boundaries will be created for all found areas except for those excluded from search
by the Minimum polygon perimeter option, but independent of the Number of objects
for showing parameter.

Double click by left mouse button the list item in the Null cells window moves the
marker to the appropriate area found during the search.

To edit DEM with null cells the system provides the following features:

• various methods of null cells filling (see Section 7.7);

• alignment of selected DEM fragment by elevation (see Section 7.7);

• vector objects editing and DEM rebuilding, when base vector layers are used for DEM
creation.

7.9.4. DEM control by TIN

The system provides possibility to control created DEM by TIN. The control is performed
by calculation of source TIN nodes discrepancies from created DEM.

To control created DEM perform the following actions:
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1. Select Terrain › DEM › Check accuracy › Check against TIN. The Parameters
of check DEM using TIN window opens.

Fig. 215. Parameters of DEM accuracy control by TIN

2. Set the following parameters:

• Display the worst..values – allows to show a list of specified number of TIN
nodes with maximal error;

• Display with shift more than..m – allows to show a list of points with discrepancy
from DEM by Z greater than specified.

3. Click OK. The system starts operation of selected DEMs comparing. When the
operation is completed the system opens the Check DEM using TIN window.

Fig. 216. Results of DEM control by TIN

The window displays a list of points coordinates, where:

• N – is serial number;

• X, Y, Z – coordinates of erroneous point;

• DZ – discrepancy by Z between DEM and TIN.
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The status line of the window displays root mean square error (RMS) of discrepancies,
Mean absolute, maximal discrepancy by Z found (Max) on points found.

The button allows to save the list to file with csv extension.

Double click the point record line by mouse to select the point in the DEM active
layer.

A list of erroneous nodes includes those located on all stereopairs of current project.

4. [optional] To change the list display parameters, click the button. In order to
display changes in the list click the button.

5. To edit TIN using the list the system provides the following features:

• to remove selected TIN node, click the button or press the Delete key;

• to remove all nodes, where the error is more or equal to the error selected in the
list, click the button.

6. Click the button, to re-build the DEM considering all changes.

7.9.5. DEM control by vector objects

The system provides possibility to control DEM creation quality by vector objects. During
comparing vector objects with DEM the system compares Z-coordinates of points or
vector objects vertices with elevation in corresponding points of the DEM. This vector
objects layer should not be used as a base layer during this DEM or TIN creation.

DEM control by vector objects is needed to estimate accuracy of imported DEM or, vice
versa, of vector objects by ’master’ DEM.

To control DEM creation against vector objects perform the following actions:

1. Load DEM;

2. Load vector layer;

3. Select Terrain › DEM › Check accuracy › Check against vector objects. The
Parameters of check DEM by vectors window opens.
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Fig. 217. Parameters of accuracy control by vectors

4. Set the following parameters:

• Display the worst..values – allows to show a list of specified number of points
with maximal error;

• Display with shift more than..m – allows to show a list of points with discrepancy
from DEM by Z greater than specified.

5. Click OK. The system starts operation of selected DEMs comparing. When the
operation is completed the system opens the Check DEM using vector objects
window.

Fig. 218. Results of DEM control by vector objects

The window displays a list of points coordinates, where:

• N – is serial number;

• X, Y, Z – coordinates of erroneous point;
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• DZ – discrepancy by Z between DEM and vector objects vertices.

The status line of the window displays root mean square error (RMS) of discrepancies,
Mean absolute, maximal discrepancy by Z found (Max), as well as Average discrep-
ancy among points found.

Double click the point record line by mouse to select the point in the DEM active
layer.

A list of erroneous nodes includes those located on all stereopairs of current project.

The button allows to save the list to file with csv extension.

The button allows to select those vector objects within the layer, the vertices of
which were selected in the table.

The button allows to save max DZ values for each vector object in the vector
object attributes.

The name of the attribute created in the process of saving is MAX_DZ.

The button allows to specify the attribute selection settings to include attributes
into a table of the results of DEM accuracy control:

Fig. 219. The “Attribute selection settings” window

Using this window, user can include into the table any vector object attributes used
for the accuracy control, if these attributes were previously created. The window
allows to select one attribute to be included, select all, or none.
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Fig. 220. Including previously created attributtes into the table

For example, to include the MAX_DZ attribute value into the table of accuracy control
results, perform the following:

1. Create the attribute ( );

2. Repeat the accuracy control operation (Terrain › DEM › Check accuracy ›
Check against vector objects);

3. Include this attribute into the table using the attribute selection settings win-
dow.

7.9.6. DEM control by triangulation points

The system provides possibility to control DEM creation quality by triangulation points.
During comparing triangulation points layer with DEM the system compares Z-coordin-
ates of triangulation points with elevation in corresponding points of the DEM. This tri-
angulation points layer should not be used during this DEM creation.

To do this use the Terrain › DEM › Check accuracy › Check against TIN menu item.

It is not necessary to create points vector layer.

The Accuracy control window includes a table of all points (GCP/check/tie), acquired
on on aerial triangulation step (see the ’Aerial triangulation’ User Manual).
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Fig. 221. Accuracy control using triangulation points

Checkboxes in the toolbar at the top of the window are used to customize the display
of triangulation points in the list according to their types and properties (see the “Point
properties” chapter in “Aerial triangulation” User Manual):

• Gr.control – set the appropriate checkbox to display points of this type in the table;;

• Check – set the appropriate checkbox to display points of this type in the table;

• Tie – set the appropriate checkbox to display points of this type in the table;

• Targeted – set the appropriate checkbox to display targeted points in the table.

Only those types of triangulation points that present in this project are available for selection.

To display only adjusted points or points inside DEM from the selected points, set the
appropriate checkboxes.

The Used points field is used to display number of points used for calculation of DEM
deviation by Z-coordinate (in the Use column the is set).

The table of triangulation points contains the following columns:

• Name – point number;

• Type – point type: GCP, check or tie point;
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• Use – data about point use for calculating of DEM deviation by Z-coordinate:

○ – the triangulation point was used;

○ – the triangulation point was not used;

○ – the triangulation point cannot be used, since it was not used for adjustment.

• X, Y, Z – adjusted coordinates of triangulation points;

• Ez – value of DEM deviation from the triangulation point by Z-coordinate.

Status panel is used to display values of root mean square error (RMS) and a value of
maximal error of DEM deviation by Z-coordinate (Max).

The button allows to display in the list a point with maximal error of deviation from
triangulation points by Z-coordinate.

The button allows to display detailed report on accuracy control.

Fig. 222. Report on accuracy control using triangulation points

The top panel of the Report window contains the following buttons:

• – allows to close report window;

• – allows to save a report to file system of Windows;

• – allows to change font, style, size, and color of report text;

• – allows to print a report.
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7.9.7. Creation of histogram by DEM

The system allows to create histogram by DEM.

A histogram can be, for example, a convenient tool to analyze a difference DEM.

To do this use the Terrain › DEM › Check accuracy › Create histogram by DEMmenu
item. The Histogram window opens.

Fig. 223. Histogram

A histogram displays the dispersion of the number of cells (Y-axis) within the working
elevation range (X-axis).

There is a table at the bottom of the Histogram window that contain the following in-
formation:

When building a histogram for the first time the work elevation range is equal to the DEM el-
evation range by default (i.e. the histogram to be created for all DEM cells). Later (see below)
the work elevation range can be narrowed, e.g., to exclude evidently false values (so called
peaks) from the data used for histogram building.

• The arithmetical mean elevation of data used for histogram building is the sum of
cell elevations divided by the number of cells. It depends on the work elevation
range that is used when building a histogram;

• The mean absolute is the sum of absolute values of cell elevations divided by the
number of cells. It depends on the work elevation range that is used when building
a histogram;
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• The RMS (root-mean-square deviation) is the square root of the sum of the squares
of the cell elevations divided by the number of cells. It depends on thework elevation
range that is used when building a histogram;

• The std. dev. is the square root of the sum of the squares of deviations divided by
the number of cells. It depends on the work elevation range that is used when
building a histogram;

A deviation is the difference between the cell elevation and the arithmetic mean elevation in
the data used (see the first item above).

• Themode is a value of elevation most frequently repeated among the data used for
histogram building. It depends on both parameters of histogram building work elev-
ation range and step);

• Themedian divides a series of ordered elevation values in two, with an equal number
of values both above and below the median (i.e. to the left and to the right of the X-
axis). It depends on both parameters of histogram building (work elevation range
and step);

• The step is calculated automatically or set manually;

• Project units.

To recalculate the histogram with the custom Work elevations range and histogram
step – click the appropriate button. The Histogram parameters window opens.

Fig. 224. Accuracy control using triangulation points

The top of the window is used to display DEM Elevations range. The bottom part of
the window is used to specify histogram creation parameters. To create histogram set
theWork elevations range and histogram step and click OK. The Histogram window
opens.

A step is to be selected taking into account the specified work elevations range. A very large
step value will be automatically reduced by the system to the maximum allowable value relative
to the current work elevations range.
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To display a pop-up help containing the exact number of cells (Y-axis) and boundaries
of the elevation working range segment (X-axis) when pointing the marker at a sertain
column of a diagram, click .

To disable the pop-up help mode, click the button again

7.9.8. Creating statistics file by DEM

The system allows to get statistics data by DEM. Statistics data is provided as a file in
*.csv format and includes information on distribution of DEM cells in specified range
of heights, as well as information on ratio of specified cells number to the all DEM cells
number.

To create a statistics file, perform the following:

1. Create or load DEM;

2. Select Terrain › DEM › Check accuracy › Get statistics by DEM. The Get stat-
istics by DEM window opens;

Fig. 225. Window of getting statistics by DEM

3. Click button to specify a location of the statistics file;

4. Set the following parameters:

• Origin – a height in meters started from which a statistic on distribution of DEM
cells number will be collected;

• Step – a size of height ranges in meters, for which a statistic on distribution of
DEM cells number will be collected;

• Minimal edges rest – permissible deviation between the 1 and the sum of the
Percent parameter values in statistic file (see below). The Percent parameter
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is the ratio of the cell number in each of the ranges to the total number of DEM
cells.

5. Click ОK. Statistic file in *.csv format is created in the specified folder.

For example, when the following parameters are specified:

• Origin – 0.0 m.

• Step – 10.0 m.

• Minimal edges rest – 0.01.

a file of statistics by DEM looks like this:

Range,Number of points,Percent

< 0,0,0

0 - 10,0,0

10 - 20,0,0

<...>

550 - 560,0,0

560 - 570,19402,0.783919

> 570,5348,0.216081

where:

• Range – is range of heights for which a statistic was collected, in meters.

• Number of points – is a number of cells in the corresponding range.

• Percent – is a ratio of specified number of cells to the all DEM cells number.

respectively, in the example above all the DEM cells are placed in two height ranges only:

• 560 – 570 meters: 19402 cells, which are about ~ 78% of the total;

• 570 – 580 meters: 5348 cells, which are about ~ 22% of the total.

Thus, a total of Percent parameter values must be 1, where a specified Minimal
edges rest parameter is an acceptable value of deviation from this number.

7.9.9. Lists of DEM min/max values

The system provides possibility to obtain DEM statistical data organized as the lists of
minimum and maximum values of DEM.

To do this, perform the following actions:
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1. Create or download DEM;

2. Choose Terrain › DEM › Check accuracy › Show DEMmin/max elevations. The
Number of elevations for showing window opens;

Fig. 226. The “Number of elevations for showing” window

3. In the Min field, specify the number of minimum DEM values displayed (from 1 to
100);

4. In the Max field, specify the number of maximum DEM values displayed (from 1 to
100);

5. ClickОK. TheDEMmin/max elevationswindow opens. The window contains lists
of minimum and maximum DEM values;

Fig. 227. The “DEM min/max elevations” window

6. [optional] clickCreate objects layer button to create a layer with points which mark
the locations of DEM cells with minimum and maximum values from the obtained
lists;

Point names are as follows: 529.638(min) and 671.232(max), where 529.638 and
671.232 are the elevations, (min) or (max) is the membership of an elevation in
minimum or maximum elevation list, respectively.

7. To close the DEM min/max elevations window, click Close button.
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7.9.10. Subtracting the matrix values from the constant height

The system allows to subtract the matrix values from the constant height (zero by de-
fault).

For this, perform the following:

1. Create or load a DEM;

2. Choose Terrain › DEM › Check accuracy › Subtract the matrix values from the
constant height. The Subtract the matrix values from the constant height
window opens:

Fig. 228. The “Subtract the matrix values from the constant height” window

3. [optional] In the Constant height input field enter the appropriate value to subtract
the matrix values from the nonzero constant height;

4. Click OK. By default, the output DEM is saved in the same folder of active profile
resources as the input DEM. It has the same name with the _invert_level suffix,
i.e. it has a name of the following kind: <Input DEM name_invert_level.x-dem.
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Fig. 229. Input DEM (top), surface with constant elevation (denoted by a rectangular polygon), output
DEMs, created with different Constant height values (bottom)

Fig. 230. Input DEM (top), surface with constant elevation (denoted by a rectangular polygon), output
DEMs, created with different Constant height values (bottom)

7.9.11. Slopes map creation

The system provides possibility to create a slopes map, which represents the rate of
change of elevation for each DEM cell.

Slope is the rate of maximum change in Z-value from each cell of the input DEM.
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For each cell, the system calculates the maximum rate of change in value from that cell
to its neighbors.

The maximum change in elevation over the distance between the cell and its eight
neighbors identifies the steepest downhill descent from the cell.

The lower the slope value, the flatter the terrain; the higher the slope value, the steeper
the terrain.

Fig. 231. Input DEM (left) and output slope map (right). Steeper slopes are shaded red on the output
slope map. θ – slope (in degrees).

During the slope map creation the slope value of the center cell of the moving window
shown below will be calculated.

The rates of change (delta) of the surface in the horizontal (dz/dx) and vertical (dz/dy)
directions from the center cell determine the slope. The values of the center cell and
its eight neighbors determine the horizontal and vertical deltas.

The neighbors are identified as letters from a to i, with e representing the cell for which
the aspect is being calculated.

The basic algorithm used to calculate the slope is:

Slope (in degrees) = ATAN (√([dz/dx]² + [dz/dy]²)) · 57.29578, where:

• [dz/dx] = ((c + 2f + i) - (a + 2d + g) ÷ (8 · <cell_size_by_x>);

• [dz/dy] = ((g + 2h + i) - (a + 2b + c)) ÷ (8 · <cell_size_by_y>);

• 57.29578 = 180 ÷ π.
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Fig. 232. Surface scanning window (left). Slope example input (center). Slope example output (right).

If there is a DEM cell in the neighborhood with an empty value, the Z-value of the center
cell will be assigned to this cell. At the edge of the DEM at least three cells (outside the
DEM’s border) will be empty. These cells will be assigned the center cell’s Z-value. The
result is a flattening of the 3×3 plane fitted to these edge cells, which usually leads to
a reduction in the slope near the DEM’s borders.

To create a slopes map perform the following actions:

1. Load at least one DEMs;

2. Select Terrain › DEM › Calculate slope map. The Slope map calculation para-
meters window opens:

Fig. 233. Parameters slope map calculation

3. In the Input resource section click the button to select input DEM in active
profile resources.

4. Input path to save file to theOutput resource field or click the button, to select
name and path in active profile resources to save output slope map.

By default, the slope map (as a DEM) is saved in the same active profile resource folder
as the input DEM. It has the same name and the _slope suffix, i.e. has the following name:
<input DEM name>_slope.x-dem.

5. Click OK. The system creates new layer in the Manager.
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7.9.12. Building DEM elevation profile along a linear object

The system allows to build a DEM elevation profile along a linear object.

For this, perform the following:

1. Load or create DEMs;

2. Create and select one linear object that crosses DEMs in the XY-plane;

3. Choose Vectors › Geometry › Vertical DEM profile along selected line.

The window opens that contains an elevation profile of all DEMs along the selected
linear object which crosses them. DEM elevations in meters are at the Z-axis, and
polyline horizontal scan in the project units is at the L-axis. Elevation profiles of each
DEM are marked with different colors. In the lowest part of the elevation profile window
there is a table with the list of DEMs, containing the following columns:

• DEM – contains information about layer name and layer type;

• A separate Color corresponding to the each DEM;

The number of colors in the palette is 12. Building elevation profiles for more than 12 DEMs
at once will result in doubling colors in the Elevation profile window.

To assign the DEM profile line a customized color, double click the object’s color in the line
Color column and select the color from the standard Windows palette.

• Z – current DEM heights;

• dZ – the current height differences between the base DEM from the list and other
DEMs;

• Base – To set a selected DEM as base, click the necessary line in the table by the
right mouse button and select the appropriate item in the dropdown menu.

When moving the cursor along the horizontal polyline scan in the Elevation profile window,
the current L value is displayed in the vicinity of the cursor, and current Z and dZ values in the
table at the bottom of the Elevation profile window.
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Fig. 234. The window of DEM elevation profile along a linear object

Table 9. The elevation profile window functionalities

FunctionButtons
zoom in along the Z-axis
zoom out along the Z-axis
gets to 1:1 scale
allows to save the window content as an image with
*.tif, *.bmp, *.png or *.jpg extensions in the
Windows file system
allows to enable amode in which cursor movements
along the horizontal scan of the polyline in the elev-
ation profile window are synchronized with marker
movements along the polyline in the 2D window in
the fixed marker mode (which turns on automatic-
ally)

The system also allows to zoom in/out the elevation profile window content rotating the mouse
wheel.
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See the description of the fixed marker mode in the “General information” User Manual.

The system also allows to set the profile’s visibility:

• – profile is visible in window;

• – profile is invisible.

7.10. DEM saving

The system allows to save a DEM to file with *.x-dem extension. File name and target
folder to place DEM in active profile resources should be specified prior to the DEM
creation.

To save opened DEM to a new file the system provides the Terrain › DEM › Save
copy... menu item.

To save DEM area select a part of the DEM (see the chapter ’Objects selection modes’
in the ’General information’ User Manual) and choose Terrain › DEM › Save selection.

To save a DEM as a raster file with geodetic reference perform the following actions:

1. Load DEM.

2. Select Terrain › DEM › Save as georeferenced raster.... The Settings window
opens.

Fig. 235. Parameters of saving DEM to raster file

3. In the Output file section click the button and specify name and target folder
of output DEM out active profile resources.
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4. Select Output file type – TIFF or Windows BMP.

5. Select Georeferenced file type:

• No – if there is no georeferenced files;

• PHOTOMOD GEO;

• ArcWorld TFW;

• MapInfo TAB.

6. [optional] To create additional interior system file in MS TIFF format, that allows to
use output raster file in the system without any conversion, set the Create MS TIFF
checkbox on.

7. [optional] To save as an image the level of the pyramid that is different from the
original, specify the Layer number.

8. Select the Colorization of output file – Color or Grayscale.

9. [optional] To increase the detail of the display when save the DEM as a raster file,
set the Hypsometry checkbox on.

10. Click OK. After that the system creates file with raster representation of the DEM,
and georeferenced file as well.

7.11. DEM recovering

The system provides possibility to recover DEM’s consistency, which may be disrupted
by applying of DEM editing or filtering operations.

To recover a DEM perform the following actions:

1. Load a DEM in the project.

2. Select Terrain › DEM › Recover. The Rebuild DEM pyramid window opens.

297

DTM GenerationPHOTOMOD 7.5



Fig. 236. DEM recovering

3. Select the following parameters of DEM recovering:

• Rebuild fragment pyramids – allows to rebuild a DEM by fragments (tiles) if
the DEM consist of them;

• Rebuild common pyramid (is set on by default) – allows to rebuild common
pyramid for DEM;

• Recalculate elevation bounds – allows to change DEM colour representation
after changing its boundaries elevation.

4. Click OK. After that the system rebuilds DEM and shows a message about success-
ful or unsuccessful DEM update.

7.12. DEM loading

The system allows to load saved DEM both from active profile resources and from file
that is out of active profile resources.

In order to load a DEM from active profile resources, do the following:

1. Select Terrain › DEM| Load (Ctrl+O, D) or click the buttons of the main toolbar.
The Open window opens.
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Fig. 237. DEM loading

2. Select one or multiple DEM files in active profile resources with x-dem extension.

When multiple files are selected, each DEM is loaded to separate layer.

3. Click Open. If one or multiple DEM containing layers are already loaded to active
layer, then during loading of a new layer the window of loading type is opened.

Fig. 238. DEM loading

The system provides the following possibilities of new layer loading to existing DEM
layer:

• Replace layer – data of active layer is replaced by data from loading layer;

• Create new layer – data is loaded to a new layer.
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Corresponding DEM layers are displayed in Manager.

The status line of 2D window displays cell height of active DEM as Z value.

To load DEM from external data without its conversion to internal format the Terrain ›
DEM › Open from file... menu item is used.

DEM loading and opening in format with extension different from x-dem may take a lot of time.

The system also allows to transfer lidar data to a DEM (see the ’LIDAR Data processing’
User Manual).

7.13. DEM export

7.13.1. DEM export

The system provides possibility of DEM export to the following formats.

• ArcInfo ASCII grid – exchange format with asc or grd extension, that is used in the
program ArcInfo;

• ASCII – exchange text format with txt extension, that is supported by a large number
of programs with different specializations (see description of the format in the ’Vector-
ization’) User Manual;

• SurferASCII grid – exchange format with grd extension, that is used in the program
Surfer;

• USGS DEM – exchange format with dem extension, developed in United States
Geological Survey (USGS).

To export DEM, for example, to ArcInfo ASCII grid format choose Terrain › DEM › Ex-
port › ArcInfo ASCII grid.... The Export to ArcInfo grid window opens. Choose a
folder to place a file inWindows file system. Specify a file name in the File name input
field. Click the Save button to complete the export.

7.13.2. Export to CSV

The system provides possibility of DEM export to CSV format. CSV format is exchange
text format with csv extension, which is supported by major applications in different in-
dustries. It is used as exchange format when special geospatial data formats are not
applicable for some reason.

In order to export DEM to CSV format perform the following actions:

1. Select Terrain › DEM › Export › CSV. The Export to CSV window opens.
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2. Choose a folder to place a file to file system of Windows.

3. Click the Save button. The Export to CSV window opens.

Fig. 239. Parameters of export to CSV format

4. [optional] To fill DEM null cells set the Set value for null cells checkbox on and
input necessary value to the input field in meters.

5. [optional] To split CSV-file into separate parts, set the Split into fragments
checkbox on.

6. In the Decimal separator section select point or comma to be used to separate
coordinates.

7. In the Field separator section choose, what is used to separate fields: comma,
space, tab, semicolon or other delimiters.

If the Field separator is selected as a comma, it is not recommended to specify the
Decimal separator as a comma, since objects with incorrect coordinates will be created
after export operation.

8. [optional] In order to swap Х,Y coordinates during DEM export, set the Swap X Y
checkbox.

9. Click OK to complete the export operation.

7.13.3. Export to DTED

The system provides possibility of DEM export to Digital Terrain Elevation Data (DTED)
format. This is exchange format with dt2 extension, that is used in the following pro-
grams: ESRI ArcGIS Desktop and Pitney Bowes MapInfo.

In order to export DEM to DTED format perform the following actions:

1. Select Terrain › DEM › Export › DTED. The Export to DTED window opens.
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2. Choose a folder to place a file in Windows file system.

3. Specify a file name in the File name input field.

4. Click the Save button. The Settings window opens.

Fig. 240. Parameters of export to DTED format

To export the data type having an integer value in the Data type field the Int16
parameters is set by default (integer data type is used to represent numbers in the
range from -32 768 to 32 767).

5. [optional] To fill DEM null cells specify the Set value for null cells parameter in
meters;

6. Set the compression parameters:

• None;

• The LZW compression – allows to use the Lempel-Ziv-Welch lossless data
compression algorithm;

• The Deflate compression – allows to use the Deflate lossless data compression
algorithm.

7. Click OK to complete the export operation.

7.13.4. Export to ERDAS Imagine

The system provides possibility of DEM export to ERDAS Imagine format. This is ex-
change format with img extension, that is used in the following programs:ERDAS Imagine
and ESRI ArcGIS Desktop.

In order to export DEM to ERDAS Imagine format perform the following actions:
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1. Select Terrain › DEM › Export › ERDAS Imagine. The Export to ERDAS Imagine
window opens.

2. Choose a folder to place a file in Windows file system.

3. Specify a file name in the File name input field.

4. Click the Save button. The Settings window opens.

Fig. 241. Parameters of export to ERDAS Imagine format

5. Choose in the Data type list one of the following data types:

• UInt 8 – integer data type, that is used to represent numbers in the range from
0 to 255;

• Int 8 – integer data type, that is used to represent numbers in the range from -
128 to 127;

• UInt 16 – integer data type, that is used to represent numbers in the range from
0 to 65535;

• Int 16 – integer data type, that is used to represent numbers in the range from -
32,768 to 32,767;

• UInt 32 – integer data type, that is used to represent numbers in the range from
0 to 4,294,967,295;

• Int 32 – integer data type, that is used to represent numbers in the range from -
2,147,483,648 to 2,147,483,647;

• Float 32 – data type, that is used to represent numbers with floating point in the
range from 3.4е-038 to 3.4е+038;
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• Float 64 – data type, that is used to represent numbers with floating point in the
range from 1.7е-308 to 1.7е+308.

6. [optional] To fill DEM null cells specify the Set value for null cells parameter in
meters.

7. Set the compression parameters:

• None;

• The LZW compression – allows to use the Lempel-Ziv-Welch lossless data
compression algorithm;

• The Deflate compression – allows to use the Deflate lossless data compression
algorithm.

8. Click OK to complete the export operation.

7.13.5. Export to GeoTIFF

The system allows to export DEM to GeoTIFF format, that is exchange format with tif
extension. GeoTIFF format – is common format for storing georeferenced images.

Information about used coordinates system for DEM are displayed as a code of European
Petroleum Survey Group (EPSG) standard.

In order to export DEM to GeoTIFF format perform the following actions:

1. Select Terrain › DEM › Export › GeoTIFF. The Export to GeoTIFF window opens.

2. Choose a folder to place a file in Windows file system.

3. Specify a file name in the File name input field.

4. Click the Save button. The Export to GeoTIFF window opens.
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Fig. 242. Parameters of export to GeoTIFF format

5. Specify the following parameters:

• [optional] Set the Tiled TIFF checkbox to create tiles;

To set tiles size choose Service › Settings. The Settings window opens. In System
tab set the Tile size for writing MS-TIFF (see the “System settings” chapter of the
“General system’s parameters” User Manual).

[optional] Set theCreate internal pyramid checkbox to create pyramids for output image
in files of internal format;

• Choose in the Data type list one of the following data types:

○ UInt 8 – integer data type, that is used to represent numbers in the range from
0 to 255;

○ Int 8 – integer data type, that is used to represent numbers in the range from
-128 to 127;

○ UInt 16 – integer data type, that is used to represent numbers in the range
from 0 to 65535;

○ Int 16 – integer data type, that is used to represent numbers in the range from
-32,768 to 32,767;

○ UInt 32 – integer data type, that is used to represent numbers in the range
from 0 to 4,294,967,295;

○ Int 32 – integer data type, that is used to represent numbers in the range from
-2,147,483,648 to 2,147,483,647;
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○ Float 32 – data type, that is used to represent numbers with floating point in
the range from 3.4е-038 to 3.4е+038;

○ Float 64 – data type, that is used to represent numbers with floating point in
the range from 1.7е-308 to 1.7е+308.

• [optional] To fill DEM null cells specify the Set value for null cells parameter in
meters.

• Set the compression parameters:

○ None;

○ The LZW compression – allows to use the Lempel-Ziv-Welch lossless data
compression algorithm;

○ TheDeflate compression – allows to use the Deflate lossless data compression
algorithm.

6. Click OK to complete the export operation.

7.13.6. Export to PCIDSK

The system allows to export DEM to PCIDSK format, that is exchange format with *.pix
extension and is used in the following program: PCI Geomatics Geomatica.

In order to export DEM to PCIDSK format perform the following actions:

1. Select Terrain › DEM › Export › PCIDSK. The Export to PCIDSK window opens.

2. Choose a folder to place a file in Windows.

3. Specify a file name in the File name input field.

4. Click the Save button. The Settings window opens.

Fig. 243. Parameters of export to PCIDSK format
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5. Choose in the Data type list one of the following data types:

• UInt 8 – integer data type, that is used to represent numbers in the range from
0 to 255;

• Int 8 – integer data type, that is used to represent numbers in the range from -
128 to 127;

• UInt 16 – integer data type, that is used to represent numbers in the range from
0 to 65535;

• Int 16 – integer data type, that is used to represent numbers in the range from -
32,768 to 32,767;

• UInt 32 – integer data type, that is used to represent numbers in the range from
0 to 4,294,967,295;

• Int 32 – integer data type, that is used to represent numbers in the range from -
2,147,483,648 to 2,147,483,647;

• Float 32 – data type, that is used to represent numbers with floating point in the
range from 3.4е-038 to 3.4е+038;

• Float 64 – data type, that is used to represent numbers with floating point in the
range from 1.7е-308 to 1.7е+308.

6. [optional] To fill DEM null cells specify the Set value for null cells parameter in
meters.

7. Set the compression parameters:

• None;

• The LZW compression – allows to use the Lempel-Ziv-Welch lossless data
compression algorithm;

• The Deflate compression – allows to use the Deflate lossless data compression
algorithm.

8. Click OK to complete the export operation.

7.13.7. Export to MTW

The system provides possibility of DEM export to theMTW formats. MTW is an exchange
format with *.mtw extension that is used in the program GIS Map 2000.

In order to export DEM to MTW format perform the following actions:
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1. Select Terrain › DEM › Export › Panorama MTW... The Export to Panorama
MTW window opens.

2. Choose a folder to place a file in Windows file system.

3. Specify a file name in the File name input field.

4. Click the Save button. The Export to Panorama MTW settings window opens.

Fig. 244. Parameters of export to MTW format

5. Choose in the Data type list one of the following data types:

• UInt 8 – integer data type, that is used to represent numbers in the range from
0 to 255;

• Int 16 – integer data type, that is used to represent numbers in the range from -
32,768 to 32,767;

• Int 32 – integer data type, that is used to represent numbers in the range from -
2,147,483,648 to 2,147,483,647;

• Float 64 – data type, that is used to represent numbers with floating point in the
range from 1.7е-308 to 1.7е+308.

6. Select DEM cell Units from the drop-down list.

7. Click OK to complete the export operation.

7.13.8. Batch DEM export

The system provides possibility to simultaneously export multiple DEM files of the same
format.

To perform export of multiple DEM files do the following:

1. Select Terrain › DEM › Export › Batch export. The DEM batch export window
opens.
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Fig. 245. Dem batch export

2. Choose a folder containing DEMs in resources tree.

button allows to display all available resources in nested files.

button allows to refresh part of the window with resources.

button allows to show a list with 10 recently selected resources.

3. Select file with DEM in the list and click the button to add the file.

and allow to add to the list or remove from it all added files with vector objects, the
button allows to remove selected file from the list.

4. Repeat the 2 and 3 actions to add next files with DEMs.

5. Click the Next button.
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Fig. 246. Output folder and extension settings window

6. Click the button in the Output folder section and select a folder in Windows
file system.

7. Select format of exported DEM in the drop-down list.

8. Click OK to start operation of DEM export.

In order to perform batch DEM export using distributed processing, do the following:

1. Change settings and run the distributed processing server/client (see the ’Dis-
tributed processing’ chapter in the ’General information about system’ User
Manual).

2. Click the Distributed processing button.

7.13.9. Convert DEM to point cloud (LAS)

The system provides for DEM conversion to LAS point cloud (see the “LIDAR Data
processing” User Manual). For this, perform the following:

1. Choose Terrain › DEM › Convert DEM to LAS.... TheConvert DEM to LASwindow
opens:
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Fig. 247. The “Export DEM to LAS” window

2. Click the button to select Source DEM file path in the active profile resources;

3. Click the button to select Output point cloud file path (LAS) in the active
profile resources;

4. In order to Split points cloud on parts set an appropriate checkbox, and specify
the following parameters:

• Output point cloud folder (LAS);

• Part size by X, pix;

• Part size by Y, pix.

5. Click OK.

7.13.10. Convert DEM to point cloud (LAS) in batch mode

The system provides for batch DEMs conversion to LAS point clouds (see the “LIDAR
Data processing” User Manual). For this, perform the following:

1. Select Terrain › DEM › Batch conversion DEM to LAS... The Parameters – Step
1 of 2: Source data window opens.
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Fig. 248. Creating a list of the initial DEMs for batch conversion to LAS

2. Choose a folder containing DEMs in resources tree.

The button allows to display all available resources in nested files. The button allows
to refresh part of the window with resources.

The button allows to show a list with 10 recently selected resources.

3. Select DEM in the list and click the button to add a layer.

The and buttons allow to add to the list or remove from it all added DEM files, the
button allows to remove selected file from the list

4. Repeat the 2 and 3 steps to add next files with DEMs.

5. Click the Next button. The Parameters – Step 2 of 2: Parameters.
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Fig. 249. Parameters of batch DTM conversion

6. Specify the following parameters:

1. Setup the output LAS placement:

• In the same place as input DEM’s;

• Click the button to set the folder for the output LAS files in the active
profile resources.

2. [optional] In order to Split LAS into fragments set an appropriate checkbox,
and specify the following parameters:

• Part size by X, pix;

• Part size by Y, pix.

7. Click OK.

To use the distributed processing mode, perform the following actions:

1. Change settings and run the distributed processing server/client (see the “Dis-
tributed processing” chapter in the “General information about system” User
Manual).

2. Click the Distributed processing button.
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7.14. DEM import

The system allows to import DEM from files with the following extensions: *.grd, *.asc,
*.tif, *.dem, *.mtw, *.dt1, *.dt2, *.img, *.pix, *.hgt and *.xml.

For example – Japanese Fundamental Geospatial Data (FGD), which uses the Geography
Markup Language Encoding Standard. The Geography Markup Language (GML) is an XML
grammar for expressing geographical features.

Table 10. Brief description of the “Import” menu

FunctionMenu items
contains items used to import DEM from files with
*.grd, *.asc, *.tif, *.dem, *.mtw, *.dt1, *.dt2,
*.img, *.pix, *.hgt extensions (see below)

Import...

is used to simultaneous import of multiple DEMBatch import
is used to simultaneous import of multiple DEM from
a specified folder

Batch import from folder

In order to perform import of DEM from a file of supported format, do the following:

1. Select Terrain › DEM › Import. The DEM import window opens.

2. In the file system of Windows select a DEM file.

3. Click the Open button. The DEM import window opens.

Fig. 250. Parameters of DEM import

4. [optional] To convert DEM cells with specified values to null cells, set the Convert
the following value to null cells checkbox and define necessary value.

5. Click OK. The Destination file window opens.
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Fig. 251. Imported DEM saving

6. Select target file placement in active profile resources and click Save.

7.14.1. Batch DEM import

The system allows to import DEM in batch mode from files with the following extensions:
*.grd, *.asc, *.tif, *.dem, *.mtw, *.dt1, *.dt2, *.img, *.pix, *.hgt. During batch import
the system loads multiple files from specified folder at once.

In order to import necessary number of DEMs, from specified folder, perform the following
actions:

1. Select Terrain › DEM › Batch import. The DEM import window opens.

2. In the file system of Windows select multiple files with DEM.

3. Click the Open button. The DEM import window opens.

Fig. 252. Parameters of DEM import

4. [optional] To convert DEM cells with specified values to null cells, set the Convert
the following value to null cells checkbox and define necessary value.
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5. Click OK. The Select folder window opens.

Fig. 253. Imported DEM saving

6. Select a folder or create a new one using the Create... button.

7. Click OK to complete the import operation.

7.14.2. Batch import from folder

The system allows to import DEMs from the folder specified in a batch mode. While
using a batch import from the folder all the DEM files with *.grd, *.asc, *.tif, *.dem,
*.mtw, *.dt1, *.dt2, *.img, *.pix, *.hgt format extensions are loaded.

To import all the DEMs placed in a specified folder, perform the following actions:

1. Choose Terrain › DEM › Batch import from folder.... The Files searching by
filter window opens;

Fig. 254. Files searching by filter window
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2. Click button to setup target folder for import in Windows file system;

3. [optional] turn on Search in subfolders checkbox to import DEMs from the sub-
folders;

4. [optional] if it’s needed to import just some of the DEMs placed in the folder specified,
in File names filter setup parameters of sorting DEMs by names and/or by exten-
sions;

In default, all the DEMs placed in the folder specified will be imported.

5. Click OK. The Parameters window opens;

Fig. 255. Parameters of importing DEMs

6. [optional] To convert DEM cells with specified value to NULL cells, turn on Convert
the following value to NULL cells checkbox and setup a value.

7. Click OK. The Select folder window opens.
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Fig. 256. Saving DEM imported

8. Select the folder or create a new one with New... button.

9. Click OK to finish import.

8. Volumes Calculation
The system provides opportunity to calculate a volume (i.e. embankment or excavation)
located between DEM (or TIN) surface and arbitrary Z-plane or in a more complex case,
the volume which is the overlap between the two (roughly, “top” and “bottom”) surfaces,
which can intersect or not.

When calculating two volumes constrained by the same surface represented either by TIN or
DEM (e.g. build using this TIN) the system achieves the accuracy wherein the difference between
the calculated volumes (by DEM and by TIN) is no worse than 1%.

The principle of calculation method comes to calculation of DEM cells volumes (cells
should be with known cell corners coordinates, otherwise, the cell is missed and its
volume is not considered). And the surface corresponding to the “ceiling” of the cell is
built by linear interpolation from the corner points.

The system also provides volume calculation if DEMs have different ground sample distance.

To calculate a volume perform the following actions:
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1. Choose Terrain › DEM › Compute volumes. The Volumes calculation window
opens;

Fig. 257. The “Volumes calculation” window, “Source data” tab

2. In the Source data tab click an appropriate button to select the TIN or DEM
surface, bounding volume to be calculated;

Click the button to open the Layer selection window and select the source DEM (or
TIN) from the list of the appropriate layers uploaded to the project.

3. [optional] In the Source data tab specify the Precision of DEM in meters – a priori
error of elevations.

For DEM-indicator cells with a lower precision a volume of changes equals null.

4. In the Reference data tab specify constant height of plane, bounding calculated
volume “from below” or select another TIN or DEM replacing the first one (in case
of calculating a volume obtained by surfaces overlap);
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Fig. 258. The “Volumes calculation” window, “Reference data” tab

5. [optional] Specify the Precision of DEM in meters in the Reference data tab;

6. [optional] To create referential DEM, indicating embankments and excavations, set
the DEM – indicator +/- checkbox in the DEM – indicator +/- tab and specify path
to save a file with output referential DEM.
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Fig. 259. The “Volumes calculation” window, “DEM – indicator” tab

Specify the Cell size for indicator DEM:

• Step from source DEM/TIN;

• Step from reference DEM/TIN;

• specify the cell size manually.

“Step” from source/reference DEM – DEM cell size.

“Step” from source/reference TIN – average distance between vertices of triangulation
irregular network.

7. [optional] Set the Boundary checkbox and click the button to specify a
boundary, additionally bounding calculated volume by XY.

Boundary of calculated volumemay be additionally bounded only by vector layer (polygon)
in PHOTOMOD format. Otherwise, it will be necessary to convert used data to PHOTOMOD
format.

Click the button to open the Layer selection window and select the vector layer from
the list of the appropriate layers uploaded to the project.
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8. [optional] Set the Show report checkbox and click the button to specify path
to save a report file with volume calculation data.

9. Click ОК.

The Report window opens when the calculation is complete.

Fig. 260. Report with volume calculation results (reference data – Z-plane with constant height)

Fig. 261. Report with volume calculation results (reference data – DEM)

Report contains the following main elements and sections:
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• the toolbar with buttons used to perform the following operations:

○ – allows to return to previous view of the report;

○ – allows to refresh results in the report;

○ – allows to perform a search for information in the report;

○ – allows to save report data to files with *.htm, *.html extensions out of
active profile resources;

○ – allows to save report data to files with *.htm, *.html extensions in active
profile resources;

○ – allows to print a report.

• the section of a report containing brief project properties:

○ a project name;

○ report generating date;

○ project coordinate system.

• the section of a report containing calculation results:

○ Embankment volume;

○ Excavation volume;

○ Relative volume of changes – math difference between embankment volume
and excavation volume;

○ Absolute volume of changes – the sum of embankment and excavation
volumes;

○ The area where calculations were made;

○ Information about the surface, bounding volume to be calculated;

○ Information about the plane with constant height (or DEM), bounding calculated
volume “from below”;

○ Error a priori estimate.
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