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1. Purpose of the document
This document contains detailed information about features and functions provided by
the 3D-Mod module. The document provides general information about 3D modelling,
description of import and export operations of vector objects, about generating and
editing of 3D-objects, using light sources and camera, assigning texture to objects, and
about work with 3D-scene.

2. 3D-Mod module
The 3D-Mod module is intended for 3D objects generation and for applying textures to
3D-objects and then to export them to different data formats and further using in third-
party software.

Generation of terrain 3D model is called 3D modelling.

3D model of terrain is a surface, created considering terrain relief. The surface is over-
lapped by image of vector or raster map along with 3D-objects, that correspond to objects
of 2D map.

In order to start 3D-Mod module perform one of the following actions:

• choose the Start › Programs › PHOTOMOD 7 x64 › PHOTOMOD 3D-Mod

• choose Terrain › 3D-Mod › Start or click the button of the main system toolbar;

• choose 3D-Mod in the context menu of System Monitor module (the icon inWin-
dows system tray).

The module allows to import vector objects from file or open vector objects layer directly
from the system.

To generate 3D terrain model, perform the following actions:

1. Load vector objects using one of the following ways:

• open layer with vector objects in the main system’s window and choose Vectors ›
Open vectors in 3D-Mod. The 3D-Mod module starts and the Parameters of
import and building window opens.

• export vector objects to ASCII-A format file (see the chapter “Vector objects export”
of the “Vectorization” User Manual). Start the 3D-Mod module.

2. Perform 3D-objects import and generation from ASCII-A format file.

3. Edit 3D-objects.
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4. Assign textures to 3D-objects.

5. Create lighting of the scene using light sources.

The following operations are available for generated terrain 3D model:

• export to *.dxf, *.txt, *.tx3, *.dae, *.3ds, *.shp formats;

• scene animation;

• create video file of the scene in AVI format.

3. Interface and its elements

3.1. Working windows interface

User interface of view area of the 3D-Mod module contains the following elements:

• the title bar to display the name of the uploaded file;

• menu bar (A);

• toolbars (B, С);

• object properties toolbar (D);

• projective cube (E);

• local coordinate system (K);

• 3D-objects (F);

• scene replay toolbar (G);

• global coordinate system (H);

• orthomosaic sheet (L);

• bounding box (M);

• name of displayed projection (N).
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Fig. 1. 3D-Mod module

3.2. Brief description of module menu

The main module menu contains menu items used to import / export objects, to work
with objects, to manage view area and set of displayed objects, and to setup different
parameters.

Table 1. Main module menu

FunctionMenu
allows to open, save 3D-scene, import objects to
3D-scene or to export objects

File

allows to select scene objects using different ways,
assign textures to 3D-objects

Edit

allows to manage 3D-scene displayingView
allows to manage 3D-scene content displayingObjects
allows to manage 3D-scene layersLayers
allows to open User ManualHelp
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3.3. Toolbar
Table 2. Brief description of main toolbar

FunctionButtons
allows to open 3D-scene from *.tx3 file
allows to open 3D-scene from active profile re-
sources (*.json)
allows to import objects to 3D-scene from *.txt,
*.tx3, *.3ds, *.obj, *.gltf, *.b3dm or *.json files
allows to import objects to 3D-scene from active
profile resources (*.json, *.b3dm)
allows to save 3D-scene changes
allows to cancel the last operation
allows to repeat the last cancelled operation
allows to move view area of 3D-scene in any direc-
tion
allows to move view area of 3D-scene perpendicular
to the screen plane
allows to rotate 3D-scene view area
allows to move view area of 3D-scene, with imitation
of the scene observation from camera.
allows to zoom in/zoom out view area
allows to zoom in of 3D-scene view area selected
by rectangle
allows to implement a comprehensive display of all
objects of 3D-scene
allows to display an area only with selected objects
of 3D-scene
allows to turn the perspective mode on, i.e. to dis-
play 3D space in 2D plane
allows to show coordinate grid
allows to show scale bar
allows to display 3D-scene in four types of projec-
tions
allows to turn on anaglyph stereo mode
allows to turn on page-flipping stereo mode
allows to turn on measurements mode
allows to start 3D-scene playback
allows to temporarily stop 3D-scene playback
allows to pause 3D-scene playback
allows to turn objects attaching mode on to move
objects simultaneously
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FunctionButtons
allows to select objects from the list to attach objects
and simultaneously move them during scene play-
back
allows to turn objects attachingmode off for selected
objects
allows to select objects from the list in view area
using their names
allows to highlight scene elements, that were not
used for objects generation
allows to highlight both the whole object, and all
elements used for objects generation
allows to turn on objects selection mode in view
area
allows to turn on moving of selected objects in view
area
allows to turn on rotating of selected objects
allows to turn on zoom of selected objects
allows to display in view area previously hidden
objects using their names in the list
allows to display only selected objects in view area;
allows to display all layer objects in view area;
allows to hide only selected objects in view area;
allows to hide in view area objects using their names
in the list
allows to turn on/of selected point objects display
allows to turn on/of display of outlines of objects
external faces
allows to turn on/of buildings display
allows to turn on/of standard library objects display
allows to turn on/of display of auxiliary objects (for
example, dummy object, light source)
allows to record and save 3D-scene in AVI format
allows to pause recording of 3D-scene
allows to stop recording of 3D-scene
allows to display in view area coordinate system
axis for each selected object
allows to display in view area the same coordinate
system axis for all selected objects
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4. Objects import and export

4.1. The “File” menu
Table 3. Brief description of the “File” menu

FunctionMenu items
allows to open 3D-scene from *.tx3 fileOpen
allows to open 3D-scene from active profile re-
sources (*.json)

Open from resources

allows to open one of recent 3D-scenesPrevious
allows to save opened 3D-scene to *.tx3 fileSave
allows to save opened 3D-scene to file with another
name and *.tx3 extension

Save as

allows to save 3D-scene image to BMP formatSave scene image
allows to import objects to 3D-scene from *.txt,
*.tx3, *.3ds, *.dae, *.obj, *.gltf, *.b3dm or *.json
files

Import...

allows to import objects to 3D-scene from active
profile resources (*.json, *.b3dm)

Import from resources

allows to export objects from 3D-scene to *.dxf,
*.txt, *.tx3, *.dae, *.3ds, *.shp, *.obj, *.gltf,
*.b3dm or *.json file

Export...

allows to export only selected objects from 3D-scene
to *.dxf, *.txt, *.tx3, *.dae, *.3ds, *.shp, *.obj,
*.gltf, *.b3dm or *.json file

Export selected...

allows for batch export from 3D-Mod-supported files
or resources (*.json, *.obj) into a single *.obj-file

3D-models batch conversion

allows to open Settings windowSettings
allows to close 3D-sceneClose
allows to close the module3D-ModExit

4.2. Import

4.2.1. Import from PHOTOMOD

In order to import vector objects from PHOTOMOD software perform the following ac-
tions:

1. Open layer with vector objects in PHOTOMOD system and select Vectors › Open
vectors in 3D-Mod. The 3D-Mod module and the Import window open.

9

Three-dimensional modelingPHOTOMOD 7.5



Fig. 2. Parameters of coordinate system import

2. [optional] In order to swap coordinate system, set the Swap X and Y checkbox on.

If the Swap X and Y checkbox is off, the initial data will be imported in the right coordinate
system. Otherwise, in the left one.

3. [optional] To define standard parameters set the Recalc coord system checkbox
on.

4. Choose the Building tab. To build 3D-objects by default the Make 3D building
checkbox is set on. Otherwise the system performs import of 2D-objects.

For correct 3D-objects generating set the following checkboxes on: Use objects without
assignment, Build objects from closed lines and Include points to 3D modeling.
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Fig. 3. Parameters of 2D-objects import

3D building parameters depend not only on the settings specified in the Building tab, but
also on the mode of construction of vector objects themselves in the PHOTOMOD (in
particular, on the topological connectivity of elements of complex objects - see the “Roofs
creation” section of the “Vectorization” User Manual).

5. To merge vertices, the distance between which is less than specified, the Join
vertices tolerance checkbox is set on by default.

6. [optional] When importing vertices with the same X,Y-coordinates, set the Over-
lapped vertices checkbox on and select option of coordinates use from the drop-
down list.

7. In order to use objects without attributes during 3D-building theUse objects without
assignment andBuild objects from closed lines checkboxes are set on by default.

8. [optional] In order to use points without attributes during 3D-building set the Include
points to 3D modelling checkbox on.
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9. To process vector objects separately in each layer the Process by layers checkbox
is on by default.

To accelerate 3D-building operation, and for correct work with layers it is highly recommen-
ded to set the Process by layers checkbox on.

10. To include to 3D-modelling roofs, walls, and footings of buildings, the Roof,Walls
and Footing checkboxes are on by default in the Result section.

11. [optional] To convert object into a grid set the Mesh checkbox on.

12. [optional] To clarify geometry of point objects, open the File DXF tab. Click the
button and select *.tx3 file with description of point objects.

Fig. 4. Parameters of DXF-file import

Select the attributes associated with the classifier entry that allow one to correlate
point objects and 3D objects in the reference file:

• [optional] Link by code – allows to match point objects with description of point
objects provided in DXF-file, using object code;
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• [optional] Link by codename – allows to match point objects with description of
point objects provided in DXF-file, using object codename.

13. Open the Level tab and perform one of the following actions:

• in the Constant height field specify an elevation level – the lower boundary of
3D-objects construction;

• click the button and select a file with DEM, which defines the lower boundary
of 3D-objects construction.

Fig. 5. Parameters of layer level elevation

14. Click OK to complete the import operation.

After import points are displayed in the module with the color similar to layer color in the
system.
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4.2.2. Import from ASCII-A and 3D-building

The module provides possibility to import vector objects from ASCII-A format. ASCII-А
format contains information about coordinates of vector objects vertices, and about
object type, layer number, attributes name and value.

Files of this format have the *.txt extension. In contrast with ASCII format, in ASCII-А
format the object description is supplemented by starting lines, containing description
of object type and attributes.

An example of ASCII-A file format:

L 101 1 13 4

OBJECT_NAME=Highway

OBJECT_COLOR=3

OBJECT_SYMBOL=R

OBJECT_SIZE=5.5

545566.505,473671.817,77.850

545715.103,473656.072,78.310

545782.001,473567.393,78.156

545860.428,473463.139,77.974

545847.506,473339.305,77.380

545795.032,473249.288,76.795

545517.126,473365.500,76.318

545269.605,473463.426,75.869

*

The first line of an object description has the following structure:

Type Code Layer N1 N2, where:

• Type - the symbol describing an object type:

○ L – polyline;
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○ P – point;

○ C – polygon.

• Code - the code of an object;

• Layer - the layer number;

• N1 - the total number of lines of an object description;

• N2 - the number of lines describing object attributes.

Then there are lines with descriptions of attributes like follows:

Name=Value

Then follow the lines with the object points coordinates. The sequence of records is
delimited by the * symbol.

In order to import vector objects from ASCII-A format perform the following actions:

1. Select File › Import. The Parameters of import and building window opens on
the Coord system tab.
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Fig. 6. Parameters of coordinate system import

2. [optional] In order to swap coordinate system, set the Swap X and Y checkbox on.

If the Swap X and Y checkbox is off, the initial data will be imported in the right coordinate
system. Otherwise, in the left one.

3. [optional] To define standard parameters set the Recalc coord system checkbox
on.

4. Choose the Building tab. To build 3D-objects by default the Make 3D building
checkbox is set on. Otherwise the system performs import of 2D-objects.

For correct 3D-objects generating set the following checkboxes on: Use objects without
assignment, Build objects from closed lines and Include points to 3D modeling.
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Fig. 7. Parameters of 2D-objects import

5. To merge vertices, the distance between which is less than specified, the Join
vertices tolerance checkbox is set on by default.

6. [optional] When importing vertices with the same X,Y-coordinates, set the Over-
lapped vertices checkbox on and select option of coordinates use from the drop-
down list.

7. In order to use objects without attributes during 3D-building theUse objects without
assignment andBuild objects from closed lines checkboxes are set on by default.

8. [optional] In order to use points without attributes during 3D-building set the Include
points to 3D modelling checkbox on.

9. To process vector objects separately in each layer the Process by layers checkbox
is on by default.

To accelerate 3D-building operation, and for correct work with layers it is highly recommen-
ded to set the Process by layers checkbox on.
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10. To include to 3D-modelling roofs, walls, and footings of buildings, the Roof,Walls
and Footing checkboxes are on by default in the Result section.

11. [optional] To convert object into a grid set the Mesh checkbox on.

12. [optional] To clarify geometry of point objects, open the File DXF tab. Click the
button and select *.tx3 file with description of point objects.

Fig. 8. Parameters of DXF-file import

Select the attributes associated with the classifier entry that allow one to correlate
point objects and 3D objects in the reference file:

• [optional] Link by code – allows to match point objects with description of point
objects provided in DXF-file, using object code;

• [optional] Link by codename – allows to match point objects with description of
point objects provided in DXF-file, using object codename.

13. Open the Level tab and perform one of the following actions:
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• in the Constant height field specify an elevation level – the lower boundary of
3D-objects construction;

• click the button and select a file with DEM, which defines the lower boundary
of 3D-objects construction.

Fig. 9. Parameters of layer level elevation

14. Click OK to complete the import operation.

After import points are displayed in the module with the color similar to layer color in the
system.

4.2.3. Import from ASCII3D, COLLADA, OBJ, GLTF, B3DM and JSON

The module provides possibility to import 3D-scene from ASCII3D, COLLADA, OBJ,
GLTF, B3DM and JSON formats:
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• To import 3D-scene from ASCII3D format select File › Import. The Import window
opens. In the File type list select ASCII3D (*.tx3), then select desired file by mouse
click and click the Open button;

• To import 3D-scene from COLLADA format select File › Import. The Import window
opens. In the File type list selectCOLLADA (*.dae), then select desired file by mouse
click and click the Open button;

• To import 3D-scene fromOBJ format select File › Import. The Importwindow opens.
In the File type list select OBJ (*.obj), then select desired file by mouse click and
click the Open button;

• To import 3D-scene from GLTF format select File › Import. The Import window
opens. In the File type list select GLTF (*.gltf), then select desired file by mouse
click and click the Open button;

• To import 3D-scene from B3DM format select File › Import. The Import window
opens. In the File type list select B3DM (*.b3dm), then select desired file by mouse
click and click the Open button.

• To import 3D-scene from JSON format select File › Import. The Import window
opens. In the File type list select Multilevel model (*.json), then select desired file
by mouse click and click the Open button.

4.2.4. Import from 3DS

The module provides possibility to import 3D-scene from 3DS format. 3DS format file
contains data about grid, object attributes, 3D-objects animation and so on. Files of this
format have the *.3ds extension.

In order to import 3D-scene from 3DS format perform the following actions:

1. Select File › Import. The Import window opens. In the File type list select 3DS
(*.3ds), then select desired file by mouse click and click the Open button. The
Import 3DS window opens.

Fig. 10. Parameters of import from 3DS format
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2. [optional] In order to import object faces with с smoothing groups, set the
Smoothing groups checkbox on (more details about smoothing groups see in
Section 6.5.6).

3. To import relations established between scene’s objects the Hierarchy checkbox
is set on by default.

4. To import coordinates of 3D-scene center the Origin checkbox is set on by default.

5. Click the Import button to complete the import.

4.2.5. Import from 3D-TIN

The system allows to create textured 3D-TIN surfaces (see the “Creation of textured
TIN 3D surface” chapter of the “DTM Generation” User Manual). The output format of
textured 3D-TIN surfaces is *.json. 3D-TIN fragments (tiles, with *.b3dm extension)
are saved in the separate directory (with the same name) in the folder chosen for output
3D-TIN saving, in the active profile’s resources.

The 3D-Modmodule provides possibility to import 3D-TIN from active profile resources.

To import 3D-TIN from active profile resources select File › Import from resources or
click the of the main toolbar. In the File type list select 3D-Mod files, then select
desired file with *.json extension by mouse click and click the Open button.

To import separate 3D-TIN fragment (tile) from active profile resources select File ›
Import from resources or click the of the main toolbar. In the File type list select
3D-Mod files, then select desired file with *.b3dm extension by mouse click (in the
separate directory of the folder chosen for output 3D-TIN saving) and click the Open
button.

4.3. Export 3D-Mod data

The system provides possibility of data export to the following formats:

• DXF – exchange format with *.dxf extension, that is used in AutoCAD software;

• ASCII-A – exchange text format with *.txt extension, which is supported by major
applications in different industries;

Export to this format is provided only for polylines/polygons and points (see the “Vectorization”
User Manual).

• ASCII3D – exchange format with *.tx3 extension;
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• COLLADA – exchange format with *.dae extension, which is supported by major
applications in different industries;

• 3DS – format with *.3ds extension, that is used in Autodesk 3ds Max (3D Studio
MAX);

• Shape – exchange format with *.shp extension, that is used in ArcInfo software;

• Cesium formats (*.obj, *.gltf, *.b3dm or *.json).

For example, to export data to *.dxf (*.tx3, *.shp, *.obj, *.gltf, *.b3dm, *.json)
format select File › Export. The Export window opens. Choose a folder to place a file
inWindows button. Specify a file name in the File name input field. Set a file extension
in the File type drop-down list. Click the Save button to complete the export.

The system provides possibility to change objects coordinate system during export to Cesium
formats (*.obj, *.gltf, *.b3dm and *.json).

When exporting an object representing a surface to *.json format, the system provides for
advanced customization of visual display of exported data in various software programs designed
for viewing and editing 3D objects.

To export just selected objects, select File › Export selected. Specify desired format
in the File type list. Specify desired parameters and click the Save button to complete
the export.

4.3.1. Export data to COLLADA

The system provides possibility of data export to COLLADA format. COLLADA format
is an exchange format with *.dae extension, that is used to exchange data between
3D software packages

In order to export data to COLLADA format perform the following actions:

1. Select File › Export. The Export window opens.

2. Choose a folder to place a file inWindows button.

3. Click the Save button. The Export parameters window opens.
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Fig. 11. Parameters of export to COLLADA format

4. In the Compatibility section select one of the following compatible programs:

• 3DS Max – is used to develop scenes, containing three-dimensional geometric
models, available for animation;

• SketchUp – is used to model relatively simple three-dimensional objects –
buildings, furniture, interior.
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5. In the Textures section the Copy and To subfolder checkboxes are set on by
default to save object textures to a separate folder.

• [optional] When 3DS Max option is selected, it is recommended to set the Save
full path checkbox on for correct work in that program.

6. Select a coordinate system of the objects to be exported;

• [optional] Local CS;

○ [optional] Configure additional exported data viewing options.

PHOTOMOD 3D-Mod allows users to work with objects created including in
PHOTOMOD system. PHOTOMOD uses global coordinate systems for data
processing (see the “Coordinate systems” chapter in the “Creating project”
User Manual). Hence, the values of coordinates of objects that were exported
from PHOTOMOD and imported for viewing in PHOTOMOD 3D-Mod, can be
quite large.

When further exporting data from PHOTOMOD 3D-Mod, for viewing in third-
party software, large values of object coordinates may be a certain inconveni-
ence (depending on the features of a particular program). For example, when
loading a 3D-scene in the third-party software for the first time, such objects
may be outside the area displayed on the screen, due to their significant dis-
tance from the origin of the local coordinate system.

COLLADA (*.dae) interchange file format allows for recording information about
the offset of the center of the 3D scene viewport, along the X, Y, and Z axes.
Such information can be read by some programs when importing data from
the COLLADA format. To display the relevant data in the X, Y, and Z input
fields of the Export parameters window, directly before exporting, perform
the following:

1. Select File › Settings. The Settings window opens (see details in Sec-
tion 11);

2. To place a 3D-scene’s center on the point that is central relative to all 3D-
scene objects, click the All button in the Origin section, Scene tab, Set-
tings window. The 3D-scene’s center offset parameters along the three
axes are displayed in the fields in the right part of the Settings window;

3. Click OK to close the Settings window and go to data export.

When opening the Export parameters window, the 3D-scene viewport center
offset parameters set in the Settings window will be displayed in the X, Y, and
Z fields. To reset these parameters, click the appropriate button. To restore
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data loaded at the moment of opening the Export parameters window, click
the appropriate button.

• [optional] Global CS (see the “Coordinate Systems” chapter of the “Creating
project” User Manual);

○ [optional] To recalculate all the objects to be exported from one coordinate
system to another perform the following actions:

1. Set the Convert CS checkbox;

2. [optional] Click the Select... button to specify initial model cs, if needed.

Coordinate system is specified using one of the following ways:

■ From DB – from international or Russian coordinate system database
(see “Coordinate systems databases” in the Project creation” User
Manual);

■ From file – allows to select coordinate system from *.x-ref-system
files, located out of active profile resources;

■ From resource – from files with *.x-ref-system extension, located in
active profile resources. It is used for example, to choose coordinate
system from another active profile project.

■ FromGeoCalculator – from the list ofGeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program”
User manual).

The GeoCalculator program allows to edit coordinate systems, to create new
ones, to perform import and export of coordinate systems (see the “The
GeoCalculator program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.

When choosing coordinate system from database theCoordinate system
database opens, which contains the list of coordinate systems. To perform
fast search for coordinate system, input the whole coordinate system name
or its part to the Find input filed.

25

Three-dimensional modelingPHOTOMOD 7.5

project.pdf
project.pdf
project.pdf
geocalc.pdf
geocalc.pdf
geocalc.pdf


Fig. 12. Coordinate systems database window

[optional] To choose geoid click the button. Select proper type of geoid
usage:

■ No geoid;

■ EGM 96.

The system also allows to use the EGM2008 geoid. See installation instructions
in the “EGM2008 Geoid installation” User Manual. After installation the geoid
is displayed in the list.

3. Define the target coordinate system in which it is necessary to convert the
objects. To do this perform the actions described above once more or click
the Export to Cesium button to select the appropriate coordinate system.

For CESIUM1.38 version, the coordinate system does not matches the geocentric
reference one. It is rotated by -90 degrees around the X axis. CESIUM 1.70 co-
ordinate system matches the classic geocentric reference system with WGS84
ellipsoid and orientation.

7. Click the Export button to complete the export.

4.3.2. Export data to 3DS

The system provides possibility of data export to 3DS format. 3DS format file contains
data about grid, object attributes, 3D-objects animation and so on. Files of this format
have the *.3ds extension.

In order to export data to 3DS format perform the following actions:
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1. Select File › Export. The Export window opens.

2. Choose a folder to place a file inWindows button.

3. Click the Save button. The Export 3DS window opens.

Fig. 13. Parameters of export to 3DS format

4. To save 3D-scene center coordinates, links between objects, and object textures
to 3DS format file, the Pivot, Origin, Hierarchy, Materials checkboxes are set on
by default.

5. Click the Export button to complete the export.

4.3.3. Exporting surfaces to JSON

Data export to *.json format is carried out in a standard way, in the same way as to
*.dxf, *.tx3, *.shp, *.obj, *.gltf and *.b3dm formats. When exporting to Cesium
formats (*.obj, *.gltf, *.b3dm and *.json) it is also possible to change objects’ coordin-
ate system.

However, when exporting an object representing a surface to *.json, format, the system
provides for advanced customization of visual display of exported data in various software
programs designed for viewing and editing 3D objects.

To export the object representing a surface to *.json, perform the following:

1. Do one of the two following:

• [optional] If one object representing a surface is open in the 3D scene, select
File › Export;

• [optional] If several objects are open in the 3D scene, select the object being a
surface and choose File › Export selected.
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2. The Export window opens. Select Multilevel model (*.json) file type, enter the
export file name and select the folder to place the file in theWindows file system;

3. Click Save. The Export parameters window opens:

Fig. 14. The “Export parameters” window

4. An object saved in *.json format is a model divided in tiles, and, in addition, having
several levels of detail. Data having such a structure often have certain display
features that are noticeable when viewed in specialized software designed to work
with 3D models.

For example, it is conceivable that during scaling, tiles with different levels of detail
can be displayed within one 3D scene. In such cases, the boundaries between
such tiles can be quite noticeable and affect the overall quality of the visual display
of the model.
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Note, that data display quality depends on many factors, including on the features
of the exported model (and its export parameters) and on the software used for its
displaying (as well as current software settings).

To optimize the quality of the display of a multilevel surface model divided in tiles,
the so called border generation is often used, i.e the construction of areas on the
boundaries of tiles, ensuring their correct display when visualizing the entire model.

The system provide for the following generating borders options:

• [optional]Without borders;

• [optional] tiles having a border, i.e. actually extending a little beyond their
boundaries, thereby providing a slight overlap with neighboring tiles (similar to
the overlap of images in the strip);

• [optional] tiles having a border of the skirt type – the border is built along the
boundaries of the tile, in the shape of a vertical “wall” directed downwards.

Fig. 15. A borderless tile (left) and a tile with a border (right)

Fig. 16. A borderless tile (left) and a “skirt” border tile (right)
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5. [optional] If the exported surface describes very rough terrain, there may be a loss
in the quality of visualization of model sections where the tile boundary passes
through an area with a significant elevation difference. When exporting such objects
to *.json, set the improved triangulation checkbox.

Fig. 17. The 3D model divided in tiles. The tile boundary passes through very rough terrain (at the
center)

6. When viewing a 3D model in specialized software (depending on the features of a
particular software), the interaction of a 3Dmodel with light sources can be provided.
To ensure the correct interaction of the model with light sources, normals to the
faces of exported surface can be generated, for further recording of these data in
the exported file.

The system provide for the following generating normals options:

• [optional]Without normals;

• [optional] Flat – provides more clear visualization of the surface when interacting
with a light source;

• [optional]Smooth – provides more “natural” surface visualization when interacting
with a light source.

7. [optional] To save texture when exporting, set the appropriate box and set the
texture tile size in pixels;

8. Select a coordinate system of the objects to be exported;

• [optional] Local CS;

○ [optional] Configure additional exported data viewing options.

PHOTOMOD 3D-Mod allows users to work with objects created including in
PHOTOMOD system. PHOTOMOD uses global coordinate systems for data
processing (see the “Coordinate systems” chapter in the “Creating project”
User Manual). Hence, the values of coordinates of objects that were exported
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from PHOTOMOD and imported for viewing in PHOTOMOD 3D-Mod, can be
quite large.

When further exporting data from PHOTOMOD 3D-Mod, for viewing in third-
party software, large values of object coordinates may be a certain inconveni-
ence (depending on the features of a particular program). For example, when
loading a 3D-scene in the third-party software for the first time, such objects
may be outside the area displayed on the screen, due to their significant dis-
tance from the origin of the local coordinate system.

*.json interchange file format allows for recording information about the offset
of the center of the 3D scene viewport, along the X, Y, and Z axes. Such in-
formation can be read by some programs when importing data from the *.json
format. To display the relevant data in the X, Y, and Z input fields of the Export
parameters window, directly before exporting, perform the following:

1. Select File › Settings. The Settings window opens (see details in Sec-
tion 11);

2. To place a 3D-scene’s center on the point that is central relative to all 3D-
scene objects, click the All button in the Origin section, Scene tab, Set-
tings window. The 3D-scene’s center offset parameters along the three
axes are displayed in the fields in the right part of the Settings window;

3. Click OK to close the Settings window and go to data export.

When opening the Export parameters window, the 3D-scene viewport center
offset parameters set in the Settings window will be displayed in the X, Y, and
Z fields. To reset these parameters, click the appropriate button. To restore
data loaded at the moment of opening the Export parameters window, click
the appropriate button.

• [optional] Global CS (see the “Coordinate Systems” chapter of the “Creating
project” User Manual);

○ [optional] To recalculate all the objects to be exported from one coordinate
system to another perform the following actions:

1. Set the Convert CS checkbox;

2. [optional] Click the Select... button to specify initial model cs, if needed.

Coordinate system is specified using one of the following ways:

■ From DB – from international or Russian coordinate system database
(see “Coordinate systems databases” in the Project creation” User
Manual);
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■ From file – allows to select coordinate system from *.x-ref-system
files, located out of active profile resources;

■ From resource – from files with *.x-ref-system extension, located in
active profile resources. It is used for example, to choose coordinate
system from another active profile project.

■ FromGeoCalculator – from the list ofGeoCalculator program database
(see the “Coordinate Systems” chapter in “The GeoCalculator program”
User manual).

The GeoCalculator program allows to edit coordinate systems, to create new
ones, to perform import and export of coordinate systems (see the “The
GeoCalculator program” User Manual).

The system also allows to select coordinate system from a list of recently used
coordinate systems.

When choosing coordinate system from database theCoordinate system
database opens, which contains the list of coordinate systems. To perform
fast search for coordinate system, input the whole coordinate system name
or its part to the Find input filed.

Fig. 18. Coordinate systems database window

[optional] To choose geoid click the button. Select proper type of geoid
usage:

■ No geoid;

■ EGM 96.
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The system also allows to use the EGM2008 geoid. See installation instructions
in the “EGM2008 Geoid installation” User Manual. After installation the geoid
is displayed in the list.

3. Define the target coordinate system in which it is necessary to convert the
objects. To do this perform the actions described above once more or click
the Export to Cesium button to select the appropriate coordinate system.

For CESIUM1.38 version, the coordinate system does not matches the geocentric
reference one. It is rotated by -90 degrees around the X axis. CESIUM 1.70 co-
ordinate system matches the classic geocentric reference system with WGS84
ellipsoid and orientation.

9. Click OK to complete exporting.

4.3.4. Batch export

The system allows for batch export from 3D-Mod-supported files or resources (*.json,
*.obj) into a single *.obj-file.

For this, perform the following:

1. Choose File › 3D-model batch export. The 3D-model batch exportwindow opens:

Fig. 19. The “3D-model batch export” window

2. Choose the Resource type for batch export:

• Windows file system;
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• PHOTOMOD resource system.

3. Choose Data source:

• Files;

• Folder.

4. Click to specify source data (*.json, *.obj) in the Windows file system or in
the PHOTOMOD resource system;

5. Click to specify the location where output data (*.obj) will be saved (the
Windows file system or the PHOTOMOD resource system);

6. Click OK.

For batch export using distributed processing, perform the following:

1. Configure and run the distributed processing server/client (see the “Distributed
processing” chapter in the “General information“User Manual);

2. Click the Distributed processing button.

4.4. Change objects coordinate system

To recalculate all vertices of current layer from one coordinate system to another perform
the following actions:

1. Set the Recalc coord system checkbox on in the window of vector objects import.

2. Click the Select... button to specify initial coordinate system.

Coordinate system is specified using one of the following ways:

• From DB – from international or Russian coordinate system database (see “Co-
ordinate systems databases” in the Project creation” User Manual);

• From file – allows to select coordinate system from *.x-ref-system files, located
out of active profile resources;

• From resource – from files with *.x-ref-system extension, located in active
profile resources. It is used for example, to choose coordinate system from an-
other active profile project.

• From GeoCalculator – from the list of GeoCalculator program database (see
the “Coordinate Systems” chapter in “The GeoCalculator program” User manual).
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The GeoCalculator program allows to edit coordinate systems, to create new ones, to
perform import and export of coordinate systems (see the “The GeoCalculator program”
User Manual).

The system also allows to select coordinate system from a list of recently used coordinate
systems.

When choosing coordinate system from database theCoordinate systemdatabase
opens, which contains the list of coordinate systems. To perform fast search for
coordinate system, input the whole coordinate system name or its part to the Find
input filed.

Fig. 20. Coordinate systems database window

[optional] To choose geoid click the button. Select proper type of geoid usage:

• No geoid;

• EGM 96.

The system also allows to use the EGM2008 geoid. See installation instructions in the
“EGM2008 Geoid installation” User Manual. After installation the geoid is displayed in
the list.

3. Output coordinate system is specified in the same way.

4.5. Loading a standard library objects layer

The system provides for loading a layer with standard library objects.

This tool allows to create a layer containing standard objects of the same type. The system also
provides the functionality of loading a layer with objects from the reference file, which allows for
importing standard objects of several types at once (see Section 4.6).
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For this, perform the following:

1. Choose Layers › Create points layer. The New points layer window opens:

Fig. 21. The “New points layer” window

2. Enter the Layer name;

3. To specify the objects location, click the button near the points field, and select
a file containing data on object coordinates in the ASCII-A format;

ASCII-A – exchange text format with *.txt extension, which is supported by major applic-
ations in different industries.

4. To specify the objects type, click the button near the geometry field, and select
a file containing one library object in ASCII3D format;

ASCII3D – exchange format with *.tx3 extension.

The file must contain one object.

5. Click OK.

To check the correctness of loading a layer of point objects, perform the following:

1. Click the button of the main toolbar. The Select objects window opens;

2. In the opened window, select loaded objects and click Select button;

3. Click the button of the main toolbar.

4.5.1. Points file

The PHOTOMOD system provides possibility of vector objects import from ASCII-А
format (see the “Export to ASCII-A” chapter of the “Vectorization” User Manual). ASCII-
А format contains information about coordinates of vector objects vertices, as well as
information about object type, layer number, attributes name and value.

36

Three-dimensional modelingPHOTOMOD 7.5

vectorization.pdf


Files of this format has the *.txt extension. Unlike ASCII, in ASCII-А format object
description contains first lines that describe object type and attributes.

Example of ASCII-A file content (with point objects):

P "None" 0 6 4

OBJECT_NAME=

OBJECT_COLOR=65535

OBJECT_SYMBOL=

OBJECT_SIZE=1

545566.505,473671.817,77.850

*

The first line of each section has the following structure:

Type, code, layer, N1, N2, where:

• Type - the symbol describing an object type:

○ L – polyline;

○ P – point;

○ C – polygon.

• Code is an object code;

• Layer is a number of layer;

• N1 – the total number of lines where there is a description of the object in the file;

• N2 – the number of lines where there is a description of the object attributes in the
file;

This is followed by lines with attributes description that have the following form:

Name=Value

Then there are lines with the object vertices coordinates. The sequence of records is
delimited by * symbol.
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4.6. Loading a layer containing objects from a reference file

The system also provides for loading a layer with objects from a reference file. This tool
allows one to import standard 3D objects of several types at once.

The system provides simplified functionality that allows one to create a layer from library objects
of the same type (see Section 4.5).

To perform this operation, user need to prepare two files in advance:

• ASCII-A point file containing data on objects’ coordinates;

ASCII-A – exchange text format with *.txt extension, which is supported bymajor applications
in different industries.

• ASCII3D reference file that allows one to specify the types of imported objects. This
file may contain more than one object.

ASCII3D – exchange format with *.tx3 extension.

To load 3D objects from the reference file instead of point vector objects when importing
data from a point file, use File DXF tab tools of the Parameters of import and building
window.

4.6.1. Preparing a point file

The point file containing data about the coordinates of objects used to load objects from
the reference file must (in addition to the standard requirements for ASCII-A files)
comply with the following parameters:

• Contain point vector objects created in the vector layer with a classifier (see the
“Classifier” section in the “Vectorization” User Manual). Point objects must have the
following attributes:

○ Attributes referred to the classifier entry (see “Vector objects attributes” in the
“Vectorization” User Manual):

■ [optional]Code – associates point objects with their descriptions in the reference
file by object code;

■ [optional] Code name – associates point objects with their descriptions in the
reference file by object code name.

○ An additional attribute having type name and library value (see “Using attributes
when building 3D-objects” in the “Vectorization” User Manual).
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To prepare a correct point file, perform the following:

1. Run 3D-Mod;

2. Import *.tx3 reference file;

3. Select the required 3D object;

4. Copy the object’s Name from the appropriate field in the Base properties section;

5. Without closing 3D-Mod, launch PHOTOMOD;

6. Create a vector layer with a classifier (see “Vector layer creation” in the “Vectoriza-
tion”);

7. Ensure that the Classifier window is open (see “Classifier” in the “Vectorization”);

8. To create attributes referred to the classifier entry allowing one to match up point
objects in the point file and 3D objects in the reference file, create a new classifier
code (see “Classifier creation” in the “Vectorization”);

For this, perform the following:

• Click in the Classifier window, to enable the classifier editing mode;

• Click on the Classifier window main toolbar, to create a new code in the
classifier. The Add code window opens;

• Set Code – Name of object from the reference file (see paragraph 4 above);

• SetCode name –Name of object from the reference file (see paragraph 4 above);

• Select object Type – P (point object);

• Click ОК.

9. [optional] Repeat the steps described in paragraphs 4 and 8 (inPHOTOMOD system,
in the layer with the classifier, create classifier codes corresponding to 3D objects
from the reference file open in 3D-Mod);

10. Ensure that the generated point objects have an additional attribute type name and
library value (see “Using attributes when building 3D objects” in the “Vectorization”).

For this, perform the following:

• Open the 3D-Mod toolbar (Windows › Toolbar › 3D-Mod);
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• Click on the 3D-Mod toolbar to enable the value input mode for the type at-
tribute;

• Select library value of the type attribute clicking ;

11. Select the required classifier code in the Classifier window, Codes tab (see para-
graphs 8 and 9);

12. Create one or more point vector objects

To check the values of attributes referred to classifier codes (as well as additional attributes),
select a vector object and chooseWindows › Object attributes or click the button on
the additional Vectors toolbar. The Object attributes window opens.

13. [optional] repeat the steps from paragraph 11 and 12;

14. Click the button on the 3D-Mod toolbar to disable the value input mode for the
type attribute;

15. [optional] Add other vector objects to this layer, if required;

16. Save the layer containing the point vector features described above as an ASCII-
A file (see “Export to ASCII-A” in the “Vectorization” User Manual).

17. Go back to the open 3D-Mod window. Choose File › Close дto close the 3D scene
with objects of the reference file.

The prepared point file can be used to import data into the 3D-Mod together with the
reference file.

5. 3D-objects creation
The module provides possibility to create 3D-objects using outlines of objects external
faces.

This operation could be also applicable, if during vector objects import the Make 3D-building
checkbox was off.

To generate 3D-objects using 2D-objects, perform the following actions:

1. Select Edit › Create › Polyline and create outlines of the upper edges of objects
(roofs) as polygons.

To create polygons set the Loop checkbox on in the Polyline section.
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Fig. 22. Polygons creation

2. Select 2D-objects to be used for 3D-objects creation.

Fig. 23. Polygons creation
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3. Choose the Objects › Build. The Parameters of building window opens.

Fig. 24. Parameters of 3D-objects creation

4. Define the following parameters of the operation:

• Join vertices tolerance – allows to merge vertices, the distance between which
is less than specified;

• Overlapped vertices – for vertices with the same coordinates (X,Y) allows to
select one of the following options:

○ connect;

○ use top;

○ use bottom;

○ use average;

○ use first;
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○ use last.

• Use objects without assignment – allows to select an action to be applied to
vector objects without attributes:

○ Build objects from closed lines;

○ Include points to 3D modeling.

• Process by layers – allows to process vector objects separately in each layer;

To accelerate 3D-building operation, and for correct work with layers it is highly recom-
mended to set the Process by layers checkbox on.

• TheResult section allows to select buildings elements to be created:Roof,Walls
and Footing. The Mesh checkbox allows to convert object elements to a grid.

5. [optional] For more accurate geometry of vector objects it is possible to use *.dxf
file containing description of polygons geometric centers. To do this, on the File
DXF tab click the button, select *.dxf file and choose one of the following options:

• Link by code – allows to match point objects with description of point objects
geometry provided in *.dxf file, using object code (see detailed description of
object attributes in the “Vectorization” User Manual);

• Link by codename – allows to match point objects with description of point ob-
jects geometry provided in *.dxf file, using object codename (see detailed de-
scription of object attributes in the “Vectorization” User Manual);

Fig. 25. Parameters of reference DXF-file
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6. [optional] On the Level tab select one of the following options of relief model use:

• if DEM file is available, click the button and select the file that determines the
lower boundary of 3D-objects construction;

• otherwise, specify constant relief elevation in the Constant height field.

Fig. 26. Parameters of layer level elevation

7. Click OK. After that 3D-objects with specified parameters are created.

Fig. 27. Created 3D-objects - view from above
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Fig. 28. Created 3D-objects - perspective view

6. Objects Editing

6.1. Menu “Edit”
Table 4. Brief description of the “Edit” menu

FunctionMenu items
allows to cancel the last operationCancel
allows to repeat the last cancelled operationRedo
contains menu items to create 3D-objectsCreate
allows to turn on objects selection mode in view
area

Select

allows to select objects from the list in view area
using their names

Select by name...

allows to select elements (outlines, breaklines) not
used for 3D-creation

Select unassigned

allows to select both the whole object, and all ele-
ments (outlines, breaklines) used for 3D-creation

Select dependent

allows to select all objectsSelect all
allows to turn on moving of selected objects in view
area

Move

allows to turn on rotating of selected objectsRotate
allows to turn on scaling of selected objects in XY
and Z planes

Scale
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FunctionMenu items
allows to convert 3D-objects to a gridConvert to
allows to turn on objects attaching mode and to
connect objects to each other to move them simul-
taneously

Attach

allows to unlink objectsDetach
allows to turn on editing mode of texture coordinates
of 3D-object

Edit texture coordinates

allows to load raster map with texture for upper
faces of 3D-objects

Map georeferenced image

allows to delete an object (duplicates the Delete
hotkey)

Delete

allows to copy an object (duplicates the Ctrl+C
hotkeys)

Copy

allows to paste an object (duplicates the Ctrl+V
hotkeys)

Paste

Use the appropriate mode ( ) to move the copied object.

6.2. 3D-objects creation

6.2.1. General information

The module allows to create the following objects:

• Dummy – auxiliary object that appears in the form of a cube frame. This object is not
displayed when viewing 3D-scene;

It is used as a guide object when moving a link of connected objects.

• Surface – flat body in the form of a DEM or orthophoto. The system also allows to
load triangulated irregular network (TIN);

• Polyline – a broken line or a curve, containing a set of vertices, joined by straight or
curve line pieces called segments; The system also allows to create a polygon (closed
polyline);

• Curve Bezier – Bezier vector line containing points, connecting line segments and
check points (in green colour), used to adjust curvature of the segments. The system
also allows to create closed Bezier curve, when start and end points coincide;

• Camera – is an object imitating surveying camera, through which lens 3D-scene
animation occurs;

• Box – is a three-dimensional body displayed in the form of a cube;
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• Sphere – is a three-dimensional body with the frame in a form of a regular convex
polygon. Faces of a sphere have a triangular shape;

If a number of faces is sufficiently large, a sphere takes shape of a ball.

• Cone – is a three-dimensional body, displayed as a cone with a round base and a
sharp end. It is also possible to create a pyramid;

• Cylinder – is a three-dimensional body displayed in the form of a cylinder;

• Tube – is a three-dimensional body displayed as a part of tube;

• Plane – is a flat rectangular body with limited size;

• Light source – is an auxiliary object, that imitates an effect of real 3D-scene lighting.

The objects consist of standard set of elements: vertices, edges and normals. Refer to
Operations with 3D-objects for detailed description of editing of objects elements.

6.2.2. Dummy

In order to create a dummy object select Edit › Create › Dummy. The system creates
an object with default size of 1.
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Fig. 29. Dummy object

6.2.3. Surface

In order to create a surface perform the following actions:

1. Select Edit › Create › Surface. The Surface window opens.
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Fig. 30. Surface properties

2. To load a DEM that is not in active profile resources click the button and choose
a file.

3. To load an orthophoto or terrain map that is not in active profile resources click the
button and choose a file.

4. In the Details field specify DEM cell size in meters.

The DEM cell size should be commensurable with the average distance between pickets
of base layer. Smaller cell size increases surface creation time, and 3D-scene editing time.

5. [optional] For correct reading coordinate values from DEM file in degrees, set the
Degrees checkbox on.

6. [optional] In order to create a surface, that is displayed as a TIN layer, set the TIN
checkbox on.

7. Click the Create button to load an orthophoto.

6.2.4. Polyline

In order to create a polyline/polygon perform the following actions:

1. Select Edit › Create › Polyline. The coordinate system of object to be created is
displayed.

2. Place mouse cursor to selected point in 3D-window and click the mouse button.
The first polyline/polygon vertex is created.
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Fig. 31. First polyline vertex

3. Continue creating new vertices of the polyline/polygon.

Fig. 32. Polyline object

4. [optional] In order to link a polyline to selected objects set the Snap to objects
checkbox on.
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5. [optional] In order to create a polygon, set the Loop checkbox on in the Polyline
section.

6. Press the Esc key to complete polyline/polygon creation.

6.2.5. Bezier curve

In order to create a Bezier curve perform the following actions:

1. Select Edit › Create › Bezier curve. The coordinate system of object to be created
is displayed.

2. Place mouse cursor to selected point in 3D-window and click the mouse button.
The first Bezier curve point is created.

Fig. 33. The first Bezier curve point

3. Continue creating new points of the Bezier curve.
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Fig. 34. Bezier curve object

4. [optional] In order to change a number of segments, specify necessary segments
number in the field and press Enter.

5. [optional] In order to link a polyline to selected objects set the Snap to objects
checkbox on.

6. [optional] In order to create closed Bezier curve, set the Loop checkbox on in the
Curve section.

7. Press the Esc key to complete Bezier curve creation.

8. [optional] Edit Bezier curve points.

6.2.6. Camera

Camera – is special object imitating surveying camera, through which lens 3D-scene
animation occurs;

The module allows to create an object, that imitates surveying camera to generate and
save different types of final scene image.
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In order to create a camera perform the following actions:

1. Select Edit › Create › Camera. The system creates a camera object.

Fig. 35. Camera object

2. Setup the following camera parameters:

• Size – a size of a camera;

• Perspective – display mode of the scene through the camera in perspective
(area of camera projection – viewing pyramid). If the checkbox is off, display
mode of the scene through the camera with parallel projection (area of camera
projection – parallelepiped);

• FOV (field of vision, perspective) – an angle between extreme light rays which
pass into the camera. Field of vision defines the scope of 3D-scene;

• Width (parallel projection) – width of parallelepiped;

• Focus – focal length of camera objective in millimetres;
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• Near – clipping plane nearest to the camera (objects located closer than this
plane are not displayed in the projection window of this camera);

• Far – far clipping plane (objects that are farther of the plane are not displayed in
the projection window of this camera).

The field of view boundary displayed in the form of a regular pyramid with a rectangular
base, is called viewing pyramid.

Fig. 36. Camera viewing pyramid

Camera lens is located on the top of viewing pyramid. Rectangular base of the pyramid
is a projection area of the camera, which dimensions are similar to the field of view of
the window of the camera projection(View › Camera › Projection).

6.2.7. Box

In order to create a box select Edit › Create › Box. The system creates an object with
length, width and height equal to 1.
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The system allows to create a box. To do this turn on zoom mode, place mouse cursor
to one of the box axes and move the cursor to the necessary direction.

To rename a box input its name to the Name field in the Base properties section.

In order to change color of a box, select color in the window opened after double click
on the rectangle in the Base properties section.

Fig. 37. Box object

6.2.8. Sphere

In order to create a sphere perform the following actions:

1. Select Edit › Create › Sphere. The system creates a sphere object.
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Fig. 38. Sphere object

2. Setup the following sphere parameters:

• Radius – a radius of a sphere;

• Horizontal segments – number of horizontal segments;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

• Vertical segments – number of vertical segments;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

3. [optional] To rename a sphere input its name to the Name field in the Base prop-
erties section.

4. [optional] In order to change color of a sphere, select color in the window opened
after double click on the rectangle in the Base properties section.
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6.2.9. Cone

In order to create a cone perform the following actions:

1. Select Edit › Create › Cone. The system creates a cone object.

Fig. 39. Cone object

2. Setup the following cone parameters:

• Radius – cone base radius;

• Height – cone height;

• R-segments – number of segments in cone radius;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

• H-segments – number of segments in cone height;
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In order to change a number of segments, specify necessary segments number in the
field and press Enter.

3. [optional] To rename a cone input its name to theName field in theBase properties
section.

4. [optional] In order to change color of a cone, select color in the window opened
after double click on the rectangle in the Base properties section.

The system allows to create a pyramid. To do this input number of segments that equals
4 to the R-segments field.

6.2.10. Cylinder

In order to create a cylinder perform the following actions:

1. Select Edit › Create › Cylinder. The system creates a cylinder object.

Fig. 40. Cylinder object

2. Setup the following cylinder parameters:
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• Radius – cylinder base radius;

• Height – cylinder height;

• R-segments – number of segments in cylinder radius;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

• H-segments – number of segments in cylinder height;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

3. [optional] To rename a cylinder input its name to the Name field in the Base prop-
erties section.

4. [optional] In order to change color of a cylinder, select color in the window opened
after double click on the rectangle in the Base properties section.

6.2.11. Tube

In order to create a tube perform the following actions:

1. Select Edit › Create › Tube. The system creates a tube object.

Fig. 41. Tube object
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2. Setup the following tube parameters:

• Radius – the external radius of the tube;

• Radius in. – the internal radius of the tube;

• Height – tube height;

• R-segments – number of segments across the thickness of the tube;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

• H-segments – number of segments along the tube height;

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

3. [optional] To rename a tube input its name to theName field in theBase properties
section.

4. [optional] In order to change color of a tube, select color in the window opened after
double click on the rectangle in the Base properties section.

6.2.12. Plane

In order to create a plane perform the following actions:

1. Select Edit › Create › Plane. The system creates a plane.

Fig. 42. Plane object
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2. Setup the following plane parameters:

• Size X and Size Y – a plane length and width;

• Segments X and Segments Y – number of segments in length and width.

In order to change a number of segments, specify necessary segments number in the
field and press Enter.

3. [optional] To rename a plane input its name to theName field in theBase properties
section.

4. [optional] In order to change color of a plane, select color in the window opened
after double click on the rectangle in the Base properties section.

6.2.13. Light source

The system provides the use of light sources for 3D-scene lighting. Built-in light sources
are used by default. When creating a new light source (Edit › Create › Light source)
built-in light sources are disabled.

Perform the following actions for creating a light source:

1. Select Edit › Create › Light source. The system creates an object that imitates
action of real light source.

Fig. 43. Light source object
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2. Setup the following parameters of light source:

• Size – a size of light source;

• Ambient – a colour of the ambient light rays emitted by the source;

• Diffuse – a colour of the direct light rays emitted by the source;

• Specular – a colour of a flare emitted by the source;

• Spoot – a point source emitting rays of light in all directions;

• Attenuation 0, Attenuation 1, Attenuation 2 – allows to change point light
source intencity, i.e. it allows to set light attenuation depending on the distance
to the object. The light intensity value, which does not depend on the distance

to the object, is set by default ( k0 =1, k1 =0, k2 =0), that means that there is no
light attenuation.

The light intensity coefficients are calculated by the following formula:

I = 1
k0 + k1 d + k2 d2

, where k0 , k1 , k2 – coefficients, which correspond to the para-
metersAttenuation 0,Attenuation 1,Attenuation 2. d – a distance between the object
and the light source.

• Project – a source of the spotlight type, which emits a divergent beam of light
directed at an angle to the object;

• Cutoff – a coefficient that allows to change the spotlight intencity;

• Angle Exponent – the angle of inner area of the spotlight directionality.

In order to increase natural lighting of 3D-scene, it is recommended to use at least two
light sources.
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Fig. 44. One light source

Fig. 45. Two light sources
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6.3. Geometric center of the object

Each 3D-scene object contains geometric center and coordinate axes, originating from
the center. Geometric center of the object allows to scale, rotate and move the object
relative to the object’s center.

During creation a new object in 3D-scene or during objects import the geometric center
is created for each object automatically. When you select a scene object in the preview
area coordinate axes, originating from the geometric center of the object, are displayed.

Fig. 46. Geometric center of the object

The system allows to change object geometric center position, for example, to move
the object on some distance relative to another object or to rotate the object relative to
an arbitrary point in space.

In order to change coordinates of object’s geometric center, perform the following actions:

1. Select an object.
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Fig. 47. Selected object

2. In the Advanced properties section select the Origin tab and click the Edit pivot
button.

3. Select Edit › Move or click the button on the main toolbar. The move mode is
on.

4. Move the geometric center of the object to an arbitrary point of scene’s space.
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Fig. 48. Moving geometric center in relation to object

5. Click the Edit center button.

Fig. 49. Rotation of object in relation to geometric center
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In order to move an object relatively to geometric center position, perform the following
actions:

1. Select an object.

Fig. 50. Selected object with displaced geometric center

2. In the Advanced properties section select the Origin tab and click the Edit geo-
metry button. Selected object changed its position in relation to geometric center.

Fig. 51. Moving object in relation to geometric center
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6.4. 3D-objects selection

Before you perform any operation with an object (group of objects) you must select the
object.

In order to select single objects or objects group in viewing area, choose Edit › Select
or click the button on the main toolbar. The objects selection mode is on. To select
a single object, click in its vicinity. To select a group of objects, press and hold left
mouse button and drag a rectangle by the mouse.

To select a group of objects, press and hold the Shift key, and click objects sequentially.

If a 3D-scene contains a large number of objects, it is recommended to select them
using their names in objects list.

In order to select a single objects or objects group in the list, perform the following ac-
tions:

1. Select Edit › Select by name or click the button on the main toolbar. The Select
objects window opens.

Fig. 52. Select objects from the list window

The list of 3D-objects contains the following columns:

• Name – object name;

• Type – object type, which is assigned to an object during its creation in the system
(Object, Outline, LibPoint, None) (see detailed description of object attributes in
the “Vectorization” User Manual);

• Assignment – shows object’s assignment;
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• State – shows objects, used for 3D-creation (Занятый) or not used (Свободный).

2. The Filter section allows to select objects type to be shown in the list.

3. [optional] To show 3D-objects in the list, set the Buildings checkbox on.

4. [optional] To show in the list point objects, converted to objects during creation from
DXF-file library, set the Library checkbox on.

5. To manage objects selection in the list, use the following buttons:

• Select all – allows to select all objects in the list;

• Inverse – allows to invert objects selection order;

• Clear – allows to deselect all objects.

6. Select objects by mouse click and click the Select button.

To select a group of objects, press and hold the Shift key, and click objects sequentially.

To select objects that are not involved in 3D-creation, choose Edit › Select unassigned
or click the button on the main toolbar.

To select both the whole object, and all elements that are involved in 3D-creation,
choose Edit › Select dependent or click the button on the main toolbar.

6.5. Operations with 3D-objects

6.5.1. Moving object

In order to move an object relatively to geometric center position, perform the following
actions:

1. Select Edit › Move or click the button on the main toolbar. Movemode of selected
objects in the viewing area is on.

2. Click the object. After that the object’s coordinate system is displayed.

3. Place mouse cursor close to the coordinate axis or to the plane in which you want
to move the object. The coordinate axis or the plane is displayed in yellow.

69

Three-dimensional modelingPHOTOMOD 7.5



Fig. 53. Selected YZ plane

4. Press and hold mouse button while moving an object to desired place.

Fig. 54. Moving an object in YZ plane
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5. [optional]Right click the button of the main toolbar. The Positionwindow opens.
Specify object moving parameters using one of the two following ways:

• relative to its current position (in the Relative section);

• relative to current origin (in the Absolute section).

Press Enter.

In the Position window you can input parameters of object moving with negative values.

After object moving its new position coordinates are displayed in the Absolute section.

Fig. 55. Object moving parameters

6.5.2. Object rotation

You can rotate the selected scene object in relation to object geometric center.

In order to rotate an object in view area, perform the following actions:

1. Select Edit › Rotate or click the button on the main toolbar. The selected objects
rotation mode is on.

2. Click the object. After that the rotation sphere is displayed.
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Fig. 56. Rotation sphere of an object

3. Select one of the following object rotation options:

• to rotate an object along one of the rotation sphere planes, place mouse cursor
close to the plane. The selected plane is displayed in yellow.
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Fig. 57. Object rotation along one of the rotation sphere planes

• to rotate an object in a free plane, move the mouse cursor to the rotation sphere
center. The rotation sphere is displayed in yellow.

Fig. 58. Selected free plane
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4. Press and hold mouse button while rotating an object to desired position.

Fig. 59. Object rotation in free plane

5. [optional] Right click the button of the main toolbar. The Rotation window
opens. Specify object rotating parameters using one of the two following ways:

• relative to its current position (in the Relative section);

• relative to current origin (in the Absolute section).

Press Enter.

In the Rotation window you can input rotation parameters with negative values.

After object rotating its new position coordinates are displayed in the Absolute section.
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Fig. 60. Object rotating parameters

6.5.3. Object scaling

You can scale the selected scene object in relation to object geometric center.

In order to change object scale along three coordinate axes or along one of them, per-
form the following actions:

1. Select Edit › Scale or click the button on the main toolbar. The selected objects
scale mode is on.

2. Click the object. After that the object’s coordinate system is displayed.
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Fig. 61. Object’s coordinate system

3. Select coordinate axis along which you want to scale an object:

• to change object scale along one of the axes, move the mouse cursor close to
the axis. The coordinate axis is displayed in yellow.
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Fig. 62. Selected Z-axis

• to change object scale in a plane of two coordinate axes, move the mouse cursor
close to the bridge in triangle shape connecting the two axes. The selected plane
is displayed in yellow.
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Fig. 63. Selected YZ plane

• to change object scale along three coordinate system axes, move the mouse
cursor close to the axes origin. Selected area is displayed in triangle shape of
yellow color.
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Fig. 64. Selected area along three coordinate system axes

4. Press and hold mouse button while moving the mouse cursor. The object scale is
changed along selected coordinate axes.

79

Three-dimensional modelingPHOTOMOD 7.5



Fig. 65. Object scaling along three coordinate system axes

5. [optional] Right click the button of the main toolbar. The Scale window opens.
Specify scaling parameters in the Relative section. Press Enter.

In the Scale window you can input scaling parameters with negative values.

After object scaling its new position coordinates are displayed in the Absolute section.

Fig. 66. Object scaling parameters

80

Three-dimensional modelingPHOTOMOD 7.5



6.5.4. Converting an object into a grid

The module allows to perform operations with any geometric body.

Geometric body is called 2D or 3D-object, created to be displayed on final 3D-scene.

A base of geometric body is its grid shell (grid).

Grid shell of geometric body has a certain structure and consists of points and faces.
Vertices and faces of any created body (Edit › Create) are not available for editing, i.e.
it is impossible to change the shape of the body in an arbitrary way. To edit a geometric
body it is necessary to convert an initial object to grid shell (mesh manifold).

In order to convert an object to a grid perform the following actions:

1. Create object or import it.

2. Select an object.

Fig. 67. Selected object - sphere

3. Select Edit › Convert to › grid. After that converted object becomes editable.
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Fig. 68. Selected object converted to a grid

6.5.5. Editing of object’s points

Object’s point – a point in which grid shell faces converge.

Perform the following actions to edit object’s points:

1. Create object or import a vector objects layer.

2. Select an object.

3. [optional] To edit created object choose Edit › Convert to › grid.

4. In the Editing section click the button. The editing of object’s points mode is on.
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Fig. 69. Editing of object’s points mode

5. [optional] In order to remove a point, select it and click the Delete button.

6. In order to combine multiple points, select two or more points and click the Weld
button.
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Fig. 70. Two selected points

Fig. 71. One point obtained by combining of two points
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7. [optional] To combine multiple points, located at a distance less than the specified,
input a value into the field and click theWeld button.

To create a smooth model of object select all its points, input minimal distance value to the
field and click theWeld button.

8. [optional] In order to split previously combined points, select them and click the
Divide button. Turn the move mode of selected objects on and drag split points to
the desired distance by mouse button.

Fig. 72. Moving of one of points by Y

9. In order to turn the object points editing mode off, click the button.

Perform the following actions to create a new object point:

1. Select an object.

2. In the Editing section click the button. The editing of object’s points mode is on.

3. In the Points section click the Create button. The points creating mode is on.

4. Move a marker into desired place on object.
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Fig. 73. The marker located in a place of new object point to be created

5. Create a new object point by mouse click.

Fig. 74. A new object point creation
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6. To turn the points creation mode off, click the Create button.

6.5.6. Editing of object’s faces

Object face – minimal triangle element of mesh body shell.

Each object face contains a normal. If the normal is directed towards the observer, the
object face is displayed. If the normal is directed in the opposite direction from the
viewpoint, then the face is not displayed.

Perform the following actions to edit object’s faces:

1. Create object or import a vector objects layer.

2. Select an object.

3. [optional] To edit created object choose Edit › Convert to › grid.

4. In the Editing section click the button. The editing of object’s faces mode is on.

Fig. 75. Editing of object’s faces mode
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5. To select faces, perform the following:

• [optional] select a single face by left mouse button click;

To select several faces, press and hold Shift, and click the desired faces one by one.

To deselect certain faces from the selected group, press and hold Ctrl, and click the
mouse to deselect the desired faces one by one.

• [optional] to select a group of adjacent faces, press and hold the left mouse
button and move the marker to “stretch” the rectangular area where the faces
will be selected;

• [optional] to select similar object’s faces, i.e. faces located near the selected
one and at the same time lying in the same plane with it (or in planes close to
the original one), perform the following:

1. Enter the maximum acceptable angle of deviation from the plane in which
the initially selected face lies in the Select similar, section, from 0 to 180
degrees.

2. Click the In plane button.

Too small values of the deviation angle will lead to extra strict check of the similarity of
the faces, too large ones - to the selection of all faces of the object, regardless of their
location. Entering reasonable angle values allows one to quickly select uniform areas
of objects, which can be useful, for example, when texturizing.

In this case, the number of detected similar faces and the range of their detection are
potentially unlimited, however, as a result of the operation, only those similar faces that
are in direct proximity to each other will be selected. In this case, the selection does not
involve isolated areas, as well as faces located in parallel planes.

6. [optional] In order to remove a face, select it and click the Delete button.

To remove vertices of selected faces set the Delete free points checkbox on and then
click the Delete button.
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Fig. 76. Selected object’s face to be deleted

Fig. 77. Deleting of selected face

7. [optional] In order to separate a face from the object, select the face and click the
Divide button. Turn the objects moving mode on and move the separated face.
After that a face remains in the object’s grid shell.
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Fig. 78. Selected object’s face to be separated

Fig. 79. Separated face

8. [optional] In order to divide a face into several pieces, click the Divide button and
use the mouse to mark boundaries of new faces as follows: drag lines between
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existing vertices or edges of the face you wish to divide into several smaller faces.
To quit faces dividing mode, click the Divide button once more.

Fig. 80. Dividing object faces into several pieces

9. [optional] In order to separate a face, select it and click the Detach button. Turn
the objects movingmode on andmove the face. Split and separated face is excluded
from object’s frame and is a separate object.
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Fig. 81. Selected object’s face to be split and separated

Fig. 82. Split and separated face

92

Three-dimensional modelingPHOTOMOD 7.5



10. To move a face in normal direction, that means to swap front and back face, click
the Redirect button.

Each face of an object contains a normal. If a face normal is directed towards the observer,
then the face is displayed in the view panel and is called front face. Otherwise, the face is
not displayed and is called back face.

Fig. 83. Selected object’s face, which normal direction to be changed

Fig. 84. Back face
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11. [optional] To align the normals of selected faces in relation to each other, click the
Turn Correct button.

In order to change back face into front one, first select the front face. The direction of the
normal of the first selected face is the basis for the rest of faces.

Fig. 85. Selected faces

Fig. 86. Back face changed to the front face
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12. [optional] To created smoothed model of an object set the Smoothing checkbox
on.

Fig. 87. Smoothed model of an object

13. [optional] To specify smoothing group for object’s selected faces, set the By group
checkbox. Select desired number of faces and click one of 32 numbered buttons
in the Groups section

14. In order to turn the object faces editing mode off, click the button.

Perform the following actions to create a new object face:

1. Select an object.

2. In the Editing section click the button. The editing of object’s faces mode is on.

3. In the Faces section click the Create button. The faces creating mode is on.
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Fig. 88. Faces creating mode

4. [optional] To create a face containing normal the Create checkbox is set on by de-
fault in the Normals section. Otherwise set the Create checkbox off.

5. Sequentially select three or more vertices to start the face’s creation.
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Fig. 89. Two points of a new face

6. Select the first point of face by mouse click one more time. A new object’s face is
created.

7. To turn the faces creation mode off, click the Create button.
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Fig. 90. New object’s face

To specify smoothing groups for selected faces of object, perform the following actions:

1. Select an object.
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Fig. 91. Selected object

2. In the Editing section click the button. The editing of object’s faces mode is on.

3. In the Normals section set the Smoothing and By groups checkboxes on.

4. Select faces and click the 00 button. After that normals of selected faces are directed
to the same side. The faces are displayed with the same brightness.

99

Three-dimensional modelingPHOTOMOD 7.5



Fig. 92. Selected faces

Fig. 93. Specifying smoothing group 00 for selected faces of object
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5. Select other faces and click the 01 button. After that normals of these faces are
directed to another side.

Fig. 94. Selected faces

Fig. 95. Specifying smoothing group 01 for selected faces of object
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6. Repeat steps 4 and 5 required number of times.

7. Click the to turn off the mode of object’s faces editing.

6.5.7. Composite object creation

The module allows to create a composite object, which consists of several pieces, each
of which represents a separate object. Any object could be used as a part.

Composite object – integrated 3D-object, created from two or more objects.

Perform the following actions to create a a composite object:

1. Create initial objects which will be used to form a composite object or import vector
objects layer.

Fig. 96. Initial objects

2. Move the objects in 3D-scene space.
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Fig. 97. Objects placement in 3D-scene space

3. Select main object to which other objects are combined in series.
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Fig. 98. Main object to which other objects are combined

4. [optional] To edit created object choose Edit › Convert to › grid.

5. In the Editing section click the button.

6. In the Parts section click the Add button. The objects adding mode is on.
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Fig. 99. Objects adding mode

7. Select objects to be combined with the main one by mouse click.
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Fig. 100. Combining other object with the main one

8. Click the Add button to turn off the objects add mode.
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Fig. 101. Composite object

9. Click the button to turn off the mode of parts editing. Separate objects became
parts of a composite object.
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Fig. 102. Selected faces of a composite object

Composite object creation itself does not lead to its automatic re-building, i.e. to the
creation of new, continuous, and combined surface that can be described by a set of
faces.

The need in such an operation directly depends on the expected result and the way of
further object processing (for example, whether texture superposition will be required).
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Fig. 103. A composite object of a cube and a sphere, those initially intersected in space

Fig. 104. Highlighted faces of the composite object (including those hidden under its surface)
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When necessary, to re-build the surface of a composite object and delete hidden (inner)
faces, perform the following:

1. Select the composite object created before;

2. In the Editing section, click the button;

3. In the Parts section, click the Delete internal faces button. The object is being
rebuilt;

Fig. 105. Reconstructed surface of a composite object

4. Click the button to disable the parts editing mode.

The system also provides for merging objects. When merging objects, operations of inner face
removing and the resulting object surface re-building are immediately performed automatically
(see below).

6.5.8. Boolean operations on objects

The system provides for logical operations including merging, intersecting, and subtract-
ing the objects (one from another).
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For this, perform the following:

1. Create source objects (two or more) or import a vector object layer;

Fig. 106. Source objects

2. Move objects within the 3D-scene;

Spatial intersection of objects is not mandatory for performing the operation (for example,
in case of merging objects), but is implied for operations of subtraction and intersection of
objects (otherwise, these operations lead to null results).
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Fig. 107. Location of objects in the 3D scene space

3. Select the main object that will be sequentially subjected to Boolean operations;
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Fig. 108. The main object other objects are merged with

4. [optional] To edit the created object, choose Edit › Convert to › grid;

5. Click the button in the Editing section;

6. Click one of the buttons in the Boolean operations section of the Parts section:

• [optional] Merge;

• [optional] Intersection;

• [optional] Subtraction (А — B);

• [optional] Subtraction (B — A).

The mode for performing the appropriate Boolean operation on objects is switched
on.
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Fig. 109. ’$QUOTE$"Editing”, “Parts”, and “Boolean operations” sections

7. Configure the accuracy of object re-building in the appropriate input field. The in-
crease in the given value causes the worsening of final object’s details. Scale down
this value to increase detailing of output objects.

An object re-building accuracy required for certain operations may vary depending on the
expected results and source data quality (for example, a quality of construction of vector
objects created using PHOTOMOD or another software). The values of this parameter can
play a significant role during the operation of merging objects, which, depending on the
circumstances of their construction, can either ideally adjoin each other or be simply quite
close.

Thus, it is recommended to perform operations with objects with default accuracy first. In
case of unsatisfactory results, the system allows the user to undo the fulfilled operation
(the button of the main toolbar) and repeat it using corrected values of this parameter.
Keep in mind that an extra high default value is likely to lead to unsatisfactory results
(represented by unintended and significant changes in the original shape of the loaded
objects).

8. Clicking the left mouse button, select the object that you want to subject to the op-
eration selected in the previous paragraph together with the main object. A dialog
box opens:
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Fig. 110. A dialog box

• [optional] Click Yes to delete the selected extra object after the operation is
complete;

• [optional] Click No, not to delete the selected extra object after the operation is
complete.

9. [optional] Sequentially repeat the steps described in the paragraphs above with
other objects loaded into the 3D scene space, if necessary;

Fig. 111. Two objects merged
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Fig. 112. Two objects intersected

Fig. 113. One object is subtracted from another (Option 1)
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Fig. 114. One object is subtracted from another (Option 2)

Fig. 115. The result of subtraction of one object from another (Option 1), the additional object was
not removed after the operation was performed (and shifted for better visualization)
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Fig. 116. Adjacent objects

Fig. 117. Adjacent objects merged with high accuracy
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Fig. 118. Adjacent objects merged with low accuracy

10. To disable current mode (intersection, merging, or subtraction), click the appropriate
button in the Boolean operations section of the Parts section;

11. Click the button in the Editing section, to disable the parts editing mode.

6.5.9. Optimizing the number of object faces

Imported objects, depending on the conditions of their creation and the tools used for
this, may contain an unreasonably large number of faces, in situations when a fragment
of an object, which is an ideal plane, can just as well be described by a much smaller
number of faces.

To optimize the number of faces describing such parts of an object, perform the following:

1. Select an object;

2. [optional] To edit the created object, choose Edit › Convert to › grid;

3. In the Editing section, click the button;
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4. [optional] Correct the accuracy of object re-building in the input field that corresponds
to the Simplify button in the Parts section.

5. Click the Simplify button. If there are redundant faces within “flat” object fragment,
their number will be reduced to minimum required.

An object under processing may also contain fragments very close to a plain in their shape,
those (if it suits the tasks being solved) would be reasonably interpolated as planes.

By varying the accuracy of object reconstruction, a user can adjust the degree on interpol-
ation. By default, with a low value of this parameter (high accuracy), interpolation is not
applied.

To interpolate close-to-a-plane fragments of an object as a plane, it is required (sometimes
significantly) to increase the entered value (to reduce the reconstruction accuracy).

6. Click the button in the Editing section to disable the parts editing mode.

6.5.10. Editing polyline points

Perform the following actions to edit polyline points:

1. Create a polyline or import a vector objects layer.

2. Select a polyline.

3. In the Editing section click the button. The editing of polyline points mode is on.

Fig. 119. Editing of polyline points mode
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4. In the Points section click the Create button and create a new point by mouse click
in view window.

Fig. 120. Creation of a new polyline point

5. [optional] In order to remove a point, select it and click the Delete button.

Fig. 121. Selected point to be deleted
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Fig. 122. Deleting of selected point

6. [optional] To change a polyline direction (to swap the first and the last points of a
polyline), click the Redirect button.

7. In order to turn the polyline points editing mode off, click the button.

6.5.11. Editing of Bezier curve

Perform the following actions to edit Bezier curve points:

1. Create Bezier curve or import a vector objects layer.

2. Select Bezier curve.

3. [optional] To change number of segments, in the Curve section input number of
segments between check points.

4. [optional] To create closed Bezier curve, in theCurve section set the Loop checkbox
on.

5. In the Editing section click the button. The editing of Bezier curve points mode
is on.
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Fig. 123. Editing of Bezier curve points mode

6. In the Points section click the Create button, and select one of the following types
of points:

• – point with two independent check points, joined by line segments (tangent
to the adjacent segments of the curve);

In order to change the curvature of the curve section, turn on the move mode, set the
mouse cursor over the control point (highlighted in green) and move it in any direction.

• – point with two check points connected to each other, joined by line segments
(tangent to the adjacent segments of the curve); when the position of one of the
checkpoints is changed, another checkpoint changes symmetrically, but the dis-
tance to the main point remains the same;

• – point with two check points firmly connected to each other, joined by line
segments (tangent to the adjacent segments of the curve); when the position of
one of the checkpoints is changed, another checkpoint changes symmetrically;

• – smoothed point (without check points).
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Fig. 124. Point type - point with two check points firmly connected to each other

7. [optional] In order to remove a point, select it and click the Delete button.
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Fig. 125. Selected point to be deleted

Fig. 126. Deleting of selected point
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8. [optional] To change a Bezier curve direction (to swap the first and the last points
of a polyline), click the Redirect button.

9. [optional] To rename a Bezier curve input its name to the Name field in the Base
properties section.

10. [optional] In order to change color of a Bezier curve points, select color in the window
opened after double click on the rectangle in the Base properties section.

11. In order to turn the Bezier curve points editing mode off, click the button.

Fig. 127. Turn off the editing of Bezier curve points mode

7. Objects attaching mode

7.1. General information

Objects attaching – establishing hierarchic relation between objects in order to move
them simultaneously (zoom, rotate) in scene 3D-space.
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The module allows to work both with individual objects located independently from each
other, and with object groups, containing hierarchical relationship like “parent object -
child object”.

Child object – an object, that when moving, rotating, or scaling the associated parent
object is synchronously moved, rotated or scaled.

Parent object – an object that is attached to child object.

There is a possibility to attach multiple objects. Such attaching in a group should be
done in ascending order, i.e. the object, which is the youngest child should be selected
as the first.

7.2. Objects attaching

In order to attach objects, perform the following actions:

1. Select Edit › Attach or click the button on the main toolbar. The objects attaching
mode is on.

Fig. 128. Objects attaching mode
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2. Select child object by mouse click.

Fig. 129. Child object

3. Press and hold mouse button and draw the cursor on another object.
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Fig. 130. Attaching child object (sphere) to the parent one (cylinder)

4. Release mouse button. Attachment line between the object is highlighted several
times, so the system performs objects attaching.

129

Three-dimensional modelingPHOTOMOD 7.5



Fig. 131. Sphere rotation along with a cylinder

Fig. 132. Sphere rotation along with a cylinder
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5. In order to turn the objects attaching mode off, click the button.

In order to attach objects using their names list, perform the following actions:

1. Select child object, i.e. the object to be synchronized to repeat the actions of another
object.

Fig. 133. Child object

2. Click the button on the main toolbar. The Select objects window opens.
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Fig. 134. Select objects from the list window

3. Select in the list parent object, i.e the object to which the selected object will be at-
tached.

Fig. 135. Selection parent object in the list

4. Click the Select button. After that the system performs objects attaching.
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Fig. 136. Sphere rotation along with a cylinder

Fig. 137. Sphere rotation along with a cylinder
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5. In order to turn the objects attaching mode off, click the button.

7.3. Cancelling objects attaching

The module allows to cancel previously established relationships between objects.

Consider the operation of detaching using the example of three attached objects. In
this example the younger child object is cone, the older child object is cylinder, the
parent object is tube. Operation of these objects attaching was performed in the following
order:

1. The cone was attached to cylinder.

2. The cylinder was attached to the tube. As a result, during rotation of the tube its
two child objects rotate synchronously.

Fig. 138. Tube rotation along with a cylinder and cone
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Fig. 139. Tube rotation along with a cylinder and cone

To cancel attachment between objects, perform the following actions:

1. Select the object which you want to unlink from the parent object.
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Fig. 140. Selecting child object

2. Select Edit › Detach or click the button on the main toolbar. As a result, the at-
tachment between selected object and the parent one will break, but the connection
with another object will remain.
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Fig. 141. Tube rotation

Fig. 142. Cylinder rotation along with a cone
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8. Texture assignment

8.1. Texture assignment to 3D-objects

The module allows to assign texture to 3D-objects, that helps to give the form of real
objects to geometric bodies.

Texture is an image, which you can assign to 3D-object to simulate real-world materials of nat-
ural or synthetic origin.

The images of the following formats could be used to assign texture to 3D-objects:

• Tag Image File Format (TIFF) – TIFF и GeoTiff format, included tags for saving of
georeference information;

• Windows Bitmap File (BMP);

• JPEG (JPEG);

• PNG (PNG);

• JPEG2000 (JP2); – raster format with jpeg compression and georeference in the
heading developed.

The limitation on output file size of JPEG2000 format – no greater then 500 Мb.

To assign texture to 3D-objects it is necessary not just load the texture into object, but
also edit texture coordinates, i.e. to specify location, change image scale on the object
surface.

To assign texture to 3D-object perform the following actions:

1. Create object or import a vector objects layer.

2. Select an object.
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Fig. 143. Selected object

3. Select Edit › Edit texture coordinates (Ctrl+T). The texturing mode is on.
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Fig. 144. Texturing mode

4. In the Texture section click the Load button. The Load texture window opens.
Select texture file by mouse click and click the Open button. The system loads the
texture to selected object.
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Fig. 145. Texture loading to object

5. [optional] If it is necessary to assign the same texture to multiple objects, perfrom
the following actions:

• in the Editing section click the button and in the Parts section click the Add
button. The objects adding mode is on.
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Fig. 146. Objects adding mode

• select other objects using mouse click and click the Add button to turn objects
adding mode off.
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Fig. 147. Turn of the objects adding mode.

• Select Edit › Edit texture coordinates. The texturing mode is on.

6. Click the button and rotate 3D-scene view area to show the front of the object.
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Fig. 148. Front side of the object

7. In the Editing section click the button. The Texture editing window opens.
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Fig. 149. Texture editing

8. In the main module window press and hold mouse button while selecting all object
faces.

Fig. 150. Selecting all object faces
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9. In the Texture editing window move viewing area to display the part of texture to
be assigned to the front side of the object.

Fig. 151. Part of texture to be assigned to the front side of the object

10. In the main module window click the Generate button (or press the Space button
on the keyboard). In the Texture editing window all object faces are displayed.

Fig. 152. All object faces in the “Texture editing” window
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11. In the Texture editing window click the button and move faces.

Fig. 153. Moving all object faces

12. Click the button. The points editing mode is on.

Fig. 154. Points editing mode

13. Select all the points and click the button. The texture coordinates scale mode
is on.
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Fig. 155. Scale texture coordinates mode

14. Place mouse cursor on one of the object vertices, press and hold mouse button
and change texture coordinates scalebutton. Changes made to the texture are
displayed in the main module window.

Fig. 156. Front side of the object with texture
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15. [optional] In order to move ( ) selected point in relation to another one using
snapping press and hold the B or V key. Vertical or horizontal dashed lines are
displayed, that allows to orient a vertex in relation to another vertex.

16. In the main module window move 3d-scene view area on one of the object sides.

Fig. 157. Right side of the object

17. In the Editing section click the button. The Texture editing window opens.
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Fig. 158. Texture editing

18. In the main module window press and hold the Shift key while selecting faces of
displayed part of the object using mouse clicks.

In order to cancel face selection press and hold the Ctrl key and cancel the face selection
by mouse click.

Fig. 159. Selection of faces of object right side

19. In the main module window click the Separate (R) button. In the Texture editing
window selected faces are displayed.
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Fig. 160. Displaying selected faces in the “Texture editing” window

20. In the main module window click the Generate button. Faces are displayed in the
Texture editing window.

Fig. 161. All object faces in the “Texture editing” window

21. In the Texture editing window click the button. Move and edit object faces in
the same way.
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Fig. 162. Faces editing

Fig. 163. Right side of the object with texture

The module allows to save object with texture. To do it, select File › Save or File › Save
as.

8.2. Texture editing

The Texture editing window is used to edit texture coordinates.
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Fig. 164. Texture editing

The toolbox of the window contains the following buttons:

• – allows to move view area of texture in any direction

• – allows to zoom in/zoom out view area

• – allows to zoom in of texture view area selected by rectangle

• – allows to display the whole texture area in view area;

• – allows to highlight texture coordinates in view area;

• – allows to move highlighted texture coordinates in view area;

• – allows to rotate highlighted texture coordinates in view area;

• (in points editing mode only) – allows to turn texture coordinates scale mode on;

• – allows to turn points editing mode on;

• – allows to turn faces editing mode on;

8.3. Snapping

Snapping is marker movement, when it “sticks” to different elements of the objects on
the screen. It is used to move selected vertex in relation to other vertices vertically /
horizontally.

For work in snapping mode the system provides B or V hotkeys.
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V (3D snapping to vertices) – marker XYZ-coordinates coincide with coordinates of
vertices. When pressing the hotkey, marker moves to the vertex of texture coordinates
nearest to the mouse cursor position.

B (2D snapping to vertices) – marker XY-coordinates coincide with coordinates of ver-
tices, but value of marker Z-coordinate does not change. When pressing the hotkey,
marker moves to the vertex of texture coordinates nearest to the mouse cursor position,
but value of marker Z-coordinate remains the same.

Hotkeys are used to temporally turn on (when the key is pressed down) or off (when
the key is released) the snapping mode. When the hotkey is pressed, marker moves
to a corresponding vertex of texture coordinates.

8.4. Assigning texture to 3D-objects upper faces

The module allows to assign raster map with texture (orthomosaic sheet, for instance)
to upper faces of 3D-objects.

The size of the raster map with texture must not exceed 4000x4000 pixels.

To load raster map with texture for upper faces of 3D-objects, perform the following
actions:

1. Open layer with vector objects in the system and select Vectors › Open vectors
in 3D-Mod. The 3D-Mod module and the Import window open.

Fig. 165. Parameters of coordinate system import
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2. Open the Building tab and set the following checkboxes.

Fig. 166. Parameters of 3D-objects import

3. Click OK. Selected layer is loaded to the module.

Fig. 167. 3D-objects layer

4. Select objects and choose Edit › Convert to › grid.
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5. Select Edit › Map georeferenced image. The Load texturewindow opens. Select
a file with raster map and texture by mouse click and click the Open button. The
system assigns texture to 3D-objects upper faces.

The size of the raster map with texture must not exceed 4000x4000 pixels.

Fig. 168. Assigning texture to 3D-objects upper faces

Fig. 169. Assigning texture to 3D-objects upper faces
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9. Management of 3D-scene view

9.1. “View” menu
Table 5. Brief description of the “View” menu

FunctionMenu items
allows to hide/show the following toolbars: 3D-scene
view, object control, object view

Toolbar

allows to move view area of 3D-scene in any direc-
tion

Moving

allows to move view area of 3D-scene perpendicular
to the screen plane

Approach/Distance

allows to rotate 3D-scene view areaRotation
allows to zoom in/zoom out 3D-scene view areaZoom
allows to zoom in of 3D-scene view area selected
by rectangle

Zoom region

allows to turn on/of frame displayingEdges
allows to turn on/of textures displayingTextures
allows to turn on anaglyph stereo modeAnaglyph stereo mode
allows to turn on page-flipping stereo modePage-flipping stereo mode
allows to turn the perspective mode on, i.e. to dis-
play 3D space in 2D plane

Perspective

allows to show coordinate gridGrid
allows to show scale barScale rule
contains menu items used to display 3D-scene view
area in one of projections

Direction

allows to display 3D-scene in four projections (front,
left, top and perspective)

Four projections

allows to show 3D-scene from cameraCamera

9.2. Management of 3D-scene view

Scene – three-dimensional virtual environment, used for #d-objects modelling and
visualization.

3D-scene may contain objects of the following types: 2D/3D-objects, orthomosaic, point
objects, helpers objects (for example, dummy object or light sources) and surveying
cameras, used for scene observation.

One of the components of the scene is the background on which the objects are dis-
played. To set the background color (which is grey by default), select Settings. Select
the Rendering tab and choose desired background color by mouse click.

To manage 3D-scene view, perform the following actions:
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• Moving ( ) – moving of 3D-scene view area in desired direction.

Tomove view area of 3D-scene, press and hold mouse button while moving the area in desired
direction.

If 3D-scene moving mode is off, press and hold the Alt key along with middle mouse button
while moving the area in desired direction.

• Approach/Distance ( ) – moving view area of 3D-scene perpendicular to the screen
plane.

To move view area perpendicular to the plane of the screen, rotate mouse wheel away form
you – to zoom in 3D-scene, in opposite direction – to zoom out 3D-scene.

• Rotation ( ) – rotation of 3D-scene view area in free plane.

To rotate view area of 3D-scene in free plane, press and hold mouse button while moving
the area in desired direction.

If 3D-scene rotate mode is off, press and hold the Shift key along with middle mouse button
while moving the area in desired direction.

• Scene observation from camera ( ) – moving view area of 3D-scene, with imitation
of the scene observation from camera. To setup moving parameters use theMoving
tab of the Settings window (see Section 11). To move the “camera” use W, A, S, D
keys.

To move the “camera” use W, A, S, D keys. Drag the mouse to rotate the camera. To turn
off the camera observation mode, press Esc.

• Zoom in /Zoom out ( ) – zoom in/zoom out of 3D-scene view area.

To zoom in the whole 3D-scene view area rotate mouse wheel forward. To zoom it out – rotate
mouse wheel backward.

If the zoom mode is off, press and hold the Ctrl key along with middle mouse button and
move the mouse forward to zoom the view area in, or move the mouse backward – to zoom
out.

• Zoom region ( ) – zoom in of certain rectangular 3D-scene area. This display option
is used to speed up scene view.

To zoom in some view area, press and hold left mouse button, while dragging a rectangle
by the mouse.
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Fig. 170. Selecting area to zoom it in

Fig. 171. Selected area zoomed in

• Perspective – displaying 3D space on 2D plane. This view option is set by default.
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Fig. 172. Displaying 3D-scene in perspective mode

Fig. 173. Displaying 3D-scene without perspective

• Camera – displaying 3D-scene in central projection. Shows 3D-scene from camera
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It is recommended to place scene’s objects in area of camera viewing pyramid.

Fig. 174. Object view from camera

9.3. Anaglyph stereo mode

Anaglyph stereo image is formed by color-coding the stereo pair of images, which are
intended for the left eye and right eye using accordingly “red” and “blue” color-filters.
To view and measure in anaglyph stereo mode special spectral anaglyph spectacles
with red and blue filters are used.

Anaglyph stereo measurements mode does not depend on monitor and video card
parameters. Anaglyph mode is not completely good for full-featured work with color
images.

Anaglyph stereo is available only for HighColor or TrueColor display mode of your monitor.

To turn on anaglyph stereo mode choose View › Anaglyph stereo mode or click
button of the system toolbar.

9.4. Page-flipping stereo mode

Page flipping (“frame by frame”) display mode provides the most high quality stereo
picture because it uses full frames instead of semi-frames. Left and right images of
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stereopair are displayed one by one synchronously with the frames switching. The
shutter glasses are synchronized with vertical refresh rate of monitor that allows to see
two images “simultaneously” and make stereo measurements. For working in page-
flipping mode you should use a monitor supporting stereo mode, and an appropriate
video adapter.

For work in page-flipping stereo mode it is necessary to use shutter glasses. Shutter
glasses are liquid crystal glasses synchronized with the vertical refresh rate of monitor.
The system supports page-flipping stereo measurements mode using shutter glasses.
See more details about stereo glasses and other special equipment for images stereo
processing in the “General information about system” User Manual.

To turn on page-flipping stereo mode choose View › Frame stereo mode or click
button of the system toolbar.

9.5. Grid

The module allows to display coordinate grid. The grid is located in loaded objects plane
and covers the entire 3D-scene viewing area. Coordinate grid allows to perform meas-
urements of geometric size of scene objects, and is also used for objects position
alignment.

Coordinate grid lines are displayed with different color. Black grid lines are complement-
ary (they are use for the decimal division), grey ones – the main. The actual distance
between the lines is determined by current scale of 3D-scene display. With zooming in
a distance between grid lines is gradually increasing, with zooming out – distance de-
creases.

To display coordinate grid select View › Grid or click the button on the main toolbar.
To specify the grid Settings open the Rendering tab of the appropriate window.
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Fig. 175. Coordinate grid – enlarged scale

Fig. 176. Coordinate grid – reduced scale
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9.6. Scale bar

The module allows to display scale bar. The scale bar is displayed in the lower right
corner of the screen. The scale bar division is determined by current scale of 3D-scene
display.

The current scale of 3D-scene is displayed in the top left corner of the screen.

The scale bar is not available when the perspective mode ( ) is on.

To display coordinate grid select View › Scale rule or click the button on the main
toolbar.

9.7. Measurements

The system provides possibility to perform measurements within 3D-scene. To go to
measurements mode use the button on the main toolbar. When the measurements
mode is enabled, the Measurements window opens.

Fig. 177. The “Measurement” window

The window contains fields with mouse cursor coordinates values:

• X – cursor X geodetic coordinate;

• Y – cursor Y geodetic coordinate;

• Z – cursor Z geodetic coordinate;

• Xp – cursor Xp geodetic coordinate;

• Yp – cursor Yp geodetic coordinate;

• Zp – cursor Zp geodetic coordinate;
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• dX – current segment incrementation by X;

• dY – current segment incrementation by Y;

• dZ – current segment incrementation by Z;

Besides, the Measurements window contains fields with values of the following para-
meters of segment:

• S – a length of segment;

• D – a length of horizontal distance (projection on a plane) of segment by Z;

• dZ/D – a value of segment slope (Z increment ratio to the horizontal distance);

• – direction of current segment relative to X axis;

• – vertical angle of current segment.

Do the following actions to perform measurements:

1. Click the button on the main toolbar. The Measurements window opens:

Fig. 178. The “Measurement” window

2. Place mouse cursor to selected point in 3D-window and click the left mouse button.
The first measurement line’s vertex is created;

3. Place mouse cursor to next point in 3D-window and click the left mouse button.
The system creates temporary line (“rubber line”), that disappears after the meas-
urement cancellation (or after the exit from measurements mode). Parameters of
created segment are displayed in theMeasurementswindow. The length of created
segment is displayed in the vicinity of the second vertex;

Measurements are performed within only one segment.
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4. [optional] to change the second vertex location, place mouse cursor to another
point in 3D-window and click the left mouse button;

5. [optional] to change the first vertex location, press the 1 button, place mouse cursor
to another point in 3D-window and click the left mouse button;

To return to the second vertex editing mode press the 2 button on the keyboard.

6. [optional] to cancel the current measurement press Esc or delete buttons on the
keyboard or click the button in the vicinity of the second vertex;

7. To complete measurements, close theMeasurementswindow or click the button
on the main toolbar (or the button in the vicinity of the second vertex).

9.8. Projection windows

The scene is displayed in module in 3D space, that is why the view area displays not
the scene’s objects, but objects projection on certain planes.

There are two projection types:

• parallel projection (View › Direction) – separate points of 3D-objects are transferred
by parallel beam of rays on specified projection plane, perpendicular to all set of
projection beams;

A particular case of parallel projection is orthographic projection, when projection plane is
aligned parallel to one of coordinate planes of three-dimensional space.

• central projection (View › Camera) – separate points of 3D-objects are transferred
on specified projection plane by beam of rays coming from a point corresponding to
the position of the observer’s eye. Projection plane is perpendicular to the central
ray.

In order to display 3D-scene in four projections at the same time, choose View › Mul-
tiview. After that the scene is displayed in four projections, each in its own window:
front view – Front, left view – Left, top view – Top, and perspective view – Perspective.

Projection windows allow to display 3D-scene content in different projections.
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Fig. 179. Displaying 3D-scene in four projection windows (active projection window in perspective)

By default the system displays three windows of orthographic projections (front, left and
right view) and fourth window of central projection (perspective view). The active window
is shown in the green frame. To make active another window, click desired window in-
side. After that selected window becomes active, and scene objects become unselected.

To estimate different geometric parameters of 3D-objects, click projective cube to select
one of the following projections:

• Front – front view;

• Back – back view;

• Тор – top view;

• Bottom – bottom view;

• Left – left view;

• Right – right view;

• Perspective – perspective view.
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The selected projection is highlighted by yellow.

Rectangular windows separated by vertical and horizontal boundaries, which can be
moved using drag and drop. To move window boundaries place the cursor over one of
the boundaries between the windows, press and hold mouse button and move the
boundary to desired direction.

Fig. 180. Projection windows zoom in – top and perspective view

To display 3D-scene view area just in one projection window, select View › Direction ›
... or select another projection in projection cube using mouse click.
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Fig. 181. 3D-scene display – top view

10. Management of objects display

10.1. The “Objects” menu
Table 6. Brief description of the “Objects” menu

FunctionMenu items
allows to display point objects, used to fix certain
coordinates of three-dimensional space to attach

Show points

position of the scene observation point to scene’s
background image
allows to display outlines of objects external facesShow lines
allows to display 3D-objectsShow buildings
allows to display standard library objectsShow library
allows to display objects, intended to simplify three-
dimensional modelling operations

Show auxiliary objects

allows to hide selected objectsHide selected
allows to hide objects in view area using their names
in the list

Hide by name
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FunctionMenu items
allows to display only selected objects, and not se-
lected objects are not displayed in the view area

Show only selected

allows to show hidden objects in view area using
their names in the list

Show by name

allows to show all hidden objectsShow all
allows to move objects from one layer to anotherMove to layer
allows to build 3D-objects using 2D-objectsBuild

10.2. Basic object’s properties

To setup object display parameters, select the object. The Base properties section is
opened.

Fig. 182. Basic object’s properties

In the Base properties section set the checkboxes to display the following:

• Name – a name of selected object;

To change a color of selected object, choose desired color by double click the rectangle and
push OK.

• Layer – a name of a layer, where the object is located;

• Faces – object faces;

• Edges – edges located on the back side of the object;

• Points – object vertices;

• Front faces – object front faces;

• Back faces – object back faces;

• Depth test – eliminating invisible surfaces of distant objects, located behind close
objects;
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To display objects in full clear the Depth test checkbox.

• Alpha test – texture coordinates are loaded with transparent background;

• Transparent – allows to create a transparent object;

To create a transparent object, select object by double click the second square near the
Name field, select alpha channel colour and set the Transparent checkbox on.

• Lighted – object lighting using embedded light sources;

• Dynamic – the checkbox is on, if camera is located on the trajectory polygon. Other-
wise, the checkbox is set off.

10.3. Parameters of surface layer

To configure parameters of surface layer display, select orthoimage. The Properties
section is opened.

Fig. 183. Parameters of surface layer display

The DEM section is used to configure the following parameters:
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• – to select a DEM out of active profile resources;

• Degrees – for correct reading coordinate values from DEM file in degrees;

• Bad Z – to reject specified value.

The Orthoimage section is used to configure the following parameters:

• – to select an orthoimage or map of terrain out of active profile resources;

• Gray – to display a single averaged channel Grey scale as output file channel (see
more details in “GeoMosaic” User Manual).

Segments – DEM cell size in pixels;

Tile size – number of cells in a tile;

Levels – number of detail levels;

Min level – high level of image details;

Max level – low level of image details;

Freeze – allows to edit only selected area of orthoimage, with no change to other areas.

To save and apply changes click the Apply button in the Properties section.

10.4. Objects displaying

The module allows to manage scene objects display.

To display point objects, that hold certain coordinates of 3D space, select Objects ›
Show points or click the button.
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Fig. 184. Point objects displaying

To display outlines of objects external faces select Objects › Show lines or click the
button.

Fig. 185. Objects outlines displaying
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To display 3D objects, select Objects › Show buildings or click the button.

Fig. 186. 3D objects displaying

To show objects, intended to simplify three-dimensional modelling operations (for ex-
ample, dummy object or light source), choose Objects › Show helpers or click the
button.
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Fig. 187. Bounding box displaying

10.5. Objects displaying in final scene

Prior to 3D-scene playback or record it is necessary to select objects, you wish to display
in a final scene.

The module allows to hide some objects from view area. This allows to seed up scene
playback operation.

To hide single or multiple objects from view area, select the objects and chooseObjects ›
Hide selected or click the button on the main toolbar.
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Fig. 188. Objects selection

Fig. 189. Selected objects are not displayed

In order to hide a single object or objects group in the list, perform the following actions:
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1. Select Objects › Hide by name or click the button on the main toolbar. The
Hide objects window opens.

Fig. 190. Hide objects from the list window

The list of 3D-objects contains the following columns:

• Name – a name of an object;

• Type – object type, which is assigned to an object during its creation in the system
(Object, Outline, LibPoint, None) (see detailed description of object attributes in
the “Vectorization” User Manual);

• Assignment – shows object’s assignment;

• State – shows objects, used for 3D-creation (Занятый) or not used (Свободный).

2. The Filter section allows to select objects type to be shown in the list.

3. [optional] To show in the list outlines, converted to buildings, set the Buildings
checkbox on.

4. [optional] To show in the list point objects, converted to objects during creation from
DXF-file library, set the Library checkbox on.

5. To manage objects selection in the list, use the following buttons:

• Select all – allows to select all objects in the list;
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• Inverse – allows to invert objects selection order;

• Clear – allows to deselect all objects.

6. Select objects by mouse click and click the Hide button.

To select a group of objects, press and hold the Shift key, and click objects sequentially.

To view the list of objects hidden from view area or to show hidden objects from the
list, perform the following actions:

1. Select Objects › Show by name or click the button on the main toolbar. The
Show objects window opens.

Fig. 191. Show objects from the list window

The list of 3D-objects contains the following columns:

• Name – a name of an object;

• Type – object type, which is assigned to an object during its creation in the system
(Object, Outline, LibPoint, None) (see detailed description of object attributes in
the “Vectorization” User Manual);

• Assignment – shows object’s assignment;
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• State – shows objects, used for 3D-creation (Занятый) or not used (Свободный).

2. The Filter section allows to select objects type to be shown in the list.

3. [optional] To show in the list outlines, converted to buildings, set the Buildings
checkbox on.

4. [optional] To show in the list point objects, converted to objects during creation from
DXF-file library, set the Library checkbox on.

5. To manage objects selection in the list, use the following buttons:

• Select all – allows to select all objects in the list;

• Inverse – allows to invert objects selection order;

• Clear – allows to deselect all objects.

6. Select objects by mouse click and click the Show button.

To select a group of objects, press and hold the Shift key, and click objects sequentially.

To show all hidden objects select Objects › Show all or click the button on the main
toolbar.

To show in the view area just selected objects, highlight them and select Objects ›
Show only selected or click the button on the main toolbar.

Fig. 192. Show selected objects only
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10.6. 3D-scene layers

Distribution of objects in layers significantly accelerates the work with scene objects, if
there are many objects.

It is recommended to move objects with the same type to the same layer.

To open a list of 3D-scene layers, select Layers › List of layers. The Layers window
opens.

Fig. 193. The list of 3D-scene layers

The Layers window contains a table with the following columns:

• # – layer number by its creation order;

• Visible – shows weather layer is displayed in view area;

• Name – layer name, that is shown in the main module window in theBase properties
section. Default layer name is LayerN (where N – integer);

• ID – identifier assigned to a layer;

• Objects – number of objects in a layer.

To remove a layer right click it and select Delete layer.

To rename a layer right click it and select Rename layer.
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To move objects from one layer to another, select them and choose Objects › Move
to layer.... Select target layer for objects moving by mouse click and click the Select
button.

To create a new layer and to add objects there, perform the following actions:

1. Select Layers › List of layers. The Layers window opens.

Fig. 194. List of layers of 3D-scene

2. Right click any layer. The context menu opens.

Fig. 195. Context menu

3. Select Add a layer. A new layer is created.

4. In view area select objects to be added to a new layer.

5. Select Objects › Move to layer.... The Select layers window opens.
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Fig. 196. The window used to select layer to add selected objects

6. Select a new layer by mouse click and click the Select button. Selected objects are
added to a new layer.

To move selected object to another layer, in the Base properties section click the
button. The Select layers window opens. Select a new layer by mouse click and

click the Select button.

11. Module settings
The module allows to configure general module parameters and display options of 3D-
scene data.

To configure module parameters select File › Settings. The Settings window opens.

The window contains the following groups of parameters:

• main 3D-scene parameters on the Scene tab;

• parameters of 3D-scene display on the Rendering tab;

• parameters of scene elements display on the Editing tab;

• texture parameters on the Textures tab;

• mouse parameters on the Navigation tab;

• parameters of 3D-scene view areamoving (observation from camera) on theMoving
tab.
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Fig. 197. Main parameters of 3D-scene

The Scene tab allows to configure the following 3D-scene parameters:

• TheOrigin section shows XYZ coordinates of 3D-scene center, and it is also possible
to configure the following parameters:

○ Auto origin – allows to automatically calculate 3D-scene center (origin);

○ Set to center of scene – allows to set 3D-scene center to center of selected ob-
jects, visible objects or all objects of 3D-scene;

○ Reset – allows to set 0 value to 3D-scene center;

○ Restore – allows to restore previous coordinate values of 3D-scene center.

• In the Optimization section:

○ Use quad tree – allows to edit 3D-scene which contains big data volume;

○ Use frustum clamp – allows to display all objects when dealing with big volume
data.
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• In the Playing section:

Scene playback duration is calculated by the following formula: Length (snaps) / Framerate
(100/25 = 4 seconds in given example).

○ Length (snaps) – number of frames;

○ Framerate – playback frame rate.

It is impossible to input zero or negative value of the Framerate parameter. Minimal value
accepted by the system is 1.0.

Fig. 198. Parameters of 3D-scene display

TheRendering tab allows to configure the following parameters of 3D-scene displaying:

• Background – 3D-scene background color;

• Skybox – imitation of sky and horizon in the whole 3D-scene space;

• Lighting – color of objects lighting by light sources;

• Fog – imitation of fog in the whole 3D-scene space.
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The Grid section allows to specify the following coordinate grid settings:

• Line width;

• The opportunity to show labels of coordinates;

• The opportunity to select the coordinates type – local or global;

• The coordinates label spacing – 1, 5 or 10 grid steps;

• The labels arrangement: at edges of screen, on central axes or at nodes with
step (see the labels spacing parameter above);

• The fonts for labels;

• The text color.

Fig. 199. Parameters of scene elements display

TheRendering tab allows to configure the following parameters of 3D-scene displaying:

• Enable actions history – allows to cancel or redo the last operation (see Sec-
tion 6.1);
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• Local bounding box – allows to display a bounding box in object’s coordinate system;

• Global bounding box – allows to display a bounding box, described around an object
in the global coordinate system;

• Object node bounding box – allows to display a bounding box, described around
selected area;

• Object node bounding box – allows to display a bounding box, described around
selected area;

• Wareframe – allows to display objects wareframe, containing faces.

Fig. 200. Texture parameters

The Textures tab allows to configure the following texture parameters:

• Use compression – allows to load textures in compressed form;

When the Use compression checkbox is on, the system reduces the quality of loaded tex-
tures.
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• In the Filtering section select one of the following options of edge pixels smoothing
in texture image:

○ Minifying;

○ Magnification.

Fig. 201. Mouse parameters

The Textures tab allows to configure the following texture parameters:

• Mouse sensitivity – allows to configure mouse pointer speed for actions requiring
increased accuracy; the greater the mouse sensitivity value, the faster the speed of
the pointer.

• Wheel sensitivity – allows to configure scrolling speed; the greater the wheel sens-
itivity value, the faster the scrolling speed.
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Fig. 202. Parameters of 3D-scene view area moving

The Moving tab is used to configure the following parameters of 3D-scene view area
moving (observation from camera):

• In the Moving section.

○ Speed – 3D-scene moving speed;

○ Acceleration;

○ Smoothness – smoothness of moving.

• In the Rotation section:

○ Speed – 3D-scene rotation speed;

○ Acceleration;

○ Smoothness – smoothness of rotation.

• In the View section define the following settings:
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○ Near – clipping plane nearest to the camera (objects located closer than this plane
are not displayed in the projection window of this camera);

○ Far – far clipping plane (objects that are farther of the plane are not displayed in
the projection window of this camera);

○ FOV – camera field of view in degrees.

12. Animation

12.1. Scene animation

Animation – operation of forming series of images (frames) of scene view, observed
through a camera. Each frame shows scene change compared to a previous frame.

Perform the following actions to create a scene animation:

1. Open 3D-scene or create a new one;

2. Select View › Multiview. 3D-scene is opened in four projection windows;

Fig. 203. 3D-scene display in four projection windows
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3. Select Edit › Create › Polyline;

4. [optional] Set the Loop checkbox on to create path polygon (if needed);

There is a possibility to create a path polyline, that is a non-closed trajectory to move a
camera along it.

5. Create path polygon;

6. Move the polygon over 3D-objects (Advanced properties › Origin › Edit pivot);

Fig. 204. Polygon of camera move path

7. Select Edit › Create › Camera. The camera is created;

8. In theAdvanced properties section select theControl tab and click theAdd button.
Click Path Controller in context menu;
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Fig. 205. Context menu

9. Click Path Controller in controllers list;

Fig. 206. Camera controllers list

10. In Path section click the Pick button and select path polygon by mouse or click the
Select button. The Select objects window opens;

Fig. 207. Select objects from the list window

11. Select created path polygon by mouse and click the Select button. After that the
camera is positioned in the beginning of path polygon;
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Fig. 208. A camera set on the selected path polygon

12. In the Time section specify a traverse time for camera, in seconds, in the Stop
field;

Fig. 209. Camera timer

13. [Optional] Set the delay for the start of camera motion in seconds in the Start field;

Total time of camera motion includes time of the delay. Therefore, with the given values:
Start - 10 sec .; Stop - 20 seconds; is takes 10 seconds for the camera to pass a full path
after a 10 second delay.

Steady position of the camera at given timemay be convenient when performing animation
of the object’s movement in the viewing area.
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It should be noted that the duration of a scene playback (which is the ratio of Length
(snaps) to Framerate, see paragraph 22) and the time of camera movement (set in
seconds) are two different values that can be set independently.

14. [optional] To hide path polygon in the view area, click the button and in the Hide
objects window select a polygon;

To show all hidden objects select Objects › Show all or click the button on the main
toolbar.

Fig. 210. Hide objects from the list window

15. In the Controllers section click the Add button and select LookAt Controller;

16. [Click LookAt Controller in controllers list;

Fig. 211. Camera controllers list
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17. In the Target section click the Select button. The Select objects window opens;

Fig. 212. Select object from the list window

18. Select object by mouse and click the Select button. After that coordinate axis of
the camera lens is directed toward the selected object;
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Fig. 213. Camera lens directed towards the selected object

19. [optional] To adjust the direction of the lens or camera coordinate system, configure
the following LookAt Controller parameters:

• Up – allows to select or specify an object to direct top object face;

• Orientation – allows to rotate a camera in relation to selected coordinate system
axis;

• Coord system – allows to select or specify axes of object coordinate system to
assign this coordinate system to the camera.

20. Choose View › Camera › NewCamera. 3D-scene is displayed as from camera
lens;
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Fig. 214. 3D-scene display in four projection windows from the camera lens

21. [optional] To configure desired view of 3D-scene from camera, setup camera
parameters in the Advanced properties section;

22. [optional] To change scene playback duration select File › Settings and input the
Length (snaps) and Framerate values on the Scene tab;

• Length (snaps) – number of frames;

• Framerate – playback frame rate.

Scene playback duration is calculated by the following formula: Length (snaps)/ Framerate
(100/25 = 4 seconds in given example).

It is impossible to input zero or negative value of the Framerate parameter. Minimal value
accepted by the system is 1.0.
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It should be noted that the duration of a scene playback (which is the ratio of Length
(snaps) to Framerate) and the time of camera movement (set in seconds, see paragraph
13) are two different values that can be set independently.

For example, with the following parameters on the Scene tab:

• Length (snaps) – 1000;

• Framerate – 25;

(i.e., the duration of the scene playback is 40 seconds) and the following parameters in
the Time section:

• Start – 20;

• Stop – 40;

(camera movement for 20 seconds after a 20 second delay) - the end of the 40 second
scene will coincide with the camera reaching the end point of its path.

23. Choose View › Multiview or click the button to display the whole area of active
projection window.

Fig. 215. 3D-scene display from the camera lens
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24. Click the button to perform scene playback.

Fig. 216. Scene playback

There are the following buttons used to manage scene playback:

To watch the movement of the camera along the path “from aside”, select View › Camera ›
Projection. To display a 3D scene from the camera lens, select View › Camera › NewCamera.
It is possible to switch between views during the playback.

• (frame selector) – allows to pass to any of adjacent frames;

• – allows to start 3D-scene playback;

• – allows to temporarily stop 3D-scene playback;

• – allows to pause 3D-scene playback.
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12.2. Animation of object rotation

The module allows to animate object rotation in scene view area using specified path.

In order to create animation keys of object rotation and start object animation, perform
the following actions:

1. Maximize the scene scale.

2. Select an object.

Fig. 217. Selected object

3. In the Advanced properties section select the Control tab, click the Add button
and select Rot (XYZ)Ex Controller.

4. In the Properties section click the button. The Rot (XYZ)Ex Controller window
opens. The selected objects rotation mode is on.
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Fig. 218. Rotation controller

5. [optional] Move the frame selector to 0.0 position.

6. Rotate the object along a single axis or in a free plane.

Fig. 219. First object position

7. Move the frame selector to desired number of seconds.

8. Rotate the object along a single axis or in a free plane.
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Fig. 220. Third object position

9. In the Rot (XYZ)Ex Controller window click the button. Animation keys chart
area is displayed.
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Fig. 221. Animation keys chart

10. Continue creation of new animation controls used to rotate an object.

11. [optional] To adjust the torque of the object in space, perform the following actions:

1. Select animation key in the Rot (XYZ)Ex Controller window.

Select animation key on the active rotation axis of the object (in the Rot (XYZ)Ex
Controller window is highlighted by a thick line).

2. Specify time value in the Point parameters section.

12. [Optional] Edit the object’s rotation path along the axes in the Rot (XYZ)Ex Con-
troller window.

13. [optional] To repeat the object animation set the Loop checkbox on in the Properties
section.

14. [optional] To replace a straight line between animation keys by a curve select anim-
ation keys and click the button. Otherwise, animation keys are connected by
straight lines.
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Fig. 222. Creating a curve between animation keys

15. Move the frame selector to 0.0 position.

16. Close the Rot (XYZ)Ex Controller window to complete animation keys creation.

17. Click the button to playback object movement animation.
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Fig. 223. Playback of object rotation animation

Fig. 224. Playback of object rotation animation
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12.3. Animation of object movement

The module allows to animate object moving in scene view area using specified path.

In order to create animation keys of object moving and start object animation, perform
the following actions:

1. Maximize the scene scale.

2. Select an object.

Fig. 225. Selected object

3. In the Advanced properties section select the Control tab, click the Add button
and select Pos (V3Ex) Controller.

4. In the Editing section click the button. The Pos (V3Ex) Controller window
opens.

205

Three-dimensional modelingPHOTOMOD 7.5



Fig. 226. Moving controller

5. [optional] Move the frame selector to 0.0 position.

6. Move the object to the first point of scene’s space.

Fig. 227. The first point of scene space

7. Move the frame selector to desired number of seconds.

8. Move the object to the second point of scene’s space.
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Fig. 228. Object moves to the second point

9. In the Pos (V3Ex) Controller window click the button. Animation keys chart
area is displayed.

Fig. 229. Animation keys chart

10. Continue creation of new animation keys used to move an object.

11. [optional] To adjust object shift moment in space, perform the following actions:
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1. Select animation key in the Pos (V3Ex) Controller window.

Select animation key on the active rotation axis of the object (in the Pos (V3Ex)
Controller window is highlighted by a thick line).

2. In the main module window click the button.

3. Specify the Time value in the Points section.

12. [Optional] Edit the object’s rotation path along the axes in the Pos (V3Ex) Controller
window.

13. [optional] To let an object move along a curve, select animation keys and in the
main module window click the button and the button. Otherwise, the object
moves along a straight line.

Fig. 230. Creation a curve line for object moving

14. [optional] To repeat the object animation set the Cyclic checkbox on in the Proper-
ties section.

15. [optional] In the Marks section input the Mark step.
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16. [optional] To hide marks of animation keys in a view area, clear theDraw checkbox.

17. Move the frame selector to 0.0 position.

18. Close the Pos (V3Ex) Controller window to complete animation keys creation.

19. Click the button to playback object movement animation.

Fig. 231. Playback of object move animation
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Fig. 232. Playback of object move animation

12.4. Controllers

Animation controller – a means for controlling an animation object or a scene.

The module provides controllers of the following types:

• key controllers (Pos (V3Ex) Controller, Rot (XYZ) Controller) – use animation
keys;

• procedure controllers (Path Controller, LookAt Controller) – use values specified
by user.

In order to animate object rotation or moving, and for scene animation there is a possib-
ility to create controllers. To do this the Controls tab in the Advanced properties
section is used.
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Fig. 233. Controllers

No more than two controllers can be assigned to one object.

Click the Add button to add a controller. The context menu opens. Select one of the
following controllers using mouse click:

• Pos (V3Ex) Controller – allows to create object move animation in view area;

• Rot (XYZ) Controller – allows to create object rotation animation in view area;

• Path Controller – allows to move a camera along path (open or closed);

• LookAt Controller – allows to orient a camera lens in direction of one of the scene
objects.

To remove a controller from the list click the Delete button.

To load controller parameters for selected object click the Load button. The Load
controllers window opens. Choose the *.tx3 file and click the Open button.

To save the controller parameters click the Save button. The Save controllers window
opens. Choose the *.tx3 file and click the Save button.

12.5. Controller window

The Rot (XYZ)Ex Controller window is used to create rotation animation keys.

The Pos (XYZ) Controller window is used to create moving animation keys.

The horizontal scale shows the move / rotate time of the object in seconds. The vertical
scale shows the move / rotate path of the object.

211

Three-dimensional modelingPHOTOMOD 7.5



Fig. 234. The Rot (XYZ)Ex Controller window

The toolbar of theRot (XYZ)Ex Controller and Pos (XYZ) Controllerwindow contains
the following buttons:

• – allows to move a view area of animation keys in any direction;

• – allows to zoom in/zoom out view area

• – allows to zoom in/zoom out time coordinates grid;

• – allows to zoom in/zoom out space coordinates grid;

• – allows to zoom in any part of view area selected by rectangle;

• – allows to display just animation keys chart in view area;

• – allows to display chart area with maximal time scale in view area;

• – allows to display chart area with maximal time scale in view area;

• – allows to turn on selection of animation keys mode;

• – allows to move in arbitrary direction animation keys highlighted in view area;

• – allows to move horizontally animation keys highlighted in view area;

• – allows to move vertically animation keys highlighted in view area;

• – allows to turn on zoom of selected animation keys in arbitrary direction;

• – allows to turn on zoom selected animation keys horizontally;

• – allows to turn on zoom selected animation keys vertically;
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• – allows to turn on adding of animation keys mode;

• – allows to remove selected animation keys.

The drop-down list on the toolbar of the Rot (XYZ)Ex Controller and Pos (XYZ) Con-
trollerwindows allows to select the active axis of the object’s movement / rotation when
editing the object’s trajectory of movement / rotation.

13. 3D-scene recording
The module provides possibility to create a video file, generated from animated frames
of 3D-scene. AVI video format is used to save a file with animated frames.

AVI (Audio Video Interleaved) – video files format with avi extension. It is used in applications
that work onWindowsplatform.

Prior to record 3D-scene to a videofile it is necessary to create a series of frames, i.e.
to perform scene animation.

Perform the following actions to create a scene video file:

1. Click the button on the main toolbar. The Save record window opens. Choose
a folder to place a file inWindows system. Specify a file name in the File name input
field. Click the Save button. The Codecs window opens.

Fig. 235. Parameters of videofile creation

2. [optional] Set video recording settings.

It is recommended to select Microsoft Video 1 program from the Программа сжатия list.

3. Click OK. A video recording process is started.

4. Click the button on the scene replay toolbar (or on the upper part of the main
toolbar) to start 3D-scene playback;
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5. Click the button on the scene replay toolbar (or on the upper part of the main
toolbar) to stop scene playback;

6. Click the button on the lower part of the main toolbar to stop video recording.
Video file in AVI format is created.

To view created video, the file should be opened with the VLC media player program.

Appendix A. Coordinate systems
The coordinate system in the module is a set of three axes (X, Y, and Z), which define
object orientation in scene space.

The module provides the following coordinate systems:

• Local (default system) – with origin in the “reference” point of selected object. Z-axis
is used to show an object height, X-axis – is used to show an object width, and Y-
axis – is used to show an object length.

Fig. A.1. Local coordinate system

• Parent (used for objects with hierarchical relationships) – with origin in the “reference”
point of selected object. Z-axis is used to show a parent object height, X-axis – is
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used to show a parent object width, and Y-axis – is used to show a parent object
length.

Fig. A.2. Parent coordinate system

• Global – with origin in zero point of 3D-scene space. Z-axis is used to show a scene
height, X-axis – is used to show a scene width, and Y-axis – is used to show a scene
length. Direction of the coordinate system axes is displayed in the lower left corner
of the module’s window.
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Fig. A.3. Global coordinate system

• View – with origin in zero point of 3D-scene space.

Fig. A.4. View coordinate system

• Grid – axes of selected object coordinate system are directed the same as axes of
coordinate grid coordinate system.
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Fig. A.5. Grid coordinate system

It is possible to choose one of the following ways to display a coordinate system of se-
lected objects:

• Individual – allows to display coordinate system axes for each selected object;

• Common – allows to display common axis of selected objects coordinate system.

Fig. A.6. Individual axes of objects coordinate system
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Fig. A.7. Common axis of objects coordinate system
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